Определение схемы соединений
Отдельные проводные соединения внутри жгута задаются на схеме проводки жгута (*.WirDoc). Добавьте этот документ в проект жгута с панели Projects, щелкнув правой кнопкой мыши по записи проекта и затем выбрав Add New to Project » Harness Wiring Diagram в контекстном меню (или используйте команду File » New » Harness Wiring Diagram в главном меню).
Настройка документа схемы проводки жгута
Параметры документа схемы проводки жгута можно настроить на панели Properties, когда в рабочей области документа не выбран ни один объект. Основные настройки:
-
В области General на вкладке General панели – выберите единицы измерения, применяемые к документу и его графическим элементам, и настройте сетки для упрощения размещения. Altium Designer предлагает три типа сетки: видимую сетку для навигации, сетку привязки для размещения и расстояние привязки для упрощения создания соединений.
-
В области Page Options на вкладке General панели – настройте размер листа документа и основную надпись либо выберите один из доступных шаблонов схемы проводки жгута.

Вкладки General и Parameters панели Properties, когда в документе схемы проводки жгута не выбран ни один объект
Синхронизация многоплатных и harness-проектов
Если проект жгута является частью проекта многоплатной разработки, схему проводки жгута можно синхронизировать по данным документа многоплатной схемы (*.MbsDoc). Для этого выберите команду Design » Import Changes From <Multi-board Project> в главном меню.
Чтобы узнать больше о добавлении проекта разработки жгута в многоплатный проект, см. страницу Harness Design.
Если документ многоплатной схемы содержит более одного определения соединения жгута, откроется диалог Select Harness Definition. Укажите определение, относящееся к текущему проекту жгута.

Диалог Select Harness Definition
Затем откроется диалог Engineering Change Order, в котором будут показаны компоненты разъемов жгута и цепи жгута, определенные в многоплатной схеме и служащие основой для схемы проводки жгута.

Используйте диалог Engineering Change Order для импорта данных из многоплатного проекта.
После выполнения изменений данные из документа многоплатной схемы импортируются в схему проводки жгута. Компоненты разъемов, каждый из которых представлен своим схематическим символом, появятся в документе схемы проводки жгута, изначально в произвольных позициях.

Пример схемы проводки жгута сразу после импорта.
Между выводами будут показаны линии цепей для представления логических соединений, определенных в многоплатной схеме. Обратите внимание, что на этом этапе в проекте еще нет физических проводов.
Работа с компонентами
Помимо синхронизации из документа многоплатной схемы, компоненты также можно размещать в схеме проводки жгута вручную. Это позволяет размещать компоненты в автономном проекте жгута (то есть не являющемся частью многоплатного проекта), а также добавлять дополнительные компоненты в схему проводки жгута, входящую в состав многоплатного проекта.
Используйте панель Components для размещения символов требуемых компонентов. Процесс размещения компонентов аналогичен процессу в редакторе схем — подробнее см. страницу Поиск и размещение компонентов. Обратите внимание, что для компонентов, добавленных вручную, не будет линий цепей, поскольку отсутствует логический проект верхнего уровня, который мог бы ими управлять.
Чтобы переместить размещенный компонент (или компонент, размещаемый с панели Components) в нужное положение, нажмите и удерживайте левую кнопку мыши на нем и перемещайте мышь. Во время перетаскивания используйте Spacebar для поворота компонентов на 90 градусов, а клавиши X и Y — для их отражения по горизонтали и вертикали соответственно.

Схема проводки жгута после перемещения компонентов
Свойства размещенного компонента можно настроить на панели Properties, когда компонент выбран в рабочей области. Панель Properties для компонента включает следующие вкладки:
-
General – общие свойства компонента, такие как позиционное обозначение и комментарий, местоположение, параметры и т. д.
-
Pins – список выводов компонента.
-
Cavities – позволяет назначать компоненту гнездовые полости (подробнее).
-
Associated Parts – позволяет назначать компоненту дополнительные части, такие как термоусадка.
Назначение гнездовых полостей
Гнездовые полости и их тип можно назначать компоненту жгута. Чтобы добавить полость и тип, выберите компонент в рабочей области. Выберите вывод на вкладке Cavities панели Properties , затем нажмите кнопку
. Выберите нужный тип из раскрывающегося списка. Поддерживаются следующие типы полостей:
-
Crimp – используется для обеспечения электрического соединения путем обжатия контактной гильзы вокруг проводника.
-
Seal – используется для защиты от внешней среды путем герметизации точки входа провода.
-
Plug – используется для заполнения открытой (неиспользуемой) полости разъема для сохранения целостности герметизации.
-
Other – используется для указания других/дополнительных деталей или материалов, например припоя.
В открывшемся диалоге Select Connector найдите и выберите нужный компонент. Конкретный тип и соответствующая информация будут добавлены к выводу на вкладке, как показано на изображениях ниже, для добавления обжима к выводу 1.
Для обжима, уплотнения или заглушки к выводу можно добавить только одну полость определенного типа. После добавления полости определенного типа соответствующая запись становится недоступной (выделена серым) в раскрывающемся списке. К выводу можно добавить любое количество полостей типа Other.
Выводы с назначенными обжимами обозначаются в рабочей области символом
, как показано на изображении ниже.
Область сетки на вкладке Cavities поддерживает множественный выбор и операции копирования/вставки/удаления для выбранных записей.
-
Несколько записей выводов можно выбирать с помощью сочетаний клавиш
Click, Hold&Drag,Ctrl+Click,Shift+ClickиCtrl+A. -
Когда выбрано несколько записей выводов, нажмите
, чтобы добавить полость ко всем выбранным выводам, или нажмите
либо клавишу Delete, чтобы удалить добавленные полости у выбранных выводов. -
Чтобы изменить полость вывода, выберите его запись, затем нажмите
, чтобы открыть диалог Select Connector для выбора новой полости.
-
Выберите одну или несколько записей выводов и используйте сочетания клавиш
Ctrl+X/Ctrl+C, чтобы вырезать/скопировать выбранные записи, затем используйте сочетание клавишCtrl+V, чтобы вставить вырезанное/скопированное содержимое в текущую выбранную запись.
Создание соединений на схеме соединений жгута
Физические провода размещаются в документе схемы соединений жгута с помощью команды Place » Harness Wire главного меню (сочетание клавиш: Shift+W).
После выбора команды щелкните по контакту разъема (когда курсор находится над точкой привязки контакта, у курсора появляется красный крест), чтобы разместить начальную точку провода жгута. Перемещайте курсор и щелкайте, чтобы зафиксировать последовательность вершинных точек, определяющих форму провода жгута. После размещения последней вершины в точке привязки другого контакта щелкните правой кнопкой мыши, чтобы завершить размещение.
При размещении провода жгута нажимайте Shift+Spacebar, чтобы переключаться между режимами размещения. Режим определяет, как создаются углы при размещении проводов и под какими углами можно размещать провода. В режиме 90 Degree или 45 Degree (истинно ортогональные режимы) нажимайте Spacebar, чтобы переключаться между подрежимами начала и конца. Текущий режим и подрежим отображаются в строке состояния.
При размещении провода жгута линии цепей отслеживаются/обновляются «вживую», показывая вам в реальном времени, где нужно выполнить соединение, как показано в видео ниже. После завершения соединения соответствующая линия цепи исчезает из документа.
Демонстрация функции live trace
После размещения и выбора вершины провода жгута можно перетаскивать, чтобы изменять угол между двумя соседними сегментами
Выберите провод жгута в рабочей области, чтобы изменить его на панели Properties. На панели можно переименовать выбранный провод жгута, изменить его ширину и цвет, а также добавить параметры, которые можно показывать или скрывать в рабочей области.

Панель Properties, когда выбран провод жгута
Добавление сращиваний и ответвлений
В ситуациях проектирования, когда новый провод необходимо подключить к уже размещенному проводу, сначала нужно разместить объект сращивания (Place » Splice) или ответвления (Place » Tap).
-
Splice – исходный провод разделяется сращиванием на два отдельных провода.
Другой провод нужно подключить к выбранному проводу (W4).
На проводе размещено сращивание. Обратите внимание, что сращивание разделяет исходный провод на два в месте сращивания.
К сращиванию подключен другой провод.
-
Tap – исходный провод остается неразрывным.
Другой провод нужно подключить к выбранному проводу (W4).
На проводе размещено ответвление. Обратите внимание, что ответвление не разделяет исходный провод.
К ответвлению подключен другой провод.
Свойства размещенного сращивания или ответвления (его расположение и визуальное представление) можно настроить на панели Properties, когда объект выбран в рабочей области.

Панель Properties, когда выбрано сращивание/ответвление
Область Associated Parts панели Properties позволяет назначать компоненты выбранному сращиванию/ответвлению, и этот компонент будет отражен в BOM проекта.
Добавление кабелей
Чтобы определить один или несколько проводов как добавленные в кабель, можно разместить объект кабеля на схеме соединений жгута (Place » Harness Cable).

Разместите кабель, чтобы определить один или несколько проводов как добавленные в кабель.
Когда объект кабеля выбран, провода, охватываемые этим кабелем, подсвечиваются в рабочей области неоново-зеленым цветом
Свойства размещенного объекта кабеля (его расположение, визуальное представление и параметры) можно настроить на панели Properties, когда объект выбран в рабочей области.

Панель Properties, когда выбран кабель
Во время размещения или графического редактирования кабель имеет фиксированное соотношение сторон 2:1, при этом окончательный размер размещения определяется текущим значением сетки привязки документа.
Экранирование и скручивание проводов
Экран (с подключением или без него, например с подключением дренажного провода) можно присоединить к группе проводов, разместив либо объект экрана (Place » Shield) , либо объект экрана с подключением (Place » Shield with Connection).
В приведенном ниже примере провода W1, W2 и W3 экранированы экраном без подключения (SH1), а провода W4, W8 и W9 экранированы экраном с подключением (SH2). Провод W10 размещен для подключения SH2 к контакту компонента.

Разместите объект экрана или экрана с подключением, чтобы обозначить провода как экранированные.
Когда выбран объект экрана или экрана с подключением, охватываемые им провода подсвечиваются в рабочей области неоново-зеленым цветом
Свойства размещенного объекта экрана или экрана с подключением (расположение и визуальное представление) можно настроить на панели Properties, когда объект выбран в рабочей области. Область Shield Objects панели перечисляет провода, охватываемые выбранным объектом.

Панель Properties, когда выбран экран
Провода можно обозначить как скрученные вместе, разместив скрутку (Place » Twist). Скрутку можно разместить поверх двух или более проводов.
В примере ниже провода W1 и W2 обозначены как скрученные вместе скруткой Tw1.

Разместите объект скрутки, чтобы обозначить провода как скрученные вместе.
Когда скрутка выбрана, охватываемые ею провода подсвечиваются в рабочей области неоново-зеленым цветом
Свойства размещенной скрутки (ее расположение и визуальное представление) можно настроить на панели Properties, когда объект выбран в рабочей области. Область Twist Objects панели перечисляет провода, охватываемые выбранной скруткой.

Панель Properties, когда выбрана скрутка
Неподключенные провода
Неподключенные концы проводов обозначаются сплошным квадратом.

Обозначенный неподключенный провод
Конец провода не следует оставлять неподключенным. Если по условиям проекта требуется неподключенный конец провода, на его конце следует разместить объект 'no connect' (Place » No Connect).

Разместите объект 'no connect' на конце провода, который должен оставаться неподключенным.
Свойства размещенного объекта 'no connect' (его расположение и визуальное представление) можно настроить на панели Properties, когда объект выбран в рабочей области.

Панель Properties, когда выбран объект 'no connect'
Работа с несколькими листами
Полная схема жгутовой разводки может быть определена на нескольких листах (в «плоском» стиле проектирования, где все листы находятся на одном уровне), каждый из которых представлен собственным документом *.WirDoc . Связность создается напрямую между любыми листами с помощью объектов разрыва провода (Place » Wire Break) с одинаковым обозначением провода.
После выбора команды размещения разрыва провода расположите объект так, чтобы его электрическая активная точка (конец, удерживаемый курсором) касалась провода, к которому нужно подключиться, затем щелкните мышью или нажмите Enter для выполнения размещения. Размещенный разрыв провода наследует свойства (обозначение и цвет) провода, к которому он подключен.
Выберите разрыв провода в рабочей области проекта, чтобы изменить его на панели Properties. На панели можно задать обозначение провода, к которому он подключен, а также его стиль: направление (Left или Right) и цвет.
Синхронизация проводов
Провода жгута, соединенные через разрыв провода, распознаются как связанные, даже если у них разные Design Item ID. Кроме того, все сегменты проводов с одинаковым обозначением, соединенные одним и тем же разрывом провода, сравниваются (по номеру детали, комментарию, цвету и всем параметрам). Если обнаружены какие-либо различия, сообщается о нарушении Mismatched parameters in connected wire segments. Предупреждение также появляется на панели Properties для провода и разрыва провода, указывая на обнаруженный конфликт между параметрами. Нажмите Synchronize в предупреждении, чтобы открыть диалог Conflict Wire Parameters, где можно выбрать, какие параметры использовать для сегмента провода.
Размещение компонента схемы жгутовой разводки
При подключении к вашему Workspace вы можете создавать компоненты с заранее определенной структурой и свойствами, как требуется в подключенном Workspace, а затем повторно использовать эти компоненты в проектах жгутов, размещая их непосредственно в документах схем жгутовой разводки.
Дополнительные сведения см. на странице Creating a Harness Wiring Component.
Эти компоненты (каждому из которых назначена определенная модель жгутовой разводки) доступны на панели Components panel. Когда нужный документ схемы жгутовой разводки активен в рабочей области проекта, разместите компонент, щелкнув правой кнопкой мыши по его записи на панели и выбрав команду Place <ComponentName> в контекстном меню. Поведение при размещении компонента различается в зависимости от того, включает ли компонент одиночный объект провода или кабельную структуру (несколько проводов и/или дополнительные объекты: кабели, экраны и т. д.).
-
Single wire – при размещении компонента, включающего одиночный объект провода, будет активирован режим размещения провода жгута. Размещаемый провод унаследует свойства, заданные при создании компонента. Подробнее о размещении проводов жгута см. в разделе Creating Connectivity in the Harness Wiring Diagram выше.
-
Cable structure – при выборе команды размещения для компонента, включающего кабельную структуру, эта кабельная структура появится прикрепленной к курсору именно в том виде, в каком она была определена при создании компонента. Щелкните в нужном месте документа схемы жгутовой разводки, чтобы разместить компонент. После этого можно отдельно редактировать объекты компонента, например, чтобы присоединить провода, составляющие кабель, к выводам жгутовых разъемов.
Обновление схемы разводки из библиотек
Следующие объекты могут быть обновлены из их исходной библиотеки Workspace:
-
Компоненты жгута
-
Полости компонентов жгута
-
Детали, связанные с компонентами жгута
-
Провода
Когда объект выбран, информация о связанном компоненте Workspace доступна на панели Properties (например, на вкладке Associated Parts для деталей, связанных с компонентом жгута).
Если доступна более поздняя ревизия компонента Workspace, запись о статусе ревизии будет отражать это текстом Out of date. На уровне отдельного объекта связь можно обновить до последней ревизии компонента Workspace, нажав кнопку
.
Пример указания устаревшей ревизии компонента жгута
Функцию Update from Libraries (Tools » Update from Libraries) также можно использовать для обновления устаревших компонентов, связанных с перечисленными выше объектами. Обратите внимание, что для включения объекта в обновление с помощью функции Update from Libraries компонент, назначенный объекту, должен содержать ссылку на условное графическое обозначение.
Аннотирование объектов схемы жгутовой разводки
Используйте команды в меню Tools » Annotation для аннотирования следующих объектов в документе схемы жгутовой разводки:
-
Компоненты жгута
-
Провода
-
Сращивания и ответвления
-
Кабели
-
Экраны и экраны с подключением
-
Скрутки
-
Объекты «No connect»
Аннотирование объектов в документе схемы жгутовой разводки аналогично аннотированию компонентов в документе схемы (*.SchDoc) проекта разработки PCB. Используйте следующие ссылки, чтобы узнать больше о командах аннотирования, доступных для документа схемы жгутовой разводки:
).

).







).

).
).
).
).
).
).





).