Выпуск в Workspace
Краткий обзор
- Определите, какие наборы исходных данных, данных для изготовления и сборки, данных вариантов исполнения и пользовательских данных следует включить в выпуск, а также как назначить необходимые задания Output Job.
- Ознакомьтесь с параметрами назначения выпуска, схемами именования элементов рабочего пространства и средствами управления целевыми ревизиями.
- Пройдите этапы выпуска и узнайте, как команды автоматизированного выпуска влияют на просмотр, формирование отчетов и публикацию в PLM.
В представлении Release в Online Mode процесс выпуска разделен на этапы. Элементы в левой части представления позволяют сразу определить, на каком этапе вы находитесь:
-
Configure Server Release — на этом этапе процесса выпуска указываются типы данных, которые необходимо сформировать: исходные данные (формируются всегда), данные для изготовления и данные для сборки (для базового проекта и каждого обнаруженного варианта).
-
Validate Project — этот этап процесса выпуска выполняется автоматически, если в назначенных файлах OutJob обнаружен хотя бы один отчет типа Validation. Выполняются все генераторы выходных данных для проверки, заданные в файле Output Job, назначенном выпускаемому элементу данных.
-
Generate Data — этот этап процесса выпуска выполняется автоматически. На нем выполняются все остальные процедуры формирования выходных данных, заданные в файлах OutJob, назначенных включенным элементам данных. В результате формируются данные для выпуска в соответствующие целевые элементы рабочего пространства.
-
Review Data — после успешного прохождения всех проверок и формирования выходных данных на этом этапе процесса выпуска можно просмотреть сформированные данные.
-
Upload Data — переход к этому этапу выполняется автоматически после подтверждения выпуска на предыдущем этапе. Здесь отображается ход загрузки данных в ревизии соответствующих элементов данных в целевом рабочем пространстве.
-
Execution Report — это заключительный этап процесса, на котором отображаются итоговые сведения о выпуске. Навигационные ссылки позволяют быстро перейти к созданным ревизиям элементов на панели Explorer. Если вы открыли Project Releaser в рамках процесса выпуска и публикации в PLM, будет отображаться кнопка
. Нажмите ее, чтобы продолжить рабочий процесс и выполнить публикацию в PLM.
-
Publish to PLM — этот этап доступен только при выполнении выпуска в рамках соответствующего активированного процесса (для выпуска и последующей публикации в PLM). Переход к этому этапу выполняется автоматически при нажатии кнопки
на предыдущем этапе (либо напрямую, если была использована команда Prepare & Release & Publish to PLM в меню кнопки Откроется диалоговое окно Login Credentials. Введите Username и Password для своего экземпляра PLM и выберите нужный шаблон PLM (он отображается в виде <PLMInstance>:<PublishingTemplate>).
Этап 1 в онлайн-режиме — настройка выпуска на сервер
На этом этапе процесса выпуска указываются типы данных, которые необходимо сформировать. Для выпуска доступны следующие элементы данных:
- Source Data — снимок исходного проекта.
- Fabrication Data — данные, необходимые производителю печатных плат для изготовления несмонтированной платы.
- Assembly Data for the Base Design (no variations) — данные, необходимые сборочному предприятию для полного монтажа компонентов на плату в соответствии со спецификацией для базового проекта без вариантов исполнения.
-
Assembly Data for Design
Variant n— данные, необходимые сборочному предприятию для монтажа компонентов на плату в соответствии со спецификацией дляVariant nбазового проекта.
Количество наборов данных для сборки соответствует базовому проекту (без вариантов исполнения) и всем обнаруженным вариантам, определенным для этого проекта.

Этап 1 процесса выпуска проекта — настройка состава выпуска (выбор данных для формирования).
Элемент Source Data всегда включается в выпуск. Остальные элементы данных включаются по необходимости.
Назначение файлов Output Job
Чтобы включить элементы Fabrication Data и Assembly Data в выпуск, каждому из них необходимо назначить хотя бы один файл Output Job. Если имеются файлы Output Job, имена которых начинаются с подстрок «fab» и «ass», при первом открытии представления Release эти файлы OutJob будут автоматически назначены разделам Fabrication Data и Assembly Data соответственно. В противном случае соответствующие файлы OutJob потребуется назначить вручную. Это можно сделать на вкладке Release Options диалогового окна Project Release Options (для его открытия нажмите кнопку
в левом нижнем углу представления).

Назначьте файлы OutJob соответствующим наборам данных.
Изменение места назначения выпуска
Вкладку Release Options диалогового окна Project Release Options также можно использовать для изменения места назначения выпуска — переключения между управляемым (Online) и неуправляемым (Offline) режимами работы. Доступны три варианта:
-
Unmanaged - Folder(Offline): выберите этот вариант, чтобы выпустить сформированные данные в локальную папку. Путь к корневой папке задается на вкладке Output Path диалогового окна. По умолчанию используется[OutputPath](на основе пути, указанного в поле Output Path на вкладке Options диалогового окна Project Options). -
Unmanaged - Zip(Offline): выберите этот вариант, чтобы выпустить сформированные данные в локальную папку. Данные будут упакованы в один ZIP-файл. Путь и имя ZIP-файла задаются на вкладке Output Path диалогового окна. По умолчанию используется[OutputPath][ProjectName].zip(на основе пути, указанного в поле Output Path на вкладке Options диалогового окна Project Options). -
Managed - <WorkspaceName>(Online): выберите этот вариант, чтобы выполнить выпуск в рабочее пространство (сWorkspaceName), к которому вы подключены в данный момент.

Измените целевое расположение выпуска — место, куда будут отправлены сформированные данные, — в параметрах выпуска проекта.
Настройка схем именования элементов рабочего пространства
При первом выпуске проекта в целевое рабочее пространство можно задать имена целевых элементов данных в этом рабочем пространстве, в ревизии которых будут помещены сформированные данные. Это выполняется на вкладке Item Naming диалогового окна Project Release Options, которое открывается нажатием кнопки
в левом нижнем углу представления (или щелчком по ссылке Target Revision для выпускаемого набора данных и выбором команды Edit в контекстном меню). На этой вкладке можно:
- Задать имя проекта. По умолчанию здесь указано фактическое имя проекта.
-
Задать схемы именования по умолчанию для различных элементов данных, которые могут быть сформированы при выпуске. Щелкните в поле столбца Item ID, затем нажмите кнопку
справа от поля, чтобы открыть диалоговое окно Choose Item (вариант панели Explorer), в котором можно выбрать существующий элемент в подключенном рабочем пространстве.
Чтобы изменить любую из схем именования, нажмите кнопку Settings для открытия диалогового окна Naming Template Settings.

Задайте имя проекта и определите имена формируемых элементов данных в целевом рабочем пространстве. Здесь поля доступны для редактирования, поскольку проект еще не был выпущен.
В шаблоне именования поддерживаются следующие форматы макросов:
-
Parameter-based — позволяет использовать параметры в квадратных скобках (например,
[ProjectName],[VariantName],[ProjectParameter]). -
Numeric-based — позволяет использовать числовые квантификаторы в фигурных скобках (например,
{0000},{9000}).
Управление целевой ревизией
Вернувшись в основное представление, щелкните по ссылке рядом с записью Target Revision, чтобы открыть меню команд, показанное на следующем изображении:

Доступ к средствам выбора целевой ревизии для набора данных, который будет сформирован при выпуске, — наведите указатель на изображение, чтобы увидеть их.
Доступные команды зависят от того, был ли уже выполнен первый выпуск элемента. Ниже приведен список всех возможных команд:
-
Auto <RevisionID> — этот пункт позволяет системе управлять ревизиями, избавляя вас от необходимости создавать запланированные ревизии там, где их еще нет.
RevisionIDпоказывает следующую ревизию элемента на том же уровне назначенной схемы именования ревизий (например, если текущая ревизия —A.1, эта команда покажет целевую ревизиюA.2). -
Next <RevisionID> — этот пункт доступен только после первого выпуска элемента. Используйте его, чтобы быстро повысить целевую ревизию на следующем уровне назначенной схемы именования ревизий.
RevisionIDпоказывает следующую ревизию (например, если текущая ревизия —A.1, эта команда изменит целевую ревизию наB.1). -
Custom — используйте этот пункт, чтобы выбрать конкретную ревизию целевого элемента, задав пользовательский идентификатор ревизии в диалоговом окне Custom Revision ID. В зависимости от используемой схемы именования ревизий диалоговое окно может содержать до трех полей идентификаторов уровней. Обратите внимание: идентификатор первой запланированной ревизии элемента можно изменить в любой момент после создания элемента и до выпуска данных в эту первую ревизию (то есть пока она находится в состоянии
Planned). - Browse — используйте этот пункт, чтобы выбрать существующую ревизию целевого элемента для выпуска данных. Для этого откроется диалоговое окно Choose Target Item (вариант панели Explorer).
- Edit — используйте этот пункт, чтобы перейти на вкладку Item Naming диалогового окна Project Release Options, где можно изменить имя создаваемого целевого элемента (и его начальной ревизии).
- Navigate — используйте этот пункт для быстрого перехода к элементу на панели Explorer (если он уже был выпущен и следующая ревизия существует в запланированном состоянии).
Пункт в верхней части меню отображает текущую выбранную или заданную целевую ревизию.
Просмотр сведений о формировании данных
Нажмите элемент управления Details в правой части заголовка набора данных, чтобы просмотреть подробные сведения о том, что именно будет сформировано этим набором данных. Чтобы свернуть развернутое представление, нажмите элемент управления Hide Details. За исключением набора Source Data, данные формируются на основе одного или нескольких назначенных файлов Output Job. Для быстрого доступа к исходному файлу OutJob нажмите элемент управления Configure.

Откройте подробное представление набора данных, чтобы увидеть, какие данные будут сформированы, — наведите указатель на изображение.
Дополнительные настройки
Дополнительные настройки выпуска проекта можно задать на странице Data Management – Servers диалогового окна Preferences:
-
Для временного хранения сформированных файлов перед отправкой в подключенное рабочее пространство можно использовать автоматически выбранную папку (
\Users\<ProfileName>\AppData\Local\Temp\Releasesпри установке по умолчанию) или вручную указать другую папку. - Включите параметр Delete contents after exiting release mode, чтобы папка временного хранения очищалась после завершения процесса выпуска.
- К имени каждого сформированного выходного файла можно добавить префикс с идентификатором элемента и идентификатором ревизии (например,
[FAB-Kame_FMU-A.1] Validation.PDF). Для этого включите параметр Prepend revision HRID to file names.
Настроив необходимые элементы данных, которые будут созданы при выпуске, нажмите кнопку
в правом нижнем углу представления, чтобы продолжить.
В ходе подготовки выполняется несколько предварительных проверок, в том числе:
- Проверка того, что проект и все файлы сохранены.
- Проверка того, что проект и все соответствующие файлы зафиксированы в системе управления версиями (VCS), если она используется.
- Проверка того, что каждому включенному элементу данных присвоено имя.
- Проверка наличия у пользователя прав на создание целевого элемента и его ревизии.
- Создание необходимых целевых элементов и запланированных ревизий в рабочем пространстве, если они еще не существуют, и использование следующей ревизии для уже существующих элементов.
При обнаружении проблем будут предложены способы их устранения, например сохранение локально измененных файлов и фиксация изменений в VCS.
На этом этапе создается элемент Source Data: снимок исходных файлов проекта выпускается в целевую ревизию элемента.
Онлайн-этап 2 — Проверка проекта
После успешного завершения этапа 1 этот этап процесса выпуска запускается автоматически, если в назначенных файлах OutJob обнаружен хотя бы один отчет типа Validation. Запускаются все генераторы проверочных выходных данных, заданные в файле Output Job, назначенном выпускаемому элементу данных. В их число входят:
- Differences Report — использование средства сравнения для проверки согласованности исходных документов проекта и документа печатной платы.
- Electrical Rules Check — проверка исходной схемы на соответствие электрическим правилам и правилам оформления.
- Design Rules Check — проверка документа печатной платы на соответствие заданным ограничениям проектирования платы.
-
BOM Checks — проверка возможных нарушений, связанных с элементами проекта или вариантами выбора компонентов в исходном документе спецификации (
*.BomDoc), если он имеется. - Footprint Comparison Report — сравнение посадочных мест на плате с исходной библиотекой, чтобы убедиться в их актуальности и соответствии.
- Component State Checking — проверка наличия компонентов, находящихся в состояниях с ограничениями. При настройке для каждого существующего состояния в каждом определении жизненного цикла целевого рабочего пространства задается действие: ничего не делать, выдать предупреждение или сформировать ошибку. В последнем случае выпуск проекта будет заблокирован. Кроме того, при проверке создается удобный HTML-отчет, позволяющий сразу увидеть, какие компоненты проекта находятся в недопустимых состояниях.
- Environment Configuration Compliance Check — проверка того, что используются только элементы данных, разрешенные конфигурацией среды, доступной назначенной вам роли (если применимо). Эта проверка также позволяет убедиться, что все элементы проекта получены из рабочего пространства.
При успешной проверке отображается значок
с текстом Passed. В противном случае отображается значок
с текстом Failed.
Онлайн-этап 3 — Формирование данных
После успешного завершения этапа 2 этот этап процесса выпуска запускается автоматически. На нем формируются все остальные выходные данные, заданные в файлах OutJob, назначенных включенным элементам данных, для последующего выпуска в соответствующие целевые элементы рабочего пространства.
Как и на других этапах, ход формирования отображается с помощью значков. На этом этапе они особенно полезны, поскольку он занимает больше времени:
— выполнение или формирование еще не началось.
— выполняется или формируется.
— успешно сформировано.
— ошибка формирования.
Онлайн-этап 4 — Просмотр данных
После успешного прохождения всех проверок и формирования выходных данных этот этап процесса выпуска позволяет просмотреть сформированные данные.

Просмотрите сформированные данные и убедитесь, что все в порядке, прежде чем подтвердить выпуск и загрузить данные в рабочее пространство.
По умолчанию на странице отображается простой (компактный) вид сформированных данных. Чтобы перейти к подробному виду, нажмите элемент управления Details в нужном разделе.

Нажмите элемент управления Details, чтобы переключить отображение сформированных данных соответствующего раздела с простого на подробное. Для возврата нажмите элемент управления Hide Details.
Состояния формирования выходных данных в подробном представлении
В следующей таблице перечислены возможные состояния выходных данных при их формировании и просмотре в подробном представлении:
Состояние |
Описание |
|---|---|
|
Выходные данные еще не сформированы или отсутствуют. |
|
Выходные данные сформированы, однако после этого в проект были внесены изменения, поэтому эти данные больше не актуальны. |
|
В данный момент выполняется формирование выходных данных. |
|
Выходные данные относятся к проверке; сформирован отчет без ошибок. Для отчета ERC ошибки либо отсутствуют, либо их уровень не превышает заданный для этого отчета максимально допустимый уровень. |
|
Выходные данные (за исключением данных проверок) успешно сформированы. |
|
Не удалось успешно сформировать выходные данные. Для данных проверок это означает, что в исходных документах проекта имеются ошибки, из-за которых не пройдены определенные проверки. Для стандартных выходных данных это означает, что их не удалось сформировать. Возможно, при предварительной проверке перед формированием обнаружены фатальные ошибки или неверно настроен соответствующий генератор выходных данных в файле Output Job. |
В компактном представлении сформированных данных нажмите ссылку View, чтобы открыть соответствующий файл данных или набор файлов в подходящем редакторе Altium Designer (например, в CAM-редакторе для файлов Gerber или сжатых/несжатых файлов ODB++) либо во внешнем приложении (например, в Microsoft Excel для спецификации). В подробном представлении дважды щелкните запись, чтобы просмотреть только этот файл.
Многие разработчики проверяют готовность к выпуску, сравнивая файлы Gerber, сформированные для текущего выпуска, с файлами Gerber предыдущего выпуска. Нажмите ссылку Compare Gerber рядом с выходными данными Gerber и выберите предыдущий выпуск в раскрывающемся меню, чтобы сравнить подготовленные данные Gerber с данными выбранного выпуска. В браузере по умолчанию откроется рабочее пространство вашей компании и отобразятся результаты.

Доступ к функции сравнения Gerber из Project Releaser перед выпуском данных в рабочее пространство.
► Подробнее о функции Gerber Comparison (рабочее пространство Altium 365, рабочее пространство Enterprise Server).
Если после проверки данных потребуется внести изменения, нажмите кнопку
в правом нижнем углу представления. Появится диалоговое окно подтверждения с предупреждением о том, что все сформированные данные будут потеряны. Нажатие OK отменит выпуск и вернет вас к этапу 1.
Если все сформированные данные в порядке, продолжите выпуск, нажав кнопку
(также в правом нижнем углу представления). Откроется диалоговое окно Confirm Release со сводкой конфигураций проекта, которые будут выпущены в рабочее пространство. Здесь также можно добавить Name (по умолчанию здесь указано [ProjectName]), Description и необходимые примечания к выпуску.

Подтверждение состава выпуска с указанием создаваемых ревизий элементов и возможность изменить имя/описание и добавить примечания к выпуску.
Онлайн-этап 5 — загрузка данных
После подтверждения выпуска на предыдущем этапе переход к этому этапу выполняется автоматически. Здесь отображается ход загрузки данных в ревизии соответствующих элементов данных в рабочем пространстве.

Этот этап лишь отображает ход загрузки сформированных данных в связанные ревизии элементов в рабочем пространстве.
Онлайн-этап 6 — отчет о выполнении
Это заключительный этап процесса, на котором представлена сводка по выпуску.
Используйте навигационные ссылки для быстрого перехода к соответствующей ревизии элемента, содержащей выпущенные данные (данные для изготовления, данные для сборки и любые пользовательские наборы данных), на панели Explorer — в вашем интерфейсе доступа к рабочему пространству.

Просмотр выпущенных данных проекта непосредственно в рабочем пространстве с помощью панели Explorer.
Просмотр выпущенного проекта
Для проекта в рабочем пространстве после завершения выпуска доступна дополнительная функция. Нажмите ссылку Project Page — последнюю из навигационных ссылок в верхней части страницы Execution Report, — чтобы открыть панель Explorer, на которой проект отображается в Project View. Эта возможность доступна только для проектов в рабочем пространстве.

Более подробно изучить проект рабочего пространства на панели Explorer можно с помощью Project View.
В области Releases (в левой нижней части представления) отображается сводная информация о выпусках проекта, включая краткое описание каждого выпуска и входящих в него пакетов. Нажмите кнопку
в этой области, чтобы открыть диалоговое окно пакетного изменения состояния, в котором можно за одну пакетную операцию изменить состояние жизненного цикла нескольких элементов, относящихся к одному выпуску.
Дополнительная информация о выпусках проекта доступна в веб-просмотрщике целевого рабочего пространства, который открывается кнопкой
на панели Explorer. В веб-просмотрщике рабочего пространства все выпуски, связанные с проектом, доступны в представлении Releases или в представлении Manufacture, если рабочее пространство размещено на локальном сервере. На странице перечислены все выпуски проекта, начиная с самого нового. Отдельный выпуск можно открыть в Manufacturing Portal рабочего пространства с помощью соответствующей кнопки открытия В представлении Manufacturing Portal содержится более подробная информация о выбранном выпуске, включая входящие в него файлы пакетов выпуска, полный набор проектных документов и сведения о производителях и поставщиках компонентов. Обратите внимание: функция Send to Manufacturer доступна только в рабочем пространстве Altium 365. ► Подробнее см. на странице «Представление выпусков в рабочем пространстве Altium 365».
Готово! Проект выпущен, и теперь можно просто закрыть представление Release (кнопкой
в правом нижнем углу). Если в дальнейшем потребуется повторно выпустить этот же проект, Project Releaser позволит сделать это быстро и легко, автоматически увеличив номера целевых ревизий элементов.
Публикация в экземпляре PLM
Related pages: Интеграция с PLM (рабочая область Altium 365, рабочая область Enterprise Server), Публикация в PLM
Вы можете опубликовать проект в экземпляре PLM при запуске Project Releaser в Altium Designer. Для управления передачей данных в PLM при публикации используется шаблон публикации, заданный в конфигурации интеграции этого экземпляра PLM. Эта возможность доступна через соответствующим образом настроенный процесс. В состав установки входит пример определения процесса — Project Releaser with Publish, — рабочий процесс которого позволяет выполнять публикацию в интегрированном экземпляре PLM в качестве дополнительного этапа работы Project Releaser. Схема рабочего процесса показана ниже.

Схема рабочего процесса для стандартного примера определения процесса Project Releaser with Publish
После активации процесс публикации в экземпляре PLM в рамках Project Releaser можно запустить в Altium Designer из подменю Project » Project Releaser активного проекта или из контекстного подменю Project Releaser, доступного по щелчку правой кнопкой мыши на записи проекта на панели Projects.

Доступ к процессу публикации в экземпляре PLM в рамках Project Releaser
Откроется Project Releaser с дополнительным этапом — 7. Publish to PLM. Кроме того, в меню кнопки
доступна команда Prepare & Release & Publish to PLM, позволяющая запустить Project Releaser без остановки для просмотра сгенерированных данных и отчета о выполнении.

Дополнительная команда для запуска Project Releaser без остановки для просмотра сгенерированных данных и отчета о выполнении
Если вы запускаете Project Releaser стандартной командой Prepare, после просмотра и выпуска данных на этапе Execution Report появится кнопка
. Нажмите ее, чтобы продолжить рабочий процесс и выполнить публикацию в PLM. Откроется диалоговое окно Login Credentials. Введите Username и Password для вашего экземпляра PLM и выберите нужный шаблон PLM (он отображается в виде <PLMInstance>:<PublishingTemplate>).

Диалоговое окно Login Credentials, открываемое при первой публикации в экземпляре PLM.
Перейдите на вкладку Diagram, чтобы просмотреть рабочий процесс.

Вкладка Diagram диалогового окна Login Credentials
Нажмите кнопку
, чтобы продолжить публикацию в соответствии с этим рабочим процессом.

).

