Выпуск проекта разработки
Краткий обзор
- Узнайте, как организуются и сохраняются исходные данные, данные для изготовления и сборки, включая выходные файлы для сборки различных вариантов проекта.
- Разберитесь, как контроль версий, однократный выпуск и дополнительные проверки помогают обеспечить целостность выпуска.
- Узнайте, как подготовиться к работе с Project Releaser и открыть его, проверить сформированные выходные файлы перед фиксацией выпуска и предоставить доступ к выпущенным данным с помощью поддерживаемых вариантов публикации.
Когда проект готов к выходу в большой мир, его необходимо выпустить — и важность этого процесса часто недооценивают.
Без четко регламентированного и продуманного процесса выпуска отслеживание постоянно развивающегося изделия со временем может обернуться множеством проблем. Представьте, что вам нужно повторно выпустить предыдущую ревизию изделия, но выясняется, что в соответствующий выпуск не были включены все необходимые исходные файлы проекта в виде снимка состояния! Ничего страшного: можно просто взять сформированные выходные файлы из соответствующих папок этого выпуска — надежные Gerber-файлы и дополнительные данные для изготовления и сборки. Ведь, по сути, больше ничего и не нужно. Но что, если эти «надежные» выходные файлы были перезаписаны или каким-то образом повреждены? Вот бы процесс выпуска был более надежным.
Altium Designer решает эту задачу, предоставляя мощные средства управления выпуском проектов с обеспечением целостности данных. Процесс выпуска проекта автоматизирован, что позволяет выпускать проекты без рисков, связанных с ручными процедурами. При выпуске проекта создается снимок состояния его исходных данных, который архивируется вместе со всеми сформированными выходными данными, описывающими реальное изделие, изготавливаемое по этому проекту и продаваемое компанией. Данные выпуска сохраняются в указанной папке или ZIP-архиве на жестком диске либо в ревизиях соответствующего элемента, связанного с проектом, в целевом рабочем пространстве:
- Source Data (PCB Project Design Item) — копия (снимок состояния) основных файлов проекта с отметкой времени, включая все исходные документы. Выпускается в отдельный элемент рабочего пространства, что позволяет хранить ценную интеллектуальную собственность отдельно от сформированных данных для изготовления и сборки, необходимых сторонним организациям для производства изделия.
- Fabrication Data (PCB Fabrication Data Item) — набор данных, необходимый производителю для изготовления печатной платы без установленных компонентов (Gerber-файлы, файлы сверления NC Drill и т. д.).
- Assembly Data (PCB Assembly Data Item) — набор данных, необходимый сборочному предприятию для установки заданных компонентов на печатную плату в соответствии с перечнем материалов (файлы Pick and Place, сборочные чертежи, перечни материалов и т. д.). Для базового исполнения проекта (с полным набором компонентов) и каждого заданного варианта сборки используется отдельный элемент.

Данные, сформированные из проекта, надежно хранятся в рабочем пространстве в ревизиях связанных с проектом элементов. Затем эти данные с гарантированной целостностью используются участниками цепочки поставок для изготовления нужной ревизии изделия.
В результате обеспечивается максимально надежное управление выпуском проектов. Не только сам проект находится под строгим контролем, резервируется и отслеживается системой контроля версий — аналогичным образом защищены и выпуски его данных в целевом рабочем пространстве.
Основные преимущества
- Интеграция с системой контроля версий. Если проект находится под управлением системы контроля версий, перед выпуском система требует, чтобы все файлы были зафиксированы в репозитории и находились в актуальном состоянии. Это гарантирует, что «личная копия» важного проектного документа не останется только на жестком диске инженера, где она может быть утрачена. Это простое правило позволяет в дальнейшем сэкономить часы на дорогостоящих поисках нужного комплекта проектных документов, использованных для создания выпущенного изделия.
- Однократный выпуск. Система позволяет выполнить выпуск в конкретную ревизию целевого элемента только один раз. При успешном выпуске данные фиксируются (сохраняются) в указанной ревизии элемента, после чего эта ревизия закрывается. Сформировать и выпустить дополнительные данные в ту же ревизию уже невозможно.
- Автоматизированный и воспроизводимый процесс выпуска проекта. Выпуск одним нажатием — без ручных этапов и связанных с ними рисков. От создания снимка состояния файлов проекта до проверки и формирования выходных данных вмешательство пользователя не требуется. Если какой-либо этап завершается с ошибкой, выпуск не выполняется. Всё просто. При этом перед окончательным сохранением данных выпуска в ревизии элемента целевого рабочего пространства можно просмотреть все сформированные данные.
-
Возможность проверки проекта как неотъемлемой части процесса выпуска. Процесс выпуска использует зафиксированный снимок состояния исходных данных проекта, включая зависимости. Как правило, предварительная проверка уже выполнена до начала выпуска. Но для дополнительной уверенности и обеспечения целостности проектных данных можно включить проверки непосредственно в процесс выпуска, соответствующим образом настроив конфигурации заданий формирования выходных данных (Output Job). Помимо стандартной проверки электрических правил (ERC) исходных схем и проверки правил проектирования (DRC) печатной платы, можно проверить согласованность исходного проекта и платы, а также сравнить посадочные места на плате с исходной библиотекой, чтобы убедиться в их актуальности и соответствии. Если хотя бы одна проверка не пройдена, выпуск не выполняется.
- К именам всех файлов данных, сформированных в процессе выпуска проекта, при необходимости можно добавить префиксы с идентификатором элемента и идентификатором его ревизии. Это исключает неоднозначность в определении того, для изготовления какой ревизии какого элемента предназначены данные.
- Публикация. Возможность публиковать данные выпуска непосредственно из рабочего пространства в общее хранилище, например Amazon S3, на FTP-серверы, Box.com или в обычную сетевую папку. Это позволяет легко и безопасно обмениваться данными рабочего пространства, не предоставляя сторонним организациям доступ к нему.
Инструмент Project Releaser
Altium Designer обеспечивает мощное и надежное управление выпуском проекта благодаря Project Releaser. Интуитивно понятный пользовательский интерфейс позволяет одновременно сформировать все производственные данные проекта: данные для изготовления и сборки, исходные данные проекта и т. д. Project Releaser также позволяет одновременно формировать данные для сборки нескольких обнаруженных вариантов проекта печатной платы. Даже если вы еще не создали файлы Output Job, беспокоиться не о чем — достаточно запросить их создание!
С помощью Project Releaser вы сможете легко формировать производственные данные, обеспечивая их максимальную целостность. Кроме того, перед окончательным завершением выпуска можно проверить сформированные данные (например, просмотреть данные Gerber/ODB++ в CAM-редакторе), чтобы убедиться, что они в точности соответствуют требованиям для изготовления вашего изделия в срок и с первого раза.
Для выпуска проекта в рабочую область необходимо выполнить следующие условия:
- Altium Designer подключен к рабочей области, в которой находится целевой репозиторий для выпуска.
- Проект содержит подходящие задания вывода Output Job — генераторы выходных данных проекта (для вывода на печать, в файл или PDF). Если файлы OutJob отсутствуют, Project Releaser предложит создать подходящие файлы OutJob для выполнения процесса.
- Проект, используемый в процессе выпуска, содержит все необходимые элементы: исходные данные корректны и актуальны, у пользователя достаточно прав для выпуска этого проекта в рабочую область и т. д.
Доступ к Project Releaser
Сам процесс выпуска выполняется с помощью Project Releaser в Altium Designer. Его пользовательский интерфейс представлен в отдельном представлении — Release. Открыть его можно следующими способами:
- Выбрать команду Project » Project Releaser в главном меню (при этом исходный документ нужного проекта должен быть открыт и активен).
- Щелкнуть правой кнопкой мыши по нужному проекту на панели Projects и выбрать команду Project Releaser в контекстном меню.

Представление Release — пользовательский интерфейс Project Releaser.
Публикация в PLM
Related page: Интеграция с PLM (рабочая область Altium 365, рабочая область Enterprise Server)
Если в рамках Project Releaser у вас активирован процесс публикации в экземпляр PLM, он будет доступен в подменю Project Releaser проекта. При запуске этого процесса в представление будет добавлен соответствующий дополнительный этап.
В вашей рабочей области доступно примерное определение процесса Publish to PLM (User selects), входящее в категорию процессов Project Activities, для выполнения стандартной публикации (то есть публикации не в рамках Project Releaser, как описано ранее). Этот процесс позволяет публиковать выпущенные выходные данные проекта в интегрированный экземпляр PLM, причем пользователь может выбрать, какие именно выходные данные следует опубликовать. Схема рабочего процесса показана ниже.

Схема рабочего процесса для стандартного Publish to PLM (User selects) примерного определения процесса
Стандартные процессы публикации в PLM доступны в Altium Designer из подменю Project » Project Activities активного проекта.

Доступ из Altium Designer к активированному процессу стандартной публикации выпущенных данных проекта рабочей области в экземпляр PLM.
Режим и целевое расположение выпуска
Project Releaser поддерживает все типы проектов — локальные, без контроля версий, под управлением внешней системы контроля версий или встроенной системы контроля версий подключенной рабочей области — и предлагает два режима работы:
- Managed (Online) Mode — выпуск всех сформированных данных в ревизии элементов целевой рабочей области. Вам даже не нужно помнить об увеличении номера ревизии элемента — все выполняется автоматически. А если у вас определен процесс выпуска в экземпляр PLM через Project Releaser, при его запуске в представление будет добавлен соответствующий дополнительный этап.
- Unmanaged (Offline) Mode — выпуск всех сформированных данных в структуру папок, которую при необходимости можно упаковать в один ZIP-файл.
Project Releaser пытается автоматически определить режим выпуска и его целевое расположение. Если возможен выбор — обычно когда проект уже выпускался в одну рабочую область, а сейчас вы подключены к другой, — система предложит доступные варианты.
Обнаружение файлов Output Job
Основной способ формирования выходных данных проекта в Altium Designer — использование различных доступных генераторов выходных данных. Они создают файлы данных и графические материалы, необходимые для физического изготовления изделия: распечатки принципиальных схем и печатных плат, производственные файлы Gerber и NC Drill, спецификацию (BOM), файлы установки компонентов (Pick and Place), производственные чертежи и другие материалы, необходимые для изготовления и сборки.
Выбранные генераторы выходных данных и конкретные выходные файлы, которые они должны создавать для проекта, совместно задаются с помощью Output Job Editor. Конфигурации сопоставления генераторов с выходными данными сохраняются в файле Output Job (*.OutJob), создаваемом командой File » New » Output Job File.
Задания Output Job в Altium Designer служат основным механизмом совместного формирования производственных файлов проекта и предоставляют следующие дополнительные возможности:
- В проект можно добавить любое количество файлов OutJob, чтобы иметь готовые конфигурации для конкретных задач: формирования выходных данных для изготовления, сборки, архивирования, закупок и документации.
-
Файлы OutJob переносимы и могут применяться к любому проекту, для которого требуется стандартизированный набор выходных данных. Например, чтобы создать универсальное и, следовательно, переносимое задание Output Job, выберите
[Project]в качестве источника документов вместо конкретного файла проекта. - Файлы OutJob могут включать файлы для проверок проекта, например проверки электрических соединений (ERC), проверки правил проектирования (DRC) и сравнения посадочных мест с исходными данными. Таким образом, задания вывода для проверки представляют собой особый «активный» случай: проект проверяется, а фактический результат вывода (например, PDF-документ) содержит результаты проверки.
- OutJobs поддерживают варианты исполнения собранной платы, для которых требуются разные наборы выходных файлов для изготовления альтернативных версий изделия — например, стандартной версии или версии с улучшенными характеристиками, в которой используются дополнительные компоненты или компоненты других типов. Подробнее о вариантах исполнения платы см. в разделе Варианты исполнения проекта.
Если с вашим проектом пока не связано ни одного файла Output Job, Project Releaser обнаружит это и предложит добавить файлы по умолчанию. Если вы согласитесь, будут созданы следующие файлы:
-
Для проекта печатной платы:
-
Assembly.OutJob— со следующими заданными выходными данными:-
Documentation Outputs:
PCB 3D Print,Schematic Prints -
Assembly Outputs:
Generates pick and place files,Assembly Drawings -
Report Outputs:
Bill of Materials -
Export Outputs:
Export STEP
-
Documentation Outputs:
-
Fabrication.OutJob— со следующими заданными выходными данными:-
Documentation Outputs:
PCB Prints -
Fabrication Outputs:
Gerber Files,NC Drill FilesиIPC-2581 -
Validation Outputs:
Design Rules Check,Footprint Comparison Report -
Export Outputs:
Save As/Export PCB
-
Documentation Outputs:
Эти файлы Output Job по умолчанию берутся из следующей стандартной папки установки:
\Users\Public\Documents\Altium\AD<Solution/Version>\OutputJobs. -
-
Для проекта жгута:
-
Assembly.OutJob— со следующими заданными выходными данными:- Documentation Outputs: Draftsman
-
Report Outputs:
Bill of Materials -
Validation Outputs:
Electrical Rules Check
Этот файл Output Job по умолчанию берётся из следующей стандартной папки установки:
\Users\Public\Documents\Altium\AD<Solution/Version>\OutputJobs\Harness. -
Обнаружение вариантов исполнения
Для проектов печатных плат одна из наиболее полезных возможностей Project Releaser заключается в обнаружении заданных для проекта вариантов исполнения и создании для каждого из них готового к выпуску набора сборочных данных. Для каждого набора сборочных данных по умолчанию используется имя целевого элемента следующего вида:
PCBA-[ProjectName]-[VariantName]
Суффикс [VariantName] гарантирует использование правильного варианта исполнения при формировании данных из назначенных файлов OutJob.

Дополнительные наборы сборочных данных, созданные на основе обнаруженных вариантов исполнения проекта.
Процесс выпуска
Процесс выпуска состоит из последовательных этапов. Элементы в левой части представления Release позволяют сразу определить, на каком этапе вы находитесь.
Подробнее о процессе выпуска в режиме Online см. на странице Выпуск в рабочую область. Подробнее об особенностях режима выпуска Offline см. на странице Локальный выпуск.
Публикация выпущенных данных
Related page: Работа с местами назначения публикации
Выпущенные данные, сформированные из проекта печатной платы (только данные изготовления платы, данные сборки платы и элементы проекта печатной платы), можно публиковать непосредственно из рабочей области или Output Job в хранилище, например Box.com, Amazon S3, на FTP-сервере или в обычной папке в общей сети. С точки зрения распространения данных и совместной работы это даёт исключительное преимущество в условиях, когда участники общей команды продукта — разработчики, производственные специалисты и все остальные, кто участвует в превращении идеи в готовое изделие, — зачастую находятся в разных частях света.
Для публикации достаточно задать Publishing Destination, а затем загрузить туда выпущенные данные нужной ревизии элемента. Все, кому необходимо знать о новом выпуске, — от производственной площадки в Китае до команд разработчиков в Киеве, Стэнстед-Эбботтсе и Сан-Диего и руководителя проекта, летящего где-то над Тихим океаном, — могут получить приглашение со ссылкой на опубликованную папку. Это обеспечивает общий, контролируемый доступ к просмотру, обсуждению и использованию данных для изготовления элемента.

Публикуйте выпущенные данные в хранилище и обменивайтесь информацией с участниками команды по всему миру.
Глобальный совместный доступ к данным производственного пакета
Одна из ключевых возможностей проектов, хранящихся в рабочей области Altium 365, — создание и предоставление другим пользователям доступа к Build Package выпуска. Если доступ предоставляется непосредственно изготовителю, такой пакет можно рассматривать как Manufacturing Package, поскольку изготовитель может просматривать, скачивать и использовать его для изготовления и сборки платы.
Для предоставления доступа к такому пакету другим пользователям и изготовителю, который обычно находится за пределами вашей организации, платформа Altium 365 предлагает специальный Manufacturing Package Viewer — элемент поддержки Global Sharing платформы. Он позволяет просматривать производственный пакет в любом веб-браузере из любой точки мира, но вне вашей рабочей области, благодаря чему сами проекты и другая ценная интеллектуальная собственность остаются недоступными.
Каждый пользователь, которому предоставлен доступ, получит по электронной почте приглашение со ссылкой для просмотра производственного пакета через Manufacturing Package Viewer. Производственные пакеты с предоставленным доступом отображаются на странице Shared with Me веб-интерфейса платформы Altium 365.
Сам Manufacturing Package Viewer позволяет основным заинтересованным сторонам — прежде всего производственным специалистам — просматривать сводную информацию о проекте с ключевыми данными платы, а также структуру исходных данных, данных изготовления и сборки и при необходимости скачивать отдельные файлы. В средстве просмотра также предусмотрены отдельные страницы данных изготовления, сборки и спецификации BOM. Страница изготовления содержит средство просмотра Gerber и позволяет всем пользователям, которым предоставлен доступ к пакету, добавлять комментарии.
В итоге производственные специалисты могут скачать пакет для изготовления просмотренного выпуска с любой страницы средства просмотра и использовать его для физического изготовления этой ревизии платы.
Веб-просмотрщик
Related page: Web Viewer (Рабочее пространство Altium 365, Рабочее пространство Enterprise Server)
Интерфейс Web Viewer рабочего пространства обеспечивает универсальный доступ к документам проекта печатной платы через стандартный веб-браузер. Это не просто веб-просмотрщик: передовая браузерная технология Web Viewer's позволяет пользователям перемещаться по структуре проекта, взаимодействовать с проектными документами, извлекать информацию об элементах проекта и выделять области или объекты для добавления комментариев.
При просмотре документов в веб-формате качество отображения схем и печатных плат не снижается. При этом доступны полноценные функции панорамирования и масштабирования, а также поиска, перекрестного выделения, выбора и просмотра свойств компонентов и цепей во всем проекте.

Интерфейс Web Viewer рабочего пространства обеспечивает наглядную интерактивную среду для просмотра, например, исходных документов схемы и печатной платы, входящих в ваш проект. Здесь показана схема в интерфейсе Web Viewer Altium 365 — наведите указатель на изображение, чтобы увидеть печатную плату в 3D.
Будучи независимой браузерной платформой просмотра, интерфейс Web Viewer предоставляет интерактивный доступ к проектным документам только для чтения, без необходимости открывать проект в среде редактирования. Действия в среде Web Viewer не влияют на других участников работы над проектом, например на ответственного за него инженера, за исключением связанных уведомлений о комментариях.
