Поддержание синхронизации схем и печатной платы

Altium Training

Altium Essentials: Transfer to PCB

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Краткий обзор

В этой статье объясняется, как Altium Designer поддерживает согласованность схем и топологии печатных плат — от первоначального переноса разработанной схемы на плату до последующих изменений с любой стороны. Вы узнаете, как компаратор обнаруживает различия, как для их устранения формируются извещения об изменениях (Engineering Change Orders, ECO) и чем отличаются два основных подхода к синхронизации: двунаправленный и однонаправленный. Также в статье рассматривается, какие данные можно синхронизировать, как настройки компаратора и ECO влияют на этот процесс и как при синхронизации переносятся классы и правила проектирования. Хотите лучше понять, как поддерживать согласованность проекта и сократить объем ручных доработок? Читайте дальше — это руководство поможет вам работать увереннее.

- Узнайте, чем двунаправленное сравнение отличается от прямого обновления и когда применяется каждый из этих подходов.
- Разберитесь, какие данные Altium Designer может синхронизировать между схемой и печатной платой, включая компоненты, электрические связи, классы и некоторые правила проектирования.
- Посмотрите, как параметры проекта, в том числе настройки Comparator и ECO Generation, влияют на процесс синхронизации и набор изменений, которые можно применить.
Узнайте больше с ИИ:

Наиболее распространенная задача при работе со схемой и печатной платой — поддержание их соответствия или синхронизации. Независимо от того, переносите ли вы впервые разработанную схему на новую печатную плату или вносите изменения в существующий проект на стороне схемы либо платы, вам необходим способ поддерживать их согласованность. Altium Designer включает мощные средства синхронизации проекта, которые упрощают эту задачу и позволяют разработчику сосредоточиться на творческих аспектах проектирования.

В процессе синхронизации выявляются и устраняются различия между схемой и печатной платой. В процессе синхронизации выявляются и устраняются различия между схемой и печатной платой.

Синхронизация проекта выполняется непосредственно между редакторами схем и печатных плат; промежуточный документ наподобие списка соединений не используется. Программа сравнивает все аспекты проекта с помощью механизма сравнения и представляет результаты в виде списка различий. Разработчик решает, на какой стороне следует внести изменения для устранения различий, после чего формируется набор извещений об изменениях (ECO). После их применения схема и плата вновь становятся согласованными.

Существует два подхода к выполнению синхронизации:

  • Двунаправленная синхронизация, при которой изменения для устранения различий могут одновременно вноситься в обоих направлениях с помощью команды Project » Show Differences (как показано выше). Подробнее об этом подходе см. в разделе Поиск различий.
  • Однонаправленная синхронизация с помощью команд Design » Update PCB или Design » Update Schematic. Подробнее об этом подходе см. в разделе Выполнение прямого обновления.

Перед переносом информации со схемы на новую печатную плату необходимо убедиться, что доступны все соответствующие библиотеки условных графических обозначений и посадочных мест компонентов.

Что можно синхронизировать?

Процесс синхронизации обеспечивает соответствие данных о компонентах и соединениях на схеме данным о компонентах и соединениях на печатной плате. Помимо этих данных, синхронизация также обеспечивает согласованность других ограничений проекта, таких как классы цепей, классы компонентов и правила проектирования.

Настройка параметров сравнения

Dialog page: Параметры проекта печатной платы, вкладка сравнения

Какие именно what данные схемы и печатной платы будут сравниваться, задается на вкладке Сравнение диалогового окна Options for PCB Project. Чтобы открыть это окно, выберите Project » Project Options.

Механизм сравнения использует настройки, заданные на вкладке Comparator диалогового окна Options for Project.
Механизм сравнения использует настройки, заданные на вкладке Comparator диалогового окна Options for Project.

Основная область диалогового окна содержит обширный список типов сравнения, таких как Different Designators и Changed Net Name, объединенных в 5 категорий. В столбце Mode справа для каждого типа предусмотрен раскрывающийся список, в котором можно выбрать режим сравнения, например Find Differences или Ignore Differences. Для сравнения текстовых данных предусмотрен третий вариант, позволяющий не учитывать регистр.

По умолчанию для нового проекта поиск различий включен для всех типов сравнения. Настройте эти параметры в соответствии с требованиями проекта.

  • При синхронизации схемы с печатной платой можно синхронизировать все данные, относящиеся к печатной плате.
  • При синхронизации печатной платы со схемой обратно на схему можно перенести только изменения позиционного обозначения, комментария и посадочного места компонента. Из изменений цепей можно синхронизировать только те, которые возникли в результате перестановки выводов или секций компонентов. Способ выполнения этой операции зависит от настроек перестановки выводов и секций. Подробнее см. на странице Перестановка выводов и секций компонентов.

В нижней части диалогового окна расположены параметры настройки Object Matching Criteria. Сопоставление — это сложный многопроходный процесс, который не сводится к простому поиску точного совпадения строк. Подробнее см. в разделе Сопоставление цепей и классов. 

Обратите внимание на параметр Ignore Rules Defined in the PCB Only в нижней части диалогового окна: включите его, чтобы исключить из сравнения правила, заданные на печатной плате.

Синхронизация классов цепей и компонентов

Dialog page: Параметры проекта печатной платы, вкладка создания классов

Помимо данных о компонентах и соединениях, при выполнении Design » Update PCB можно также создавать и синхронизировать классы и правила проектирования.

Подробнее о создании и синхронизации классов на основе схемы см. в разделе Создание и синхронизация классов на основе схемы на странице Работа с классами на схеме и печатной плате.

Синхронизация правил проектирования

Правила проектирования можно задавать на схеме с помощью объекта «Набор параметров». Если выбран объект «Набор параметров», панель или модальное диалоговое окно Properties содержит область Rules. Чтобы добавить правило проектирования, щелкните раскрывающийся список Add. Правило будет применено к цепи, шине, жгуту или объектам под областью охвата, к которым присоединен объект «Набор параметров».

На изображении ниже правило ограничения ширины применяется к классу цепей USB_data (этот класс цепей также задан в составе данного набора параметров, в области Classes раскрывающегося списка Parameters ).

Набор параметров используется для задания класса цепей и правила проектирования для цепей под объектом области охвата на схеме. Обратите внимание: необходимые единицы измерения задаются в нижней части диалогового окна редактирования правила печатной платы.
Набор параметров используется для задания класса цепей и правила проектирования для цепей под объектом области охвата на схеме. Обратите внимание: необходимые единицы измерения задаются в нижней части диалогового окна редактирования правила печатной платы.

На вкладке Comparator диалогового окна Options for Project убедитесь, что включены необходимые типы сравнения правил, чтобы правила проектирования можно было добавлять и обновлять на печатной плате.

Каждому правилу печатной платы, созданному на основе определения правила на схеме, автоматически присваивается имя Schematic <RuleType>. При необходимости это имя можно изменить, поскольку оно не используется для последующей синхронизации правил.

На изображениях выше и ниже правило проектирования задано в объекте «Набор параметров», присоединенном к области охвата. Если включить в набор параметров определение класса, на печатной плате также будет создан класс цепей. Благодаря наличию определения класса область действия правила печатной платы будет задана как InNetClass('<PCB_NetClassName >'). 

На изображении ниже объект «Набор параметров» отображается в виде директивы дифференциальной пары. Это особый тип объекта «Набор параметров», размещаемый с помощью команды Place » Directives » Differential Pair.  

Директива дифференциальной пары используется для задания класса цепей и правила проектирования, которое затем применяется к целевым дифференциальным парам.
Директива дифференциальной пары используется для задания класса цепей и правила проектирования, которое затем применяется к целевым дифференциальным парам.

Работа с дифференциальными парами

Директива Differential Pair используется для обозначения цепей, входящих в дифференциальную пару. Программа требует, чтобы цепи пары назывались <Name>_P и <Name>_N. В этом случае дифференциальная пара на печатной плате будет называться <Name>.

Пары можно определить, разместив директиву Differential Pair на каждой цепи дифференциальной пары, либо разместив область Blanket так, чтобы она охватывала имена цепей пары, как показано на изображении выше.

На изображении выше объект Parameter Set для дифференциальных пар приводит к созданию:

  • Восьми дифференциальных пар с именами V_RX0, V_TX0, V_RX1, V_TX1, RX0, TX0, RX1, TX1.
  • Класса цепей печатной платы с именем ROCKET_IO_LINES.
  • Правила проектирования Differential Pairs Routing, настроенного для применения к классу цепей печатной платы ROCKET_IO_LINES.

Настройка параметров формирования ECO

Диалоговое окно Options for Project также содержит вкладку Формирование ECO. Эта вкладка определяет, для каких изменений проекта можно создавать ECO. Обычно все эти параметры включены, а параметры на вкладке Компаратор этого диалогового окна используются для настройки того, какие изменения проекта следует синхронизировать между схемой и печатной платой.

Вкладка «Формирование ECO» определяет, для каких типов изменений можно создавать ECO.
Вкладка «Формирование ECO» определяет, для каких типов изменений можно создавать ECO.

Поиск различий

Функция синхронизации проекта позволяет обнаруживать и устранять различия в обоих направлениях: от схемы к печатной плате и от печатной платы к схеме.

Существует два подхода к обнаружению и устранению различий: 

  1. Назначить направление обновления для каждого изменения.
  2. Применить все обновления в одном направлении.

Если вам не требуется одновременно применять обновления в обоих направлениях, выбирать документы для сравнения и настраивать направление обновления для устранения различий не нужно. В этом случае можно сразу перейти к разделу Performing a Direct Update.

Программа позволяет устранять эти различия, одновременно применяя изменения с обеих сторон. Например, представьте ситуацию, в которой разработчик схемы изменил номинал конденсатора, а разработчик печатной платы изменил посадочное место того же конденсатора. Эти два различия можно устранить за один процесс обновления: изменение комментария передать из схемы на плату, а изменение посадочного места — с платы в схему.

Когда механизм сравнения сравнивает проект схемы с печатной платой, формируется полный список различий — на этом этапе не предполагается, какую сторону нужно изменить для восстановления синхронизации.

Список различий можно просмотреть в диалоговом окне Differences between.

Чтобы открыть диалоговое окно Difference between и просмотреть список различий:

  • Чтобы открыть диалоговое окно Choose Documents to Compare, показанное на изображении ниже, выполните команду Project » Show Differences или щёлкните правой кнопкой мыши запись нужного проекта (либо одного из его исходных документов) на панели Projects  и выберите команду Show Differences в контекстном меню. Диалоговое окно Choose Documents to Compare используется для выбора двух документов или наборов документов для сравнения; обычно сравнивают схемную часть проекта с печатной платой. Это окно также позволяет сравнивать любые документы друг с другом, если установить флажок Advanced Mode. Например, можно сравнить список цепей с печатной платой или одну печатную плату с другой.

    Как правило, настройки диалогового окна по умолчанию — как в базовом, так и в расширенном режиме — подходят для большинства задач сравнения проекта, когда требуется сравнить исходные документы и целевой проект печатной платы для их синхронизации. Однако окно позволяет сравнивать и другие документы, что может быть полезно, если нужно загрузить разные версии проекта и сравнить соответствующие исходные документы.

    Выберите печатную плату для сравнения со схемной частью проекта.
    Выберите печатную плату для сравнения со схемной частью проекта.

  • Выберите печатную плату в основной части диалогового окна и нажмите OK, чтобы открыть диалоговое окно Difference between, показанное ниже. Если документ печатной платы уже синхронизирован с исходными документами, появится сообщение о том, что различий не обнаружено.

Откроется диалоговое окно Differences between. Синхронизатор работает в обоих направлениях. Это означает, что в одном ECO можно задать обновления для обоих документов. Для синхронизации сравниваемых документов необходимо определить для каждого различия, требуется ли действие и в каком направлении следует внести изменение, то есть указать, какой документ нужно обновить для устранения различия. Поэтому следующий шаг — назначить направление обновления для каждого различия:

  • Для отдельного различия щёлкните в столбце Update, чтобы открыть элемент выбора направления, как показано на изображении ниже.
  • Для нескольких различий одного типа щёлкните правой кнопкой мыши заголовок, например «Различающиеся посадочные места», и выберите нужную команду Update Same Kind.
  • Для всех различий щёлкните правой кнопкой мыши в любом месте диалогового окна и выберите нужную команду Update All.

Чтобы сформировать ECO для устранения различия, необходимо задать направление обновления для этого различия.
Чтобы сформировать ECO для устранения различия, необходимо задать направление обновления для этого различия.

Нажмите кнопку Explore Differences, чтобы открыть панель Differences и изучить различия, как описано ниже в разделе Изучение изменений проекта с помощью панели Differences.

Поскольку при таком открытии панели Differences диалоговое окно Differences between закрывается, все ранее принятые решения об обновлении будут потеряны. Поэтому лучше изучить различия до принятия решений об обновлении. Также можно выполнить перекрёстный переход к объекту непосредственно из диалогового окна Differences between , дважды щёлкнув запись объекта в области Differences этого окна.

Нажмите Report Differences, чтобы настроить и распечатать или экспортировать отчёт о различиях, обнаруженных компаратором, заданных решениях об обновлении и действиях, которые будут включены в сформированный ECO.

После назначения направления обновления нажмите кнопку Create Engineering Change Order, чтобы открыть диалоговое окно Engineering Change Order, описанное ниже в разделе Устранение различий — применение ECO.

Изучение изменений проекта с помощью панели Differences

На панели Differences  различия между документами представлены в виде иерархии.
На панели Differences различия между документами представлены в виде иерархии.

Общие сведения

Панель Differences предназначена для отображения логических или физических различий, обнаруженных встроенным средством сравнения Differences Comparator при сравнении проектных документов (например, при сравнении иерархии исходных документов проекта (схем) с документом печатной платы). Панель позволяет интерактивно изучить различия, прежде чем принять решение о создании извещения об изменениях (Engineering Change Order, ECO), которое будет использоваться для синхронизации документов проекта.

Доступ к панели

Чтобы открыть панель Differences :

  • Выберите View » Panels » Differences в главном меню.
  • Нажмите кнопку Panels в правом нижнем углу рабочей области проектирования, затем выберите Differences.

Панели можно настроить как плавающие в рабочей области редактора или закрепленные по краям экрана. Если панель Differences  находится в группе закрепленных панелей, используйте вкладку Differences в нижней части панелей, чтобы вывести ее на передний план.

Отображение различий

Способ использования панели Differences зависит от того, требуется ли:

  • Проверить целостность всего проекта с точки зрения его содержимого и структуры, выявив логические различия в иерархии проекта.
  • Сравнить две версии одного документа схемы или печатной платы, выявив их графические (физические) различия.
Панель Differences заполняется при использовании функции Explore Differences в диалоговом окне Различия между средства Differences Comparator. Это окно открывается щелчком правой кнопкой мыши на панели Projects и выбором Show Differences.

Отображение логических различий

Сравнение документов проекта для выявления логических различий выполняется в диалоговом окне Choose Documents To Compare, которое открывается щелчком правой кнопкой мыши на проекте (или документе проекта) на панели Projects и выбором Show Differences в соответствующем контекстном меню.

Щелкните правой кнопкой мыши на имени проекта и выберите Show Differences, чтобы открыть диалоговое окно Choose Documents To Compare.
Щелкните правой кнопкой мыши на имени проекта и выберите Show Differences, чтобы открыть диалоговое окно Choose Documents To Compare.

Обычно документ печатной платы сравнивается с иерархией исходных документов проекта, к которому он относится, чтобы выявить логические различия между содержимым схемы и содержимым проекта печатной платы.

Если между выбранными документами есть различия, после нажатия OK откроется диалоговое окно Различия между. Информация на панели Differences появится только после нажатия кнопки Explore Differences в диалоговом окне Differences between.

На панели Differences отображаются только различия, перечисленные в диалоговом окне Differences between. В свою очередь, их состав определяется настройками на вкладке Comparator диалогового окна Project Options  (Project » Options). На этой вкладке перечислены все типы сравнения, например различия, связанные с компонентами, цепями и параметрами. Выбор значения Find Differences или Ignore Differences для параметра Mode каждой категории сравнения определяет, будет ли Differences Comparator передавать результаты в диалоговое окно Differences between .

Настройте способ обнаружения и представления различий в диалоговом окне Project Options .
Настройте способ обнаружения и представления различий в диалоговом окне Project Options .

Панель Differences отображает найденные различия между исходными документами в виде древовидной структуры, в которой папка верхнего уровня показывает общее количество обнаруженных различий. Для каждого отдельного типа сравнения, представленного в диалоговом окне Различия между, создаются вложенные папки. В каждой вложенной папке перечислены конкретные найденные различия, которые, в свою очередь, раскрываются до объектов документов, вызывающих эти различия.

Если соответствующий документ открыт (в том числе если он скрыт), щелчок на записи объекта на панели приведет к переходу к этому объекту в документе.

При отображении объекта используются масштабирование и затемнение: объект выделяется за счет затемнения всех остальных объектов. Степень затемнения можно изменить с помощью ползунка Dimming в области Highlight Methods на странице Система — Навигация диалогового окна Preferences .

Отображение физических различий

Графическое (физическое) сравнение двух версий одного документа схемы или печатной платы выполняется в основном так же, как описанное выше логическое сравнение, но дополнительно используется Advanced Mode в диалоговом окне Choose Documents To Compare.

Для физического сравнения документов используйте команду Show Differences (в контекстном меню панели Projects), чтобы открыть диалоговое окно Choose Documents To Compare, затем установите флажок Advanced Mode. После того как в окне отобразятся все файлы проекта, выберите две версии документа для сравнения.

Выбор документов для физического сравнения в диалоговом окне Choose Documents To Compare в Advanced Mode.
Выбор документов для физического сравнения в диалоговом окне Choose Documents To Compare в Advanced Mode.

Нажатие OK запустит графическое сравнение и откроет диалоговое окно Различия между, как описано выше. Нажмите Explore Differences, чтобы открыть интерактивный список различий на панели Differences.

Панель отображает найденные различия между документами в виде древовидной структуры. Папка верхнего уровня показывает общее количество обнаруженных различий. Для каждого типа различий создаются записи, содержащие конкретные обозначения и соответствующий объект (порт, компонент и т. д.) для каждого различия.

При выборе записи объекта, связанного с обнаруженным различием, этот объект будет выделен и показан в увеличенном масштабе в рабочей области редактора.

Примечания

  • Если объект на панели находится в документе, который в данный момент скрыт, при щелчке на соответствующей записи документ автоматически откроется и станет активным в окне редактора .
  • Фильтрация, применяемая при переходе к объектам с панели Differences , является временной. Поэтому вы можете выбирать и редактировать объекты проекта, не входящие в область действия фильтра.
  • Информация на панели Differences очищается при выполнении нового сравнения документов или компиляции проекта, к которому они относятся.
  • Используйте команду Project » Show Physical Differences из главного меню, чтобы обнаружить физические различия между двумя версиями документа схемы или печатной платы и представить их графически при просмотре двух документов рядом в рабочей области проектирования. Функция Show Physical Differences предназначена только для визуального сравнения: ни один из сравниваемых документов нельзя обновить путем формирования ECO. Она предназначена для сравнения двух версий одного документа, однако при сравнении разных документов, например иерархии исходных документов проекта с печатной платой, появится панель Differences со списком обнаруженных логических различий.

Прямое обновление

Поскольку разработчик обычно знает, в каком направлении нужно применить изменения, и все изменения вносятся в одном направлении, можно пропустить описанную выше процедуру обнаружения различий и выбора направления их применения.

Вместо команды Show Differences из меню Project выберите команду Update из меню Design в редакторе схем или редакторе печатных плат. Выбор редактора, из которого запускается команда, определяет направление внесения изменений — из редактора this в редактор that. Например, чтобы перенести все изменения из схемы на печатную плату, выберите Design » Update в редакторе схем.

Активный документ печатной платы также можно обновить с учетом всех изменений, внесенных в исходные документы схем, выбрав команду Design » Import Changes from <ProjectName> в главном меню редактора печатных плат.

Диалоговое окно Differences between будет пропущено, и вы сразу перейдете к диалоговому окну Engineering Change Order.

Если все обновления необходимо применить в одном направлении, используйте команду Design » Update. Если все обновления необходимо применить в одном направлении, используйте команду Design » Update. 

Если документ печатной платы уже синхронизирован с исходными документами, появится диалоговое окно с сообщением о том, что различий не обнаружено. При обновлении схем, напротив, может оказаться, что некоторые или даже все обнаруженные различия невозможно устранить с помощью автоматически сформированных распоряжений на внесение инженерных изменений (ECO). В этом случае вам будет предложено просмотреть эти различия в диалоговом окне Различия между. Даже если внести изменение в схему невозможно, может потребоваться обновить печатную плату (например, удалить объект или сущность). Проанализировав различия, вы можете сформировать ECO для тех из них, которые удается устранить. Если останутся различия, которые нельзя устранить через диалоговое окно, необходимо вернуться к проекту и решить эти проблемы, прежде чем запускать сравнение повторно.

Устранение различий — применение ECO

Каждое различие устраняется путем применения распоряжения на внесение инженерных изменений (ECO). ECO перечислены в диалоговом окне Engineering Change Order: каждое занимает отдельную строку и имеет собственный флажок Enable.

При работе с диалоговым окном Engineering Change Order:

  • При открытии диалогового окна все изменения включены. Отключите те из них, которые хотите пока отложить. Диалоговое окно поддерживает множественный выбор — используйте контекстное меню, открываемое правой кнопкой мыши, чтобы включать или отключать выбранные ECO.
  • Используйте команду перекрестного выбора в контекстном меню, чтобы проверить объекты, затрагиваемые данным ECO.
  • Нажмите кнопку Validate Changes, чтобы проверить возможность внесения изменений. Обычно ECO не выполняются из-за отсутствия объекта — например, указанный посадочный рисунок печатной платы отсутствует в Доступных файловых библиотеках или в посадочном рисунке нет указанной контактной площадки.
  • ECO также может не выполниться, если необходимый для него объект изначально отсутствовал, но был добавлен при обработке текущих ECO. В этом случае повторно запустите команду обновления, чтобы завершить выполнение этого ECO.

Каждое изменение проекта представлено отдельным ECO. Включите необходимые ECO.
Каждое изменение проекта представлено отдельным ECO. Включите необходимые ECO.

Сообщения, связанные с модулем сравнения, будут отображаться на панели Messages.

Связь между схемой и печатной платой

Сопоставление компонентов по уникальным идентификаторам

Каждый компонент схемы связан с соответствующим компонентом печатной платы посредством уникального идентификатора (UID). UID назначается при размещении компонента на листе схемы, а затем передаётся компоненту печатной платы при переносе проекта в редактор печатных плат. При первом переносе информации о компонентах из исходных документов схемы в пустой документ печатной платы с помощью Synchronizer все компоненты автоматически связываются по уникальному идентификатору: идентификатор каждого компонента схемы назначается соответствующему посадочному месту компонента.

Такой подход подходит для простого проекта, но не позволяет работать с многоканальным проектом. В многоканальном проекте один и тот же компонент схемы повторяется в каждом физическом канале, поэтому повторяющиеся компоненты печатной платы имели бы одинаковый UID. Чтобы учесть это, UID компонента печатной платы формируется путём объединения UID родительского символа листа и UID компонента схемы. Формат UID на печатной плате немного различается в зависимости от способа создания многоканального проекта.

Если многоканальный проект создан путём размещения нескольких символов листов, ссылающихся на один и тот же лист схемы, каждый символ листа предоставляет уникальный идентификатор, поэтому UID на печатной плате имеет следующий формат:

\SheetSymbolUID\SchComponentUID

Если многоканальный проект создан с использованием ключевого слова Repeat, доступен только один UID символа листа, поэтому UID на печатной плате также включает значение ChannelIndex и имеет следующий формат:

\ChannelIndex+SheetSymbolUID\SchComponentUID

UID не отображаются на панелях и в диалоговых окнах.

Если компоненты не связаны

Преимущество использования UID для сопоставления компонентов схемы и печатной платы заключается в том, что позиционные обозначения могут рассинхронизироваться (например, после нескольких перенумераций компонентов на печатной плате) без риска потерять возможность синхронизации схемы и печатной платы.

Если на схеме или печатной плате есть компонент, для которого в другом редакторе отсутствует соответствующий компонент с тем же UID, происходит следующее:

  • Если дополнительный компонент присутствует только в исходном редакторе, создаётся ECO для добавления этого компонента в целевой редактор.
  • Если дополнительный компонент присутствует только в целевом редакторе, создаётся ECO для его удаления.
  • Если несопоставленные компоненты присутствуют в обоих редакторах, программе необходимо указать, как с ними поступить, поэтому открывается диалоговое окно Failed to Match Unique Identifiers.

Диалоговое окно e Failed to Match Unique Identifiers  Диалоговое окно e Failed to Match Unique Identifiers  

Кнопки диалогового окна предоставляют следующие возможности:

  • Automatically Create Component Links - нажмите эту кнопку, если вы знаете, что у несопоставленных компонентов уже совпадают позиционные обозначения. Используя позиционные обозначения компонентов, программа назначит этим дополнительным компонентам совпадающие UID. Для компонентов, которые удалось сопоставить по позиционному обозначению, любые другие различия свойств (например, несовпадающие параметры) приведут к созданию ECO. Если какие-либо компоненты не удастся сопоставить по позиционному обозначению, будут созданы ECO для их добавления или удаления (дополнительные компоненты в исходном редакторе будут добавлены, а дополнительные компоненты в целевом редакторе — удалены).
  • Manual Component Links - нажмите эту кнопку, если вы знаете, что соответствующие компоненты существуют, но не знаете, совпадают ли их позиционные обозначения. Откроется диалоговое окно Edit Component Links (описано ниже), в котором можно вручную выбрать каждый исходный и целевой компонент и перенести их в список сопоставленных компонентов, назначив им совпадающие UID. Затем будут созданы ECO для синхронизации позиционных обозначений и любых других несовпадающих свойств компонентов.

    Рекомендуется сопоставить все компоненты по уникальным идентификаторам, чтобы можно было назначать позиционные обозначения в документе схемы или печатной платы, сохраняя возможность повторной синхронизации документов на любом этапе. Документы можно синхронизировать, даже если компоненты не сопоставлены по уникальным идентификаторам, но в этом случае вам будет предложено сопоставить компоненты только по позиционным обозначениям. Комментарий и посадочное место не учитываются, поэтому некоторые компоненты могут быть сопоставлены неправильно.
  • Cancel - нажмите эту кнопку, чтобы создать ECO для добавления дополнительных компонентов, присутствующих в исходном редакторе, и удаления дополнительных компонентов из целевого редактора.

Связывание компонентов вручную

Состояние связей между компонентами схемы и соответствующими посадочными местами компонентов на печатной плате можно в любой момент проверить и изменить в диалоговом окне Edit Component Links (редактор печатных плат, команда Projects » Component Links).

Связывание компонентов вручную only выполняется из документа печатной платы, поскольку информацию об уникальных идентификаторах необходимо обновлять только для посадочных мест компонентов на печатной плате — на схеме она уже присутствует.

Диалоговое окно редактирования связей компонентов (Edit Component Links) используется для обнаружения и устранения несовпадений UID и вызывается из редактора печатных плат.
Диалоговое окно редактирования связей компонентов (Edit Component Links) используется для обнаружения и устранения несовпадений UID и вызывается из редактора печатных плат.

Основные возможности диалогового окна:

  • Несопоставленные компоненты представлены в двух столбцах Un-Matched Components слева, а компоненты с совпадающими UID — в области Matched Components справа.
  • Кнопки со стрелками в центре диалогового окна используются для ручного сопоставления выбранных компонентов (или отмены их сопоставления), а также для отмены сопоставления всех компонентов, сопоставленных на данный момент.
  • Кнопка Add Pairs Matched By и параметры в нижней части диалогового окна используются для просмотра списка несопоставленных компонентов и попытки сопоставить их по выбранным свойствам (позиционное обозначение, комментарий, посадочное место).
  • При нажатии кнопки Perform Update каждому вновь сопоставленному компоненту печатной платы назначается UID соответствующего компонента схемы. Если вы переместили какие-либо записи в Matched раздела диалогового окна обратно в Unmatched разделы появится диалоговое окно подтверждения с предупреждением о том, что при продолжении существующие связи компонентов будут разорваны. Нажатие Yes продолжит обновление, после чего появится информационное диалоговое окно со сводкой изменений связей компонентов в документе PCB. Новая запись в разделе Matched отображается в сводке как Link Modified, а ранее связанная запись, для которой вы отменили сопоставление, — как Link Removed.
  • После ручного связывания компонентов в этом диалоговом окне рекомендуется проверить состояние синхронизации (выполнить команду Design » Update).
  • Используйте это диалоговое окно на любом этапе проектирования, чтобы просмотреть связи между компонентами и убедиться, что компоненты в исходных документах схемы правильно сопоставлены с соответствующими посадочными местами компонентов в проекте PCB.
  • Уникальные идентификаторы можно удалить в любой момент, переместив связанные компоненты обратно в области несопоставленных компонентов диалогового окна Edit Component Links. При удалении связи компонента уникальный идентификатор удаляется только у соответствующего посадочного места на PCB. Компонент схемы сохраняет уникальный идентификатор, если только для него не будет создан новый (с помощью команды сброса уникального идентификатора на уровне схемы).
  • Уникальный идентификатор также автоматически назначается каждому определению параметра в исходном документе схемы. Он используется для параметров, добавленных в качестве директив правил проектирования. При переносе проекта в документ PCB все заданные параметры правил используются для создания соответствующих правил проектирования на PCB. Созданным правилам назначаются те же уникальные идентификаторы, что позволяет изменять ограничения правил как на схеме, так и на PCB и передавать эти изменения при синхронизации.
  • При копировании и вставке или вырезании и вставке компонента схемы его UID автоматически обновляется — благодаря этому у каждого компонента сохраняется уникальный идентификатор.
  • Если вы реорганизуете схему, которая уже была перенесена в редактор PCB, и вам нужно переместить компоненты на другой лист, не используйте вырезание и вставку: выделите компоненты и выполните команду Edit » Refactor » Move Selected Sub-circuit to Different Sheet.

 

Сопоставление цепей и классов

И цепи, и классы имеют родительский объект (саму цепь или класс) и дочерние объекты (элементы этой цепи или класса). Для их сопоставления требуется подход, отличный от механизма UID, используемого для связывания компонентов, чтобы поддерживать изменения родительского объекта, дочерних объектов или и тех и других. Например, простое изменение имени цепи на схеме не должно требовать удаления с PCB этой цепи и всех входящих в нее выводов, последующего добавления цепи с новым именем и, наконец, добавления всех выводов в эту новую цепь.  

Для этого в программном обеспечении предусмотрены отдельные алгоритмы сопоставления цепей и классов по их элементам, а также по имени. Процесс сопоставления настраивается в разделе Object Matching Criteria на вкладке Comparator диалогового окна Options for Project.

По умолчанию сначала выполняется сопоставление по элементам, а затем — по имени типа объекта.
По умолчанию сначала выполняется сопоставление по элементам, а затем — по имени типа объекта.

Сопоставление объектов этих типов выполняется следующим образом:

  • При синхронизации проекта по умолчанию сначала выполняется попытка сопоставления по элементам в соответствии с настройками Min Match % и Min Match Member.
  • Если сопоставление по элементам не удалось, программа пытается выполнить сопоставление по имени (если включена опция Use Name Matching).
  • Если любой из этих способов сопоставления сработает, откроется диалоговое окно Engineering Change Order.
  • Если оба способа сопоставления не сработают (или для опции Use Name Matching задано значение Never), откроется диалоговое окно Match Manually.

  • Нажатие No в диалоговом окне Match Manually позволяет пропустить ручное сопоставление и сразу перейти к диалоговому окну Engineering Change Order. Поскольку вы не попытались сопоставить несопоставленные объекты, программа считает исходные и целевые объекты не связанными между собой. Поэтому будут созданы ECO для удаления Unmatched Reference Objects с платы и добавления Unmatched Target Objects в качестве новых объектов.
  • Если нажать Yes в диалоговом окне для ручного сопоставления, откроется диалоговое окно Match, показанное ниже (заголовок окна будет зависеть от типа несопоставленных объектов).

Диалоговое окно Match используется для ручного сопоставления объектов, о соответствии которых вам известно. Если вы не уверены, оставьте правую часть пустой и нажмите Continue.Диалоговое окно Match используется для ручного сопоставления объектов, о соответствии которых вам известно. Если вы не уверены, оставьте правую часть пустой и нажмите Continue.

  • В этом диалоговом окне выберите объекты, которые требуется сопоставить, в Unmatched Reference Objects и Unmatched Target Objects, а затем перенесите их в раздел Matched Pairs диалогового окна. Для этих объектов программа создаст ECO для обновления имен, чтобы они совпадали, а также ECO для удаления и добавления элементов, чтобы их состав тоже совпадал.
  • Если вы не уверены, выполнять ручное сопоставление объектов необязательно. Для всех несопоставленных объектов программа считает исходные и целевые объекты не связанными между собой, поэтому создаст ECO для удаления Unmatched Reference Objects с платы и добавления Unmatched Target Objects в качестве новых объектов.
  • После сопоставления объектов, в соответствии которых вы уверены, нажмите Continue, чтобы открыть диалоговое окно Engineering Change Order.
  • При нажатии Cancel процесс обновления завершается.

Сопоставление правил проектирования

Правила проектирования, заданные на схеме, также должны быть связаны с соответствующими правилами на PCB. Без механизма связывания вы не смогли бы обновлять правило на схеме и переносить эти изменения на PCB. Для связывания правила проектирования схемы с правилом проектирования PCB используются UID.

UID автоматически назначается в наборе параметров (Parameter Set), содержащем определение правила на схеме, и переносится на PCB при синхронизации проекта.

Для сопоставления определения правила проектирования на схеме с правилом проектирования на PCB используется UID.Для сопоставления определения правила проектирования на схеме с правилом проектирования на PCB используется UID.

Как правило, управлять сопоставлением правил вручную не требуется, если только вы не изменили UID вручную в диалоговом окне PCB Rules and Constraints редактора печатных плат. Если UID не совпадают, программа добавит на печатную плату новое правило для каждого правила схемы, которому не соответствует ни одно правило печатной платы, и удалит все правила проектирования печатной платы, которым не соответствует ни одно правило проектирования схемы.

Вы можете изменять компоненты в любом из редакторов и синхронизировать эти изменения с другим редактором. Изменения цепей, классов и правил можно передавать только из схемы на печатную плату. 

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents