Поиск компонентов в базах данных и библиотеках на основе файлов

Altium Training

Altium Essentials: Schematic Capture

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Краткий обзор

В этой статье объясняется, как Altium Designer предоставляет доступ к файловым библиотекам и библиотекам баз данных для размещения компонентов, а также как управлять этими библиотеками и выполнять поиск в них с помощью диалогового окна Libraries Preferences и панели Components. Рассматриваются различия между библиотеками проекта, установленными библиотеками и библиотеками в путях поиска: порядок, в котором Altium Designer выполняет поиск в них, ситуации, в которых каждый вариант наиболее полезен, а также возможные проблемы с производительностью и путями к файлам. Кроме того, в статье описывается, как библиотеки баз данных отображаются на панели Components, как работает кэширование библиотек баз данных SVN и какие инструменты доступны для простого и расширенного поиска компонентов. Если вы хотите лучше понять, где Altium Designer ищет компоненты и как повысить эффективность поиска, читайте дальше — эта статья поможет вам уверенно ориентироваться в доступных возможностях.

- Разберитесь в различиях между библиотеками проекта, установленными библиотеками и библиотеками в путях поиска, а также в том, как каждый тип влияет на доступность компонентов в Altium Designer.
- Узнайте, где управлять доступными библиотеками, в каком порядке выполняется поиск и почему некоторые настройки библиотек могут влиять на скорость и надежность работы.
- Ознакомьтесь с особенностями поиска компонентов в файловых библиотеках и библиотеках баз данных, в том числе при использовании источников DbLib и SVNDbLib.
Узнайте больше с ИИ:

Управление доступными библиотеками на основе баз данных и файлов

В Altium Designer компоненты библиотек на основе баз данных и файлов можно размещать только из библиотек, доступных в данный момент. К ним относятся:

  • Libraries in the current project — если библиотека входит в состав проекта, ее компоненты автоматически доступны для размещения в этом проекте.

  • Installed libraries — эти библиотеки установлены в Altium Designer; их компоненты доступны для использования в любом открытом проекте.

  • Libraries on a defined search path — также можно задать путь поиска к папке с несколькими библиотеками. Поскольку при каждом выборе нового компонента на панели выполняется поиск по всем файлам в указанном пути, этот подход рекомендуется только для небольших библиотек с простыми определениями моделей, например моделей для моделирования. Пути поиска не рекомендуется использовать для сложных моделей, например посадочных мест, содержащих 3D-модели.

Для управления доступными библиотеками на основе баз данных и файлов можно использовать диалоговое окно Libraries Preferences, которое открывается нажатием кнопки Components panel menu в верхней части панели Components и выбором пункта Libraries Preferences в меню.

В диалоговом окне Libraries Preferences есть три вкладки. Все библиотеки и расположения моделей, указанные на этих вкладках, объединяются в список доступных библиотек. При выполнении действия, требующего поиска модели, например переноса проекта из схемы в топологию печатной платы, поиск в библиотеках выполняется в порядке расположения вкладок, а затем на каждой вкладке — в порядке перечисления библиотек и моделей. Как только нужная модель найдена, поиск прекращается. 

Библиотеки проекта

Библиотеки, входящие в состав активного проекта, перечислены на вкладке Project диалогового окна Libraries Preferences, когда этот проект активен в программе. Преимущество библиотек проекта заключается в том, что модели и библиотеки автоматически становятся доступными при каждом открытии проекта. Недостаток состоит в том, что если модели и библиотеки хранятся вне структуры папок проекта с файлами разработки, о них легко забыть при переносе файлов проекта.

На вкладке Project  представлен список доступных библиотек текущего проекта.
На вкладке Project представлен список доступных библиотек текущего проекта.

Любая библиотека может быть библиотекой проекта; для этого ей не обязательно находиться в папке проекта. Чтобы включить библиотеки в проект, щелкните правой кнопкой мыши имя проекта на панели Projects и выберите команду Add Existing to Project.

Установленные библиотеки

Библиотеки и модели, доступные в вашей установленной копии программы, называются установленными библиотеками. Они перечислены на вкладке Installed диалогового окна Libraries Preferences.

Этот список относится к настройкам рабочей среды. Все добавленные в него библиотеки будут доступны во всех проектах, а сам список сохраняется между сеансами проектирования. Библиотеки проекта можно добавить в этот список, но изначально они в него не входят.

Для установленных библиотек можно указывать абсолютный путь или путь относительно значения настройки Library Path Relative To. Преимущество относительного пути заключается в возможности создать одинаковую структуру рабочей среды на нескольких компьютерах, что позволяет легко переносить между ними файлы проекта. Кроме того, установленные библиотеки можно временно отключить, сняв флажок Activated, вместо того чтобы удалять их.

На панели Components доступны только библиотеки Activated.

На вкладке Installed перечислены библиотеки, доступные в этой установленной копии Altium Designer.
На вкладке Installed перечислены библиотеки, доступные в этой установленной копии Altium Designer.

При подключении к рабочему пространству Altium 365 также отображается сводка о состоянии библиотеки рабочего пространства. Она позволяет сразу увидеть количество компонентов без проблем и количество компонентов, у которых есть хотя бы одна проблема. Нажмите элемент See Details, чтобы открыть страницу Components  веб-интерфейса рабочего пространства в браузере по умолчанию.

При подключении к рабочему пространству Altium 365 можно импортировать в него установленную библиотеку, выбранную в таблице диалогового окна, нажав Import в крайнем правом столбце. Откроется Library Importer в простом режиме с загруженной выбранной библиотекой.

Путь поиска

На вкладке Search Path представлен список библиотек, найденных в соответствии с настройками путей, заданными на вкладке Search Paths диалогового окна Project Options, которое открывается нажатием кнопки Paths. Каждый путь поиска задает папку и может включать вложенные папки, если включен параметр Recursive (доступен на вкладке Search Paths диалогового окна Project Options после добавления пути). Все файлы моделей и библиотек, найденные по указанному пути поиска, будут доступны. Пути поиска сохраняются вместе с проектом.

Нажмите кнопку Refresh , чтобы обновить список с учетом актуальных путей поиска (заданных на вкладке Search Paths диалогового окна Project Options ).

На вкладке Search Path перечислены библиотеки, найденные по заданным путям поиска.
На вкладке Search Path перечислены библиотеки, найденные по заданным путям поиска.

Вкладка Search Paths диалогового окна Project Options доступна, если включен параметр UI.ProjectOptions.SearchPaths в диалоговом окне Advanced Settings.

Поиск моделей по заданным путям может выполняться медленно, если в папках поиска находится большое количество файлов. Поэтому такой подход не рекомендуется использовать для библиотек посадочных мест печатных плат: они могут представлять собой большие файлы с множеством посадочных мест. Эта функция была разработана для обеспечения доступа к имеющимся моделям для моделирования и анализа целостности сигналов.

Хотя программа обеспечивает гибкость и контроль над расположением конкретных моделей и библиотек, для каждого типа модели необходимо использовать правильное расширение файла. Например, посадочное место будет найдено, только если оно находится в файле с расширением .Lib или .PcbLib. Аналогично, SPICE *.SUBCKT будет найден, только если он находится в файле  .ckt, а SPICE *.MODEL — только если он находится в файле .mdl. Если поиск модели не дает совпадений, на панели Messages появляется сообщение об ошибке. 

Локальное кэширование условных обозначений и моделей, используемых библиотеками баз данных SVN

При добавлении файла SVNDbLib в список доступных библиотек библиотеки условных обозначений и моделей из репозитория кэшируются во временной папке на компьютере проектировщика. Когда для выполнения действия в программе требуется условное обозначение или модель, они извлекаются из локального кэша.

Автоматическое обновление кэша

Библиотеки в кэше автоматически обновляются до последних версий из репозитория системы контроля версий при выполнении в программе любого из следующих действий:

  • Размещение компонента из установленного файла SVNDbLib (с панели Components).

  • Передача проекта (т. е. обновление печатной платы).

  • Использование команды Tools » Update From Libraries в редакторе схем.

  • Использование команды Tools » Update From PCB Libraries в редакторе печатных плат.

Хотя обновление выполняется автоматически, им можно управлять с помощью параметра Do not check files more often than xx minutes на странице Data Management - SVN Libraries диалогового окна Preferences . По сути, этот параметр задает таймер обновления локального кэша. Если с момента последнего обновления кэша прошло указанное время, при выполнении одного из перечисленных действий кэш обновится автоматически. Если действие выполняется до истечения этого времени, используется текущее содержимое кэша, которое может быть устаревшим по сравнению с содержимым репозитория.

Принудительное обновление кэша вручную

Иногда может потребоваться принудительно обновить локальный кэш, чтобы гарантировать использование самых актуальных библиотек, хранящихся в репозитории системы контроля версий. Например, при подготовке к переносу проекта со схемы на печатную плату.

Принудительно обновить кэш вручную можно одним из следующих способов:

  • С помощью одной из команд Refresh , доступных в контекстном меню панели Components.
  • Удалив файл SVNDbLib из списка Available Libraries и добавив его снова.
При каждом перезапуске Altium Designer локальный кэш автоматически обновляется до последних версий библиотек, хранящихся в репозитории SVN.

Поиск компонентов в библиотеках баз данных и файловых библиотеках

Для поиска компонентов в файловых библиотеках (как установленных, так и не установленных в данный момент) и библиотеках баз данных в Altium Designer предусмотрена функция поиска по библиотекам.

Искать компоненты в библиотеках баз данных и файловых библиотеках можно с помощью поля Search на панели Components. Введите строку и нажмите Enter, чтобы найти эту строку в текущей библиотеке среди всех видимых параметров компонентов.

Поиск можно выполнять непосредственно на панели Components.Поиск можно выполнять непосредственно на панели Components.

Диалоговое окно File-based Libraries Search позволяет выполнять более подробный поиск. Чтобы открыть его, нажмите кнопку Components panel menu на панели Components и выберите в меню File-based Libraries Search. Верхняя половина диалогового окна используется для определения what, а нижняя — для определения where.

Поиск в установленных библиотеках (Available libraries) или библиотеках на жестком диске (Libraries on path).Поиск в установленных библиотеках (Available libraries) или библиотеках на жестком диске (Libraries on path).Процесс поиска можно кратко описать следующим образом:

  • Поиск выполняется путем задания Filters, которые применяются ко всем библиотекам, доступным для поиска в соответствии с текущими настройками Scope.

  • Scope включает тип библиотек для поиска. Одновременно можно выполнять поиск только по одному типу библиотек.

  • Чтобы включить поиск компонентов базы данных, установите в поле Search in значение Database Components и выберите нужную Table. Обратите внимание: доступные Fields, перечисленные в раскрывающемся списке выше, изменятся в соответствии с заголовками столбцов выбранной таблицы. Остальные параметры диалогового окна станут неактивными, поскольку они не применяются при поиске в библиотеках баз данных.

  • Scope определяет, в каких библиотеках будет выполняться поиск: в библиотеках, к которым программа в данный момент имеет доступ (Available libraries), или во всех библиотеках в папке (Libraries on path).

  • При поиске библиотек по указанному пути поиск выполняется в определенной папке, а также может Include Subdirectories.

  • Можно также выполнять поиск в результатах поиска, установив для Scope значение Refine last search.

  • Нажмите Clear, чтобы очистить введенные параметры поиска.

Настройка фильтра поиска

Область Filters используется для задания текстовых строк, применяемых при поиске. Необходимо настроить три области:

  • Field — атрибут компонента, по которому будет выполняться поиск. Это может быть любой атрибут компонента или посадочного места, включая имя, описание, комментарий, посадочное место или любой параметр, добавленный к компоненту. Выберите доступное поле из раскрывающегося списка или введите его в текстовое поле.

  • Operator — определяет условие совпадения. Оно может выполняться, когда значение equals, contains, starts with или ends with. Обратите внимание: equals требуют точного совпадения строки, поэтому их следует использовать только тогда, когда вы уверены, что строка поиска указана правильно и полностью.

  • Value — символы для поиска в выбранном Field с проверкой совпадения согласно выбранному Operator. Выберите доступное значение из раскрывающегося списка или введите значение в текстовое поле.

По умолчанию предусмотрено три условия фильтрации; с помощью элемента управления Add Row можно добавить еще до семи строк, доведя их общее количество до 10. Последнюю добавленную строку условия фильтрации можно удалить с помощью Remove Row. Неиспользуемые строки можно удалить.

Настройка области поиска

Существует два основных подхода к поиску:

  • Доступные в данный момент библиотеки — это список библиотек, отображаемый в раскрывающемся списке в верхней части панели Components .

  • Библиотеки, хранящиеся в указанной папке, включая вложенные папки, если включен соответствующий параметр.

Поиск возвращает все элементы типа, выбранного в раскрывающемся списке Search in (Components/Footprints/3D Models/Database Components), найденные во всех библиотеках, входящих в заданную область Scope:

  • Available libraries — включите для поиска указанных типов моделей только в доступных библиотеках.
  • Libraries on path — включите для поиска указанных типов моделей в доступных библиотеках в заданных папках. В области Path диалогового окна, которая становится доступной при выборе области поиска Libraries on path, можно задать путь, включить вложенные папки и указать маску файлов библиотек, чтобы задать и сузить критерии поиска:
    • Path — укажите папку для поиска библиотек или нажмите значок обзора в конце поля, чтобы выбрать папку.
    • Include Subdirectories — включите, чтобы искать библиотеки по указанному пути и во вложенных папках.
    • File Mask — введите строку маски файлов или выберите одну из существующих масок в раскрывающемся списке. В результаты поиска попадут только файлы, соответствующие этой строке. В строке можно использовать подстановочный знак * (любой символ). Например, введите * для поиска всех файлов или M для поиска всех файлов, имена которых начинаются с буквы M.

Включите Refine last search, чтобы уточнить критерии поискового запроса для списка результатов предыдущего поиска. Например, если вы искали посадочные места печатной платы с именами на основе DIP и хотите найти только те из них, для которых задана высота менее 100 мил, включите этот параметр. Введите новое выражение запроса и нажмите Search. Подмножество результатов предыдущего запроса будет отображено как новый список результатов запроса на панели Components.

Например, если вы хотите найти компонент, который, по вашему предположению, находится в библиотеке в определенных папках на жестком диске, а сама библиотека в настоящее время отсутствует в списке Available File-based Libraries, настройте поиск следующим образом:

  1. В области Scope установите для Search in значение Components и выберите Libraries on path.
  2. В области Path задайте в Path путь к папке, содержащей документ библиотеки, в которой требуется выполнить поиск.
  3. Нажмите Search. Результаты отображаются на панели Components по мере выполнения поиска.

Размещать можно только компоненты из библиотек, установленных в Altium Designer. При попытке разместить компонент из библиотеки, которая в данный момент не установлена, потребуется подтвердить ее установку.

Расширенный режим поиска

Поиск в библиотеках фактически выполняется с помощью запросов. В диалоговом окне File-based Libraries Search переключитесь в режим Advanced, чтобы просмотреть запрос. 

В режиме Advanced этого диалогового окна также можно создавать собственные запросы, используя ключевые слова языка запросов для выполнения поиска. Подробнее о доступных ключевых словах языка запросов см. в разделе ниже.

При выборе режима Advanced используйте следующие дополнительные элементы управления:

  • Helper — нажмите, чтобы открыть диалоговое окно Помощник запросов для удобного создания запроса поиска по библиотекам с помощью предопределенных библиотечных и системных функций. Также можно использовать кнопки History и Favorites для выбора недавно примененного или предопределенного запроса к библиотеке.

  • History — нажмите, чтобы открыть диалоговое окно Диспетчер выражений и выбрать одно из ранее примененных выражений запроса для поиска в библиотеках. Также можно использовать кнопку Favorites для применения предопределенного запроса к заданному поиску в библиотеках.

  • Favorites — нажмите, чтобы открыть диалоговое окно Диспетчер выражений и выбрать одно из избранных выражений запроса для поиска в библиотеках. Также можно изменять список Favorites, удаляя, переименовывая или копируя выражения из списка History.

При поиске среди Database Components режим Advanced позволяет выполнять поиск с помощью SQL-запроса. Этот уровень поиска обеспечивает точный поиск на основе заданного выражения запроса: SQL-запрос можно ввести непосредственно в области редактора запросов диалогового окна.

Нажмите Advanced для доступа к мощным возможностям поиска на основе SQL-запросов. Нажмите Advanced еще раз, чтобы вернуться к простому поиску.

Функции запросов к компонентам и библиотекам

Функции запросов к компонентам и библиотекам в диалоговом окне Query Helper
Функции запросов к компонентам и библиотекам в диалоговом окне Query Helper

В основе редакторов схем и печатных плат Altium Designer лежит мощный механизм запросов. Вводя запросы, можно логически ограничить выборку именно теми объектами, которые вам нужны.

Запрос — это строка, которую вводят с использованием определенных ключевых слов и синтаксиса для получения нужных объектов. Доступно множество ключевых слов, позволяющих выбирать объекты по их типу, свойствам или обоим критериям.

Подробный обзор использования языка запросов см. в разделе Работа с языком запросов.

В разделах ниже подробно описаны ключевые слова языка запросов, доступные при поиске компонентов в базах данных и файловых библиотеках в Altium Designer. Чтобы получить справку по определенному ключевому слову запроса, воспользуйтесь следующими раскрывающимися разделами либо выделите нужное ключевое слово (или щелкните внутри него) в Query Helper.

Для доступа к функциям запросов к компонентам и библиотекам нажмите кнопку Helper в диалоговом окне Поиск в файловых библиотеках.

Компоненты

Все

Посадочные места

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents