Altium Designer Documentation

Project Release Options

Created: 09.05.2019 | Updated: 09.05.2019

  The Release Options tab and Item Naming tab of the Project Release Options dialog

Summary

The Project Release Options dialog is used to assign the applicable Outjobs and define how the target data items in a server (whose revisions receive the generated data) are named when releasing a project.

Access

The dialog is accessed in the following ways:

  • Click Options in the Release view of the Project Releaser (Project » Project Releaser).
  • From the Project Releaser, click on the Target Revision link for a data set to be released then choose Edit from the context menu.
This access option is available only when performing an online release (i.e. if you are currently connected to a server). 

Options/Controls

Release Options Tab

  • Release Target - use the drop-down to select a release target server.
    • Managed - <Server Name> - select to release to the specified server.
    • Unmanaged Folder - select to release locally in offline mode to a folder.
    • Unmanaged - Zip - select to release locally in offline mode to a zip file.
  • Output Jobs
    • Source Data - enable the desired project source data. 
    • Fabrication Data - enable the desired data that will be used for board manufacturing (e.g., Gerber, ODB++, drilling information, etc.). The exact content will be determined by the outjob.
    • Assembly Data - enable the desired data that represents assembly information (e.g., pick and place, assembly drawings, etc.). The exact content will be determined by the outjob. Each variant is released to an individual item.
  • Release Target
    • Include Design subfolder into the item content (for legacy compatibility, not recommended) - enable to include the design sub-folder. 
Enabling this option is not recommended. It should be used only for legacy compatibility. Use with caution! 

Item Naming Tab

  • Project Name - use to define the name for the project. By default, this will be filled with the actual name of the project. Enter a new name if desired.
  • Project Folder - use to define the top-level target folder in the server into which the data will be released. Click  to open a dialog in which you can search for and select a different folder. 
  • Item Type/ID - displays the default naming schemes for the various data items that can be generated as part of the release.

Additional Controls

For a detailed, high-level overview of the process, see  Working with the Project Releaser.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: