熟悉Altium设计环境

Altium Designer 提供了一个完整的电子产品开发环境,涵盖了电子开发过程的所有方面,包括前端设计和捕获、混合信号电路仿真、物理 PCB 设计等。

本页面讨论了使用 Altium Designer 的基本工作技巧,以便您可以快速开始下一个产品设计。

主要 UI 元素

Altium Designer 使用与其他 Windows 应用程序和 CAD 工具相同的 UI 元素。下面显示并随后描述了这些主要元素。

设计空间
面板
主菜单
活动栏
快速访问栏
Javascript

设计空间 – 应用程序窗口的主要区域,显示活动文档。在设计空间中,您可以探索文档的内容(例如,如上图所示的原理图文档)并对其进行操作。

面板 – 提供对与活动项目或文档相关的不同功能和功能的访问。可以从设计空间右下角面板按钮的菜单中访问面板。

主菜单 – 提供访问与当前文档类型相关的命令。可用的菜单和命令集取决于当前活动文档的类型。

活动栏 – 始终显示在当前文档设计空间的顶部,活动栏提供了方便地访问最常用的命令,例如放置和选择对象的命令。

快速访问栏 – 提供访问高级操作的功能,例如保存文档和撤销/重做操作。

了解更多关于 Altium Designer 环境的这些和其他元素:环境的元素

登录您的Altium账户

为了访问Altium的按需服务,例如按需许可和连接到Altium 365工作区,您必须从Altium Designer中登录到您的Altium账户。当您未登录到您的Altium账户时,设计空间右上角的当前用户控件显示为。要登录,请点击控件并在关联菜单上选择登录项。使用随后出现的登录对话框输入您的Altium账户凭据,然后点击登录按钮。控件将更改为您的Altium个人资料图片(例如,)。

了解更多关于登录选项: 登录您的Altium账户

连接到您的Altium 365工作区

登录到您的Altium账户后,您可以连接到可用的Altium 365工作区以访问其功能和数据。要这样做,请点击设计空间右上角的活动工作区控件(当您未连接到工作区时,控件显示为)。在随后的菜单中,点击您希望连接到的Altium 365工作区的条目。控件将更改为反映已连接工作区的名称(例如,)。

了解更多关于连接选项: 访问您的工作区

设置环境

首选项对话框是一个中心位置,您可以在其中设置跨Altium Designer不同功能区域的全局系统设置。要访问首选项对话框,请点击设计空间右上角的图标。

在对话框左侧点击一个页面条目以在对话框右侧显示其选项。为了方便,页面被归类到功能区域的类别中(系统数据管理原理图等)。

了解更多关于Altium Designer首选项: 访问、定义和管理系统首选项

处理设计项目和文档

在Altium Designer中创建的每个设计的起点都是一个项目。Altium Designer项目是一组设计文档,其输出定义了特定的实现。除了存储项目中每个文档的链接,项目文件还存储特定于项目的选项,例如错误检查设置。

Altium Designer支持PCB、多板和线束类型的设计项目。以下是每种类型的简要描述。

大多数项目管理操作(创建、打开等)都是使用文件主菜单和项目面板执行的。

 
 
 
 
 
Javascript

要创建一个新的设计项目,请从主菜单中选择文件 » 新建 » 项目命令。在打开的创建项目对话框中,选择您想要创建项目的位置、项目类型以及其他选项,如项目名称、存储文件夹等。点击创建按钮后,新项目的条目将出现在项目面板中。

所有与项目相关的数据都存储在文档中,这些文档也被称为文件。要向项目中添加新文档,右键点击项目面板中的项目条目,然后在添加新项目到项目菜单中选择所需的文档类型。

请注意,新创建的文档最初是未保存的。使用文档条目在项目面板中的右键菜单来保存它。同样,当项目发生变化时(例如,通过添加新文档改变其结构时),使用项目条目在项目面板中的右键菜单来保存项目。

要打开现有项目,请使用主菜单中的文件 » 打开项目命令和随后的打开项目对话框。打开的项目的结构将出现在项目面板中。

双击面板中的文档条目,以在设计空间中打开该文档。

 

 

 

项目面板中,项目和文档条目旁边的图标提供了它们的打开/修改状态和版本控制状态的视觉总结。

当你处理一个“图形”类型的文档(例如,原理图或PCB文档)时,你可以缩放和平移文档以聚焦于特定的文档区域。可以使用的基本快捷方式有:

  • Ctrl+鼠标滚轮中键点击,按住&拖动 来放大和缩小
  • 右键点击,按住&拖动鼠标滚轮Shift+鼠标滚轮 来滑动文档

下面的视频演示了这些快捷方式的使用。

要了解更多关于项目和文档的操作,请参考以下页面:

处理设计对象

无论是原理图、PCB还是图纸,创建文档本质上是放置对象并设置其属性。下面列出了大多数Altium Designer编辑器通用的主要放置和编辑技术。

  1. 要放置一个对象,请从主菜单或活动栏中选择相应的放置命令。例如,要在原理图中放置一条线,请从主菜单中选择放置 » 线命令,或点击活动栏中的图标。
  2. 选择放置命令后,你将进入放置模式,光标下方会出现十字线。将光标定位在设计空间中,然后左键点击以放置对象。对于复杂的对象,如线或多边形,你必须继续定位和点击程序以放置对象的所有顶点。
  3. 在放置模式中,按Tab键打开属性面板以编辑对象的属性,然后再放置对象。设置完属性后,点击设计空间中的 按钮返回到放置模式。
  4. 要结束放置模式,请右键点击。
  5. 要编辑已放置对象的属性,请在设计空间中点击它以选中。它的属性将显示在属性面板中。如果面板没有打开,双击对象即可选中并打开面板。

下面的视频演示了对象放置过程和编辑其属性。

获取帮助

Altium Designer 提供了多种方式帮助您查找更多信息和帮助。

  • 在任何对象、编辑器、面板、菜单条目或按钮上按F1键,可以打开该项的文档。
  • 在执行命令时按Shift+F1键,可以查看在该命令中可以使用的快捷键列表。
  • 使用文档左侧的导航树阅读有关特定主题的信息( 显示图片)。

可用的功能取决于您的 Altium Designer 软件订阅级别

Content