使用表格

概览

本文介绍如何在 Altium Designer 中放置和配置 Draftsman 表格,重点讲解物料清单(BOM)表格,以及其数据如何直接来源于 PCB 工程、ActiveBOM、变体和装配视图。文章将逐步介绍“属性”面板中的主要设置,包括格式设置、数据源选择、视图模式、基于变体的筛选、列管理,以及面向较大设计的跨页 BOM 处理。如果您希望更清楚地了解如何在 Draftsman 文档中准确、整洁地呈现制造和装配数据,本文将为您介绍可用的选项及其有效用法。继续阅读,进一步掌控您的 PCB 文档。

- 您将了解 BOM 表格的数据来源,以及“工程”“电路板”、变体和装配视图等选项如何影响显示的内容。
- 您将了解如何自定义 BOM 表格的外观和结构,包括标题、字体、行颜色、列、排序和别名。
- 您将了解拆分 BOM 表格的工作方式,从而将大型物料清单分布在多个表格对象和页面中呈现。
使用 AI 深入了解:

Draftsman 文档允许在图纸上放置各种数据表,并根据需要进行配置。表格数据直接来源于项目的 PCB 文档,可通过简单直观的方式传达 PCB 制造和装配过程所需的关键信息。

可从 Place 主菜单中选择要放置的表格类型。

物料清单

Draftsman 物料清单(Place » Bill Of Materials)是一种自动生成的表格对象,用于列出 PCB 设计中的实体装配项。BOM 表格数据直接来源于项目的 ActiveBOM 文档;如果当前项目中没有 ActiveBOM 文档,则直接来源于项目源文档。BOM 表格还可以列出指定 设计变体 或已放置的 板装配视图中的组成项。

拆分为两个 BOM 对象的物料清单表格。在上面的示例中,BOM 内容经过筛选,仅包含顶面板装配视图中的项目。
拆分为两个 BOM 对象的物料清单表格。在上面的示例中,BOM 内容经过筛选,仅包含顶面板装配视图中的项目。

在设计空间中选中已放置的物料清单表格后,可在 Properties 面板中配置其视觉样式和包含的数据内容。表格的常规属性在该面板的 General 选项卡()中配置。

标题

标题

随表格一起显示(如果已启用)的标题名称字符串。使用对应的 按钮可切换标题在图纸中的可见性。

此字段可包含静态文本,以及以特殊字符串形式表示的任何所需参数。使用 =<ParameterName> 语法可在标题中包含参数。所包含参数的值将显示在图纸的标题中。有关可用系统参数和 PCB 参数的列表,请参阅 设置 Draftsman 文档页面。

Location 使用下拉列表可从多种标题相对位置中进行选择。如果手动移动标题(将其拖放到新位置),则会自动选择 Manual 选项。
Font

设置标题使用的字体。

  • 启用 Use Document Font 选项时,标题将使用 文档选项中定义的字体(在设计空间中未选中任何对象时,位于 Properties 面板的 General 选项卡的 General 区域中的 Document Font 条目)。

  • 禁用 Use Document Font 选项时,可使用提供的选项选择所需的字体类型、大小、颜色和文本属性。

属性

Table Line Style

使用下拉列表选择用于绘制表格的线条。可用选项在设计空间中未选中任何对象时的 Properties 面板的 Line Styles 区域中定义。有关更多信息,请参阅设置 Draftsman 文档页面。使用对应的颜色按钮指定线条颜色。

Justification 选择表格尺寸更新时用于调整其位置的参考点。
Even Row Color 选择表格中偶数行的对比色。
Non-Even Row Color 选择表格中奇数行的对比色。
Font

设置表格数据内容使用的字体。

  • 启用 Use Document Font 选项时,将使用 文档选项中定义的字体(在设计空间中未选中任何对象时,位于 Properties 面板的 General 选项卡的 General 区域中的 Document Font 条目)。

  • 禁用 Use Document Font 选项时,可使用提供的选项选择所需的字体类型、大小、颜色和文本属性。

表格将自动缩放,以适应所选的字体大小。

Data Source 此选项以及项目中是否存在 ActiveBOM 文档共同决定表格中包含的数据:

 

  • Project – 选中此选项且当前项目中包含 ActiveBOM 文档时,该文档的配置和内容将成为 Draftsman BOM 表格的数据源。使用 Draftsman 的 Tools » Import Changes From <PCBDocumentName>.PcbDoc 命令可获取 ActiveBOM 文档中的实时更改。
    如果当前项目中不包含 ActiveBOM 文档,则 Draftsman BOM 表格中的数据直接取自项目源文档。

  • Board – 选中此选项时,Draftsman BOM 表格中的条目将仅限于项目实际 PCB 上存在的元件。

Assembly View 使用下拉菜单选项可筛选列出的 BOM 条目,仅包含指定板装配视图中显示的项目。
View Mode
  • Base – 每种唯一的元件类型占用一行,并在 Designator 列中列出所有包含的项目。

  • Flat – 每个元件项目占用一行。

  • Consolidated – 如果源项目包含变体,表格将包含所有设计变体中的元件条目。选择此选项会自动将 Variant 选项设置为 [No Variations]。

Variant

使用下拉菜单选择一个 设计变体(如果有)作为 BOM 表格的数据源。表格将根据 Show Components 选项,反映未装配或参数有变化的条目。

当选择 Document : <VariantName> 选项作为 Variation 时,将对表格应用为文档指定的变体。在设计空间中未选中任何对象时,可使用 Properties 面板的 General 选项卡的 Source 区域中的 Variants 下拉列表选择文档级变体。有关更多信息,请参阅 设置 Draftsman 文档页面。

Show Components

选择变体后,使用下拉列表选择要在列表中包含哪些元件条目:

  • Fitted – 仅显示当前所选设计变体中装配的元件。

  • All – 显示所有元件。

  • Not Fitted – 仅显示当前所选设计变体中未装配的元件。

  • Replaced – 仅显示当前所选设计变体中已选择替代器件的元件,或参数值有变化的已装配元件。

当 BOM 表格的 Show Components 选择了 Fitted、 Not Fitted 或 Replaced 选项时,其 View Mode 可配合使用 Base 和 Flat 选项(而非 Consolidated)。

页面i

BOM Table ID BOM 表格实例的数字标识符。完整表格可以拆分为多个 BOM 表格对象(页面),这些对象共用同一个 ID。
Limit Page Height 选中后,BOM 表将划分为一系列虚拟页面,每页的高度由 Max Page Height 属性指定。
Max Page Height 设置表格每页的高度,从而确定每页包含的行数。放置的 BOM 表对象仅包含一页(请参见下文的 Page),需要放置更多 BOM 表对象来涵盖所有页面。
Page 指示所选 BOM 表对象中显示的表格页码(1 from 2、3 from 5 等)。使用关联的下拉菜单,为当前选中的 BOM 表对象指定所需页面。
Show Empty Lines 选中后,将显示 BOM 表中的空白行。这些空白行通常位于 BOM 表的最后一页,因为指定的页面高度超出了现有 BOM 数据行所需的高度。

使用 Properties 面板的 Columns 选项卡管理 BOM 表的数据列。

在 Properties 面板的 Columns 选项卡中调整已放置 BOM 表的列。
在 Properties 面板的 Columns 选项卡中调整已放置 BOM 表的列。

  • 可以编辑这些条目,以指定 BOM 表包含的(可见)列及其文本对齐方式(Align)。

  • 使用 Width 条目定义列宽与其所含文本之间的关系。输入 Auto,使列宽动态调整,以适应该列中最宽的单元格文本。

  • 在 Order 列中单击,可在表格列数据的排序选项(不排序、升序和降序)之间循环切换。可以按优先级对多列进行排序,表格中位置靠左的已排序列具有更高的优先级。

  • 通过为表格列参数名称输入 Alias,可以更改 BOM 表的列标题;此设置适用于表格内容不由 ActiveBOM 文档确定的情况(请参见上文的 Data Source)。

  • 使用列类型筛选复选框,使可用列列表显示匹配的参数数据类型:BOM()、原理图()、服务器()、PCB()。取消选择所有类型,则仅列出 BOM 表中可见的列。

  • 使用 和 按钮将所选条目上移或下移一位,从而在 BOM 表的列顺序中将其左移或右移。仅适用于设置为可见的列。

  • 单击 按钮,将表格列恢复为默认条目(由 Preferences 对话框的 Draftsman – 默认设置页面 上的 BOM 表对象默认设置定义)。

拆分 BOM 表

大多数高级 PCB 项目的物料清单通常包含大量条目,很难以适合图纸文档大小的表格形式呈现。借助 BOM 拆分功能,可以将 BOM 表分成多个“页面”显示,而不必缩放字体和表格、创建多个自定义表格条目或使用外部文档。

要创建多页 BOM 表,请选中已放置的 BOM 表(其高度很可能超出图纸高度),然后选中 Properties 面板的 Pages 区域中的 Limit Page Height 复选框。这会将表格高度限制为指定的高度值(Max Page Height, mm),从而限制 BOM 表中显示的行数。

Javascript ID: Draftsman_BOM_LimitPageHeight

Draftsman 会检测到 BOM 未完整显示,并通过面板中的 Page 条目(例如 Page 1 from 2)予以指示;关联的下拉菜单可用于指定要显示的页面。要添加 BOM 的后续页面(此处为 BOM Table ID = 0),请再放置一个 BOM 表,并在 Properties 面板的 Pages 区域中指定下一个 Page。

由于 BOM 的每一页都是通过添加另一个 BOM 表并进行相应配置来放置的,因此各个 BOM 页面(分段)可以放置在 Draftsman 文档的任意图纸上。要放置另一组拆分的 BOM 页面,请为已放置的 BOM 指定不同的 BOM Table ID,例如使用 1 而非 0,以创建 different 页面组。

请注意,Max Page Height 属性指定 BOM 表中 first 页的高度。选中第二页(第 2 页)时,Max Page Height 属性定义的是第一个被排除页面(第 1 页)的高度。因此,第 2 页显示剩余的 BOM 条目。开始时,请将每一页的 Max Page Height 属性设置为相同值。

钻孔表

Draftsman 钻孔表(Place » Drill Table)是自动生成的表格对象,包含电路板钻孔符号和数据。钻孔表与 Draftsman 的 钻孔图视图相结合,可为电路板制造过程提供表格和图形信息。表示特定钻孔类型的符号行可以包含多种孔信息,例如孔径、是否金属化以及孔数量。各类孔按照 Drill Symbol Configurations 对话框中的设置归组到相应符号下。

已放置的钻孔表,其中的孔条目按孔径分组
已放置的钻孔表,其中的孔条目按孔径分组

如果您的 Altium Designer 安装中已安装 GOST 2.701-2008/2.106-1996 软件扩展,则钻孔表的 Plated 列中的值将显示为 Есть(金属化孔)和 Нет(非金属化孔)。

有关管理扩展的更多信息,请参阅 Extending Your Installation 页面(Altium Designer Develop、Altium Designer Agile、Altium Designer)。

在设计空间中选中已放置的钻孔表后,可以在 Properties 面板中配置其视觉样式和数据内容,包括所使用的符号。表格的常规属性在该面板的 General 选项卡()中配置。

标题

Title

与表格一同显示的标题名称字符串(如果已启用)。使用关联的 按钮切换标题在图纸中的可见性。

该字段可以包含静态文本,以及以特殊字符串形式表示的任何所需参数。使用 =<ParameterName> 语法在标题中包含参数。所包含参数的值将显示在图纸的标题中。有关可用系统参数和 PCB 参数的列表,请参阅 设置 Draftsman 文档页面。

Location 打开下拉菜单,从多个相对位置中选择标题的位置。如果手动移动标题(将其拖放到新位置),则会自动选中 Manual 选项。
Font

设置标题使用的字体。

  • 启用 Use Document Font 选项后,标题使用的字体由 文档选项定义(General 中的 Document Font 条目区域中,位于 General 选项卡内,该选项卡属于 Properties 面板(在设计空间中未选中任何对象时)。

  • 禁用 Use Document Font 选项时,使用提供的选项选择所需的字体、字号、颜色和文本属性。

属性

Layer Pairs 选择要在图纸视图中显示哪些 PCB 钻孔层对的孔。使用下拉菜单从源电路板设计中可用的层对中进行选择。这些层对可在 PCB 编辑器中查看和编辑,并可通过 层叠管理器 访问。所有电路板设计都包含一个 Top - Bottom 层对,其他层对则表示贯穿其他层或连接到其他层(例如内层/平面层)的过孔。

仅当 PCB 文档包含在 PCB 相应侧启用了沉孔特征的焊盘时,Counterhole Bottom 和 Counterhole Top 选项才可用(了解更多)。

请注意,除 Counterhole Bottom 和 Counterhole Top 以外的层对均不包含沉孔。 All Layers 层对也不包含沉孔。

Pads / Vias 使用下拉菜单选择要在表格中显示的钻孔类型(Pads、Vias 或 All)。
Plated / Non-Plated 使用下拉菜单选择要在表格中显示的孔镀覆类型(Plated、Non-Plated 或 All)。
Border Line Style

使用下拉菜单选择用于绘制表格边框/轮廓的线型。可用选项在设计空间中未选中任何对象时的 Properties 面板的 Line Styles 区域中定义。有关更多信息,请参阅设置 Draftsman 文档页面。使用关联的颜色按钮指定线条颜色。

Justification 选择表格尺寸更新时用于调整其位置的参考点。
Even Row Color 选择表格偶数行的对比色。
Non-Even Row Color 选择表格奇数行的对比色。
Font

设置表格数据内容使用的字体。

  • 启用 Use Document Font 选项时,将使用文档选项中定义的字体(在设计空间中未选中任何对象时,位于 Properties 面板的 General 选项卡的 General 区域中的 Document Font 条目)。

  • 禁用 Use Document Font 选项时,使用提供的选项选择所需的字体、字号、颜色和文本属性。

表格将自动缩放以适应所选字号。

Show Footer 勾选以启用表格页脚,显示钻孔总数。
选择以打开 Drill Symbol Configurations 对话框,该对话框以表格形式显示所有钻孔数据,并允许设置每个孔符号的样式和大小(了解更多)。

单位

Primary Units

选择表格中显示的主测量单位类型。使用关联的  按钮切换测量单位的显示状态。

当选择 Document : <Units> 选项作为 Primary Units 时,文档指定的主单位将应用于表格。文档级主单位可在设计空间中未选中任何对象时,通过 Properties 面板的 General 选项卡的 Units 区域中的 Primary Units 下拉菜单进行选择。有关更多信息,请参阅 设置 Draftsman 文档页面。

Dual Units

选择表格中显示的辅助(双重)测量单位类型。使用关联的  按钮切换辅助单位数值的显示状态。

当选择 Document : <Units> 选项作为 Dual Units 时,文档指定的双重单位将应用于表格。文档级双重单位可在设计空间中未选中任何对象时,通过 Properties 面板的 General 选项卡的 Units 区域中的 Dual Units 下拉菜单进行选择。有关更多信息,请参阅 设置 Draftsman 文档页面。

精度

Primary Units

使用 Value Precision 下拉菜单设置主孔径表格条目的精度(小数点后最多五位,最后一位四舍五入)。

选择 Document : <Precision> 选项时,文档指定的主单位数值/公差精度将应用于表格。文档级主单位数值和公差精度可在设计空间中未选中任何对象时,通过 Properties 面板的 General 选项卡的 Units 区域中针对 Primary Units 的 Value Precision 和 Tolerance Precision 选项进行选择。有关更多信息,请参阅 设置 Draftsman 文档页面。

Dual Units

使用 Value Precision 下拉菜单设置双重(辅助)孔径条目的精度(小数点后最多五位,最后一位四舍五入),前提是已启用这些条目。

选择 Document : <Precision> 选项时,文档指定的双重单位数值/公差精度将应用于尺寸标注。文档级双重单位数值和公差精度可在设计空间中未选中任何对象时,通过 Properties 面板的 General 选项卡的 Units 区域中针对 Dual Units 的 Value Precision 和 Tolerance Precision 选项进行选择。有关更多信息,请参阅 设置 Draftsman 文档页面。

使用 Properties 面板的 Columns 选项卡管理钻孔表的数据列()。

  • 可以编辑这些条目,以指定钻孔表中包含(显示)的列及其 Horizontal 和 Vertical 对齐方式。

  • 使用 Width 条目定义列宽与列内文本的关系。输入 Auto 可使列宽动态调整,以适应该列中最宽的单元格文本。

  • 单击 Order 列中的单元格,可在表格列数据排序选项(关闭、升序和降序)之间循环切换。可以按优先级对多列应用排序,其中表格中靠左的已排序列具有更高优先级。

  • 可以通过为表格列参数名称输入 Caption 来更改钻孔表的表头。

  • 使用  和  按钮可将所选条目上移或下移一位 ,从而在钻孔表的列顺序中向左或向右移动。仅适用于设置为可见的列。

钻孔表的符号样式以及各符号下钻孔类型的分组方式由 Drill Symbol Configurations 对话框中的设置决定。在设计空间中选中表格后,单击 Properties 面板(位于 General 选项卡的 Properties 区域)中的 按钮即可打开该对话框。

此对话框与从钻孔图视图的 Properties 面板中打开的对话框相同,但在此情况下,仅显示钻孔表中已启用(设为可见)的列。请注意,这两个版本的 Drill Symbol Configuration 对话框使用相同的数据源,因此会相互影响。

Symbol Graphics 使用下拉列表,从一系列预定义的形状和字母中选择所需的孔表示图形。
Sync Symbols with PCB 启用后,钻孔表中的符号将与 PCB 中的符号同步。
Symbol Size Table

输入表格中符号所需的尺寸。

  • 请注意,符号尺寸的更改将应用于对话框顶部网格中当前选中的钻孔符号。要在网格中选择多个钻孔符号,请使用 Ctrl+Click 或 Shift+Click 方式。

  • 另请注意,如果链接图标显示为已链接状态(),则钻孔图视图与钻孔表中的符号尺寸将保持关联。要单独设置钻孔符号尺寸,请单击链接图标以取消两者的尺寸关联,然后根据需要分别设置尺寸。

Symbol Size View 输入视图中符号所需的尺寸。要访问和编辑此字段,链接图标必须显示为未链接状态()。单击链接图标可切换链接状态。
Symbol Line Style

使用下拉列表选择用于绘制符号图形边框/轮廓的线条。可用选项在设计空间中未选中任何对象时的 Properties 面板的 Line Styles 区域中定义。有关更多信息,请参阅设置 Draftsman 文档 页面。 使用关联的颜色按钮指定线条颜色。

Grouping 所选条件将决定哪些孔归为一组并使用同一符号。例如,如果仅选择 HoleSize ,则 PCB 中使用的每种孔径都会分配一个单独的符号。随着选择更多分组选项,符号分配将根据新增条件进一步细分,形成更精细的分组方案。

您可以使用 Preferences 对话框的 Draftsman – 默认设置页面,为 Symbol Size Table、Symbol Size View、Symbol Line Style 和 Grouping 定义默认设置。在此页面上,在 Primitive List 中选择 Drill Table,然后打开右侧属性区域中的 Drill Symbol 选项卡()。

传输线表

阻抗控制布线中的计算会生成旨在满足目标传输线阻抗的走线结构,从而满足电路板设计的高速和/或电磁场要求。电路板层及其指定或计算得到的属性可通过层叠管理器访问,其中的阻抗控制布线层与可定义的阻抗配置相关联。每个配置中的板材和尺寸均用于传输线阻抗计算,从而得出相应的走线结构。该结构支持单根走线和差分对,以及带状线(内层)或微带线(表层)形式。

有关配置阻抗配置的更多信息,请参阅 定义层叠页面。

由于电路板层叠中每个传输线定义的结构及相关数据都是 PCB 制造过程的重要信息,因此 Draftsman 提供了专用的传输线表对象(Place » Transmission Line Table)来记录这些信息。 表格中的数据来自层叠管理器及其传输线阻抗计算结果。

已放置的传输线表
已放置的传输线表

在设计空间中选中已放置的传输线表后,可在 Properties 面板中配置其视觉样式和数据内容。表格的常规属性在该面板的 General 选项卡中配置()。

标题

Title

随表格显示的标题名称字符串(如果已启用)。使用关联的 按钮可切换标题在图纸中的可见性。

此字段可包含静态文本,以及以特殊字符串形式表示的任何所需参数。使用 =<ParameterName> 语法可在标题中包含参数。所包含参数的值将显示在图纸的标题中。 有关可用系统参数和 PCB 参数的列表,请参阅 设置 Draftsman 文档页面。

Location 使用下拉列表,从一系列相对位置中选择标题位置。如果手动移动标题(将其拖放到新位置),则会自动选择 Manual 选项。
Font

设置标题使用的字体。

  • 启用 Use Document Font 选项时,标题使用文档选项中定义的字体(在设计空间中未选中任何对象时,位于 Properties 面板的 General 选项卡的 General 区域中的 Document Font 条目)。

  • 禁用 Use Document Font 选项时,使用提供的选项选择所需的字体类型、大小、颜色和文本属性。

属性

Table Line Style

使用下拉列表选择用于绘制表格线的线条。可用选项在设计空间中未选中任何对象时的 Properties 面板的 Line Styles 区域中定义。有关更多信息,请参阅设置 Draftsman 文档 页面。 使用关联的颜色按钮指定线条颜色。

Justification 选择表格尺寸更新时用于调整表格位置的参考点。
Even Row Color 选择表格偶数行的对比色。
Non-Even Row Color 选择表格奇数行的对比色。
Caption Font

设置表格数据内容使用的字体。

  • 启用 Use Document Font 选项时,使用文档选项中定义的字体(在设计空间中未选中任何对象时,位于 Properties 面板的 General 选项卡的 General 区域中的 Document Font 条目)。

  • 当 Use Document Font选项禁用时, 使用提供的选项选择所需的字体、字号、颜色和文本属性。

表格将自动缩放,以适应所选字号。

Rows Font

设置表格正文(表格行中的文本)使用的字体。

  • 启用 Use Document Font 选项时, 使用的字体由文档选项定义(在设计空间中未选中任何对象时,位于 Properties 面板的 General 选项卡中 General 区域内的 Document Font 条目)。

  • 禁用 Use Document Font 选项时, 使用提供的选项选择所需的字体、字号、颜色和文本属性。

表格将自动缩放,以适应所选字号。

单位

Primary Units

选择将在表格中显示的主测量单位类型。使用对应的  按钮切换测量单位的可见性。

选中 Document : <Units> 选项时,文档指定的主单位将应用于表格。在设计空间中未选中任何对象时,可使用 Properties 面板的 General 选项卡中 Units 区域内的 Units 下拉列表选择文档级主单位。 有关更多信息,请参阅 设置 Draftsman 文档页面。

Primary Precision

选择主单位数值的精度(小数点后最多五位,最后一位四舍五入)。

选中 Document : <Precision> 选项时,文档指定的主单位数值/公差精度将应用于表格。在设计空间中未选中任何对象时,可使用 Properties 面板的 General 选项卡中 Units 区域内 Primary Units 的 Value Precision 和 Tolerance Precision 选项选择文档级主单位数值和公差精度。 有关更多信息,请参阅 设置 Draftsman 文档页面。

Dual Units

选择将在表格中显示的辅助(双重)测量单位类型。使用对应的  按钮切换辅助单位数值的可见性。

选中 Document : <Units> 选项时,文档指定的双重单位将应用于表格。在设计空间中未选中任何对象时,可使用 Properties 面板的 General 选项卡中 Units 区域内的 Dual_Units 下拉列表选择文档级双重单位。 有关更多信息,请参阅 设置 Draftsman 文档页面。

Dual Precision

如果启用了辅助单位,请选择其数值的精度(小数点后最多五位,最后一位四舍五入)。

选中 Document : <Precision> 选项时,文档指定的双重单位数值/公差精度将应用于尺寸标注。在设计空间中未选中任何对象时,可使用 Properties 面板的 General 选项卡中 Units 区域内 Dual Units 的 Value Precision 和 Tolerance Precision 选项选择文档级双重单位数值和公差精度。 有关更多信息,请参阅 设置 Draftsman 文档页面。

使用 Properties 面板的 Columns 选项卡管理传输线的数据列和行 ()。

  • Columns 区域列出了表格中包含的列。 对于每个列条目,您可以切换其可见性、重命名列标题(Caption)、依次切换文本对齐选项(Align),或设置具体列宽或自动列宽(Width)。 使用对应的  和  按钮移动选定列条目的位置,即可调整列表条目的顺序,从而更改已放置表格中的列顺序。

  • Rows 区域提供表格中的行数据列表,按 Impedance Id 列排序,该列对应于源层叠中已命名的板层。使用各行条目对应的可见性控件,可切换该行在表格中的可见性。

表格

Draftsman 文档允许在图纸上放置通用表格,随后可在 Properties 面板以及表格单元格中对其进行配置。自定义表格的布局和内容可根据其用途自由定义,从而为在任何 Draftsman 文档中添加补充信息提供灵活的方式。

已放置的表格,采用了多种单元格格式
已放置的表格,采用了多种单元格格式

  • 结合使用表格属性中的可用选项和表格命令,可以创建自定义表格,以满足 Draftsman 文档中各种信息展示需求。例如,下图所示的表格用于显示从板层叠报告中获取的信息。

    可以创建自定义表格来呈现各种 PCB 装配和制造信息。
    可以创建自定义表格来呈现各种 PCB 装配和制造信息。

  • 表格既可以包含在图纸模板中,也可以包含在文档模板中。

启动表格放置命令 (Place » Table)将打开 Insert table 对话框,可在其中指定新表格的行数和列数。在 Insert table 对话框中单击 OK 后,新表格将附着在光标上,再次单击即可将其放置在所需位置。

指定表格的行数和列数,之后可通过单元格右键菜单中的 Table 命令进行修改。
指定表格的行数和列数,之后可通过单元格右键菜单中的 Table 命令进行修改。

要以图形方式更改已放置表格的位置,可在设计空间中选中表格对象,然后使用其移动手柄(即左上角的  图标)将其拖动到新位置。

拖动选定表格的移动图标,可在设计空间中重新定位表格。
拖动选定表格的移动图标,可在设计空间中重新定位表格。

单击单元格或表格标题即可选中表格对象。但是,Delete 命令将应用于所单击的具体元素。 

通过直接在单元格中键入(或粘贴)文本来添加表格内容。使用 Ctrl+Enter 可在单元格内换行。

在设计空间中选中表格时,可在 Properties 面板中定义表格的图形和文本属性()。表格对象提供丰富的文本和结构编辑功能,可使用标准的 Shift+Click 或 Click, Hold&Drag 按单元格、行或列进行编辑 技术。

标题

Title

随表格显示(如果启用)的标题名称字符串。使用关联的 按钮可切换标题在图纸中的可见性。

此字段可包含静态文本,以及以特殊字符串形式表示的任何所需参数。使用 =<ParameterName> 语法可在标题中包含参数。所包含参数的值将显示在图纸的标题中。 有关可用系统参数和 PCB 参数的列表,请参阅 设置 Draftsman 文档页面。

Location 展开下拉列表,可从一系列标题相对位置中进行选择。如果手动移动标题(将其拖放到新位置),则会自动选中 Manual 选项。
Font

设置标题使用的字体。

  • 启用 Use Document Font 选项时,标题将使用 文档选项中定义的字体(即在设计空间中未选中任何对象时, Properties 面板的 General 选项卡中 General 区域内的 Document Font 条目)。

  • 禁用 Use Document Font 选项时, 可使用提供的选项选择所需的字体类型、大小、颜色和文本属性。

属性

外边框线

使用下拉列表选择用于绘制表格边框/轮廓的线条。可用选项在设计空间中未选中任何对象时的 Properties 面板的 Line Styles 区域中定义。有关更多信息,请参阅设置 Draftsman 文档 页面。 使用关联的颜色按钮指定线条颜色。

Inner Line 使用下拉列表选择用于绘制表格内部单元格分隔线的线条。可用选项在设计空间中未选中任何对象时的 Properties 面板的 Line Styles 区域中定义。有关更多信息,请参阅设置 Draftsman 文档 页面。 使用关联的颜色按钮指定线条颜色。
Column Width

设置所选单元格的宽度,从而设置其所在列的宽度。如果选中了整个表格(通过单击其轮廓或标题),则宽度设置将应用于所有单元格。使用关联的颜色按钮指定当前所选单元格的颜色。

Row Height 使用此字段调整在设计空间中选定行的高度。输入所需高度,后跟英制或公制单位。
Cell Padding Vertical 设置所选单元格中文本的上下间距。
Cell Padding Horizontal 设置所选单元格中文本的左右间距。
Font

设置所选单元格中文本使用的字体。

  • 启用 Use Document Font 选项时, 将使用 文档选项中定义的字体(即在设计空间中未选中任何对象时, Properties 面板的 General 选项卡中 General 区域内的 Document Font 条目)。

  • 禁用 Use Document Font 选项时, 可使用提供的选项选择所需的字体类型、大小、颜色和文本属性。

表格将自动缩放,以适应所选字体大小。

Alignment 使用这些按钮可设置所选单元格中文本的 Horizontal (左对齐、居中或右对齐)和 Vertical (顶部、居中或底部)对齐方式与位置。
Justification 选择表格尺寸更新时用于调整表格位置的参考点。

表格单元格中的特殊字符串

表格支持以特殊字符串形式包含 Draftsman 文档参数。项目参数(包括本地参数和工作区端参数)、系统参数、PCB 参数和用户参数以特殊字符串形式输入表格单元格后,将转换为各自的值。在设计空间中未选中任何对象时,可在 Properties 面板的 Parameters 选项卡下访问 Draftsman 文档参数。有关更多信息,请参阅设置 Draftsman 文档页面。

表格对参数字符串的处理还支持使用标准复制/粘贴操作,在表格与电子表格之间正确传输特殊字符串数据。

  • 将特殊字符串从 Draftsman 粘贴到电子表格时,目标电子表格单元格将填入该字符串解析后的值。

  • 将特殊字符串数据从电子表格粘贴到 Draftsman 时,粘贴的文本将被解析为特殊字符串值,前提是该特殊字符串与可用的系统参数、项目参数或用户参数相匹配。

    在电子表格中准备特殊字符串条目时,需要在每个值条目前加上单引号('),以便将单元格内容视为文本数据。例如,Units 参数的特殊字符串应输入为 '=DocumentUnits。也可以将所有电子表格单元格设置为文本格式。

表格结构

右键单击单元格,然后从上下文菜单中选择 Table 菜单,即可访问单元格配置命令。这些命令提供一整套表格操作功能,用于添加和删除列/行以及合并单元格。

右键菜单中的 Table 命令提供一系列标准表格操作功能。
右键菜单中的 Table 命令提供一系列标准表格操作功能。

  • 只有在表格中选中了两个或更多连续单元格时,Merge Cells 命令才可用。

    • 合并单元格时,如果所选单元格中包含文本,则合并后仅保留最左侧/最顶部单元格(视具体情况而定)中的文本。

  • 只有当光标位于表格中的合并单元格内,或所选单元格区域中至少包含一个合并单元格时,Unmerge Cells 命令才可用。

    • 请注意,如果该单元格中包含文本,则取消合并后,该文本将显示在最左侧/最顶部的单元格中(视具体情况而定)。

    • 取消合并单元格时,如果所选单元格区域中包含多个合并单元格,请注意,此命令仅会取消合并最左侧/最顶部的合并单元格。

AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。

Contents