熟悉Altium设计环境

概览

通过了解 Altium Designer 的界面、账户与工作区连接、环境设置以及日常设计任务,熟悉这款软件。本文将介绍如何使用项目和文档、浏览设计空间,以及开始放置和配置设计对象。继续阅读,掌握基础操作,为开始下一个设计做好准备。

- 认识主要界面元素,找到命令、面板和首选项设置。
- 学习如何登录 Altium 账户并连接到可用的 Altium 365 工作区。
- 了解项目类型,掌握创建、打开、保存和浏览文档以及放置设计对象的基本方法。
使用 AI 深入了解:

Altium Designer 提供完整的电子产品开发环境,涵盖电子开发流程的各个方面,包括前端设计与原理图绘制、混合信号电路仿真、PCB 物理设计等。

本页介绍 Altium Designer 的基本操作技巧,帮助您快速开始下一个产品设计。

主要界面元素

Altium Designer 采用了其他 Windows 应用程序和 CAD 工具中常见的界面元素。下图展示了其中的主要元素,随后将逐一介绍。

Design space – 应用程序窗口中显示当前活动文档的主要区域。在设计空间中,您可以浏览文档内容(例如上图所示的原理图文档),并进行相关操作。

Panels – 用于访问与当前活动项目或文档相关的各种特性和功能。您可以通过设计空间右下角的 Panels 按钮菜单访问各个面板。

Main menus – 用于访问处理当前文档类型的命令。可用的菜单和命令取决于当前活动文档的类型。

Active Bar – 活动栏始终显示在当前文档设计空间的顶部,方便您访问最常用的命令,例如放置和选择对象的命令。

Quick Access Bar – 用于访问高级操作,例如保存文档以及撤销/重做操作。

 

进一步了解 Altium Designer 环境中的这些元素和其他元素:环境元素。

登录 Altium 账户

要访问 Altium 按需服务,例如按需许可和连接 Altium 365 工作区,您必须从 Altium Designer 登录您的 Altium 账户。当您尚未登录 Altium 账户时,设计空间右上角的“当前用户”控件显示为 。要登录,请单击该控件,然后在弹出的菜单中选择 项。

在 Altium Designer Develop 中,将显示 Sign In 对话框,同时默认浏览器会打开一个页面,供您登录 Altium 账户。

在 Altium Designer Agile 或 Altium Designer 中,将显示 Sign In 对话框,提示您使用浏览器登录。单击 按钮后,默认浏览器将打开一个页面,供您登录 Altium 账户。

 

登录后,“当前用户”控件将变为您的 Altium 个人资料头像(例如 )。

进一步了解可用的登录选项:登录 Altium 账户。

连接到 Altium 365 工作区

登录 Altium 账户后,您可以连接到可用的 Altium 365 工作区(Altium Develop 工作区、Altium Agile Teams 工作区或 Altium Agile Enterprise 工作区),以访问其中的功能和数据。为此,请单击设计空间右上角的“活动工作区”控件(未连接到工作区时,该控件显示为 )。在随后出现的菜单中,单击您要连接的 Altium 365 工作区对应的条目。该控件将随之显示已连接工作区的名称(例如 )。

进一步了解可用的连接选项:访问您的工作区。

设置环境

Preferences 对话框是一个集中设置位置,您可以在其中配置 Altium Designer 各个功能区域的全局系统设置。要访问 Preferences 对话框,请单击设计空间右上角的 图标。

单击对话框左侧的页面条目,即可在对话框右侧显示其选项。为方便使用,各页面按功能区域进行分类(System、Data Management、Schematic 等)。

进一步了解 Altium Designer 首选项:访问、定义和管理系统首选项。

使用设计项目和文档

在 Altium Designer 中创建的每个设计都始于一个项目。Altium Designer 项目是一组设计文档,其输出定义了具体的实现方案。项目文件不仅存储指向项目中各个文档的链接,还存储项目专用选项,例如错误检查设置。

Altium Designer 支持 PCB、多板和线束这几种设计项目类型。下面简要介绍各个类型。

大多数项目管理操作(创建、打开等)都通过 File 主菜单和 Projects 面板执行。

Javascript

要创建新的设计项目,请从主菜单中选择 File » New » Project 命令。在打开的 Create Project 对话框中,选择项目的创建位置、项目类型,以及项目名称、存储文件夹等其他选项。单击 Create 按钮后,新项目的条目将显示在 Projects 面板中。

所有与项目相关的数据都存储在文档中,文档也称为文件。要向项目添加新文档,请右键单击 Projects 面板中的项目条目,然后在 Add New to Project 菜单中选择所需的文档类型。

请注意,新创建的文档最初处于未保存状态。使用 Projects 面板中文档条目的右键菜单来保存文档。同样,在项目发生更改时(例如,添加新文档导致其结构发生变化),请使用 Projects 面板中项目条目的右键菜单来保存项目。

要打开现有项目,请使用主菜单中的 File » Open Project 命令以及随后显示的 Open Project 对话框。所打开项目的结构将显示在 Projects 面板中。

双击面板中的文档条目,即可在设计空间中打开该文档。

Projects 面板中项目和文档条目旁的图标,直观地显示了它们的打开/修改状态和版本控制状态。

处理“图形”类型的文档(例如原理图图纸或 PCB 文档)时,您可以缩放和平移文档,以聚焦于文档的特定区域。可用于执行这些操作的基本快捷键如下:

  • Ctrl+Mouse Wheel 或 Middle-Click, Hold&Drag:放大和缩小

  • Right-Click, Hold&Drag 或 Mouse Wheel 或 Shift+Mouse Wheel:平移文档

下面的视频演示了这些快捷键的用法。

要了解有关使用项目和文档的更多信息,请参阅以下页面:

使用设计对象

创建文档,无论是原理图图纸、PCB 还是绘图,本质上都是按照所需的布局放置对象并设置其属性。下面列出了大多数 Altium Designer 编辑器通用的主要放置和编辑方法。

  1. 要放置对象,请从主菜单或活动栏中选择相应的放置命令。例如,要在原理图图纸中放置导线,请从主菜单中选择 Place » Wire 命令,或单击活动栏中的  图标。

  2. 选择放置命令后,您将进入放置模式,此时光标下方会显示十字准线。将光标定位到设计空间中,然后单击鼠标左键以放置对象。对于导线或多边形等复杂对象,您必须继续执行定位和单击操作,以放置对象的所有顶点。

  3. 在放置模式下,按 Tab 可打开 Properties 面板,在放置对象之前编辑其属性。完成属性设置后,单击设计空间中的  按钮以返回放置模式。 

  4. 要结束放置模式,请单击鼠标右键。

  5. 要编辑已放置对象的属性,请在设计空间中单击该对象以将其选中。其属性将显示在 Properties 面板中。如果面板尚未打开,请双击对象以选中它并打开面板。

下面的视频演示了对象的放置过程及其属性的编辑方法。

示例

在学习软件的特定功能时,示例能帮助我们快速入门。有时,这些示例会展示某个功能或一组功能,让学习过程变得更加轻松。同样,我们也希望能使用一套预先开发好的库,以便更方便地选择“开箱即用”的元件。

在首次安装时,软件会一并安装一些示例设计。采用标准默认安装方式时,可以在安装目录的 \Users\Public\Documents\Altium\AD<Solution/Version>\Examples 文件夹中找到这些示例。连接到工作区后,也可以使用一些示例项目、元件和其他设计内容(前提是在激活/安装工作区时选择了包含示例数据)。此外,还可以使用制造商器件搜索面板查找配有各领域模型(符号、封装、仿真模型)的元件。

在 Altium Designer 10 发布时创建的旧版参考设计可在此处下载。其中包含多个仿真和脚本示例。请注意,这些都是旧版内容,并且 不再更新。

获取帮助

Altium Designer 提供了多种途径,方便您查找更多信息和帮助。

  • 将鼠标悬停在任意对象、编辑器、面板、菜单项或按钮上,按 F1 即可打开相应项目的文档。
  • 在执行命令时,按 Shift+F1 可查看该命令中可用的快捷键列表。
  • 使用文档左侧的导航树来阅读特定主题的内容 — 显示图片。

如果您在使用 Altium Designer 时遇到软件错误,可以向 Altium 开发人员发送崩溃报告。在弹出的错误/异常对话框中,单击 Send Report 按钮,并描述错误发生时您正在执行的操作。提供的信息越详细,就越有可能重现导致崩溃的问题并加以解决。

如果发生崩溃时未弹出异常对话框,且软件无响应、看似处于冻结状态,请使用 Ctrl+Alt+Insert 键盘快捷键强制生成崩溃报告。此对话框可能会出现在 Altium Designer 应用程序窗口后方。

AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。

Contents