Arbeiten mit Reuse Blocks & Snippets (altes Design-Reuse-Panel)

Auf einen Blick

Dieser Artikel erläutert, wie Sie mit Altium Designer häufig verwendete Schaltungsabschnitte als Wiederverwendungsblöcke und Snippets speichern und wiederverwenden können. So müssen Sie wiederkehrende Designelemente nicht jedes Mal von Grund auf neu erstellen. Sie erfahren, was die einzelnen Wiederverwendungsoptionen umfassen, wie Sie auf das Panel „Design Reuse“ zugreifen und es verwenden und wie Sie sowohl Workspace-basierte als auch lokale Designinhalte erstellen, verwalten, umbenennen und organisieren. Wenn Sie regelmäßig mit wiederkehrenden Schaltplan- oder Leiterplattenabschnitten arbeiten, zeigt Ihnen dieser Leitfaden, wie sich diese Werkzeuge in Ihren Arbeitsablauf einfügen und wie Sie sie effektiv einsetzen. Lesen Sie weiter, um Ihren Designprozess schneller und einheitlicher zu gestalten.

- Lernen Sie die Unterschiede zwischen Wiederverwendungsblöcken, Schaltplan-Snippets und Leiterplatten-Snippets kennen und erfahren Sie, wann welche Option zum Einsatz kommt.
- Erfahren Sie, wie Sie mit dem Panel „Design Reuse“ wiederverwendbare Designinhalte finden, filtern, sortieren, durchsuchen und verwalten.
- Folgen Sie den Anleitungen zum Erstellen, Speichern, Umbenennen und Organisieren von Wiederverwendungsblöcken und Snippets – sowohl im Workspace als auch an lokalen Speicherorten.
Mit KI tiefer einsteigen:

Die auf dieser Seite beschriebene Benutzeroberfläche für die Wiederverwendung von Designs ist die vorherige Version des Panels Design Reuse, die verfügbar ist, wenn die Option UI.ModernDesignReusePanel im Dialogfeld Advanced Settings deaktiviert ist. Wenn diese Option aktiviert ist, wird eine neue Version des Panels verwendet, die auf den Seiten Arbeiten mit Wiederverwendungsblöcken und Arbeiten mit Snippets beschrieben wird. Das neue Panel Design Reuse befindet sich in der offenen Beta-Phase.

Wenn Ihre Designs häufig gleiche Schaltungsabschnitte enthalten, bietet Altium Designer eine einfache Möglichkeit, diese Abschnitte zu speichern und wiederzuverwenden – sowohl Workspace-basiert als auch lokal dateibasiert. Solche Abschnitte lassen sich jedem PCB-Design hinzufügen, ohne jedes Mal von vorn beginnen zu müssen. Dies ist eine hervorragende Funktion für häufig verwendete Fragmente und kleinere Schaltungsabschnitte, die Sie wiederverwenden möchten. Mit dem System können Sie eine beliebige Auswahl der folgenden Elemente speichern:

  • Schaltungen auf einem einzelnen Schaltplanblatt (ein Schaltplan-Snippet).

  • Schaltungen in einem PCB-Design, einschließlich der Bauteile und des Routings (ein PCB-Snippet).

Wenn Sie mit einem Workspace verbunden sind, können Sie eine einzelne Einheit – einen Wiederverwendungsblock – erstellen, die sowohl eine Schaltplanschaltung als auch deren physische Darstellung für die Leiterplatte enthalten kann. Wenn ein solcher Wiederverwendungsblock auf einem Schaltplanblatt platziert wird, wird seine physische Darstellung während des ECO-Prozesses automatisch im PCB-Dokument platziert.

Das Panel Design Reuse ist die zentrale Anlaufstelle zum Erstellen, Verwalten und Verwenden von Wiederverwendungsblöcken und Snippets – sowohl Workspace-basiert als auch lokal dateibasiert.

Das Panel Design Reuse
Das Panel Design Reuse

Das Panel kann auf folgende Weise aufgerufen werden:

  • Klicken Sie unten rechts im Designbereich auf die Schaltfläche Panels und anschließend auf Design Reuse.
  • Wählen Sie View » Panels » Design Reuse aus den Hauptmenüs.
  • Wählen Sie Place » Reuse Block aus den Hauptmenüs.

Das obere Dropdown-Menü des Panels listet alle derzeit in Ihrem verbundenen Workspace vorhandenen Ordner auf, die Wiederverwendungsblöcke und Workspace-basierte Snippets enthalten. Die Zahl neben jedem Ordnernamen gibt an, wie viele Wiederverwendungsblöcke und Snippets dieser Ordner und seine Unterordner enthalten. Wählen Sie einen Ordner im Dropdown-Menü aus, um die Wiederverwendungsblöcke und Snippets, die dieser Ordner und seine Unterordner enthalten, im Hauptbereich des Panels anzuzeigen. Wählen Sie den Eintrag Ihres verbundenen Workspace im Dropdown-Menü aus, um alle verfügbaren Wiederverwendungsblöcke und Snippets anzuzeigen.

Die Ordnerstruktur des Workspace kann in Altium Designer über das Panel Explorer festgelegt werden.

Verwenden Sie die Filterschaltflächen im Popup des Symbols , um Inhalte bestimmter Typen (Reuse Blocks, Schematic Snippets, PCB Snippets) im Panel ein- oder auszublenden. Verwenden Sie das Steuerelement Sort By, um die gewünschte Sortieroption auszuwählen.

Verwenden Sie die Filter- und Sortieroptionen, um die Anzeige der Inhalte im Panel zu konfigurieren
Verwenden Sie die Filter- und Sortieroptionen, um die Anzeige der Inhalte im Panel zu konfigurieren

Um im ausgewählten Ordner anhand des Namens oder der Beschreibung nach verfügbaren Wiederverwendungsblöcken und Snippets zu suchen, geben Sie einen Suchbegriff in das Feld Search ein. So können Sie die Liste gezielt filtern und auf Ihre Anforderungen eingrenzen.

Jeder Wiederverwendungsblock und jedes Snippet wird im Hauptbereich des Panels durch eine Kachel mit folgenden Angaben dargestellt:

  • Vorschaubild – kann angeklickt werden, um zwischen normaler und voller Größe umzuschalten. Verwenden Sie bei einem Wiederverwendungsblock die Schaltfläche  Zum Verschieben klicken und ziehen​, um zwischen der Vorschau des PCB- und des Schaltplandokuments umzuschalten;

  • Typsymbol –  Zum Verschieben klicken und ziehen​ für einen Wiederverwendungsblock,  Zum Verschieben klicken und ziehen​ für ein Schaltplan-Snippet,  Zum Verschieben klicken und ziehen​ für ein PCB-Snippet;

  • Name und Beschreibung (falls definiert);

  • ID der neuesten Revision, Erstellungsdatum und Autor eines Wiederverwendungsblocks oder eines Workspace-Schaltplan-/PCB-Snippets.

Informationen und Steuerelemente zu einem Wiederverwendungsblock oder Snippet werden in einer Kachel im Panel angezeigt.
Informationen und Steuerelemente zu einem Wiederverwendungsblock oder Snippet werden in einer Kachel im Panel angezeigt.

Erstellen eines Wiederverwendungsblocks

Ein neuer Wiederverwendungsblock kann auf folgende Weise erstellt werden:

  1. Wählen Sie den Befehl zum Erstellen eines neuen Wiederverwendungsblocks:

    • Im Panel Design Reuse, indem Sie oben im Panel auf die Schaltfläche  klicken.

    • Über den Befehl File » New » Reuse Block im Hauptmenü.

    • Im Panel Explorer, indem Sie oben rechts im Panel auf die Schaltfläche  klicken, während ein Ordner des Typs Design Reuse Blocks angezeigt wird.

  2. Eine temporäre, bearbeitbare Struktur des Wiederverwendungsblocks, die einem PCB-Projekt ähnelt, wird im Panel Projects geöffnet (unter einem Eintrag für den Workspace, mit dem Sie derzeit verbunden sind). Der temporäre Schaltplaneditor wird im Hauptdesignfenster geöffnet und ist bereit, das Schaltplandokument des Wiederverwendungsblocks zu erstellen. Verwenden Sie die üblichen Platzierungsbefehle und -techniken, um das Schaltplandokument des Wiederverwendungsblocks zu erstellen.

  3. Verwenden Sie anschließend den Befehl Design » Update PCB Document und den ECO-Prozess, um den erfassten Schaltplan in das PCB-Dokument des Wiederverwendungsblocks zu übertragen. Nehmen Sie dann die erforderlichen Änderungen an diesem Dokument vor (Festlegen der Bauteilpositionen, Routing usw.).

    Dem zu erstellenden Wiederverwendungsblock können mehrere PCB-Dokumente hinzugefügt werden. Verwenden Sie dazu den Befehl Add New to Project » PCB aus dem Kontextmenü des Eintrags des Wiederverwendungsblocks im Panel Projects.

    Verwenden Sie den Befehl Rename aus dem Kontextmenü des Eintrags des hinzugefügten PCB-Dokuments im Panel Projects, um einen aussagekräftigen Namen dafür festzulegen. Verwenden Sie einen Befehl Design » Update aus dem Hauptmenü des Schaltplaneditors, um das gewünschte PCB-Dokument zu aktualisieren.

    Wenn sowohl das Schaltplan- als auch das PCB-Dokument des Wiederverwendungsblocks fertiggestellt sind, speichern Sie den Wiederverwendungsblock im Workspace. Verwenden Sie dazu den Befehl Save to Server aus dem Kontextmenü des Eintrags des Wiederverwendungsblocks im Panel Projects oder das Steuerelement Save to Server rechts neben dem Eintrag.

    Da Wiederverwendungsblöcke im verbundenen Workspace gespeichert werden, sollten sie Bauteile aus diesem Workspace verwenden. So profitieren Sie in vollem Umfang von dem Content-System, das der Workspace bereitstellt.

    • Sowohl das Schaltplan- als auch das PCB-Dokument des Wiederverwendungsblocks müssen mindestens ein Bauteil enthalten, damit der Block im Workspace gespeichert werden kann.

    • Wenn die Schaltplan- und PCB-Dokumente des Wiederverwendungsblocks nicht synchronisiert sind (Unterschiede zwischen den Schaltplan- und PCB-Dokumenten werden erkannt), wird beim Versuch, den Wiederverwendungsblock im Workspace zu speichern, ein Warndialog angezeigt. Sie können den Speichervorgang abbrechen, um zum Wiederverwendungsblock zurückzukehren und die Unterschiede zu beheben, oder mit dem Speichern fortfahren.

  4. Das Dialogfeld New Reuse Block wird angezeigt. Darin können Sie Name, Description und den Workspace-Folder festlegen, in dem der neue Wiederverwendungsblock gespeichert wird.

    Das Dialogfeld New Reuse Block
    Das Dialogfeld New Reuse Block

  5. Nach einem Klick auf OK wird der Wiederverwendungsblock im Workspace gespeichert und seine temporäre Struktur geschlossen.

Ein gespeicherter Wiederverwendungsblock ist anschließend im Panel Design Reuse zu finden, wenn der Ordner, in dem er gespeichert wurde (oder der Eintrag Ihres verbundenen Workspace), in der oberen Dropdown-Liste ausgewählt ist. Möglicherweise müssen Sie den Befehl Refresh im Menü der Schaltfläche  ausführen, damit der neue Wiederverwendungsblock im Panel angezeigt wird.

Umbenennen eines Wiederverwendungsblocks

Nach dem Erstellen eines Wiederverwendungsblocks können Sie ihm bei Bedarf einen passenderen Namen geben. Verwenden Sie dazu den Befehl Rename , der über das Untermenü  und das per Rechtsklick aufrufbare Kontextmenü des Panels Design Reuse verfügbar ist. Geben Sie im daraufhin geöffneten Dialogfeld Rename Reuse Block den neuen Namen ein und klicken Sie auf OK. Der Wiederverwendungsblock trägt nun den gewünschten Namen, wie in den folgenden Abbildungen gezeigt.

Erstellen eines Snippets

Ein neues Schaltplan- oder PCB-Snippet lässt sich schnell aus einer vorhandenen Schaltung auf einem Schaltplanblatt oder in einem PCB-Dokument erstellen:

  1. Wählen Sie die gewünschte Schaltung im Schaltplan- oder PCB-Editor aus.

  2. Klicken Sie mit der rechten Maustaste und wählen Sie Snippets » Create Snippet from selected objects im Kontextmenü oder den Befehl Tools » Convert » Create Snippet from selected objects in den Hauptmenüs.

  3. Das Dialogfeld New Schematic Snippet oder New PCB Snippet wird angezeigt. Darin können Sie den Namen, die Beschreibung, das Speicherziel (einen Workspace oder einen lokalen Ordner) und den Ordner festlegen, in dem das neue Snippet gespeichert wird.

    Wenn Sie ein Snippet in einem lokalen Ordner speichern, klicken Sie im Dialogfeld auf die Schaltfläche  rechts neben dem Feld Path, um das Dialogfeld Choose Snippet Folder zu öffnen. Dort können Sie einen vorhandenen lokalen Snippet-Ordner auswählen, in dem das Snippet gespeichert wird, oder einen neuen Unterordner innerhalb eines vorhandenen lokalen Snippet-Ordners erstellen.

    Informationen zum Organisieren lokaler Snippets in Ordnern finden Sie weiter unten im Abschnitt Organisation lokaler Snippets.
  4. Nach einem Klick auf OK wird das Snippet gespeichert.

Ein gespeichertes Snippet ist anschließend im Panel Design Reuse zu finden, wenn der Eintrag Ihres verbundenen Workspace (oder der Ordner, in dem es gespeichert wurde) in der oberen Dropdown-Liste ausgewählt ist.

Ein Snippet kann aus einer Gruppe ausgewählter Objekte erstellt werden. Hier wird die Erstellung eines Schaltplan-Snippets gezeigt. Bewegen Sie den Mauszeiger über das Bild, um die Erstellung eines PCB-Snippets zu sehen.
Ein Snippet kann aus einer Gruppe ausgewählter Objekte erstellt werden. Hier wird die Erstellung eines Schaltplan-Snippets gezeigt. Bewegen Sie den Mauszeiger über das Bild, um die Erstellung eines PCB-Snippets zu sehen.

Möglicherweise müssen Sie den Befehl Refresh im Menü der Schaltfläche  des Panels ausführen, damit der neue Wiederverwendungsblock im Panel angezeigt wird.

Um über das Panel Design Reuse auf lokale Snippets zugreifen zu können, muss die Option Local Snippets im Menü  aktiviert sein.

Ein Workspace-basiertes Snippet kann auch aus einem vorhandenen lokalen Snippet erstellt werden. Klicken Sie dazu auf die Schaltfläche  in der Kachel des Snippets (oder klicken Sie mit der rechten Maustaste auf eine beliebige Stelle der Kachel) und wählen Sie den Befehl Save to Server im Menü. Legen Sie im daraufhin angezeigten Dialogfeld New Schematic Snippet oder New PCB Snippet die Angaben für Name, Description und den Workspace-Folder fest, in dem das Snippet gespeichert wird.

Ein lokales Snippet kann mit dem Befehl Save to Server im verbundenen Workspace gespeichert werden.
Ein lokales Snippet kann mit dem Befehl Save to Server im verbundenen Workspace gespeichert werden.

Workspace-Snippets sollten Bauteile aus diesem Workspace verwenden. So können Sie die Vorteile des vom Workspace bereitgestellten Content-Systems in vollem Umfang nutzen.

Organisation lokaler Snippets

Im Panel Design Reuse können lokale Snippets in Snippet-Ordnern organisiert werden. So lassen sich zusammengehörige Snippets gruppieren und leichter finden. Snippet-Ordner sind vorhandene Windows-Ordner, die nicht im Panel Design Reuse erstellt werden können. Stattdessen werden sie beim Durchsuchen der darin enthaltenen lokalen Snippets „geöffnet“ oder „geschlossen“. Diese Ordner können nur außerhalb von Altium Designer direkt auf Ihrer Festplatte oder im Netzwerk erstellt werden.

Snippet-Ordner können über das Dialogfeld Available Snippets Folders geöffnet und geschlossen werden. Sie erreichen es, indem Sie oben rechts im Panel Design Reuse auf die Schaltfläche  klicken und im Menü den Befehl Snippet Folders auswählen. Klicken Sie auf Open Folder, um zum gewünschten Ordner auf Ihrer Festplatte oder im Netzwerk zu navigieren. Der ausgewählte Ordner wird der Liste im Dialogfeld hinzugefügt und erscheint anschließend in der Dropdown-Liste oben im Panel Design Reuse.

Um einen Snippet-Ordner aus der Liste zu entfernen (und ihn damit für die Anzeige praktisch zu schließen), wählen Sie den Ordner in der Liste aus und klicken Sie auf Remove Folder. Mit den Schaltflächen Move Up und Move Down können Sie die Reihenfolge ändern, in der die lokalen Snippets im Panel Design Reuse angezeigt werden, wenn in der Dropdown-Liste des Panels der Eintrag Local ausgewählt ist.

Platzieren von Wiederverwendungsblöcken und Snippets

Um einen Wiederverwendungsblock oder ein Snippet in einem Design zu platzieren, klicken Sie in dessen Kachel und anschließend auf die Schaltfläche , klicken Sie auf die Schaltfläche in der Kachel oder klicken Sie mit der rechten Maustaste auf eine beliebige Stelle der Kachel und wählen Sie einen der folgenden Befehle:

  • Place – Wählen Sie diesen Befehl, um den Wiederverwendungsblock oder das Snippet direkt im aktiven Schaltplan- oder PCB-Dokument zu platzieren.
  • Place as Sheet Symbol – Wenn ein Schaltplandokument aktiv ist, wählen Sie diesen Befehl, um den Wiederverwendungsblock oder das Schaltplan-Snippet als Blattsymbol auf dem Schaltplanblatt zu platzieren. Der Inhalt des Wiederverwendungsblocks oder Schaltplan-Snippets wird auf einem automatisch erstellten untergeordneten Schaltplanblatt platziert, auf das das platzierte Blattsymbol verweist.

Platzieren Sie einen Wiederverwendungsblock oder ein Snippet über das Menü der Schaltfläche Place auf der zugehörigen Kachel im Panel. Hier wird die Auswahl des Befehls Place gezeigt, mit dem der Wiederverwendungsblock bzw. das Schaltplan-Snippet auf dem aktiven Schaltplanblatt platziert wird. Bewegen Sie den Mauszeiger über das Bild, um die Auswahl des Befehls Place as Sheet Symbol zu sehen, mit dem der Wiederverwendungsblock bzw. das Schaltplan-Snippet auf dem untergeordneten Blatt platziert wird, auf das das platzierte Blattsymbol verweist.
Platzieren Sie einen Wiederverwendungsblock oder ein Snippet über das Menü der Schaltfläche Place auf der zugehörigen Kachel im Panel. Hier wird die Auswahl des Befehls Place gezeigt, mit dem der Wiederverwendungsblock bzw. das Schaltplan-Snippet auf dem aktiven Schaltplanblatt platziert wird. Bewegen Sie den Mauszeiger über das Bild, um die Auswahl des Befehls Place as Sheet Symbol zu sehen, mit dem der Wiederverwendungsblock bzw. das Schaltplan-Snippet auf dem untergeordneten Blatt platziert wird, auf das das platzierte Blattsymbol verweist.

Klicken Sie auf das Steuerelement Show more auf der Kachel des Wiederverwendungsblocks, um den Abschnitt PCB mit der Liste der PCB-Dokumente des Wiederverwendungsblocks anzuzeigen. Wählen Sie das gewünschte PCB-Dokument in der Liste aus. Der Wiederverwendungsblock wird dann mit diesem Dokument platziert. Das ausgewählte PCB-Dokument wird im Vorschaubereich der Kachel des Wiederverwendungsblocks angezeigt, wenn PCB für die Vorschau ausgewählt ist.

Wählen Sie ein PCB-Dokument aus, das mit dem Wiederverwendungsblock platziert werden soll, um dessen Vorschau anzuzeigen.
Wählen Sie ein PCB-Dokument aus, das mit dem Wiederverwendungsblock platziert werden soll, um dessen Vorschau anzuzeigen.

Nachdem Sie das Schaltplandokument eines Wiederverwendungsblocks platziert haben, kann dessen PCB-Dokument über den ECO-Prozess im PCB-Dokument platziert werden. Verwenden Sie im Schaltplaneditor den Befehl Design » Update PCB Document aus dem Hauptmenü und validieren Sie anschließend die Änderungen im Dialogfeld Engineering Change Order und führen Sie sie aus. Das PCB-Dokument wird als Union im PCB-Dokument platziert und kann über den Modus „Unions“ des PCB-Panels verwaltet werden.

Wenn ein ausgewähltes Schaltplan- oder PCB-Bauteil zu einem im Design platzierten Wiederverwendungsblock gehört, können Sie dessen Eigenschaften überprüfen, indem Sie im Panel Properties auf den Link Reuse Block klicken. Die Eigenschaften des übergeordneten Wiederverwendungsblocks des Bauteils werden im Panel angezeigt. Um zu den Eigenschaften des ursprünglich ausgewählten Bauteils zurückzukehren, verwenden Sie den Link Component .

Greifen Sie über ein Bauteil, das zum Wiederverwendungsblock gehört, auf dessen Eigenschaften zu. Die obigen Bilder zeigen den Zugriff auf die Eigenschaften über ein Schaltplanbauteil. Bewegen Sie den Mauszeiger über das Bild, um den Zugriff über ein PCB-Bauteil zu sehen.
Greifen Sie über ein Bauteil, das zum Wiederverwendungsblock gehört, auf dessen Eigenschaften zu. Die obigen Bilder zeigen den Zugriff auf die Eigenschaften über ein Schaltplanbauteil. Bewegen Sie den Mauszeiger über das Bild, um den Zugriff über ein PCB-Bauteil zu sehen.

Bei einem Wiederverwendungsblock wird bei Verwendung des Platzierungsbefehls dessen Schaltplan- oder PCB-Dokument verwendet, je nachdem, welcher Dokumenttyp beim Ausführen des Befehls aktiv ist.

Stellen Sie bei einem Snippet sicher, dass das richtige Zieldokument als aktives Dokument geöffnet ist, bevor Sie das Snippet platzieren. Der Platzierungsbefehl ist nur verfügbar, wenn das Snippet korrekt in diesem Dokument platziert werden kann, d. h., Snippet-Typ und Dokumenttyp müssen übereinstimmen.

Wiederverwendungsblöcke und Snippets bearbeiten

Um einen Workspace-basierten Wiederverwendungsblock oder ein Snippet zu bearbeiten, klicken Sie auf die Schaltfläche auf der zugehörigen Kachel (oder klicken Sie mit der rechten Maustaste auf eine beliebige Stelle der Kachel) und wählen Sie den Befehl Edit aus dem Menü.

Öffnen Sie einen Workspace-basierten Wiederverwendungsblock oder ein Snippet zur Bearbeitung über den Befehl Edit auf der zugehörigen Kachel im Panel.
Öffnen Sie einen Workspace-basierten Wiederverwendungsblock oder ein Snippet zur Bearbeitung über den Befehl Edit auf der zugehörigen Kachel im Panel.

Der temporäre Editor wird geöffnet. Dabei wird das Dokument mit dem ursprünglichen Wiederverwendungsblock bzw. Snippet aus der neuesten Revision des Workspace-Elements zur Bearbeitung geöffnet. Nehmen Sie die gewünschten Änderungen vor und speichern Sie das Dokument anschließend als nächste Revision des Wiederverwendungsblocks bzw. Snippets. Verwenden Sie dazu den Befehl File » Save to Server aus dem Hauptmenü oder den Befehl Save to Server aus dem Kontextmenü des Wiederverwendungsblock- bzw. Snippet-Eintrags im Projects-Panel.

Die Eigenschaften (Name, Beschreibung und Pfad) eines lokalen Snippets können im Dialogfeld Snippet Properties bearbeitet werden. Dieses öffnen Sie, indem Sie auf die Schaltfläche  auf der Kachel des lokalen Snippets klicken (oder mit der rechten Maustaste auf eine beliebige Stelle der Kachel klicken) und den Befehl Edit Properties aus dem Menü auswählen.

Bearbeiten Sie die Eigenschaften eines lokalen Snippets im Dialogfeld Snippet Properties, das Sie über das Panel Design Reuse öffnen.
Bearbeiten Sie die Eigenschaften eines lokalen Snippets im Dialogfeld Snippet Properties, das Sie über das Panel Design Reuse öffnen.

Wiederverwendungsblöcke und Snippets löschen

Um einen Wiederverwendungsblock oder ein Snippet zu löschen, klicken Sie auf die Schaltfläche  auf der Kachel des Snippets (oder klicken Sie mit der rechten Maustaste auf eine beliebige Stelle der Kachel) und wählen Sie den Befehl Delete aus dem Menü.

  • Bei einem Workspace-basierten Wiederverwendungsblock oder Snippet wird das Dialogfeld Delete Items angezeigt, in dem Sie den Löschvorgang bestätigen. Tatsächlich handelt es sich dabei um ein „Soft Delete“, bei dem der Wiederverwendungsblock oder das Snippet in den Bereich Trash des Workspace verschoben wird. Der Bereich Trash ist im Wesentlichen ein Papierkorb, in den beliebige Inhalte Ihres Workspace durch einen Soft-Delete-Vorgang verschoben werden können. Er ist vom übrigen Workspace isoliert. Bei einem Wiederverwendungsblock können Sie auch festlegen, dass die zugehörigen Inhalte (z. B. Schaltplan- und PCB-Snippets) ebenfalls gelöscht werden.

    Führen Sie ein Soft Delete für einen Wiederverwendungsblock oder ein Snippet über den Befehl Delete auf der zugehörigen Kachel im Panel durch.
    Führen Sie ein Soft Delete für einen Wiederverwendungsblock oder ein Snippet über den Befehl Delete auf der zugehörigen Kachel im Panel durch.

  • Bei einem lokalen Snippet wird das Dialogfeld Confirm angezeigt, um den Löschvorgang zu bestätigen. Dabei werden die Snippet-Dateien von Ihrer Festplatte entfernt.

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Nav
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents