Arbeiten mit Wiederverwendungsblöcken

Auf einen Blick

Dieser Artikel erläutert, wie Sie mit dem Panel „Design Reuse“ in Altium Designer formale Wiederverwendungsblöcke erstellen, verwalten, suchen, platzieren, bearbeiten und organisieren, die in einem verbundenen Workspace gespeichert sind. Er beschreibt, wie Wiederverwendungsblöcke sowohl Schaltplan- als auch PCB-Daten enthalten können und wie diese PCB-Elemente über den ECO-Prozess auf eine Leiterplatte übertragen werden. Außerdem führt er Sie durch die wichtigsten Panel-Funktionen: das Durchsuchen von Workspace-Ressourcen, das Anzeigen von Details, die Auswahl von Platzierungsoptionen, das Speichern von Revisionen sowie Verwaltungsaufgaben wie Umbenennen, Verschieben, Freigeben, Herunterladen und Löschen. Wenn Sie bewährte Designabschnitte projektübergreifend übersichtlicher und effizienter wiederverwenden möchten, lesen Sie weiter. Dieser Artikel zeigt Ihnen, wo Sie anfangen und wie Sie die verfügbaren Werkzeuge sicher einsetzen.

- Erfahren Sie, wie formale Wiederverwendungsblöcke erstellt, in einem Workspace gespeichert und über das Panel „Design Reuse“ in Schaltplan- und PCB-Designs wiederverwendet werden.
- Lernen Sie, wie Sie Wiederverwendungsblöcke finden, prüfen und platzieren – einschließlich der Optionen für die direkte Platzierung, die Platzierung als Schaltplanblattsymbol und den Umgang mit mehreren PCB-Dokumenten.
- Machen Sie sich mit den wichtigsten Verwaltungsfunktionen für Wiederverwendungsblöcke vertraut, darunter Bearbeiten, Aktualisieren von Revisionen, Freigeben, Verschieben, Herunterladen und vorläufiges Löschen.
Mit KI tiefer einsteigen:

Das Design Reuse Panel, das zur Verwaltung von Wiederverwendungsblöcken dient und auf dieser Seite beschrieben wird, befindet sich in der offenen Betaphase und ist verfügbar, wenn die Option UI.ModernDesignReusePanel im Dialogfeld Advanced Settings aktiviert ist. Wenn diese Option deaktiviert ist, wird die vorherige Version des Panels verwendet, die auf der Seite Arbeiten mit Wiederverwendungsblöcken & Snippets beschrieben wird.

Wenn Ihre Designs häufig identische Schaltungsabschnitte im Schaltplan und auf der Leiterplatte enthalten, bietet Altium Designer einfache Möglichkeiten, diese Abschnitte zu speichern und wiederzuverwenden, sodass Sie sie nicht jedes Mal von Grund auf neu erstellen müssen.

Wenn Sie mit einem Workspace verbunden sind, können Sie einen reuse block erstellen, der sowohl die Schaltplanschaltung als auch deren physische Darstellung für die Leiterplatte enthalten kann. Wenn ein solcher Wiederverwendungsblock auf einem Schaltplanblatt platziert wird, wird seine physische Darstellung während des ECO-Prozesses automatisch im PCB-Dokument platziert.

Das Panel Design Reuse bietet Ihnen schnellen Zugriff auf alle Steuerelemente, die Sie zum Arbeiten mit Ihren Wiederverwendungsblöcken und zu deren Verwaltung benötigen.

  • Das Panel bietet außerdem Zugriff auf Ihre verwalteten Schaltplanblätter und Snippets.

  • Neben den üblichen Methoden zum Öffnen eines Panels (über das Menü der Schaltfläche  und das Untermenü View » Panels der Hauptmenüs) können Sie das Panel Design Reuse öffnen, indem Sie im Schaltplan- oder PCB-Editor den Befehl Place » Reuse Block aus den Hauptmenüs wählen.

Um über das Panel Design Reuse mit Wiederverwendungsblöcken zu arbeiten, stellen Sie sicher, dass das Panel für das Durchsuchen von Workspace-Ressourcen konfiguriert ist. Klicken Sie dazu auf das Symbol ganz links in der Adressleiste oben im Panel und wählen Sie den Eintrag Ihres verbundenen Workspace aus. Das Symbol wird als angezeigt.

Erstellen eines Wiederverwendungsblocks

Ein neuer Wiederverwendungsblock kann wie nachfolgend beschrieben erstellt werden.

  1. Klicken Sie oben rechts im Panel Design Reuse auf die Schaltfläche  . Alternativ können Sie den Befehl File » New » Reuse Block aus den Hauptmenüs wählen.

  2. Im Panel Projects wird unter einem Eintrag für den verbundenen Workspace eine temporäre, bearbeitbare Struktur des Wiederverwendungsblocks geöffnet, die einem PCB-Projekt ähnelt. Außerdem wird der temporäre Schaltplan-Editor geöffnet, in dem Sie das Schaltplandokument des Wiederverwendungsblocks definieren können. Verwenden Sie die üblichen Platzierungsbefehle und -techniken, um das Schaltplandokument des Wiederverwendungsblocks zu definieren.

    Wenn Sie einen Wiederverwendungsblock erstellen möchten, der nur einen Schaltplan oder nur eine Leiterplatte enthält, können Sie das PCB- bzw. Schaltplandokument aus der Struktur des Snippets entfernen. Klicken Sie dazu im Panel Projects mit der rechten Maustaste auf das jeweilige Dokument und wählen Sie den Befehl Remove from Project.

  3. Verwenden Sie den Befehl Design » Update PCB Document und den ECO-Prozess, um den erfassten Schaltplan in das PCB-Dokument des Wiederverwendungsblocks zu übertragen. Nehmen Sie anschließend die erforderlichen Änderungen an diesem Dokument vor (Bauteilpositionen festlegen, Leiterbahnen routen usw.).

    Dem Wiederverwendungsblock, den Sie gerade definieren, können mehrere PCB-Dokumente hinzugefügt werden. Verwenden Sie dazu den Befehl Add New to Project » PCB aus dem Kontextmenü des Eintrags des Wiederverwendungsblocks im Panel Projects .

    Verwenden Sie den Befehl Rename aus dem Kontextmenü des Eintrags des hinzugefügten PCB-Dokuments im Panel Projects , um einen aussagekräftigen Namen dafür festzulegen. Verwenden Sie einen Design » Update Befehl aus dem Hauptmenü des Schaltplan-Editors, um das gewünschte PCB-Dokument zu aktualisieren.

  4. Wenn sowohl das Schaltplan- als auch das PCB-Dokument des Wiederverwendungsblocks definiert sind, speichern Sie den Wiederverwendungsblock im Workspace. Verwenden Sie dazu den Befehl Save to Server aus dem Kontextmenü des Eintrags des Wiederverwendungsblocks im Panel Projects oder das Steuerelement Save to Server rechts neben dem Eintrag.

    Da Wiederverwendungsblöcke im verbundenen Workspace gespeichert werden, empfiehlt es sich, im Wiederverwendungsblock Bauteile aus diesem Workspace zu verwenden. So profitieren Sie in vollem Umfang von dem Content-System, das der Workspace bereitstellt.

    • Sowohl das Schaltplan- als auch das PCB-Dokument des Wiederverwendungsblocks müssen mindestens ein Bauteil enthalten, damit der Block im Workspace gespeichert werden kann.

    • Wenn die Schaltplan- und PCB-Dokumente des Wiederverwendungsblocks nicht synchronisiert sind, also Unterschiede zwischen ihnen erkannt werden, wird beim Versuch, den Wiederverwendungsblock im Workspace zu speichern, ein Warndialog angezeigt. Sie können den Speichervorgang abbrechen, um zum Wiederverwendungsblock zurückzukehren und die Unterschiede zu beheben, oder mit dem Speichern fortfahren.

  5. Das Dialogfeld Create New Reuse Block wird angezeigt. Darin können Sie Name, Description und den Workspace-Folder festlegen, in dem der neue Wiederverwendungsblock gespeichert werden soll.

  6. Nachdem Sie im Dialogfeld Create New Reuse Block auf OK geklickt haben, wird der Wiederverwendungsblock im Workspace gespeichert und seine temporäre Struktur geschlossen.

Suchen und Platzieren eines Wiederverwendungsblocks

Wiederverwendungsblöcke, die in Ihrem verbundenen Workspace gespeichert sind, können über das Panel Design Reuse durchsucht und verwendet werden, wenn es für die Anzeige von Workspace-Ressourcen () eingestellt ist. In diesem Modus zeigt das Panel die Ordnerstruktur Ihres Workspace an, sodass Sie die Ordner durchsuchen können, in denen Ihre Wiederverwendungsblöcke gespeichert sind. Jeder Ordner und jeder Wiederverwendungsblock wird in der Liste oben im Panel mit Namen und Beschreibung angezeigt.

Um den gewünschten Wiederverwendungsblock zu finden, können Sie durch die Ordner navigieren oder über das Feld Search oben im Panel Design Reuse anhand des Namens oder der Beschreibung nach einem Wiederverwendungsblock suchen ().

  • Im Panel Design Reuse wird nur die neueste Revision jedes Wiederverwendungsblocks angezeigt.

  • Wenn sich die neueste Revision eines Wiederverwendungsblocks in einem Lebenszyklusstatus befindet, in dem die Option Visible in Vault panels deaktiviert ist (mehr erfahren), wird dieser Wiederverwendungsblock standardmäßig nicht im Panel angezeigt. Um die derzeit nicht sichtbaren Wiederverwendungsblöcke anzuzeigen, klicken Sie oben rechts im Panel auf die Schaltfläche  und aktivieren Sie anschließend im zugehörigen Menü die Option Show Hidden Revisions.

Klicken Sie unten im Panel auf das Steuerelement Details, um den Bereich Details zu erweitern. Dieser zeigt Details zum ausgewählten Wiederverwendungsblock an, darunter:

  • Name des Wiederverwendungsblocks.

  • Symbol für den Lebenszyklusstatus und Revision (klicken Sie auf den Link, um die detaillierte Verlaufsansicht des Wiederverwendungsblock-Elements mit ausgewählter neuester Revision zu öffnen).

  • Beschreibung des Wiederverwendungsblocks.

  • Allgemeine Informationen zum Wiederverwendungsblock und seine Parameter.

  • Vorschaubilder der Schaltplan- und PCB-Dokumente des Wiederverwendungsblocks.

  • Liste der Projekte () und Projektfreigaben (), in denen der Wiederverwendungsblock verwendet wird (Bereich Where Used).

Mithilfe des kontrollierten Zugriffs auf Workspace-Inhalte in Verbindung mit einem geeigneten Lebenszyklusschema können autorisierte Personen (Bibliothekare, leitendes Designmanagement) ausschließlich diejenigen Wiederverwendungsblöcke genehmigen und bereitstellen, die in Designs verwendet werden sollen. So können sich Entwickler ganz auf ihre Arbeit konzentrieren und darauf verlassen, dass sie ausschließlich zur Verwendung freigegebene Wiederverwendungsblöcke nutzen.

Um einen Wiederverwendungsblock in einem Design zu platzieren, bewegen Sie den Mauszeiger über dessen Eintrag im Design Reuse-Panel, klicken Sie auf die Schaltfläche  (oder klicken Sie mit der rechten Maustaste auf den Eintrag) und wählen Sie einen der folgenden Befehle aus dem Menü:

  • Place – Wählen Sie diese Option, um den Wiederverwendungsblock direkt im aktiven Schaltplan- oder PCB-Dokument zu platzieren. Je nachdem, welcher Dokumenttyp beim Ausführen des Befehls aktiv ist, wird das Schaltplan- oder PCB-Dokument des Wiederverwendungsblocks platziert.

     
  • Place as Sheet Symbol – Wenn ein Schaltplandokument aktiv ist, wählen Sie diese Option, um den Wiederverwendungsblock als Blattsymbol auf dem Schaltplanblatt zu platzieren. Das platzierte Blattsymbol enthält Blatteinträge, die den Ports im Wiederverwendungsblock entsprechen. Der Inhalt des Wiederverwendungsblocks wird auf einem automatisch erstellten untergeordneten Schaltplanblatt platziert, auf das das Blattsymbol verweist. Das Blattsymbol eines platzierten Wiederverwendungsblocks ist mit einem eindeutigen Symbol gekennzeichnet.

Wenn der Wiederverwendungsblock mehrere PCB-Dokumente enthält, wählen Sie vor dem Platzieren des Wiederverwendungsblocks das gewünschte PCB-Dokument aus, indem Sie im Bereich Preview des Fensters Details auf dessen Registerkarte unterhalb des PCB-Dokument-Vorschaubilds klicken (). Wenn der Wiederverwendungsblock im Schaltplan platziert wird, wird das ausgewählte PCB-Dokument mit dem Wiederverwendungsblock verknüpft und bei der Aktualisierung über den ECO-Prozess auf der Leiterplatte platziert.

Nachdem das Schaltplandokument eines Wiederverwendungsblocks platziert wurde, kann dessen PCB-Dokument über den ECO-Prozess im PCB-Dokument platziert werden. Verwenden Sie im Schaltplaneditor den Befehl Design » Update PCB Document aus den Hauptmenüs, prüfen Sie anschließend die Änderungen im Dialogfeld Engineering Change Order und führen Sie sie aus.

Bearbeiten eines Wiederverwendungsblocks

Um einen Wiederverwendungsblock zu bearbeiten, bewegen Sie den Mauszeiger über dessen Eintrag im Design Reuse-Panel, klicken Sie auf die Schaltfläche  (oder klicken Sie mit der rechten Maustaste auf den Eintrag) und wählen Sie den Befehl Edit aus dem Menü.

Die temporäre Projektstruktur des Wiederverwendungsblocks, die die neueste Revision des Wiederverwendungsblock-Elements enthält, wird zur Bearbeitung geöffnet. Nehmen Sie die gewünschten Änderungen vor und speichern Sie den Wiederverwendungsblock anschließend als nächste Revision (File » Save to Server).

Weitere Aktionen für Wiederverwendungsblöcke

Das Menü der Schaltfläche  (und das Kontextmenü) eines Wiederverwendungsblock-Eintrags im Design Reuse-Panel bietet außerdem Zugriff auf die folgenden Befehle:

  • Rename – Verwenden Sie diesen Befehl, um den Namen des Wiederverwendungsblocks zu ändern. Geben Sie nach Auswahl des Befehls den gewünschten neuen Namen im angezeigten Dialogfeld Rename Reuse Block ein und klicken Sie anschließend auf OK.

  • Move – Verwenden Sie diesen Befehl, um den Speicherort des Wiederverwendungsblock-Elements in der Workspace-Ordnerstruktur zu ändern. Beim Ausführen des Befehls wird das Dialogfeld Move Item geöffnet, in dem Sie den Zielordner auswählen können, in dem das Element abgelegt werden soll.

  • Share – Verwenden Sie diesen Befehl, um die Freigabeberechtigungen für den Wiederverwendungsblock festzulegen. Nach Auswahl des Befehls wird das Dialogfeld Share For Item geöffnet, in dem Sie die Freigabe nach Bedarf konfigurieren können. Erfahren Sie mehr über die Freigabe auf Elementebene.

  • Operations – Verwenden Sie diesen Befehl, um ein Dropdown-Menü mit zusätzlichen Funktionen für Wiederverwendungsblöcke zu öffnen, die nachfolgend beschrieben werden.

    • Make a Copy – Verwenden Sie diesen Befehl, um den Wiederverwendungsblock zu kopieren. Eine temporäre Projektstruktur des Wiederverwendungsblocks wird mit demselben Inhalt wie im ursprünglichen Wiederverwendungsblock geöffnet. Nehmen Sie die erforderlichen Änderungen vor und speichern Sie den Wiederverwendungsblock im Workspace. 

    • Change Revision State – Verwenden Sie diesen Befehl, um den Revisionsstatus der neuesten Revision des Wiederverwendungsblocks zu ändern. Nach Auswahl des Befehls wird das Dialogfeld zur stapelweisen Statusänderung geöffnet, in dem Sie den Revisionsstatus des Wiederverwendungsblocks ändern können.

    • Download – Verwenden Sie diesen Befehl, um die im Wiederverwendungsblock gespeicherten Daten (seine Schaltplan- und/oder PCB-Dokumente) herunterzuladen. Die zugehörigen Daten werden in einen Unterordner des ausgewählten Verzeichnisses heruntergeladen, der nach der Revisions-ID des Wiederverwendungsblock-Elements benannt ist. Die Dateien befinden sich in den darin enthaltenen Released-Ordnern.

  • Delete – Verwenden Sie diesen Befehl, um den Wiederverwendungsblock aus Ihrem verbundenen Workspace zu löschen. Nach Auswahl des Befehls wird das Dialogfeld Delete Items angezeigt, in dem Sie den Löschvorgang bestätigen können. Sie können auch festlegen, dass die zugehörigen Inhalte des Wiederverwendungsblocks (d. h. Schaltplan- und PCB-Snippets) gelöscht werden.

    Bei dieser Aktion handelt es sich um ein „weiches Löschen“, bei dem der Wiederverwendungsblock in den Bereich Trash des Workspace verschoben wird. Erfahren Sie mehr über das weiche Löschen.

  • History – Verwenden Sie diesen Befehl, um eine Detailansicht des Wiederverwendungsblocks zu öffnen, die als neue Registerkartenansicht in Altium Designer angezeigt wird.

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Nav
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents