Arbeiten mit verwalteten Schaltplanblättern

Auf einen Blick

Dieser Artikel erläutert, wie verwaltete Schaltplanblätter in einem verbundenen Altium Designer Workspace die Wiederverwendung von Designs zuverlässiger, nachvollziehbarer und konsistenter machen als einfaches Kopieren und Einfügen. Er zeigt, was ein verwaltetes Schaltplanblatt ist, wie es sich von Device Sheets unterscheidet, wie es im Workspace gespeichert und versioniert wird und welche wesentlichen Möglichkeiten es gibt, es zu erstellen und für die spätere Verwendung zu speichern. Außerdem erfahren Sie, welche Rolle Ordnertyp, Inhaltstyp, Benennung, Lebenszyklus und direkte Bearbeitung beim Aufbau wiederverwendbarer Schaltplaninhalte spielen, auf die sich Ihr Team verlassen kann. Lesen Sie weiter und erfahren Sie, wie im Workspace verwaltete Schaltplanblätter Ihnen helfen, bewährte Designblöcke mit größerer Sicherheit wiederzuverwenden.

- Erfahren Sie, was verwaltete Schaltplanblätter sind, wie sie die Wiederverwendung unterstützen und warum die Speicherung im Workspace Versionskontrolle, Nachvollziehbarkeit und die Integrität der Inhalte gewährleistet.
- Lernen Sie die verschiedenen Möglichkeiten zum Erstellen und Speichern verwalteter Schaltplanblätter kennen – von der direkten Bearbeitung über das Speichern des aktuellen Schaltplanblatts bis hin zum Hochladen eines Schaltplandokuments in eine Revision.
- Erfahren Sie, wie Einstellungen wie Ordnertyp, Inhaltstyp, Benennungsschemata und Lebenszykluseinstellungen dabei helfen, wiederverwendbare Schaltplaninhalte zu organisieren und zu verwalten.
Mit KI tiefer einsteigen:

Die Wiederverwendung von Designinhalten ist etwas, das sich alle Unternehmen in der Produktentwicklung wünschen und von dem sie erheblich profitieren können. Sie spart nicht nur Zeit: Wenn sich ein Abschnitt eines früheren Designs einfach wiederverwenden lässt, sind auch sämtliche Qualifizierungs- und Testschritte für diesen Teil des Designs bereits abgeschlossen. Echte Wiederverwendung ist jedoch weit mehr als Kopieren und Einfügen. Die Inhalte müssen gegen Änderungen gesperrt sein, damit garantiert ist, dass sie mit der ursprünglichen Version übereinstimmen. Keine schnellen Änderungen an der Farbe eines Bauteils oder kleine Anpassungen eines Widerstandswerts – die Arbeit mit wiederverwendbaren Inhalten muss wie die Arbeit mit Standardbauteilen sein: Inhalte platzieren, anschließen, und sie funktionieren genau wie beim letzten Mal.

Altium Designer bietet in Verbindung mit einem verbundenen Workspace die Möglichkeit, verwaltete Schaltplanblätter (Managed Schematic Sheet Items) in diesem Workspace zu erstellen. Solche Blätter können auf folgende Weise erstellt werden:

  • Durch direkte Bearbeitung.

  • Durch Speichern des aktuellen Schaltplanblatts im Workspace.

  • Durch Hochladen des entsprechenden Schaltplandokuments (*.SchDoc) in eine Revision eines verwalteten Ziel-Schaltplanblatts.

Sobald ein verwaltetes Schaltplanblatt erstellt wurde (und Daten in einer seiner Revisionen gespeichert wurden), kann es in zukünftigen Leiterplattenprojekten wiederverwendet werden.

Was genau ist ein verwaltetes Schaltplanblatt?

Ein verwaltetes Schaltplanblatt ist ein standardmäßiges Altium Designer-Schaltplanblatt mit Bauteilen und Verdrahtung, das in einem Workspace gespeichert wurde, damit es in anderen Designs wiederverwendet werden kann. Es wird wie jedes andere Schaltplanblatt bearbeitet. Das Konzept verwalteter Schaltplanblätter ist auch nicht auf ein einzelnes Schaltplanblatt beschränkt: Sie können ein verwaltetes Schaltplanblatt in Ihrem Design platzieren, das die oberste Ebene einer Hierarchie weiterer verwalteter Schaltplanblätter bildet.

Verwaltete Schaltplanblätter unterscheiden sich von Device Sheets dadurch, dass sie in einem Workspace gespeichert werden, während Device Sheets in einem Ordner auf einer Festplatte liegen. Verwaltete Blätter profitieren somit von den Vorteilen von Workspace-Inhalten, darunter eine vereinfachte Speicherung, eine verbindliche Versionskontrolle und natürlich eine gesicherte Integrität.

► Siehe Informationen zu lokal verwalteten Device Sheets.

Der Wechsel von Device Sheets zu verwalteten Schaltplanblättern bietet sich an, wenn Sie von wiederverwendbaren Inhalten zu Workspace wiederverwendbaren Inhalten übergehen möchten – also wenn der Wunsch oder die Notwendigkeit besteht, die Freigabe dieser Designinhalte zu steuern und dem gesamten Team eine zentrale Quelle für diese Inhalte bereitzustellen.

Indem Sie ein verwaltetes Schaltplanblatt als Workspace-Inhalt bereitstellen, stellen Sie sicher, dass sich die in einem Design verwendete Revision jederzeit einfach identifizieren und zu ihrer Quelle zurückverfolgen lässt. Als Workspace-Inhalt kann das Blatt bei Bedarf überarbeitet und aktualisiert werden. Zudem lassen sich sämtliche Verwendungsbeziehungen nachverfolgen – sowohl bis hinunter zu den Bauteilen auf dem Blatt als auch bis hinauf zu den Designs, die dieses Blatt verwenden. So stehen Ihnen alle Informationen zur Verfügung, um zu entscheiden, ob das überarbeitete Blatt in bestehende Designs übernommen werden muss oder ob ein bestimmtes Design weiterhin die vorherige Revision verwenden soll.

Ordnertyp

Beim Erstellen des Ordners, in dem verwaltete Schaltplanblätter gespeichert werden sollen, können Sie den Ordnertyp festlegen. Dieser hat keinen Einfluss auf den Inhalt des Ordners – beim Speichern eines Schaltplanblatts wird immer ein entsprechendes Managed Schematic Sheet Item erstellt. Der Typ liefert lediglich einen visuellen Hinweis darauf, was in einem Ordner gespeichert ist, und kann bei der Suche nach bestimmten Inhalten in einem Workspace hilfreich sein. Um einen Ordner als Ablage für verwaltete Schaltplanblätter zu kennzeichnen, setzen Sie beim Festlegen der Ordnereigenschaften im Dialog Edit Folder die Eigenschaft Folder Type auf Managed Schematic Sheets.

Die Angabe des Ordnertyps – also seines Verwendungszwecks – gibt beim Durchsuchen des Workspace einen visuellen Hinweis auf den Inhalt dieses Ordners.
Die Angabe des Ordnertyps – also seines Verwendungszwecks – gibt beim Durchsuchen des Workspace einen visuellen Hinweis auf den Inhalt dieses Ordners.

Inhaltstyp

Wenn Sie ein Managed Schematic Sheet Item als Ziel für die Speicherung Ihres Schaltplanblatts erstellen, stellen Sie sicher, dass dessen Content Type im Dialog Create New Item auf Managed Schematic Sheet gesetzt ist. Wenn Sie das Item in einem Ordner des Typs Managed Schematic Sheets erstellen, ist dieser Inhaltstyp beim Erstellen des Items im Rechtsklick-Kontextmenü verfügbar.

Erstellen eines verwalteten Schaltplanblatts in einem Ordner vom Typ Managed Schematic Sheets – der richtige Content Type ist im Kontextmenü verfügbar.
Erstellen eines verwalteten Schaltplanblatts in einem Ordner vom Typ Managed Schematic Sheets – der richtige Content Type ist im Kontextmenü verfügbar.

Speichern eines Schaltplanblatts

Related page: Erstellen und Bearbeiten von Inhalten

Bisher haben wir die Unterstützung für verwaltete Schaltplanblätter im Workspace im Hinblick auf die zugehörigen Ordner- und Inhaltstypen behandelt. Ein fertig definiertes Schaltplanblatt lässt sich auf verschiedene Arten in einer Revision eines solchen Managed Schematic Sheet Items speichern. Diese werden in den folgenden Abschnitten beschrieben.

Um die reibungslose Wiederverwendung verwalteter Schaltplanblätter in Ihren Designs zu unterstützen, wird dringend empfohlen, das Schaltplanblatt vor dem Speichern als verwaltetes Schaltplanblatt manuell zu annotieren (Tools » Annotation » Annotate Schematics). Wenn ein Design mit verwalteten Schaltplanblättern fertiggestellt ist, können alle Blätter und Bauteile projektweit neu nummeriert werden.

► Weitere Informationen finden Sie unten im Abschnitt Annotieren von Bauteilen und Blättern.

Direkte Bearbeitung

Dank der Unterstützung für die direkte Bearbeitung im Workspace kann ein Schaltplanblatt bearbeitet und in der ersten Revision eines neu erstellten Managed Schematic Sheet Items gespeichert werden. Die direkte Bearbeitung befreit Sie von der Bindung an separate, versionsverwaltete Quelldaten. Sie können einen unterstützten Inhaltstyp einfach in einem temporären Editor bearbeiten, der die neuesten Quelldaten direkt aus dem Workspace lädt. Nach Abschluss der Bearbeitung wird das Objekt in einer nachfolgenden geplanten Revision seines übergeordneten Items gespeichert bzw. erneut gespeichert und der temporäre Editor geschlossen. Es befinden sich keine Dateien auf Ihrer Festplatte, Sie müssen sich nicht fragen, ob Sie mit den richtigen oder neuesten Quelldaten arbeiten, und Sie müssen keine separate Versionsverwaltungssoftware pflegen. Der Workspace übernimmt all dies mit hoher Datenintegrität und beschleunigt Änderungen an Ihren Daten erheblich.

Wenn Sie ein Managed Schematic Sheet Item erstellen, können Sie anschließend ein Schaltplanblatt bearbeiten und in der ersten Revision dieses Items speichern. Aktivieren Sie dazu die Option Open for editing after creation unten im Dialog Create New Item (sie ist standardmäßig aktiviert). Das Item wird erstellt und der temporäre Schaltplaneditor geöffnet. Darin wird ein .SchDoc-Dokument als aktives Dokument im Hauptdesignfenster angezeigt. Dieses Dokument wird entsprechend der Item-Revision im folgenden Format benannt: <Item><Revision>.SchDoc (z. B. SCH-0007-1.SchDoc).

Wenn Ihr Workspace mindestens eine gespeicherte Schaltplanvorlage enthält, wird der Dialog Select configuration item (Schematic Templates) angezeigt. Wählen Sie darin aus, welche Vorlage auf das Schaltplandokument angewendet werden soll.

Beispiel für die Bearbeitung der ersten Revision eines verwalteten Schaltplanblatts direkt aus dem Workspace – der temporäre Schaltplaneditor stellt das Dokument bereit, in dem Sie Ihr Schaltplanblatt definieren.
Beispiel für die Bearbeitung der ersten Revision eines verwalteten Schaltplanblatts direkt aus dem Workspace – der temporäre Schaltplaneditor stellt das Dokument bereit, in dem Sie Ihr Schaltplanblatt definieren.

Verwenden Sie das Dokument, um das Schaltplanblatt nach Bedarf zu definieren. Da verwaltete Schaltplanblätter in einem Workspace gespeichert werden, sollten auch die darauf verwendeten Bauteile im Workspace gespeichert sein. So nutzen Sie die Vorteile des vom Workspace bereitgestellten Inhaltssystems vollständig aus. Dazu gehört, dass Sie alle auf dem verwalteten Schaltplanblatt verwendeten Bauteile (die untergeordneten Elemente) sowie die Designs, in denen das verwaltete Schaltplanblatt verwendet wurde (Verwendungsnachweis), identifizieren und auffinden können. Weitere Informationen finden Sie unter Aufbau und Pflege Ihrer Bauteile und Bibliotheken.

Die Möglichkeit, mit Workspace-Bauteilen größere Designbausteine aufzubauen, ermöglicht einen immer effizienteren Designablauf auf einer höheren Abstraktionsebene. Ähnlich wie bei der Auswahl von Teilen aus einem Regal verwendet der Entwickler diese verwalteten Schaltplanblätter mit ihrer jeweiligen Funktionalität als Bestandteile eines größeren Designprojekts wieder. Je mehr verwaltete Schaltplanblätter mit solchen Schaltungen erstellt und im Workspace gespeichert werden, desto mehr Funktionalität steht dem Entwickler zur Verfügung. Dies wiederum steigert die Produktivität bei nachfolgenden Designs.

Für die direkte Bearbeitung stehen drei relevante Bedienelemente zur Verfügung, die über Quick Access Bar (oben links im Hauptanwendungsfenster) oder über die Symbolleiste Schematic Standard leicht zugänglich sind:

  • – Save Active Document. Verwenden Sie diese Schaltfläche, um alle am Dokument vorgenommenen Änderungen lokal zu speichern. So können Sie den aktuellen Änderungsstand speichern, wenn Sie zu einem späteren Zeitpunkt weitere Änderungen vornehmen möchten, bevor Sie das Dokument endgültig im Workspace speichern.
  • / – Save to Workspace. Verwenden Sie diese Schaltfläche, um das definierte Schaltplanblatt im Workspace zu speichern. Es wird dabei in der ersten (geplanten) Revision des verwalteten Ziel-Schaltplanblatt-Items abgelegt. Das Dialogfeld Edit Revision wird geöffnet. Darin können Sie den Namen und die Beschreibung ändern sowie bei Bedarf Freigabehinweise hinzufügen. Nach dem Speichern werden das Dokument und der Editor geschlossen. Das Dokument mit dem Quellschaltplanblatt (*.SchDoc) wird in der Revision des Items gespeichert.

    Ein Bedienelement Save to Server steht außerdem direkt rechts neben dem Eintrag des Schaltplanblatts im Panel Projects zur Verfügung.
  • / – Discard Local Changes. Verwenden Sie diese Schaltfläche, wenn Sie die Bearbeitung abbrechen und alle vorgenommenen Änderungen verwerfen möchten. Das Dokument und der Editor werden geschlossen, und es wird nichts im verwalteten Ziel-Schaltplanblatt-Item gespeichert.

Diese Bedienelemente stehen auch als Befehle – Save (Tastenkürzel: Ctrl+S), Save to Server (Tastenkürzel: Ctrl+Alt+S) und Discard Local Changes – im Hauptmenü File sowie im Kontextmenü des Schaltplanblatt-Eintrags im Panel Projects zur Verfügung.

Die im Workspace gespeicherten Daten umfassen das Quellschaltplanblatt, das in der Schaltplandokumentdatei (<Item><Revision>.SchDoc) definiert ist, sowie alle zugehörigen Kabelbaum-Definitionsdateien (*.Harness). Wechseln Sie im Panel Explorer zur Ansichtsregisterkarte Preview, um eine grafische Darstellung des Blatts zusammen mit einer Liste der enthaltenen Bauteile (und gegebenenfalls der verwalteten Schaltplanblattvorlage) anzuzeigen.

Klicken Sie auf den Hyperlink-Eintrag einer untergeordneten Bauteil-Item-Revision, um im Panel Explorer direkt zu dieser zu springen. Der Bereich für untergeordnete Items bietet außerdem ein Kontextmenü mit Befehlen für die Arbeit mit einer untergeordneten Bauteil-Item-Revision.

Durchsuchen Sie die gespeicherte Revision des verwalteten Schaltplanblatts wieder im Panel Explorer. Wechseln Sie zur Ansichtsregisterkarte Preview, um eine grafische Darstellung und eine Liste der untergeordneten Bauteilrevisionen anzuzeigen.
Durchsuchen Sie die gespeicherte Revision des verwalteten Schaltplanblatts wieder im Panel Explorer. Wechseln Sie zur Ansichtsregisterkarte Preview, um eine grafische Darstellung und eine Liste der untergeordneten Bauteilrevisionen anzuzeigen.

Die auf dem Blatt verwendeten untergeordneten Bauteile können auch über die Ansichtsregisterkarte Children durchsucht werden. Doppelklicken Sie auf einen Eintrag, um direkt zu diesem zu springen, oder klicken Sie mit der rechten Maustaste darauf, um auf bauteilbezogene Befehle zuzugreifen.

Durchsuchen Sie die auf dem verwalteten Schaltplanblatt enthaltenen Bauteile über die Ansicht Children.
Durchsuchen Sie die auf dem verwalteten Schaltplanblatt enthaltenen Bauteile über die Ansicht Children.

Ein vorhandenes Blatt im Workspace speichern

Die direkte Bearbeitung ist zwar der bevorzugte Ansatz für die meisten Designinhalte, die in einem Workspace gespeichert werden können, doch bei vorhandenen Schaltplanblättern (oder auch Geräteblättern) haben Sie zusätzlich die Möglichkeit, ein Blatt direkt im Workspace zu speichern. Voraussetzung dafür ist eine geplante Revision eines vorhandenen verwalteten Schaltplanblatt-Items, in der das Blatt gespeichert wird. Gehen Sie wie folgt vor:

  1. Erstellen Sie ein neues verwaltetes Schaltplanblatt-Item mit einer ersten geplanten Revision oder verwenden Sie bei Bedarf eine geplante Revision eines anderen vorhandenen Items.

  2. Öffnen Sie das Schaltplanblatt oder Geräteblatt in Altium Designer.

  3. Wählen Sie den Befehl File » Save as Managed Sheet to Server aus den Hauptmenüs.

  4. Das Dialogfeld Choose Planned Item Revision wird geöffnet. Wählen Sie darin die Zielrevision des gewünschten verwalteten Schaltplanblatt-Items aus (diese muss sich im Status Planned befinden) und klicken Sie dann auf OK.

    Wenn das verwaltete Ziel-Schaltplanblatt-Item noch nicht vorhanden ist, können Sie es direkt über das Dialogfeld Choose Planned Item Revision erstellen. Achten Sie dabei darauf, die Option Open for editing after creation (im Dialogfeld Create New Item) zu deaktivieren, da Sie andernfalls in den direkten Bearbeitungsmodus wechseln.
  5. Das Dialogfeld Edit Revision wird geöffnet. Darin können Sie den Namen und die Beschreibung ändern sowie bei Bedarf Freigabehinweise hinzufügen.

  6. Nachdem Sie auf OK geklickt haben, wird das Blatt gespeichert und in der Revision des Items abgelegt.

Beispiel für das Übertragen eines vorhandenen Geräteblatts in den Workspace, mit dem Sie aktuell verbunden sind. Das Speichern muss in einer vorhandenen Revision eines verwalteten Schaltplanblatts erfolgen, und diese Revision muss sich im Status Planned befinden.
Beispiel für das Übertragen eines vorhandenen Geräteblatts in den Workspace, mit dem Sie aktuell verbunden sind. Das Speichern muss in einer vorhandenen Revision eines verwalteten Schaltplanblatts erfolgen, und diese Revision muss sich im Status Planned befinden.

Ein verwaltetes Schaltplanblatt suchen und platzieren

Das unten beschriebene Panel Design Reuse befindet sich in der offenen Betaphase und ist verfügbar, wenn die Option UI.ModernDesignReusePanel im Dialogfeld Advanced Settings aktiviert ist. Wenn diese Option deaktiviert ist, kann ein verwaltetes Schaltplanblatt über das Panel Explorer platziert werden. Navigieren Sie dazu zum gewünschten verwalteten Schaltplanblatt oder suchen Sie danach. Klicken Sie mit der rechten Maustaste auf die benötigte Revision des verwalteten Schaltplanblatts (in der Regel die neueste; in diesem Fall klicken Sie einfach direkt auf den Item-Eintrag der obersten Ebene) und wählen Sie den Befehl Place.

Verwaltete Schaltplanblätter, die in Ihrem verbundenen Workspace gespeichert sind, können über das Panel Design Reuse durchsucht und verwendet werden, wenn es für die Anzeige von Workspace-Ressourcen () eingestellt ist.

Sie können die Workspace-Ordner durchsuchen, um das gewünschte verwaltete Schaltplanblatt zu finden. Alternativ können Sie über das Feld Search oben im Panel Design Reuse anhand des Namens oder der Beschreibung nach einem verwalteten Schaltplanblatt suchen.

  • Im Panel Design Reuse wird nur die neueste Revision jedes verwalteten Schaltplanblatts angezeigt.

  • Wenn sich die neueste Revision eines verwalteten Schaltplanblatts in einem Lebenszyklusstatus befindet, in dem die Option Visible in Vault panels deaktiviert ist (mehr erfahren), wird dieses verwaltete Schaltplanblatt standardmäßig nicht im Panel angezeigt. Um die derzeit ausgeblendeten verwalteten Schaltplanblätter anzuzeigen, klicken Sie oben rechts im Panel auf die Schaltfläche  und aktivieren Sie anschließend im zugehörigen Menü die Option Show Hidden Revisions.

Klicken Sie unten im Panel auf das Steuerelement Details, um den Bereich Details aufzuklappen. Dieser zeigt Details zu den ausgewählten verwalteten Schaltplanblättern an, darunter:

  • Name des verwalteten Schaltplanblatts.

  • Symbol des Lebenszyklusstatus und Revision (klicken Sie auf den Link, um die detaillierte Verlaufsansicht des Elements für das verwaltete Schaltplanblatt zu öffnen, wobei die neueste Revision ausgewählt ist).

  • Beschreibung des verwalteten Schaltplanblatts.

  • Allgemeine Informationen zum verwalteten Schaltplanblatt.

Durch den kontrollierten Zugriff auf Workspace-Inhalte in Verbindung mit einem geeigneten Lebenszyklusschema kann autorisiertes Personal (Bibliothekare, leitende Designverantwortliche) gezielt nur diejenigen verwalteten Schaltplanblätter genehmigen und bereitstellen, die in Designs verwendet werden sollen. So können Designer unbesorgt arbeiten und sicher sein, dass sie ausschließlich freigegebene Blätter mit wiederverwendbaren Schaltungen verwenden.

Prior to Placement

Bevor Sie ein verwaltetes Schaltplanblatt in einem Design platzieren, sind einige Punkte zu beachten:

  • Das Blattsymbol eines verwalteten Schaltplanblatts kann nicht auf einem freien Schaltplan platziert werden. Das Zielblatt muss Teil eines Projekts sein.

  • Stellen Sie sicher, dass das Schaltplanblatt, auf dem das zugehörige Blattsymbol platziert werden soll, in Altium Designer geöffnet und das aktive Dokument ist. Wenn Dokumente in mehreren Fenstern geöffnet sind, stellen Sie außerdem sicher, dass das Fenster mit diesem aktiven Schaltplandokument den Fokus hat.

Um ein verwaltetes Schaltplanblatt in einem Design zu platzieren, bewegen Sie den Mauszeiger über dessen Eintrag im Panel Design Reuse, klicken Sie auf die Schaltfläche  (oder klicken Sie mit der rechten Maustaste auf den Eintrag) und wählen Sie im Menü den Befehl Place. Ein Blattsymbol, das auf das Blatt verweist, hängt nun am Mauszeiger. Klicken Sie auf die gewünschte Stelle im Schaltplanblatt, um es zu platzieren.

Beim Platzieren des Blattsymbols kopiert Altium Designer das verwaltete Blatt, das durch das Symbol repräsentiert wird, aus dem Workspace in einen Unterordner namens \Managed\Sheets im Projektordner. Hier wird eine Kopie jedes verwalteten Blatts gespeichert, jeweils in einem eigenen Unterordner, der durch eine vom System erzeugte eindeutige Kennung (GUID) identifiziert wird.

Der nach der GUID benannte Unterordner, in den die Instanz des verwalteten Schaltplanblatts heruntergeladen und in dem sie gespeichert wird, darf in keiner Weise bearbeitet oder umbenannt werden.

Annotieren von Bauteilen und Blättern

Um die Integrität der Schaltung in einem verwalteten Schaltplanblatt zu gewährleisten, kann dieses Blatt bei der normalen Verwendung im Design nicht bearbeitet werden. Das bedeutet, dass die Blattnummer und die Bezeichnerzuweisungen auf dem Blatt nicht geändert werden können. Wie nummerieren Sie also alle Blätter im Projekt und annotieren sämtliche Bauteile?

Diese Aufgaben werden über zwei Befehle ausgeführt: Blätter werden mit dem Befehl Tools » Annotation » Annotate Compiled Sheets nummeriert und Bauteile mit dem Befehl Tools » Annotation » Board Level Annotate annotiert. Die Blattnummern und Bezeichnerzuweisungen werden in einer separaten Datei, <ProjectName>*.annotation, gespeichert. 

Die Werkzeuge zur Bauteilannotation müssen wissen, in welcher Reihenfolge die Schaltplanblätter verarbeitet werden sollen. Daher empfiehlt es sich, zuerst die Blätter und anschließend die Bauteile zu nummerieren.

Die Grundsätze zum Annotieren von Bauteilen und Blättern sind dieselben wie bei der Verwendung lokaler Device Sheets. Weitere Informationen zum Annotieren von Designs mit verwalteten Schaltplanblättern finden Sie in den folgenden Abschnitten auf der Seite „Device Sheets“:

Bearbeiten eines verwalteten Schaltplanblatts

Um ein verwaltetes Schaltplanblatt zu bearbeiten, bewegen Sie den Mauszeiger über dessen Eintrag im Panel Design Reuse, klicken Sie auf die Schaltfläche  (oder klicken Sie mit der rechten Maustaste auf den Eintrag) und wählen Sie im Menü den Befehl Edit. Der temporäre Editor wird geöffnet. Darin ist das Schaltplanblatt aus der neuesten Revision des Elements für das verwaltete Schaltplanblatt zur Bearbeitung geöffnet. Nehmen Sie die erforderlichen Änderungen vor und speichern Sie das Dokument anschließend als nächste Revision des Elements (File » Save to Server).​​​

Wenn Sie das in einem Element für ein verwaltetes Schaltplanblatt gespeicherte Schaltplanblatt ändern müssen und Ihnen das aktualisierte Blatt vorliegt, können Sie es über das Panel Explorer in dieses Element hochladen. Das neue Blatt wird in der nächsten Revision dieses Elements gespeichert. Weitere Informationen finden Sie auf der Seite Erstellen & Bearbeiten von Inhalten.

Weitere Aktionen für verwaltete Schaltplanblätter

Das Menü der Schaltfläche  (und das Kontextmenü) eines Eintrags für ein verwaltetes Schaltplanblatt im Panel Design Reuse bietet außerdem Zugriff auf die folgenden Befehle:

  • Move – Hiermit ändern Sie den Speicherort des Elements für das verwaltete Schaltplanblatt in der Ordnerstruktur des Workspace. Beim Aufrufen des Befehls wird das Dialogfeld Move Item geöffnet, in dem Sie den Zielordner auswählen können, in dem das Element abgelegt werden soll.

  • Share – Hiermit legen Sie die Freigabeberechtigungen für das verwaltete Schaltplanblatt fest. Nach Auswahl des Befehls wird das Dialogfeld Share For Item geöffnet, in dem Sie die Freigabe nach Bedarf konfigurieren können. Erfahren Sie mehr über die Freigabe auf Elementebene.

  • Operations – Hiermit öffnen Sie ein Dropdown-Menü mit zusätzlichen Funktionen für verwaltete Schaltplanblätter, die im Folgenden beschrieben werden.

    • Make a Copy – Hiermit kopieren Sie das verwaltete Schaltplanblatt. Ein temporärer Editor für das verwaltete Schaltplanblatt wird geöffnet, der denselben Inhalt wie das ursprüngliche verwaltete Schaltplanblatt enthält. Nehmen Sie die erforderlichen Änderungen vor und speichern Sie das verwaltete Schaltplanblatt im Workspace. 

    • Change Revision State – Hiermit ändern Sie den Revisionsstatus der neuesten Revision des verwalteten Schaltplanblatts. Nach Auswahl des Befehls wird das Dialogfeld Batch-Statusänderung geöffnet, in dem Sie den Revisionsstatus des verwalteten Schaltplanblatts ändern können.

    • Download – Hiermit laden Sie die im verwalteten Schaltplanblatt gespeicherten Daten herunter. Die zugehörigen Daten werden in einen Unterordner im ausgewählten Verzeichnis heruntergeladen, der nach der Revisions-ID des Elements für das verwaltete Schaltplanblatt benannt ist. Die Datei befindet sich in den darin enthaltenen Ordnern Released.

  • Delete – Hiermit löschen Sie das verwaltete Schaltplanblatt aus dem verbundenen Workspace. Nach Auswahl des Befehls wird das Dialogfeld Delete Items angezeigt, in dem Sie den Löschvorgang bestätigen können. 

    Bei dieser Aktion handelt es sich um ein „vorläufiges Löschen“, bei dem das verwaltete Schaltplanblatt in den Bereich Trash des Workspace verschoben wird. Erfahren Sie mehr über das vorläufige Löschen.

  • History – Hiermit öffnen Sie eine Detailansicht des verwalteten Schaltplanblatts als neue Registerkartenansicht in Altium Designer.

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Nav
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents