Acceder, definir y gestionar las opciones del proyecto
Altium Essentials: Schematic Electrical Rules Validation
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Las pestañas General, Error Reporting y Options del cuadro de diálogo Project Options
Resumen
Un proyecto existente o recién creado está asociado a una serie de opciones de configuración específicas de ese proyecto. Estas se almacenan en el archivo del proyecto (*.PrjPcb, por ejemplo) y varían según el tipo de proyecto. Las opciones se configuran en el cuadro de diálogo Project Options.
Acceso
Se puede acceder al cuadro de diálogo Project Options de una de las siguientes maneras:
- Haga clic con el botón derecho en la entrada del proyecto en el panel Projects y, a continuación, haga clic en Project Options en el menú contextual.
-
Haga clic en el icono
del panel Projects cuando el proyecto deseado esté seleccionado en el panel.
- Desde cualquier editor, seleccione Project » Project Options en los menús principales.
Pestañas del cuadro de diálogo
General

La pestaña General del cuadro de diálogo Project Options
La pestaña General del cuadro de diálogo Project Options permite controlar la disponibilidad en línea y la sincronización de un proyecto de un espacio de trabajo.
Opciones/Controles
Cuando se accede a esta pestaña para un proyecto sin estar conectado a su espacio de trabajo, la única opción disponible es el botón Turn Off Synchronization.
Cuando se accede a ella para un proyecto que no pertenece a un espacio de trabajo, la pestaña General del cuadro de diálogo Project Options solo mostrará el botón Make Project Available Online. Haga clic en el botón para abrir el cuadro de diálogo Hacer disponible en línea, que añadirá su proyecto al espacio de trabajo después de completar los pasos necesarios. Una vez finalizado el proceso, todas las opciones de la pestaña estarán disponibles.
General
- Description - utilice este campo para proporcionar una descripción opcional del proyecto, que se reflejará en el campo de descripción al explorar el proyecto en la interfaz web del espacio de trabajo.
Disponibilidad en línea y sincronización
-
Version Control - el estado de esta casilla refleja el modo actual de disponibilidad en línea. Active esta opción para almacenar este proyecto bajo control de versiones (VCS) en el repositorio de diseños Git Versioned Storage del espacio de trabajo, o desactívela para utilizar la sincronización simple. Activar el control formal de versiones permite que varios usuarios trabajen en el proyecto, lo que significa que se compartirá con todos los demás colaboradores conectados a su espacio de trabajo.
-
Migrate to Altium 365 Versioned Storage - active esta opción para migrar un proyecto que utilice un sistema VCS externo al VCS nativo del espacio de trabajo de Altium 365. El proyecto de diseño convertido, que conservará el historial previo de confirmaciones del VCS, podrá aprovechar las funciones del espacio de trabajo que utilizan el VCS nativo, como la cronología del historial basada en eventos. Esta opción solo está disponible para un proyecto reflejado.
-
Server Folder - la carpeta del espacio de trabajo en la que reside el proyecto.
-
Enable Conflict Prevention Notifications - active esta opción para gestionar el acceso a la edición de archivos mediante una alerta cuando un miembro del equipo esté editando el mismo documento de un proyecto del espacio de trabajo, con el fin de evitar posibles conflictos de datos.
-
Turn Off Synchronization - haga clic en este botón para desactivar la sincronización, de modo que la copia local del proyecto deje de estar vinculada a la que reside en el espacio de trabajo. El proyecto ubicado en el espacio de trabajo permanecerá intacto.
Requisitos
-
Link Requirements – si el bloque del portal de requisitos no está vinculado al proyecto de diseño, haga clic en este botón para abrir el cuadro de diálogo Link Requirements , desde el que puede seleccionar el bloque que se vinculará al proyecto.
-
Linked Requirements – si el bloque del portal de requisitos está vinculado al proyecto de diseño, esta entrada mostrará el bloque vinculado Haga clic en el enlace para cambiar la asignación actual entre el proyecto y el bloque. Haga clic en el botón Unlink para eliminar el vínculo.
Consulte la página Requisitos en un diseño para obtener más información.
Notificación de infracciones

La pestaña Error Reporting del cuadro de diálogo Project Options (para un proyecto de PCB)
La pestaña Error Reporting del cuadro de diálogo Project Options permite definir los niveles de notificación para cada una de las posibles infracciones eléctricas y de dibujo que puedan existir en los documentos esquemáticos de origen al validar el proyecto. Cuando se valide el proyecto, estos ajustes de infracciones se utilizarán junto con los ajustes de la pestaña Matriz de conexiones para comprobar si hay infracciones de conectividad en los documentos de origen.
Opciones/Controles
Lista de infracciones
Esta lista presenta todas las posibles infracciones eléctricas y de dibujo que pueden existir en los documentos de origen del proyecto. Las infracciones se agrupan en las siguientes categorías:
PCB Design:
Multi-board Design:
Harness Design:
Cada tipo específico de infracción se presenta con los siguientes campos:
- Violation Type Description - una breve descripción del tipo de infracción.
-
Report Mode - utilice este campo para especificar el nivel de gravedad asociado al incumplimiento de la comprobación. Utilice la lista desplegable para elegir entre los siguientes niveles de notificación:
-
Menú contextual
Los siguientes comandos están disponibles en el menú contextual:
- All Off - establezca Report Mode para todos los tipos de infracción en No Report.
- All Warning - establezca Report Mode para todos los tipos de infracción en Warning.
- All Error - establezca Report Mode para todos los tipos de infracción en Error.
- All Fatal - establezca Report Mode para todos los tipos de infracción en Fatal Error.
- Selected Off - establezca Report Mode para todos los tipos de infracción seleccionados en No Report.
- Selected To Warning - establezca Report Mode para todos los tipos de infracción seleccionados en Warning.
- Selected To Error - establezca el Report Mode de todos los tipos de infracción seleccionados en Error.
- Selected To Fatal - establezca el Report Mode de todos los tipos de infracción seleccionados en Fatal Error.
- Default - restablezca el Report Mode de todos los tipos de infracción a sus valores predeterminados.
- Report Suppressed Violations in Messages Panel - active esta opción para mostrar las infracciones en el panel Messages, incluso si se han suprimido a través de esta pestaña.
Opción adicional
- Set To Installation Defaults - haga clic para restablecer las opciones de la pestaña a los valores predeterminados de la instalación.
Matriz de conexiones

La pestaña Connection Matrix del cuadro de diálogo Project Options
La pestaña Connection Matrix del cuadro de diálogo Project Options ofrece una matriz que permite establecer reglas de conectividad entre los pines de los componentes y los identificadores de red, como los puertos y las entradas de hoja. Define las condiciones lógicas o eléctricas que deben notificarse como advertencias o errores. Por ejemplo, un pin de salida conectado a otro pin de salida normalmente se consideraría una condición de error, pero no dos pines pasivos conectados entre sí. Al validar el proyecto, se utilizará esta configuración de infracciones (junto con la configuración definida en la pestaña Notificación de errores) para comprobar si los documentos fuente presentan infracciones.
Opciones/Controles
Matriz de conexiones
La matriz presenta todas las comprobaciones posibles de conexiones de cableado entre combinaciones de pines, puertos y entradas de hoja, así como comprobaciones de elementos sin conectar. La matriz se lee por filas y columnas, y el color del elemento situado en la intersección de una fila y una columna especifica cómo responderá el compilador al comprobar esa condición concreta.
Para cambiar el modo de notificación de una comprobación de infracción en la matriz, haga clic en el cuadrado de color donde se cruzan la fila y la columna de dos elementos. Cada vez que haga clic, el modo pasará al siguiente nivel de notificación. Se admiten los siguientes niveles:
- No Report
- Warning
- Error
- Fatal Error
Menú contextual
Los siguientes comandos están disponibles en el menú contextual que aparece al hacer clic con el botón derecho:
- All Off - establezca todas las entradas de la matriz en No Report.
- All Warning - establezca todas las entradas de la matriz en Warning.
- All Error - establezca todas las entradas de la matriz en Error.
- All Fatal - establezca todas las entradas de la matriz en Fatal Error.
- Default - restablezca todas las entradas a sus valores predeterminados.
Opción adicional
- Set To Installation Defaults - haga clic para restablecer las opciones de la pestaña a los valores predeterminados de la instalación.
Generación de clases

La pestaña Class Generation del cuadro de diálogo Project Options
La pestaña Class Generation del cuadro de diálogo Project Options permite configurar y controlar la generación de clases. Las clases son conjuntos lógicos de un tipo concreto de objeto de diseño. Por ejemplo, un grupo de componentes relacionados podría agruparse en su propia clase de componentes, que luego podría utilizarse como base para crear una regla específica. Esta pestaña proporciona controles para determinar qué clases se generan automáticamente y qué clases definidas por el usuario se generan al sincronizar los documentos esquemáticos fuente con el documento de diseño de PCB.
Opciones/Controles
Clases generadas automáticamente
-
Generate Net Classes for Buses - marque esta opción para generar automáticamente una clase de redes para cada bus del diseño. Los miembros de una clase serán las redes individuales que componen el bus (a partir del cual se generó dicha clase).
-
Generate Net Classes for Components - marque esta opción para generar automáticamente una clase de redes para cada componente del diseño. Los miembros de una clase serán las redes asociadas a las que están conectados los pines del componente (a partir del cual se generó dicha clase).
-
Generate Separate Net Classes for Bus Sections - marque esta opción para generar automáticamente una clase de redes independiente para cada sección de bus. Una sección de bus se crea al especificar un bus que en realidad es una sección de otro más grande, por ejemplo,
D[15..8], del busD[15..0]. -
Generate Net Classes for Named Signal Harnesses - active esta opción para generar automáticamente una clase de redes para cada arnés de señales con nombre del diseño. Los miembros de una clase serán las redes asociadas a las señales agrupadas por el arnés de señales con nombre (a partir del cual se generó la clase).
-
Sheet-Level Class Generation Grid - esta sección permite controlar la generación automática de clases de componentes y/o de redes para cada hoja de esquemático. Se enumeran todas las hojas de esquemático fuente del proyecto y se presenta la siguiente información para cada una:
- Sheet Name - el nombre del documento de esquema.
- Full Path - la ruta absoluta de la carpeta en la que se encuentra el documento.
-
Component Classes - marque esta opción para generar una clase de componentes para la hoja.
- Generate Rooms - marque esta opción para generar una habitación para la clase de componentes.
-
Net Classes Scope - utilice este campo para determinar si se debe generar una clase de redes para la hoja y, en ese caso, el alcance de la generación. El menú desplegable del campo ofrece las siguientes opciones:
- None - no generar una clase de redes para esta hoja.
- Local Nets Only - generar una clase de redes para esta hoja, pero que solo contenga redes miembro locales de la hoja.
- All Nets - generar una clase de redes para esta hoja que contenga todas las redes miembro asociadas a la hoja (las locales y las que se extienden a otras hojas).
-
Structure Classes Generate Structure - marque esta opción para generar una clase de estructura para la hoja.
Una clase de estructura es un tipo especial de clase que puede incluir, como miembros, cualquier tipo de clase (clase de redes, clase de componentes, etc.). Al generar automáticamente una clase de estructura a partir de cada hoja de esquema del proyecto que contenga componentes y/o redes al transferir el diseño a la PCB, la estructura del proyecto puede representarse fielmente en la PCB. Las clases de estructura no solo permiten reproducir la estructura de los documentos de esquema en el entorno de PCB para facilitar una navegación avanzada, sino que también pueden utilizarse en consultas lógicas, por ejemplo, al definir el alcance de las reglas de diseño o al aplicar filtros.
Clases definidas por el usuario
- Generate Component Classes - marque esta opción para generar clases de componentes definidas por el usuario cuando el diseño se transfiera a la PCB. Las clases de componentes se definen manualmente en el esquema añadiendo un parámetro ClassName a los componentes deseados y estableciendo su valor en el nombre de clase deseado.
- Generate Rooms for Component Class - marque esta opción para generar habitaciones basadas en las clases de componentes definidas por el usuario. Estos componentes deben tener un parámetro de componente cuyo nombre sea 'ClassName'.
- Generate Net Classes - marque esta opción para generar clases de redes definidas por el usuario cuando el diseño se transfiera a la PCB. Las clases de redes se definen manualmente en el esquema mediante la directiva de clase de redes. Para que una red sea miembro de una clase de redes, adjunte una directiva de clase de redes al cable o bus correspondiente (o a una cobertura) y establezca el valor de su parámetro ClassName en el nombre de clase deseado.
► Aprenda a crear una clase de redes definida por el usuario
► Aprenda a crear una clase de componentes definida por el usuario
Opción adicional
- Set To Installation Defaults - haga clic para restablecer las opciones de la pestaña a los valores predeterminados de la instalación.
Notas
-
Para generar clases (automáticas y/o definidas por el usuario) al transferir el diseño a la PCB, debe asegurarse de que los ajustes correspondientes del comparador estén establecidos en Find Differences en la pestaña Comparador del cuadro de diálogo Project Options, de la siguiente manera:
- Clases de redes: establezca el tipo de comparación Extra Net Classes (en la categoría Differences Associated with Nets) en Find Differences.
- Clases de componentes: establezca el tipo de comparación Extra Component Classes (en la categoría Differences Associated with Components) en Find Differences.
-
Además, en la pestaña Generación de ECO del cuadro de diálogo Project Options , debe asegurarse de que los ajustes de ECO correspondientes estén establecidos en Generate Change Orders.
- Clases de redes: establezca el tipo de modificación Add Net Classes (en la categoría Modifications Associated with Nets) en Generate Change Orders.
- Clases de componentes: establezca el tipo de modificación Add Component Classes (en la categoría Modifications Associated with Components) en Generate Change Orders.
Comparador

La pestaña Comparator del cuadro de diálogo Project Options
La pestaña Comparator del cuadro de diálogo Project Options permite definir qué tipos de diferencias se deben buscar y cuáles se deben ignorar al comparar documentos. Para cada comparación posible, puede elegir entre buscar o ignorar las diferencias mediante el menú desplegable asociado en la columna Mode. Puede configurar la búsqueda de diferencias en componentes, redes, parámetros y objetos físicos según sea necesario.
Opciones/Controles
Este cuadro de diálogo se divide en dos regiones principales:
- La región superior, titulada Comparison Type Description/Mode, muestra la descripción y el modo de comparación de cada tipo de comparación disponible.
- La región inferior, titulada Object Matching Criteria, se utiliza para definir los criterios de correspondencia de Net, Net Class, Component Class, Differential Pair y Structure Class.
Descripción/Modo del tipo de comparación
- Comparison Type Description - esta región muestra las descripciones de cada tipo de comparación disponible en el proyecto. Utilice la barra de desplazamiento del extremo derecho para desplazarse hasta Differences Associated with Components, Differences Associated with Nets, Differences Associated with Parameters, Differences Associated with Physical y Differences Associated with Structure Classes para ver o cambiar los modos de comparación de cada área.
-
Mode - haga clic en una entrada para cambiar el modo de comparación mediante el menú desplegable:
-
Find Differences- seleccione esta opción para buscar diferencias dentro de ese tipo de comparación. -
Ignore Differences- seleccione esta opción para ignorar cualquier diferencia dentro de ese tipo de comparación (no se realizará ninguna comparación de ese tipo).
-
Criterios de correspondencia de objetos
- Object Type - lista de tipos de objetos, como Net, Net Class, Component Class, Differential Pair y Structure Class.
- Min Match % - introduzca el porcentaje mínimo de correspondencia deseado o haga clic en el lado derecho de la columna y, a continuación, utilice las teclas de flecha arriba y abajo para aumentar o disminuir el valor.
- Min Matched Members - introduzca el número mínimo deseado de miembros coincidentes o haga clic en el lado derecho de la columna y, a continuación, utilice las teclas de flecha arriba y abajo para aumentar o disminuir el valor.
- Use Name Matching - haga clic en la entrada o utilice el menú desplegable para seleccionar After member matching o Never.
- Show Manual Matching Dialog - haga clic en la entrada o utilice el menú desplegable para seleccionar For unmatched objects o Never.
Opciones adicionales
- Ignore Rules Defined in PCB Only - marque esta opción para ignorar las reglas definidas únicamente en la PCB dentro del proyecto de diseño. Por ejemplo, al realizar una orden de cambio de ingeniería, los cambios se pueden aplicar del esquema a la PCB y, si esta opción está activada, se ignoran las reglas que solo existen en la PCB. Si no hay reglas correspondientes en las hojas de esquema del mismo proyecto, el comparador no intentará añadir reglas nuevas.
- Set To Installation Defaults - haga clic para restablecer las opciones de la pestaña a los valores predeterminados de la instalación.
Generación de ECO

La pestaña ECO Generation del cuadro de diálogo Project Options
La pestaña ECO Generation del cuadro de diálogo Project Options permite configurar qué tipos de modificación se pueden incluir al generar una orden de cambio de ingeniería (ECO) basada en las diferencias encontradas por el comparador.
Opciones/Controles
Lista de tipos de modificación
Esta lista presenta todas las modificaciones posibles que se pueden realizar mediante una orden de cambio de ingeniería al sincronizar los documentos de esquema de origen con el documento de diseño de PCB. Las entradas de la lista incluyen categorías de tipos de modificación asociados con Components, Nets, Parameters, Structure Classes, etc.
Cada tipo de modificación específico incluye los siguientes campos:
- Modification Type Description – una breve descripción del tipo de modificación (la acción que debe realizar el sincronizador).
-
Mode – utilice este campo para controlar si el tipo de modificación se incluye o no en las ECO generadas. Utilice el menú desplegable para elegir entre las siguientes opciones:
- Generate Change Orders - incluir el tipo de modificación en una ECO generada.
- Ignore Differences - excluir el tipo de modificación de una ECO generada.
Menú contextual
El siguiente comando está disponible en el menú contextual que se abre al hacer clic con el botón derecho:
- Report – utilice este comando para generar un informe de los modos de modificación configurados actualmente. Aparecerá el cuadro de diálogo Report Preview con el informe ya cargado. Utilice este cuadro de diálogo para revisar el informe mediante los distintos controles de página y zoom antes de exportarlo a un archivo o imprimirlo.
Opciones adicionales
- Push Component Designator Changes to Annotation File (if any) – marque esta opción para incluir los cambios de designador de componente en el archivo de anotación.
- Set To Installation Defaults – haga clic para restablecer las opciones de la pestaña a los valores predeterminados de la instalación.
Opciones

La pestaña Options del cuadro de diálogo Project Options
La pestaña Options del cuadro de diálogo Project Options permite especificar la ruta de salida y las opciones relacionadas con las salidas generadas para el proyecto. También puede especificar diversas opciones de generación de netlists y el alcance de los identificadores de red.
Opciones/Controles
-
Output Path – la ruta de salida predeterminada para generar los archivos de salida del proyecto de diseño actual (
*.PrjPcb). - ECO Log Path – la ruta de salida predeterminada para los archivos de registro de ECO.
-
Schematic Template Location – utilice este campo para especificar el directorio del que se obtendrán los archivos de plantilla de esquema (
*.SchDot,*.SchDoc) para el proyecto.
Opciones de salida
- Open outputs after compile – active esta opción para abrir los archivos generados tras compilar el proyecto de diseño. Para un proyecto de paquete de biblioteca integrada, active la opción para instalar la biblioteca integrada después de compilar el proyecto de paquete.
-
Timestamp folder – active esta opción para crear una carpeta con marca de tiempo para la salida generada, como un informe de BOM (Reports » Bill of Materials). El nombre de la carpeta tiene el formato
<FolderName> Date Time, donde<FolderName>se especifica en el campo Output Path, yDateyTimetienen el mismo formato que el establecido en la configuración del sistema. - Archive project document – active esta opción para archivar el documento del proyecto. Por ejemplo, al generar las salidas de fabricación de un diseño de PCB (File » Fabrication Outputs y File » Assembly Outputs), la carpeta de salida de destino incluirá una copia del documento de PCB relacionado.
- Use separate folder for each output type – active esta opción para crear carpetas independientes para cada tipo de salida generado para el proyecto de diseño. Esta estructura de carpetas también se representará en el panel Projects.
Opciones de netlist
- Allow Ports to Name Nets – active esta opción para asignar un nombre a una red utilizando la propiedad Name de un puerto conectado, en lugar de utilizar un nombre de red predeterminado generado por el sistema.
- Allow Sheet Entries to Name Nets – active esta opción para asignar un nombre a una red utilizando el nombre de la entrada de hoja, en lugar de utilizar un nombre de red predeterminado generado por el sistema.
- Allow Single Pin Nets – active esta opción para permitir la existencia de redes que contengan un solo pin.
-
Append Sheet Numbers to Local Net – active esta opción para añadir el valor del parámetro Sheet Number de un documento de esquema (un parámetro a nivel de documento) a los nombres de las redes locales de esa hoja. Una red local es una red que no sale de la hoja. Esta opción no se aplica a una red que salga de la hoja (y que, por tanto, no sea local).
- Higher Level Names Take Priority – active esta opción para que las etiquetas de red utilizadas en las hojas superiores de la jerarquía den nombre a las redes de las hojas inferiores.
-
Power Port Names Take Priority – el software permite convertir una red de alimentación global en local conectando un puerto de alimentación a un puerto normal. Esto obliga a que todos los pines de esa hoja conectados a ese puerto de alimentación formen una red independiente. Al activar esta opción, se fuerza la asignación del nombre de la red utilizando el nombre de la red asignada al puerto de alimentación.
Alcance de los identificadores de red
Los diseños de varias hojas se definen a nivel eléctrico (o de conectividad) mediante identificadores de red. Los identificadores de red (etiquetas de red, puertos, entradas de hoja, puertos de alimentación y pines ocultos) crean conexiones lógicas entre puntos de una misma red. Estas conexiones pueden establecerse dentro de una hoja o entre varias hojas. Las conexiones físicas existen cuando un objeto está conectado directamente a otro objeto eléctrico mediante un cable. Las conexiones lógicas se crean cuando dos identificadores de red del mismo tipo (por ejemplo, dos etiquetas de red) tienen el mismo valor en la propiedad Net .
Al crear el modelo de conectividad del diseño, debe definir cómo desea que se conecten entre sí los identificadores de red; esto se conoce como configurar el Net Identifier Scope. Básicamente, existen dos formas de conectar las hojas en un diseño de varias hojas: horizontalmente, directamente de una hoja a otra y así sucesivamente, o verticalmente, desde una subhoja hasta el símbolo de hoja que la representa en la hoja superior. En la conectividad horizontal, las conexiones se establecen de puerto a puerto (también es posible conectar una etiqueta de red con otra). En la conectividad vertical, las conexiones se establecen entre una entrada de hoja y un puerto.
Utilice la lista desplegable para elegir entre los siguientes alcances:
-
Automatic (Based on project contents) – este modo selecciona automáticamente el modo de identificadores de red que se utilizará según los siguientes criterios: si hay entradas de hoja en la hoja de nivel superior, se utiliza Hierarchical; si no hay entradas de hoja, pero sí hay puertos, se utiliza Flat; si no hay entradas de hoja ni puertos, se utiliza Global.
- Flat (Only ports global) – los puertos se conectan globalmente entre todas las hojas del diseño. Con esta opción, las etiquetas de red son locales a cada hoja, es decir, no se conectan entre hojas. Todos los puertos con el mismo nombre se conectarán en todas las hojas. Esta opción puede utilizarse para diseños planos de varias hojas. No se recomienda para diseños grandes, ya que puede resultar difícil seguir una red a través de las hojas.
- Hierarchical (Sheet entry <-> port connections, power ports global) – establece conexiones verticales entre un puerto y la entrada de hoja correspondiente. Esta opción establece conexiones entre hojas únicamente mediante las entradas de los símbolos de hoja y los puertos correspondientes de las subhojas. Utiliza los puertos de las hojas para llevar las redes o los buses hasta las entradas de hoja de los símbolos de hoja correspondientes en la hoja superior. Los puertos sin una entrada de hoja correspondiente no se conectarán, aunque exista un puerto con el mismo nombre en otra hoja. Las etiquetas de red son locales a cada hoja, es decir, no se conectan entre hojas. Sin embargo, los puertos de alimentación son globales: todos los puertos de alimentación con el mismo nombre se conectan en todo el diseño. Esta opción permite crear diseños con cualquier profundidad o jerarquía y seguir una red por todo el diseño en el esquema impreso.
- Strict Hierarchical (Sheet entry <-> port connections, power ports local) – este modo de conectividad funciona de la misma manera que el modo Hierarchical , con la diferencia de que los puertos de alimentación se mantienen locales a cada hoja, es decir, no se conectan con puertos de alimentación del mismo nombre en otras hojas.
- Global (Netlabels and ports global) – los puertos y las etiquetas de red se conectan entre todas las hojas del diseño. Con esta opción, todas las redes con la misma etiqueta de red se conectarán entre sí en todas las hojas. Asimismo, todos los puertos con el mismo nombre se conectarán en todas las hojas. Si una red conectada a un puerto también tiene una etiqueta de red, el nombre de la red será el de la etiqueta de red. Esta opción también puede utilizarse para diseños planos de varias hojas; sin embargo, resulta difícil seguir una red de una hoja a otra, ya que no siempre es fácil localizar visualmente los nombres de las redes en el esquema.
Permitir el intercambio de pines mediante estos métodos
En el editor de PCB, los intercambios de pines, pares diferenciales y partes se realizan intercambiando las redes de los pads de los componentes y su cobre correspondiente. Cuando los cambios se incorporan a los esquemas, el intercambio de pines puede gestionarse de dos maneras:
-
Adding / Removing Net-Labels – active esta opción para permitir el intercambio de pines en el símbolo de un componente. El intercambio en el esquema mediante el intercambio de etiquetas de red solo puede realizarse si la conectividad se establece a través de las etiquetas de red, es decir, si los pines no están conectados directamente entre sí mediante cables.
-
Changing Schematic Pins – active esta opción para permitir el intercambio de etiquetas de red en los cables conectados a los pines de un componente. El intercambio de pines será la única opción disponible cuando las redes estén conectadas físicamente a un componente mediante cables. Este método puede utilizarse con componentes sencillos (como una matriz de resistencias) o cuando no exista otra alternativa debido a la estructura del diseño del esquema.
General
- Automatic Sheet Numbering – active esta opción para numerar automáticamente las hojas del esquema de este proyecto. Esto permite controlar la designación de las hojas y almacenarlas como parámetros en los documentos de esquema correspondientes.
-
Automatic Cross References – active esta opción para añadir automáticamente información de referencias cruzadas de puertos, conectores entre hojas y entradas de hoja a todos los documentos de esquema de origen del proyecto activo. Esta función ayuda a seguir la conectividad de las redes en un diseño no jerárquico.
- New Indexing of Sheet Symbols – active esta opción para utilizar cualquier dígito o número como índice inicial o final de un símbolo de hoja repetido, incluido el 0. No se permiten números negativos. El índice final siempre debe ser mayor que el índice inicial.
Referencias cruzadas
-
Sheet Style – elija uno de los siguientes estilos de hoja para las referencias cruzadas de los puertos en una hoja de esquema o en las hojas de esquema de un proyecto.
-
None– no se añade ningún estilo de hoja a la cadena de referencia cruzada de los puertos. -
Name– los nombres de las hojas a las que están vinculados los puertos se añaden a las cadenas de referencia cruzada. -
Number– los números de las hojas a las que están vinculados los puertos se añaden a las cadenas de referencia cruzada.
-
-
Location Style – elija uno de los siguientes estilos de ubicación para las referencias cruzadas de los puertos en una hoja de esquema o en las hojas de esquema de un proyecto.
-
None– no se añade ningún estilo de ubicación a la cadena de referencia cruzada de los puertos. -
Zone– la numeración de las zonas de referencia (las zonas se encuentran en los bordes de la hoja) se añade a las cadenas de referencia cruzada de todos los puertos asociados a los objetos superiores, como la ubicación de los símbolos de hoja. -
Location X,Y– las ubicaciones de los puertos se muestran entre paréntesis en las cadenas de referencia cruzada de todos los puertos asociados a los objetos superiores, como la ubicación de los símbolos de hoja.
-
- Follow Cross References settings in Preferences – cuando esta opción está habilitada, los valores de las opciones Sheet Style y Location Style se heredarán de las opciones de la sección Port Cross References de la página Esquema – General del cuadro de diálogo Preferences.
-
Display Cross References for:
-
Ports – utilice la lista desplegable para seleccionar el modo de visualización de las referencias cruzadas de los puertos.
-
Disabled– no se añade ninguna referencia cruzada a los puertos. -
Only Related Sheet Entry– muestra la referencia cruzada a la entrada de hoja asociada en la hoja de esquema superior. -
Only Related Ports– muestra las referencias cruzadas a los puertos asociados. -
Sheet Entry & Ports– muestra las referencias cruzadas tanto a la entrada de hoja como a los puertos.
-
- Off-sheet Connectors – habilite esta opción para mostrar las referencias cruzadas de los objetos de conector fuera de hoja.
- Sheet Entries – habilite esta opción para mostrar las referencias cruzadas de los objetos de entrada de hoja.
-
Ports – utilice la lista desplegable para seleccionar el modo de visualización de las referencias cruzadas de los puertos.
Pares diferenciales
-
Custom Diff Pair Suffix Grid – enumera los sufijos predeterminados de los pares diferenciales (
_P/_N) y todos los sufijos personalizados definidos para pares diferenciales, en términos de:- Positive Suffix – el sufijo de la red positiva de un par diferencial.
- Negative Suffix – el sufijo de la red negativa de un par diferencial.
- Add – haga clic para añadir un nuevo par de sufijos a la lista.
- Remove – haga clic para eliminar de la lista los pares de sufijos seleccionados.
Creación de xNets
- Sources/Destinations – defina una lista de prefijos separados por comas para los designadores de los componentes que se pueden utilizar como componentes de origen o destino en las xNets.
- Discretes – defina una lista de prefijos separados por comas para los designadores de los componentes que se pueden utilizar como componentes en serie en las xNets.
Multicanal

La pestaña Multi-Channel del cuadro de diálogo Project Options
La pestaña Multi-Channel del cuadro de diálogo Project Options permite definir el esquema de nomenclatura de las rooms y el formato de los designadores de componentes para su uso en diseños multicanal. El diseño multicanal permite hacer referencia varias veces a la misma subhoja dentro del proyecto. Esto se puede hacer colocando varios símbolos de hoja que hagan referencia a la misma subhoja o incluyendo la palabra clave Repeat en el designador de un símbolo de hoja para crear varias instancias de este.
Altium Designer ofrece un verdadero diseño multicanal, lo que significa que puede hacer referencia repetidamente a una misma hoja dentro de un proyecto. Los cambios necesarios se pueden aplicar en un único lugar y, al recompilar el proyecto, se propagan a cada instancia. Altium Designer no solo admite varios canales, sino que también permite anidarlos.
La correspondencia entre un único componente lógico del esquema y sus múltiples instancias físicas en la PCB se controla mediante el esquema de designadores multicanal definido en esta pestaña.
Opciones/Controles
Nomenclatura de las rooms
-
Room Naming Style - utilice este campo para especificar el estilo que se utilizará para nombrar las rooms. Al seleccionar un estilo de la lista, la imagen inferior se actualiza para reflejar la convención de nomenclatura que aparecerá en el diseño. Al compilar el diseño, se crea una room para cada hoja del diseño, incluidos cada banco y cada canal de nivel inferior. Hay cinco estilos disponibles: dos planos y tres jerárquicos (los que incluyen la ruta):
- Flat Numeric With Names
- Flat Alpha With Names
- Numeric Name Path
- Alpha Name Path
- Mixed Name Path
-
Level Separator for Paths - utilice este campo para especificar el carácter o símbolo necesario para separar la información de la ruta al utilizar los estilos de nomenclatura jerárquicos (los que incluyen la ruta). De forma predeterminada, se utilizará el guion bajo (_).
- Preview - a medida que se realizan cambios en Room Naming Style y/o Designator Format, la imagen de esta sección se actualiza dinámicamente para reflejar la convención de nomenclatura que aparecerá en el diseño. La imagen muestra un ejemplo de un diseño de canales anidados de 2 x 2. Las áreas más grandes con trama cruzada representan los dos canales de nivel superior (o bancos), y las áreas sombreadas de su interior representan los canales de nivel inferior (con dos componentes de ejemplo en cada uno).
Nomenclatura de los componentes
-
Designator Format - utilice este campo para especificar el formato utilizado al asignar designadores a los componentes del diseño. La lista desplegable del campo ofrece los siguientes ocho formatos predefinidos: cinco planos y tres que pueden utilizarse en un contexto jerárquico (que incluyen la nomenclatura de los canales):
- $Component_$RoomName
- $RoomName_$Component
- $Component$ChannelAlpha
- $Component_$ChannelPrefix$ChannelAlpha
- $Component_$ChannelIndex
- $Component_$ChannelPrefix$ChannelIndex
- $ComponentPrefix_$ChannelIndex_$ComponentIndex
- $ComponentPrefix_$RoomName_$ComponentIndex
Definir su propio formato de designador
También puede definir su propio formato de designador de componentes escribiendo directamente en el campo Designator Format. Al crear la cadena de formato, puede utilizar las siguientes palabras clave:
- $RoomName - es el nombre del canal asociado según el estilo elegido en el campo Room Naming Style .
- $Component- es el designador lógico del componente.
- $ComponentPrefix - es el prefijo del designador lógico del componente (p. ej., U para U1).
- $ComponentIndex - es el índice del designador lógico del componente (p. ej., 1 para U1).
- $ChannelPrefix - es el designador lógico del símbolo de hoja.
- $ChannelIndex - es el índice del canal.
- $ChannelAlpha - es el índice del canal expresado como un carácter.
Notas
- La indexación alfabética de un canal solo resulta realmente útil si el diseño contiene menos de 26 canales en total o si utiliza un formato de designador de naturaleza jerárquica.
- En un diseño multicanal, se muestran pestañas en la parte inferior de la hoja de esquemático en la ventana de diseño, una por cada canal (o banco). Los nombres de las pestañas se componen de los nombres de los símbolos de hoja más el número de canal, p. ej., BANKA. Estas son las vistas compiladas (vistas físicas) del diseño, mientras que el diseño lógico permanece como antes en la pestaña Editor.
Impresiones predeterminadas

La pestaña Default Prints del cuadro de diálogo Project Options
La pestaña Default Prints del cuadro de diálogo Project Options permite configurar las salidas de impresión predeterminadas para varios editores de Altium Designer. Estos valores predeterminados son los que se utilizan al ejecutar los siguientes comandos de impresión desde los menús principales de los editores:
- File » Print
- File » Print Preview » Print
También se puede acceder a la pestaña Default Prints del cuadro de diálogo Project Options desde el editor de esquemáticos y el editor de PCB, seleccionando el comando File » Default Prints en los menús principales.
Opciones/Controles
El área principal de la pestaña presenta una lista de todas las salidas de impresión compatibles que pueden generarse desde los editores de esquemáticos y PCB. Los tipos de salida se agrupan en las siguientes categorías:
-
Assembly Outputs -
Documentation Outputs -
Fabrication Outputs -
Other Outputs -
Report Outputs -
Validation Outputs
Para cada entrada, se muestra la siguiente información:
- Output Description – qué se genera al utilizar este tipo de salida de impresión.
- Supports – el editor que admite este tipo de salida de impresión.
-
Default Print – indica si este tipo de salida de impresión se utilizará como tipo de impresión predeterminado (habilitado) o no (deshabilitado).
Opciones adicionales
-
Configure – haga clic en este botón para acceder a un cuadro de diálogo asociado con el que configurar la salida de impresión seleccionada. Los cuadros de diálogo disponibles incluyen:
- Cuadro de diálogo Imprimir – para configurar planos de ensamblaje, plano compuesto, impresiones de PCB, impresiones de PCBLIB, impresiones de esquemáticos, plano compuesto de taladrado, plano/guías de taladrado, impresiones del arte final, impresiones de planos de alimentación e impresiones de máscaras de soldadura/pasta.
- Cuadro de diálogo Configuración de impresión 3D de PCB – para configurar impresiones 3D de PCB.
- Cuadro de diálogo Vídeo 3D de PCB – para configurar salidas de vídeo 3D de PCB.
- Cuadro de diálogo PDF3D – para configurar salidas PDF3D y PDF3D MBA.
- Cuadro de diálogo Propiedades avanzadas de impresión de texto – para configurar impresiones de informes y de texto. Defina las opciones de la salida impresa (p. ej., el encabezado y la numeración de páginas/líneas). También puede especificar que se utilice una fuente determinada.
- Wave Print Properties Form cuadro de diálogo – para configurar impresiones de SimView.
- Cuadro de diálogo Configuración del informe de apilado de capas – para configurar las salidas de informes de apilado de la placa.
- Cuadro de diálogo Administrador de informes – para configurar informes de lista de materiales y de comparación de BOM.
- Cuadro de diálogo Configuración de exportación de comentarios – para configurar un informe de exportación de comentarios.
- Cuadro de diálogo Configuración de diferencias – para configurar un informe de diferencias.
- Cuadro de diálogo Configuración de comprobación de reglas eléctricas – para configurar un informe de validación de la comprobación de reglas eléctricas.
- Page Setup – haga clic para acceder a un cuadro de diálogo de configuración de página para la salida de impresión seleccionada. En este cuadro de diálogo, puede configurar la impresión con la impresora elegida en cuanto a papel, escala y color. También puede acceder al cuadro de diálogo de configuración correspondiente y al cuadro de diálogo de configuración de la impresora, obtener una vista previa de la impresión y, finalmente, imprimir la salida en la impresora seleccionada.
Rutas de búsqueda

La pestaña Search Paths del cuadro de diálogo Project Options
La pestaña Search Paths del cuadro de diálogo Project Options permite especificar las rutas de búsqueda de los archivos de bibliotecas y modelos del proyecto.
Opciones/Controles
Lista ordenada de rutas de búsqueda
Esta cuadrícula muestra la lista ordenada de rutas de búsqueda de archivos de bibliotecas y modelos (p. ej., bibliotecas de huellas de PCB, modelos de simulación e integridad de señal). Para cada ruta, puede especificar el filtro y los ajustes de búsqueda recursiva.
- Path - ubicación de la ruta de búsqueda.
- Filter - el filtro de búsqueda. De forma predeterminada, el filtro busca todos los archivos.
- Recursive - marque esta opción para buscar en todos los subdirectorios del directorio de la ruta de búsqueda. Haga doble clic en una ruta de búsqueda para editarla.
- Add - utilícelo para abrir el cuadro de diálogo Edit Search Path y añadir una nueva ruta de búsqueda.
Se admiten los siguientes tipos de archivos: bibliotecas de huellas (*.PcbLib), archivos de modelos de simulación (*.mdl), archivos de subcircuitos de simulación (*.ckt) y archivos de modelos IBIS (*.ibs).
- Delete - utilícelo para eliminar una ruta de búsqueda seleccionada.
- Properties - utilícelo para acceder al cuadro de diálogo Edit Search Path y editar las propiedades de la ruta de búsqueda seleccionada.
- Move Up - utilícelo para subir una línea la ruta de búsqueda seleccionada.
- Move Down - utilícelo para bajar una línea la ruta de búsqueda seleccionada.
Archivos encontrados en todas las rutas de búsqueda
Esta cuadrícula muestra los archivos de bibliotecas y modelos que se encuentran en las rutas de la lista Ordered List of Search Paths. Utilice el botón Refresh List para ver una lista actualizada.
Parámetros

La pestaña Parameters del cuadro de diálogo Project Options
La pestaña Parameters del cuadro de diálogo Project Options le permite gestionar los parámetros definidos para el proyecto, a menudo denominados project-level parameters. Los parámetros definidos a nivel de proyecto están disponibles para su uso en todas las hojas de esquemático y documentos PCB del proyecto mediante cadenas especiales: =<ProjectParameterName> en un esquemático (p. ej., =Project) y .<ProjectParameterName> en una PCB (p. ej., .Project). Los parámetros pueden utilizarse para proporcionar información adicional sobre el diseño. Los parámetros a nivel de proyecto, por ejemplo, pueden utilizarse de forma global como fuente de datos paramétricos de cadenas especiales que se añaden a las hojas de esquemático y/o al documento PCB; este último no admite parámetros locales.
Los parámetros del proyecto del lado del Workspace se guardan en el Workspace junto con el proyecto y solo pueden editarse desde la interfaz de navegador del Workspace (obtenga más información sobre Editing a Project en Altium 356 Workspace o On-Prem Enterprise Workspace). Por el contrario, los parámetros del proyecto del lado del diseño se guardan en el archivo del proyecto (*.PrjPcb) y pueden editarse en Altium Designer. Los parámetros del proyecto del lado del Workspace aparecen en la pestaña Parameter del cuadro de diálogo Project Options con un icono azul , mientras que los parámetros del proyecto del lado del diseño aparecen con un icono naranja
Opciones/Controles
-
Parameters Grid – la región principal muestra todos los parámetros definidos actualmente para el proyecto, con los siguientes atributos:
- Name – el nombre del parámetro.
- Value – el valor del parámetro.
-
Add – haga clic para abrir el cuadro de diálogo Parameter Properties, donde puede añadir un parámetro. Utilice los campos Name y Value para asignar al parámetro un nombre significativo que refleje su propósito y su valor, respectivamente. Ambos campos admiten un máximo de 255 caracteres.
- Remove – haga clic para eliminar los parámetros seleccionados de la lista de parámetros. Esta opción no está disponible para los parámetros del proyecto del lado del Workspace, ya que solo pueden eliminarse o editarse en el Workspace.
- Edit – haga clic para abrir el cuadro de diálogo Parameter Properties, donde puede modificar el contenido del parámetro seleccionado actualmente. Esta opción no está disponible para los parámetros del proyecto del lado del Workspace, ya que solo pueden eliminarse o editarse en el Workspace.
- Refresh – haga clic para revertir los últimos cambios realizados en el parámetro del proyecto del lado del diseño. En el caso de los parámetros del proyecto del lado del Workspace, haga clic para asegurarse de disponer de la versión más reciente del parámetro. Los cambios realizados en los parámetros del proyecto del lado del Workspace dentro del Workspace no se reflejarán en este cuadro de diálogo hasta que se utilice esta opción.
Menú contextual
Los siguientes comandos están disponibles en el menú contextual:
-
Edit – utilícelo para modificar el parámetro seleccionado actualmente en el cuadro de diálogo Parameter Properties. Este comando no está disponible para los parámetros del proyecto del lado del Workspace, ya que solo pueden eliminarse o editarse en el Workspace.
-
Add – utilícelo para añadir un nuevo parámetro del lado del diseño a la lista en el cuadro de diálogo Parameter Properties.
-
Remove – utilice esta opción para eliminar los parámetros seleccionados de la lista. Este comando no está disponible para los parámetros de proyecto del Workspace, ya que solo se pueden eliminar o editar en el Workspace.
-
Copy – utilice esta opción para copiar los parámetros seleccionados al portapapeles de Windows.
-
Paste – utilice esta opción para pegar los parámetros del portapapeles de Windows en la lista de parámetros. Este comando no está disponible para los parámetros de proyecto del Workspace, ya que solo se pueden eliminar o editar en el Workspace.
Hojas de dispositivo

La pestaña Device Sheets del cuadro de diálogo Project Options
La pestaña Device Sheets del cuadro de diálogo Project Options permite especificar las carpetas en las que se pueden encontrar las hojas de dispositivo y su orden.
Opciones/Controles
- Main region - muestra las Device Sheet Folders rutas del proyecto actual. Marque Include Sub-folders para incluir las subcarpetas de las carpetas principales de la lista.
- Move Up - utilice esta opción para subir la carpeta de hojas de dispositivo seleccionada un nivel cada vez.
- Move Down - utilice esta opción para bajar la carpeta de hojas de dispositivo seleccionada un nivel cada vez.
- Add - utilice esta opción para abrir un cuadro de diálogo y buscar una nueva carpeta que añadir.
- Remove - utilice esta opción para eliminar la carpeta de hojas de dispositivo seleccionada.
Trabajos de salida gestionados

La pestaña Managed OutputJobs del cuadro de diálogo Project Options
La pestaña Managed OutputJobs del cuadro de diálogo Project Options permite configurar una lista de plantillas de trabajos de salida disponibles a través del Workspace al que está conectado para utilizarlas con el proyecto.
Opciones/Controles
- Outputjob List - muestra todos los trabajos de salida del Workspace en términos de Item Revision, Revision State, Description y Name.
- Add - haga clic para abrir el cuadro de diálogo Select configuration item (Output Jobs) y seleccionar los trabajos de salida deseados.
- Remove - haga clic para eliminar los trabajos de salida seleccionados.
Opciones de biblioteca

La pestaña Library Options del cuadro de diálogo Project Options
La pestaña Library Options del cuadro de diálogo Project Options permite seleccionar el formato de un proyecto de biblioteca integrada.
Opciones/Controles
-
Integrated Library Format
- Original - seleccione esta opción para utilizar el formato original de biblioteca integrada. Se utiliza para garantizar la compatibilidad con el software Protel DXP (DXP 2002), anterior a la aparición de Altium Designer.
-
Altium Designer- seleccione esta opción para utilizar Altium Designer como formato de biblioteca integrada (utilizado en todas las versiones del software desde el Altium Designer 2004 original).
).
