Importación de bibliotecas existentes a su Connected Workspace

De un vistazo

Incorpora tus bibliotecas de componentes existentes a tu Workspace conectado con el Importador de bibliotecas de Altium Designer. Este artículo explica cómo el modo Simple del importador automatiza las importaciones habituales y cómo el modo Avanzado te ofrece un mayor control sobre los tipos de componentes, los parámetros y la configuración de importación. También aborda los formatos de biblioteca compatibles, los datos que se transfieren y las comprobaciones de validación que ayudan a identificar problemas de importación. Sigue leyendo para encontrar el método de importación que mejor se adapte a tus bibliotecas y dar el siguiente paso hacia una gestión centralizada de componentes.

- Aprende a acceder al Importador de bibliotecas y a elegir entre los modos Simple y Avanzado.
- Descubre qué bibliotecas y datos de componentes se pueden importar, así como las principales limitaciones.
- Explora las vistas previas de importación, la clasificación de componentes, la configuración de parámetros y los informes para revisar y optimizar tus importaciones.
Profundiza con IA:

Altium Designer, junto con su espacio de trabajo conectado, ofrece un proceso simplificado y altamente automatizado para importar rápidamente sus bibliotecas existentes a ese espacio de trabajo. La interfaz de este proceso, Library Importer , ofrece una solución de un solo clic que analiza automáticamente las bibliotecas seleccionadas y las importa al espacio de trabajo al que está conectado actualmente.

Compatible con todos los tipos de bibliotecas relacionados con metodologías anteriores de gestión de componentes (SchLib, PcbLib, IntLib, DbLib, SVNDbLib), el importador de bibliotecas es una solución específica para crear rápidamente la biblioteca de componentes del espacio de trabajo de su empresa y aprovechar sus numerosas ventajas: almacenamiento y gestión centralizados de alta integridad, facilidad para reutilizar diseños e información de la cadena de suministro en tiempo real.

El importador de bibliotecas ofrece un modo de interfaz Simple minimalista en el que las bibliotecas de componentes seleccionadas, basadas en archivos y bases de datos, se importan como componentes del espacio de trabajo en un solo paso, mientras que el importador se encarga automáticamente de la clasificación por tipo, la carpeta de origen de destino, la inclusión de parámetros y el tipo de valor, así como de la transferencia de todos los datos pertinentes. La interfaz también está disponible en un modo Advanced que proporciona una vista previa completa de la importación de bibliotecas propuesta y acceso a los datos y ajustes relacionados. Y, aunque de forma predeterminada la importación se realiza con un solo clic, el importador también ofrece opciones de configuración avanzadas a través del panel Properties para controlar con mayor precisión cómo se realiza la importación.

¿Qué se importa?

Toda la información presente en una biblioteca de origen se importa a los componentes del espacio de trabajo , incluidos todos los modelos de dominio referenciados (símbolos de esquemático, huellas de PCB, modelos de simulación), información paramétrica, opciones de piezas asignadas, archivos de hojas de datos, etc. También se crean plantillas de componentes cuando es necesario, que posteriormente pueden perfeccionarse y utilizarse en futuras importaciones de bibliotecas.

Si sus componentes originales tienen varias huellas de PCB definidas, el importador de bibliotecas transferirá esos modelos y conservará la huella predeterminada actual. Y si solo trabaja con bibliotecas de PCB, porque únicamente le interesa el diseño de PCB, el importador de bibliotecas permite importar solo esas bibliotecas, o bien cambiar a un modo de importación exclusivo de modelos en el que se importan los tipos de modelos especificados desde bibliotecas integradas o de bases de datos. Las bibliotecas que incluyen varios tipos de componentes (bibliotecas monolíticas) también se detectan y procesan automáticamente.

Aunque el proceso de importación de bibliotecas debe trabajar con bibliotecas de origen basadas en archivos y bases de datos que pueden utilizar distintos estándares de formato, sus procesos de análisis automatizado detectan los tipos de componentes de la biblioteca de origen (resistencia, condensador, etc.), así como los nombres de los parámetros y sus tipos de valor (voltios, ohmios, etc.). El sistema realiza y gestiona una serie de validaciones, por ejemplo, para garantizar que no haya identificadores duplicados en los componentes de la biblioteca del espacio de trabajo resultante, que no se creen modelos ni plantillas de componentes duplicados y que dichas entidades se reutilicen entre los componentes (vinculándose a ellos) cuando sea necesario. Si surgen problemas, el sistema los señala y ofrece sugerencias para resolverlos, con el objetivo de que la importación vuelva a desarrollarse con normalidad lo antes posible y sin contratiempos.

Los tipos de bibliotecas que se pueden importar son:

  • Biblioteca de esquemáticos (*.SchLib).

  • Biblioteca de huellas de PCB (*.PcbLib).

  • Biblioteca integrada (*.IntLib)

  • Biblioteca de base de datos (*.DbLib).

  • Biblioteca de base de datos SVN (*.SVNDbLib).

Actualmente no se admite la importación de información de asignación de pines (para modelos de simulación).

Acceso al importador de bibliotecas

El importador de bibliotecas está disponible cuando está conectado a un espacio de trabajo. Para acceder al importador en su modo Simple :

  • En el panel Components, elija la opción Import Library del menú  . Si hay una biblioteca basada en archivos o en una base de datos seleccionada en la columna Categories del panel (o en el menú desplegable superior cuando el panel está en modo compacto), el importador de bibliotecas se abrirá para esa biblioteca. Cuando se selecciona un tipo de componente de la biblioteca del espacio de trabajo, se abre el cuadro de diálogo estándar de Windows Open para buscar y seleccionar el archivo de biblioteca que se va a importar.

    Las bibliotecas basadas en archivos y bases de datos disponibles actualmente en el software se pueden consultar y gestionar en el cuadro de diálogo Libraries Preferences, al que se accede desde la opción Libraries Preferences del menú del botón  en el panel Components.

    También puede consultar y gestionar las bibliotecas basadas en archivos instaladas actualmente en la página Data Management – File-based Libraries del cuadro de diálogo Preferences.

  • Haga clic con el botón derecho en un archivo de biblioteca en el panel Projects y seleccione Import Library en el menú contextual.

  • Seleccione Tools » Import Library en el editor de símbolos de esquemático o de huellas de PCB cuando haya un archivo de biblioteca local abierto.

  • Seleccione File » Import Library o Tools » Import Library en el editor de bibliotecas de bases de datos.

  • En el cuadro de diálogo Libraries Preferences, seleccione una entrada de biblioteca en la pestaña Installed y, a continuación, haga clic en el control Import .

  • Arrastre y suelte un archivo de biblioteca desde una carpeta de Windows en el panel Explorer.

El modo Simple ofrece opciones para importar inmediatamente la biblioteca seleccionada () o abrir el importador de bibliotecas en su modo de interfaz gráfica completo ().

El importador de bibliotecas al acceder a él en su modo de importación con un solo clic Simple.
El importador de bibliotecas al acceder a él en su modo de importación con un solo clic Simple.

Para acceder directamente al importador de bibliotecas en su modo de interfaz Advanced, seleccione File » Library Importer en el menú principal.

El importador de bibliotecas, al acceder a él en su modo de interfaz completo Advanced, también permite realizar la importación con un solo clic.
El importador de bibliotecas, al acceder a él en su modo de interfaz completo Advanced, también permite realizar la importación con un solo clic.

Modo Simple

El modo Simple del importador de bibliotecas preselecciona todos los aspectos del proceso de importación a partir de su análisis de la biblioteca de origen y del espacio de trabajo conectado. A continuación, el cuadro de diálogo Library Importer presenta un resumen de la estructura de importación, incluido el número total de elementos de cada tipo. La importación de la biblioteca se realiza en un solo paso mediante el comando .

Este modo de interfaz Simple se adapta a los formatos de bibliotecas de origen más habituales, que suelen contener tipos de componentes comunes (resistencias, condensadores, circuitos integrados, etc.) y valores de parámetros estandarizados. Durante el proceso de análisis inicial, el sistema deduce el tipo de componentes de la biblioteca a partir del designador o de palabras clave de los parámetros (LD?, LED, etc.) y, a continuación, localiza una plantilla de componentes correspondiente en el espacio de trabajo de destino (LED). Esta plantilla se aplica a la importación de esos componentes y define los ajustes de importación, como la carpeta de destino (Components/LED), la asignación de parámetros, las unidades de los valores de los parámetros, etc. El espacio de trabajo incluye plantillas adecuadas si se seleccionó la opción de incluir datos de ejemplo durante la activación de un espacio de trabajo de Altium 365 o la instalación de Altium On-Prem Enterprise Server.

Los resultados de la importación de bibliotecas, en forma de componentes recién creados en el espacio de trabajo, se pueden ver tanto en el panel Explorador como en el panel Componentes. Los componentes importados incluyen todos los modelos, los parámetros interpretados según las plantillas de componentes aplicadas, las opciones de piezas derivadas de los datos de origen de los enlaces de proveedores y cualquier enlace o archivo de referencia.

Las plantillas de componentes creadas por el Importador de bibliotecas se encuentran en la carpeta Managed Content\Templates\Component Templates del panel Explorador.

Si por algún motivo —como un resultado de importación insatisfactorio— desea eliminar un conjunto de componentes, puede eliminar de forma completa los seleccionados en el panel Componentes eligiendo la opción Delete en el menú contextual que aparece al hacer clic con el botón derecho. Junto con los componentes seleccionados, también se pueden eliminar sus modelos asociados (si no los utilizan otros componentes).

Los aspectos más destacados del proceso de importación de bibliotecas son:

  • Las bibliotecas monolíticas (aquellas que contienen varios tipos de componentes) se dividen automáticamente en subgrupos, donde cada grupo representa un tipo de componente encontrado en esa biblioteca. Los grupos se procesan como bibliotecas individuales.

  • Una biblioteca de origen con un tipo de componente no reconocible (no detectado) se importará sin interpretación, con tipos de componentes sin asignar, a una carpeta Components/Uncategorized del espacio de trabajo. Antes de ejecutar la importación, esto se puede resolver aplicando la asignación de designadores o la agrupación por parámetros en el modo Advanced (interfaz completa). También puede continuar con la importación y modificar después la configuración y la carpeta del componente a través del panel Explorador.
  • El proceso de importación de bibliotecas incluye una etapa automática de validación de componentes. Los componentes que generen un error de validación se omitirán.
  • Si se detectan modelos duplicados en la biblioteca de origen que se va a importar, solo se importará uno de esos modelos, que se vinculará a los componentes resultantes en el espacio de trabajo de destino. Se mostrará la notificación correspondiente en la parte superior del cuadro de diálogo Library Importer.
  • Los errores encontrados durante el proceso se pueden consultar en Importing Report, disponible mediante el botón una vez completada la importación.

Modo avanzado

La interfaz gráfica completa del Importador de bibliotecas se muestra en el modo Advanced, que ofrece un control detallado de la gestión de bibliotecas, tipos de componentes y parámetros de componentes. En combinación con el panel Propiedades, permite configurar la importación de bibliotecas de componentes al espacio de trabajo según sus necesidades específicas. Tenga en cuenta que la configuración del importador se puede guardar y restaurar mediante la exportación e importación de archivos de configuración.

El modo avanzado se activa al abrir el Importador de bibliotecas mediante el comando File » Library Importer o al seleccionar el botón desde el modo simple. Las bibliotecas se añaden a la sección SOURCE LIBRARIES del importador (si aún no contiene bibliotecas) arrastrando y soltando un archivo de biblioteca en el área, haciendo clic con el botón derecho en <All Libraries> y seleccionando Add Library en el menú contextual, o seleccionando el botón .

La sección Import Preview enumera los grupos de tipos de componentes identificados en las bibliotecas de origen, como Types () o el Folder Structure propuesto (), e incluye una vista de tabla basada en parámetros de esos componentes (Components). Los valores de los parámetros de la tabla se pueden editar directamente, lo que evita tener que abrir y editar la biblioteca de origen. El área inferior Details incluye información adicional procedente del componente seleccionado: opciones de piezas, modelos y hojas de datos.

Puede cambiar el tipo de componente haciendo clic con el botón derecho en un tipo de la lista Types y seleccionando el comando Change Component Type.

Independientemente de las opciones detalladas y los datos que se muestran en la interfaz, la vista avanzada del importador se puede utilizar del mismo modo que la vista simple: basta con hacer clic en el botón para iniciar el proceso de importación, sin necesidad de intervenir. Al igual que en el proceso de la vista simple, el importador habrá analizado la biblioteca, deducido el tipo de componentes que contiene y aplicado la plantilla de componentes correcta. A su vez, la plantilla determina la carpeta de destino en el espacio de trabajo, los esquemas de nomenclatura y las definiciones de ciclo de vida aplicados, así como la asignación e interpretación de los parámetros.

  • Utilice el botón (arriba a la izquierda) para actualizar el Importador de bibliotecas. Esto volverá a cargar todas las bibliotecas de origen y los datos del espacio de trabajo para incorporar los cambios que se hayan producido desde que se abrió el importador.
  • Utilice el campo de búsqueda (arriba a la derecha) para filtrar las entradas de componentes según un valor de parámetro coincidente.

Bibliotecas monolíticas

Las rutinas de análisis del importador detectan las bibliotecas de origen que contienen varios tipos de componentes y las dividen en grupos de subbibliotecas, que se pueden procesar como bibliotecas de tipos individuales. La detección del tipo de componente se basa en los designadores de los componentes de origen (R?, C?, etc.) y también en las palabras clave (Resistor, Res, etc.) contenidas en los demás parámetros principales del componente (descripción, ID, etc.).

En el ejemplo que se muestra a continuación, la biblioteca de origen (ProjectABC.IntLib) se ha «dividido» automáticamente según los tipos de componentes detectados (condensadores, resistencias, etc.), que se pueden seleccionar en la columna Folder Structure (o en la columna Types) para obtener una vista previa de las entradas de los componentes que los integran en la tabla Components.

Los tipos de componentes que aún no existen en el espacio de trabajo, pero que se crearán durante el proceso de importación, se identifican con el icono .

Tenga en cuenta que la presentación de la lista Components se puede modificar de varias formas:

  • Haga clic en el encabezado de una columna para ordenar la lista según ese parámetro y vuelva a hacer clic para invertir el orden.

  • En el menú contextual que aparece al hacer clic con el botón derecho en el encabezado:

    • Seleccione Clear Sorting para restablecer el orden predeterminado de la lista (por la columna Name en orden ascendente).

    • Seleccione Best Fit para ajustar el ancho de una columna concreta a su contenido.

    • Seleccione Select Best Fit All Columns para ajustar todas las columnas disponibles al ancho de su contenido.

    • Seleccione Select Columns para acceder al cuadro de diálogo Select Columns, donde puede activar o desactivar las columnas de parámetros y cambiar su posición en la lista.

  • Haga clic en el icono de filtro () del encabezado para limitar la lista a un valor de parámetro disponible en la columna, a valores vacíos o no vacíos, o a una configuración de filtro Custom. El filtro aplicado se muestra en la parte inferior de la lista, donde se puede activar o desactivar (mediante su casilla de verificación asociada), modificar en Filter Editor o eliminar. Si selecciona All mediante el icono de filtro del encabezado (), también se eliminará el filtro aplicado.

Componentes sin categoría

Si una entrada de subgrupo de bibliotecas se denomina Uncategorized (y aparece como Uncategorized en Types o Folder Structure y va acompañada de  icono), esto indica que el importador no ha podido detectar y asignar un tipo a ese grupo de componentes: el tipo de componente queda establecido en None. En este caso, los componentes no detectados (CI de lógica inversora) utilizan un prefijo de designador no reconocido (U?) y sus parámetros no contienen palabras clave detectadas como IC, logic, etc.

Si se ejecuta la importación, los componentes se importan como un tipo sin categorizar, sin interpretación. Sin embargo, si se incluyen parámetros clave o estándar (como Resistance, Capacitance, Tolerance, etc.), el importador les asignará automáticamente un tipo de unidad de parámetro adecuado (Ohm, Farad, Percent, etc.).

Este problema se puede resolver asignando manualmente los designadores utilizados para esos componentes al tipo de componente deseado en el cuadro de diálogo Library Splitting, al que se accede desde el botón , disponible cuando se selecciona la biblioteca de origen (ProjectABC.IntLib). El cuadro de diálogo Library Splitting, con los valores predeterminados, ofrece controles para establecer opciones personalizadas de agrupación de bibliotecas para los componentes sin categorizar, basadas en la asignación de designadores por tipo de componente y en la división según parámetros.

Con la opción Map Designators  del cuadro de diálogo seleccionada, elija el tipo de componente que corresponda a los componentes sin categorizar en la lista desplegable Component Type (se incluyen todos los tipos de componentes disponibles). Confirme la asignación de tipo a designadores (el tipo de componente Logic a los designadores U?) con el botón .

Una vez especificado el tipo de componente mediante la asignación aplicada, el importador utilizará la plantilla de componente correspondiente (Logic) para configurar la importación de la biblioteca según los ajustes de la plantilla (carpeta, nomenclatura, etc.).

  • El cuadro de diálogo Library Splitting también incluye la opción de agrupar los componentes divididos según el valor de un parámetro especificado (por ejemplo, de un parámetro Category o Component_Type), si este está definido en la biblioteca de origen. Para ello, seleccione la opción Parameter Grouping del cuadro de diálogo y, a continuación, un parámetro adecuado en el menú desplegable.
  • Como alternativa, el tipo de componente de una biblioteca se puede seleccionar manualmente en la sección General del panel Propiedades.
  • Para cambiar el tipo de componente de una entrada individual de la lista Components, haga clic en su celda Component Type y elija otro tipo en el menú desplegable, o haga clic con el botón derecho en el tipo de componente y seleccione Change Component Type en el menú contextual.

Tenga en cuenta que, gracias a la flexibilidad de los ajustes del importador de bibliotecas, se puede importar un nuevo tipo de biblioteca de componentes (sin categorizar) con toda la infraestructura necesaria para futuras importaciones de ese tipo de biblioteca. Al elegir una configuración de importación adecuada —nuevo tipo de componente, plantilla de componente, carpeta de destino, asignación de parámetros y tipos de unidad para los valores de los parámetros—, el único requisito para la siguiente importación de ese tipo de biblioteca será seleccionar el tipo de componente definido previamente. El tipo de componente seleccionado determinará entonces todos los demás aspectos de la importación.

Excluir del importador

También puede excluir tipos de componentes específicos de la importación. Para excluir un tipo de componente, haga clic con el botón derecho en el tipo de componente que desee excluir en la lista Types y seleccione Exclude from Importer en el menú contextual. Si lo desea, cambie la lista de la columna de Folder Structure a Types ().

El tipo de componente excluido aparecerá atenuado en la lista Types. Para ver los componentes excluidos en la cuadrícula, haga clic en Show Excluded Component (n), donde n indica el número de componentes excluidos.

Incluir en el importador

Si ha excluido un tipo de componente de la importación mediante el comando Exclude from Importer descrito anteriormente y finalmente necesita incluirlo, haga clic con el botón derecho en el tipo de componente atenuado de la lista Types (o Folder Structure) y seleccione Include to Importer en el menú contextual. El tipo de componente volverá a aparecer en la lista Types, lo que indica que no está excluido.

Errores y advertencias de validación

Los componentes que no se importarán correctamente al espacio de trabajo, o que no se importarán en absoluto, se indican mediante etiquetas de advertencia o error en la interfaz avanzada al ejecutar el importador de bibliotecas () o realizar una validación de la importación (). La validación también comprueba si hay rutas de carpetas del espacio de trabajo vacías, parámetros de sistema en conflicto y modelos duplicados. Un error fatal bloqueará la importación.

Al intentar realizar la importación, el panel Messages muestra las infracciones detectadas y un cuadro de diálogo ofrece la opción de cancelar o continuar con la configuración de importación actual. En este último caso, los componentes no válidos no se importarán o el proceso de importación fallará.

Si se cancela una importación o se ejecuta la validación manual, los componentes que no superen las comprobaciones de importación se asociarán con iconos de error o advertencia e información adicional en el área inferior Details. Los iconos de la columna de vista previa Status indican las entradas de componentes específicas que incumplen las reglas de comprobación de la importación.

A continuación se enumeran las comprobaciones de validación predefinidas disponibles.

Las comprobaciones definidas por el usuario se configuran en la sección Import Checks del panel Properties. Utilice el menú desplegable Report Mode para elegir un nivel de notificación diferente para el tipo de infracción asociado. Estas comprobaciones se enumeran a continuación.

Resolución de errores y advertencias

Los errores de parámetros, como el del ejemplo que se muestra aquí, en el que el valor Forward Voltage del componente no se puede interpretar como una tensión válida, se pueden resolver de las siguientes maneras:

  • Editando el valor del parámetro que causa el problema: localice y edite su celda para que tenga un formato válido.

  • Cambiando la unidad del parámetro asignado Type, determinada por la plantilla de componente aplicada, de Voltage a sin interpretar Text: seleccione la biblioteca de origen en la interfaz del importador y, a continuación, cambie Forward Voltage Type en la lista del panel Propiedades Parameter Mapping (en la pestaña General).

  • Eliminando el componente del proceso de importación: haga clic con el botón derecho en su entrada y elija la opción Exclude from Importer .

Un error de archivo ausente, como el archivo de hoja de datos que no se puede localizar y que se muestra aquí, se puede resolver de las siguientes maneras:

  • La solución evidente es localizar el archivo ausente y restaurarlo en la ubicación esperada.
  • Desactivando la importación de archivos de hojas de datos: cambie la opción Migrate en la sección del panel Propiedades Datasheet (en la pestaña Advanced).
  • Excluyendo el componente del proceso de importación de la biblioteca, como se ha descrito anteriormente.

Utilice el campo Search (arriba a la derecha) si desea buscar entradas de componentes específicas. La búsqueda filtra la lista de elementos según los valores de parámetros coincidentes para el tipo de componente seleccionado actualmente: seleccione All en Types (Folder Structure) para que la búsqueda se aplique a todos los componentes de las bibliotecas de origen disponibles.

Importación de bibliotecas de esquemáticos

Si encuentra un error de «modelo no encontrado» (como Footprint <footprint name> not found in available libraries) al intentar importar una biblioteca de esquemáticos, significa que el importador de bibliotecas no puede localizar los modelos vinculados a los componentes del archivo SCHLIB.

En el modo simple, estos errores se mostrarán en el Importing Report basado en HTML, al que se accede mediante el botón , disponible una vez ejecutada la importación. En el modo avanzado, los errores se indican mediante iconos de estado en la interfaz principal () y como entradas en el panel Messages; esto ocurre al realizar una comprobación de validación () o al intentar importar la biblioteca ().

El proceso de validación detecta correctamente las huellas ausentes y también ofrece una opción Choose a Library en su informe de errores (en el menú desplegable Details). Si se detecta que falta la huella de más de un componente, un cuadro de diálogo Apply PcbLib Selection ofrece opciones para utilizar la PcbLib especificada en este caso o para todos los componentes con huellas ausentes.

Otra forma de resolver (o evitar) este problema es asegurarse de que los archivos de biblioteca de modelos necesarios estén disponibles desde Altium Designer. Las bibliotecas se instalan a través de la página Gestión de datos – Bibliotecas basadas en archivos del cuadro de diálogo Preferences.

Como alternativa, si no desea instalar varias bibliotecas de modelos, deberá colocarlas en la ruta de bibliotecas predeterminada del software (o editar la ruta) y comprobar que la biblioteca de origen de los modelos esté especificada para los componentes de la biblioteca de esquemáticos:

  • Incluya la biblioteca de modelos en la ubicación de la ruta de búsqueda predeterminada del software. Añada la biblioteca de modelos, como una biblioteca de PCB correspondiente, a la ubicación especificada por la ruta de bibliotecas predeterminada del sistema. Para comprobar esta ubicación, consulte la entrada Library Path en la página Sistema – Ubicaciones predeterminadas del cuadro de diálogo Preferences. Si se ha añadido o copiado un archivo de biblioteca en esa ubicación, es posible que deba reiniciar Altium Designer para registrar el cambio.
  • Especifique el nombre de la biblioteca de modelos de destino para los componentes de la biblioteca de esquemáticos. Para que el importador de bibliotecas reconozca la biblioteca de modelos vinculada a un componente de una biblioteca de esquemáticos, especifique su nombre en el cuadro de diálogo Modelo de PCB de la biblioteca.

Tenga en cuenta que no es necesario, ni siquiera recomendable, importar una biblioteca de PCB junto con su biblioteca de esquemáticos correspondiente, ya que el propio importador de bibliotecas se encargará de importar y vincular los modelos necesarios. El proceso de importación identifica, localiza y transfiere los modelos correctos de cada componente para crear un componente unificado en el espacio de trabajo de destino.

Detección de duplicados

El importador de bibliotecas también incluye mecanismos para evitar que se creen componentes duplicados en el espacio de trabajo de destino. Esto se consigue durante la validación comparando los parámetros de identificación de los componentes y las opciones de piezas de la biblioteca de origen con los de los componentes del espacio de trabajo de destino y de las bibliotecas de origen que se van a importar. Con la configuración predeterminada del importador, un paso de validación () mostrará un mensaje Warning cuando se detecte una misma entrada Name o Part Choices de componente (lo que indica un posible componente duplicado). El mensaje de advertencia o error mostrado incluye el tipo de infracción por duplicación (parámetro u opción de pieza), el nombre del componente de biblioteca que causa la infracción y el componente (por su ID) con el que entra en conflicto.

Dos posibles duplicados detectados por el proceso de validación, en los que el Name del componente (imagen superior) o su Part Choice (imagen inferior) ya existen en componentes del espacio de trabajo.
Dos posibles duplicados detectados por el proceso de validación, en los que el Name del componente (imagen superior) o su Part Choice (imagen inferior) ya existen en componentes del espacio de trabajo.

El par nombre-valor del parámetro utilizado para detectar infracciones por duplicación se especifica en la sección Duplicates Detection del panel Properties, en la pestaña Advanced. Utilice el menú desplegable Unique Field (establecido en Name de forma predeterminada) para seleccionar uno de los parámetros disponibles en la biblioteca de origen. Esta selección resulta especialmente útil para las configuraciones de bibliotecas de empresa que utilizan un campo de identificación propio vinculado al sistema empresarial general.

Una infracción por duplicación detectada cuando el valor de un parámetro especificado (ERP-REF) es el mismo para un componente de la biblioteca local y un componente del espacio de trabajo.
Una infracción por duplicación detectada cuando el valor de un parámetro especificado (ERP-REF) es el mismo para un componente de la biblioteca local y un componente del espacio de trabajo.

Se puede establecer un tipo diferente de indicador de estado para las infracciones por duplicación seleccionando un Report Mode alternativo en la sección Import Checks, en la pestaña General del panel Properties.

La detección de duplicados también se realiza en los modelos de símbolos de los componentes. Si los componentes que se van a importar tienen modelos de símbolos con la misma geometría en las bibliotecas de origen, solo se importará uno de estos modelos.

Esta función está disponible cuando la opción LibraryMigrator.DuplicatedModelCheck está habilitada en el cuadro de diálogo Configuración avanzada.

Bibliotecas de modelo único

La detección automática de duplicados también se utiliza para procesar bibliotecas de origen que usan un modelo de símbolo común para todos los componentes. Estas bibliotecas suelen estar compuestas por un único tipo de componente con distintos estilos y valores, como resistencias de un formato de encapsulado concreto, en las que el símbolo de cada una es una representación gráfica estándar.

El importador de bibliotecas detecta esta situación de modelo único y común y configura la importación para transferir un modelo de símbolo que se aplica a todos los componentes importados, en lugar de un símbolo correspondiente con un nombre individual para cada componente. El símbolo que se va a importar adopta el nombre de uno de los símbolos que se van a importar, y todos los parámetros de los componentes permanecen sin cambios.

El símbolo de biblioteca importado (que tiene el nombre genérico y el campo Descripción vacío) se puede editar según sus necesidades. En el panel Componentes, utilice la opción Edit del menú contextual para ejecutar la acción. Durante el proceso, seleccione la opción Update items related to <symbol ID> en el cuadro de diálogo Create Revisions for Item para asegurarse de que los componentes importados utilicen la nueva revisión del símbolo.

Combinar tipos de componentes

El conjunto de tipos de componentes registrados en el sistema —o, en la práctica, en el espacio de trabajo conectado— se puede consultar y gestionar en la página Gestión de datos – Tipos de componentes del cuadro de diálogo Preferences. Los tipos se muestran con su Template de componente y su Folder del espacio de trabajo asociados, e incluirán los nuevos tipos creados cuando el importador de bibliotecas haya importado archivos de biblioteca al espacio de trabajo.

La creación de varios tipos de componentes nuevos suele producirse cuando una configuración del importador de bibliotecas ha utilizado la agrupación por parámetros (el valor de un parámetro de componente designado) para determinar el tipo de cada componente importado. Por ejemplo, el parámetro Categories podría ser Resistor-0608 para un conjunto de componentes importados y Resistor-0402 para otro, y así sucesivamente. En este caso, lo más conveniente sería agruparlos todos en un único tipo de componente Resistors para su uso futuro.

En lugar de cambiar manualmente todos los tipos de componentes en estas circunstancias, la página Tipos de componentes de Preferences permite combinar las entradas de tipo seleccionadas en una única entrada especificada. Para obtener más información, consulte la sección Combinar tipos de componentes de la página Tipos de componentes.

El resultado de esta combinación es que, cuando se elija Resistors como tipo de componente importado en el importador de bibliotecas, se aplicará si selecciona cualquiera de las plantillas combinadas (Resistor_0402, etc.) como alternativa.

Importación solo de modelos

El importador de bibliotecas se puede cambiar a un modo de importación especial Models Only que detecta y procesa los modelos de componentes disponibles en una biblioteca de origen.

Esta función está disponible cuando la opción LibraryMigrator.ModelsOnlyMode está habilitada en el cuadro de diálogo Configuración avanzada.

En el modo Solo modelos, el proceso de análisis del importador detectará todos los modelos de símbolos, huellas y simulación disponibles en una biblioteca de origen (IntLib, SchLib, PcbLib, etc.) y, a continuación, importará esos modelos al espacio de trabajo utilizando las ubicaciones, los esquemas de nomenclatura y las definiciones de ciclo de vida predeterminados del sistema.

Cuando el importador de bibliotecas se cambia al modo avanzado () o se abre en dicho modo (File » Library Importer), se muestran todos los detalles de la importación de modelos propuesta. La sección Import Preview muestra el Folder Structure que se utilizará en el espacio de trabajo de destino, que puede modificarse respecto a la configuración predeterminada en el campo Folder de cada tipo de modelo en el panel Properties. Los esquemas de nomenclatura y la definición de ciclo de vida aplicados a cada modelo se pueden seleccionar entre los tipos disponibles en el sistema (consulte Panel Propiedades, a continuación).

Si lo desea, la importación de modelos de componentes al espacio de trabajo se puede limitar por tipo, deshabilitando (o habilitando) tipos de modelos específicos en el panel Properties mediante sus botones asociados.

Una vez configurado el importador de bibliotecas, seleccione el botón para completar la importación de los modelos de componentes enumerados. Los resultados se pueden revisar en el archivo de registro de importación, al que se puede acceder desde el cuadro de diálogo de progreso Library Importer (), o consultando los modelos importados en el panel Componentes.

Importación solo de componentes

De forma similar al modo de importación Models Only descrito anteriormente, el importador de bibliotecas se puede cambiar a un modo de importación especial Components Only que permite importar los componentes disponibles en una biblioteca de origen sin sus modelos vinculados.

Esta función está disponible cuando la opción LibraryMigrator.ReleaseComponentsWithoutModels está habilitada en el cuadro de diálogo Configuración avanzada.

En el modo Solo componentes, el proceso de análisis del importador detectará todos los componentes, parámetros y opciones de piezas de una biblioteca de origen y, a continuación, importará estos componentes al espacio de trabajo utilizando la ubicación, el esquema de nomenclatura y la definición de ciclo de vida predeterminados del sistema.

Cuando el importador de bibliotecas se cambia a su modo avanzado () o se abre en dicho modo (File » Library Importer), se muestran todos los detalles de la importación de componentes propuesta. La carpeta aplicada, los esquemas de nomenclatura y la definición del ciclo de vida se pueden seleccionar entre los tipos disponibles en el sistema (consulte el panel Properties, más abajo).

Una vez configurado el importador de bibliotecas, seleccione el botón para completar la importación de los componentes enumerados. Solo se crearán elementos de componentes en el espacio de trabajo, sin modelos vinculados. Los resultados se pueden revisar en el archivo de registro de importación, disponible en el cuadro de diálogo de progreso Library Importer (), o consultando los componentes importados en el panel Components. 

Panel Properties

Los ajustes del panel Properties asociado al importador de bibliotecas proporcionan un control avanzado de la configuración de importación de la biblioteca seleccionada (o del grupo de subbibliotecas). Se puede acceder al panel desde el modo avanzado del importador de bibliotecas seleccionando la opción Properties en el menú del botón  (en la parte inferior derecha del espacio de diseño), haciendo clic en el botón  situado en la parte superior derecha de la vista del importador de bibliotecas, o haciendo clic en el botón  situado junto a <All Libraries> o a una entrada de categoría específica en la lista Source Libraries.

Los ajustes de las opciones del panel se definen mediante los ajustes predeterminados del sistema o los especificados por la plantilla de componentes aplicada, que a su vez viene determinada por el tipo de componente detectado en la biblioteca: LED en el ejemplo que se muestra aquí. El usuario también puede editar los ajustes para adaptar el proceso de importación según sea necesario, y puede restaurarlos mediante el enlace Reset to Default (arriba a la derecha).

Las secciones de la pestaña General del panel son las siguientes:

  • General:
    • Component Type – el tipo de componente detectado por el importador para la biblioteca seleccionada y, por asociación, la plantilla que se aplica (consulte Component Template más abajo). Para sustituir este ajuste, edite el campo, lo que creará un nuevo tipo de componente, o seleccione otro tipo mediante las opciones del menú desplegable (o mediante el botón ); esta es otra forma de resolver un problema de componente sin categorizar. Elija la opción [LibraryName] para establecer el nombre de la biblioteca seleccionada como tipo.
    • Component Template – la plantilla de componentes del espacio de trabajo que se aplicará a los componentes importados y, por asociación, su ajuste de tipo de componente. Para sustituir este ajuste, seleccione otra plantilla mediante las opciones del menú desplegable (o mediante el botón ). Establezca esta opción en [Create new] para crear automáticamente una plantilla a partir de los parámetros de la biblioteca de origen y de los ajustes actuales del importador de bibliotecas, o elija [No Template] para impedir que se aplique o cree una plantilla.

      Tenga en cuenta que los ajustes Component Type y Component Template están vinculados entre sí cuando se selecciona un tipo o una plantilla disponible; por ejemplo, si cualquiera de ellos se establece en Capacitors, el otro se establece automáticamente en Capacitors. Sin embargo, si en este caso el ajuste Component Template se cambia a [Create New], se creará otra plantilla Capacitors (con un sufijo de versión/revisión adecuado en el nombre) para ajustarse a la configuración actual. El proceso de importación no modifica las plantillas de componentes existentes.
  • Parameter Mapping – la correspondencia entre los parámetros de la biblioteca y los de la plantilla de componentes aplicada (o los ajustes predeterminados cuando no hay ninguna plantilla disponible), así como el tipo de valor de cada parámetro (texto o un tipo compatible con unidades). Utilice las opciones del menú desplegable de la columna Source Library Parameter para cambiar la asignación, y las opciones del menú de la columna Type para sustituir el ajuste existente determinado por la plantilla o los valores predeterminados. Elija la opción <Skip> para no incluir un parámetro. Cualquier parámetro que no se haya asociado automáticamente con un parámetro de la biblioteca de origen (el sistema lo establece en <Skip>) se puede asignar manualmente a un parámetro adecuado de la plantilla; por ejemplo, se podría seleccionar el parámetro de origen ROHS para que se corresponda con el parámetro RoHS Compliant definido por la plantilla del espacio de trabajo. Los nombres de los parámetros se pueden editar, y los conjuntos de parámetros se pueden añadir, editar y eliminar. Los parámetros básicos del componente (ID, Name, Description) se pueden reasignar, pero por lo demás son de solo lectura.

    Para el parámetro del espacio de trabajo ID, el parámetro de la biblioteca de origen se establece en <Auto>. Esto hace que los identificadores de los componentes se creen automáticamente según el Naming Template especificado en la sección Component del panel, que se encuentra en la pestaña Advanced. La asignación de identificadores se puede cambiar para utilizar cualquier parámetro de la biblioteca de origen (que sea único para cada entrada de componente), eligiendo otra opción en el menú desplegable del parámetro de la biblioteca de origen. Tenga en cuenta que los parámetros básicos del componente (ID, Name, Description) se pueden reasignar, pero por lo demás son de solo lectura.
  • Part Choice Mapping – la lista de parámetros de piezas de fabricante o de enlaces a proveedores reconocidos por el importador, que se utilizarán para generar entradas de opciones de piezas para los componentes importados. Utilice las opciones del menú desplegable para redefinir la asignación, o añada y elimine conjuntos de asignaciones. Tenga en cuenta que, de forma predeterminada, los parámetros de piezas de fabricante y de enlaces a proveedores no se incluyen (se omiten) en el proceso de importación. Cuando un componente de biblioteca incluye varios enlaces a proveedores, se utiliza la referencia del proveedor principal (Supplier 1 / Supplier Part Number 1) para las entradas de los campos de opciones de piezas.
  • Import Checks – permite ver o establecer la respuesta de error o advertencia del importador ante incumplimientos de las reglas de validación de importación. Utilice el menú desplegable Report Mode para cambiar la respuesta y el icono de una entrada Violation Type. Tenga en cuenta que, si se selecciona el modo de notificación Fatal Error, el proceso de importación se bloqueará cuando se detecte este incumplimiento.

La pestaña Advanced del panel ofrece ajustes para todos los elementos de objetos de datos del importador, según los valores predeterminados del sistema o la plantilla de componentes aplicada. Estos incluyen modelos de componentes, archivos de hojas de datos y cualquier plantilla de componentes creada. A excepción de la opción Datasheet (un control de activación/desactivación), los ajustes de cada objeto de importación incluyen:

  • Folder – la carpeta de destino del espacio de trabajo para el objeto importado, que se puede editar manualmente (por ejemplo, para crear una nueva carpeta de destino) o seleccionar mediante el botón de exploración ().
  • Naming Scheme – la especificación de nomenclatura del objeto en el espacio de trabajo, definida por la plantilla de componentes o, si no hay una plantilla activa, el esquema establecido para la carpeta de destino (o el introducido manualmente). Utilice el menú desplegable para elegir entre los esquemas de nomenclatura disponibles. Tenga en cuenta que un cambio en la ruta de la carpeta de destino (Folder) puede ir acompañado de un cambio en el esquema de nomenclatura aplicado, según lo establecido por la propia carpeta o por una plantilla de componentes aplicada o asociada.
  • Revision Naming Scheme – el esquema de nomenclatura utilizado para las revisiones del objeto en el espacio de trabajo, según lo establecido por la plantilla aplicada o lo seleccionado en las opciones del menú desplegable de la entrada. Solo estarán disponibles como opción los esquemas habilitados por el sistema.
  • Lifecycle Definition – el sistema de ciclo de vida que se utiliza para el objeto, según lo establecido por la plantilla aplicada o lo seleccionado entre las opciones del menú desplegable de la entrada. Solo estarán disponibles como opción las definiciones habilitadas por el sistema.
La sección del objeto Component incluye el ajuste de Duplicates Detection, como se ha descrito anteriormente.

Exportación e importación de la configuración

El importador de bibliotecas permite exportar un archivo de texto detallado que recoge la configuración actual e incluye todos los ajustes de importación configurables, como las rutas de destino, la asignación de parámetros, el esquema de nomenclatura, las definiciones de ciclo de vida, los tipos de componentes de destino, etc.

El archivo de configuración del importador se guarda mediante el comando File » Export » Importer Config como un archivo de tipo *.lmcfg y puede restaurarse en cualquier momento mediante la opción de menú File » Import » Importer Config .

La posibilidad de restaurar una configuración resulta especialmente útil cuando se ha actualizado la base de datos de origen o la biblioteca basada en archivos y es necesario importar esos cambios al espacio de trabajo. Si la configuración se exportó al importar la biblioteca por primera vez, la configuración restaurada (importada) restablecerá exactamente los ajustes utilizados, lo que garantiza un esquema de transferencia de datos coherente para esa biblioteca (o bibliotecas).

Tenga en cuenta que un archivo de configuración del importador exportado (guardado) incluye referencias a los archivos de biblioteca que estaban abiertos como bibliotecas de origen cuando se exportó la configuración. Cuando ese archivo de configuración del importador se importa posteriormente (se vuelve a cargar), una o más de las bibliotecas a las que hace referencia la configuración deben estar disponibles; es decir, deben estar disponibles en ese momento como bibliotecas de origen en el importador de bibliotecas.
AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents