Creazione del documento BOM
A colpo d'occhio
- Imparerai a creare un BomDoc, scoprirai cosa succede quando viene aggiunto a un progetto e conoscerai il limite fondamentale di un solo BomDoc per progetto.
- Vedrai come è organizzato l'elenco delle voci della distinta base, comprese le modalità di visualizzazione, i controlli delle colonne, gli strumenti di modifica, le modalità di raggruppamento e le opzioni di configurazione della visualizzazione.
- Capirai come ActiveBOM gestisce i componenti raggruppati e le voci personalizzate della distinta base, così da includere sia i componenti del progetto sia gli elementi aggiuntivi.
Creazione del documento BOM
Il documento BOM di lavoro di ActiveBOM è denominato BomDoc. Aggiungi un nuovo BomDoc al progetto tramite il sottomenu File » New oppure facendo clic con il pulsante destro del mouse sul progetto nel pannello Projects. Quando nel progetto è presente almeno un componente, è possibile creare un nuovo BomDoc facendo clic sul controllo + Create accanto alla voce ActiveBOM nella struttura del progetto nel pannello Projects. Tieni presente che ogni progetto PCB può includere un solo BomDoc.
Quando aggiungi un nuovo BomDoc al progetto, lo schema viene compilato automaticamente e tutti i componenti esistenti vengono elencati nel BomDoc. Per i componenti della libreria del Workspace che includono scelte del componente, le soluzioni vengono descritte in dettaglio nella parte inferiore dell'interfaccia, come illustrato nella sezione Comprendere la soluzione più avanti.
Man mano che vengono posizionati altri componenti sullo schema, questi vengono aggiunti automaticamente al BomDoc. È inoltre possibile aggiungere manualmente altre voci BOM e altri parametri direttamente in ActiveBOM tramite il pulsante Add new situato sopra l'elenco dei componenti. Per ulteriori informazioni, consulta la sezione Voci e colonne BOM personalizzate.
L'elenco delle voci BOM
La parte superiore del BomDoc contiene un elenco tabellare di tutti i componenti rilevati nel progetto PCB, oltre alle voci BOM aggiunte direttamente nel BomDoc. Questa area è denominata elenco delle voci BOM.

L'elenco dei componenti, o delle voci BOM, visualizzato nella vista Base.
Sono disponibili 3 modalità di visualizzazione delle voci BOM. Seleziona la modalità desiderata utilizzando i pulsanti sopra l'elenco:
Flat view - una riga per ogni componente.
Base view - una riga per ciascun componente univoco nel progetto; la colonna Designatore elenca i designatori di tutti i componenti di questo tipo. Sono disponibili diverse opzioni di presentazione per i designatori raggruppati. Seleziona la modalità Designator Grouping desiderata nel pannello Properties.
Consolidated view - utilizzata quando il progetto include varianti, per visualizzare una BOM consolidata per tutte le varianti.
Funzionalità di modifica dell'elenco delle voci BOM
L'elenco dei componenti supporta diverse funzionalità di modifica simili a quelle di un foglio di calcolo, tra cui:
- Utilizza la scheda Column del pannello Properties per mostrare/nascondere una colonna e definirne un alias. È possibile definire un alias anche tramite la finestra di dialogo Inserisci proprietà colonna, accessibile facendo clic con il pulsante destro del mouse sul nome di una colonna nell'area delle intestazioni delle colonne del BomDoc e selezionando il comando Rename Column dal menu contestuale. Tieni presente che l'alias viene utilizzato come nome della colonna negli output BOM generati.
-
È inoltre possibile aggiungere e rimuovere colonne tramite la finestra di dialogo Select Columns, accessibile facendo clic con il pulsante destro del mouse sul nome di una colonna nell'area delle intestazioni delle colonne del BomDoc e scegliendo Select Columns.

La finestra di dialogo Select ColumnsOpzioni/Controlli della finestra di dialogo Seleziona colonne
- Search - digita dei caratteri nel campo per filtrare l'elenco delle colonne, mostrando solo quelle il cui nome include i caratteri digitati.
-
Visibility column - consente di controllare se una colonna di ActiveBOM è visibile nel documento ActiveBOM (
*.BomDoc). Fai clic sull'icona a forma di occhio per mostrare o nascondere una colonna. Le colonne visibili sono sempre elencate nella parte superiore della finestra di dialogo nell'ordine in cui appaiono nel BomDoc. -
Data Source column - mostra l'origine dati della colonna. Le origini dati supportate includono:
-
- voci aggiunte direttamente alla BOM
-
- parametri dei componenti dello schema
-
- parametri dei componenti del Workspace
-
- parametri del database collegato (DbLink, DbLib)
-
- parametri del documento schematico
-
- Altium Cloud Services
-
- Column Name - mostra il nome dell'origine dati, che viene visualizzato come nome della colonna nel BomDoc.
- Up / Down - consente di spostare la colonna attualmente selezionata verso l'alto o verso il basso nell'elenco. Di conseguenza, la colonna si sposterà a sinistra o a destra nel BomDoc quando si fa clic su OK. Tieni presente che è possibile cambiare la posizione nell'ordine solo delle colonne visibili.
-
- fai clic sul simbolo del filtro accanto a ciascuna intestazione per filtrare le informazioni nella griglia in base alla voce selezionata nell'elenco.
- Trascina e rilascia per modificare l'ordine delle colonne.
- Ordina in base a qualsiasi colonna; tieni premuto Shift per applicare un ordinamento secondario in base ad altre colonne.
-
Fai clic sull'icona del filtro per filtrare in base ai valori delle colonne
- Seleziona le celle utilizzando le tecniche di selezione standard di Windows.
- Copia il contenuto delle celle da ActiveBOM e incolla i valori da un editor di fogli di calcolo esterno nelle colonne personalizzate di ActiveBOM.
- È possibile definire numeri di riga configurabili dall'utente quando la BOM è nella vista Base. Nella vista Base, fai clic sul pulsante Set line numbers per aggiungere un numero di riga a ciascuna riga. Fai clic sull'icona a discesa a destra del pulsante per aprire la finestra di dialogo Opzioni numero di riga, in cui è possibile definire il valore iniziale e l'incremento. Per ulteriori informazioni, consulta la sezione Colonna del numero di riga.
- Fai clic sul menu a discesa Add New per aggiungere altre righe o colonne. Per ulteriori informazioni, consulta la sezione Voci e colonne BOM personalizzate.
- Fai clic sul pulsante Group by per raggruppare la griglia in base alla colonna abilitata. È possibile abilitare più colonne di raggruppamento (mostra immagine) e modificarne l'ordine mediante trascinamento. Questa è una funzionalità di visualizzazione della griglia: il raggruppamento non viene trasferito alla finestra di dialogo Report Manager quando viene eseguito il comando Bill of Materials.
- Fai clic sul pulsante Reset Supply Chain per rimuovere la classificazione delle soluzioni definita dall'utente e le priorità SPN assegnate manualmente dagli elementi della distinta base selezionati.
- La configurazione corrente della griglia degli elementi della distinta base può essere salvata come set della distinta base. Per ulteriori informazioni, consulta la sezione Configurazione e salvataggio della visualizzazione della griglia degli elementi della distinta base.
-
Utilizza le scorciatoie standard di Windows per scorrere l'elenco degli elementi della distinta base:
- Scorrimento verticale = MouseWheel Roll
- Scorrimento orizzontale = Shift + MouseWheel Roll
I gruppi di colonne

L'elenco dei componenti di ActiveBOM presenta gruppi distinti di colonne in ciascuna modalità di visualizzazione; l'immagine sopra mostra la vista Base.
La griglia degli elementi della distinta base è suddivisa nei seguenti gruppi principali:
- Item Details (evidenziato in arancione nell'immagine): queste colonne mostrano i dettagli parametrici dei componenti, come il designatore, la descrizione, il riferimento di libreria e altri parametri dei componenti.
- Solutions (evidenziato in verde nell'immagine): il produttore e i relativi fornitori con la classificazione più alta nella catena di approvvigionamento. Il numero di soluzioni (parti del produttore) e il numero di fornitori per ciascuna soluzione vengono configurati nel pannello Properties di ActiveBOM e sono indicati da una barra di colore pieno nel riquadro del fornitore. La classificazione è automatica e può anche essere definita manualmente, come illustrato nella sezione Comprendere la soluzione di seguito.
- BOM Status (evidenziato in ciano nell'immagine): un'indicazione del rischio attuale associato a ciascun componente. Passa il puntatore su un'icona per visualizzare una descrizione oppure abilita la colonna dettagliata BOM Status nel pannello Properties per visualizzarla.
Elementi e colonne personalizzati della distinta base
La gestione della distinta base per un progetto PCB richiede di gestire componenti ed elementi della distinta base oltre a quelli posizionati nello schema elettrico e nel PCB, ad esempio parti ancora da definire nel dettaglio, elementi di fissaggio, la scheda nuda o la colla di montaggio. Sono molti i casi in cui nel progetto PCB vengono utilizzati elementi o parametri personalizzati della distinta base. Per queste situazioni, ActiveBOM consente di aggiungere ulteriori elementi e colonne (parametri) alla distinta base, che possono poi essere inclusi nella distinta base generata:
- Custom row - un modo semplice per aggiungere un elemento personalizzato della distinta base di cui occorre tenere conto nel progetto (scheda nuda, colla, ecc.). Tutti i campi di una riga personalizzata sono definiti dall'utente. Le righe personalizzate non sono gestite da ActiveBOM; ad esempio, se la quantità è impostata su 3, nella vista Flat non verranno visualizzati 3 elementi separati. Inoltre, per le righe personalizzate non è supportata la ricerca nella catena di approvvigionamento.
- Custom column - una colonna aggiuntiva della distinta base, gestita in ActiveBOM, che può contenere qualsiasi testo definito dall'utente.
- Custom Item - un elemento aggiuntivo della distinta base, in genere utilizzato per gli elementi che saranno necessari ma che non sono ancora completamente definiti o non esistono ancora nella libreria. Ciò consente di includerne il costo nella stima del costo complessivo della scheda.
-
Managed Component - un elemento aggiuntivo della distinta base, gestito manualmente nel documento della distinta base. Si aprirà la finestra di dialogo Component Search, che elenca i componenti presenti nel Workspace attualmente connesso.
Opzioni e controlli della finestra di dialogo Component Search
- Search - utilizza la casella di testo di ricerca per cercare manualmente un componente specifico.
-
- fai clic per accedere a un menu e selezionare una delle seguenti opzioni:
- File-based Libraries Preferences - fai clic per aprire la finestra di dialogo Available File-based Libraries per aggiungere o rimuovere librerie.
- File-based Libraries Search - fai clic per aprire la finestra di dialogo File-based Libraries Search per cercare librerie.
- Refresh - fai clic per aggiornare la finestra di dialogo.
-
- fai clic per aprire/chiudere l'Details area della finestra di dialogo (descritta di seguito).
Categorie
Utilizza questo filtro per mostrare determinati tipi di componenti o per visualizzare tutti i componenti disponibili. Utilizza
per accedere alla Categories barra di ricerca, che consente di cercare manualmente un componente specifico o un file .IntLib.
Filtri
Fai clic sull'Filters icona per aprire l'area Filters , in cui puoi filtrare ulteriormente le categorie selezionate nell'elenco Components .
Componenti
- Name - il nome del componente.
- Description - la descrizione di ciascun componente.
- Footprint - il footprint del componente.
- Operating Temperature Range - l'intervallo di temperatura appropriato in cui operano questi componenti.
- Package Description - la descrizione del package del componente.
- Manufacturer Part Search - fare clic per aprire il pannello Ricerca componenti del produttore per cercare e scegliere il componente più adatto.
- Create component - fare clic per aprire la finestra di dialogo Create new component per selezionare il tipo di componente.
- Results - indica il numero totale di componenti trovati/elencati nella ricerca.
Dettagli
- Component Revision ID - mostra l'ID revisione e il prezzo di un determinato componente. Fare clic sull'ID revisione per aprire il pannello Esplora e ottenere ulteriori informazioni sul componente.
- References - fare clic per aprire le informazioni di riferimento del componente in un browser web. Utilizzare il menu a discesa per accedere a Manufacturer URL o Datasheet.
- Place - fare clic per posizionare il componente selezionato in un documento schematico.
- Component information - mostra informazioni pertinenti sul componente, tra cui produttore, data di rilascio e informazioni descrittive. Fare clic sul collegamento Show More per visualizzare tutte le informazioni; fare clic su Show Less per comprimerle.
- Models - espandere per visualizzare i modelli forniti. Utilizzare i collegamenti disponibili per visualizzare varie parti di un singolo modello.
- References - espandere per accedere a Manufacturer URL o Datasheet.
- Part Choices - espandere per visualizzare le scelte dei componenti. Vengono forniti nome, prezzo e descrizione. Viene inoltre elencata la scheda tecnica del componente.
- Where Used - espandere per visualizzare i progetti che utilizzano il componente.
Menu contestuale
- Place <component> - fare clic per posizionare il componente nel documento appropriato.
- Edit - fare clic per aprire i documenti di libreria del componente selezionato.
- Navigate to <revision> - fare clic per aprire il componente selezionato nel pannello Esplora.
- Operations - passare il puntatore per accedere alle opzioni Submit Request, Create, Download, Make a copy, Change Component Type, Create / Edit PCL e Full Item History.
- Refresh - fare clic per aggiornare la visualizzazione e vedere gli aggiornamenti o le modifiche recenti. È anche possibile aggiornare utilizzando la scorciatoia F5.
Aggiunta di istanze di un componente gestito o di una voce personalizzata
Dopo aver aggiunto un componente gestito o una voce personalizzata, fare clic con il pulsante destro del mouse su di esso e selezionare il comando Operations » Add Instances of per accedere alla finestra di dialogo Add to BOM Components. Utilizzare questa finestra di dialogo per definire il numero di istanze del componente da aggiungere alla distinta base.
Specificare Designator prefix, il valore facoltativo Separator (che può essere definito per ottenere risultati come X-1 o X:1) e Quantity dei componenti richiesti (questo valore viene utilizzato per definire l'intervallo dei designatori e comparirà anche nella colonna Quantity di ActiveBOM). Tutti gli altri parametri, come la descrizione, possono essere modificati direttamente nella griglia delle voci della distinta base.
Modifica/rimozione di un componente gestito o di una voce personalizzata
Per modificare il designatore o rimuovere un'istanza di un componente gestito o di una voce personalizzata, fare clic con il pulsante destro del mouse su di esso e selezionare il comando Operations » Edit item. Si aprirà la finestra di dialogo Change / Remove.
Opzioni e controlli della finestra di dialogo Modifica/Rimuovi
- BOM Components - la griglia della finestra di dialogo elenca ogni istanza della nuova voce. Per modificare il prefisso o il valore del designatore, fare clic nella cella New Designator appropriata e modificarla secondo necessità.
- Remove All - facendo clic su questo pulsante si selezionano tutte le istanze della voce aggiuntiva della distinta base elencate nella finestra di dialogo e le si contrassegna per la rimozione. Quando si fa clic sul pulsante OK della finestra di dialogo, tutte le voci contrassegnate per la rimozione vengono rimosse dalla griglia delle voci della distinta base di ActiveBOM. Si noti che, non essendoci più istanze della nuova voce, anche la voce stessa viene rimossa. Questa azione non può essere annullata.
- Remove None - fare clic su questo pulsante per cancellare tutti i contrassegni di rimozione.
- Remove Selected - quando è selezionata un'istanza non contrassegnata per la rimozione, il terzo pulsante consente di impostare il contrassegno di rimozione per le istanze attualmente selezionate.
- Restore Selected - quando è selezionata un'istanza attualmente contrassegnata per la rimozione, il terzo pulsante consente di cancellare il contrassegno di rimozione dalle istanze attualmente selezionate.
Origini dati
Le origini dati predefinite disponibili in ActiveBOM sono i parametri dei componenti dello schema , i parametri dei componenti del Workspace per i contenuti del Workspace e i dati forniti da ActiveBOM A partire da queste origini, ActiveBOM genera la griglia principale delle voci della distinta base del progetto. Le origini dati vengono abilitate e la loro visualizzazione viene controllata nella scheda Columns del pannello Proprietà di ActiveBOM.
Abilitando il relativo pulsante Sources (sopra l'elenco Colonne), la distinta base può includere anche informazioni tratte dalle seguenti origini dati aggiuntive:
The PCB - abilitare queste opzioni per includere i dati relativi a posizione, rotazione e lato della scheda nel PCB tra i Columns disponibili per ciascun componente. Se il progetto contiene più documenti PCB, si aprirà la finestra di dialogo Scegli PCB da utilizzare, dalla quale selezionare il PCB desiderato.
Database - per caricare parametri aggiuntivi dei componenti da un database esterno (tramite *.DbLib, *.SVNDbLib o *.DbLink).
Altium Cloud Services - abilitare questa opzione per accedere a un'ampia gamma di dati aggiuntivi sui componenti, per le voci della distinta base identificate da Altium Parts Provider e che presentano una soluzione di approvvigionamento.
Document Parameters - abilitare questa opzione per includere tutti i parametri dei documenti schematici rilevati, in tutti gli schemi del progetto PCB, tra i Columns disponibili.

L'origine di ciascun parametro è indicata dall'icona nell'elenco delle colonne.
Priorità dei parametri delle origini dati
Se lo stesso parametro è presente in più origini dati, in ActiveBOM vengono applicate le seguenti priorità (dalla più alta alla più bassa):
- Distinta base
- PCB
- Documenti
- Server
- Database
- Cloud
- Schema
- Manuale
Colonna del numero di riga
Per i progetti PCB con disegni di assemblaggio, o per lo scambio dei dati della distinta base tra progettisti, ingegneri dei costi o specialisti degli acquisti, il numero di riga della distinta base (numero di posizione della voce della distinta base) è un metodo semplice per distinguere le singole righe della distinta base, che possono quindi essere utilizzate per identificare esplicitamente o find il richiamo, il componente e la rappresentazione corrispondenti nel progetto.
In quanto origine dati della distinta base del progetto, ActiveBOM supporta numeri di riga definiti dall'utente per la distinta base del progetto e offre funzionalità di gestione sia manuale sia automatica dei numeri di riga (numeri di posizione delle voci della distinta base).
-
Per impostare automaticamente il numero di posizione di tutte le voci della distinta base del progetto (nella vista Base), fare clic sul pulsante Set Line #
. I numeri di riga vengono visualizzati nella colonna Line #, nel gruppo di colonne Item Details. Fare clic sull'icona a discesa a destra del pulsante per aprire la finestra di dialogo Line # Options, in cui è possibile definire i valori iniziale e di incremento.

La finestra di dialogo Line Number Options- Start number - il valore da utilizzare se la prima cella Line # è vuota.
- Increment - incrementa ciascun campo Line # vuoto di questo valore.
-
Per modificare manualmente i numeri di riga, passare alla modalità di visualizzazione Base, quindi selezionare le celle desiderate nella colonna Line # e:
- Premere Delete sulla tastiera per cancellare il contenuto delle celle, quindi
- digitare manualmente i nuovi valori, oppure
- incollare un intervallo di valori dagli Appunti di Windows.
-
Per rinumerare o proseguire la numerazione a partire da un numero aggiunto manualmente, fare clic sulla cella Line # della voce desiderata, quindi sul pulsante Set Line #
. Si aprirà la finestra di dialogo Line Numbering, in cui è possibile utilizzare i numeri esistenti come riferimento e numerare in sequenza le celle vuote selezionate o tutte le celle vuote, partendo dalle celle non vuote più vicine che si trovano sopra (Continue numbering), oppure eliminare tutti i numeri esistenti e rinumerare tutte le righe (Renumber all). Per calcolare i numeri aggiunti vengono utilizzati i valori di base e di incremento definiti più di recente nella finestra di dialogo Line # Options; se necessario, è possibile immettere un valore iniziale nella cella Line # selezionata per definire il numero di partenza.
Configurazione e salvataggio della visualizzazione della griglia delle voci della distinta base
Come in qualsiasi buona applicazione per fogli di calcolo, la griglia delle voci della distinta base può essere configurata in base alle proprie esigenze. Oltre alle tradizionali funzionalità di disposizione e ordinamento delle colonne, è possibile salvare la configurazione corrente come set della distinta base.
Funzionalità di configurazione della griglia
- Mostrare o nascondere qualsiasi colonna: tramite la funzionalità Columns nel pannello Properties. Utilizzare il campo Search nella parte superiore del pannello per individuare rapidamente una colonna.
- Modificare l'ordine delle colonne: tenere premuto il pulsante del mouse sul titolo della colonna e trascinarla nella posizione desiderata.
- Modificare la larghezza di una colonna: posizionare il puntatore sul bordo della colonna nell'area del titolo, quindi fare clic e trascinare (cercare il cursore , oppure fare doppio clic in quel punto per adattare automaticamente la larghezza al contenuto della colonna.
-
Ordinare l'intera griglia in base a una colonna:
- Fare clic sul titolo della colonna per ordinare la griglia in modo alfanumerico in base al contenuto di quella colonna.
- Fare clic una seconda volta per invertire l'ordinamento.
- Tenere premuto Maiusc e fare clic sul titolo di un'altra colonna per applicare un ordinamento secondario in base al contenuto di quest'ultima.
-
Filtrare la griglia in base a un valore specifico: fare clic sull'icona del filtro
per filtrare la griglia in base a un valore utilizzato in quella colonna. Selezionare (Custom) per accedere alla finestra di dialogo Filter Editor e definire la condizione, l'operatore, il valore, il tipo di operatore e così via, per filtrare la colonna selezionata.
- Memorizzare la configurazione come set della distinta base: ulteriori informazioni sono disponibili di seguito.
Utilizzo dei set della distinta base
È possibile salvare un numero qualsiasi di configurazioni della griglia delle voci della distinta base; ciascuna di esse è denominata set della distinta base. Dopo aver configurato la griglia in base alle proprie esigenze, fare clic sul pulsante Add nell'area BOM Sets del pannello Properties di ActiveBOM per aggiungere un set della distinta base all'elenco.

Fare clic sull'icona a forma di occhio per abilitare un set della distinta base.
I set della distinta base vengono configurati nel pannello Properties di ActiveBOM.
Sostituzione di un componente
Non è raro individuare un problema con un componente durante il controllo del BomDoc e la sua preparazione per l'ordine dei componenti. Ad esempio, il progettista potrebbe aver dimenticato di finalizzare la selezione di un componente, oppure un componente potrebbe essere giunto a fine vita (EOL) e il progettista desidera esaminare il prezzo e la disponibilità di possibili alternative. In precedenza, l'unico modo per risolvere il problema era tornare allo schema e modificare il componente, selezionare un componente adatto e quindi aggiornare il BomDoc.
In alternativa, è possibile cambiare un componente nel BomDoc e quindi trasferire tale modifica allo schema tramite un ordine di modifica tecnica (ECO). Fare clic con il pulsante destro del mouse sui componenti selezionati e selezionare il comando Operations » Change <ComponentName>. Si aprirà la finestra di dialogo Replace Component, in cui è possibile cercare il componente sostitutivo.
Facendo clic sul pulsante Replace Component OK, si aprirà la finestra di dialogo Engineering Change Order, che riporta in dettaglio le modifiche necessarie per sincronizzare lo schema con il BomDoc.
Lavorare con le varianti
ActiveBOM supporta i progetti PCB che includono varianti di progetto. La funzione Varianti di progetto consente di creare un unico progetto PCB di base, che viene poi popolato (assemblato) in modi diversi. Ogni diversa configurazione di montaggio della scheda assemblata è chiamata design variant.
Lavorare con le varianti di progetto:
- Le varianti di progetto vengono configurate nella finestra di dialogo Gestione varianti o nel Gestore delle varianti (Project » Variants).
- Per esaminare una variante, fai doppio clic sul suo nome nella cartella Varianti del progetto nel pannello Projects, come mostrato nell'immagine seguente.
ActiveBOM supporta le varianti nei seguenti modi:
- Visualizzazione della distinta base per una variante specifica in modalità di visualizzazione Base o Piatta
- Possibilità di includere gli elementi non montati nell'elenco degli elementi della distinta base
- Visualizzazione di un elenco consolidato di tutti i componenti utilizzati in tutte le varianti, in modalità di visualizzazione Consolidata
- Definizione di soluzioni manuali sia per i componenti di base sia per i componenti modificati nelle varianti
Varianti in modalità di visualizzazione Base
Per la variante selezionata, abilita l'opzione Show Not Fitted nel pannello Properties per includere questi componenti nella griglia degli elementi della distinta base. Quando questa opzione è abilitata, la colonna Fitted viene visualizzata automaticamente nei dettagli dell'elemento.
In modalità di visualizzazione Base, la colonna Fitted visualizzerà Fitted oppure Not Fitted. Se un componente è modificato nella variante (è stato scelto un componente alternativo per questa variante), i dettagli del componente alternativo vengono visualizzati automaticamente per quell'elemento della distinta base.

Nota che la variante corrente è visualizzata nella barra di stato di ActiveBOM.
Varianti in modalità di visualizzazione Consolidata
La modalità di visualizzazione Consolidata mostra tutti i componenti utilizzati in tutte le varianti. La vista Consolidata offre le seguenti funzionalità:
- Se un componente è modificato nelle varianti, sarà presente un elemento della distinta base per ogni componente alternativo utilizzato, e tutti questi elementi avranno lo stesso designatore. Ad esempio, nell'immagine seguente, i componenti DS1 e DS2 sono elencati due volte ciascuno, poiché la variante BGA utilizza un LED di colore diverso rispetto alla variante TSOP. Il componente R1 compare tre volte perché entrambe le varianti BGA e TSOP utilizzano un resistore diverso da quello originale del progetto di base.
-
In modalità di visualizzazione Consolidata, quando l'opzione Show Not Fitted è abilitata, la colonna Fitted visualizzerà
FittedoppureVaried. Poiché la vista Consolidata mostra tutti i componenti utilizzati in tutte le varianti, ogni componente visualizzato è montato nel progetto di base o in una variante. - Per ogni variante sono presenti una colonna <VariantName> - Qty (che indica quante unità di questo componente vengono utilizzate nella variante) e una colonna <VariantName> - Price, il cui valore è dato dal prezzo unitario moltiplicato per il valore nella colonna della quantità.
- Poiché alcuni progettisti creano la documentazione di assemblaggio sia per il progetto di base sia per le varianti, è presente anche una colonna Quantity, che riflette il numero di istanze di questo componente utilizzate nell'assemblaggio del progetto di base. Nascondi questa colonna se non generi la documentazione di assemblaggio per il progetto di base.
- La griglia in modalità di visualizzazione Consolidata utilizza il colore per indicare una cella il cui valore è diverso da quello della stessa cella nel progetto di base, come mostrato di seguito.

Il colore di una cella indica che il suo valore è diverso da quello della stessa cella nel progetto di base.
Per saperne di più sulle varianti, consulta la pagina Varianti di progetto.
Lavorare tra BomDoc, schema elettrico e PCB
Sono disponibili due funzioni per aiutarti a lavorare tra BomDoc, schema elettrico e progetto PCB: Selezione incrociata e Sondaggio incrociato. Il comportamento di queste funzioni viene configurato nella pagina Sistema - Navigazione della finestra di dialogo Preferences.
Entrambe le funzioni possono essere utilizzate per individuare lo stesso componente in altri documenti. La differenza tra Selezione incrociata e Sondaggio incrociato è che la modalità Selezione incrociata seleziona il componente nel documento di destinazione senza portare in primo piano tale documento, mentre Sondaggio incrociato porta in primo piano il documento di destinazione e può anche passare al relativo editor e renderlo attivo.
Puoi utilizzare Selezione incrociata o Sondaggio incrociato dal BomDoc verso lo schema elettrico e il PCB, ma non puoi utilizzarli dallo schema elettrico o dal PCB verso il BomDoc.
Modalità Selezione incrociata
La modalità Selezione incrociata deve essere abilitata in ogni editor in cui desideri utilizzarla. Seleziona il comando Tools » Cross Select Mode (Shift+Ctrl+X). Quando la modalità Selezione incrociata è abilitata, l'icona del menu viene evidenziata con un contorno
.
La modalità Selezione incrociata richiede che il documento di destinazione sia aperto. Quando selezioni un componente nell'elenco degli elementi della distinta base del BomDoc, quel componente viene selezionato e centrato nei documenti di destinazione dello schema elettrico e del PCB (se Zooming è abilitato nelle opzioni Cross Select Mode nella pagina Sistema - Navigazione della finestra di dialogo Preferences). Nota che il documento di destinazione non diventerà il documento attivo.
Se il BomDoc è in modalità di visualizzazione Base, vengono selezionate tutte le istanze di quel componente nello schema elettrico e nel PCB, come mostrato nell'immagine seguente.

Utilizza la funzione Selezione incrociata per individuare e selezionare, nello schema elettrico e sul PCB, il componente scelto nell'elenco degli elementi della distinta base.
Sondaggio incrociato
Mentre Selezione incrociata è semplicemente una modalità che, quando abilitata, visualizza il risultato ogni volta che fai clic nell'elenco degli elementi della distinta base, Sondaggio incrociato è un'azione esplicita.
Scegli Tools » Cross Probe dal menu principale oppure fai clic con il pulsante destro del mouse su una voce della distinta base e seleziona Cross Probe dal menu contestuale per individuare quel componente nello schema tramite cross probing; se il file della scheda è aperto, verrà individuato anche il componente sul PCB.
Una funzionalità importante del cross probing è la possibilità di passare all'editor del documento di destinazione. Per eseguire il cross probing e cambiare editor, tieni premuto il tasto Ctrl mentre selezioni il comando Cross Probe.

Fai clic con il pulsante destro del mouse per accedere al comando Cross Probe: sarà presente una voce per il designatore di ciascun componente incluso in quella voce della distinta base.
Pannello Properties
Quando il documento attivo è una distinta base (*.BomDoc), il pannello Properties presenta Document Options.
Le seguenti sezioni espandibili contengono informazioni sulle opzioni e sui controlli disponibili:
Generale
- Production Quantity – il numero di schede da produrre. È importante definire questo campo, poiché viene utilizzato durante la ricerca nella catena di approvvigionamento per verificare la disponibilità dei componenti presso i fornitori.
- Currency – la valuta preferita per visualizzare i prezzi dei componenti. I tassi di cambio per la conversione valutaria vengono aggiornati quotidianamente, a condizione che tu abbia effettuato l'accesso al tuo account Altium. Quando ti disconnetti da Altium (nella pagina System – Account Management della finestra di dialogo Preferences), perdi l'accesso a questi tassi aggiornati. In questa situazione, nella finestra di dialogo dei report della distinta base è disponibile un'opzione per utilizzare i dati memorizzati nella cache.
- Price Per Board – ricavato dai dati dei fornitori, è la somma di Supplier Subtotals per Board, come descritto di seguito. Tieni presente che Price Per Board non tiene conto delle quantità minime d'ordine (MOQ).
- Order Price – somma di Supplier Subtotals. Tieni presente che Order Price tiene conto delle eventuali MOQ e corrisponde all'importo pagato al fornitore.
Catena di approvvigionamento
Le informazioni sulla catena di approvvigionamento sono presentate nella parte inferiore dell'interfaccia di ActiveBOM, con un componente del produttore a sinistra e uno o più riquadri colorati dei fornitori alla sua destra. Questa sezione visualizza i dati quando è possibile identificare informazioni valide sulla catena di approvvigionamento per una voce della distinta base. Ciascuna di queste righe Manufacturer & Supplier(s) Details viene definita una soluzione. I dettagli del produttore sono abbreviati in MPN (Manufacturer Part Number, codici componente del produttore) e quelli del fornitore in SPN (Supplier Part Number, codici componente del fornitore).
- Solutions per Item – il numero di componenti dei produttori da individuare per ciascuna voce della distinta base.
- Suppliers per Solution – il numero di fornitori da individuare per ciascun componente del produttore.
-
Solutions
- Exclude Invalid SPNs – seleziona per escludere gli SPN non validi.
- Favorite Suppliers List – apre la finestra di dialogo Favorite Suppliers, in cui è possibile configurare l'elenco complessivo dei fornitori per questo BomDoc.
-
Manufacturer Link – apre la finestra di dialogo Define Manufacturer Link Fields, in cui vengono identificati i parametri dei componenti dello schema che contengono il nome del produttore e il codice componente del produttore. Se nel progetto sono presenti componenti di libreria non provenienti da un Workspace (componenti non inseriti da un Workspace e privi di dettagli sui fornitori), ActiveBOM può interrogare Altium Parts Provider per identificare soluzioni di approvvigionamento adatte. È possibile definire più coppie di parametri Nome / Codice componente. Nella finestra di dialogo, fai clic sul pulsante Detect fields per aggiungere automaticamente tutte le coppie di parametri che includono il termine
manufacturernel nome e che possono essere abbinate logicamente.
Voci della distinta base
Questa sezione consente di configurare il raggruppamento delle voci nella griglia delle voci della distinta base.
-
Items
-
Show not Fitted – se il progetto PCB include varianti e la variante scelta contiene componenti impostati su
Not Fitted, abilita questa opzione per visualizzare le voci non montate nella griglia delle voci della distinta base. - Designator Grouping – le modalità di visualizzazione Base e Consolidata mostrano i componenti comuni su un'unica riga nella griglia delle voci della distinta base. Utilizza questa opzione per configurare se visualizzare i designatori singolarmente o come intervalli quando una riga contiene più componenti.
- Component Grouping – facendo clic sul pulsante Edit si apre la finestra di dialogo Component Grouping. Nella vista Base o Consolidated, ActiveBOM identifica i componenti come uguali quando condividono lo stesso ItemID (libreria del Workspace) o LibRef (libreria basata su file o database). Abilita i parametri nella finestra di dialogo per definire ulteriormente il raggruppamento dei componenti. Tieni presente che, se il progetto include solo componenti gestiti, il pulsante Edit non sarà accessibile, poiché i componenti gestiti vengono sempre raggruppati per ItemID.
-
Show not Fitted – se il progetto PCB include varianti e la variante scelta contiene componenti impostati su
Set della distinta base
I set della distinta base consentono di acquisire il layout e la configurazione della griglia delle voci della distinta base e salvarli come set con un nome. È possibile definire un numero qualsiasi di set della distinta base.
-
Current BOM Set – fai clic sull'icona a forma di occhio per applicare quel set alla griglia delle voci della distinta base.
-
Add – configura la visibilità, l'ordine e la larghezza delle colonne, quindi fai clic su Add per salvare questa configurazione come set BOM. Per modificare il nome del set BOM, fai clic una volta per selezionarlo, quindi fai clic una seconda volta per modificare il testo.
-
Update – se la configurazione della griglia delle voci BOM viene modificata, fai clic su Update per salvare nuovamente questa configurazione.
-
Delete – fai clic su
per rimuovere il set BOM attualmente selezionato.
Controlli BOM
ActiveBOM esegue controlli completi su ogni voce BOM e su tutti i dati della catena di approvvigionamento rilevati per tale voce.
- Violation Type grid – visualizza un elenco dei tipi e del numero di violazioni attualmente presenti nel BomDoc. Fai clic sull'icona del filtro per visualizzare solo le voci BOM che non superano il controllo BOM corrispondente. Tieni presente che una voce BOM può non superare più controlli BOM.
-
BOM Checks – fai clic su
per aprire la finestra di dialogo Controlli BOM, in cui è possibile configurare la modalità di segnalazione per ogni possibile tipo di violazione.
Colonne
Questa area del pannello consente di configurare i parametri visualizzati per ogni voce BOM e le origini dati disponibili per tali parametri.
-
Sources – oltre ai dati aggiunti direttamente al BomDoc , le origini dati predefinite disponibili in ActiveBOM sono i parametri dei componenti dello schema elettrico e i parametri dei componenti della libreria del Workspace per i contenuti del Workspace A partire da queste origini, ActiveBOM genera la griglia principale delle voci BOM del progetto. La BOM può includere anche informazioni provenienti dalle seguenti origini dati aggiuntive:
-
PCB – abilita questa opzione per includere i dati relativi a posizione sul PCB, rotazione e lato della scheda nei Columns disponibili per ciascun componente.
-
Database – abilita questa opzione per caricare ulteriori parametri dei componenti da un database esterno (*.DbLib,*.SVNDbLibo*.DbLink). -
Document – abilita questa opzione per includere nei Columns disponibili tutti i parametri dei documenti schematici rilevati in tutti gli schemi elettrici del progetto PCB.
-
Altium Cloud Services – abilita questa opzione per accedere a un'ampia gamma di dati aggiuntivi sui componenti per le voci BOM che sono state identificate da Altium Parts Provider e presentano una soluzione di approvvigionamento.
-
-
Columns – elenco di tutte le origini delle informazioni sui componenti disponibili per ActiveBOM. L'area Colonne può essere ordinata facendo clic su uno qualsiasi dei campi di intestazione.
- Visibility – ogni riga presenta un'icona a forma di occhio; fai clic per controllare la visibilità della colonna corrispondente nella griglia principale delle voci BOM.
- Source – visualizza un'icona che indica l'origine del parametro.
- Name – il nome della proprietà o del parametro, così come definito nel documento di origine o immesso per una colonna BomDoc creata dall'utente.
- Alias – se necessario, è possibile definire un alias per rinominare una colonna.
- Add – fai clic per aggiungere una nuova colonna personalizzata alla griglia delle voci BOM.





