Librerie integrate

A colpo d'occhio

Le librerie integrate di Altium Designer riuniscono simboli schematici, modelli collegati e parametri dei componenti in un unico file portabile. Questo articolo spiega come creare un pacchetto di libreria integrata, rendere disponibili i modelli a cui fa riferimento e compilare il pacchetto verificando la presenza di modelli mancanti ed errori di mappatura dei pin. Continua a leggere per fare il prossimo passo verso la creazione e la convalida delle tue librerie integrate.

- Comprendi come le librerie integrate migliorano la portabilità e mantengono insieme i modelli dei componenti.
- Impara a preparare le librerie sorgente e a rendere disponibili i modelli tramite file di progetto, librerie installate o percorsi di ricerca.
- Scopri come configurare la segnalazione degli errori e compilare il pacchetto di libreria in un file IntLib.
Approfondisci con l'IA:

Le librerie integrate rispecchiano il modello Integrated Component di Altium Designer. In questo modello, il componente di livello superiore è modellato all'interno del simbolo schematico in un file di libreria schematica (*.SchLib). Gli altri modelli sono collegati al simbolo e i parametri del componente vengono aggiunti al simbolo stesso. Tutte le librerie sorgente, ovvero simboli e modelli collegati, sono definite all'interno di un progetto Integrated Library Package, che viene successivamente compilato in un unico file: un Integrated Library, o IntLib.

Questo documento illustra i vari modi in cui è possibile creare una libreria integrata, nonché come posizionare componenti da tale libreria e modificarla.

I vantaggi delle librerie integrate

I principali vantaggi della compilazione in una libreria integrata sono:

  • Tutte le informazioni sui componenti sono disponibili in un unico file portabile. Poiché tutti i modelli sono inclusi nella libreria integrata, è sufficiente che un solo file sia disponibile per il progetto o venga spostato quando il progetto viene trasferito. Questa portabilità è preziosa se si lavora su più postazioni o se si desidera condividere i propri progetti con altri.
  • Se un componente viene posizionato sullo schema di un progetto a partire da una libreria integrata, Altium Designer è in grado di trovare con certezza il modello corretto, purché riesca a individuare la libreria integrata da cui proviene. Non occorre quindi destreggiarsi tra file di libreria e di modello separati, nei quali i collegamenti ai modelli possono rivelarsi molto «fragili» ed essere facilmente interrotti da normali attività di gestione, come la ridenominazione delle cartelle su un disco rigido.
  • Dal punto di vista della sicurezza, le librerie integrate sono affidabili. Una volta generate, non possono essere modificate. Di fatto, aggiornare una libreria integrata significa sostituirla completamente. È necessario aprire appositamente il pacchetto di librerie originale, aggiornare i documenti sorgente e quindi ricompilarlo.
  • Durante la compilazione viene verificata anche l'integrità di queste librerie. Ciò significa che non viene controllata solo la disponibilità dei modelli, ma anche la correttezza delle mappature dei pin. Anche se si desidera continuare a utilizzare file di libreria separati, si consiglia di compilare le librerie schematiche in un pacchetto di librerie integrate, anche solo per assicurarsi che i componenti sorgente siano mappati correttamente ai modelli di destinazione. Una volta verificato questo aspetto, è possibile ignorare la libreria integrata creata e continuare a posizionare i componenti direttamente dalle librerie schematiche.

Creazione di una IntLib mediante un pacchetto di librerie

Un pacchetto di librerie integrate (*.LibPkg) è un tipo di progetto di Altium Designer utilizzato per riunire l'insieme dei documenti di progettazione necessari a produrre una libreria integrata. I simboli schematici vengono disegnati nell'editor delle librerie schematiche e, per ciascuno di essi, vengono definiti riferimenti/collegamenti ai modelli, insieme alle eventuali informazioni parametriche. Questi dati vengono memorizzati in uno o più file di libreria schematica. I modelli referenziati possono includere footprint PCB, modelli di simulazione circuitale e modelli di integrità del segnale.

L'unico documento che deve essere aggiunto al pacchetto di librerie integrate è la libreria schematica (o le librerie schematiche). I file contenenti i modelli 2D/3D dei componenti PCB e i modelli di simulazione/sottocircuiti possono trovarsi in qualsiasi posizione di ricerca valida all'interno del progetto, nei file presenti nell'elenco Installed Libraries oppure nei percorsi di ricerca specificati per il pacchetto.

Il pacchetto di librerie viene quindi compilato in un unico file di libreria integrata (*.IntLib).

La scelta di riunire le librerie di modelli nel progetto o di individuarle tramite percorsi di ricerca dipende dal proprio metodo di lavoro. Se si controllano e modificano i modelli durante la preparazione del pacchetto di librerie integrate, può essere utile avere le librerie di modelli a portata di mano e quindi aggiungerle al pacchetto stesso. Se invece si aggiungono continuamente librerie di modelli a cartelle specifiche su un disco rigido o in rete, si potrebbe preferire l'uso dei percorsi di ricerca, lasciando che il compilatore rilevi automaticamente le nuove librerie aggiunte.
Si noti che i modelli SPICE delle librerie *.LIB non vengono attualmente aggiunti alle librerie integrate compilate.

In sintesi, la creazione di una libreria integrata prevede essenzialmente quattro passaggi:

  1. Creare un pacchetto di librerie sorgente.

  2. Creare e aggiungere i file di libreria schematica sorgente necessari.

  3. Creare e aggiungere i file dei modelli di dominio necessari (oppure specificarne il percorso).

  4. Compilare il pacchetto di librerie per generare il file di libreria integrata.

Creazione del pacchetto di librerie sorgente

Creare un nuovo pacchetto di librerie integrate scegliendo il comando File » New » Library dai menu principali, quindi selezionando l'opzione Integrated Library nell'area File della finestra di dialogo New Library che si apre. Dopo aver fatto clic su Create, il nuovo progetto vuoto del pacchetto di librerie verrà aggiunto al pannello Projects e inizialmente non conterrà alcun documento.

Creazione e aggiunta di una libreria schematica sorgente

Creare la libreria schematica sorgente (*.SchLib) contenente i componenti necessari. Per ogni componente, aggiungere i collegamenti ai modelli e le informazioni parametriche richiesti. Esistono due modi per creare una libreria schematica sorgente:

  • Da zero, utilizzando il comando File » New » Library dai menu principali e selezionando l'opzione Schematic Library nell'area File della finestra di dialogo New Library. Creare nuovi componenti utilizzando l'editor dei simboli schematici oppure copiare i componenti da altre librerie schematiche aperte.
  • Facendo clic con il pulsante destro del mouse sulla voce del pacchetto di librerie nel pannello Projects e scegliendo quindi il comando Add New to Project » Schematic Library dal menu contestuale.
  • A partire dai componenti già posizionati nei documenti schematici di un progetto, utilizzando il comando Design » Make Schematic Library.
Quando si crea una libreria schematica a partire dai componenti posizionati in un progetto esistente, tutti i documenti schematici sorgente vengono aperti automaticamente. La libreria risultante prenderà il nome del progetto (<ProjectName>.SchLib).

Una volta preparate le librerie schematiche sorgente, aggiungerle al pacchetto di librerie utilizzando uno dei seguenti metodi:

  • Utilizzando il comando Project » Add Existing to Project.
  • Facendo clic con il pulsante destro del mouse sulla voce del pacchetto di librerie nel pannello Projects e scegliendo quindi il comando Add Existing to Project dal menu contestuale.

SchLib sorgente aggiunta al pacchetto di librerie.
SchLib sorgente aggiunta al pacchetto di librerie.

Creazione e aggiunta dei file dei modelli di dominio

Creare i modelli, referenziati dai componenti schematici, nei file corrispondenti: i modelli 2D/3D dei componenti PCB in una libreria PCB (*.PcbLib), i modelli di simulazione e i sottocircuiti nei file Model (*.Mdl) e Subcircuit (*.Ckt). Il modello più importante sarà naturalmente il modello 2D/3D del componente PCB che, come la sua controparte nella libreria schematica, può essere creato in due modi:

  • Utilizzando il comando File » New » Library dai menu principali e selezionando l'opzione PCB Library nell'area File della finestra di dialogo New Library. Creare nuovi footprint 2D (e aggiungere le eventuali informazioni sui corpi 3D) utilizzando l'editor dei footprint PCB oppure copiare i componenti da altre librerie PCB aperte.
  • Facendo clic con il pulsante destro del mouse sulla voce del pacchetto di librerie nel pannello Projects e scegliendo quindi il comando Add New to Project » PCB Library dal menu contestuale.
  • A partire dai modelli 2D/3D dei componenti PCB già posizionati nel documento PCB, utilizzando il comando Design » Make PCB Library.
Quando si crea una libreria PCB a partire da un documento PCB esistente, assicurarsi che il documento sia aperto e attivo. La libreria risultante prenderà il nome del file del documento PCB (<PCBDocumentName>.PcbLib).

Specifica delle posizioni in cui cercare i modelli

Una volta definiti i file dei modelli, è necessario renderli disponibili al pacchetto di librerie, in modo che possano essere individuati facilmente quando necessario. Ricorda che i modelli sono referenziati dai componenti dello schema, o collegati a essi. Altium Designer dispone di un sistema standard per rendere disponibili i modelli, sia durante la creazione di un pacchetto di librerie integrate sia durante il lavoro su uno schema. Esistono tre modi per rendere disponibili i modelli:

  • Aggiungere la libreria o il modello al progetto.
  • Installare la libreria o il modello nell'elenco delle librerie installate. In questo modo, saranno disponibili per tutti i progetti.
  • Definire un percorso di ricerca per la libreria o il modello.

Ogni metodo offre dei vantaggi, quindi scegli quello più adatto al tuo modo di lavorare. Inoltre, tipi diversi di modelli si prestano meglio ad approcci diversi. Ad esempio, potresti non voler visualizzare un gran numero di modelli di simulazione nel pannello Projects quando viene aperto il pacchetto di librerie, ma preferire visualizzare le librerie di modelli 2D/3D dei componenti PCB. In questo caso, definisci un percorso di ricerca per la cartella in cui sono memorizzati i modelli di simulazione e aggiungi la libreria PCB al pacchetto di librerie.

Nel loro insieme, questi tre metodi per rendere disponibili i modelli costituiscono il Libraries Preferences (disponibile per un progetto) e possono essere tutti definiti nella finestra di dialogo Libraries Preferences, accessibile facendo clic su Libraries dialogs access button in alto a destra nel pannello Components e selezionando quindi il comando Libraries Preferences.

Definisci la disponibilità dei modelli nella finestra di dialogo Libraries Preferences .
Definisci la disponibilità dei modelli nella finestra di dialogo Libraries Preferences .

La libreria PCB (e altri file di modelli, se necessario) può anche essere aggiunta direttamente al pacchetto di librerie usando il comando Add Existing to Project, disponibile nel menu principale Project o nel menu contestuale associato alla voce del pacchetto di librerie nel pannello Projects.

PcbLib sorgente aggiunta al pacchetto di librerie.
PcbLib sorgente aggiunta al pacchetto di librerie.

La definizione dei percorsi di ricerca dei file dei modelli dalla scheda Search Path della finestra di dialogo Libraries Preferences consente di accedere alla scheda Search Paths della finestra di dialogo Options for Integrated Library (Project » Project Options). Aggiungi uno o più percorsi secondo necessità, ricordando che i modelli vengono cercati in questi percorsi nell'ordine dall'alto verso il basso. Fai clic sul pulsante Refresh List per verificare che i file dei modelli richiesti vengano effettivamente trovati e modifica un percorso, se necessario.

Per accedere alla scheda Search Paths della finestra di dialogo Options for Integrated Library, l'opzione UI.ProjectOptions.SearchPaths deve essere abilitata nella finestra di dialogo Advanced Settings, accessibile facendo clic sul pulsante Advanced nella pagina System – General della finestra di dialogo Preferences. Per rendere effettiva la modifica di questa impostazione, è necessario riavviare Altium Designer.

Un esempio di percorso di ricerca definito per trovare il file del modello PcbLib richiesto.
Un esempio di percorso di ricerca definito per trovare il file del modello PcbLib richiesto.

Compilazione e convalida del pacchetto di librerie

Dopo aver aggiunto le librerie sorgente al pacchetto di librerie e aver definito gli eventuali percorsi dei file dei modelli, è possibile compilare il pacchetto per generare la libreria integrata. Come per qualsiasi altro progetto, il compilatore di un pacchetto di librerie integrate genera un elenco di messaggi di avviso e/o di errore, ad esempio segnalando eventuali modelli non trovati. Inoltre, è possibile verificare la presenza di errori di mappatura dei pin, come istruzioni di mappatura verso le piazzole 1 e 2 quando il footprint effettivo contiene le piazzole A e K.

Anche se desideri continuare a utilizzare file di libreria separati (*.SchLib, *.PcbLib), è consigliabile compilare le librerie di schemi in un pacchetto di librerie integrate, anche solo per assicurarti che i componenti sorgente siano mappati correttamente ai modelli di destinazione.

Prima di avviare una compilazione, è opportuno esaminare e impostare adeguatamente le condizioni di segnalazione degli errori nella scheda Error Reporting della finestra di dialogo Options for Integrated Library.

È buona norma impostare le opzioni di segnalazione degli errori e i livelli di gravità secondo necessità prima di compilare il pacchetto di librerie.
È buona norma impostare le opzioni di segnalazione degli errori e i livelli di gravità secondo necessità prima di compilare il pacchetto di librerie.

Per procedere con la compilazione, usa il comando Compile Integrated Library dal menu principale Project o dal menu contestuale associato alla voce del pacchetto di librerie nel pannello Projects. Le librerie sorgente e i file dei modelli vengono compilati in una libreria integrata che prende il nome dal pacchetto di librerie sorgente (<LibraryPackageName>.IntLib). Il compilatore verifica la presenza di violazioni ed elenca gli eventuali errori o avvisi nel pannello Messages. Correggi gli eventuali problemi nelle librerie sorgente, quindi ripeti la compilazione.

Esempi di errori segnalati dal compilatore durante la compilazione del pacchetto di librerie integrate.
Esempi di errori segnalati dal compilatore durante la compilazione del pacchetto di librerie integrate.

La libreria integrata viene salvata nella cartella di output specificata nella scheda Options della finestra di dialogo Options for Integrated Library (per impostazione predefinita, una sottocartella del percorso del progetto: \Project Outputs for <ProjectName>). Se l'opzione Open outputs after compile è abilitata nella scheda Options della finestra di dialogo Options for Integrated Library, la libreria integrata viene aggiunta automaticamente alla scheda Installed della finestra di dialogo Libraries Preferences  e alla pagina Data Management – File-based Libraries della finestra di dialogo Preferences.

La libreria integrata compilata viene aggiunta alla scheda Installed della finestra di dialogo Libraries Preferences .
La libreria integrata compilata viene aggiunta alla scheda Installed della finestra di dialogo Libraries Preferences .

Creazione di una IntLib dai documenti del progetto

Una libreria integrata può anche essere creata direttamente dai documenti che costituiscono il progetto (schemi sorgente e documento PCB). Questa funzione è utile se desideri creare e riutilizzare una libreria operativa o un archivio del progetto completato. Usa il comando Make Integrated Library, disponibile nel menu principale Design sia nell'editor degli schemi sia nell'editor PCB.

Il processo prevede essenzialmente:

  1. L'apertura di tutti i documenti degli schemi sorgente e la creazione di una libreria di schemi.
  2. La creazione di una libreria PCB dal documento PCB.
  3. La compilazione di queste librerie in una libreria integrata che prende il nome dal progetto (<ProjectName>.IntLib).

La IntLib viene aggiunta al progetto (sotto Libraries\Compiled Libraries nel pannello Projects), aggiunta alle librerie installate (come parte del Available File-based Libraries disponibile per qualsiasi progetto) e resa disponibile tramite il pannello Components.

Creazione semplificata di una libreria integrata, direttamente dai documenti degli schemi e del PCB nel progetto attivo.
Creazione semplificata di una libreria integrata, direttamente dai documenti degli schemi e del PCB nel progetto attivo.

  • Se vengono trovati componenti con lo stesso riferimento di libreria ma con una struttura interna diversa, si apre la finestra di dialogo Duplicated Components. Usa questa finestra di dialogo per specificare come gestire tali componenti: elaborare la prima istanza e ignorare tutte le altre, elaborare tutti i componenti assegnando loro nomi univoci oppure interrompere la creazione della libreria.
  • Il pannello Messages elenca gli eventuali problemi riscontrati durante la generazione della IntLib, ad esempio modelli collegati che non è stato possibile trovare.

Creazione di una IntLib da una libreria di database

Related page: Librerie di database

Le librerie di database di Altium Designer sono la scelta ideale se desideri che i componenti di Altium Designer siano strettamente collegati al database aziendale. Se il progetto deve essere trasferito all'esterno dell'azienda, o se preferisci che i progettisti lavorino con librerie integrate sicure, puoi farlo facilmente. Altium Designer consente di compilare una libreria integrata direttamente da una libreria di database: una libreria di database standard (DbLib) oppure una libreria di database SVN con controllo di versione (SVNDbLib). In questo modo, i responsabili delle librerie CAD possono continuare a utilizzare le librerie di database, mentre i progettisti utilizzano librerie integrate rigenerate regolarmente, lavorando, per così dire, in modalità «offline».

La conversione viene eseguita tramite la procedura guidata Offline Integrated Library Maker. Il processo viene eseguito per ciascuna tabella del database, con il pieno controllo sulle tabelle da includere. Per ogni tabella inclusa viene generata una libreria integrata separata.

Converti le librerie di database (DbLib o SVNDbLib) in librerie integrate «offline» utilizzando Offline Integrated Library Maker.
Converti le librerie di database (DbLib o SVNDbLib) in librerie integrate «offline» utilizzando Offline Integrated Library Maker.

Il processo prevede i seguenti passaggi:

  1. Con il file della libreria di database (*.DbLib) o della libreria di database SVN (*.SVNDbLib) da convertire aperto come documento attivo, scegli il comando Tools » Offline Integrated Library Maker dai menu principali per accedere a Offline Integrated Library Maker.
  2. Utilizza la pagina Library to Convert per specificare la DbLib o SVNDbLib da elaborare. Per impostazione predefinita, viene indicata come libreria da convertire la libreria attiva da cui è stato aperto Offline Integrated Library Maker. Se necessario, puoi cercare e selezionare un'altra libreria di database.
  3. Utilizza la pagina Options per specificare quali tabelle del database collegato includere nella conversione. Per impostazione predefinita, tutte le tabelle del database sono incluse nella conversione. Per escludere una tabella, assicurati che l'opzione Convert associata sia disabilitata. Questa pagina di Offline Integrated Library Maker consente inoltre di specificare una cartella di destinazione in cui verranno salvate le librerie integrate generate. Inserisci direttamente il percorso di questa cartella di base oppure fai clic sull'icona Browse icon a destra del campo per accedere a una finestra di dialogo in cui puoi cercare e selezionare la cartella desiderata. L'output generato (libreria integrata) per ogni tabella del database inclusa verrà salvato in una sottocartella dedicata all'interno della cartella di destinazione specificata, con lo stesso nome della tabella.
  4. Dopo aver scelto la libreria di database e impostato le relative opzioni di conversione secondo necessità, fai clic su Next per procedere con la conversione. Verrà visualizzata una barra di avanzamento, insieme alle informazioni sulla tabella del database attualmente in fase di conversione. Ricorda che il processo di conversione viene eseguito per ogni tabella del database selezionata. Di seguito sono descritte le fasi principali del processo:
    1. Viene creato un pacchetto di libreria integrata (*.LibPkg), che viene aperto nel pannello Projects. Al pacchetto viene assegnato il nome della tabella. Ad esempio, per una tabella denominata Capacitor - Ceramic, si otterrebbe Capacitor - Ceramic.LibPkg.
    2. Viene creato un documento di libreria di simboli schematici e aggiunto al LibPkg. Anche questo documento prende il nome della tabella (ad esempio, Capacitor - Ceramic.SchLib).
    3. Viene quindi esaminato ogni record della tabella e creato il componente Altium Designer corrispondente. A tale scopo, il simbolo schematico a cui fa riferimento il record viene recuperato dalla libreria sorgente appropriata e aggiunto come componente al nuovo documento di libreria di simboli schematici. Al componente vengono quindi aggiunte le informazioni sui parametri e sui collegamenti ai modelli definite nel record.
    4. I modelli di footprint a cui fa riferimento il record vengono recuperati e aggiunti a un documento di libreria PCB. Anche questo documento prende il nome della tabella (ad esempio, Capacitor - Ceramic.PcbLib). Il documento di libreria PCB viene quindi aggiunto al LibPkg.
    5. Se la libreria sorgente è una DbLib e nel record del database sono stati definiti collegamenti a modelli PCB3D e/o di simulazione, vengono aggiunti al LibPkg anche i file della libreria PCB3D e dei modelli di simulazione a cui fanno riferimento. La posizione di questi modelli rimane invariata. Il percorso completo di un modello è specificato nel relativo collegamento al modello.
    6. Il LibPkg viene quindi compilato per ottenere la libreria integrata (ad esempio, Capacitor - Ceramic.IntLib), che viene successivamente aggiunta alle librerie installate di Altium Designer.

Le librerie attualmente installate possono essere visualizzate nella pagina Data Management – File-based Libraries della finestra di dialogo Preferences e nella scheda Installed della finestra di dialogo Available File-based Libraries, accessibile facendo clic su Libraries dialogs access button nell'angolo in alto a destra del pannello Components e selezionando quindi File-based Libraries Preferences.

Risultati del processo di conversione: i progetti dei pacchetti di libreria con i relativi documenti di simboli e modelli di footprint e le IntLib compilate, che vengono aggiunte anche come librerie installate.
Risultati del processo di conversione: i progetti dei pacchetti di libreria con i relativi documenti di simboli e modelli di footprint e le IntLib compilate, che vengono aggiunte anche come librerie installate.

Creazione di una IntLib tramite l'acquisizione di componenti

Related page: Acquisizione dei dati del Workspace tramite il Content Cart

Puoi anche acquisire componenti dal tuo Workspace e inserirli in una libreria integrata (*.IntLib). Quando inserisci componenti da una libreria integrata di questo tipo, i collegamenti effettivi rimandano ai componenti nel Workspace. Questo ti consente di utilizzare efficacemente i componenti del Workspace aziendale in modalità offline, garantendo al contempo che il progetto mantenga un collegamento effettivo a tali componenti nel Workspace sorgente.

Dalla finestra di dialogo Content Cart, la procedura per acquisire una IntLib è la seguente:

  1. Fai clic sul collegamento Select target server e scegli IntLib file dal menu.

    Imposta come destinazione di Content Cart un file IntLib.
    Imposta come destinazione di Content Cart un file IntLib.

  2. Specifica il nome e la posizione del file IntLib generato. Per impostazione predefinita, il file verrà denominato nel formato Integrated_Library - <Date> - <Time>.IntLib e generato nella posizione \Users\Public\Documents\Altium\AD<Solution/Version>\Library\ExportCmpLib. Modifica queste impostazioni secondo necessità tramite la finestra di dialogo Save As, accessibile facendo clic sul collegamento Change.

    Accetta la cartella di destinazione e il nome del file predefiniti oppure modificali secondo necessità.
    Accetta la cartella di destinazione e il nome del file predefiniti oppure modificali secondo necessità.

  3. Se devi acquisire altri componenti nella stessa IntLib, fai clic sul collegamento Add More Items e scegli la voce Select per accedere alla finestra di dialogo Choose Item (una versione «ridotta» del pannello Explorer). Da qui puoi esplorare il Workspace sorgente per trovare altri elementi. In alternativa, scegli la voce Add manually per accedere alla finestra di dialogo Add new items. Questa finestra di dialogo consente di incollare un elenco esterno degli elementi necessari (un elemento per riga), che possono quindi essere cercati nel Workspace sorgente utilizzando un criterio di ricerca a scelta (GUID, Item ID, Name o MPN).

  4. Quando sei pronto, fai clic sul pulsante per procedere con la generazione della IntLib. Verrà creato un pacchetto di libreria integrata temporaneo (*.LibPkg), al quale verranno aggiunti i file sorgente SchLib (con simboli, parametri e collegamenti ai modelli) e PcbLib (con modelli di footprint) generati. Il pacchetto viene quindi compilato per produrre il file IntLib, che viene generato nella cartella specificata. Una finestra di dialogo informativa confermerà la corretta generazione del file.

    Trasferisci il contenuto del carrello nella cartella di destinazione, che conterrà il file di libreria integrata richiesto.
    Trasferisci il contenuto del carrello nella cartella di destinazione, che conterrà il file di libreria integrata richiesto.

Dopo la generazione, la IntLib viene aggiunta all'elenco Installed Libraries, che fa parte del Available File-based Libraries del software.

Posizionamento di componenti da una libreria integrata

Il posizionamento dei componenti da una libreria integrata viene eseguito dal pannello Components. È possibile posizionare i componenti nel documento schematico attivo o nel documento PCB attivo. Il posizionamento può essere eseguito nei seguenti modi:

  • Selezionare il file *.IntLib desiderato dal menu a discesa del pannello Components, quindi fare clic con il pulsante destro del mouse sul componente da posizionare e scegliere Place <ComponentName> dal menu contestuale. Portare il componente nella posizione desiderata sul documento schematico, quindi fare clic per posizionarlo.

  • Fare clic sul componente desiderato e trascinarlo nell'area di progettazione.

Utilizzando il metodo del pulsante Place, è possibile posizionare più istanze di un componente, poiché questa modalità di posizionamento rimane attiva finché non si fa clic con il pulsante destro del mouse o si preme Esc. Il metodo di trascinamento è più immediato, ma consente di posizionare un solo componente alla volta.

Sebbene una libreria di simboli schematici e una libreria integrata possano contenere lo stesso componente (con tutti gli stessi collegamenti ai modelli), i componenti posizionati da ciascuna di queste librerie si comportano diversamente quando vengono recuperate le informazioni sui relativi modelli. I componenti posizionati dalle librerie integrate cercano i propri modelli nella libreria integrata originale, mentre quelli posizionati dalle librerie di simboli schematici non possono accedere ai modelli memorizzati nelle librerie integrate.

Modifica di una libreria integrata

Le librerie integrate vengono utilizzate per posizionare i componenti e non possono essere modificate direttamente. Per apportare modifiche a una libreria integrata, modificare prima le librerie sorgente, quindi ricompilare il pacchetto di librerie per generare una nuova libreria integrata che includa tali modifiche.

Per modificare una libreria integrata:

  1. Aprire il progetto del pacchetto di librerie sorgente della libreria integrata desiderata.
  2. Aprire le librerie sorgente di simboli schematici o di modelli da modificare.
  3. Apportare le modifiche necessarie, salvare le librerie modificate e chiuderle.
  4. Ricompilare il pacchetto di librerie. La libreria integrata appena generata sostituirà la versione precedente.

Decompilazione di una libreria integrata

Può capitare di dover accedere alle librerie sorgente contenute in una libreria integrata per modificarle, ma di non poter accedere, per qualsiasi motivo, al progetto originale del pacchetto di librerie sorgente. È qui che entra in gioco un altro vantaggio di un file di libreria integrata unico e portabile. Sebbene le librerie integrate non possano essere modificate direttamente, possono essere decompilate per ricavare le librerie sorgente di simboli e modelli che le costituiscono.

Per farlo:

  1. Aprire la libreria integrata che contiene le librerie sorgente da modificare. È possibile procedere in uno dei seguenti modi:
    1. Scegliere il comando File » Open, individuare la libreria integrata nella finestra di dialogo Choose Document to Open, quindi fare clic su Open.
    2. Trascinare il file IntLib da Esplora file di Windows alla finestra di Altium Designer.
  2. Nella finestra di dialogo Open Integrated Library visualizzata, fare clic sul pulsante Extract.

Le librerie sorgente di simboli schematici e di modelli vengono estratte e salvate in una nuova cartella con lo stesso nome del file della libreria integrata, all'interno della cartella in cui si trova la libreria integrata originale. Viene quindi creato un pacchetto di librerie (<IntegratedLibraryFileName>.LibPkg) e le librerie sorgente di simboli schematici e PCB vengono aggiunte al progetto e visualizzate nel pannello Projects. I file dei modelli di simulazione e dei sottocircuiti non vengono aggiunti automaticamente al progetto.


Estrazione delle librerie sorgente da una libreria integrata: decompilazione per produrre un progetto di pacchetto di librerie.

Un percorso alla cartella contenente la libreria sorgente e i file dei modelli (ove presenti) viene aggiunto automaticamente nella scheda Search Paths della finestra di dialogo Options for Integrated Library (Project » Project Options), garantendo che tutti i modelli (in particolare i file .mdl e .ckt) vengano trovati.
Il pacchetto di librerie non viene salvato automaticamente. Specificare dove e con quale nome salvare il progetto: per impostazione predefinita, il file viene salvato nella stessa cartella dei file sorgente estratti.
AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents