Ricerca dei componenti nelle librerie basate su database e file
Altium Essentials: Schematic Capture
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
A colpo d'occhio
- Comprendi le differenze tra librerie di progetto, librerie installate e librerie nei percorsi di ricerca e scopri come ciascuna influisce sulla disponibilità dei componenti in Altium Designer.
- Scopri dove gestire le librerie disponibili, come funziona l'ordine di ricerca e perché alcune scelte di configurazione delle librerie possono influire su velocità e affidabilità.
- Scopri come funziona la ricerca dei componenti nelle librerie basate su file e su database e cosa aspettarti quando utilizzi sorgenti DbLib e SVNDbLib.
Gestione delle librerie disponibili basate su database e su file
In Altium Designer, i componenti delle librerie basate su database e su file possono essere posizionati solo dalle librerie attualmente disponibili. Queste includono:
-
Libraries in the current project – se una libreria fa parte del progetto, i suoi componenti sono automaticamente disponibili per il posizionamento all'interno di quel progetto.
-
Installed libraries – queste librerie sono state installate in Altium Designer; i loro componenti sono disponibili per l'uso in qualsiasi progetto aperto.
-
Libraries on a defined search path – è anche possibile definire un percorso di ricerca verso una cartella contenente più librerie. Poiché tutti i file nel percorso di ricerca vengono esaminati ogni volta che si sceglie un nuovo componente in un pannello, questo approccio è consigliato solo per librerie di piccole dimensioni con definizioni dei modelli semplici, come i modelli di simulazione. I percorsi di ricerca non sono consigliati per modelli complessi, come i footprint che includono modelli 3D.
Per gestire le librerie disponibili basate su database e su file, è possibile utilizzare la Libraries Preferences finestra di dialogo, accessibile facendo clic sul pulsante
nella parte superiore del pannello Components e selezionando Libraries Preferences dal menu.
La Libraries Preferences finestra di dialogo contiene tre schede. Tutte le librerie e le posizioni dei modelli definite in queste schede vengono riunite per comporre l'elenco delle librerie disponibili. Quando viene eseguita un'azione che richiede la ricerca di un modello, ad esempio il trasferimento del progetto dallo schema al layout PCB, la ricerca nelle librerie segue l'ordine delle schede e, all'interno di ciascuna scheda, l'ordine in cui sono elencati le librerie e i modelli. Non appena viene individuato il modello corretto, il processo di ricerca si interrompe.
Librerie di progetto
Le librerie che fanno parte del progetto attivo sono elencate nella scheda Project della finestra di dialogo Libraries Preferences quando quel progetto è attivo nel software. Il vantaggio delle librerie di progetto è che i modelli e le librerie diventano automaticamente disponibili ogni volta che il progetto viene aperto. Lo svantaggio è che, se i modelli e le librerie non sono memorizzati nella stessa struttura di cartelle del progetto dei file di progettazione, possono essere facilmente dimenticati quando si spostano i file del progetto.

La scheda Project fornisce un elenco delle librerie disponibili nel progetto corrente.
Librerie installate
Le librerie e i modelli resi disponibili nell'installazione del software sono definiti librerie installate. Sono elencati nella scheda Installed della finestra di dialogo Libraries Preferences.
Le librerie installate possono essere elencate utilizzando un percorso assoluto o un percorso relativo all'impostazione Library Path Relative To. Il vantaggio di utilizzare un percorso relativo è che consente di creare un sottoambiente comune su più PC, permettendo di spostare facilmente i file di progettazione da uno all'altro. Inoltre, le librerie installate possono essere disattivate temporaneamente deselezionando la casella di controllo Activated, anziché rimuoverle.

La scheda Installed elenca le librerie rese disponibili in questa installazione di Altium Designer.
Percorso di ricerca
La scheda Search Path presenta un elenco delle librerie individuate in base alle impostazioni dei percorsi definite nella scheda Percorsi di ricerca della finestra di dialogo Opzioni progetto, accessibile facendo clic sul pulsante Paths. Ogni percorso di ricerca definisce una cartella e può includere sottocartelle se l'opzione Recursive è abilitata (disponibile nella scheda Search Paths della finestra di dialogo Project Options dopo l'aggiunta di un percorso). Tutti i file di modelli e librerie trovati nel percorso di ricerca saranno disponibili. I percorsi di ricerca vengono salvati con il progetto.

La scheda Search Path elenca le librerie trovate nei percorsi di ricerca definiti.
Il recupero dei modelli tramite percorsi di ricerca può essere lento se le cartelle dei percorsi di ricerca contengono un numero elevato di file. Per questo motivo, non è consigliabile utilizzare questo approccio per le librerie PCB, poiché possono essere file di grandi dimensioni contenenti molti footprint. Questa funzionalità è stata sviluppata per fornire un modo per fare riferimento ai modelli di simulazione e di integrità del segnale disponibili.
Consultazione dei componenti del database
Una volta aggiunto il file DbLib/SVNDbLib all'elenco delle librerie disponibili basate su file, i componenti del database saranno disponibili per la consultazione nel pannello Components. Sebbene venga aggiunto un solo file DbLib/SVNDbLib, ogni tabella del database collegato verrà presentata come se fosse una libreria distinta.
L'elenco a discesa nella parte superiore del pannello verrà popolato con voci nel formato:
- <LibraryName>.DbLib - <TableName> o <LibraryName>.SVNDbLib - <TableName> ----se il database contiene tabelle
- <LibraryName>.DbLib - <SheetName>$ oppure <LibraryName>.SVNDbLib - <SheetName>$ ----dove il database è composto da fogli di una cartella di lavoro Excel.
Esempio di una DbLib caricata con tre tabelle, un'altra con una tabella e una SVNDbLib con una tabella.
Ogni voce di componente nel pannello corrisponde a un record di quella specifica tabella del database. Infatti, quando si esplorano le librerie di database caricate, il pannello Components si comporta come un browser diretto del database. Le informazioni su simboli e modelli vengono ricavate dalle librerie di simboli e modelli sottostanti, a cui rimandano i relativi campi del database (e in base ai percorsi e alle posizioni di ricerca definiti).
Esplorazione dei componenti in un database esterno collegato tramite una libreria di database.
Per impostazione predefinita, nell'area dell'elenco dei componenti del pannello vengono visualizzati solo i campi Part Number e Library Ref. Per rendere visibili altri campi della tabella del database, fai clic con il pulsante destro del mouse nell'area e scegli Select Columns dal menu contestuale. Si aprirà la finestra di dialogo Select Columns, in cui puoi abilitare la visualizzazione di qualsiasi campo aggiuntivo della tabella.
Memorizzazione nella cache locale di simboli e modelli utilizzati dalle librerie di database SVN
Quando un file SVNDbLib viene aggiunto all'elenco delle librerie disponibili, le librerie di simboli e modelli presenti nel repository vengono memorizzate nella cache in una cartella temporanea locale sul computer del progettista. Quando un'azione nel software richiede l'utilizzo di un simbolo schematico o di un modello, tale simbolo o modello viene recuperato dalla cache locale.
Aggiornamento automatico della cache
Le librerie nella cache vengono aggiornate automaticamente con le versioni più recenti del repository di controllo versione quando si esegue una delle seguenti azioni nel software:
-
Posizionamento di un componente da un file SVNDbLib installato (dal pannello Components).
-
Esecuzione di un trasferimento del progetto (ovvero aggiornamento del PCB).
-
Utilizzo del comando Tools » Update From Libraries nell'editor degli schemi.
-
Utilizzo del comando Tools » Update From PCB Libraries nell'editor PCB.
Sebbene l'aggiornamento sia automatico, è possibile controllarlo tramite l'opzione Do not check files more often than xx minutes nella pagina Data Management - SVN Libraries della Preferences finestra di dialogo. Questa opzione fornisce essenzialmente un «timer di aggiornamento» per la cache locale. Se è trascorso il tempo specificato dall'ultimo aggiornamento della cache, questa viene aggiornata automaticamente quando si esegue una delle azioni elencate. Se un'azione viene eseguita entro questo intervallo, viene utilizzato il contenuto corrente della cache, che potrebbe non essere aggiornato rispetto al contenuto del repository.
Forzare manualmente un aggiornamento della cache
In alcuni casi potresti voler forzare un aggiornamento della cache locale, per assicurarti di disporre delle librerie più recenti attualmente archiviate nel repository di controllo versione. Ad esempio, quando ti prepari a trasferire il progetto dallo schema al PCB.
Puoi forzare manualmente un aggiornamento della cache utilizzando uno dei seguenti metodi:
- Utilizzando uno dei Refresh comandi disponibili nel menu accessibile con un clic destro nel pannello Components.
- Rimuovendo e aggiungendo nuovamente il file SVNDbLib nell'elenco delle librerie disponibili.
Ricerca di componenti nelle librerie di database e basate su file
Per facilitare la ricerca di un componente nelle librerie basate su file (sia installate sia non attualmente installate) e nelle librerie di database, Altium Designer include una funzione di ricerca nelle librerie.
È possibile cercare un componente nelle librerie di database e basate su file utilizzando il campo Search del pannello Components. Inserisci una stringa e premi Enter per cercarla nella libreria corrente, in qualsiasi punto dei parametri visibili dei componenti.
Puoi eseguire una ricerca direttamente nel pannello Components.
La finestra di dialogo File-based Libraries Search consente ricerche più dettagliate. Per accedervi, fai clic sul pulsante
nel pannello Components e seleziona File-based Libraries Search dal menu. La metà superiore della finestra di dialogo serve a definire what cercare; la metà inferiore serve a definire where eseguire la ricerca.
Ricerca nelle librerie installate (Available libraries) o nelle librerie sul disco rigido (Libraries on path).Il processo di ricerca può essere riassunto come segue:
-
La ricerca viene eseguita definendo Filters che vengono applicati a tutte le librerie in cui è possibile cercare in base alle impostazioni correnti di Scope della ricerca.
-
Il Scope include il tipo di librerie in cui cercare. È possibile cercare in un solo tipo alla volta.
-
Per abilitare la ricerca di componenti di database, imposta il campo Search in su Database Components e seleziona il Table desiderato. Nota che i Fields disponibili nell'elenco a discesa sopra cambiano per riflettere le intestazioni delle colonne disponibili nella tabella scelta. Le opzioni rimanenti nella finestra di dialogo vengono disabilitate, poiché non sono pertinenti alla ricerca nelle librerie di database.
-
Il Scope definisce le librerie in cui verrà eseguita la ricerca: le librerie a cui il software ha attualmente accesso (Available libraries) oppure tutte le librerie all'interno di una cartella (Libraries on path).
-
Quando si cercano librerie in un percorso, la destinazione è una cartella specifica ed è anche possibile Include Subdirectories.
-
Puoi anche cercare all'interno dei risultati della ricerca impostando Scope su Refine last search.
-
Fai clic su Clear per cancellare i parametri di ricerca inseriti.
Impostazione del filtro di ricerca
L'area Filters serve a definire le stringhe di testo da applicare alla ricerca. Sono disponibili tre aree da configurare:
-
Field – è l'attributo del componente in cui eseguire la ricerca. Può essere qualsiasi attributo del componente o del footprint, inclusi nome, descrizione, commento, footprint o qualsiasi parametro aggiunto a un componente. Seleziona un campo disponibile dall'elenco a discesa oppure inserisci un campo nella casella di testo.
-
Operator – definisce come viene determinata una corrispondenza. Questa può verificarsi quando il valore equals, contains, starts with o ends with. Nota che equals richiede una corrispondenza esatta della stringa, quindi dovrebbe essere utilizzato solo quando sei sicuro che la stringa di ricerca sia corretta e completa.
-
Value – i caratteri da cercare nel Field scelto, con corrispondenza determinata in base al Operator scelto. Seleziona un valore disponibile dall'elenco a discesa oppure inserisci un valore nel campo di testo.
Per impostazione predefinita sono presenti tre vincoli di filtro; puoi aggiungere fino a sette righe aggiuntive, per un totale di 10 righe, utilizzando il Add Row controllo. L'ultima riga di vincolo di filtro aggiunta può essere rimossa utilizzando il Remove Row. Puoi rimuovere le righe non utilizzate.
Impostazione dell'ambito
Esistono essenzialmente due approcci alla ricerca:
-
Librerie attualmente disponibili – è l'elenco delle librerie visualizzato nel menu a discesa nella parte superiore del pannello Components .
-
Librerie memorizzate in una cartella specifica, incluse le sottocartelle se l'opzione è abilitata.
La ricerca restituisce tutti gli elementi del tipo di ricerca scelto nel menu a discesa Search in (Components/Footprints/3D Models/Database Components) presenti in tutte le librerie che rientrano nell'ambito definito da Scope:
- Available libraries - abilitare per cercare i tipi di modello specificati solo nelle librerie disponibili.
-
Libraries on path - abilitare per cercare i tipi di modello specificati nelle librerie disponibili in una o più cartelle specifiche. Nell'area Path della finestra di dialogo, che diventa disponibile con l'opzione di ambito Libraries on path selezionata, è possibile definire il percorso, includere le sottocartelle e specificare la maschera dei file di libreria per definire e restringere i criteri di ricerca:
- Path - modificare per definire la cartella in cui cercare le librerie oppure fare clic sull'icona di selezione alla fine del campo per individuare una cartella.
- Include Subdirectories - abilitare per cercare le librerie nel percorso specificato e nei relativi sottopercorsi.
-
File Mask - immettere la stringa della maschera file o scegliere una delle maschere file esistenti dall'elenco a discesa. La ricerca viene filtrata in base alla corrispondenza con la stringa. Nella stringa è possibile utilizzare il carattere jolly * (qualsiasi carattere). Ad esempio, digitare * per cercare tutti i file e digitare M per cercare tutti i file che iniziano con la lettera M.
Ad esempio, per trovare un componente che si ritiene presente in una libreria all'interno di cartelle specifiche sul disco rigido, quando tale libreria non è attualmente elencata in Available File-based Libraries, definire la ricerca come segue:
- Nell'area Scope, impostare Search in su Components e selezionare Libraries on path.
- Nell'area Path, impostare Path in modo che punti alla cartella contenente il documento di libreria in cui si desidera effettuare la ricerca.
- Fare clic su Search. I risultati vengono visualizzati nel pannello Components durante la ricerca.
Modalità di ricerca avanzata
La ricerca nelle librerie viene in realtà eseguita mediante query. Nella finestra di dialogo File-based Libraries Search, passare alla modalità Advanced per esaminare la query.
Nella modalità Advanced della finestra di dialogo, è anche possibile creare query personalizzate utilizzando le parole chiave del linguaggio di query per eseguire una ricerca basata su query. Consultare la sezione seguente per ulteriori informazioni sulle parole chiave disponibili nel linguaggio di query.
Utilizzare i seguenti controlli aggiuntivi quando è selezionata la modalità Advanced:
-
Helper - fare clic per aprire la finestra di dialogo Assistente query e creare facilmente una query di ricerca nelle librerie con funzioni di libreria predefinite e funzioni di sistema. È anche possibile utilizzare i pulsanti History e Favorites per scegliere una query di libreria applicata di recente o predefinita.
-
History - fare clic per aprire la finestra di dialogo Gestione espressioni e scegliere una delle espressioni di query applicate in precedenza da utilizzare per la ricerca nelle librerie. È anche possibile utilizzare il pulsante Favorites per usare una query predefinita per una ricerca specifica nelle librerie.
-
Favorites - fare clic per aprire la finestra di dialogo Gestione espressioni e scegliere una delle espressioni di query preferite da utilizzare in una ricerca nelle librerie. È anche possibile modificare l'elenco Favorites rimuovendo, rinominando o copiando espressioni dall'elenco History.
Durante la ricerca tra Database Components, la modalità Advanced consente di eseguire una ricerca tramite query SQL. Questo livello di ricerca offre una ricerca dettagliata basata su un'espressione di query specifica, consentendo di immettere una query SQL direttamente nella sezione dell'editor di query della finestra di dialogo.
Fare clic su Advanced per accedere a una potente ricerca basata su query SQL. Fare nuovamente clic su Advanced per tornare alla ricerca semplice.
Funzioni di query per componenti e librerie

Funzioni di query per componenti e librerie nella finestra di dialogo Query Helper
Alla base degli editor di schemi e PCB di Altium Designer vi è un potente motore di query. Immettendo query in questo motore, è possibile delimitare con precisione, in modo logico, l'insieme degli oggetti necessari.
Una query è una stringa immessa utilizzando parole chiave e una sintassi specifiche, che restituisce gli oggetti desiderati. Sono disponibili numerose parole chiave, che consentono di individuare gli oggetti in base al tipo, alle proprietà o a entrambi.
Le sezioni seguenti descrivono in dettaglio le parole chiave del linguaggio di query disponibili per la ricerca di componenti basati su database e su file in Altium Designer. Per informazioni su una parola chiave di query specifica, utilizzare le seguenti sezioni espandibili oppure evidenziare una parola chiave (o fare clic al suo interno) in Query Helper.
Componenti
Commento
Riepilogo
Restituisce tutti i componenti il cui Comment soddisfa la query.
Sintassi
Comment : String
Esempi di utilizzo
Comment = 'Res1'
Restituisce tutti i componenti il cui Comment è Res1.
Comment = '100nF'
Restituisce tutti i componenti il cui Comment è 100nF.
Comment Like '*33*'
Restituisce tutti i componenti il cui Comment contiene 33.
Note
-
Assicurarsi che l'ambito della ricerca sia impostato su Components utilizzando il campo Search in nella finestra di dialogo Ricerca nelle librerie di file.
-
Durante la ricerca di componenti, vengono interrogate tutte le librerie SchLib e IntLib disponibili o presenti lungo un percorso di ricerca definito.
-
Tutti i risultati sono riportati nell'elenco Query Results nel pannello Componenti.
Tipo di componente
Riepilogo
Restituisce tutti i componenti la cui proprietà Component Type soddisfa la query.
Sintassi
ComponentType = ComponentType_String
ComponentType_String deve essere una delle stringhe del seguente elenco:
- 'Graphical'
- 'Jumper'
- 'Mechanical'
- 'Net Tie'
- 'Net Tie (In BOM)'
- 'Standard'
- 'Standard (No BOM)'
Esempi di utilizzo
ComponentType = 'Graphical'
Restituisce tutti i componenti il cui Component Type è Graphical.
ComponentType = 'Standard'
Restituisce tutti i componenti il cui Component Type è Standard.
Note
-
Assicurarsi che l'ambito della ricerca sia impostato su Components utilizzando il campo Search in nella finestra di dialogo Ricerca nelle librerie di file.
-
Durante la ricerca dei componenti, vengono interrogate tutte le librerie SchLib e IntLib disponibili o presenti lungo un percorso di ricerca definito.
-
Tutti i risultati sono riportati nell'elenco Query Results, nel pannello Componenti.
-
I caratteri di apice singolo (') all'inizio e alla fine di
ComponentType_Stringsono obbligatori.
Designatore
Riepilogo
Restituisce tutti i componenti la cui proprietà Designator soddisfa la query.
Sintassi
Designator : String
Esempi di utilizzo
Designator = 'U2'
Restituisce tutti i componenti la cui proprietà Designator è U2.
Designator Like '*Channel*'
Restituisce tutti i componenti la cui proprietà Designator include Channel.
Designator <> 'C*'
Restituisce tutti i componenti except quelli la cui proprietà Designator inizia con C.
Note
-
Assicurarsi che l'ambito della ricerca sia impostato su Components utilizzando il campo Search in nella finestra di dialogo Ricerca nelle librerie di file.
-
Durante la ricerca dei componenti, vengono interrogate tutte le librerie SchLib e IntLib disponibili o presenti lungo un percorso di ricerca definito.
-
Tutti i risultati sono riportati nell'elenco Query Results nel pannello Componenti.
HasModel
Riepilogo
Restituisce ogni componente collegato a un modello di dominio (o che vi fa riferimento) le cui proprietà soddisfano la query.
Sintassi
HasModel(ModelType : String,ModelName : String,CurrentModelOnly : Boolean) : Boolean/Boolean_String
La stringa ModelType specifica la proprietà Type di un modello collegato e deve essere una delle stringhe del seguente elenco:
- 'PCB3DLIB' - utilizzare questa stringa per individuare un modello collegato la cui proprietà Type è PCB3D.
- 'PCBLIB' - utilizzare questa stringa per individuare un modello collegato la cui proprietà Type è Footprint.
- 'IBIS' - utilizzare questa stringa per individuare un modello collegato la cui proprietà Type è Ibis Model.
- 'SI' - utilizzare questa stringa per individuare un modello collegato la cui proprietà Type è Signal Integrity.
- 'SIM' - utilizzare questa stringa per individuare un modello collegato la cui proprietà Type è Simulation.
La stringa ModelName specifica la proprietà Name di un modello collegato.
Il parametro CurrentModelOnly specifica se il modello collegato debba essere o meno un modello corrente di ciascun componente. Quando è False, il modello collegato non deve necessariamente essere un modello corrente (ma può esserlo); quando è True, il modello collegato deve essere un modello corrente.
Esempi di utilizzo
HasModel('PCBLIB','SOIC14',False)
HasModel('PCBLIB','SOIC14',False) = True
HasModel('PCBLIB','SOIC14',False) = 'True'
Restituisce tutti i componenti collegati a un modello di footprint la cui proprietà Name è SOIC14; tale modello non deve necessariamente essere il modello di footprint corrente di ciascun componente (ma può esserlo).
HasModel('PCBLIB','DIP14',True)
HasModel('PCBLIB','DIP14',True) = True
HasModel('PCBLIB','DIP14',True) = 'True'
Restituisce tutti i componenti collegati a un modello di footprint la cui proprietà Name è DIP14; tale modello deve essere il modello di footprint corrente del componente.
HasModel('SI','RES1',False)
HasModel('SI','RES1',False) = True
HasModel('SI','RES1',False) = 'True'
Restituisce tutti i componenti collegati a un modello di integrità del segnale la cui proprietà Name è RES1; tale modello non deve necessariamente essere il modello di integrità del segnale corrente di ciascun componente (ma può esserlo).
HasModel('SIM','RESISTOR',True)
HasModel('SIM','RESISTOR',True) = True
HasModel('SIM','RESISTOR',True) = 'True'
Restituisce tutti i componenti collegati a un modello di simulazione la cui proprietà Name è RESISTOR; tale modello deve essere il modello di simulazione corrente del componente.
Note
-
Assicurarsi che l'ambito della ricerca sia impostato su Components utilizzando il campo Search in nella finestra di dialogo Ricerca nelle librerie di file.
-
Durante la ricerca dei componenti, vengono interrogate tutte le librerie SchLib e IntLib disponibili o presenti lungo un percorso di ricerca definito.
-
Tutti i risultati sono riportati nell'elenco Query Results nel pannello Componenti.
HasModelParameter
Riepilogo
Restituisce ogni componente collegato a un modello di dominio (o che vi fa riferimento) contenente un oggetto parametro le cui proprietà Parameter Name e Value soddisfano la query.
Sintassi
HasModelParameter(Parameter Name : String,Value : String,CurrentModelOnly : Boolean) : Boolean/Boolean_String
Il parametro CurrentModelOnly specifica se il modello collegato (che contiene un parametro conforme alla query) debba essere o meno un modello corrente di ciascun componente. Quando è False, il modello collegato non deve necessariamente essere un modello corrente (ma può esserlo); quando è True, il modello collegato deve essere un modello corrente.
Esempi di utilizzo
HasModelParameter('Inductance A','1mH',False)
HasModelParameter('Inductance A','1mH',False) = True
HasModelParameter('Inductance A','1mH',False) = 'True'
Restituisce tutti i componenti collegati a un modello che contiene un oggetto parametro la cui proprietà Parameter Name è Inductance A e la cui proprietà Value è 1mH. Tale modello non deve necessariamente essere un modello corrente di ciascun componente (ma può esserlo).
HasModelParameter('Coupling Factor','0.999',True)
HasModelParameter('Coupling Factor','0.999',True) = True
HasModelParameter('Coupling Factor','0.999',True) = 'True'
Restituisce tutti i componenti collegati a un modello che contiene un oggetto parametro la cui proprietà Parameter Name è Coupling Factor e la cui proprietà Value è 0.999. Tale modello deve essere un modello corrente del componente.
Note
-
Assicurarsi che l'ambito della ricerca sia impostato su Components utilizzando il campo Search in nella finestra di dialogo Ricerca nelle librerie di file.
-
Durante la ricerca dei componenti, vengono interrogate tutte le librerie SchLib e IntLib disponibili o presenti lungo un percorso di ricerca definito.
-
Tutti i risultati sono riportati nell'elenco Query Results nel pannello Componenti.
LibReference
Riepilogo
Restituisce tutti i componenti la cui proprietà Library Reference soddisfa la query.
Sintassi
LibReference : String
Esempi di utilizzo
LibReference = 'LM833'
Restituisce tutti i componenti la cui proprietà Library Reference è LM833.
LibReference Like 'C*'
Restituisce tutti i componenti la cui proprietà Library Reference inizia con C.
Note
-
Assicurarsi che l'ambito della ricerca sia impostato su Components utilizzando il campo Search in nella finestra di dialogo Ricerca nelle librerie di file.
-
Durante la ricerca dei componenti, vengono interrogate tutte le librerie SchLib e IntLib disponibili o presenti lungo un percorso di ricerca definito.
-
Tutti i risultati sono riportati nell'elenco Query Results nel pannello Componenti.
Conteggio delle parti
Riepilogo
Restituisce tutti i componenti la cui proprietà Part Count soddisfa la query.
Sintassi
PartCount : Number
Esempio di utilizzo
PartCount = 2
Restituisce tutti i componenti il cui valore di Part Count è 2.
PartCount > 4
Restituisce tutti i componenti il cui valore di Part Count è maggiore di 4 (ovvero tutti i componenti multiparte contenenti più di quattro sottoparti).
Note
-
Assicurarsi che l'ambito della ricerca sia impostato su Components utilizzando il campo Search in nella finestra di dialogo Ricerca nelle librerie di file.
-
Durante la ricerca dei componenti, verranno interrogate tutte le librerie SchLib e IntLib disponibili o presenti lungo un percorso di ricerca definito.
-
Tutti i risultati sono riportati nell'elenco Query Results nel pannello Componenti.
Conteggio dei pin
Riepilogo
Restituisce tutti i componenti la cui proprietà Pin Count soddisfa la query.
Sintassi
PinCount : Number
Esempio di utilizzo
PinCount = 2
Restituisce tutti i componenti il cui valore di Pin Count è 2.
PinCount > 14
Restituisce tutti i componenti il cui valore di Pin Count è maggiore di 14.
Note
-
Assicurarsi che l'ambito della ricerca sia impostato su Components utilizzando il campo Search in nella finestra di dialogo Ricerca nelle librerie di file.
-
Durante la ricerca dei componenti, verranno interrogate tutte le librerie SchLib e IntLib disponibili o presenti lungo un percorso di ricerca definito.
-
Tutti i risultati sono riportati nell'elenco Query Results nel pannello Componenti.
Tutti
Descrizione
Riepilogo
Restituisce tutti i componenti o i footprint la cui proprietà Description soddisfa la query.
Sintassi
Description : String
Esempio di utilizzo
Description = 'TTL-RS232 DRIVER'
Restituisce tutti i componenti o i footprint la cui proprietà Description è TTL-RS232 DRIVER.
Description Like '*RS485*'
Restituisce tutti i componenti o i footprint la cui proprietà Description include RS485.
Note
-
Le entità restituite, componenti o footprint, dipendono dall'ambito scelto, definito tramite il campo Search in nella finestra di dialogo Ricerca nelle librerie di file.
-
Tutti i risultati sono riportati nell'elenco Query Results nel pannello Componenti.
Ha un parametro
Riepilogo
Restituisce tutti i componenti contenenti un oggetto parametro le cui proprietà Parameter Name e Value soddisfano la query.
Sintassi
HasParameter(Parameter Name : String,Value : String) : Boolean/Boolean_String
Esempio di utilizzo
HasParameter('Comment','1K')
HasParameter('Comment','1K') = True
HasParameter('Comment','1K') = 'True'
Restituisce tutti i componenti che contengono un oggetto parametro la cui proprietà Parameter Name è Comment e la cui proprietà Value è 1K.
Note
-
Le entità restituite, componenti o footprint, dipendono dall'ambito scelto, definito tramite il campo Search in nella finestra di dialogo Ricerca nelle librerie di file.
-
Tutti i risultati sono riportati nell'elenco Query Results nel pannello Componenti.
Nome della libreria
Riepilogo
Restituisce tutti i componenti o i footprint il cui nome della libreria di appartenenza soddisfa la query.
Sintassi
LibraryName : String
Esempio di utilizzo
LibraryName = 'Miscellaneous Devices.SchLib'
Restituisce tutti i componenti la cui libreria di appartenenza è Miscellaneous Devices.SchLib.
LibraryName Like 'Miscellaneous*.IntLib'
Restituisce tutti i componenti o i footprint il cui nome della libreria di appartenenza inizia con Miscellaneous e termina con .IntLib.
LibraryName Like '*Vishay*'
Restituisce tutti i componenti il cui nome della libreria di appartenenza contiene Vishay.
Note
-
Le entità restituite, componenti o footprint, dipendono dall'ambito scelto, definito tramite il campo Search in nella finestra di dialogo Ricerca nelle librerie di file.
-
Durante la ricerca dei componenti, verranno interrogate tutte le librerie SchLib, IntLib e DbLib disponibili o presenti lungo un percorso di ricerca definito. Durante la ricerca dei footprint, verranno interrogate tutte le librerie PcbLib e IntLib.
-
Tutti i risultati sono riportati nell'elenco Query Results nel pannello Componenti.
Percorso della libreria
Riepilogo
Restituisce tutti i componenti o i footprint presenti nella libreria specificata nella query.
Sintassi
LibraryPath : String
Esempio di utilizzo
LibraryPath = 'C:\Documents\Altium\Library\MyExampleLibrary.SchLib'
Restituisce tutti i componenti la cui libreria di appartenenza è MyExampleLibrary.SchLib e si trova nella cartella C:\Documents\Altium\Library.
LibraryPath Like ' C:\Documents\Altium\Library\Miscellaneous*.IntLib'
Restituisce tutti i componenti o i footprint il cui nome della libreria di appartenenza inizia con Miscellaneous e termina con .IntLib e la cui libreria si trova nella cartella C:\Documents\Altium\Library.
LibraryPath = 'C:\Test Projects\Example DBLib\VishayCapacitor.DBLib'
Restituisce tutti i componenti la cui libreria di appartenenza è VishayCapacitor.DBLib e si trova nella cartella C:\Test Projects\Example DBLib.
Note
-
Le entità restituite, componenti o footprint, dipendono dall'ambito scelto, definito tramite il campo Search in nella finestra di dialogo Ricerca nelle librerie di file.
-
Durante la ricerca dei componenti, verranno interrogate tutte le librerie SchLib, IntLib e DbLib disponibili lungo il percorso delle librerie definito. Durante la ricerca dei footprint, verranno interrogate tutte le librerie PcbLib e IntLib.
-
Tutti i risultati sono riportati nell'elenco Query Results nel pannello Componenti.
Nome
Riepilogo
Restituisce tutti i componenti o i footprint il cui nome soddisfa la query.
Sintassi
Name : String
Esempio di utilizzo
Name = 'Res1'
Restituisce tutti i componenti o i footprint il cui nome è Res1.
Name Like 'DIP*'
Restituisce tutti i componenti o i footprint il cui nome inizia con DIP.
Name Like '*33*'
Restituisce tutti i componenti o i footprint il cui nome contiene 33.
Note
-
Le entità restituite, componenti o footprint, dipendono dall'ambito scelto, definito tramite il campo Search in nella finestra di dialogo Ricerca nelle librerie di file.
-
Durante la ricerca dei componenti, verranno interrogate tutte le librerie SchLib e IntLib disponibili o presenti lungo un percorso di ricerca definito. Durante la ricerca dei footprint, verranno interrogate tutte le librerie PcbLib e IntLib.
-
Tutti i risultati sono riportati nell'elenco Query Results, nel pannello Componenti.
-
Il nome di un componente schematico viene verificato rispetto alla sua proprietà Design Item ID , mentre il nome di un footprint PCB viene verificato rispetto alla sua proprietà Footprint .
Nome della libreria sorgente
Riepilogo
Restituisce tutti i componenti o i footprint il cui nome della libreria sorgente di appartenenza soddisfa la query.
Sintassi
SourceLibraryName : String
Esempio di utilizzo
SourceLibraryName = 'Miscellaneous Devices.SchLib'
Restituisce tutti i componenti la cui libreria sorgente di appartenenza è Miscellaneous Devices.SchLib.
SourceLibraryName = 'Miscellaneous Devices.PcbLib '
Restituisce tutti i footprint la cui libreria sorgente di appartenenza è Miscellaneous Devices.PcbLib.
Note
-
Le entità restituite, componenti o footprint, dipendono dall'ambito scelto, definito tramite il campo Search in nella finestra di dialogo Ricerca nelle librerie di file.
-
Durante la ricerca di componenti, vengono interrogate solo le librerie sorgente degli schemi disponibili o presenti in un percorso di ricerca definito. Durante la ricerca di footprint, vengono interrogate solo le librerie PCB.
-
Tutti i risultati sono riportati nell'elenco Query Results nel pannello Componenti.
Percorso della libreria sorgente
Riepilogo
Restituisce tutti i componenti o footprint presenti nella libreria sorgente specificata nella query.
Sintassi
SourceLibraryPath : String
Esempi di utilizzo
SourceLibraryPath = ' C:\Documents\Altium\Library\MyExampleLibrary.SchLib'
Restituisce tutti i componenti la cui libreria sorgente di appartenenza è MyExampleLibrary.SchLib, se tale libreria si trova nella cartella C:\Documents\Altium\Library.
SourceLibraryPath = ' C:\Documents\Altium\Library\Miscellaneous Devices.PcbLib'
Restituisce tutti i footprint la cui libreria sorgente di appartenenza è Miscellaneous Devices.PcbLib, se tale libreria si trova nella cartella C:\Documents\Altium\Library.
SourceLibraryPath Like ' C:\Documents\Altium\Library\*'
Restituisce tutti i componenti o footprint la cui libreria sorgente di appartenenza si trova nella cartella C:\Documents\Altium\Library.
Note
-
Le entità restituite, componenti o footprint, dipendono dall'ambito scelto, definito tramite il campo Search in nella finestra di dialogo Ricerca nelle librerie di file.
-
Durante la ricerca di componenti, vengono interrogate solo le librerie degli schemi disponibili nel percorso delle librerie definito. Durante la ricerca di footprint, vengono interrogate solo le librerie PCB.
-
Tutti i risultati sono riportati nell'elenco Query Results nel pannello Componenti.
Footprint
Altezza
Riepilogo
Restituisce tutti i footprint la cui proprietà Height soddisfa la query.
Sintassi
Height : Number
Number segue le unità di misura attualmente utilizzate per la libreria: imperiali (mil; 1 mil = 0,001 pollici) o metriche (mm; 1 mm = 0,001 metri).
Esempi di utilizzo
Height = 300
Restituisce tutti i footprint con una proprietà Height pari a 300 nelle unità di misura correnti.
Height >= 5.08
Restituisce tutti i footprint con una proprietà Height maggiore o uguale a 5.08 nelle unità di misura correnti.
Height <> 550
Restituisce tutti i footprint con una proprietà Height che è not pari a 550 nelle unità di misura correnti.
Note
-
Assicurarsi che l'ambito della ricerca sia impostato su Components tramite il campo Search in nella finestra di dialogo Ricerca nelle librerie di file.
-
Durante la ricerca di footprint, vengono interrogate tutte le librerie PcbLib e IntLib disponibili o presenti in un percorso di ricerca definito.
-
Tutti i risultati sono riportati nell'elenco Query Results nel pannello Componenti.
Numero di pad
Riepilogo
Restituisce tutti i footprint la cui proprietà Pad Count soddisfa la query.
Sintassi
PadCount : Number
Esempi di utilizzo
PadCount = 2
Restituisce tutti i footprint il cui valore di Pad Count è 2.
PadCount > 14
Restituisce tutti i footprint il cui valore di Pad Count è maggiore di 14.
Note
-
Assicurarsi che l'ambito della ricerca sia impostato su Components tramite il campo Search in nella finestra di dialogo Ricerca nelle librerie di file.
-
Durante la ricerca di footprint, vengono interrogate tutte le librerie PcbLib e IntLib disponibili o presenti in un percorso di ricerca definito.
-
Tutti i risultati sono riportati nell'elenco Query Results nel pannello Componenti.