Annotazione dei componenti in un progetto
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
A colpo d'occhio
- Scopri lo scopo dell'annotazione del progetto e perché i designatori univoci dei componenti sono importanti negli schemi elettrici, nel layout PCB e nei documenti di output, come la distinta base (BOM).
- Comprendi le differenze tra l'annotazione a livello di schema, PCB e scheda, inclusi i tipi di progetto per cui ciascun approccio è più indicato.
- Ottieni una panoramica della finestra di dialogo Annotate e delle principali impostazioni utilizzate per controllare l'ambito dell'annotazione, l'ordine di elaborazione, le opzioni di corrispondenza e le modifiche proposte.
L'annotazione del progetto è il processo sistematico e metodico che garantisce che ogni componente del progetto possa essere identificato singolarmente mediante un designatore univoco. Sebbene Altium Designer sia in grado di mantenere l'identità dei componenti utilizzando identificatori univoci globali (GUID), tradizionalmente la maggior parte dei progettisti utilizza il designatore del componente come riferimento principale nei domini dello schema elettrico (logico) e del PCB (fisico), nonché negli output come la distinta base (BOM).
Esistono tre approcci all'annotazione di un progetto. La scelta dello strumento di annotazione dipende da diversi fattori, tra cui il tipo di progetto, le preferenze personali e le politiche e procedure aziendali.
Schematic Level Annotation
L'annotazione a livello di schema utilizza una visione puramente logica del progetto per determinare i designatori dei componenti. È particolarmente utile per i progetti semplici che non utilizzano fogli dispositivo, ma, poiché consente di specificare l'ordine di elaborazione e offre la possibilità di completare i package esistenti per i componenti multiparte, costituisce anche un prerequisito per l'annotazione a livello di scheda.
In sintesi, l'annotazione a livello di schema consente di:
- Raggruppare le parti dei componenti multiparte nei rispettivi package.
- Annotare i componenti in base alla loro posizione nello schema elettrico.
- Annotare i progetti multicanale utilizzando lo schema di denominazione predefinito specificato nelle opzioni del progetto.
- Preparare un progetto per un'ulteriore annotazione.
PCB Annotation
L'annotazione PCB utilizza la posizione fisica dei componenti sul PCB per determinarne i designatori. Ciò consente di codificare efficacemente le informazioni sulla posizione nel designatore di un componente e può essere molto utile durante il debug di un PCB assemblato. In breve, l'annotazione PCB va utilizzata per annotare i componenti in base alla loro posizione sulla scheda nel progetto PCB.
Board Level Annotation
L'annotazione a livello di scheda fornisce una mappatura tra i designatori utilizzati nello schema elettrico (logico) e le loro controparti reali nel progetto PCB (fisico). Sebbene possa essere utilizzata in qualsiasi progetto, è particolarmente utile per i progetti multicanale o per quelli che incorporano fogli dispositivo in cui i designatori non possono essere modificati direttamente sul foglio dispositivo. In questo modo, è possibile annotare nuovamente l'intero progetto senza modificare effettivamente i fogli dispositivo originali. L'annotazione a livello di scheda risolve gli eventuali conflitti di annotazione dovuti a designatori duplicati all'interno di un progetto e memorizza le modifiche in un *.Annotation file di testo. Include parole chiave aggiuntive per personalizzare gli schemi di denominazione e consente di applicarli a tutte le parti o solo a un insieme selezionato.
In sintesi, l'annotazione a livello di scheda consente di:
- Annotare i componenti compilati nei fogli dispositivo.
- Assegnare nomi univoci a tutti i componenti su più canali utilizzando schemi di denominazione che includono annotazione posizionale, indicizzazione globale e altre opzioni configurabili.
- Assegnare manualmente i nomi ai componenti.
Annotazione dello schema
L'annotazione dello schema viene configurata tramite la finestra di dialogo Annotate . La finestra di dialogo fornisce i controlli per assegnare sistematicamente i designatori a tutte le parti o a quelle selezionate nei fogli selezionati di un progetto e garantisce che i designatori siano univoci e ordinati in base alla posizione. Le opzioni di annotazione possono essere configurate per raggruppare le parti dei componenti multiparte nei package, impostare le opzioni relative a indici e suffissi, reimpostare i designatori dello schema, inclusi quelli duplicati, e riportare nello schema l'annotazione dal PCB.
Si accede alla finestra di dialogo Annotate eseguendo il comando Annota schemi (Tools » Annotation » Annotate Schematics).

La finestra di dialogo Annotate viene aperta tramite il comando Annotate Schematics.
La finestra di dialogo è suddivisa in due aree principali:
- Schematic Annotation Configuration - quest'area consente di configurare lo schema di annotazione e l'ambito dell'annotazione.
- Proposed Change List - quest'area elenca le modifiche proposte che verranno apportate una volta accettate ed eseguite mediante un ordine di modifica tecnica (ECO).
Opzioni e controlli della finestra di dialogo di annotazione
Configurazione dell'annotazione dello schema
Ordine di elaborazione
Utilizzare quest'area per specificare il metodo di annotazione posizionale desiderato. Quando si seleziona un metodo dall'elenco a discesa, la rappresentazione grafica associata si aggiorna dinamicamente per illustrare come verranno annotati i componenti. Scegliere tra i seguenti metodi di annotazione posizionale:
- Up Then Across
- Down Then Across
- Across Then Up
- Across Then Down
Posizione di riferimento per l'elaborazione
Utilizzare quest'area per specificare il riferimento per la posizione dei componenti durante l'elaborazione dell'ordine di annotazione. Scegliere tra le seguenti opzioni:
- Designator - il designatore del componente viene utilizzato come riferimento per la sua posizione nel determinare l'ordine di elaborazione.
- Part - il centro del componente viene utilizzato come riferimento per la sua posizione nel determinare l'ordine di elaborazione.
Sostituisci sottoparti
Utilizzare l'elenco a discesa per scegliere se sostituire o meno le sottoparti durante il processo di annotazione.
Opzioni di corrispondenza
Quando si utilizzano package multiparte, è spesso opportuno raggruppare il maggior numero possibile di parti nel minor numero di componenti fisici, poiché ciò riduce al minimo il costo complessivo della distinta base del progetto. I controlli in quest'area consentono di definire come verranno abbinate e raggruppate le parti, nonché i criteri utilizzati per determinare i raggruppamenti validi.
-
Complete Existing Packages - utilizzare questo controllo per decidere se e come includere nei package esistenti le parti non ancora annotate. Utilizzare l'elenco a discesa per scegliere tra le seguenti opzioni:
- None - i package esistenti non verranno completati e tutte le nuove parti verranno inserite in nuovi package.
- Per Sheet - i package esistenti includeranno solo nuove parti provenienti dallo stesso foglio dello schema.
- Whole Project - i package esistenti includeranno nuove parti provenienti da qualsiasi foglio dello schema del progetto.
- Component Parameter - questo elenco include tutti i parametri presenti nei componenti del progetto corrente. Selezionare la casella associata a un parametro per utilizzarlo nell'abbinamento delle parti nei package. Se i componenti multiparte condividono gli stessi parametri abilitati e un valore comune, verranno raggruppati nello stesso package (a condizione che l'opzione Complete Existing Packages non sia impostata su None). Anche gli eventuali componenti rimanenti che non dispongono dei parametri abilitati vengono raggruppati insieme.
- Strictly - abilitare questa opzione per un Component Parameter nell'elenco per indicare che tutti i componenti must avere quel parametro per essere raggruppati in un package. I componenti che non dispongono di questo parametro vengono annotati come componenti singoli e non vengono raggruppati in package.
Menu contestuale
- Parameter » Enable Selected Parameters - consente di selezionare la casella di controllo 'Includi' per tutti i parametri attualmente selezionati nell'elenco.
- Parameter » Enable All Parameters - consente di selezionare la casella di controllo 'Includi' per tutti i parametri nell'elenco.
- Parameter » Disable Selected Parameters - consente di deselezionare la casella di controllo 'Includi' per tutti i parametri attualmente selezionati nell'elenco.
- Parameter » Disable All Parameters - consente di deselezionare la casella di controllo 'Includi' per tutti i parametri nell'elenco.
- Match Strictly » Enable Strict Matching On Selected Parameters - consente di abilitare l'opzione Strictly per tutti i parametri attualmente selezionati nell'elenco.
- Match Strictly » Enable Strict Matching On All Parameters - consente di abilitare l'opzione Strictly per tutti i parametri nell'elenco.
- Match Strictly » Disable Strict Matching On Selected Parameters - consente di disabilitare l'opzione Strictly per tutti i parametri attualmente selezionati nell'elenco.
- Match Strictly » Disable Strict Matching On All Parameters - consente di disabilitare l'opzione Strictly per tutti i parametri nell'elenco.
- Selection » Select All - consente di selezionare tutte le voci dei parametri nell'elenco.
- Selection » Deselect All - consente di deselezionare tutte le voci dei parametri nell'elenco.
- Selection » Invert Selection - consente di selezionare tutti i parametri attualmente non selezionati nell'elenco e di deselezionare quelli selezionati.
Fogli schematici da annotare
Questa sezione della finestra di dialogo elenca tutti i fogli schematici sorgente del progetto. I controlli disponibili in questa sezione consentono di determinare quali fogli includere nel processo di annotazione e le modalità di calcolo delle modifiche di annotazione. Per ciascun foglio vengono presentati i seguenti elementi:
- Include/Exclude checkbox - selezionare questa casella di controllo per includere il foglio schematico nel processo di annotazione.
- Schematic Sheet - questo campo visualizza il nome del foglio schematico.
-
Annotation Scope - utilizzare questo campo per determinare l'ambito dell'annotazione rispetto ai componenti sul foglio. Utilizzare l'elenco a discesa per scegliere uno dei seguenti ambiti:
- All - verranno annotate tutte le parti sul foglio schematico.
- Ignore Selected Parts - verranno annotate tutte le parti, tranne quelle attualmente selezionate nel progetto.
- Only Selected Parts - verranno annotate solo le parti attualmente selezionate nel progetto.
- Order - utilizzare questo campo per specificare la posizione di questo foglio nell'ordine complessivo di annotazione dei fogli. Digitare il numero d'ordine desiderato direttamente nel campo oppure utilizzare le frecce che compaiono facendo clic nel campo per scorrere fino al valore desiderato.
- Designator Index Control - utilizzare i controlli in questa colonna per abilitare l'uso di un indice iniziale (selezionando la casella associata) e definirne il valore. Il valore del designatore partirà da questo valore di indice.
- Add Suffix - utilizzare questo campo per specificare un suffisso da aggiungere a ciascun designatore annotato. Sono supportati suffissi alfabetici (A, B, C...), numerici (1, 2, 3...) e non alfanumerici (_ * . %...), comprese le loro combinazioni.
Additional Controls
- All On - fare clic per includere tutti i fogli schematici nel processo di annotazione.
- All Off - fare clic per escludere tutti i fogli schematici dal processo di annotazione.
-
Right-Click Menu - nel menu contestuale della sezione, accessibile con il pulsante destro del mouse, sono disponibili i seguenti comandi:
-
Order Alphabetically - consente di ordinare alfabeticamente l'elenco degli schemi. Questa operazione influisce sulla voce Order associata a ciascun foglio.
-
Order By Project Order - consente di ordinare l'elenco degli schemi in base all'ordine in cui compaiono nel progetto (come visualizzato nel pannello Projects ). Questa operazione influisce sulla voce Order associata a ciascun foglio.
-
All On - consente di includere tutti i fogli schematici nel processo di annotazione.
-
All Off - consente di escludere tutti i fogli schematici dal processo di annotazione.
-
Elenco delle modifiche proposte
-
Main List - questa sezione della finestra di dialogo elenca tutti i designatori delle parti contenute nei fogli selezionati per l'annotazione. Per ogni voce sono inclusi i dettagli dei valori Current e Proposed Designator , insieme a Sub (parte) del componente e a Location of Part di origine. Le icone a forma di lucchetto vengono utilizzate per indicare le colonne bloccate, impedendo modifiche ai designatori e alle sottoparti.
Selezionando la casella accanto a un designatore nella colonna Current ('designatore bloccato'), si impedisce qualsiasi modifica a quel designatore specifico. Analogamente, selezionando la casella accanto al campo Sub di un designatore ('sottoparte bloccata'), si impedisce l'aggiornamento di quella specifica sottoparte del componente multiparte a cui appartiene.
Nel menu contestuale della sezione sono disponibili i seguenti comandi:
- Designator » Lock Selected Designators - consente di selezionare la casella di controllo 'designatore bloccato' per tutti i designatori attualmente selezionati nell'elenco.
- Designator » Lock All Designators - consente di selezionare la casella di controllo 'designatore bloccato' per tutti i designatori.
- Designator » Unlock Selected Designators - consente di deselezionare la casella di controllo 'designatore bloccato' per tutti i designatori attualmente selezionati nell'elenco.
- Designator » Unlock All Designators - consente di deselezionare la casella di controllo 'designatore bloccato' per tutti i designatori.
- Part ID » Lock Selected Part ID - consente di selezionare la casella di controllo 'sottoparte bloccata' per tutti i designatori attualmente selezionati nell'elenco.
- Part ID » Lock All Part ID - consente di selezionare la casella di controllo 'sottoparte bloccata' per tutti i designatori.
- Part ID » Unlock Selected Part ID - consente di deselezionare la casella di controllo 'sottoparte bloccata' per tutti i designatori attualmente selezionati nell'elenco.
- Part ID » Unlock All Part ID - consente di deselezionare la casella di controllo 'sottoparte bloccata' per tutti i designatori.
- Selection » Select All - consente di selezionare tutte le voci dei designatori nell'elenco.
- Selection » Select All With '?' - consente di selezionare tutte le voci il cui designatore attuale contiene ? (ovvero che sono state reimpostate).
- Selection » Deselect All - consente di deselezionare tutte le voci dei designatori nell'elenco.
- Selection » Invert Selection - consente di selezionare tutti i designatori attualmente non selezionati nell'elenco e di deselezionare quelli selezionati.
- Annotation Summary - quest'area fornisce un riepilogo dell'annotazione in termini di numero di fogli coinvolti e opzioni di corrispondenza. Si aggiorna dinamicamente quando vengono apportate modifiche a queste impostazioni.
- Update Changes List - fare clic per aggiornare l'elenco principale delle modifiche proposte con le nuove modifiche calcolate in base alle impostazioni di annotazione definite sul lato sinistro della finestra di dialogo. Una finestra di dialogo informativa mostrerà il numero di modifiche apportate rispetto allo stato precedente e a quello originale.
- Reset All - fare clic per ripristinare tutti i designatori nell'elenco principale (che non sono bloccati) ai prefissi predefiniti dei rispettivi componenti, ad es. R?, C?, D?. Le modifiche verranno caricate nella colonna dei designatori Proposed . Il menu a discesa del pulsante consente di cambiare il comando in Reset Duplicates. Se due o più componenti hanno lo stesso designatore, tutti tranne uno verranno reimpostati ai rispettivi prefissi predefiniti. Anche in questo caso, una finestra di dialogo informativa mostrerà il numero di modifiche apportate rispetto allo stato precedente e a quello originale.
- Back Annotate - fare clic per aprire una finestra di dialogo in cui cercare e selezionare il file per la retroannotazione.
- Accept Changes (Create ECO) - dopo aver esaminato tutte le modifiche proposte, fare clic su questo pulsante per accedere alla finestra di dialogo Engineering Change Order, che elenca le modifiche proposte nella categoria di modifica Annota componente. Utilizzare questa finestra di dialogo per convalidare ed eseguire l'ECO, completando il processo di annotazione a livello di schema.
Bloccare i componenti
Per i componenti multiparte non omogenei, assicurarsi che le icone di blocco siano chiuse nel pannello Properties per impedire modifiche alle sottoparti durante l'annotazione.
Opzione Strictly
Se la casella di controllo Strictly è abilitata per un Component Parameter, tutti i componenti devono avere un valore corrispondente di tale parametro per essere raggruppati in un package. I componenti che non dispongono di questo parametro vengono annotati come componenti singoli e non vengono raggruppati.
L'esempio seguente illustra come queste opzioni si combinano per ottenere un risultato specifico:
Si consideri un progetto con otto porte OR e otto resistori (come mostrato nell'immagine seguente). Le porte OR contengono un parametro denominato QuadOrGate: un gruppo di quattro porte OR ha il valore del parametro Package1 e l'altro gruppo di quattro porte OR ha il valore Package2. I resistori non dispongono di questo parametro. Abilitando la casella di controllo per QuadOrGate nel controllo Component Parameter, questo parametro verrà utilizzato per determinare il raggruppamento dei componenti nei package; in questo caso, la casella di controllo Strictly non è abilitata.
Dopo aver avviato il comando Tools » Annotation » Annotate Schematics, le parti con il parametro QuadOrGate = Package1 verranno raggruppate nello stesso componente fisico, mentre quelle con il parametro QuadOrGate = Package2 verranno raggruppate separatamente. Tutti i componenti rimanenti che non dispongono del parametro QuadOrGate verranno raggruppati insieme. In questo caso, i resistori vengono raggruppati insieme poiché la loro caratteristica comune è l'assenza del parametro QuadOrGate.

Esempio di componenti raggruppati quando l'opzione Strictly non è selezionata.
Se si annota lo stesso progetto con l'opzione Strictly selezionata, verranno raggruppati solo i componenti che dispongono del parametro QuadOrGate . In questo caso, le porte OR verranno raggruppate, mentre i resistori rimarranno separati. Di conseguenza, sebbene l'opzione Strictly offra un controllo estremamente preciso sul processo di raggruppamento, nella maggior parte dei casi è opportuno lasciarla deselezionata.

Esempio di componenti raggruppati quando l'opzione Strictly è selezionata.
Fogli schematici da annotare
È possibile controllare in modo dettagliato quali fogli schematici e componenti saranno interessati dall'annotazione e come verranno calcolate le modifiche.

Definizione dell'ambito dell'annotazione.
- Un segno di spunta nella casella a sinistra del foglio schematico elencato indica che il foglio verrà elaborato dal comando di annotazione.
- L'ambito dell'annotazione è determinato dall'elenco a discesa Annotation Scope e può essere esteso all'intero foglio schematico o limitato ai componenti selezionati o non selezionati. L'utilizzo delle opzioni Ignore Selected Parts o Only Selected Parts richiede che i componenti siano stati selezionati nel progetto prima di eseguire il comando di annotazione.
- Configurare l'ordine in cui annotare i fogli schematici utilizzando il campo Order. Digitare un valore direttamente nel campo oppure utilizzare le frecce che compaiono quando si fa clic nel campo per impostare il valore desiderato.
- Se l'opzione Designator Index Control è selezionata, la numerazione dei designatori inizierà dal valore Start Index. Il valore Start Index non ha alcun effetto se l'opzione Designator Index Control non è selezionata.
- È possibile aggiungere un ulteriore suffisso alla fine di ciascun designatore specificando una stringa o un valore nella colonna Suffix associata. Evitare suffissi di un solo carattere, come 'A' o '1', poiché possono essere facilmente confusi con le sottoparti e/o con altri valori dei designatori.
Elenco delle modifiche proposte
Fare clic sul pulsante Update Changes List per aggiornare Proposed Change List, in modo da poter esaminare tutte le modifiche ai designatori prima di applicarle. Verranno modificati solo i designatori non ancora assegnati (ad es. R?, C?, ecc.). Pertanto, se si desidera aggiornare tutti i designatori del progetto, è necessario prima reimpostarli premendo il pulsante Reset All.

Reimpostazione dei designatori prima di applicare le impostazioni di annotazione.
Proposed Change List elenca tutti i designatori delle parti contenute nei fogli selezionati per l'annotazione. Per ogni voce sono riportati i valori dei designatori Current e Proposed, insieme alla Sub (parte) del componente e al Location of Part di origine.
Selezionando la casella associata a un Designator , si impedisce qualsiasi modifica a quel designatore specifico. Analogamente, selezionando la casella Sub , si impedisce l'aggiornamento di quello specifico componente multiparte. Questa opzione può essere utilizzata in alternativa all'impostazione dell'icona Lock nel pannello Properties .
Dopo aver esaminato l'elenco delle modifiche proposte, fare clic sul pulsante Accept Changes (Create ECO) per aprire la finestra di dialogo Engineering Change Order. Una volta eseguito l'ECO, le modifiche di annotazione verranno applicate al progetto.
Ulteriori comandi di annotazione dello schema
Il menu Strumenti » Annotation contiene diversi comandi specifici per l'annotazione dello schema. La prima voce del gruppo, Annotate Schematic, è già stata trattata.

I vari comandi di annotazione disponibili
Reimpostare i designatori dello schema
Se ampie porzioni di contenuto sono state tagliate e incollate da fonti diverse in un nuovo progetto, potrebbe essere necessario reimpostare tutti i designatori. Poiché questo comando utilizza le impostazioni della finestra di dialogo Annotazione , verrà applicato agli elementi precedentemente impostati in tale finestra. Ad esempio, se in precedenza erano stati selezionati tutti i Schematic Sheets To Annotate, il comando Reset Schematic Designators verrà applicato all'intero progetto, indipendentemente dal fatto che i fogli siano attualmente aperti nell'editor. Se in precedenza erano stati selezionati solo alcuni Schematic Sheets To Annotate, il comando Reset Schematic Designators avrà effetto solo su quei fogli.
Dopo l'avvio del comando, verrà visualizzata una finestra di dialogo di conferma che riepiloga il numero di designatori da aggiornare e chiede se si desidera procedere con le modifiche. Dopo aver fatto clic su Yes, tutti i designatori dei componenti presenti in tutti i fogli schematici del progetto attivo abilitati all'annotazione verranno reimpostati e appariranno nella forma: R?, C?, D?, U?, ecc.
I designatori bloccati non vengono reimpostati né modificati in alcun modo.
Reimpostazione dei designatori schematici duplicati
Quando si duplicano porzioni di un progetto, i componenti appena copiati mantengono gli stessi valori dei designatori dei componenti originali. Il comando Reset Duplicate Schematic Designators consente di reimpostare rapidamente i designatori duplicati su '?'. Poiché questo comando utilizza le impostazioni della finestra di dialogo Annotate , verrà applicato agli elementi precedentemente impostati in tale finestra. Ad esempio, se in precedenza erano stati selezionati tutti i Schematic Sheets To Annotate, il comando Reset Duplicate Schematic Designators verrà applicato all'intero progetto, indipendentemente dal fatto che i fogli siano attualmente aperti nell'editor. Se in precedenza erano stati selezionati solo alcuni Schematic Sheets to Annotate, il comando Reset Schematic Designators avrà effetto solo su quei fogli.
Dopo l'avvio del comando, verrà visualizzata una finestra di dialogo di conferma che riepiloga il numero di designatori da aggiornare e chiede se si desidera procedere con le modifiche. Dopo aver fatto clic su Yes, tutti i designatori dei componenti duplicati individuati in tutti i fogli schematici del progetto attivo abilitati all'annotazione verranno reimpostati e appariranno nella forma: R?, C?, D?, U?, ecc.
I designatori bloccati non vengono reimpostati né modificati in alcun modo.
Annotazione degli schemi senza finestre di dialogo
Il comando Annotate Schematics Quietly consente di esaminare tutti i documenti schematici sorgente del progetto attivo abilitati all'annotazione e di assegnare un designatore univoco a ogni componente che ne è attualmente privo. L'annotazione viene eseguita senza visualizzare finestre di dialogo, consentendo di applicare tutte le impostazioni precedenti della finestra di dialogo Annotate senza doverla riaprire. Questa funzione è particolarmente utile quando il progetto attraversa una fase di rapido sviluppo e il progettista desidera eseguire velocemente l'annotazione prima di compilare il progetto.
Annotazione forzata di tutti gli schemi
Questo comando consente di esaminare tutti i documenti schematici sorgente del progetto attivo abilitati all'annotazione e di annotare nuovamente tutti i componenti in essi contenuti in base al criterio di annotazione attualmente definito nella finestra di dialogo Annotate.
L'esecuzione del comando Force Annotate All Schematics equivale a eseguire il comando Reset Schematic Designators seguito immediatamente dal comando Annotate Schematics Quietly. Di conseguenza, il comando Force Annotate All Schematics utilizza le impostazioni precedentemente definite nella finestra di dialogo Annotate per determinare quali componenti e fogli possono essere aggiornati.
Dopo l'avvio di questo comando, viene visualizzata una richiesta di conferma che specifica il numero di designatori che verranno aggiornati in caso di accettazione. Dopo aver fatto clic su Yes, tutti i designatori dei componenti presenti in tutti i fogli schematici del progetto attivo abilitati all'annotazione verranno annotati nuovamente, ove necessario, per rispettare il criterio di annotazione posizionale attualmente definito nell'area Schematic Annotation Configuration della finestra di dialogo Annotate .
Retroannotazione degli schemi
Prima dell'introduzione di Design Compiler e Synchronizer di Altium Designer, le modifiche all'annotazione venivano tradizionalmente trasferite dallo schema al PCB tramite un file netlist (*.net). Le modifiche all'annotazione da propagare nella direzione opposta, dal PCB allo schema, venivano gestite tramite un processo di retroannotazione. Questo processo utilizza un file Was-Is (*.WAS) o un file di ordine di modifica tecnica (Engineering Change Order, *.ECO) per indicare le modifiche da applicare ai designatori dello schema.
Dopo l'avvio del comando, verrà visualizzata la finestra di dialogo Choose WAS-IS File for Back-Annotation from PCB. Individua e seleziona il file .was (o .eco) richiesto. Dopo aver fatto clic su Open, verrà visualizzata una finestra di dialogo informativa che indica quante modifiche ai designatori sono state apportate rispetto allo stato precedente e quante rispetto allo stato originale. A questo punto, le modifiche non sono ancora state effettivamente applicate. Fai clic su OK per aprire la finestra di dialogo Annotate, da cui puoi visualizzare le modifiche proposte ai designatori attuali prima di decidere se creare un ECO per applicarle.
Numerazione dei fogli schematici
Il comando Number Schematic Sheets non modifica i designatori dei componenti, bensì i designatori (numeri) dei fogli schematici. Dal punto di vista concettuale, è quindi collegato al concetto generale di annotazione del progetto.
La numerazione dei fogli e dei documenti consente di controllare i designatori dei fogli e di memorizzarli come parametri nei rispettivi documenti schematici. La funzione delle stringhe speciali di Altium Designer (=SheetNumber, =DocumentNumber, =SheetTotal) può quindi essere utilizzata per visualizzare questi valori sul foglio (ad esempio, nel piè di pagina) come oggetti di testo.

Numerazione dei fogli schematici.
La procedura di numerazione dei fogli è la seguente:
Numerazione automatica dei fogli (opzione di progetto)
Abilita questa opzione per eseguire la numerazione automatica dei fogli. I valori verranno visualizzati nel pannello Projects. Puoi anche abilitare la numerazione automatica dei fogli selezionando l'opzione Automatic Sheet Numbering nella scheda Opzioni della finestra di dialogo Project Options.
Numerazione automatica dei fogli
Fai clic sul pulsante a discesa Auto Sheet Number per accedere alle opzioni di numerazione dei fogli.
Le opzioni di Select Numbering Scheme sono:
- Display Order - i fogli vengono numerati nell'ordine in cui sono visualizzati.
- Sheets Hierarchical Structure - Depth First - i fogli vengono numerati a partire dal livello superiore, procedendo lungo ciascun ramo. Viene numerato prima il livello superiore, quindi viene numerato interamente il primo ramo sottostante, poi il secondo e così via.
- Sheets Hierarchical Structure - Breadth First - i fogli vengono numerati in base al loro livello nella gerarchia. Viene numerato prima il livello superiore, poi tutti i fogli del secondo livello e così via.
Le opzioni Select Numbering Method consentono di selezionare valori sequenziali Increasing o Decreasing .
Numerazione automatica dei documenti
Fai clic sul menu a discesa Auto Document Number per accedere alle opzioni di numerazione dei documenti. Sono sostanzialmente le stesse opzioni di Auto Sheet Number, con l'aggiunta dei valori Prefix e Postfix .
Le opzioni Parameters sono le seguenti:
-
Prefix - scegli un prefisso da inserire prima del numero del documento. Sono supportati prefissi alfabetici (
A,B,C, ecc.), numerici (1,2,3, ecc.) e non numerici (_,*,.,%, ecc.), comprese combinazioni di tutti questi tipi. - Start - scegli un valore numerico da cui iniziare la numerazione.
-
Postfix - scegli un suffisso da aggiungere al numero del documento. Sono supportati suffissi alfabetici (
A,B,C, ecc.), numerici (1,2,3, ecc.) e non numerici (_,*,.,%, ecc.), comprese combinazioni di tutti questi tipi. - Step - scegli il valore di cui incrementare ciascun numero di documento. Ad esempio, se l'indice Start è impostato su 1 e il valore Step è impostato su 100, il primo numero di documento sarà 1, il successivo sarà 101 (valore iniziale + incremento), quello seguente 201 e così via.
Aggiornamento del conteggio dei fogli
Fai clic sul pulsante Update Sheet Count per contare i fogli del progetto corrente e inserire il risultato nella colonna SheetTotal. Il conteggio corrisponderà al numero totale di fogli del progetto, indipendentemente dallo schema di numerazione selezionato in uno dei due controlli precedenti.
Spostamento verso l'alto o verso il basso
Usa i pulsanti Move Up o Move Down per spostare un documento schematico selezionato verso l'alto o verso il basso nell'elenco. Questa operazione è rilevante quando si utilizza lo schema di numerazione Display Order per specificare i numeri dei fogli o dei documenti.
Numerazione e denominazione personalizzate
Se un'organizzazione utilizza un sistema di numerazione o denominazione specifico che non può essere automatizzato tramite i comandi Auto Sheet Number o Auto Document Number, è possibile inserire nomi e numeri di foglio personalizzati direttamente nei campi SheetNumber o DocumentNumber .
Numerazione dei fogli schematici e Device Sheets
Non è possibile configurare i numeri di foglio o di documento per i Device Sheets quando sono di sola lettura (stato predefinito); nella finestra di dialogo Numerazione dei fogli del progetto saranno contrassegnati da un tratteggio incrociato per indicare che non possono essere aggiornati. Quando i Device Sheets vengono impostati come modificabili, il tratteggio viene rimosso e la numerazione dei fogli e dei documenti può essere configurata normalmente.
Controllo della visualizzazione del designatore sul PCB
Le stringhe dei designatori estesi in un progetto multicanale possono essere scomode da posizionare nell'editor PCB. Puoi scegliere opzioni di denominazione che generino un nome breve oppure visualizzare il designatore logico originale del componente. Ad esempio, C30_CIN1 verrebbe visualizzato come C30. In questo caso sarebbe necessario aggiungere alla scheda un'altra indicazione per distinguere i canali, ad esempio disegnando un riquadro attorno a ciascun canale sulla serigrafia dei componenti.
Puoi scegliere se visualizzare i designatori logici o fisici sul PCB utilizzando il menu a discesa Designator Display nell'area Other del pannello Properties in modalità Board . Se scegli di visualizzare i designatori logici dei componenti in un progetto multicanale, questi verranno visualizzati sul PCB e in tutti gli output generati, come stampe e file Gerber. I designatori fisici univoci, tuttavia, vengono sempre utilizzati per generare la distinta base.
Sincronizzazione del progetto - Completamento del processo di annotazione
La sincronizzazione diretta del progetto è il metodo preferito per mantenere allineati i designatori dello schema e del PCB, a meno che tu non abbia accesso a entrambi gli editor. La sincronizzazione del progetto confronta i componenti e le connessioni dello schema direttamente con quelli del PCB, producendo un elenco delle differenze. Viene quindi generato un elenco delle modifiche necessarie per risolvere tali differenze sotto forma di ECO (Engineering Change Order, ordine di modifica tecnica). Un file ECO descrive le differenze tra il progetto corrente e quello desiderato e può essere eseguito per aggiornare la destinazione e sincronizzare il progetto.
Sincronizzazione diretta e inversa
I termini sincronizzazione diretta e sincronizzazione inversa descrivono la direzione in cui vengono trasferite le modifiche all'annotazione e al progetto durante la sincronizzazione dei dati. Considerando un flusso di progettazione che parte dallo schema ed è guidato da esso, la sincronizzazione diretta è il processo che trasferisce al PCB le modifiche apportate nell'editor degli schemi. La sincronizzazione inversa è il processo che trasferisce all'editor degli schemi le modifiche apportate al PCB.
Sincronizzazione diretta
Ecco alcuni motivi per sincronizzare i dati dallo schema al PCB:
- È stato aggiunto un nuovo componente nell'editor degli schemi ed è necessario inserirlo nel layout del PCB.
- Hai annotato il progetto schematico per la prima volta o dopo l'ultima sincronizzazione del progetto.
- In un progetto multicanale, hai modificato Project Options per cambiare lo stile di denominazione fisico (PCB).
- Hai eseguito un'annotazione a livello di scheda per la prima volta o dopo l'ultima sincronizzazione del progetto.
Sincronizzare il progetto schematico con il progetto PCB
Scegli uno dei seguenti metodi per sincronizzare il progetto schematico con il progetto PCB:
- Seleziona Update PCB Document nel menu Design dell'editor degli schemi. Se esistono differenze rispetto al documento PCB di destinazione, si apre la finestra di dialogo Engineering Change Order con un elenco delle modifiche necessarie per sincronizzare il PCB con il progetto schematico. Fai clic su Execute Changes per sincronizzare il progetto.
- Seleziona Import Changes nel menu Design dell'editor PCB per importare le modifiche dai documenti schematici al documento PCB.
Sincronizzazione inversa
La sincronizzazione inversa viene eseguita quando hai annotato o modificato il progetto PCB e desideri aggiornare il progetto schematico.
Sincronizzare il progetto PCB con il progetto schematico
Scegli uno dei seguenti metodi per sincronizzare il progetto PCB con il progetto schematico:
-
Nell'editor PCB, seleziona Update Schematics nel menu Design . Per impostazione predefinita, l'opzione Push Component Designator Changes to Annotation File (if any) nella scheda Generazione ECO della finestra di dialogo Project Options è selezionata, quindi le modifiche apportate nell'editor PCB verranno trasferite solo al file di annotazione e, successivamente, ai documenti compilati durante la compilazione. Deseleziona questa opzione per trasferire le modifiche solo al documento schematico sorgente (vista Editor ).
- Dall'editor degli schemi, seleziona Tools » Annotation » Annotate Schematics, quindi fai clic sul pulsante Back Annotate nella finestra di dialogo Annotazione. Scegli il file WAS-IS generato durante la riannotazione dei designatori nell'ambiente PCB.
- Dall'editor degli schemi, seleziona Tools » Annotation » Board Level Annotate, quindi fai clic sul pulsante Back Annotate nella finestra di dialogo Annotazione a livello di scheda. Scegli il file WAS-IS generato durante la riannotazione dei designatori nell'ambiente PCB.
- Dall'editor degli schemi, seleziona Tools » Annotation » Back Annotate Schematics. Scegli il file WAS-IS generato durante la riannotazione dei designatori nell'ambiente PCB.
Metodi tradizionali di sincronizzazione del progetto
Altium Designer supporta l'approccio tradizionale basato su file intermedi (netlist e WAS/IS) per la sincronizzazione del progetto. La sincronizzazione diretta dei dati di annotazione può essere eseguita utilizzando un file netlist, mentre la sincronizzazione inversa può essere eseguita utilizzando un file WAS/IS (che elenca ciascun designatore com'era WAS e com'è ora IS). Il metodo preferito per sincronizzare il progetto è la sincronizzazione diretta del progetto.
Collegamento dei componenti tramite ID univoci
Se hai riannotato il progetto, i designatori dei componenti dello schema o i designatori dei componenti compilati non corrisponderanno più a quelli dei componenti del PCB; pertanto, è necessaria una sincronizzazione per completare correttamente il progetto. Anziché basarsi sul designatore stesso come campo chiave che associa un simbolo schematico al footprint PCB equivalente, Altium Designer può mantenere la sincronizzazione del progetto tramite il sistema di identificatori univoci (UID). L'UID è un valore generato dal sistema che identifica in modo univoco il componente sorgente e associa ciascun componente dello schema al componente PCB corrispondente.
Quando un componente viene posizionato su un foglio schematico, gli viene assegnato automaticamente un UID. La prima volta che le informazioni sui componenti vengono trasferite dai documenti schematici sorgente a un PCB vuoto, le informazioni UID di ciascun componente dello schema vengono assegnate al componente PCB corrispondente.
Il refactoring consente di convertire i fogli dispositivo in fogli schematici e viceversa, mantenendo l'ID univoco del foglio e dei suoi componenti. Inoltre, puoi eseguire il refactoring dei sottocircuiti (o spostarli) su altri fogli schematici del progetto corrente, mantenendo l'ID univoco del sottocircuito. Il comando Refactor si trova nel menu Edit .
La funzionalità di sincronizzazione di Altium Designer, avviata eseguendo il comando Design » Update, utilizza questi UID per associare ciascun componente dello schema al suo equivalente sul PCB. Gli aggiornamenti e le modifiche al progetto possono quindi essere implementati utilizzando gli ordini di modifica tecnica (Engineering Change Orders, ECO). Un ECO elenca tutte le modifiche necessarie da apportare a uno o più documenti di progetto per soddisfare l'azione di sincronizzazione richiesta. Gli ECO vengono utilizzati per applicare aggiornamenti al progetto in varie situazioni, ad esempio:
- Aggiornamenti del progetto dallo schema al PCB.
- Aggiornamenti dell'annotazione dei designatori dei componenti dello schema e dei designatori dei componenti compilati.
- Implementazione degli aggiornamenti ai parametri utilizzando Parameter Manager (Tools » Parameter Manager).
- Aggiornamento delle informazioni sui parametri con quelle memorizzate nelle librerie sorgente o in un database aziendale. Ogni volta che confronti lo schema e il PCB (ad esempio quando selezioni Design » Update), Altium Designer associa innanzitutto i componenti che condividono lo stesso UID. Quando vengono rilevati componenti che non condividono un UID, viene visualizzato un avviso e l'applicazione propone di tentare l'associazione in base al designatore. Finché non avrai assegnato un UID corrispondente sia nello schema sia nel PCB, continuerai a ricevere questo messaggio. Gli ID univoci e le relative corrispondenze vengono gestiti nella finestra di dialogo Modifica collegamenti dei componenti (Project » Component Links).
Tieni presente che la finestra di dialogo può essere aperta solo quando è attivo un documento PCB, poiché le modifiche agli UID vengono sempre applicate al PCB anziché allo schema. Puoi utilizzare questa finestra di dialogo in qualsiasi fase della progettazione per visualizzare i collegamenti tra i componenti e verificare che i componenti dei diversi documenti siano associati correttamente, nonché per assegnare UID corrispondenti ai componenti attualmente non associati.
