Creazione di un footprint PCB

L'area occupata dal componente sulla scheda fabbricata è definita dal footprint del componente. Un footprint tipico include pad e una serigrafia del componente e può includere anche altri dettagli meccanici necessari. Nel footprint di esempio riportato di seguito, gran parte del contorno del componente è definita su un layer meccanico (le linee verdi) anziché sulla serigrafia (gialla), perché questo componente verrà montato in modo da sporgere sopra un'apertura nella scheda.

Il footprint definisce lo spazio occupato dal componente e fornisce i punti di connessione tra i pin/pad del componente e le piste sulla scheda. 
Il footprint definisce lo spazio occupato dal componente e fornisce i punti di connessione tra i pin/pad del componente e le piste sulla scheda.

Il componente montato su quel footprint può essere modellato utilizzando oggetti Corpo 3D. L'oggetto Corpo 3D viene utilizzato come contenitore in cui è possibile importare un modello in un formato MCAD generico, come mostrato nell'immagine seguente.

Un modello MCAD adatto può essere importato in un oggetto Corpo 3D.
Un modello MCAD adatto può essere importato in un oggetto Corpo 3D.

Anche con un ampio insieme di risorse che forniscono componenti PCB già pronti (come il pannello Manufacturer Part Search), è probabile che, prima o poi nella tua carriera, tu debba creare un componente PCB personalizzato. I footprint dei componenti PCB vengono creati nell'editor di footprint PCB utilizzando lo stesso insieme di oggetti primitivi disponibile nell'editor PCB. Oltre ai footprint, anche loghi aziendali, definizioni di fabbricazione e altri oggetti necessari durante la progettazione della scheda possono essere salvati come componenti PCB.

Creazione di un nuovo footprint PCB

I footprint possono essere creati direttamente nel Workspace a cui sei connesso. Per farlo:

  1. Seleziona File » New » Library dai menu principali, quindi, nella finestra di dialogo New Library che si apre, seleziona Create Library Content » Footprint nell'area Workspace della finestra di dialogo.

    Crea un nuovo footprint del Workspace utilizzando la finestra di dialogo New Library
    Crea un nuovo footprint del Workspace utilizzando la finestra di dialogo New Library

  2. Nella finestra di dialogo Create New Item che si apre, inserisci le informazioni richieste, assicurati che l'opzione Open for editing after creation sia abilitata e fai clic su OK. Il footprint del Workspace verrà creato e si aprirà l'editor temporaneo di footprint PCB, con un documento .PcbLib come documento attivo. Questo documento verrà denominato in base alla revisione dell'elemento, nel formato: <Item><Revision>.PcbLib (ad esempio, PCC-001-0001-1.PcbLib). Utilizza il documento per definire il footprint come descritto di seguito.

    Esempio di modifica della revisione iniziale di un footprint del Workspace: l'editor temporaneo di footprint PCB fornisce il documento con cui definire il footprint.
    Esempio di modifica della revisione iniziale di un footprint del Workspace: l'editor temporaneo di footprint PCB fornisce il documento con cui definire il footprint.

  3. Una volta definito il footprint come richiesto, salvalo nel Workspace utilizzando il Save to Server controllo a destra della voce del footprint nel pannello Projects. Verrà visualizzata la finestra di dialogo Edit Revision, in cui puoi modificare Nome e Descrizione e aggiungere note di rilascio secondo necessità. Il documento e l'editor verranno chiusi dopo il salvataggio.

Un footprint del Workspace salvato può essere utilizzato quando si definisce un componente mediante l'editor dei componenti nella modalità di modifica di un singolo componente o nella modalità di modifica in batch dei componenti.

I footprint del Workspace possono essere esplorati utilizzando il pannello Components. Abilita la visibilità dei modelli facendo clic sul pulsante  nella parte superiore del pannello e selezionando Models, quindi seleziona la categoria Footprints.

Per modificare un footprint del Workspace, fai clic con il pulsante destro del mouse sulla relativa voce nel pannello Components e seleziona il comando Edit. Si aprirà nuovamente l'editor temporaneo, con il footprint aperto per la modifica. Apporta le modifiche necessarie, quindi salva il documento nella revisione successiva del footprint del Workspace.

 
 
 
 
 

Quando salvi un footprint modificato nel Workspace, puoi preservarne lo stato corrente del ciclo di vita. Questa possibilità è offerta dall'opzione Preserve lifecycle state (not recommended) disponibile nella finestra di dialogo Create Revision durante un nuovo salvataggio (). Quando l'opzione è abilitata, alla nuova revisione del footprint verrà automaticamente assegnato lo stato del ciclo di vita della revisione precedente. Questa funzionalità è disponibile per gli utenti a cui è stata assegnata l'autorizzazione operativa Allow to skip lifecycle state change for new revisions (scopri di più sull'impostazione delle autorizzazioni operative globali per un Workspace).

  • Quando modifichi un footprint del Workspace, nel momento in cui salvi tale modifica in una nuova revisione del footprint, tutti i componenti del Workspace che utilizzano quel footprint diventano di fatto obsoleti, poiché continuano a utilizzare la revisione precedente. Nella maggior parte dei casi, vorrai sicuramente salvare nuovamente tali componenti del Workspace, aggiornando i rispettivi collegamenti ai modelli affinché utilizzino le ultime revisioni disponibili. Per semplificare questo processo, un Workspace, insieme ad Altium Designer, consente di aggiornare i componenti padre al momento del nuovo salvataggio di un footprint del Workspace, dopo aver apportato modifiche a tale footprint tramite la funzionalità di modifica diretta.

    Per ulteriori informazioni sull'aggiornamento dei componenti padre quando si salva un modello di dominio, consulta la pagina Creazione e modifica dei contenuti.

  • Puoi anche aggiornare al volo il footprint del Workspace utilizzato da un componente del Workspace durante la modifica di tale componente nell'editor dei componenti, nella modalità di modifica di un singolo componente o nella modalità di modifica in batch dei componenti.

  • Dal punto di vista del progettista, un componente del Workspace riunisce in un'unica entità tutte le informazioni necessarie per rappresentare quel componente in tutti i domini di progettazione. In questo senso può quindi essere considerato un contenitore in cui vengono memorizzati tutti i modelli di dominio e le informazioni parametriche. Per quanto riguarda la sua rappresentazione nei vari domini, un componente del Workspace non contiene i modelli di dominio del Workspace stessi, ma piuttosto collegamenti a tali modelli. Questi collegamenti vengono specificati durante la definizione del componente.

  • I footprint PCB possono essere creati nel Workspace anche durante l'importazione di librerie di componenti esistenti di vecchia generazione (SchLib, PcbLib, IntLib, DbLib, SVNDbLib). L'interfaccia per questo processo, il Library Importer, offre un flusso intuitivo che parte dalle librerie inizialmente selezionate e le importa nel Workspace. Scopri di più sul Library Importer.

  • Un nuovo footprint del Workspace può essere creato anche durante la definizione di un componente del Workspace nell'editor dei componenti in modalità di modifica di un singolo componente.

  • Un footprint può essere creato anche all'interno di una libreria di footprint PCB basata su file.

Definizione di un footprint PCB

I footprint vengono sempre creati sul lato superiore, indipendentemente dal lato della scheda su cui verranno infine posizionati, utilizzando lo stesso insieme di strumenti e oggetti di progettazione disponibili nell'editor PCB. Gli attributi specifici dei layer, come le piazzole a montaggio superficiale e le definizioni della solder mask, vengono trasferiti automaticamente ai layer appropriati del lato inferiore quando si ribalta il footprint sull'altro lato della scheda durante il posizionamento dei componenti.

Gli oggetti di progettazione possono essere posizionati su qualsiasi layer; tuttavia, il contorno viene normalmente creato sul layer Top Overlay (serigrafia) e le piazzole sul layer multistrato (per i pin dei componenti a foro passante) o sul layer di segnale superiore (per i pin dei componenti a montaggio superficiale). Quando si posiziona il footprint su un PCB, tutti gli oggetti che lo compongono vengono assegnati ai layer definiti.

Viste 2D e 3D del footprint di un componente joystick. L'immagine 3D mostra il modello STEP importato del componente. Si noti che le piazzole e la serigrafia del componente sono visibili sotto il modello STEP.
Viste 2D e 3D del footprint di un componente joystick. L'immagine 3D mostra il modello STEP importato del componente. Si noti che le piazzole e la serigrafia del componente sono visibili sotto il modello STEP.

I footprint mostrati in questa pagina servono solo a illustrare le procedure richieste; le loro dimensioni non sono accurate. Verificare sempre le specifiche di un nuovo footprint confrontandole con la scheda tecnica del produttore.

La sequenza tipica per creare manualmente il footprint di un componente è la seguente:

  1. Preparare lo spazio di progettazione: definire le opzioni di aggancio, configurare griglie e guide - scopri di più.

  2. I footprint devono essere creati attorno al punto di riferimento dello spazio di progettazione, al centro dell'editor dei footprint PCB. Questo punto di riferimento è in realtà l'origine relativa dello spazio di progettazione ed è il punto mediante il quale il footprint del componente viene agganciato al cursore durante le operazioni di posizionamento e spostamento (a seconda dell'impostazione corrente Object Snap Options nella pagina PCB Editor – General della finestra di dialogo Preferences). Utilizzare i tasti di scelta rapida J, R per passare direttamente al punto di riferimento. Se si è dimenticato di spostarsi sul punto di riferimento prima di iniziare a creare il footprint, è possibile portare il punto di riferimento sul footprint utilizzando i comandi del sottomenu Edit » Set Reference:
    • Pin 1 - impostare il punto di riferimento del componente sul pin 1 del footprint.

    • Center - impostare il punto di riferimento del componente al centro del footprint.

    • Location - impostare il punto di riferimento del componente in una posizione definita dall'utente.

    Il punto scelto verrà impostato su 0,0 - diventerà la nuova origine relativa e le posizioni di tutte le primitive verranno aggiornate rispetto a questo punto.

  3. Posizionare le piazzole (Place » Pad) in base ai requisiti del componente. Dopo aver eseguito il comando Place Pad, ma prima di posizionare la prima piazzola, premere il tasto Tab per aprire il pannello Properties e definire tutte le proprietà della piazzola, inclusi Designator, Size and Shape, Layer e Hole Size (per una piazzola a foro passante). Il designatore viene incrementato automaticamente per le piazzole posizionate successivamente. Per una piazzola a montaggio superficiale, impostare Layer su Top Layer. Per una piazzola a foro passante, impostare Layer su Multi-Layer.

    Alcuni footprint richiedono piazzole di forma irregolare. È possibile crearle utilizzando oggetti piazzola di tipo Custom Shape. Per ulteriori informazioni, consultare la pagina Personalizzazione di uno stack di piazzola.
    • Una delle procedure più importanti nella creazione del footprint di un nuovo componente è il posizionamento delle piazzole che verranno utilizzate per saldare il componente al PCB. Queste devono essere posizionate con precisione per corrispondere ai pin del dispositivo fisico.
    • Occorre prestare attenzione anche nell'assegnazione dei designatori alle piazzole, poiché è questa proprietà che Altium Designer utilizza per stabilire la corrispondenza con i numeri dei pin del simbolo schematico.
  4. Per garantire un posizionamento accurato delle piazzole, valutare la possibilità di impostare una griglia specifica per questa operazione. Utilizzare i tasti di scelta rapida Ctrl+G per aprire la finestra di dialogo Cartesian Grid Editor e il tasto Q per passare dalla griglia imperiale a quella metrica.

  5. Per posizionare con precisione una piazzola mentre la si sposta con il mouse, utilizzare i tasti freccia della tastiera per spostare il cursore secondo gli incrementi della griglia corrente. Inoltre, tenendo premuto Shift, lo spostamento avverrà con passi pari a 10 volte quello della griglia. La posizione X, Y corrente viene visualizzata sulla barra di stato e anche nel display Heads Up. Il display Heads Up contiene sia la posizione sia lo scostamento tra la posizione dell'ultimo clic e la posizione corrente del cursore. Utilizzare la scorciatoia Shift+H per attivare o disattivare il display Heads Up. In alternativa, fare doppio clic per modificare una piazzola già posizionata e inserire le coordinate X e Y richieste nel pannello Properties .

  6. Per verificare la distanza tra due punti nello spazio di progettazione, utilizzare Reports » Measure Distance (scorciatoia Ctrl+M). Seguire le indicazioni sulla barra di stato.

  7. Gli attributi specifici delle piazzole, come la solder mask e la paste mask, vengono calcolati automaticamente in base alle dimensioni delle piazzole e alle regole di progettazione delle maschere applicabili. Sebbene le impostazioni delle maschere possano essere definite manualmente per ogni piazzola, questa scelta rende difficile modificarle in seguito durante il processo di progettazione della scheda. In genere si procede in questo modo solo quando non è possibile gestire le piazzole mediante regole di progettazione. Si noti che le regole vengono definite nell'editor PCB durante la progettazione della scheda.

  8. Utilizzare piste, archi e altre primitive per definire il contorno del componente che appare sulla serigrafia del PCB nel layer Top Overlay. Se il componente viene ribaltato sul lato inferiore della scheda durante il posizionamento, la serigrafia viene trasferita automaticamente al layer Bottom Overlay.

  9. Posizionare piste e altre primitive su un layer meccanico per definire ulteriori dettagli meccanici, come l'area di rispetto per il posizionamento. I layer meccanici sono layer di uso generico. È necessario assegnare una funzione a questi layer e utilizzarli in modo coerente in tutti i footprint.

  10. Posizionare oggetti 3D Body per definire la forma tridimensionale del componente fisico da montare sul PCB.

    Un oggetto 3D Body aggiunto a un footprint può fare riferimento a un modello 3D caricato nel Workspace connesso.
  11. Le stringhe Designator e Comment vengono aggiunte automaticamente al layer Overlay del footprint durante il posizionamento nello spazio di progettazione PCB. È possibile includere ulteriori stringhe Designator e Comment posizionando le stringhe speciali .Designator e .Comment su un layer meccanico.

    Quando si posizionano le stringhe Designator e Comment, è necessario definire una coppia di layer nell'editor PCB. In questo modo, le stringhe saranno associate al lato della scheda su cui è montato il componente e passeranno all'altro lato della scheda quando il componente viene ribaltato. Per ulteriori informazioni, consultare la sezione Gestione dei requisiti speciali specifici dei layer di seguito.
  12. Definire le proprietà del footprint (ad esempio, nome e descrizione) nella scheda Footprint del pannello Properties in modalità Library Options (attiva quando non è selezionato alcun oggetto nello spazio di progettazione, accessibile utilizzando Tools » Footprint Properties comando dai menu principali). Consulta la sezione seguente per saperne di più sulle opzioni e sui controlli disponibili nella scheda Footprint del pannello.

  • Per una definizione standardizzata di pad e via in tutti i footprint, è possibile utilizzare la libreria Pad/Via (*.PvLib) per il posizionamento di pad e via – scopri di più.
  • L'editor PCB Footprint offre anche alcune procedure guidate per velocizzare la creazione dei footprint:
    • La procedura IPC Compliant Footprint Wizard – genera un footprint PCB pienamente conforme alla revisione B dello standard IPC 7351 – Generic Requirements for Surface Mount Design and Land Pattern Standard – scopri di più.
    • La procedura IPC Compliant Footprints Batch Generator – quando lavori con una libreria di footprint PCB basata su file, utilizza IPC Compliant Footprints Batch Generator per generare rapidamente più footprint, a diversi livelli di densità – scopri di più.
    • La procedura Footprint Wizard – consente di scegliere tra vari tipi di package e inserire le informazioni appropriate, per poi creare il footprint del componente – scopri di più.

Preparazione dell'area di progettazione

Per impostazione predefinita, le griglie vengono visualizzate con punti. Se preferisci, puoi visualizzarle con linee. Questa impostazione si configura nella finestra di dialogo Grid Editor, accessibile facendo clic sul pulsante Properties nel pannello Properties, come mostrato nell'immagine seguente. In alternativa, premi la combinazione di tasti Ctrl+G per aprire la finestra di dialogo.

Nell'immagine, la griglia fine è visualizzata con punti e la griglia grossolana con linee.
Nell'immagine, la griglia fine è visualizzata con punti e la griglia grossolana con linee.

Pannello Proprietà

Durante la modifica di un footprint nell'editor di footprint PCB, quando nell'area di progettazione non è selezionato alcun oggetto, il pannello Properties mostra Library Options.

Le seguenti sezioni espandibili contengono informazioni sulle opzioni e sui controlli disponibili nella scheda General del pannello:

Le seguenti sezioni espandibili contengono informazioni sulle opzioni e sui controlli disponibili nella scheda Footprint del pannello:

La possibilità di definire le proprietà del footprint utilizzando la scheda Footprint del pannello Properties è disponibile quando l'opzione PCB.FootprintParameters è abilitata nella finestra di dialogo Impostazioni avanzate. Quando questa opzione è disabilitata, le proprietà del footprint vengono definite utilizzando la finestra di dialogo PCB Library Footprint (), accessibile selezionando il comando Tools » Footprint Properties dai menu principali, oppure selezionando una voce di footprint nell'area Footprints del pannello PCB Library e facendo clic sul pulsante Edit, oppure facendo doppio clic su una voce di footprint nell'area Footprints del pannello PCB Library.

Quando si seleziona un oggetto di progettazione, il pannello presenta le opzioni specifiche per quel tipo di oggetto. La tabella seguente elenca i tipi di oggetto disponibili per il posizionamento nell'area di progettazione dei footprint PCB: fai clic su un collegamento per accedere alla pagina delle proprietà dell'oggetto.

Corpo 3D Arco
Arco di esclusione Riempimento
Riempimento di esclusione Piazzola
Regione Regione di esclusione
Testo (stringa, riquadro di testo) Pista
Pista di esclusione Via

Espansioni della maschera di saldatura e della maschera della pasta saldante

Per verificare che le maschere di saldatura e/o della pasta saldante siano state definite correttamente nell'editor dei footprint PCB, apri il pannello Configurazione vista e abilita l'opzione di visualizzazione () per ciascun layer delle maschere.

L'anello che appare attorno al bordo di ogni piazzola, nel colore del layer della maschera di saldatura superiore, rappresenta il bordo della forma della maschera di saldatura che sporge da sotto la piazzola multistrato per il valore di espansione, poiché multi-layer si trova in cima all'ordine di disegno dei layer e viene quindi disegnato sopra gli altri. Il Layer Drawing Order si imposta nella pagina Editor PCB - Visualizzazione della finestra di dialogo Preferences).

L'immagine seguente mostra un footprint PCB con un bordo viola (il colore del layer della maschera di saldatura superiore) attorno a ogni piazzola.

Per scorrere rapidamente i layer, usa la modalità a layer singolo (Shift+S) in combinazione con Ctrl+Shift+Wheel roll.

Per impostazione predefinita, la forma creata sui layer delle maschere corrisponde alla forma della piazzola, espansa o ridotta del valore specificato dalle regole di progettazione Espansione della maschera di saldatura e Espansione della maschera della pasta saldante impostate nel PCB su cui viene posizionato il footprint. In alcuni casi, potrebbe essere necessario ignorare le regole di progettazione relative all'espansione e specificare un'espansione della maschera come attributo della piazzola, scegliere tra un insieme standard di forme predefinite per la maschera oppure creare una forma personalizzata. In queste situazioni, puoi configurare le maschere della pasta saldante e di saldatura per una piazzola selezionata nel relativo pannello Properties - scopri di più. In alternativa, puoi posizionare primitive appropriate (regioni, piste, ecc.) sul layer della maschera desiderato.

In una libreria PCB, tutti gli oggetti con espansione della maschera di saldatura determinata dalle regole avranno un valore di espansione pari a 0 mil. Questa funzionalità è disponibile quando l'opzione PCB.SolderMaskZeroExpansion è abilitata nella finestra di dialogo Impostazioni avanzate. Quando questa opzione è disabilitata, il valore di espansione della maschera di saldatura per tali oggetti in una libreria PCB è di 4 mil.

Supporto dei parametri

I parametri applicati agli oggetti in Altium Designer offrono un mezzo potente e flessibile per aggiungere informazioni supplementari a un progetto PCB. Applicati come proprietà dell'oggetto principale, i parametri possono essere utilizzati a vari livelli, inclusi progetti, documenti, modelli e singoli oggetti all'interno di un documento di progettazione.

Per ulteriori informazioni, consulta Oggetto parametro.

I parametri disponibili nell'ambiente PCB possono essere utilizzati per filtrare query, regole di progettazione, script e varianti, e possono essere applicati ai footprint dei componenti PCB per richiamare stringhe personalizzate nei footprint posizionati.

Parametri tramite un ordine di modifica tecnica

Le funzionalità dei parametri PCB si basano sulle funzioni incluse nel meccanismo ECO e nel documento PCB, che consentono di trasferire e conservare nell'ambiente PCB i parametri dei componenti definiti dall'utente. Si tratta di un trasferimento unidirezionale e i parametri trasferiti sono di sola lettura nell'ambiente PCB.

Il trasferimento dei parametri avviene creando un ECO dallo schema al PCB con il comando di menu Design » Update PCB Document.

Quando viene eseguito l'ECO (tramite il pulsante Execute Changes ), tutti i nuovi parametri dei componenti dello schema definiti dall'utente vengono trasferiti al riferimento del footprint corrispondente nel progetto PCB. 

Il rilevamento e la migrazione dei parametri al PCB sono determinati dalle impostazioni delle opzioni del progetto (Project » Project Options). Nella finestra di dialogo Project Options, imposta il comportamento di rilevamento delle differenze e di modifica nella sezione Differences Associated with Parameters della scheda Comparator e nella sezione Modifications Associated with Parameters della scheda ECO Generation.

Per visualizzare i parametri trasferiti nell'editor PCB, fai doppio clic su un componente per aprire il pannello Properties , quindi scegli la scheda Parameters . La scheda elenca i parametri utente attualmente assegnati al footprint del componente selezionato. I parametri del footprint del componente selezionato sono disponibili anche nel pannello Components .

Collegamenti alle informazioni di riferimento

L'ambiente PCB accetta automaticamente i parametri predefiniti ComponentLink provenienti dallo schema. Questi sono definiti come coppie di parametri (descrizione e URL del collegamento) che normalmente creano collegamenti a informazioni di riferimento in file specifici o risorse Internet, in genere il sito web del produttore o l'URL di una scheda tecnica.

Consulta Definizione di collegamenti cliccabili alle informazioni di riferimento in una libreria di schemi e Accesso ai collegamenti cliccabili alle informazioni di riferimento in un documento PCB per informazioni sui parametri dei collegamenti di riferimento.

Sia nell'area di progettazione dello schema sia in quella del PCB, i collegamenti sono accessibili dal menu contestuale visualizzato facendo clic con il pulsante destro del mouse su un componente (nelle opzioni del sottomenu References). Questi parametri specifici vengono aggiunti nel pannello Properties e, quando vengono trasferiti nell'ambiente PCB, compaiono come parametri del footprint del componente. 

Parametri nei footprint di origine

I parametri trasferiti al PCB possono essere utilizzati per fornire informazioni aggiuntive sulla produzione o sul funzionamento della scheda tramite i footprint dei componenti. Aggiungendo stringhe speciali dei parametri ai footprint nella libreria di origine, le stringhe personalizzate verranno interpretate sul layer meccanico o di serigrafia di destinazione.

Una stringa speciale che rappresenta un parametro definito dall'utente può essere aggiunta al footprint del componente di origine utilizzando il pulsante e il menu a discesa delle stringhe speciali () nel pannello Properties .

Nel footprint di libreria riportato di seguito, la stringa speciale .Designator è stata posizionata sul layer Meccanico 2.

È possibile aggiungere al footprint del componente una stringa speciale che rappresenta un parametro utente.

Quando tale parametro personalizzato è stato applicato anche ai componenti dello schema e i dati del parametro sono stati trasferiti al PCB, le stringhe interpretate del footprint appariranno sia nella vista della scheda sia nei file di output generati. In questo caso, la stringa speciale del parametro contiene un identificativo personalizzato del componente per facilitare l'assemblaggio.

L'applicazione dei parametri utente ai footprint dei componenti come stringhe speciali può soddisfare numerose altre esigenze di personalizzazione del PCB, incluse le etichette funzionali per interruttori e connettori, per i quali una stringa del parametro 'funzione' potrebbe essere posizionata sulla serigrafia superiore nei footprint di questi tipi di componenti.

Per vedere il valore interpretato delle stringhe speciali nel layout della scheda, abilita l'opzione Special Strings nella sezione Additional Options della scheda View Options nel View Configuration pannello. Le stringhe speciali vengono sempre convertite nei file di output generati.
Nell'editor degli schemi, se necessario, abilita l'opzione Display Names of Special Strings that have No Value Defined nella pagina Schematic – Graphical Editing della finestra di dialogo Preferences.

Query sui parametri

Le stringhe dei parametri nell'ambiente PCB sono accessibili anche tramite il linguaggio di query di Altium Designer e sono quindi disponibili per le funzioni di filtro degli oggetti, inclusa la funzione Trova oggetti simili.

Per selezionare oggetti simili, fai clic con il pulsante destro del mouse su un componente, quindi seleziona Find Similar Objects dal menu contestuale per aprire la finestra di dialogo Find Similar Objects.

La finestra di dialogo Trova oggetti simili include una sezione Parameters in cui è possibile selezionare le opzioni di filtro in base alle esigenze.

Il pannello PCB Filter può applicare termini di query specifici dei parametri come criteri di filtro e può essere utilizzato per creare regole di progettazione basate sui parametri PCB.

Sono disponibili diversi termini di query per lavorare con i parametri dei footprint PCB, incluse funzioni specifiche per convertire i valori stringa in numeri (come StrToNumber). Le conversioni dei valori stringa tengono conto delle unità di misura (V, mA, mV, kOhm, ecc.) e consentono di determinare il risultato della query mediante l'elaborazione numerica della stringa del valore di un parametro.

I tipi di unità supportati che possono essere specificati nelle query sono:

  • % – Percentuale
  • A – Corrente
  • C – Temperatura
  • dB – Decibel
  • F – Capacità
  • G – Conduttanza
  • H – Induttanza
  • Hz – Frequenza
  • Kg – Massa
  • m – Lunghezza
  • Ohm – Resistenza
  • Q – Carica
  • s – Tempo
  • V – Tensione
  • W – Potenza
  • Z – Impedenza

Sono disponibili diversi termini di query sui parametri per lavorare con i parametri dei footprint dei componenti PCB.

L'esempio mostrato nella finestra di dialogo Query Helper sopra elabora il parametro Voltage Rating di ciascun componente (utilizzando la conversione da stringa a numero – StrToNumber(Unit Value, Unit Type))  per determinare se il suo valore è superiore a 50 V. Quando viene applicato nel pannello PCB Filter, il layout della scheda di esempio evidenzia un unico componente ad alta tensione, C1 (che ha un valore di Voltage Rating pari a 3 kV).

È supportata anche la notazione scientifica E; ad esempio, una query per filtrare i valori dei condensatori superiori a 1 nF sarebbe simile a:
StrToNumber(ParameterValue('CapacitanceValue'), F) > 1e-9
In alternativa, la funzione di conversione numerica potrebbe essere utilizzata sia per il ParameterValue restituito and sia per il valore di confronto:
StrToNumber(ParameterValue('CapacitanceValue'), F) > StrToNumber('1nF', F)

Regole e script

Le query sui parametri PCB possono essere applicate anche agli script e alle regole di progettazione di Altium Designer. Queste ultime possono eseguire controlli di convalida del layout, ad esempio rilevando i parametri dei footprint per valutare il posizionamento dei componenti o l'assegnazione dei layer. Nota che le funzioni elencate nella finestra di dialogo Query Helper sopra sono disponibili nel linguaggio di scripting.

L'esempio seguente mostra la query sulla tensione nominale dei condensatori (vedi la query di filtro sopra) applicata a una regola di posizionamento dei componenti che, quando viene eseguita, verifica valori di distanza specifici per i componenti identificati come dispositivi ad alta tensione (>50V).

Le regole di progettazione definite mediante parametri specifici dei footprint, trasferiti dall'ambiente dello schema, possono essere utilizzate per rilevare condizioni personalizzate del layout.

Analogamente, i parametri PCB personalizzati possono essere utilizzati per verificare la compatibilità dei componenti con i layer, ad esempio quando un componente non supporta la saldatura a onda e quindi il posizionamento sul layer inferiore. In questo caso, una query di corrispondenza degli oggetti che elabora un parametro personalizzato ‘WaveSoldering’ (Yes/No) potrebbe essere applicata alla regola dei layer consentiti.

La regola (batch) verificherà quindi il valore di quel parametro del componente e genererà una violazione se un componente non è compatibile con il posizionamento sul layer inferiore.

Varianti

I parametri trasferiti al PCB e inclusi nelle varianti del progetto (Varianti di progetto) vengono elaborati in base alla selezione della variante.

In pratica, un parametro di componente modificato da una variante nell'ambiente PCB verrà rilevato dinamicamente da una stringa di query oppure, ad esempio, visualizzato su un layer della scheda tramite una stringa speciale. 

Parametri dei footprint definiti dall'utente

Questa funzione è disponibile quando l'opzione PCB.FootprintParameters è abilitata nella finestra di dialogo Impostazioni avanzate.

Altium Designer supporta i parametri dei footprint definiti dall'utente. La sezione Parameters nella scheda Footprint del pannello Properties , in modalità Library Options , può essere utilizzata per visualizzare e modificare i parametri dei footprint quando non è selezionato alcun oggetto nell'area di progettazione dell'editor dei footprint PCB.

Quando il componente viene posizionato sul PCB, puoi visualizzare questi parametri nel pannello Properties  in modalità Component  nella scheda Parameters .

  • I parametri dei footprint dei componenti posizionati su un PCB verranno propagati ai footprint nelle librerie generate tramite il comando Make PCB Library o Make Integrated Library del menu principale dell'editor PCB.
  • I parametri dei footprint sono supportati dal motore di confronto di Altium Designer e negli output Pick and Place e ODB++ generati.
Altium MCAD CoDesigner supporta il posizionamento di componenti MCAD nativi nell'ambiente MCAD in base al collegamento configurato. In alcuni casi, più footprint con modelli diversi sono collegati a un unico componente (ad esempio, un LED che può essere montato su un PCB in due modi: verticalmente, con terminali dritti, oppure orizzontalmente, con terminali piegati). Utilizzando i parametri dei footprint, ora puoi fare riferimento ai diversi modelli MCAD da questi diversi footprint. Scopri di più sul collegamento dei componenti di progettazione ECAD e MCAD nativi.

Stringhe del designatore e del commento

Stringhe predefinite del designatore e del commento

Quando un footprint viene posizionato su una scheda, gli vengono assegnati un designatore e un commento in base alle informazioni estratte dalla vista dello schema del progetto. Non è necessario definire manualmente i segnaposto per le stringhe del designatore e del commento, poiché vengono aggiunti automaticamente quando il footprint viene posizionato su una scheda. La posizione di queste stringhe è determinata dall'opzione Autoposition per la stringa del designatore e del commento nel pannello Properties in modalità Parameter quando la stringa del designatore o del commento è selezionata nell'area di progettazione. La posizione e le dimensioni predefinite delle stringhe del designatore e del commento sono configurate nella rispettiva primitiva nella pagina Editor PCB - Impostazioni predefinite della finestra di dialogo Preferences .

Stringhe aggiuntive del designatore e del commento

Possono esserci situazioni in cui si desiderano copie aggiuntive delle stringhe del designatore o del commento. Ad esempio, il fornitore di assemblaggio richiede un disegno di assemblaggio dettagliato con il designatore visualizzato all'interno del contorno di ogni componente, mentre la tua azienda richiede che il designatore sia posizionato appena sopra il componente sul layer serigrafico del PCB finale. Questa esigenza di un designatore aggiuntivo può essere soddisfatta includendo la stringa speciale .Designator nel footprint. È disponibile anche una stringa speciale .Comment per specificare la posizione della stringa del commento su layer o in posizioni alternative.

Per soddisfare i requisiti del fornitore di assemblaggio, la stringa .Designator va posizionata su un layer meccanico nell'editor dei footprint PCB; sarà quindi possibile generare stampe che includano questo layer come parte delle istruzioni di assemblaggio del progetto.

Gestione dei requisiti speciali specifici dei layer

Un componente PCB può avere diversi requisiti speciali, come la necessità di un punto di colla o di una definizione della maschera di saldatura rimovibile. Molti di questi requisiti speciali sono legati al lato della scheda su cui è montato il componente e devono passare all'altro lato della scheda quando il componente viene ribaltato.

Anziché includere un gran numero di layer dedicati che potrebbero essere usati raramente, l'editor PCB di Altium Designer supporta questa esigenza tramite una funzionalità chiamata coppie di layer. Una coppia di layer è costituita da due layer meccanici definiti come coppia. Ogni volta che un componente viene ribaltato da un lato della scheda all'altro, tutti gli oggetti su un layer meccanico accoppiato vengono trasferiti all'altro layer meccanico della coppia. Con questo approccio, si seleziona un layer meccanico adatto per includere il punto di colla (o altri requisiti speciali) e se ne definisce la forma utilizzando gli oggetti disponibili. Quando si posiziona il footprint su una scheda, è necessario configurare l'accoppiamento dei layer. In questo modo si indica al software su quale layer trasferire gli oggetti quando il componente viene ribaltato sull'altro lato della scheda. Non è possibile definire coppie di layer nell'editor dei footprint PCB; questa operazione viene eseguita nell'editor PCB.

L'accoppiamento dei layer deve essere definito before il componente venga ribaltato. Se l'accoppiamento viene definito dopo che il componente è stato spostato sul lato inferiore, gli elementi del layer meccanico verranno ribaltati, ma rimarranno sul layer originale. Se dimentichi di creare le coppie di layer prima del ribaltamento, puoi eseguire un aggiornamento dalla libreria per aggiornare l'istanza del componente posizionata sulla scheda.

I nomi dei layer meccanici possono essere modificati direttamente dal pannello View Configurations facendo clic con il pulsante destro del mouse e selezionando Edit Layer.

Un approccio comune alla gestione dell'uso dei layer meccanici consiste nell'assegnare un numero di layer dedicato a ciascuna funzione richiesta. Questo approccio richiede che tutti i progettisti rispettino lo stesso schema di assegnazione e numerazione dei layer. Può inoltre creare difficoltà quando i componenti provengono da altre fonti che non seguono lo stesso schema di assegnazione e numerazione. Se è stato utilizzato uno schema diverso, gli oggetti del progetto devono essere spostati dal loro layer meccanico attuale al layer meccanico assegnato a quella funzione.

Questo problema viene risolto con l'introduzione della proprietà Layer Type. Quando un componente viene posizionato da una libreria nell'editor PCB, copiato da una libreria a un'altra o creato tramite IPC Footprint Wizard, le assegnazioni esistenti del tipo di layer vengono abbinate automaticamente, indipendentemente dai numeri dei layer meccanici assegnati a tali tipi di layer. Gli oggetti vengono riposizionati sui layer corretti in base al loro tipo di layer. Se il software non riesce a trovare una corrispondenza in base al tipo di layer, utilizzerà il numero del layer.

Sia per i singoli layer meccanici sia per le coppie di layer dei componenti, è possibile selezionare un tipo di layer da un elenco predefinito. Puoi accedere alle finestre di dialogo mostrate di seguito facendo clic con il pulsante destro del mouse su un singolo layer, quindi selezionando il comando Edit Layer o Add Component Layer dal menu.

Per informazioni dettagliate sui tipi di layer meccanici relativi ai componenti, consulta la pagina Lavorare con i layer meccanici.

Aggiunta dell'altezza a un footprint PCB

Al livello più semplice di rappresentazione 3D, è possibile aggiungere informazioni sull'altezza a un footprint PCB. Per farlo, apri il pannello Properties in modalità Library Options (attiva quando non è selezionato alcun oggetto nell'area di progettazione) e inserisci l'altezza consigliata per il componente nel campo Height della scheda Footprint del pannello.

Durante la progettazione della scheda è possibile definire regole di progettazione relative all'altezza (fai clic su Design » Rules nell'editor PCB), in genere per verificare l'altezza massima dei componenti appartenenti a una classe o all'interno di una room.

Un'opzione migliore per definire le informazioni sull'altezza consiste nell'associare corpi 3D al footprint PCB.

Gestione dei componenti con primitive di sbroglio

Quando un progetto viene trasferito, il footprint specificato in ciascun componente viene estratto dalle librerie disponibili e posizionato sulla scheda. La proprietà net di ciascun pad del footprint viene quindi impostata sul nome della net collegata a quel pin del componente nello schema. Tutti gli oggetti a contatto con un pad si collegano alla stessa net del pad.

L'editor PCB include uno strumento completo per la gestione delle net. Per avviarlo, seleziona Design » Netlist » Configure Physical Nets dai menu principali per aprire la finestra di dialogo Configura net fisiche. Fai clic sul pulsante Menu per visualizzare un menu di opzioni. Fai clic sul menu a discesa dell'intestazione New Net Name per selezionare la net da assegnare alle primitive non assegnate.

Footprint con più pad collegati allo stesso pin

Il footprint mostrato di seguito, relativo a un transistor SOT223, presenta più pad collegati allo stesso pin logico del componente nello schema: il pin 2. Per realizzare questo collegamento, sono stati aggiunti due pad con lo stesso designatore: '2'. Quando si utilizza il comando Design » Update PCB nell'editor degli schemi per trasferire le informazioni del progetto al PCB, la sincronizzazione risultante mostrerà nell'editor PCB le linee di connessione verso entrambi i pad, ovvero entrambi appartengono alla stessa net. È possibile sbrogliare entrambi.

Footprint SOT223 che mostra due pad con designatore 2.
Footprint SOT223 che mostra due pad con designatore 2.

Preparazione della serigrafia

Per aiutare a risolvere i comuni problemi di progettazione per la produzione (DFM) causati dalla sovrapposizione della serigrafia al rame esposto e ai fori, l'editor dei footprint PCB include una funzionalità dedicata alla preparazione della serigrafia dei footprint. Questi problemi possono essere risolti efficacemente mediante:

  • ritaglio automatico di linee e archi della serigrafia;
  • ritaglio o spostamento automatico di riempimenti e regioni;
  • spostamento automatico delle stringhe di testo della serigrafia.
Lo strumento di preparazione della serigrafia è accessibile anche durante la progettazione di un PCB – scopri di più.

Per accedere allo strumento di preparazione della serigrafia nell'editor dei footprint PCB, utilizza il comando Tools » Silkscreen Preparation dai menu principali. Si aprirà la finestra di dialogo Silkscreen Preparation.

Utilizza la finestra di dialogo per configurare le impostazioni di ritaglio/spostamento degli oggetti della serigrafia. Le opzioni disponibili sono:

  • Clip to Exposed Copper – abilita questa opzione per ritagliare automaticamente gli oggetti in corrispondenza del rame esposto.
  • Clip to Solder Mask Openings – abilita questa opzione per ritagliare automaticamente gli oggetti in corrispondenza delle aperture della maschera di saldatura.
  • Silkscreen Clearance – definisci la distanza minima accettabile tra gli oggetti della serigrafia e il rame esposto, le aperture della maschera di saldatura e i fori.
  • Min Remaining Length – se la lunghezza della linea/dell'arco è inferiore al valore definito dopo il ritaglio, gli oggetti verranno rimossi dal footprint. Si noti che questa lunghezza è misurata da vertice a vertice, non da bordo a bordo – mostra immagine.
  • Move Text – abilitare per allontanare le stringhe di testo della serigrafia dal rame esposto, dalle aperture della solder mask e dai fori se la distanza tra questi elementi è inferiore a Silkscreen Clearance. Lo spostamento è limitato dal valore di Max Distance.
  • Fill & Region – selezionare un'azione da eseguire sui riempimenti e sulle regioni quando la distanza tra questi elementi e il rame esposto, le aperture della solder mask e i fori è inferiore a Silkscreen Clearance:
    • None – i riempimenti e le regioni rimangono invariati.
    • Clip – i riempimenti e le regioni verranno ritagliati per mantenere Silkscreen Clearance. I riempimenti vengono convertiti in regioni, se necessario.
    • Move – i riempimenti e le regioni verranno allontanati dal rame esposto, dalle aperture della solder mask e dai fori. Lo spostamento è limitato dal valore di Max Distance.
  • Max Distance – definire la distanza massima di spostamento delle stringhe di testo, dei designatori dei componenti, dei riempimenti e delle regioni per mantenere Silkscreen Clearance.

Fare clic su OK per ritagliare e/o spostare gli oggetti della serigrafia in base alle impostazioni della finestra di dialogo.

Se non è possibile eseguire un'azione su un oggetto (ad esempio, una stringa di testo non può essere spostata a causa del limite imposto da Max Distance), nel pannello Messages verrà visualizzato un messaggio relativo a tale oggetto.

Di seguito è mostrato un esempio del risultato ottenuto con lo strumento di preparazione della serigrafia.

Javascript

Creazione di un footprint mediante la procedura guidata per footprint conformi allo standard IPC

IPC Compliant Footprint Wizard genera un footprint PCB pienamente conforme alla revisione B dello standard IPC 7351 - Generic Requirements for Surface Mount Design and Land Pattern Standard. Anziché lavorare direttamente sulle dimensioni del footprint (come fa la procedura guidata per footprint), IPC Compliant Footprint Wizard utilizza le informazioni dimensionali del componente stesso e calcola quindi le proprietà appropriate delle piazzole e degli altri elementi del footprint in base agli algoritmi pubblicati dall'IPC.

Anziché richiedere l'inserimento delle proprietà delle piazzole e delle piste utilizzate per definire il footprint, Wizard accetta come dati di ingresso le dimensioni effettive del componente. In base alle formule sviluppate per lo standard IPC-7351, Wizard genera quindi il footprint utilizzando oggetti standard di Altium Designer, come piazzole e piste.

  • Questa finestra di dialogo è conforme alla revisione B dello standard IPC 7351 - Requisiti generici per la progettazione a montaggio superficiale e standard per i pattern delle piazzole. IPC-7351B è stato pubblicato nel 2010 e sostituisce IPC-7351A (pubblicato nel 2007).

  • Per accedere a IPC Compliant Footprint Wizard in Altium Designer, è necessario che sia installata l'estensione software IPC Footprint Generator. Questa estensione viene installata per impostazione predefinita con Altium Designer. Può essere installata o rimossa manualmente.

    Per ulteriori informazioni sulla gestione delle estensioni, consultare la pagina Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Per avviare IPC Compliant Footprint Wizard, selezionare Tools » IPC Compliant Footprint Wizard dai menu principali di un documento di libreria PCB.

Nella pagina Select Component Type, scegliere la famiglia di componenti per cui si desidera creare un footprint nella pagina Select Component Type. L'area di anteprima sul lato destro della procedura guidata cambia dinamicamente per mostrare il componente attualmente selezionato e indica anche i tipi di package che è possibile generare. La tabella seguente elenca i tipi di componenti e i package supportati dalla procedura guidata.

Nome Descrizione Package inclusi
BGA Matrice di sfere BGA, CGA
BQFP Package piatto quadrilaterale con paracolpi BQFP
CAPAE Condensatore elettrolitico in alluminio CAPAE
CFP Package piatto ceramico a due lati - Terminali ad ala di gabbiano tagliati e sagomati CFP
Matrice di chip Matrice di chip Matrice di chip
DFN Package piatto a due lati senza terminali sporgenti DFN
CHIP Componenti chip a 2 pin Condensatore, induttore, resistore
CQFP Package piatto ceramico quadrilaterale - Terminali ad ala di gabbiano tagliati e sagomati CQFP
DPAK Package per transistor DPAK
LCC Supporto per chip senza terminali sporgenti LCC
LGA Matrice di piazzole LGA
MELF Componenti MELF a 2 pin Diodo, resistore
MOLDED Componenti stampati a 2 pin Condensatore, induttore, diodo
PLCC Supporto plastico quadrato per chip con terminali a J PLCC
PQFN Package piatto quadrilaterale con terminali non sporgenti arretrati PQFN
PQFP Package piatto plastico quadrilaterale PQFP, PQFP con piazzola esposta
PSON Package a profilo ridotto con terminali non sporgenti arretrati PSON
QFN Package piatto quadrilaterale senza terminali sporgenti QFN, LLP
QFN-2ROW Package piatto quadrilaterale senza terminali sporgenti, a 2 file, quadrato QFN a doppia fila
SODFL Diodo a profilo ridotto con terminali piatti SODFL
SOIC Package per circuito integrato a profilo ridotto, passo di 1,27 mm - Terminali ad ala di gabbiano SOIC, SOIC con piazzola esposta
SOJ Package a profilo ridotto - Terminali a J SOJ
SON Package a profilo ridotto senza terminali sporgenti SON, SON con piazzola esposta
SOP, TSOP Package a profilo ridotto - Terminali ad ala di gabbiano SOP, TSOP, TSSOP
SOT143/343 Transistor a profilo ridotto SOT143, SOT343
SOT223 Transistor a profilo ridotto SOT223
SOT23 Transistor a profilo ridotto 3 terminali, 5 terminali, 6 terminali
SOT89 Transistor a profilo ridotto SOT89
SOTFL Transistor a profilo ridotto con terminali piatti 3 terminali, 5 terminali, 6 terminali
A FILO AVVOLTO Induttore di precisione a filo avvolto, a 2 pin Induttore

Le pagine successive della procedura guidata cambiano a seconda del tipo di componente selezionato. Seguire le pagine intuitive della procedura guidata per configurare il footprint del componente in base alle proprie esigenze. Alcune note sull'utilizzo di IPC Compliant Footprint Wizard:

  • Tutte le dimensioni vengono inserite nella procedura guidata in unità metriche (mm).

  • È possibile inserire e visualizzare immediatamente le dimensioni complessive del package, le informazioni sui pin, la distanza tra i talloni dei terminali, i raccordi di saldatura e le tolleranze.

    La modifica delle tolleranze IPC può produrre footprint PCB non conformi allo standard IPC.

  • È possibile inserire le dimensioni meccaniche, come le informazioni relative a Courtyard, Assembly e al corpo del componente (3D).

  • La Wizard consente di tornare ai passaggi precedenti, facilitando la revisione e le modifiche.

  • Le anteprime del footprint vengono mostrate in ogni fase. Per ciascun tipo di componente, l'area Preview si aggiorna dinamicamente per mostrare la nuova posizione, le dimensioni e così via per diverse impostazioni. Nell'area Preview , è possibile fare clic su  o  per passare dalle immagini di anteprima 2D a quelle 3D e viceversa.

  • Se lo si desidera, è possibile visualizzare un'anteprima del modello STEP 3D prima di generarlo. Fare clic su Generate STEP Model Preview in qualsiasi pagina della Wizard dopo aver selezionato il tipo di componente per visualizzare un'anteprima del modello STEP 3D nell'area Preview.

  • Le maschere della pasta saldante vengono suddivise in piccole aree piene per i package con un pad termico di grandi dimensioni (2,1 mm x 1,6 mm o superiori).

  • Per i package con terminali ad ala di gabbiano, i pad vengono accorciati per evitare che si estendano sotto il corpo del package.

  • Per i package di piccole dimensioni con un grande pad termico centrale, i pad periferici vengono accorciati per garantire la distanza richiesta tra i pad in conformità allo standard IPC.

  • Quando viene applicato l'accorciamento dei pad, nella finestra di dialogo viene visualizzato un avviso.

  • Il nome e la descrizione del footprint vengono suggeriti automaticamente in base alle informazioni inserite nella Wizard ma possono essere modificati per soddisfare i requisiti aziendali.

  • In conformità allo standard IPC, la procedura guidata supporta tre varianti di footprint (_L, _N, _M), ciascuna adatta a una diversa densità della scheda.

  • Il pulsante Finish può essere premuto in qualsiasi fase per generare il footprint attualmente visualizzato in anteprima. Se si fa clic su Finish prima di completare l'intera Wizard, il footprint verrà creato utilizzando le impostazioni predefinite del sistema per il tipo di componente selezionato.

  • Quando si lavora con una libreria di footprint PCB basata su file, utilizzare IPC Compliant Footprints Batch Generator per generare rapidamente più footprint a diversi livelli di densità.

Quando si accede alla procedura guidata da una libreria di footprint PCB basata su file, è disponibile la pagina Footprint Destination, in cui è possibile selezionare la posizione in cui memorizzare il footprint appena creato – mostra immagine:

  • Selezionare Existing PcbLib File se si desidera memorizzare il footprint in un file di libreria PCB esistente. È possibile inserire il file direttamente nella casella di testo oppure utilizzare  per aprire una finestra di dialogo e cercare il file desiderato.
  • Selezionare New PcbLib File se si desidera memorizzare il footprint in un nuovo file di libreria PCB. Inserire il nome del nuovo file di libreria PCB nella casella di testo. Il sistema aggiungerà l'estensione .PcbLib al nome del nuovo file di libreria.
  • Selezionare Current PcbLib File per memorizzare il footprint nel file di libreria PCB visualizzato.
  • Abilitare Produce 3D/STEP model per generare un modello STEP 3D.
  • Se si dispone di una licenza valida 'MCAD Co-Designer - SOLIDWORKS(R)', è possibile scegliere di salvare il modello come file di tipo Parasolid. Fare clic sul menu a discesa a destra di Format quindi selezionare Parasolid. Il file mostrato nella casella di testo External File è ora un file *.x_t. Questi sono il nome e la posizione del file che verrà salvato.
  • Selezionare Embedded (impostazione predefinita) oppure External File. Selezionare External File per salvare il modello STEP 3D come file esterno. Il tipo di file predefinito è STEP e il nome del file appare nella casella di testo External File con *.step come estensione. Se lo si desidera, fare clic su  per cercare e selezionare la cartella in cui salvare il modello STEP 3D generato.

Creazione di un footprint mediante la procedura guidata Footprint Wizard

L'editor di footprint PCB include una Footprint Wizard. Questa Wizard consente di scegliere tra vari tipi di package e di inserire le informazioni appropriate, per poi creare il footprint del componente. Si noti che nella Footprint Wizardsi inseriscono le dimensioni richieste per i pad e per la serigrafia del componente.

Per avviare la Footprint Wizard, selezionare Tools » Footprint Wizard dai menu principali oppure fare clic con il pulsante destro del mouse nell'area di progettazione e scegliere il comando Tools » Footprint Wizard dal menu contestuale.

Utilizzare la pagina Component patterns per specificare la configurazione del componente che si desidera creare. Selezionare la configurazione desiderata dall'elenco, quindi utilizzare il menu a discesa per selezionare l'unità di misura del componente (Imperial (mil) o Metric (mm)). Le configurazioni disponibili sono:

  • Ball Grid Arrays (BGA)
  • Capacitors
  • Diodes
  • Dual In-line Packages (DIP)
  • Edge Connectors
  • Leadless Chip Carriers (LCC)
  • Pin Grid Arrays (PGA)
  • Quad Packs (QUAD)
  • Resistors
  • Small Outline Packages (SOP)
  • Staggered Ball Grid Arrays (SBGA)
  • Staggered Pin Grid Arrays (SPGA)

Le pagine successive della procedura guidata cambiano in base alla configurazione del componente selezionata. Seguire le pagine intuitive della procedura guidata per configurare il footprint del componente in base alle proprie esigenze.

Quando si imposta lo stile di denominazione dei pad per un footprint con configurazione Edge Connectors, Leadless Chip Carriers (LCC) o Quad Packs (QUAD), fare clic sulla freccia verde per modificare l'ordine/la direzione di denominazione – mostra immagine.

Generazione di un report del componente

Per generare un report per il footprint PCB attivo, scegliere il comando Reports » Component dai menu principali. Dopo l'esecuzione del comando, il report verrà generato (<PCBLibraryDocumentName>.CMP) nella stessa cartella del documento della libreria PCB di origine e verrà aperto automaticamente come documento attivo nella finestra principale di progettazione. Il report elenca informazioni quali le dimensioni del footprint e il dettaglio degli oggetti primitivi che lo costituiscono e dei layer su cui si trovano.

Il report verrà aggiunto al pannello Projects come documento libero nella sottocartella Documentation\Text Documents.

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents