Convalida di un componente
Prima di salvare in Single Component Editing o Batch Component Editing nella connected Workspace un componente di Workspace Library definito/modificato nell’editor dei componenti e renderlo disponibile per l’uso nei progetti, è essenziale assicurarsi che il componente soddisfi i requisiti in base alle impostazioni configurate. Quando si tenta di salvare un componente nel Workspace, l’editor dei componenti esegue una convalida – un Component Rule Check. Questa funzionalità può essere eseguita anche in qualsiasi momento, manualmente, scegliendo il comando Tools » Component Rule Check dai menu principali. Assicurarsi di aver salvato localmente il componente (File » Save) prima di farlo.
Proprio come un progetto di scheda dispone di un processo di convalida per rilevare eventuali violazioni, l’editor dei componenti dispone di una funzionalità di convalida dei componenti. Tutte le violazioni rilevate sono elencate nel pannello Messages.
La convalida del componente verifica una serie di potenziali problemi relativi al componente e ai modelli definiti, inclusi sia controlli incorporati sia una gamma di tipi di violazione definibili dall’utente a livello globale.
I seguenti controlli di convalida incorporati hanno tutti una modalità di report
:
Folder path not specified for component
Riepilogo
Questa violazione si verifica quando non viene specificata una cartella nel Workspace di destinazione in cui deve essere salvato un componente definito nel Component Editor.
Notifica
Nel pannello Messages verrà visualizzata una notifica nel seguente formato:
Folder path not specified for component <ItemID>
dove:
- ItemID è l’ID utilizzato per il componente nel Workspace.
Raccomandazione per la risoluzione
-
Nel Component Editor in Single Component Editing mode, utilizzare il campo Folder nel Component per specificare una cartella nel Workspace di destinazione in cui salvare il componente. Per specificare manualmente una cartella di destinazione, fare clic sul pulsante
per accedere alla finestra di dialogo Choose Folder. Sfogliare, quindi scegliere una cartella esistente oppure crearne una nuova al volo.
-
Nel Component Editor in Batch Component Editing mode, utilizzare il campo FolderPath (nel gruppo di colonne Component) nell’area di definizione del componente dell’editor per specificare una cartella nel Workspace di destinazione in cui salvare il componente. Per specificare manualmente una cartella di destinazione, fare clic una volta all’interno del campo FolderPath di un componente per visualizzare il pulsante
, quindi fare clic per accedere alla finestra di dialogo Choose Folder. Sfogliare, quindi scegliere una cartella esistente oppure crearne una nuova al volo.
Component not having a unique Id
Riepilogo
Questa violazione si verifica quando l’Item ID di un componente definito nel Component Editor è uguale all’Item ID di un altro elemento nel connected Workspace.
Notifica
Nel pannello Messages verrà visualizzata una notifica nel seguente formato:
Duplicate Component Id: "<ItemID>"
dove:
- ItemID è l’ID utilizzato per il componente nel Workspace.
Raccomandazione per la risoluzione
-
Nel Component Editor in Single Component Editing mode, utilizzare il campo Id nell’area Component per specificare un altro ID univoco per il contenuto del Workspace connesso.
-
Nel Component Editor in Batch Component Editing mode, utilizzare il campo Item ID nel gruppo di colonne Component dell’area di definizione del componente per specificare un altro ID univoco per il contenuto del Workspace connesso.
Nota
Questa violazione si verifica in genere quando un valore Item ID assegnato automaticamente a un componente viene sovrascritto manualmente. Per un nuovo componente creato tramite il comando File » New » Component o il pannello Components panel, questo campo viene popolato in base al template del componente definito per il tipo di componente scelto nella finestra di dialogo Create new component dialog. Quando non esiste un template, oppure quando nella finestra di dialogo viene scelta la voce <Undefined> , viene utilizzato uno schema di denominazione predefinito; CMP-{00000}. Per un nuovo componente creato tramite il pannello Explorer panel, questo campo viene popolato in base allo schema di denominazione predefinito specificato per la cartella padre del componente. Se alla cartella padre è associato un template del componente, la denominazione del componente definita verrà ereditata da quel template. Il software assegnerà automaticamente il successivo ID univoco disponibile, in base a tale schema, dopo aver analizzato l’intero Workspace e gli identificatori del contenuto esistente.
I controlli definibili dall’utente sono configurati nella pagina Data Management – Component Rule Checks page della finestra di dialogo Preferences.
Qualsiasi controllo incorporato che non viene superato o qualsiasi controllo definito dall’utente con livello Fatal Error impedirà il salvataggio del componente nel Workspace.
Le impostazioni predefinite dei controlli definiti dall’utente potrebbero non essere adatte ai propri componenti, quindi è importante acquisire familiarità con le opzioni e con il modo di configurarle in base ai propri progetti. Di seguito sono riportate informazioni su ciascun controllo di errore definito dall’utente.
Violazioni associate ai componenti
Duplicate component by Name
Default report mode:
Riepilogo
Questa violazione si verifica quando il nome di un componente definito nel Component Editor è uguale al nome di un componente nel connected Workspace.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Duplicate component by Name
Raccomandazione per la risoluzione
Assegnare ai componenti nomi diversi e univoci, secondo necessità.
-
Nel Component Editor in Single Component Editing mode, utilizzare il campo Name nell’area Component per specificare un altro nome univoco per i componenti nel Workspace connesso.
-
Nel Component Editor in Batch Component Editing mode, utilizzare il campo Item ID nel gruppo di colonne Component dell’area di definizione del componente per specificare un altro nome univoco per i componenti nel Workspace connesso.
Duplicate component by PCL
Default report mode:
Riepilogo
Questa violazione si verifica quando un componente definito nel Component Editor ha una Part Choice utilizzata da un altro componente nel connected Workspace.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Duplicate component by Part Choice list
Raccomandazione per la risoluzione
Assegnare ai componenti Part Choice diverse e univoche, secondo necessità.
-
Nel Component Editor in Single Component Editing mode, utilizzare l’area Part Choices per modificare l’elenco delle Part Choice del componente in modo che sia univoco per i componenti nel Workspace connesso.
-
Nel Component Editor in Batch Component Editing mode, utilizzare il gruppo di colonne Part Choice n dell’area di definizione del componente per modificare l’elenco delle Part Choice del componente in modo che sia univoco per i componenti nel Workspace connesso.
Invalid pin mappings
Default report mode:
Riepilogo
Questa violazione si verifica quando un componente definito nel Component Editor presenta una mappatura ambigua tra simbolo del componente e footprint. Ad esempio, la violazione si verifica se il simbolo ha pin definiti nei campi Designator come 1, 2, 3, mentre il footprint ha pad definiti nei campi Designator come B, C, E, oppure quando il numero di pin del simbolo è maggiore del numero di pad del footprint.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Pin <PinDesignator> of the symbol <SymbolName> (<SymbolRevisionID>) does not have corresponding pad <PadDesignator> in footprint <FootprintName> (<FootprintRevisionID>)
dove:
-
PinDesignatorè il Designator del pin del simbolo. -
SymbolNameè il nome del simbolo. -
SymbolRevisionIDè l’ID Item-Revision del simbolo. -
PadDesignatorè il Designator del pad del footprint. -
FootprintNameè il nome del footprint. -
FootprintRevisionIDè l’ID Item-Revision del footprint.
Raccomandazione per la risoluzione
Modificare il modello attualmente aggiunto oppure selezionarne un altro per assicurarsi che i pin del simbolo corrispondano uno a uno ai pad del footprint.
-
Nel Component Editor in Single Component Editing mode:
-
fare clic sul controllo
in alto a destra nell’anteprima del modello per modificare il modello attualmente usato (referenziato) dal componente nell’editor temporaneo corrispondente per quel tipo di modello;
-
fare clic sul controllo
in alto a destra nell’anteprima del modello e scegliere dal menu la voce Select Model per sfogliare e scegliere un modello diverso, oppure una revisione diversa dello stesso modello;
-
fare clic sul controllo
in alto a destra nell’anteprima del simbolo per accedere al pannello Pins panel e modificare direttamente le destinazioni pad/pin mappate facendo clic su una cella del modello e inserendo il valore richiesto.
-
-
Nel Component Editor in Batch Component Editing mode:
-
fare clic con il pulsante destro del mouse sulla voce del modello nell’area Model Links e scegliere dal menu contestuale il comando Edit per modificare il modello attualmente usato (referenziato) dal componente nell’editor temporaneo corrispondente per quel tipo di modello;
-
fare clic nel campo Item ID del modello nell’area Model Links, quindi fare clic sul pulsante
per sfogliare e scegliere un modello diverso, oppure una revisione diversa dello stesso modello.
-
Missing Component Description
Default report mode:
Riepilogo
Questa violazione si verifica quando non viene specificata la descrizione di un componente definito nel Component Editor.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Component Description is not specified
Raccomandazione per la risoluzione
Specificare una descrizione per i componenti interessati, secondo necessità.
-
Nel Component Editor in Single Component Editing mode, utilizzare il campo Description nell’area Component per specificare una descrizione.
-
Nel Component Editor in Batch Component Editing mode, utilizzare il campo Description nel gruppo di colonne Component dell’area di definizione del componente per specificare una descrizione per i componenti interessati.
Missing Component Name
Default report mode:
Riepilogo
Questa violazione si verifica quando non viene specificato il nome di un componente definito nel Component Editor.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Component Name is not specified
Raccomandazione per la risoluzione
Specificare un nome per i componenti interessati, secondo necessità.
-
Nel Component Editor in Single Component Editing mode, utilizzare il campo Name nell’area Component per specificare un nome.
-
Nel Component Editor in Batch Component Editing mode, utilizzare il campo Name nel gruppo di colonne Component dell’area di definizione del componente per specificare un nome per i componenti interessati.
Missing Component Type
Default report mode:
Riepilogo
Questa violazione si verifica quando non viene specificato il tipo di un componente definito nel Component Editor.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Component Type is not specified
Raccomandazione per la risoluzione
Specificare un tipo per i componenti interessati, secondo necessità.
-
Nel Component Editor in Single Component Editing mode, utilizzare il campo Type nell’area Component per specificare un tipo.
-
Nel Component Editor in Batch Component Editing mode, utilizzare il campo Type nel gruppo di colonne Component dell’area di definizione del componente per specificare un tipo per i componenti interessati.
Model revision is in Inapplicable State
Default report mode:
Riepilogo
Questa violazione si verifica quando un modello collegato che viene usato (referenziato) da una definizione di componente viene rilevato in uno stato non applicabile. Ad esempio, il modello è attualmente Obsolete e pertanto non dovrebbe essere usato. L’applicabilità è determinata tramite l’opzione Allowed to be used in designs nella finestra di dialogo State Properties dialog. Dalla finestra di dialogo Edit Lifecycle Definitions dialog, è possibile accedere a questa finestra di dialogo per lo stato richiesto facendo doppio clic sulla voce dello stato all’interno della definizione del ciclo di vita padre oppure selezionando la relativa voce e facendo clic sull’icona di modifica visualizzata Quando questa opzione è abilitata, un modello in questo stato può essere usato in un componente. È considerato Applicable. Se questa opzione è disabilitata, un modello in questo stato non può essere usato validamente ed è considerato Inapplicable (o non applicabile).
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
<ModeName> (<ModelRevisionID>) revision is in inapplicable state
dove:
-
ModelNameè il nome del modello. -
ModelRevisionIDè l’ID Item-Revision del modello.
Raccomandazione per la risoluzione
Scegliere un modello sostitutivo o una revisione dello stesso modello valida per l’uso nel componente.
-
Nel Component Editor in Single Component Editing mode, fare clic sul controllo
in alto a destra nell’anteprima del modello e scegliere dal menu la voce Select Model per sfogliare e scegliere un modello diverso, oppure una revisione diversa dello stesso modello.
-
Nel Component Editor in Batch Component Editing mode, fare clic nel campo Item ID del modello nell’area Model Links, quindi fare clic sul pulsante
per sfogliare e scegliere un modello diverso, oppure una revisione diversa dello stesso modello.
Model revision is Out Of Date
Default report mode:
Riepilogo
Questa violazione si verifica quando un modello collegato che viene usato (referenziato) da una definizione di componente viene rilevato come non aggiornato. Se è disponibile una revisione successiva del modello, il campo Revision State lo indicherà con il testo Out of date, a destra dello stato del ciclo di vita della revisione corrente sotto l’anteprima del modello (nel Component Editor in Single Component Editing mode), oppure il campo Revision Status nell’area Model Links sarà contrassegnato dal testo Out of date, mostrato in grassetto (nel Component Editor in Batch Component Editing mode).
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
<ModelName> (<ModelRevisionID>) revision is Out of Date
dove:
-
ModelNameè il nome del modello. -
ModelRevisionIDè l’ID Item-Revision del modello.
Raccomandazione per la risoluzione
Aggiornare i collegamenti del modello del componente non aggiornati affinché utilizzino la revisione più recente dei modelli.
-
Nel Component Editor in Single Component Editing mode, fare clic sul controllo
in alto a destra dell’anteprima del modello e scegliere dal menu la voce Update to Latest.
-
Nel Component Editor in Batch Component Editing mode, fare clic con il pulsante destro del mouse in un punto qualsiasi sulla voce del modello nell’area Model Links regione e scegli Update to Latest Revision dal menu.
Number of Pads exceeds Number of Pins
Default report mode:
Riepilogo
Questa violazione si verifica quando un modello di footprint utilizzato (referenziato) da una definizione di componente include più pad (pad SMD posizionati sui layer di rame e pad passanti metallizzati) rispetto ai pin del simbolo schematico referenziato.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Number of pads in the footprint <FootprintName> (<FootprintRevisionID>) (<FootprintNumberOfPads>) exceeds number of pins in the symbol <SymbolName> (<SymbolRevisionID>) (<SymbolNumberOfPins>)
dove:
-
FootprintNameè il nome del footprint. -
FootprintRevisionIDè l'ID Item-Revision del footprint. -
FootprintNumberOfPadsè il numero di pad nel footprint. -
SymbolNameè il nome del simbolo. -
SymbolRevisionIDè l'ID Item-Revision del simbolo. -
SymbolNumberOfPinsè il numero di pin nel simbolo.
Raccomandazione per la risoluzione
Modifica il modello attualmente aggiunto oppure seleziona un altro simbolo/modello di footprint per assicurarti che il footprint abbia un numero di pad che non superi il numero di pin del simbolo.
-
Nel Component Editor in modalità Single Component Editing:
-
fai clic sul controllo
in alto a destra nell'anteprima del modello per modificare il modello attualmente utilizzato (referenziato) dal componente nel corrispondente editor temporaneo per quel tipo di modello;
-
fai clic sul controllo
in alto a destra nell'anteprima del modello e scegli la voce Select Model dal menu per sfogliare e scegliere un modello diverso o una revisione diversa dello stesso modello.
-
-
Nel Component Editor in modalità Batch Component Editing:
-
fai clic con il pulsante destro sulla voce del modello nella regione Model Links e scegli il comando Edit dal menu contestuale per modificare il modello attualmente utilizzato (referenziato) dal componente nel corrispondente editor temporaneo per quel tipo di modello;
-
fai clic sul campo Item ID del modello nella regione Model Links , quindi fai clic sul pulsante
per sfogliare e scegliere un modello diverso o una revisione diversa dello stesso modello.
-
Revision that is being edited is not latest
Default report mode:
Riepilogo
Questa violazione si verifica quando la revisione del componente in corso di modifica non è l'ultima revisione disponibile nel Workspace connesso.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
<ComponentName> (<ComponentRevisionID>) revision is Out of Date
dove:
-
ComponentNameè il Name del componente. -
ComponentRevisionIDè l'ID Item-Revision del componente.
Raccomandazione per la risoluzione
Seleziona l'ultima revisione del componente per la modifica. Per farlo, cerca il componente nel Components panel, fai clic con il pulsante destro sulla sua voce nel pannello e scegli Edit.
Unrecognized combination of Manufacturer+Part Number in Part Choice
Default report mode:
Riepilogo
Questa violazione si verifica quando viene aggiunta una voce errata per la scelta parte di un componente e il Workspace non riesce a recuperare la parte.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Manufacturer+Part Number combination was not found in the available Part Sources ("Part Choice <n>")
dove:
-
nè il numero progressivo della scelta parte non valida.
Raccomandazione per la risoluzione
Specifica una scelta parte valida per i componenti interessati.
-
Nel Component Editor in modalità Single Component Editing, rimuovi le scelte parte non valide dalla regione Part Choices e aggiungi nuove scelte parte corrette.
-
Nel Component Editor in modalità Batch Component Editing, inserisci valori corretti nei campi Part Choice n nella regione di definizione del componente. Nota che, finché il valore di un campo della scelta parte contiene una voce errata, il testo apparirà in grigio e in corsivo. Una volta che entrambe le voci sono corrette, il testo apparirà normalmente, in bianco.
Violazioni associate ai footprint
Duplicate Pad Designator
Default report mode:
Riepilogo
Questa violazione si verifica quando un modello di footprint collegato a un componente definito nel Component Editor contiene più oggetti Pad con lo stesso valore della proprietà Designator.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Duplicate Pad Designator On Pads Pad <Identifier1> on <Layer1> And Pad <Identifier2> on <Layer2>
dove:
-
Identifier1è l'identificatore della prima istanza del pad con designatore duplicato, rappresentato dall'abbinamento net-designator e dalle coordinate del pad. -
Layer1è il layer su cui è posizionata la prima istanza del pad con designatore duplicato. -
Identifier2è l'identificatore della seconda istanza del pad con designatore duplicato, rappresentato dall'abbinamento net-designator e dalle coordinate del pad. -
Layer2è il layer su cui è posizionata la seconda istanza del pad con designatore duplicato.
Raccomandazione per la risoluzione
Assegna designatori diversi e univoci ai pad del modello di footprint collegato.
-
Nel Component Editor in modalità Single Component Editing, fai clic sul controllo
in alto a destra nell'anteprima del footprint.
-
Nel Component Editor in modalità Batch Component Editing, fai clic con il pulsante destro sulla voce del footprint nella regione Model Links e scegli il comando Edit dal menu contestuale.
Il modello di footprint attualmente utilizzato (referenziato) dal componente si aprirà nell'editor temporaneo PCB Footprint. Seleziona i pad interessati e modifica i valori della loro proprietà Designator nella Pad mode of the Properties panel.
Duplicate Primitives
Default report mode:
Riepilogo
Questa violazione si verifica quando un modello di footprint collegato a un componente definito nel Component Editor contiene oggetti identici posizionati nella stessa posizione sullo stesso layer.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Duplicate Primitives: <ObjectType1> <Identifier1> on <Layer1> And <ObjectType2> <Identifier2> on <Layer2>
dove:
-
ObjectType1è il tipo della prima istanza dell'oggetto duplicato. -
Identifier1è l'identificatore della prima istanza dell'oggetto duplicato; la rappresentazione dell'identificatore dipende dal tipo di oggetto. -
Layer1è il layer su cui è posizionata la prima istanza dell'oggetto duplicato. -
ObjectType2è il tipo della seconda istanza dell'oggetto duplicato. -
Identifier2è l'identificatore della seconda istanza dell'oggetto duplicato; la rappresentazione dell'identificatore dipende dal tipo di oggetto. -
Layer2è il layer su cui è posizionata la seconda istanza dell'oggetto duplicato.
Raccomandazione per la risoluzione
Rimuovi gli oggetti duplicati dal modello di footprint.
-
Nel Component Editor in modalità Single Component Editing, fai clic sul controllo
in alto a destra nell'anteprima del footprint.
-
Nel Component Editor in modalità Batch Component Editing, fai clic con il pulsante destro sulla voce del footprint nella regione Model Links e scegli il comando Edit dal menu contestuale.
Il modello di footprint attualmente utilizzato (referenziato) dal componente si aprirà nell'editor temporaneo PCB Footprint. Seleziona gli oggetti duplicati e rimuovili usando la scorciatoia Delete.
Mirrored Footprint (designed on bottom layer)
Default report mode:
Riepilogo
Questa violazione si verifica quando un modello di footprint collegato a un componente definito nel Component Editor ha primitive significative (pad, track, archi, fill, regioni, rettangoli, stringhe di testo, oggetti keepout) posizionate sul Bottom Layer ma non ha primitive di questo tipo posizionate sul Top Layer.
Nell'editor PCB Footprint, il footprint è costruito per il lato superiore della scheda; se necessario, può essere capovolto sul lato inferiore durante il processo di progettazione PCB.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Bottom Layer Component
Raccomandazione per la risoluzione
Capovolgi le primitive del footprint da Bottom Layer a Top Layer.
-
Nel Component Editor in modalità Single Component Editing, fai clic sul controllo
in alto a destra nell'anteprima del footprint.
-
Nel Component Editor in modalità Batch Component Editing, fai clic con il pulsante destro sulla voce del footprint nella regione Model Links e scegli il comando Edit dal menu contestuale.
Il modello di footprint attualmente utilizzato (referenziato) dal componente si aprirà nell'editor temporaneo PCB Footprint. Seleziona le primitive su Bottom Layer e modifica la loro proprietà Layer nella modalità corrispondente del pannello Properties in Top Layer.
Missing Pad Designator
Default report mode:
Riepilogo
Questa violazione si verifica quando un modello di footprint collegato a un componente definito nel Component Editor contiene un oggetto Pad senza alcun valore specificato per la proprietà Designator.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Missing Pad Designator on Pad: Pad <Identifier> on <Layer>
dove:
-
Identifierè l'identificatore del pad senza designatore specificato, rappresentato dalla net del pad e dalle coordinate. -
Layerè il layer su cui è posizionato il pad senza designatore specificato.
Raccomandazione per la risoluzione
Specifica i valori del designatore per i pad del modello di footprint collegato.
-
Nel Component Editor in modalità Single Component Editing, fai clic sul controllo
in alto a destra nell'anteprima del footprint per aprire il footprint attualmente utilizzato (referenziato) dal componente nell'editor temporaneo PCB Footprint.
-
Nel Component Editor in modalità Batch Component Editing, fai clic con il pulsante destro sulla voce del footprint nella regione Model Links e scegli il comando Edit dal menu contestuale.
Il modello di footprint attualmente utilizzato (referenziato) dal componente si aprirà nell'editor temporaneo PCB Footprint. Seleziona un pad interessato e specifica il valore della relativa proprietà Designator nella Pad mode of the Properties panel.
Offset Footprint Reference
Default report mode:
Riepilogo
Questa violazione si verifica quando un modello di footprint collegato a un componente definito nel Component Editor ha il proprio punto di riferimento (origine) al di fuori del rettangolo di delimitazione formato dagli oggetti del footprint.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Offset Component Origin
Raccomandazione per la risoluzione
Modifica la posizione del punto di riferimento in modo che si trovi all'interno del rettangolo di delimitazione formato dagli oggetti del footprint.
-
Nel Component Editor in modalità Single Component Editing, fai clic sul controllo
in alto a destra nell'anteprima del footprint per aprire il footprint attualmente utilizzato (referenziato) dal componente nell'editor temporaneo PCB Footprint.
-
Nel Component Editor in modalità Batch Component Editing, fai clic con il pulsante destro sulla voce del footprint nella regione Model Links e scegli il comando Edit dal menu contestuale.
Il modello di footprint attualmente utilizzato (referenziato) dal componente si aprirà nell'editor temporaneo PCB Footprint. Usa i comandi del sottomenu Edit » Set Reference dei menu principali per modificare la posizione corrente del riferimento del footprint.
Shorted Copper
Default report mode:
Riepilogo
Questa violazione si verifica quando un modello di footprint collegato a un componente definito nel Component Editor contiene oggetti Pad collegati tra loro da oggetti su un layer di rame.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Shorted Copper Connection Between Pad <Identifier1> on <Layer1> And Pad <Identifier2> on <Layer2>
dove:
-
Identifier1è l'identificatore della prima istanza del pad nella coppia di pad in corto, rappresentato dall'abbinamento net-designator e dalle coordinate del pad. -
Layer1è il layer su cui è posizionata la prima istanza del pad nella coppia di pad in corto. -
Identifier2è l'identificatore della seconda istanza del pad nella coppia di pad in corto, rappresentato dall'abbinamento net-designator e dalle coordinate del pad. -
Layer2è il layer su cui è posizionata la seconda istanza del pad nella coppia di pad in corto.
Raccomandazione per la risoluzione
Rimuovi gli oggetti sul layer di rame che collegano i pad del modello di footprint collegato.
-
Nel Component Editor in modalità Single Component Editing, fai clic sul controllo
in alto a destra nell'anteprima del footprint.
-
Nel Component Editor in modalità Batch Component Editing, fai clic con il pulsante destro sulla voce del footprint nella regione Model Links e scegli il comando Edit dal menu contestuale.
Il modello di footprint attualmente utilizzato (referenziato) dal componente si aprirà nell'editor temporaneo PCB Footprint. Seleziona gli oggetti sul layer di rame che collegano i pad, quindi modificali in modo che non colleghino i pad, oppure rimuovi tali oggetti.
Unconnected Copper
Default report mode:
Riepilogo
Questa violazione si verifica quando un modello di footprint collegato a un componente definito nel Component Editor contiene oggetti su un layer di rame e tali oggetti non sono collegati ad alcun oggetto Pad. Quando un footprint di questo tipo viene posizionato in un progetto PCB, a questi oggetti sul layer di rame non verrà assegnata alcuna net e diventeranno rame morto.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Unconnected Copper on primitive : <ObjectType> <Identifier> on <Layer>
dove:
-
ObjectTypeè il tipo di istanza dell'oggetto che non è collegato ad alcun oggetto Pad nel modello di footprint. -
Identifierè l'identificatore dell'oggetto che non è collegato ad alcun oggetto Pad nel modello di footprint; la rappresentazione dell'identificatore dipende dal tipo di oggetto. -
Layerè il layer su cui è posizionata l'istanza dell'oggetto che non è collegato ad alcun oggetto Pad nel modello di footprint.
Raccomandazione per la risoluzione
Modifica il modello di footprint in modo che gli oggetti che attualmente non sono collegati ad alcun oggetto Pad nel modello di footprint siano collegati ai pad.
-
Nel Component Editor in modalità Single Component Editing, fai clic sul controllo
in alto a destra nell'anteprima del footprint.
-
Nel Component Editor in modalità Batch Component Editing, fai clic con il pulsante destro sulla voce del footprint nella regione Model Links e scegli il comando Edit dal menu contestuale.
Il modello di footprint attualmente utilizzato (referenziato) dal componente si aprirà nell'editor temporaneo PCB Footprint. Posiziona oggetti sui layer di rame per formare una connessione tra i pad del footprint e gli oggetti che attualmente non sono collegati ad alcun oggetto Pad, oppure rimuovi questi oggetti non collegati.
Violazioni associate ai simboli
Different pins between modes
Default report mode:
Riepilogo
Questa violazione si verifica quando una delle modalità di visualizzazione di un simbolo contiene un pin aggiuntivo.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Extra Pin in display mode <DisplayMode> of the symbol <SymbolRevisionID>. Part <PartDesignator>. Pin Name "<PinName>"
dove:
-
DisplayModeè la modalità specifica di rappresentazione grafica del simbolo in cui sono stati trovati i pin aggiuntivi. Un simbolo ha una modalità Normal e può avere fino a 255 modalità Alternate definite. Ulteriori informazioni su come creare più modalità di visualizzazione grafica dello stesso simbolo di componente. -
SymbolRevisionIDè l'ID revisione-elemento del simbolo. -
PartDesignatorè il Designator della parte del simbolo. -
PinNameè il Name del pin interessato.
Raccomandazione per la risoluzione
Questa violazione in genere si verifica quando per un simbolo viene definita una modalità grafica alternativa e si verifica una delle seguenti condizioni:
- È stato aggiunto un pin in più a una modalità di visualizzazione che non è specificato in un'altra modalità di visualizzazione, oppure
- È stato specificato un pin con un Designator e/o un Name diversi rispetto a un pin specificato in un'altra modalità di visualizzazione.
Non solo deve esserci un numero identico di pin tra le modalità di visualizzazione grafica, ma i pin devono anche essere identici sia per Designator sia per Name. Ulteriori informazioni su come creare più modalità di visualizzazione grafica dello stesso simbolo di componente.
Modificare il Designator e/o il Name dei pin interessati in modo che il numero di pin e le relative proprietà Designator e Name siano gli stessi tra le modalità di visualizzazione del simbolo, oppure rimuovere un pin aggiuntivo da una modalità di visualizzazione.
-
Nel Component Editor in modalità Single Component Editing, fare clic sul controllo
in alto a destra nell'anteprima del simbolo.
-
Nel Component Editor in modalità Batch Component Editing, fare clic con il pulsante destro sulla voce del simbolo nell'area Model Links e scegliere il comando Edit dal menu contestuale.
Il modello del simbolo attualmente utilizzato (referenziato) dal componente verrà aperto nell'editor temporaneo della Schematic Library. Selezionare i pin interessati e modificare i valori delle relative proprietà Designator e/o Name nella modalità Pin del pannello Properties, oppure rimuovere questi pin utilizzando la scorciatoia Delete.
Duplicate Pin Designators
Default report mode:
Riepilogo
Questa violazione si verifica quando due o più pin nel modello di simbolo del componente hanno lo stesso designatore.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Duplicate Pin Designator(s) (mode <DisplayMode>): <PinDesignatorList>
dove:
-
DisplayModeè la modalità specifica di rappresentazione grafica del simbolo in cui sono stati trovati i pin duplicati. Un simbolo ha una modalità Normal e può avere fino a 255 modalità Alternate definite. -
PinDesignatorListè l'elenco, separato da virgole, dei designatori dei pin duplicati nel simbolo interessato.
Raccomandazione per la risoluzione
Modificare il designatore dei pin interessati in modo appropriato, affinché ciascuno abbia un'assegnazione univoca.
-
Nel Component Editor in modalità Single Component Editing, fare clic sul controllo
in alto a destra nell'anteprima del simbolo.
-
Nel Component Editor in modalità Batch Component Editing, fare clic con il pulsante destro sulla voce del simbolo nell'area Model Links e scegliere il comando Edit dal menu contestuale.
Il modello del simbolo attualmente utilizzato (referenziato) dal componente verrà aperto nell'editor temporaneo della Schematic Library. Selezionare i pin interessati e modificare i valori della relativa proprietà Designator nella modalità Pin del pannello Properties, oppure rimuovere questi pin utilizzando la scorciatoia Delete.
Missing Default Designator
Default report mode:
Riepilogo
Questa violazione si verifica quando nel modello di simbolo del componente non è specificato alcun designatore predefinito.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Missing Default Designator
Raccomandazione per la risoluzione
Specificare un designatore predefinito per il modello di simbolo interessato.
-
Nel Component Editor in modalità Single Component Editing, fare clic sul controllo
in alto a destra nell'anteprima del simbolo.
-
Nel Component Editor in modalità Batch Component Editing, fare clic con il pulsante destro sulla voce del simbolo nell'area Model Links e scegliere il comando Edit dal menu contestuale.
Il modello del simbolo attualmente utilizzato (referenziato) dal componente verrà aperto nell'editor temporaneo della Schematic Library. Aprire la modalità Symbol del pannello Properties (attiva quando nessun oggetto è selezionato nello spazio di progettazione) e specificare il prefisso di designatore richiesto seguito dal carattere '?' nel campo Designator (ad esempio, C?). I punti interrogativi nei designatori dei componenti posizionati su un foglio schematico verranno aggiornati con i numeri effettivi durante il processo di Design Annotation.
Missing Pin Designator
Default report mode:
Riepilogo
Questa violazione si verifica quando un pin nel modello di simbolo del componente non ha alcun designatore specificato.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Missing Pin Designator of the symbol <SymbolRevisionID>
dove:
-
SymbolRevisionIDè l'ID revisione-elemento del simbolo interessato.
Raccomandazione per la risoluzione
Specificare un designatore per ciascun pin nel modello di simbolo interessato.
-
Nel Component Editor in modalità Single Component Editing, fare clic sul controllo
in alto a destra nell'anteprima del simbolo.
-
Nel Component Editor in modalità Batch Component Editing, fare clic con il pulsante destro sulla voce del simbolo nell'area Model Links e scegliere il comando Edit dal menu contestuale.
Il modello del simbolo attualmente utilizzato (referenziato) dal componente verrà aperto nell'editor temporaneo della Schematic Library. Selezionare i pin interessati e specificare i valori della relativa proprietà Designator nella modalità Pin del pannello Properties, oppure rimuovere i pin utilizzando la scorciatoia Delete.
Missing Pin Name
Default report mode:
Riepilogo
Questa violazione si verifica quando un pin nel modello di simbolo del componente non ha alcun nome specificato.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Missing Pin Name of the symbol <SymbolRevisionID>. Pin Designator "<PinDesignator>".
dove:
-
SymbolRevisionIDè l'ID revisione-elemento del simbolo interessato. -
PinDesignatorè il Designator del pin interessato.
Raccomandazione per la risoluzione
Specificare un nome per ciascun pin nel modello di simbolo interessato.
-
Nel Component Editor in modalità Single Component Editing, fare clic sul controllo
in alto a destra nell'anteprima del simbolo.
-
Nel Component Editor in modalità Batch Component Editing, fare clic con il pulsante destro sulla voce del simbolo nell'area Model Links e scegliere il comando Edit dal menu contestuale.
Il modello del simbolo attualmente utilizzato (referenziato) dal componente verrà aperto nell'editor temporaneo della Schematic Library. Selezionare i pin interessati e specificare i valori della relativa proprietà Name nella modalità Pin del pannello Properties, oppure rimuovere questi pin utilizzando la scorciatoia Delete.
Nota
Nel pannello Messages verrà elencata una sola istanza di violazione per ciascun componente distinto. Un componente può benissimo avere un simbolo con più di un pin senza nome definito.
Missing Pins in Sequence
Default report mode:
Riepilogo
Questa violazione si verifica quando vengono rilevati pin mancanti nella sequenza numerica dei valori di designatore dei pin del simbolo interessato. Ad esempio, se il simbolo ha pin con designatori 1, 2, 5 e non ci sono pin con designatore 3 e 4.
Notifica
Nel pannello Messages viene visualizzata una notifica nel seguente formato:
Missing Pin Designator In Sequence : <PinDesignatorList> [<LowerPinDesignator>..<UpperPinDesignator>]
dove:
-
PinDesignatorListè l'elenco, separato da virgole, dei designatori dei pin mancanti nella sequenza numerica rilevata nel simbolo interessato. -
LowerPinDesignatorè il valore numerico minimo dei designatori dei pin rilevati nel simbolo interessato. -
UpperPinDesignatorè il valore numerico massimo dei designatori dei pin rilevati nel simbolo interessato.
Raccomandazione per la risoluzione
Nel modello di simbolo interessato, aggiungere pin con i designatori mancanti nella sequenza oppure modificare i designatori dei pin in modo che formino una sequenza continua di valori interi.
-
Nel Component Editor in modalità Single Component Editing, fare clic sul controllo
in alto a destra nell'anteprima del simbolo.
-
Nell'Editor dei componenti in modalità Modifica batch dei componenti, fai clic con il pulsante destro del mouse sulla voce del simbolo nella regione Model Links e scegli il comando Edit dal menu contestuale.
Il modello del simbolo attualmente utilizzato (referenziato) dal componente si aprirà nell'editor temporaneo della Libreria schematica. Utilizzando il comando Place » Pin dai menu principali, aggiungi il numero richiesto di pin e specifica i valori della loro proprietà Designator nella modalità Pin del pannello Proprietà in modo che i designatori dei pin nel simbolo formino una sequenza continua di valori interi. Puoi anche modificare la proprietà Designator dei pin già posizionati nel simbolo.
Nota
Esistono componenti che non utilizzano una numerazione sequenziale dei pin, ad esempio un BGA con numerazione dei pin non sequenziale: A1, A3, A5 (e così via). In questa situazione, si suggerisce di rilasciare il componente con questa violazione e annotarne il motivo nelle Note di rilascio. In alternativa, imposta il controllo Missing Pins in Sequence nella pagina Data Management – Component Rule Checks della finestra di dialogo Preferences su No Report.


