Creare e mantenere i propri componenti e librerie
A colpo d'occhio
- Scopri come i simboli schematici, i footprint PCB e altri modelli rappresentano i componenti reali.
- Confronta le opzioni disponibili per le librerie ed esplora le funzionalità del Workspace, come la condivisione dei dati dei componenti, il riutilizzo dei modelli, le informazioni sulla catena di fornitura e il monitoraggio del ciclo di vita.
- Scopri come iniziare a creare un componente nel Workspace utilizzando l'editor dei componenti e i template dei componenti.
Un progetto elettronico è un insieme di componenti collegati tra loro. La parte gratificante dello sviluppo di un prodotto consiste nell'ideare soluzioni ingegnose alle sfide tecniche e nel collegare questi componenti per realizzare un progetto unico.
Tuttavia, gran parte del lavoro, e per molti progettisti la parte più noiosa, consiste nel creare i componenti. Anche se può non essere entusiasmante, i componenti diventano una risorsa preziosa per l'azienda ed è essenziale che rappresentino accuratamente il componente reale.
Il componente che acquisti e saldi sulla scheda o utilizzi in un cablaggio è il componente reale, ma deve essere modellato in ciascuno degli ambiti della progettazione elettronica in cui desideri utilizzarlo.
A seconda delle implementazioni progettuali che intendi realizzare, il componente potrebbe includere un simbolo per lo schema elettrico, un modello di simulazione per il simulatore circuitale, un modello IBIS per l'analisi dell'integrità del segnale, un pattern o un footprint per il layout del PCB e un modello 3D per la visualizzazione, la verifica delle distanze di isolamento in 3D e l'esportazione nell'ambiente CAD meccanico.
Gestione dei componenti
Una gestione efficace dei dati dei componenti è essenziale per la progettazione elettronica, e la gestione dei componenti utilizzati in un progetto è sempre stata un elemento fondamentale del software di progettazione Altium. Con l'evoluzione del software nel corso degli anni, le metodologie di gestione dei componenti hanno fatto molta strada: dalle semplici librerie separate di modelli schematici e PCB, passando per le librerie basate su database, fino ai componenti del Workspace, che estendono la rappresentazione dei componenti di progetto all'intero contesto dello sviluppo prodotto, offrendo funzionalità all'avanguardia e facili da usare per una collaborazione senza pari durante l'intero processo di progettazione.
| Libreria del Workspace | Componenti memorizzati in un Workspace connesso che offre un'unica fonte di dati aggiornati e standardizzati sui componenti per l'intero team di progettazione. Le funzionalità di ricerca parametrica e a faccette consentono di trovare e posizionare i componenti necessari in modo rapido ed efficiente. Questi componenti sono strettamente associati al componente fisico prodotto e ai dati della catena di approvvigionamento accessibili durante la progettazione, offrendo un miglioramento significativo in termini di costi e tempi di approvvigionamento per la produzione del prodotto assemblato. |
|
| Libreria database | Vuoi associare strettamente i componenti di progetto al database aziendale? Allora esplora le librerie database. Ogni record è un componente e fa riferimento ai modelli necessari e ai dati parametrici del componente. I collegamenti ai modelli e i parametri vengono aggiunti al simbolo durante il posizionamento, trasformandolo in un componente Altium Designer. | |
| Libreria database SVN | Una libreria database SVN è un'estensione del modello di libreria database, con la differenza che il simbolo e i modelli sorgente sono archiviati sotto controllo di versione. Le librerie sorgente vengono create, ampliate e gestite all'interno di un repository basato su Subversion. Il collegamento al repository e al database esterno è definito in un file di libreria database SVN (*.SVNDbLib). |
|
| Collegamento al database | Con questo metodo, il file di collegamento al database (*.DbLink) definisce il collegamento tra il componente schematico e un record corrispondente in un database. La corrispondenza del record viene stabilita mediante il collegamento di campi chiave, che può utilizzare un singolo campo chiave (ad esempio un codice componente) oppure più campi chiave (definendo una clausola Where). |
|
| Libreria integrata | Preferisci avere i componenti già raggruppati e verificati in un unico file? Allora compila i modelli sorgente di schema elettrico, PCB e simulazione per generare una libreria integrata (*.IntLib). |
|
| Libreria schematica | Una libreria schematica (*.SchLib) può essere una libreria di modelli, contenente i simboli dei componenti; se invece a ogni simbolo vengono aggiunti collegamenti ai modelli e dati parametrici, diventa una libreria di componenti. |
|
| Libreria PCB | Una libreria per memorizzare i modelli di footprint PCB (*.PcbLib). Se necessario, è possibile aggiungere un modello 3D a ciascun footprint. I modelli 3D vengono creati a partire da oggetti corpo 3D oppure da un modello STEP importato in un oggetto corpo 3D. |
Libreria del Workspace
I componenti sono memorizzati nel tuo Workspace: un'unica posizione centralizzata e sicura per tutti i dati di progettazione, accessibile all'intero team. I vantaggi dell'utilizzo di componenti ospitati in un Workspace sono numerosi. Eccone alcuni:
-
Single source of component data – con un Workspace accessibile all'intero team, i progettisti possono reperire componenti aggiornati e standardizzati da un'unica posizione sicura, ottenere dati in tempo reale sulla catena di approvvigionamento e utilizzare la ricerca parametrica e a faccette per trovare esattamente i componenti di cui hanno bisogno.
-
Design-time choice of physical components – per ogni componente, puoi scegliere quali parti di produzione possono essere utilizzate per implementarlo durante l'assemblaggio della scheda.
-
Real-time supply-chain information – restituiti dal database aggregato dei componenti di Altium Parts Provider (che a sua volta si interfaccia con i fornitori abilitati e ne raccoglie i componenti), per consentire al progettista di conoscere i costi e la disponibilità attuali delle parti selezionate presso tutti i venditori che le commercializzano (come definito nel catalogo locale dei componenti del Workspace). Queste informazioni possono essere aggiunte a un componente in qualsiasi momento, anche dopo averlo salvato nel Workspace, senza modificarlo direttamente e quindi senza influire sui progetti in cui è già utilizzato, per poi essere impiegate in una distinta base.
-
Concurrent editing of the library – poiché la libreria del Workspace è essenzialmente un insieme di elementi componente ospitati dal Workspace stesso, più utenti possono modificare o creare nuovi componenti per la libreria in modo indipendente, senza dover attendere che gli altri utenti terminino il proprio lavoro.
-
Component Models Reuse – un componente può essere considerato un «contenitore» in cui vengono memorizzate tutte le informazioni parametriche e i modelli dei vari ambiti, inclusi il simbolo schematico, i footprint PCB e i modelli di cablaggio e simulazione. Un componente non contiene i modelli stessi, ma collegamenti ai relativi elementi modello, anch'essi presenti in un Workspace, in modo che un singolo modello possa essere utilizzato da più componenti. Se un modello cambia, ti verrà suggerito di aggiornare tutti i componenti che lo utilizzano, assicurando così che nessun componente utilizzi un modello obsoleto.
-
Direct Component Editing – se un componente deve essere modificato, puoi aprirlo per la modifica direttamente dal Workspace. Un'istanza temporanea dell'editor dei componenti consente di modificarne ogni aspetto, inclusi i modelli a cui fa riferimento, senza dover gestire alcun documento basato su file.
-
Use of Component Templates – applica modelli basati sui parametri e sulla tassonomia dei componenti, affinché ogni nuovo tipo di componente disponga automaticamente del corretto insieme di parametri conforme alla distinta base, automatizzando inoltre l'applicazione dei corretti schemi di denominazione, revisione e ciclo di vita.
-
Component Lifecycle Validation – se un componente si trova nello stato «fine vita», «obsoleto» o «abbandonato», riceverai un avviso prima di tentare di produrre schede che lo utilizzano.
-
Where-used Component Traceability – i componenti sono tracciabili in tutti i loro utilizzi: se un componente diventa obsoleto, puoi verificare in quali progetti è stato utilizzato per sapere quali devono essere aggiornati. Se un simbolo o un footprint presenta un errore, puoi visualizzare tutti i componenti che lo utilizzano per poterli correggere.
-
Requests of new components – un progettista può inviare richieste di componenti nuovi (o mancanti) ai responsabili delle librerie e ricevere una notifica quando il componente diventa disponibile per l'utilizzo nei progetti, sia per il richiedente sia per gli altri progettisti dell'azienda.
Creazione di un nuovo componente della libreria del Workspace
Il componente fisico che viene montato sulla scheda o utilizzato nella produzione del cablaggio è rappresentato da un simbolo schematico durante la realizzazione dello schema e da un footprint PCB durante la progettazione della scheda (facoltativamente, con un modello 3D per la visualizzazione, il controllo delle distanze in 3D e l'esportazione nell'ambiente CAD meccanico). Un componente di progetto può includere anche un modello di simulazione per il simulatore circuitale e un modello IBIS per l'analisi dell'integrità del segnale. Per rappresentare i componenti di progetto nel più ampio contesto dello sviluppo del prodotto, è possibile aggiungere a ciascuno di essi una o più scelte di parti.
I componenti per il tuo progetto possono essere creati e inseriti nella libreria del Workspace aziendale. Vengono posizionati tramite il pannello Components, che utilizza il motore di ricerca avanzata dei componenti di Altium Designer.
Un nuovo componente della libreria del Workspace viene creato utilizzando l'editor dei componenti, in cui puoi definire manualmente tutti i dati del componente (modelli di dominio, parametri, scelte di parti, ecc.) oppure utilizzare i dati acquisiti dal pannello Manufacturer Part Search.
Per creare un nuovo componente della libreria del Workspace:
-
Seleziona un comando di creazione del componente. Puoi accedervi nei seguenti modi:
-
Seleziona il comando File » New » Component dai menu principali.
-
Seleziona File » New » Library dai menu principali, quindi, nella finestra di dialogo New Library che si apre, seleziona Create Library Content » Component nell'area Workspace della finestra di dialogo.
-
Nel pannello Components, fai clic con il pulsante destro del mouse nell'area dell'elenco dei componenti e seleziona il comando Create dal menu contestuale.
-
-
Nella finestra di dialogo Create new component che si apre, scegli un tipo di componente. Se al tipo di componente selezionato è collegato un template di componente, questo verrà utilizzato per precompilare il componente con i dati che contiene.

Accedi alla finestra di dialogo Create new component per selezionare il tipo di componente da creare. -
Dopo aver fatto clic su OK, si apre l'editor dei componenti in modalità di modifica di un singolo componente. Questa modalità offre un'interfaccia semplificata per la definizione e la modifica di un singolo componente.
-
Definisci il componente aggiungendone i dettagli nell'editor dei componenti:
- Nell'area Component dell'editor dei componenti, definisci Name e Description del componente. Questi dettagli sono essenziali per le successive ricerche dei componenti, quando dovrai utilizzare un componente nel tuo progetto.
-
Fai clic sul controllo Advanced Settings per definire o modificare altri dettagli del componente, come Id utilizzato per il componente salvato nel Workspace e Folder nel Workspace di destinazione in cui verrà salvato il componente.
-
Nell'area Parameters dell'editor dei componenti, definisci ulteriori dettagli del componente: parametri standard, collegamenti URL a pagine web (ad esempio, il sito web di un produttore) e collegamenti alle schede tecniche (in qualsiasi formato).
-
Nell'area Part Choices dell'editor dei componenti, specifica una o più scelte di parti per il componente, ovvero le parti del produttore 'consentite' che possono essere utilizzate per realizzare il componente sulla scheda assemblata.
-
Nell'area Models dell'editor dei componenti, aggiungi collegamenti ai modelli di dominio salvati (o creati al momento) che il componente utilizzerà. Un componente può avere un simbolo schematico e più modelli di footprint PCB e di simulazione, oppure un modello di cablaggio. Un componente deve avere almeno un modello.
-
Verifica il componente definito per assicurarti che soddisfi i requisiti in base alle impostazioni della pagina Data Management – Component Rule Checks della finestra di dialogo Preferences. Salva il componente localmente (File » Save), quindi scegli il comando Tools » Component Rule Check dai menu principali. Le eventuali violazioni rilevate vengono elencate nel pannello Messages.
-
Una volta definito il componente, seleziona il comando File » Save to Server dai menu principali per salvarlo nel Workspace. Verrà visualizzata la finestra di dialogo Edit Revision, in cui puoi modificare il nome e la descrizione e aggiungere note di rilascio, se necessario. L'editor si chiuderà dopo il salvataggio.
Il nuovo componente sarà disponibile per la ricerca e l'utilizzo tramite il pannello Components.
Note
-
Per creare un nuovo componente simile a un componente esistente nel tuo Workspace, puoi creare una copia di quest'ultimo. Nel pannello Components, individua il componente desiderato, fai clic su di esso con il pulsante destro del mouse e seleziona il comando Operations » Make a copy. L'editor dei componenti si aprirà con il componente precompilato con i dati del componente scelto.
-
Un componente può essere definito utilizzando i dati forniti dalla funzionalità di ricerca dei componenti del produttore. Inizia a digitare nel campo Name e seleziona un componente del produttore corrispondente oppure aggiungi una scelta di componente al componente in fase di definizione: si aprirà la finestra di dialogo Usa dati componente, che offre i controlli per selezionare i dati da applicare al componente attualmente in fase di creazione/modifica: nome, descrizione, parametri, modelli e schede tecniche.

I dati del componente possono essere acquisiti tramite la ricerca dei componenti del produttore. Qui è mostrato un esempio di accesso alla funzionalità digitando il nome di un componente nel campo Name e selezionando una voce corrispondente dall'elenco a comparsa. -
L'editor dei componenti può anche operare nella modalità di modifica in batch dei componenti, che fornisce l'interfaccia per definire/modificare più componenti. Quando l'editor dei componenti è in modalità Single Component Editing, è possibile accedere alla modalità di modifica in batch scegliendo il comando Tools » Switch to Batch Editor dai menu principali dell'editor.
-
Per importare rapidamente nel Workspace le librerie esistenti basate su file e database (SchLib, PcbLib, IntLib, DbLib, SVNDbLib), è possibile utilizzare Library Importer. Library Importer offre una soluzione con un solo clic che analizza automaticamente le librerie selezionate e le importa nel Workspace a cui sei attualmente connesso.
-
È possibile creare un nuovo componente anche facendo clic con il pulsante destro del mouse sulla voce del Workspace connesso nel pannello Projects e scegliendo il comando Create Component dal menu.
-
Per modificare un componente del Workspace, fai clic con il pulsante destro del mouse sulla voce di un componente nel pannello Componenti e scegli il comando Edit dal menu contestuale. Si aprirà l'editor dei componenti in modalità Single Component Editing, con la definizione del componente aperta per la modifica. Apporta le modifiche necessarie, quindi salva la definizione del componente nella revisione successiva del componente del Workspace.
-
Allo stesso modo, puoi selezionare più componenti nel pannello Componenti e scegliere il comando Edit dal menu contestuale. Se i componenti selezionati fanno riferimento allo stesso modello di componente, si aprirà una sola istanza dell'editor dei componenti nella modalità di modifica in batch dei componenti. In caso contrario, si aprirà un'istanza separata dell'editor dei componenti per ogni gruppo di componenti che condividono lo stesso modello di componente.
-
I componenti del Workspace aperti per la modifica vengono mostrati sotto la voce Workspace Components nel pannello Projects.
Dal menu contestuale della voce Workspace Component, accessibile con il pulsante destro del mouse, puoi aprire i componenti del gruppo, chiuderli, salvarli localmente, salvarli nel Workspace connesso oppure annullare le modifiche (chiudere senza modifiche)
. Quando si utilizza il comando Close All e sono stati modificati più componenti del gruppo, viene visualizzata una finestra di dialogo di conferma del salvataggio, con opzioni pertinenti alla gestione di un'entità del Workspace aperta per la modifica
-
Se tenti di aprire un componente del Workspace per modificarlo come utente con autorizzazioni di sola visualizzazione, l'editor dei componenti si aprirà consentendoti di accedere ai dettagli del componente, ma senza la possibilità di salvare modifiche nel Workspace. In questo caso, la voce relativa a questo componente del Workspace nel pannello Projects viene mostrata con l'etichetta Local Edits Only
-
Quando salvi un componente modificato nella libreria del Workspace, puoi conservarne lo stato attuale del ciclo di vita. Questa funzionalità è controllata dall'opzione Preserve lifecycle state (not recommended), disponibile nella finestra di dialogo Edit Revision quando si salva nuovamente il componente (mostra immagine). Quando l'opzione è abilitata, alla nuova revisione del componente viene automaticamente assegnato lo stato del ciclo di vita della revisione precedente. Questa funzionalità è disponibile per gli utenti a cui è stata assegnata l'autorizzazione operativa Allow to skip lifecycle state change for new revisions (scopri di più su Impostazione delle autorizzazioni operative globali per un Workspace).
Librerie di database
Altium Designer consente di posizionare componenti direttamente da un database aziendale, creando e utilizzando un Database Library. Il posizionamento viene eseguito dal pannello Components che, dopo l'installazione di una libreria di database, funge da browser per il database.
Dopo il posizionamento, le informazioni sui parametri di progetto possono essere sincronizzate tra i componenti posizionati e i corrispondenti record collegati nel database. È possibile eseguire aggiornamenti completi dei componenti, inclusi il simbolo grafico, i riferimenti ai modelli e i parametri. Le informazioni parametriche del database possono anche essere incluse nella distinta base (BOM) finale, pronta per l'approvvigionamento dei componenti.
Scopri di più sulle librerie di database.
Librerie basate su file
Se devi conservare i componenti localmente, nel file system, puoi organizzarli in librerie basate su file.
Una libreria basata su file di Altium Designer è una raccolta arbitraria di modelli o componenti. Sei tu a decidere come organizzare i modelli o i componenti nelle librerie. Puoi strutturare le librerie in base ai fornitori dei dispositivi oppure raggruppare i componenti per funzione, ad esempio creando una libreria per tutti i microcontrollori utilizzati dalla tua azienda.
I simboli dei componenti dello schema vengono creati nelle librerie schematiche (*.SchLib). I componenti di queste librerie fanno quindi riferimento a footprint e altri modelli definiti in librerie di footprint separate (*.PcbLib) e in file di modello. Come progettista, puoi posizionare i componenti da queste singole librerie di componenti oppure compilare le librerie di simboli, le librerie di footprint e i file di modello in librerie integrate (*.IntLib).
Scopri di più sulle librerie di componenti basate su file.
Modelli
Dal punto di vista del progettista, un componente riunisce in un'unica entità tutte le informazioni necessarie per rappresentarlo in tutti gli ambiti di progettazione. In questo senso, può quindi essere considerato un contenitore.
Ogni componente è una raccolta di modelli collegati e dati parametrici del componente. Sono i modelli a contenere le informazioni dettagliate necessarie per ciascun ambito di progettazione.
È possibile utilizzare i seguenti tipi di modello:
| Simbolo schematico | Il simbolo rappresenta il componente sul foglio dello schema. Il simbolo viene creato utilizzando oggetti di disegno standard, mentre i pin aggiungono le proprietà elettriche. |
| Modello SPICE | Simula il comportamento dei componenti collegati utilizzando il simulatore SPICE. I modelli SPICE vengono solitamente forniti dai fornitori dei dispositivi. |
| Modello di integrità del segnale | Con l'aumento delle velocità di commutazione dei dispositivi e dei circuiti, le interconnessioni del PCB diventano parte integrante del circuito. I modelli IBIS descrivono il comportamento dei pin, consentendo al simulatore di integrità del segnale di Altium Designer di analizzare le piste. |
| Footprint PCB | Per ogni componente è necessario definire sul PCB uno spazio in cui montarlo e collegarlo: il footprint è il modello che definisce tale spazio. Un footprint PCB viene creato da un insieme di oggetti standard, con le piazzole che forniscono la connettività. |
| Modello 3D | I prodotti elettronici di oggi sono compatti, con componenti disposti in spazi molto ridotti, hanno forme insolite e possono includere un PCB ripiegato per adattarsi all'involucro. Per progettare un prodotto di questo tipo, è necessario poter modellare il PCB in 3D, così da visualizzare la scheda finita, verificare le distanze di isolamento in 3D e trasferire la scheda completa di componenti nell'ambiente CAD meccanico. Per farlo, serve un modello 3D di ciascun componente. |
Scopri come creare e gestire simboli, modelli di footprint, modelli di simulazione e modelli 3D nel tuo Workspace.
Il pannello Components
Il pannello Components consente di accedere direttamente a tutti i componenti disponibili in Altium Designer, inclusi quelli del Workspace e delle librerie basate su database e file.
Il pannello attinge ai componenti di un Workspace e di tutti i file di libreria aperti o installati. Offre informazioni complete sul componente selezionato (parametri, modelli, scelte dei componenti, dati dei fornitori, ecc.), il confronto tra componenti e, per i componenti del Workspace, una funzione di ricerca parametrica basata su filtri per specificare i parametri desiderati. Grazie a filtri dinamici contestuali, la funzione di ricerca del pannello consente di individuare rapidamente il componente esatto di cui hai bisogno nel Workspace connesso della tua azienda.
Scopri di più sul pannello Components.
Il pannello Manufacturer Part Search
Puoi anche cercare componenti effettivamente in produzione utilizzando il pannello Manufacturer Part Search, che impiega le funzionalità di base del motore di ricerca e la vista utilizzate nel pannello Components. Un componente del produttore selezionato può essere utilizzato come base per un nuovo componente nel Workspace connesso, oppure i suoi parametri e le sue schede tecniche possono essere aggiunti a un componente già posizionato.
L'icona
nella voce di un componente indica che a tale componente sono assegnati dei modelli (simboli schematici, footprint PCB, modelli di simulazione). Quando si crea un nuovo componente basato su questo componente del produttore, vengono acquisiti anche i relativi modelli. In alternativa, puoi scaricare il componente in locale o posizionarlo direttamente sullo schema elettrico.
Scopri di più sul pannello Manufacturer Part Search.
Come proseguire?
Creazione di un simbolo schematico
Creazione di un componente per il cablaggio di un cablaggio elettrico



).
).



