Preparazione dei report

A colpo d'occhio

Altium Designer offre report per documentare i componenti, monitorare le modifiche al progetto e preparare i dati di produzione. Questo articolo descrive i tipi di report disponibili, spiega come configurarli ed esportarli tramite Report Manager e indica dove generare e salvare gli output. Continua a leggere per scegliere i report necessari e organizzarne gli output per il tuo progetto.

- Esplora i tipi di report, tra cui distinta base, confronto delle distinte base, dati di produzione dei cablaggi, riferimenti incrociati dei componenti, commenti e cronologia del progetto.
- Scopri come configurare i report supportati, visualizzarli in anteprima, stamparli ed esportarli in diversi formati di file.
- Scopri come aggiungere report ai file Output Job o generarli direttamente e come gestire le cartelle di output per evitare di sovrascrivere i report.
Approfondisci con l'IA:

È possibile preparare e generare diversi report relativi al progetto o a uno specifico documento del progetto per il proprio design, tra cui:

  • Distinta base – questo documento di report fornisce un elenco sintetico di tutti i componenti necessari per realizzare il prodotto, inclusa la scheda nuda, che rappresenta essenzialmente il "componente" di base su cui vengono assemblate tutte le altre parti. La distinta base funge da guida per l'approvvigionamento di quanto necessario a realizzare il prodotto così come è stato progettato. Consente inoltre di calcolare i costi in base al numero di schede assemblate richiesto per un determinato ciclo di produzione.

    I dati presentati nella finestra di dialogo Report Manager, utilizzata per configurare il report della distinta base, possono provenire da due fonti. Se al progetto è associato un documento ActiveBOM (*.BomDoc), questo verrà utilizzato come origine dei dati. In caso contrario, i dati verranno estratti dai documenti schematici sorgente del progetto.

  • Confronto delle distinte base – un report che fornisce informazioni sui componenti modificati (ad esempio aggiunti, rimossi o sostituiti) durante il rilascio di un progetto del Workspace.

  • Manufacturing Data – un'unica cartella di lavoro Excel contenente dati destinati ai produttori di cablaggi. La cartella di lavoro generata include quattro fogli distinti:

    • Bill of Materials – utile per generare rapidamente preventivi.

    • Wiring List – da utilizzare con le macchine per la lavorazione dei fili.

    • Labels – un riepilogo delle etichette fisiche da stampare per i fasci di cavi, da utilizzare con stampanti Zebra o di altro tipo.

    • Coverings – un riepilogo dei rivestimenti da applicare ai fasci di cavi.

     

    Si consiglia di utilizzare il documento ActiveBOM del progetto di cablaggio come origine per l'output dei dati di produzione.

    Per ulteriori informazioni sulla progettazione dei cablaggi, consultare la pagina Progettazione dei cablaggi.

  • Report dei riferimenti incrociati dei componenti – crea un elenco di componenti in base al foglio schematico in cui si trovano nel progetto.

    I report della distinta base e dei riferimenti incrociati dei componenti sono altamente configurabili grazie a un potente motore dedicato alla generazione dei report, la cui interfaccia è la finestra di dialogo Report Manager. Una volta definito e organizzato il contenuto del report secondo le proprie esigenze, è possibile generarlo, stampandolo oppure esportandolo in uno dei diversi formati di file disponibili: CSV (delimitato da virgole) (*.csv), foglio di lavoro Microsoft Excel (*.xls;*.xlsx;*.xlt;*.xltx), Portable Document Format (*.pdf), testo delimitato da tabulazioni (*.txt), pagina Web (*.htm;*.html), foglio di calcolo XML (*.xml). Il file esportato può essere salvato in qualsiasi posizione specificata. Inoltre, dopo la creazione, può essere aperto nell'applicazione software pertinente e/o aggiunto al progetto. Utilizzare il comando Report , nei menu della finestra di dialogo Report Manager, per accedere alla finestra di dialogo Report Preview con il report già caricato. Utilizzare i vari controlli della finestra per regolare la visualizzazione del report. Fare clic sul pulsante Print per aprire la finestra di dialogo Print , in cui è possibile stabilire cosa stampare e a quale dispositivo di stampa inviare il lavoro. L'anteprima del report può anche essere esportata in diversi formati di file.

  • Esporta commenti – crea un file PDF contenente i commenti esportati dai documenti del progetto.

  • Cronologia del progetto – crea un file PDF contenente la cronologia del progetto esportata. Configurare l'output utilizzando la finestra di dialogo Project History Report Configuration, in cui è possibile impostare Period per cui esportare il report: l'intera cronologia del progetto oppure un intervallo da/a un rilascio specifico del progetto (o all'ultimo rilascio).

  • Report della gerarchia del progetto – crea un elenco dei documenti sorgente utilizzati nel progetto. Questo output non prevede opzioni di configurazione; il report ASCII viene scritto nella cartella di output specificata.

  • Report delle net con un solo pin – crea un report che elenca tutte le net con una sola connessione. Questo output non prevede opzioni di configurazione; il report ASCII viene scritto nella cartella di output specificata. Un report che elenca tutti i documenti schematici sorgente del progetto in base alla loro gerarchia all'interno del progetto. Il file viene generato direttamente ed è nel formato <ActiveDocumentName>.REP.

Gli output dei report possono essere aggiunti al file Output Job attivo dal menu del controllo [Add New Report Output] nell'area Report Outputs del file oppure dai sottomenu Edit » Add Report Outputs dei menu principali.

Sebbene i file OutputJob semplifichino la preparazione degli output dei progetti e la loro successiva generazione mediante il processo di rilascio del progetto ad alta integrità, gli output dei report per il progetto attivo possono anche essere generati direttamente utilizzando il comando del menu principale Reports  dell'editor degli schemi oppure del sottomenu Reports » Project Reports dell'editor PCB.
  • Poiché la finestra di dialogo Report Manager è altamente configurabile, può anche essere utilizzata per generare report in qualsiasi formato necessario, ad esempio un file pick and place i cui dati devono essere strutturati in modo specifico per adattarsi a una determinata macchina di posizionamento.
  • Tutti i file di output verranno scritti nella cartella di output specificata nel campo Output Path, nella scheda Options della finestra di dialogo Options for Project. Per impostazione predefinita, il percorso di output corrisponde a una sottocartella della cartella che contiene il file di progetto e ha il nome Project Outputs for <ProjectName>. Il percorso di output può essere modificato secondo le esigenze. Nel pannello Projects, i file generati verranno visualizzati nelle sottocartelle Generated\Text Documents (.csv, .txt, .rep) oppure Generated\Documents (.xls, .pdf, .htm, .xml). Tenere presente che, se si genera un report in un formato diverso dallo stesso documento attivo, il file del report generato in precedenza verrà sovrascritto (se ha lo stesso nome).
  • Se l'opzione Use separate folder for each output type è abilitata (anch'essa nella scheda Options ), l'output verrà scritto in un'ulteriore sottocartella denominata Reports (ad esempio Project Outputs for <ProjectName>\Reports). Nel pannello Projects , l'output verrà visualizzato nelle sottocartelle Generated (Reports)\Text Documents (.csv, .txt, .rep) oppure Generated (Reports)\Documents (.xls, .pdf, .htm, .xml). Questo consente di generare più report dallo stesso documento attivo senza sovrascrivere alcun file.
AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.