Preparazione di un file PDF 3D

A colpo d'occhio

Condividi una vista 3D interattiva del tuo progetto PCB con produttori, aziende di assemblaggio e clienti grazie alla funzionalità di esportazione PDF3D di Altium Designer. Questo articolo spiega come generare un PDF 3D, configurarne i contenuti e l’aspetto ed esplorare la scheda esportata in Adobe Acrobat Reader. Continua a leggere per preparare un PDF 3D su misura per ciò che il tuo pubblico ha bisogno di vedere.

- Scopri come accedere all’esportazione PDF3D e configurare geometria, combinazioni di colori, viste iniziali ed eventuali viste Key Frame salvate.
- Comprendi come i contenuti del progetto inclusi influiscono sulle dimensioni del file e sulle prestazioni di visualizzazione.
- Scopri come la barra degli strumenti 3D e l’albero del modello di Acrobat Reader consentono di navigare, evidenziare e controllare la visibilità di componenti e reti.
Approfondisci con l'IA:

Gli utenti di Altium Designer possono da tempo visualizzare in modo interattivo i progetti PCB in 3D con rendering completo, ottenendo una visione unica della struttura reale della scheda, dei suoi componenti e delle parti meccaniche associate.

Offrire questa funzionalità 3D anche a chi non fa parte del team di progettazione, come i produttori e gli assemblatori e, non da ultimo, i clienti, comporta vantaggi significativi. Ciò è possibile grazie alla funzionalità di esportazione in PDF 3D di Altium Designer. Questo formato 3D interattivo è accessibile a chiunque disponga di una versione recente del diffusissimo Adobe® Acrobat® Reader.

Visualizza in modo interattivo un progetto 3D esportato in Adobe Reader: ingrandisci, ruota e seleziona gli elementi del progetto che desideri vedere.
Visualizza in modo interattivo un progetto 3D esportato in Adobe Reader: ingrandisci, ruota e seleziona gli elementi del progetto che desideri vedere.

A differenza di una vista fissa del progetto 3D di una scheda, che offre una specifica prospettiva angolare, il formato PDF 3D esportato è concettualmente equivalente alla 3D Layout Mode interattiva di Altium Designer. Il PDF 3D esportato offre quindi le stesse funzionalità di rotazione, zoom e panoramica, oltre a segnalibri per ogni componente e net, e può utilizzare uno dei diversi schemi di colori predefiniti.

Per accedere alla funzionalità di esportazione in PDF 3D in Altium Designer, è necessario installare l'estensione software PDF3D Exporter. Questa estensione viene installata per impostazione predefinita con Altium Designer. Può essere installata o rimossa manualmente.

Per ulteriori informazioni sulla gestione delle estensioni, consulta la pagina Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Il 3D in Acrobat Reader

La visualizzazione 3D interattiva dei file PDF è diventata possibile con l'introduzione delle funzionalità avanzate di visualizzazione 3D in Acrobat Reader, a partire dalla versione 7. Il livello elevato di dettaglio e le opzioni di configurazione offerti dall'esportazione in PDF 3D di Altium Designer sono compatibili con le versioni 9 e successive di Acrobat Reader, nelle quali queste funzionalità sono state progressivamente migliorate.

Alla base di questa nuova funzionalità 3D vi è il formato Universal 3D (U3D) per i file di grafica computerizzata, sviluppato dall'industria e standardizzato dalla European Computer Manufacturers Association (ECMA) come Standard ECMA-363 - Formato di file Universal 3D. U3D è supportato nativamente dal formato PDF e può essere facilmente incorporato (e compresso) in un file PDF per la visualizzazione 3D interattiva in Acrobat Reader.

Il risultato è un formato di file 3D multipiattaforma di dimensioni contenute, che non richiede software specializzati per la visualizzazione 3D. Nel caso dei file PDF 3D esportati da Altium Designer, il contenuto incorporato comprende la maggior parte dei dati visualizzabili nella vista 3D di Altium Designer, tra cui tutte le piste, le piazzole, le via, i poligoni, ecc., tutti i componenti e l'intero insieme degli strati della scheda.

Generazione di un PDF

Per esportare un file PDF 3D, apri il documento del progetto PCB desiderato nell'area di progettazione e scegli il comando File » Export » PDF3D dai menu principali (il file PDF 3D verrà creato in formato 3D, indipendentemente dalla modalità di visualizzazione corrente dell'editor PCB, 2D o 3D).

A differenza di una vista fissa del progetto 3D di una scheda, ripresa da una specifica prospettiva angolare, la nuova esportazione in PDF 3D è concettualmente equivalente alla vista 3D interattiva di Altium Designer.

Il PDF 3D esportato offre quindi le stesse funzionalità di rotazione, zoom e panoramica e può utilizzare qualsiasi schema di colori definito dalla configurazione di visualizzazione attiva. Per esaminare o modificare la configurazione corrente, e quindi i colori di rendering disponibili per il PDF esportato, passa alla visualizzazione 3D della scheda (scorciatoia da tastiera: 3) e apri il pannello View Configuration. I colori di rendering sono visibili nella sezione 3D Settings, nella scheda View Options del pannello.

È possibile accedere rapidamente alla scheda View Options del pannello View Configuration utilizzando la scorciatoia da tastiera Ctrl+D.

Il file PDF 3D verrà creato in formato 3D, indipendentemente dalla modalità di visualizzazione corrente dell'editor PCB (2D o 3D).

Opzioni di esportazione

Dopo aver avviato l'esportazione in PDF 3D (File » Export » PDF3D) e specificato il nome e il percorso del file di destinazione nella finestra di dialogo standard di Windows Export File, si apre la finestra di dialogo Export 3D, che consente di definire il rendering, il comportamento e i contenuti del progetto da includere nel PDF.

La finestra di dialogo Export 3D consente di configurare l'aspetto e il comportamento del PDF esportato.
La finestra di dialogo Export 3D consente di configurare l'aspetto e il comportamento del PDF esportato.

Utilizzare la finestra di dialogo Export 3D per configurare le opzioni di esportazione secondo le proprie esigenze, quindi fare clic sul pulsante Export per generare il file PDF 3D.

I file 3D possono essere di grandi dimensioni, anche con la compressione dei dati intrinseca al formato, quindi è opportuno valutare quali contenuti del progetto siano importanti per l'utente destinatario. Ad esempio, il contenuto dei layer di rame (piste, piazzole, ecc.) potrebbe non essere necessario per chi esamina gli aspetti meccanici del progetto di una scheda.

  • Si noti che Acrobat Reader consente agli utenti di attivare o disattivare la visualizzazione degli elementi del modello (in gruppi o singolarmente) in base alle proprie esigenze; vedere di seguito.

  • I fotogrammi chiave definiti in un documento PCB possono essere integrati nell'esportazione PDF 3D selezionando l'opzione Use 3D Movie views nella finestra di dialogo Export 3D. I fotogrammi chiave esportati nel documento PDF 3D saranno quindi disponibili come viste selezionabili in Acrobat Reader.

Quando si scelgono i contenuti 3D da includere, è opportuno considerare anche le capacità di rendering 3D del PC di chi visualizzerà il file. Anche se le dimensioni del file PDF 3D risultante possono essere ragionevoli, la CPU e il sistema grafico del computer di destinazione potrebbero avere difficoltà a eseguire in modo fluido il rendering di un progetto multistrato complesso.

Le opzioni descritte sopra definiscono le impostazioni iniziali all'apertura del PDF in Acrobat Reader e possono essere facilmente modificate secondo le proprie preferenze dalla barra degli strumenti 3D del lettore. Si noti che, se la barra degli strumenti è disabilitata nelle opzioni di esportazione PDF 3D, l'utente non potrà modificare la vista.

Visualizzazione di un PDF 3D

Come si può immaginare, visualizzare un PDF 3D in Acrobat Reader è piuttosto semplice, con comandi e menu che sono estensioni logiche delle consuete funzioni 2D.

È possibile eseguire panoramiche, ingrandimenti e rotazioni degli oggetti 3D con semplici operazioni di trascinamento del mouse e con la rotellina di scorrimento, selezionando le funzioni dalla barra degli strumenti mobile 3D.

La barra degli strumenti 3D di Acrobat offre controlli per la navigazione 3D e le impostazioni di illuminazione e visualizzazione.
La barra degli strumenti 3D di Acrobat offre controlli per la navigazione 3D e le impostazioni di illuminazione e visualizzazione.

Una funzione particolarmente utile del lettore è il riquadro di navigazione Model Tree, che può essere aperto (se non lo è già) con il pulsante . Consente all'utente di esplorare tutti gli oggetti del PDF 3D, selezionare ed evidenziare quelli di interesse e attivarne o disattivarne la visibilità.


Il riquadro di navigazione Albero modello è particolarmente utile
per controllare la visualizzazione di componenti e reti specifici.

Il riquadro di navigazione Model Tree offre un potente strumento per esaminare tutti gli aspetti di un progetto 3D con un elevato livello di dettaglio. Che si tratti di esaminare da vicino il posizionamento e la disposizione dei componenti o di ispezionare in dettaglio la struttura interna della scheda, l'albero di navigazione può essere utilizzato per trovare e visualizzare gli oggetti desiderati.

Il progetto visualizzato con i componenti e i layer serigrafici della scheda deselezionati, a dimostrazione del livello di controllo 3D disponibile in Acrobat Reader.
Il progetto visualizzato con i componenti e i layer serigrafici della scheda deselezionati, a dimostrazione del livello di controllo 3D disponibile in Acrobat Reader.

Quando vengono selezionati nel riquadro Model Tree, i singoli oggetti sono evidenziati nella finestra di visualizzazione con il colore definito nella parte superiore del riquadro (in questo caso, rosso). Ciò semplifica l'individuazione di un particolare componente o di una rete ed evita di dover attivare o disattivare la visibilità di un oggetto per trovarne la posizione. Analogamente, selezionando un oggetto nella finestra della vista 3D, viene evidenziata la voce corrispondente nel riquadro Model Tree.

Per ulteriori informazioni sull'uso dei vari controlli, delle funzioni e delle impostazioni di Acrobat Reader, consultare il relativo contenuto della guida Adobe: Visualizzazione di modelli 3D nei PDF.

Un documento PDF 3D esportato include anche i metadati di base del progetto provenienti da Altium Designer. I dati includono il file sorgente del progetto, il suo autore, la versione di Altium Designer, le date di creazione e modifica, ecc. Le informazioni possono essere visualizzate in Adobe Reader nella scheda Description della finestra di dialogo Document Properties – File » Properties.

Esportazione di PDF 3D tramite OutJob

Per includere l'esportazione di un file PDF 3D in un OutJob di progetto, fare clic su Add New Documentation Output sotto la voce Documentation Outputs, selezionare PDF3D quindi selezionare il documento sorgente desiderato: un documento PCB specifico da esportare (oppure [PCB Document] per mantenere l'OutJob riutilizzabile in modo generico).

Aggiunta di un generatore di output PDF3D a un file di configurazione dei job di output.Aggiunta di un generatore di output PDF3D a un file di configurazione dei job di output.

Le impostazioni di generazione del PDF 3D possono essere preconfigurate selezionando la voce del generatore di output, facendo clic con il pulsante destro del mouse e scegliendo Configure dal menu contestuale. Si apre così la finestra di dialogo di configurazione Export 3D (come descritto in precedenza).

Quando il job di output viene eseguito o avviato manualmente, il file PDF 3D viene esportato come definito nella sezione Output Containers dell'OutJob. La destinazione è il Workspace e il percorso configurati, oppure la destinazione di pubblicazione locale o remota definita nella pagina Gestione dati – Destinazioni di pubblicazione della finestra di dialogo Preferences.

Generazione di un file PDF 3D in un contenitore di output PDF definito, da un OutJob configurato.
Generazione di un file PDF 3D in un contenitore di output PDF definito, da un OutJob configurato.

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents