アイテムの参照
Altium Essentials: Workspace Folder Structure
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Workspace内のコンテンツには、いくつかの方法でアクセスできます。
- ExplorerパネルのServer Folders領域で、内容を確認したいフォルダーをクリックします。
- パネル上部のアドレスバーを使用します。アドレスバーには、現在参照しているフォルダーと、そのフォルダーまでの階層パスが表示されます。
-
Workspaceの検索機能を使用します。コメントや説明に基づくキーワードを入力し、Enterを押すか、虫眼鏡アイコンをクリックします。Workspace全体が検索され、一致するアイテムが検索結果として一覧表示されます。
選択したフォルダーの内容は、パネルのアイテム領域に表示されます。
アイテム領域のコマンド
-
Place – 現在選択されているアイテムリビジョンのインスタンスを、配置がサポートされている場所に配置します。たとえば、アクティブな回路図シートにコンポーネントや管理対象シートを配置できます。コンポーネントのシンボルまたは管理対象シートのシンボルがカーソルに追従して表示され、配置できる状態になります。
-
Edit – コンポーネント、管理対象シート、テンプレートなどのアイテムを、対応するエディターで開きます。編集後は、アイテムの新しいリビジョンとしてWorkspaceに保存されます。
-
Upload – 新規リビジョンの作成ダイアログを使用して、アイテムを構成するオブジェクトをアップロードします。たとえば、管理対象回路図シートに回路図ドキュメントを、出力ジョブテンプレートにOutJobファイルをアップロードできます。
-
Operations – 以下のコマンドを含むサブメニューにアクセスします。
-
Add to Content Cart – コンテンツカートダイアログを使用して、現在選択されているアイテムをコンテンツカートに追加します。
-
Download – Browse for Folderダイアログを使用して、現在選択されているアイテムをダウンロードし、別の場所に保存します。
-
Change state – 一括状態変更ダイアログを開き、現在選択されているアイテムリビジョンの状態を変更します。
-
Make a copy – 現在選択されているアイテムリビジョンをコピーします。コピーされたアイテムは、対応するエディターで編集用に開かれます。たとえば、コンポーネントを複製すると、コンポーネントエディターで開かれます。
-
Change component type – Choose component typeダイアログにアクセスし、選択したコンポーネントの
ComponentTypeパラメーターを別のタイプに設定します。 -
Export Grid – データエクスポート用の列を選択ダイアログを開き、エクスポートする列データを指定します。エクスポートされるセミコロン区切りのCSVファイルには、現在のリストのグリッドビューにあるすべてのアイテムのデータが含まれます。
-
-
Create Item – 現在のフォルダーに対応するタイプ(コンポーネント、テンプレート、管理対象回路図シートなど)の新しいコンテンツアイテムを追加し、対応するエディターで開きます。別のタイプのアイテムを作成するには、Other Item Typeサブオプションを選択し、新規アイテムの作成ダイアログのContent Typeメニューから別のタイプを選択します。
-
Delete Item – アイテムを削除します。
-
History – 現在選択されているアイテムの詳細ビューにアクセスし、ソフトウェア内の新しいタブとして開きます。アイテムビューには、特定のアイテムのリビジョン履歴とライフサイクル履歴が詳細に表示され、そのアイテムを構成するすべての要素も表示されます。このビューにはタイムラインも含まれます。タイムラインを使用すると、アイテムのリビジョンレベルまたはライフサイクル状態が変更された正確な日時と、変更したユーザーを確認できます。
-
Properties – View Item Propertiesダイアログにアクセスし、現在選択されているアイテムのプロパティを表示します。そのアイテムのリビジョンがまだリリースされていない場合は、プロパティを変更できます。
-
Navigate To <item> – Item ID列から、選択したアイテムのプレビューをExplorerパネルで開きます。
Workspace内の各アイテムリビジョンについて、Explorerパネルでは、該当するリビジョンのさまざまな情報を参照できます。パネル下部のタブを使用して、そのリビジョンの1つ以上のビューを切り替えます。
デフォルトのビューはPreviewです。その他のタブをクリックすると、さらに詳しい情報を表示できます(使用できるタブは、現在選択されているアイテムのタイプによって異なります)。
-
Preview – 選択したアイテムの情報をまとめて表示します。これには、ドキュメントやモデルのグラフィカルな表示、パラメーターデータ、関連するサブアイテムなどが含まれます。ビューはアイテムのタイプに応じて自動的に設定され、コンポーネントとプロジェクトについては、クラシックビューモードと解釈ビューモード(上記参照)のどちらが選択されているかによっても設定されます。
-
Lifecycle – アイテムのリビジョンレベルとライフサイクルの状態変更を確認します。ライフサイクルは、そのアイテムタイプに割り当てられた状態に沿って進めることができます。たとえば、コンポーネントにはコンポーネントのライフサイクル状態(
Draft、Prototypeなど)が適用されます。 -
Children – アイテムの構成要素を表示します。たとえば、リリースされたプロジェクトの製造パッケージ(
FAB-<project name>)に含まれる生成済みの製造ドキュメント(Gerber、NC Drillなど)や、管理対象回路図シートで使用される回路図ドキュメントとコンポーネントを表示できます。 -
Part Choices – コンポーネントに割り当てられた部品候補(サプライヤーデータが関連付けられたメーカー部品エントリ)を表示または追加します。
-
Where-used – 選択したアイテムリビジョンが、他のWorkspaceアイテムで使用されている場所を表示します。たとえば、現在選択されているコンポーネントを使用するプロジェクトなどです。
-
Origin – アイテムの取得元を表示します。たとえば、Altiumのクラウドリソースから取得したコンポーネントなどです。可能な場合は、取得元アイテムの詳細情報がすべて表示されます。
-
Data Sheet – 選択したコンポーネントとともに保存されているファイル形式のデータシートを表示または追加します。

関連するビューを使用して、アイテムリビジョンのさまざまな側面を参照できます。
クリック可能なURL
Workspaceの使いやすさをさらに高めるため、Explorerパネルはクリック可能なURLに対応しています。この機能は、以下を含むさまざまな関連箇所で利用できます。
- URLを値として持つコンポーネント パラメーターをクリックすると、外部のWebブラウザーでリンク先のページが開きます。
- コンポーネントのサプライチェーンデータ内のURLをクリックすると、外部のWebブラウザーでリンク先のページが開きます。
- PCB製造データアイテム、PCB実装データアイテム、またはPCBプロジェクト設計アイテムのリビジョンのPreviewアスペクトビュータブにあるReleased Documents領域でドキュメントをクリックすると、そのドキュメントが開きます。
クリック可能なサプライチェーンのURL
Workspace内の各リリース済みコンポーネントには、部品候補の形式でサプライチェーンデータを定義できます。これらはPart Choicesアスペクトビュータブに表示されます。実際のサプライチェーン情報は、WorkspaceのローカルのPart Catalogと、対応する部品ソースから取得されます。部品ソースは、Altium Parts Providerの統合部品データベース(有効化されたサプライヤーと連携し、そこから部品情報を収集します)、またはリンクされたローカル部品データベース(カスタムデータベース部品プロバイダーとして構成された部品ソースで、使用しているWorkspaceの種類が対応している場合)のいずれかです。各部品候補に関連付けられているクリック可能なURLは、以下のとおりです。
- メーカー名とメーカー部品番号 – 該当するメーカー部品の詳細情報を提供する、メーカーサイトへのクリック可能なリンクです。
- サプライヤー部品番号(SPNタイル内) – サプライヤーサイト上の該当部品へのクリック可能なリンクです。
URLをクリックすると、外部ブラウザーで開きます。
クリック可能なリリース済みドキュメントのURL
基板設計プロジェクトをリリースすると、製造済みのベアボード(PCB製造データアイテム)または実装済み基板(PCB実装データアイテム)のいずれの場合も、その設計の任意のドキュメントを開くことができます。まず、対象プロジェクトのフォルダーがクラシックビューで表示されていることを確認します(Explorerパネルの右上にある
ボタンをクリックし、コンテキストメニューから Classic Viewコマンドを選択します)。該当するアイテムリビジョンに移動し、そのリビジョンのPreviewアスペクトビュータブに切り替えます。次に、Released Documents領域で生成された出力ドキュメントにカーソルを合わせると、URLと同様にカーソルが手の形に変わります。これらのURLをクリックすると、そのドキュメントが開きます。Altium Designerのネイティブドキュメントは、Altium Designer内で直接開かれ、閲覧できます。 出力PDFファイルやExcel形式のBOMなど、Altium Designerのネイティブ形式ではないドキュメントは、対応するソフトウェアアプリケーションで直接開かれます(そのアプリケーションがインストールされている場合)。

クリックすると、リリース済みドキュメントが開きます。Altium Designerのネイティブ形式ではないドキュメントは、それぞれに対応するアプリケーションで開かれます(利用可能な場合)。
リビジョンの表示
アイコンをクリックしてリビジョン選択用のドロップダウンを開くと、パネルに表示するリビジョンを設定できます。
- Load all pages – すべてのリビジョンを読み込むには、これを選択します。
- Show Hidden Revisions – 非表示のリビジョンを表示するには、これを選択します。
- Show only latest – 最新のリビジョンのみを表示するには、これを選択します。
- View – アイテムをClassic Viewで表示するか、専用ビュー(Components View/Project View)で表示するかを選択します。
フォルダー内容の読み込み
ExplorerパネルのServer Folders構造領域にあるフォルダーをクリックすると、適用可能な場合、そのフォルダーの内容は最初に一部のみが読み込まれます。これにより、フォルダーの初回読み込み時間が大幅に短縮されます。最初に読み込まれた内容の末尾までスクロールすると、フォルダーの内容が追加で読み込まれます。
非表示のリビジョンの表示
Related page: Workspaceのライフサイクル定義の設定 – アイテムリビジョンの表示と適用可否の制御
アイテムリビジョンが、Visible in Vault panels属性が無効になっているライフサイクル状態に移行すると、そのリビジョンはデフォルトではExplorerパネルに表示されなくなります。また、それがアイテムの最新リビジョンである場合、そのアイテムのエントリ全体が実質的に非表示になります。状態レベルで定義されるこの表示設定は、すべてのアイテムに対して一括で上書きできます。
現在非表示になっているすべてのアイテムリビジョンを表示するには、パネルのItems領域の右上にある
コントロールをクリックし、表示されるメニューでShow Hidden Revisionsオプションを有効にします。

Explorerパネルでコンテンツを参照しながら、非表示のアイテムリビジョンを表示します。画像にマウスポインターを合わせると、結果を確認できます。
最新のアイテムリビジョンのみの表示
Workspace内のコンテンツは、時間とともに更新されることがあり、変更のたびに、変更されたデータを格納する新しいリビジョンが作成されます。アイテムを参照する際、通常必要なのは最新のリビジョンのみです。過去のリビジョンは余分な情報となり、設計者の画面を煩雑にしがちです。これを軽減するため、Explorerパネルでは、デフォルトでアイテムの最新リビジョンのみが表示されます。
Explorerパネルでアイテムのすべてのリビジョンを表示するには、パネルのItems領域の右上にある
コントロールをクリックし、表示されるメニューでShow only latestオプションを無効にします。

デフォルトでは、Explorerパネルにはアイテムの最新リビジョンのみが表示されます。画像にマウスポインターを合わせると、このコマンドを無効にした例を確認できます。
専用ビュー
このパネルには、コンポーネントとプロジェクトに適用される2種類の特別な専用ビューも用意されています。パネルの表示オプションがClassic Viewモードに変更されていない限り、コンポーネントまたはプロジェクトを選択すると、自動的にこの表示形式に切り替わります。
これらの特別なアイテムタイプのいずれかを選択すると、表示メニューからクラシックビューまたは専用ビュー(Component View / Project View)のオプションを選択できます。
- Classic View – アイテムとそのリビジョンのみを表示するには、これを選択します。
- Components View – リビジョンと、表示用に整理されたコンポーネントデータを表示するには、これを選択します。詳細は、コンポーネントビューを参照してください。
- Project View – プロジェクトリリースデータやプロジェクトパラメーターへのアクセスを含む、プロジェクトの構造をグラフィカルに表示するには、これを選択します。詳細は、プロジェクトビューを参照してください。
アイテムリビジョンの比較
Workspaceでは、Altium Designerのネイティブファイル形式比較技術を活用し、サポートされているさまざまなコンテンツタイプについて、同じアイテムまたは異なるアイテムの2つのリビジョンを、Explorerパネルから直接、視覚的に比較できます。次のコンテンツタイプのアイテムリビジョンを比較できます。
- コンポーネントアイテム
- シンボルアイテム
- フットプリントアイテム
- 管理対象回路図シートアイテム
- 回路図テンプレートアイテム
- PCB製造データアイテム
- PCB実装データアイテム
- PCBプロジェクト設計アイテム
Explorerパネルで該当するフォルダーに移動し、比較する2つのアイテムリビジョンを選択してから、右クリックしてコンテキストメニューのOperations » Compareを選択します。
2つのコンポーネントアイテムリビジョンの比較
2つのコンポーネントアイテムリビジョンを比較する際、Compareをクリックすると、次の処理が順に実行されます。
- 参照されているフットプリントアイテムのリビジョンが比較されます。
- 参照されているシンボルアイテムのリビジョンが比較されます。
- 2つのコンポーネントアイテムリビジョンのパラメトリックデータが比較されます。
比較結果はCompare component revisionsダイアログに表示されます。
このダイアログは3つのセクションに分かれており、パラメトリックデータ、フットプリント、シンボルの比較結果が表示されます。パラメーターの値が一致しない場合は、赤みがかった背景で強調表示されます。フットプリントとシンボルについては、一致または不一致と表示されます。
シンボルアイテムの2つのリビジョンの比較
シンボルアイテムの2つのリビジョンを比較する場合、Compareをクリックするとグラフィカルな比較が実行され、検出された差異が差異パネルに一覧表示されます。2つのリビジョンのSchLibドキュメントが設計スペース内で開かれます。設計エディターのウィンドウに並べて表示することで、差異を視覚的に確認できます。検出された差異の最上位フォルダーをクリックすると、両方のドキュメントでその差異が同時にハイライトされます。
フットプリントアイテムの2つのリビジョンの比較
フットプリントアイテムの2つのリビジョンを比較する場合、Compareをクリックするとグラフィカルな比較が実行され、検出された差異がCompare Componentsダイアログに一覧表示されます。

フットプリントの2つのリビジョンの比較例。ソースライブラリは設計スペース内で開かれません。ここでは、実際に存在する差異を示すためにフットプリントのプレビューを掲載しています。
フットプリントは正方形のセルに分割され、各セルの差異が解析されます。差異が存在するセルはフルカラーで表示され、差異がハイライトされます。レイヤータブには、比較対象の各レイヤーで差異のあるプリミティブオブジェクトの数が表示されます。タブをクリックすると、差異をより詳しく確認できます。
グリッドデータのエクスポート
Explorerパネルでは、グリッドビューのデータをcsv形式またはxls形式のファイルにエクスポートできます。この機能を利用できる場所には、以下のようなものがあります。
- コンポーネントアイテムのグリッド(クラシックビューとコンポーネントビューの両方)。
- アイテムのグリッド。
- Preview詳細ビュータブのリンクされたモデルのグリッド(選択したコンポーネントアイテムが対象)。
- 検索結果のグリッド。
- Where-used詳細ビュータブのアイテムのグリッド。
- Children詳細ビュータブのアイテムのグリッド。
グリッド内で右クリックし、コンテキストメニューからOperations » Export Gridコマンドを選択します。Select columns for data exportダイアログが表示されます。列リストのチェックボックスを使用するか、 Select All / Deselect All ボタンをクリックして、エクスポートするデータを有効または無効にします。 このダイアログには、グリッドで使用可能なすべての列が表示されます。現在パネルに表示されている列は、デフォルトでエクスポート対象として有効になっています。OKをクリックすると、Windows標準のSave Asダイアログが表示されます。このダイアログで、エクスポートするファイルの保存先とファイル名を指定します。Save as typeフィールドで、ファイル形式をカンマ区切り値ファイル(*.csv)またはExcelファイル(*.xls)から選択します。

データをExcel形式のファイルにエクスポートする例。ここでは、選択したコンポーネントアイテムのリビジョンにリンクされたモデルをエクスポートしています。
プロジェクトビュー
パネルで解釈・表示されるProject Viewでは、選択したプロジェクトがプロセスを中心としたビューで表示され、関連するプロジェクトデータとそのリリースに直接アクセスできます。
Project Viewには、プロジェクトのプレビュー、基本的な説明、パラメーター、およびリリースが表示されます。
Releases領域には、選択したプロジェクトに関連するプロジェクトリリースが一覧表示され、各リリースとそれを構成するパッケージの概要が含まれます。この領域の
ボタンをクリックすると、状態の一括変更ダイアログが開きます。このダイアログでは、同じリリースに関連する複数のアイテムのライフサイクル状態を、1回のバッチ処理でまとめて変更できます。
プロジェクトビューの右上には、以下のコントロールがあります。
- Open – 対象のプロジェクトをAltium Designerで開きます。
- Open in Web – Workspaceのブラウザーベースのインターフェースでプロジェクトを開きます。
- Share – 共有ダイアログを開きます。このダイアログでは、ソフトウェア内から直接、世界中のユーザーと設計プロジェクトを共有できます。
-
– このボタンをクリックすると、以下のコマンドにアクセスできます。
-
コピーを作成 – Create Project Copyダイアログを開き、プロジェクトをコピーして、接続先のWorkspaceに保存します。デフォルトでは、元のプロジェクト名に接尾辞
' - Copy'が付加されます。 - History – プロジェクトのCAD中心の詳細管理ページから、そのプロジェクトの履歴ビューを開きます。
- Delete – プロジェクト、そのフォルダー、およびプロジェクトのすべてのコンテンツを削除します。削除が完了する前に、確認を求められます。
-
コピーを作成 – Create Project Copyダイアログを開き、プロジェクトをコピーして、接続先のWorkspaceに保存します。デフォルトでは、元のプロジェクト名に接尾辞










