Altium Designer Documentation

Browsing Open Content through the Projects Panel in Altium Designer

Created: December 6, 2021 | Updated: June 17, 2022

Parent page: Working with Panels

The Projects panel
The Projects panel

Summary

The Projects panel displays all projects that are currently open. Any open documents that have not been created as part of a project or added to an existing open project will be listed.

Panel Access

The Projects panel is accessed in the following ways:

  • Choose View » Panels » Projects from the main menus.
  • Click the Panels button at the bottom right of the design space then click Projects.
Panels can be configured to be floating in the editor space or docked to the sides of the screen.

Projects within the Projects Panel

Altium Designer also supports the concept of projects that are stored entirely within a connected Workspace. Projects can be created as, or converted to, Workspace projects that are hosted in a secure version-controlled repository within the Workspace. This approach greatly simplifies the process of managing project storage, versioning, lifecycle, and implementing design collaboration. Projects will be stored in the Projects panel under the Workspace they are hosted on, rather than the Project Group, as local projects are. When connected to a Workspace, the Workspace icon (/). When the local working copy of a project is opened but the Workspace where the project resides is not connected, a grayed-out Workspace icon (/) will appear.

An example of a project within a Workspace in the Projects panel.
An example of a project within a Workspace in the Projects panel.

Shared Project Icons

This icon appears next to the .PrjPcb document file while connected to the Workspace in which the shared project resides.
This icon appears next to the .PrjPcb document file when not connected to the Workspace in which the shared project resides.

To access the context menu regarding your Workspace, right-click on your Workspace name or click the  control at its far right. These commands include:

  • Open Project – opens the Open Project dialog.
  • Create Project – opens the Create Project dialog.
  • Show in Explorer – opens the Explorer panel.
  • Show in Web Browser – opens the Projects page of the Workspace's browser interface in your default Web Browser.
  • Sign out – signs you out of the Workspace.
You must be connected to a Workspace to access these commands.

When signed out of a Workspace, right-click the Workspace you want to connect to, and click the Sign In command.

► To learn more about Workspace projects, visit the Design Management with a Connected Workspace page.

Project Documents Tree

When you open an existing project or create a new one, its entry will appear in the Projects panel. Any existing documents that are part of a project (and any new ones that have been added) will appear under sub-folders according to their purpose and/or type. For example, the following common folders and content document types can appear under a project:

  • Source Documents – core design documents such as schematics, PCBs, etc.
  • Settings – provides various files used within the project, including Output Job Files, Harness Definitions Files, and Annotation Documents, among other pertinent files.
  • Libraries – local source library documents. Documents are further sub-divided based on library type (e.g., schematic libraries, PCB libraries, etc.).
  • Documentation – additional documents that have been added to the project, of a type that is known by Altium Designer (e.g., text, PDF, etc.).
  • Other Documents – additional documents that have been added to the project, of a type that is not known by Altium Designer. These can be opened by Altium Designer if the owner application is known by Windows (eg, Word documents, Excel spreadsheets, etc).
  • Generated – documents generated as output. Documents are further sub-divided based on type (e.g., BOM documents, text documents, etc.). As project output is generated, the corresponding sub-folders in the main tree will be created and become populated.
  • Components – this folder lists each component (grouped by the first letter in the designator), and the number of components whose designator starts with that letter in the project. Validate the project if this folder does not appear (Project menu).
  • Nets – this folder lists each net used in the project. Validate the project if this folder does not appear (Project menu).
To manage the visibility of the Components and Nets folders, use the Show Components and Nets folders option in the General section of the Settings pop-up (appears when the  icon is clicked at the top of the panel).
Documents that are stored in the project folder or a sub-folder of the project folder are associated in the project file using relative referencing. Documents that are stored in a different folder path are associated in the project file using absolute referencing. These documents include a small arrow in the bottom corner to indicate that they are linked to the project, as shown by the file in the image above.

Working in the Documents Tree

  • Any documents that are independent of a project will appear as Free Documents and will appear under corresponding sub-folders. By right-clicking on a free document and choosing the Add to Project <ActiveProjectName> command from the context menu, you can add a currently open free document to the active project. Alternatively, you can drag and drop it onto the required project name, in the Projects panel.
  • Along with allowing multiple documents to be open for editing, the environment also supports multiple projects being open at the same time. These could be related or unrelated projects.
  • Documents in the Projects panel are automatically arranged in logical groups or 'folders', such as Source Documents (Schematic, PCB, etc.), Settings documents (Harness, Outjob, etc.,) and, in the case of a hierarchical design, top-level schematic documents. The documents within each folder group are displayed by default in the order they were added but can be dragged and dropped to a new order position within the group.
  • In the case of a new hierarchical design, the parent-child relationship between documents will be displayed in the panel. Note that the connectivity relationships cannot be defined by dragging and dropping schematic documents since the inter-sheet connections and design hierarchy are in fact defined by Sheet Symbols and Port definitions.
  • The project document sub-folders, whether expanded or closed, share these right-click menu commands:
    • Open All – used to open all documents within the focused project document sub-folder.
    • Close All – used to close all documents within the focused project document sub-folder.
    • Save All – used to save all documents within the focused project document sub-folder.
    • Remove All – used to remove all documents within the focused project document sub-folder. Use the following Remove from project dialog to select how the documents should be removed.
    • Refresh – used to update the panel with any changes you have made.

The right-click options listed below are pertinent only to files found within the specified project document sub-folders:

Libraries

  • SVN Database Library Maker – used to access the SVN Database Library Conversion Wizard, from the currently focused project library document – either a Schematic Library (*.SchLib), PCB 2D/3D Component Model Library (*.PcbLib), or an Integrated Library (*.IntLib).

Components, Nets

  • Cross Probe to Schematic – used to cross-probe from the selected component or net entry in the Projects panel to that entity on the source schematic document(s) of the parent PCB design project.
  • Cross Probe to PCB – used to cross-probe from the selected component or net entry in the Projects panel to that entity on the PCB document of the parent PCB design project.
  • Component Grouping – used to quickly access the Components Grouping controls for the Projects panel.

Active Versus Focused

In the panel's main tree, the active project is highlighted. When there are no documents open in the design editor window, a project is made active by selecting it from a list of all currently open (loaded) projects in the panel. As soon as a project document is opened (in an editor/viewer), the parent project of that document automatically becomes the active project. The active document in the design editor window will also be highlighted in the panel.

The highlighting of an open active document and its active parent project.
The highlighting of an open active document and its active parent project.

If no project documents are open in the design editor window, opening an additional project will automatically make it the active project in the panel.

The ability to search for a particular document is made possible with the Search function featured near the top of the panel. You may enter keywords to narrow down a search, or to find a particular document.

With numerous documents open in the design editor window, changing the active document using the editor's document tabs will cause the Projects panel to update accordingly, i.e. to reflect both the active document and the active project (if the document made active does not reside in the same project as the previously active document). Conversely, clicking on the entry for a document that is already open (and that belongs to a non-active project) will make the parent project of that document the active project.

Only one project and document may be active at any given time, however, the panel allows you to focus and perform actions on any project or document. Right-clicking on the entry for a non-active project or a non-active document will bring up an associated menu with commands targeting the focused project or focused document, respectively.

In the case of focusing a document, the document will only become focused if it is closed, otherwise, it will become the active document and its parent project will become the active project. For example, in the image below, the active project is MiniPC.PrjPcb and the active document DDR4.SchDoc. The focused document is Ethernet-HPS.SchDoc (distinguished in the panel by a dotted outline box).

An opened active document (blue) and a selected focused document indicated by the dotted outline.
An opened active document (blue) and a selected focused document indicated by the dotted outline.

A project document can be removed from a project. If it is currently open in the design editor window it will be removed from its parent project but remain open in the panel as a free document. If, however, it is not currently open in the design editor window, removal will effectively close it.

Quick Access Controls

This command is used to locally save the currently focused project.
This command is used to validate all source documents of the focused project.
This command is used to open an instance of Windows Explorer, at the location where the focused file is stored.
This command is used to access Project Options – Options dialog, from where you can set up project-specific options for the focused project.
This command is used to quickly access controls relating to the behavior of the Projects panel. Descriptions of the controls are located on the System – Projects panel page of the Preferences dialog.

There are several right-click menu options that appear within the quick access controls section of the Projects panel. When not actually right-clicking on one of the quick access control buttons, but merely around blank areas of the panel that do not house icons or documents, the following options appear:

  • Recent Project Groups – hover to unveil a list of Design Project Groups (*.DsnWrk) that have recently been opened.
  • Add New Project – used to create a new design project (PCB or Multiboard).
  • Add Existing Project – used to open any existing Altium Designer project.
  • Open Project Group – used to open any existing Design Project Groups.
  • Save Project As – used to save the current Design Project Group.
  • Rename – used to rename the currently active Design Project Group in the Projects panel with a new name.
  • Save All – used to locally save all projects and documents that have been modified.
  • Explore – used to open an instance of Windows Explorer, at the location where the current Design Project Group is stored.
  • Refresh – used to update the Projects panel.

Right-click Menus

Project File

Right-clicking on a project file in the panel provides access to additional options and commands in the right-click menu.

The first image shows the typical right-click menu for a Workspace-based project, while the second image displays the typical right-click menu for a local project.
The first image shows the typical right-click menu for a Workspace-based project, while the second image displays the typical right-click menu for a local project.

Right-click selections include:

  • Validate PCB Project – the compiling process detects electrical and drafting violations and is integral to producing a valid netlist for a project. Results are displayed in the Messages panel (View » Panels » Messages).
  • Make Project Available Online – when connected to your Altium 365 Workspace, this command opens open the Make Available Online dialog, where you may register a project that is not currently under the Workspace's version control.
  • Make Project Available on Server – when signed into your Concord Pro Workspace, this command opens the Make Available on Server dialog to allow you to make that project available as a project in the Workspace.
  • Add New to Project – add a new, blank Schematic, PCB, ActiveBOM, Draftsman, type of library, output job, CAM, or Database link document to the current project.
  • Add Existing to Project – add an existing, locally stored Schematic or PCB document to the current project. Other file types (text, etc.,) are also supported.
  • Clone – used to clone projects. After launching the command, the Clone Project dialog will display the Project Name and Description. By default, the original project name will be used with the suffix ' - Copy'.
  • Save – saves the project.
  • Rename – rename the project.
  • Save to Server – opens the Save to Server dialog, from where you can save locally, modified files.
  • Make Active Project – ensures that the desired project becomes the currently active project.
  • Close Project Documents – used to close all currently open and/or open and hidden documents associated with the focused project.
  • Close Project – closes the project and any active project documents. You will receive prompts to save any documents that have been modified.
  • Explore – used to open an instance of Windows Explorer, at the location where the focused project document is stored.
  • Show Differences – detect and resolve the difference between two design files.
  • Variants – opens the Variant Management dialog to define variations of the base design where components can be configured as fitted or not, or fitted with modified component parameters.
  • History & Version Control – opens a menu of history and version control options. Use the Local History (Legacy) submenu option to compare an open document with its last saved contents. Refresh, commit, update, or lock your project. You also can resolve conflicts, revert local modifications, add/remove from version control, or compare locally saved schematic documents with a commit or release of the project. Use the Storage Manager option to open the Storage Manager panel.
  • Project Packager – opens the Project Packager Wizard to package files into a portable ZIP file.
  • Project Releaser – click to open the Project Releaser.
  • Show in Explorer – used to open the Explorer panel Project View for the selected project.
  • Show in Web Browser – used to open the web browser interface of a project.
  • Share – click to open the Share dialog, where you may share your design projects with others, anywhere around the world, directly from within the software.
  • Project Options – click to open the Project Options dialog.

Document Files

Right-click on a document file in the panel to open a pop-up context menu offering a range of document-specific options and commands.

Example right-click context menu for a document (Schematic Library in this case).
Example right-click context menu for a document (Schematic Library in this case).

Several right-click options are basically the same as when right-clicking on a Project, outlined above. Others include:

  • Close – a closed document will no longer be open in the design editor.
  • Explore – used to open an instance of Windows Explorer, at the location where the focused project document is stored.
  • Add to Project – used to add a currently open free document to the active project.
  • Remove from Project – use to exclude the document from the parent project.
  • Save – save the document locally.
  • Rename – rename the document.
  • Page Setup/Print Preview/Print – manage document printing, replicating the functions available from the main Print options (Outputs » Documentation » Print).
  • Show Differences – detect and resolve the inconsistencies in the design structure or the difference between two design files.
  • History & Version Control – opens a menu of history and version control options. Use the Local History (Legacy) submenu option to compare an open document with its last saved contents. Refresh, commit, update, or lock your project. You also can resolve conflicts, revert local modifications, or add/remove from version control. Use the Storage Manager option to open the Storage Manager panel.
  • SVN Database Library Maker – used to access the SVN Database Library Conversion Wizard, from the currently focused project library document – either a Schematic Library (*.SchLib), PCB 2D/3D Component Model Library (*.PcbLib), or an Integrated Library (*.IntLib).
  • Import Library – used to open the Library Importer (Simple mode), which provides a streamlined process to import selected file-based component libraries to your Workspace.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: