回路図シートの番号付け
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
概略
- シートの採番ツールにアクセスする場所、SheetNumber、DocumentNumber、SheetTotalの編集方法、自動採番を有効または無効にする必要がある場面を学びます。
- 論理的な回路図シートへの採番と、コンパイル済みシートインスタンスへのアノテーションの違いを、それぞれの保存方法や表示方法も含めて理解します。
- =SheetNumberなどの特殊文字列を表題欄、印刷出力、プロジェクトデータで使用し、設定した番号を反映する方法を確認します。
プロジェクト内の回路図シートに番号を付けることで、シートの識別番号を管理し、それぞれの回路図ドキュメント内にパラメーターとして保存できます。その後、特殊文字列機能(=SheetNumber、=DocumentNumber、=SheetTotal)を使用して、これらの値をシート上(たとえば、シートのタイトルブロック内)にテキストオブジェクトとして表示できます。この番号付けで変更されるのはコンポーネントのデジグネーターではなく、回路図シートの識別番号です。そのため、設計のアノテーションという一般的な概念に関連しています。
シートの番号付け
シートの番号付けを行うには、メインメニューからTools » Annotation » Number Schematic Sheetsをクリックし、Sheet Numbering For Projectダイアログを開きます。

Sheet Numbering For Project ダイアログを使用して、プロジェクト内の回路図シートに番号を付け、整理します。
Sheet Numbering For Projectダイアログのオプションとコントロール
このダイアログのオプションやコントロールの多くは、わかりやすく、詳しい説明を必要としません。説明が必要なものについては、以下に記載します。
| SheetNumber DocumentNumber |
これらのフィールドは、グリッド内で直接編集できます。1回クリックしてセルにフォーカスを合わせ、もう一度クリックして編集モードに入ります。右クリックメニューのコマンドを使用して、値のコピーと貼り付けや、選択した複数のセルの編集を行えます。複数のセルを編集するには、必要なセルを選択し、そのうちの1つを右クリックしてEditコマンドを選択します。新しい値を入力してEnterを押すと、 選択範囲内の各セルにその値が適用されます。 |
| SheetTotal | ドキュメントのドキュメントレベルパラメーターSheetTotal の現在の値です。このフィールドは、Update Sheet Countボタンをクリックすると更新されます。 |
| Automatic Sheet Numbering (Project Option) | このオプションを有効にすると、プロジェクト内の回路図シートに自動で番号が付けられます。これにより、シートの識別番号を管理し、それぞれの回路図ドキュメント内にパラメーターとして保存できます。このオプションは、Project Options - Optionsダイアログからも有効にできます。 |
| Auto Sheet Number Auto Document Number |
クリックすると、選択した番号付けの方式や方法に従って、シート/ドキュメントに番号が付けられます。ボタンに付随するドロップダウン矢印をクリックすると、使用可能な番号付けオプションにアクセスできます。
|
| Update the Sheet Count | クリックすると、現在のプロジェクト内のシート総数が集計され、結果がSheetTotal列に入力されます。シート数は、それ以前のコントロールで選択された番号付け方式にかかわらず、プロジェクト内のシートの総数となります。このフィールドにアクセスするには、 Automatic Sheet Numbering (Project Option) オプションを無効にする必要があります。 |
回路図シートの番号付けとデバイスシート
デバイスシートが読み取り専用(デフォルトの状態)の場合、シート番号やドキュメント番号は設定できません。Sheet Numbering For Projectダイアログでは、以下の画像に示すように、更新できないことを示す網掛けが表示されます。デバイスシートを編集可能に設定すると、網掛けが解除され、通常どおり番号付けを設定できます。
シートの自動番号付け
シートの自動番号付け機能は、Project OptionsダイアログのOptionsタブにあるAutomatic Sheet Numberingオプション、およびSheet Numbering For ProjectダイアログのAutomatic Sheet Numbering (Project Option) オプションを使用して、有効または無効にできます。いずれか一方のダイアログでオプションを有効にするだけで、シートの自動番号付けが行われます。両方のダイアログでオプションが無効になっている場合は、手動でシートに番号を付けることができます。
上記のいずれかのオプションが有効になっている場合、Projects パネルで回路図シートに自動番号付けを直接適用できます。番号付けを変更するには、パネル内で回路図シートをドラッグ&ドロップします。シート番号は、回路図シート名の左側に表示されます。
コンパイル済みシートのアノテーション
コンパイル済みシートのアノテーションでは、シートの番号付けで論理シートの番号を管理するのと同様に、コンパイル済みシート(シートの物理インスタンス)の番号付け方法を管理できます。
たとえば、Input channel.SchDocという回路図ドキュメントを含む設計を考えてみます。このシート内の回路が設計内で8回使用されている場合、設計のコンパイル後、Input channel.SchDocは8回インスタンス化されます(つまり、物理PCB上の回路の各インスタンスに対して1回ずつ)。シートの番号付けは、設計の論理構造内にあるInput channel.SchDocシートに番号を付けるために使用します。一方、コンパイル済みシートのアノテーションは、設計の物理(コンパイル済み)ビュー内にある、そのシートの個々のインスタンスに番号を付けるために行います。
コンパイル済みシートのアノテーションは、Annotate Compiled Sheetsダイアログで行います。このダイアログには、メインメニューからTools » Annotation » Annotate Compiled Sheetsコマンドを選択してアクセスします。
このダイアログには、現在のプロジェクトのすべてのコンパイル済みシートが一覧表示されます。Sheet Number フィールドに直接入力することで、コンパイル済みシートに独自の名前を付けることができます。英数字や記号を任意に組み合わせて入力し、OK をクリックすると、独自のアノテーションが適用されます。
ボタンに付随する下向き矢印をクリックしてオプションを選択した後、Annotate Sheetボタンをクリックしてシートにアノテーションを適用します。(必要に応じて、フィールドの説明については「シートの番号付け」セクションを参照してください。)選択内容に合わせてSheetNumberが更新されます。
このダイアログで更新されたシート番号は、Projects パネルのSettings\Annotation Documentsサブフォルダーにある、プロジェクトの*.Annotationファイルに保存されます。これにより、プロジェクトの編集セッションをまたいで、アノテーション情報と設定が保持されます。
基板レベルのアノテーションでコンパイル済みシートのアノテーションを使用する
Annotate Compiled Sheetsダイアログでコンパイル済みシートにアノテーションを適用すると、基板レベルのアノテーションオプションダイアログの命名規則の一部として、$SheetNumberキーワードを使用できます。プロジェクトのコンパイル済みシートにまだアノテーションが適用されていない場合は、デフォルトでSheet Numbering For Projectダイアログで定義されたシート番号が使用されます。
プロジェクトでのコンパイル済みシートのアノテーションの使用
コンパイル済みシートにアノテーションを適用すると、プロジェクト内にSheetNumber特殊文字列を配置して、この情報を参照できます。
-
特殊文字列は常に表示されます。 値が空の場合は、パラメーター名が表示されます。
-
コンパイル済みシートのアノテーション値を使用するには、値が
=SheetNumberとなる特殊文字列を配置します。特殊文字列は、パラメータープロパティの値、テキスト文字列、ネットラベルなどで使用できます。 -
ダイアログで割り当てられたシート番号は、 =SheetNumber 特殊文字列を使用して、コンパイル済み(物理)シートの印刷出力上で参照できます。この値は、設計のすべての印刷出力で更新されます。

