回路図エディタと回路図ライブラリエディタのショートカット

概略

この記事は、Altium Designerの回路図エディターおよび回路図ライブラリエディターで使用するショートカットキーの実用的なリファレンスです。利用可能なコマンドを確認する前に、キーの組み合わせやマウス操作の表記方法をすばやく理解できます。編集、選択、移動、整列、表示、グリッド制御、テキスト検索、パネルへのアクセスなど、日常的に使うショートカットを紹介しているため、メニューを何度もたどることなく効率的に作業できます。これらのエディターを日常的に使用している方は、このガイドを活用することで、よく行う作業をスピードアップし、設計スペースをより自在に操作できるようになります。回路図の作業をより速く、スムーズに進めるために、ぜひ続きをお読みください。

- キーの組み合わせやマウス操作など、Altium Designerのショートカット表記をわかりやすく解説。
- 編集、選択、移動、整列、ナビゲーション、表示など、一般的な回路図作業に使うショートカットをカテゴリ別に紹介。
- 回路図エディターおよび回路図ライブラリエディターで、グリッドの操作、テキスト検索、主要パネルの表示に使うショートカットをすばやく参照可能。
AIでさらに深掘り:

以下のセクションでは、回路図エディターおよび回路図シンボルエディター固有のショートカットキーを紹介します。ショートカットキーへのアクセスや編集、Altium環境全般のショートカット、アクセラレーターキーなど、ショートカットキーに関する一般的な情報については、Altium Designerのショートカットキーを参照してください。

ショートカットキーの一覧を参照する際は、以下の点に注意してください。

  • ショートカットの表記では、プラス記号(+)は、示された順序でキーボードの複数のキーを押し続けることを意味します。たとえば、Shift+F1は、Shiftキーを押しながらF1キーを押すことを意味します。同様に、Shift+Ctrl+PgUpは、Shift キーを押したままCtrl キーも同時に押し続け、PgUpキーを押すことを意味します。
  • 標準のマウスボタンを使用する場合、Click はマウスの左ボタンを1回クリックすること、Double-Clickはマウスの左ボタンを2回クリックすること、Right-Clickはマウスの右ボタンを1回クリックすることを意味します。

標準ショートカット

以下は、回路図エディターおよび回路図シンボルエディターの標準ショートカットです。通常の操作時に使用でき、対話型の処理を実行している必要はありません。

General Editing

Double-Click 現在カーソルの下にあるオブジェクトのプロパティを変更します。
Right-Click デザインスペース、または現在カーソルの下にあるオブジェクトのコンテキストメニューを開きます。対話型コマンドの実行中の場合は、現在の操作を終了します。
F2 選択したテキストオブジェクトをその場で編集します(直接編集)。
Ctrl+C 選択項目をコピーします。
Ctrl+X 選択項目を切り取ります。
Ctrl+V 選択項目を貼り付けます。
Ctrl+R 選択したオブジェクトをコピーし、デザインスペース内の必要な場所に繰り返し貼り付けます(ラバースタンプ)。
Shift+Ctrl+V スマート貼り付けダイアログを開きます。
Delete 選択項目を削除します。
Ctrl+Z 元に戻します。
Ctrl+Y やり直します。

Selecting

Shift+F 類似オブジェクト検索機能にアクセスします(基本テンプレートとして使用するオブジェクトをクリックします)。
Click 現在カーソルの下にあるオブジェクトを選択または選択解除します。
Shift+Click 他のオブジェクトの選択状態に影響を与えずに、現在カーソルの下にあるオブジェクトの選択状態を変更します。
Shift+Ctrl+X クロス選択モードのオンとオフを切り替えます。
Shift+Ctrl+Y クロス選択モードのReposition selected component in PCBオプションのオンとオフを切り替えます。
Ctrl+A 現在のドキュメント内のすべてのオブジェクトを選択します。
Alt+Click ネットオブジェクト上で操作すると、そのオブジェクトを選択し、アクティブな設計プロジェクトのすべてのシートにわたって、そのネットに関連するすべてのオブジェクトをハイライト表示します。
Click(オブジェクトのない場所で), Hold&Drag (左から右へ) 選択領域内に完全に収まるすべてのオブジェクトを選択します。
Click(オブジェクトのない場所で), Hold&Drag (右から左へ) 選択領域内に完全に収まるオブジェクト、または領域の境界に接するオブジェクトをすべて選択します。
Ctrl+n(n = 1~8) 現在の選択内容をメモリ位置nに保存します。
Alt+n(n = 1~8) メモリ位置nから選択内容を呼び出します。
Shift+n(n = 1~8) 現在の選択内容を、メモリ位置nに保存されている選択内容に追加します。
Alt+Shift+n(n = 1~8) メモリ位置nから選択内容を呼び出し、デザインスペース内の現在の選択内容に追加します。
Shift+Ctrl+n(n = 1~8) メモリ位置nの選択セットに基づいてフィルタリングを適用します。

Moving

Click(オブジェクト上で), Hold&Drag

現在カーソルの下にある単一のオブジェクトを移動します(そのオブジェクトが選択項目に含まれる場合は、選択したオブジェクトのグループを移動します)。Always Dragオプション(Preferences ダイアログのSchematic - Graphical Editing ページ)が有効な場合、このショートカットを使用して電気オブジェクトを移動すると、他の電気オブジェクトとの接続が維持されます。

Ctrl+Click, Hold&Drag 現在カーソルの下にある単一のオブジェクトを移動します(そのオブジェクトが選択項目に含まれる場合は、選択したオブジェクトのグループを移動します)。Always Dragオプション(Preferences ダイアログのSchematic - Graphical Editing ページ)が無効な場合、このショートカットを使用して電気オブジェクトを移動すると、他の電気オブジェクトとの接続が維持されます。
Left Arrow 現在のドキュメントのデザインスペース内で、カーソルをスナップグリッド1単位ずつ左へ移動します。
Shift+Left Arrow 現在のドキュメントのデザインスペース内で、カーソルをスナップグリッド10単位ずつ左へ移動します。
Right Arrow 現在のドキュメントのデザインスペース内で、カーソルをスナップグリッド1単位ずつ右へ移動します。
Shift+Right Arrow 現在のドキュメントのデザインスペース内で、カーソルをスナップグリッド10単位ずつ右へ移動します。
Up Arrow 現在のドキュメントのデザインスペース内で、カーソルをスナップグリッド1単位ずつ上へ移動します。
Shift+Up Arrow 現在のドキュメントのデザインスペース内で、カーソルをスナップグリッド10単位ずつ上へ移動します。
Down Arrow 現在のドキュメントのデザインスペース内で、カーソルをスナップグリッド1単位ずつ下へ移動します。
Shift+Down Arrow 現在のドキュメントのデザインスペース内で、カーソルをスナップグリッド10単位ずつ下へ移動します。
Ctrl+Left Arrow 現在のドキュメントのデザインスペース内で、現在の選択項目(選択されている1つ以上の設計オブジェクト)をスナップグリッド1単位ずつ左へ移動します。
Shift+Ctrl+Left Arrow 現在のドキュメントのデザインスペース内で、現在の選択項目(選択されている1つ以上の設計オブジェクト)をスナップグリッド10単位ずつ左へ移動します。
Ctrl+Right Arrow 現在のドキュメントのデザインスペース内で、現在の選択項目(選択されている1つ以上の設計オブジェクト)をスナップグリッド1単位ずつ右へ移動します。
Shift+Ctrl+Right Arrow 現在のドキュメントのデザインスペース内で、現在の選択項目(選択されている1つ以上の設計オブジェクト)をスナップグリッド10単位ずつ右へ移動します。
Ctrl+Up Arrow 現在のドキュメントのデザインスペース内で、現在の選択項目(選択されている1つ以上の設計オブジェクト)をスナップグリッド1単位ずつ上へ移動します。
Shift+Ctrl+Up Arrow 現在のドキュメントのデザインスペース内で、現在の選択項目(選択されている1つ以上の設計オブジェクト)をスナップグリッド10単位ずつ上へ移動します。
Ctrl+Down Arrow 現在のドキュメントのデザインスペース内で、現在の選択項目(選択されている1つ以上の設計オブジェクト)をスナップグリッド1単位ずつ下へ移動します。
Shift+Ctrl+Down Arrow 現在のドキュメントのデザインスペース内で、現在の選択項目(選択されている1つ以上の設計オブジェクト)をスナップグリッド10単位ずつ下へ移動します。

Aligning

Shift+Ctrl+L 選択したオブジェクトの左端を揃えます。
Shift+Ctrl+R 選択したオブジェクトの右端を揃えます。
Shift+Ctrl+H 選択したオブジェクトの水平方向の間隔を均等にします。
Shift+Ctrl+T 選択したオブジェクトの上端を揃えます。
Shift+Ctrl+B 選択したオブジェクトの下端を揃えます。
Shift+Ctrl+V 選択したオブジェクトの垂直方向の間隔を均等にします。
Shift+Ctrl+D 選択したオブジェクトを、現在のスナップグリッド上の最も近い点に移動します。
Spacebar 選択項目を反時計回りに90°回転します。
Shift+Spacebar 選択項目を時計回りに90°回転します。

Viewing the Schematic

Ctrl+PgDn 現在のドキュメント内のすべての設計オブジェクトを表示します。
PgUp 現在のカーソル位置を基準にズームインします。

以下のいずれかの方法で、マウスを使用してドキュメントの特定の領域を拡大することもできます(使用できる方法は、マウスボタンの割り当てによって異なります)。

  • Ctrl キーを押しながら、マウスホイールを上方向に回します。Ctrl キーの使用はデフォルト設定であり、PreferencesダイアログのSystem - Mouse Wheel Configurationページで変更できます。
  • Ctrl キーとマウスの右ボタンを両方押したまま、マウスを前方に動かします。
  • マウスの右ボタン、左ボタンの順に押し、そのままマウスを前方に動かします。
  • マウスホイールを押したまま、マウスを前方に動かします。
PgDn 現在のカーソル位置を基準にズームアウトします。

次のいずれかの方法で、マウスを使用してドキュメント内の領域からズームアウトできます(使用できる方法は、マウスのボタンの割り当てによって異なります)。

  • Ctrl キーを押しながら、マウスホイールを下方向に回します。Ctrl キーの使用はデフォルト設定であり、PreferencesダイアログのSystem - Mouse Wheel Configurationページで変更できます。
  • Ctrl キーとマウスの右ボタンを両方押したまま、マウスを後方に動かします。
  • マウスの右ボタン、左ボタンの順に押し、そのままマウスを後方に動かします。
  • マウスホイールを押したまま、マウスを後方に動かします。
Mouse Wheel デザインスペース内を垂直方向にスクロールします。これはデフォルト設定であり、PreferencesダイアログのSystem - Mouse Wheel Configurationページで変更できます。
Shift+Mouse Wheel デザインスペース内を水平方向にスクロールします。これはデフォルト設定であり、PreferencesダイアログのSystem - Mouse Wheel Configurationページで変更できます。
Shift+Ctrl+Mouse Wheel マルチチャネル設計のチャネルを順に切り替えます。 マウスホイールを上方向または下方向に回すと、メインデザインウィンドウの下部にある、次または前のコンパイル済みチャネルのタブがアクティブになります。これはデフォルト設定であり、PreferencesダイアログのSystem - Mouse Wheel Configurationページで変更できます。
Home コマンドを実行する前のカーソル位置がウィンドウの中央に来るように、メインデザインウィンドウの表示を再描画します。
End 画面を更新し、現在のドキュメントを再描画して、描画更新による不要な表示の乱れを取り除きます。
Alt+End 現在のドキュメントの現在のレイヤーを再描画して、描画更新による不要な表示の乱れを取り除きます。
Alt+F5 現在のドキュメントのエディターを、最大化表示と通常表示の間で切り替えます。
F5 Net Color Override機能の表示をオンまたはオフに切り替えます。
Shift+C アクティブなドキュメントに現在適用されているフィルターを解除します。
Right-Click, Hold&Drag スライダー(パン)用の手の形のカーソルを表示し、ドラッグしてデザインスペースの表示位置を移動します。

Grids

G 事前定義されたスナップグリッド設定を順方向に切り替えます。
Shift+G 事前定義されたスナップグリッド設定を逆方向に切り替えます。
Shift+Ctrl+G 現在のドキュメントの表示グリッドをオンまたはオフにします。
Ctrl+Shift グリッドを一時的に無効にします。
Shift+E カーソルの電気グリッドをオンまたはオフにします。

Finding Text

Ctrl+F テキストを検索します。
Ctrl+H テキストを検索して置換します。
F3 検索テキストの次の出現箇所を検索します。

Quick Panel Access

F11 Propertiesパネルの表示を切り替えます。
F12 状況に応じて、SCH Filterパネル またはSCHLIB Filterパネルの表示を切り替えます。
Shift+F12 状況に応じて、Listパネル(SCH ListまたはSCHLIB Listパネル)の表示を切り替えます。

Commenting

Alt+Ctrl+C アクティブな回路図ドキュメントの点、オブジェクト、または領域に新しいコメントスレッドを追加します。 コメント機能を使用する前に、管理対象プロジェクトを開き(チェックアウトし)、そのソース回路図ドキュメントのいずれかで作業していることを確認してください。

Miscellaneous

Ctrl+Double-Click
  • シートエントリ上で実行すると、そのエントリの親であるシートシンボルが参照する下位シート上の対応するポートにジャンプします。
  • ポート上で実行すると、そのポートがある下位シートを参照する親シートシンボル内の、対応するシートエントリにジャンプします。
  • ポート上で実行すると、指定された移動先回路図ドキュメント上の同じ名前の別のポートにジャンプします(Project のOptionsタブで設定するNet Identifier ScopeOptions dialog が、FlatまたはGlobalに設定されている場合にのみ使用できます)。
  • シートシンボル上で実行すると、設計階層を下り、そのシンボルが参照する子シートを開きます。
Ctrl+L Board Level Annotateダイアログを使用して、Board Level Annotation を実行します。
Ctrl+W ワイヤ配置モードに入ります。
Ctrl+Home 現在のドキュメントの絶対原点座標(0,0)にカーソルを移動します。
Ctrl+Q
  • メインデザインスペースで実行すると、Selection Memoryダイアログを開き、選択メモリ機能のすべての設定を管理できます。
  • ダイアログまたはパネル内で実行すると、そのダイアログまたはパネル内の測定単位のみを、メートル法(mm)とヤード・ポンド法(mil)の間で切り替えます。
Ctrl+M 現在のドキュメント内の任意の2点間の距離を測定し、表示します。
F9

Simulation Dashboardパネルで現在定義されている解析と関連設定を使用して、アクティブな設計のシミュレーションを実行します。この設計で初めてシミュレーションを実行する場合は、デフォルトの解析であるOperating Point、DC Sweep、Transient Analysis、およびAC Analysisが、それぞれのデフォルト設定で実行されます。この場合は、まずSimulation Dashboardパネルでシミュレーションの設定を行うことを強くお勧めします。このショートカットに関連付けられたRun Simulationコマンドは、Mixed Simulationシステム拡張機能がインストールされている場合にのみ使用できます。この拡張機能をインストールすると、回路図エディターにSimulate メニューが追加されます。詳細については、Extending Your Installation (Altium Designer Develop、Altium Designer Agile、Altium Designer)を参照してください。

 、Click 現在の回路図ドキュメントで選択したオブジェクトから、PCBドキュメント上の対応するオブジェクトにクロスプローブします。元のドキュメントはアクティブなままです(Continuous Mode)。
、Ctrl+Click 現在の回路図ドキュメントで選択したオブジェクトから、PCBドキュメント上の対応するオブジェクトにクロスプローブし、移動先のドキュメントをアクティブにします(Jump To Mode)。

インタラクティブ操作のショートカット

以下のショートカットは、新しい設計オブジェクトの配置や既存オブジェクトの移動など、インタラクティブな処理を開始すると使用できるようになります。 使用できるショートカットは、実行中のインタラクティブコマンドと、そのコマンドの対象となる設計オブジェクトによって異なります。

F1 Graphical Editing Hot key Listダイアログを開きます。このダイアログには、使用可能なショートカットの一覧が表示されます(ここから実行することはできません)。また、現在実行中のコマンドのドキュメントにもアクセスできます。
Shift+F1 現在実行中のインタラクティブコマンドの現在の段階で使用できる、すべてのショートカットを一覧表示するメニューを開きます。
Enter オブジェクトの配置中または移動中に、マウスのClick と同様に動作します。
PgUp ズームインします。
PgDn ズームアウトします。
End 画面を更新します。
Home カーソル(配置中または移動中のオブジェクトが付随)が設計ウィンドウの中央に来るように表示を変更します。
Left Arrow 現在のドキュメントのワークスペース内で、カーソル(配置中または移動中のオブジェクトが付随)をスナップグリッド1単位ずつ左に移動します。
Shift+Left Arrow 現在のドキュメントのワークスペース内で、カーソル(配置中または移動中のオブジェクトが付随)をスナップグリッド10単位ずつ左に移動します。
Right Arrow 現在のドキュメントのワークスペース内で、カーソル(配置中または移動中のオブジェクトが付随)をスナップグリッド1単位ずつ右に移動します。
Shift+Right Arrow 現在のドキュメントのワークスペース内で、カーソル(配置中または移動中のオブジェクトが付随)をスナップグリッド10単位ずつ右に移動します。
Up Arrow 現在のドキュメントのワークスペース内で、カーソル(配置中または移動中のオブジェクトが付随)をスナップグリッド1単位ずつ上に移動します。
Shift+Up Arrow 現在のドキュメントのワークスペース内で、カーソル(配置中または移動中のオブジェクトが付随)をスナップグリッド10単位ずつ上に移動します。
Down Arrow 現在のドキュメントのワークスペース内で、カーソル(配置中または移動中のオブジェクトが付随)をスナップグリッド1単位ずつ下に移動します。
Shift+Down Arrow 現在のドキュメントのワークスペース内で、カーソル(配置中または移動中のオブジェクトが付随)をスナップグリッド10単位ずつ下に移動します。
Tab インタラクティブ操作を一時停止し、Properties パネルの対応するモードにアクセスして、配置中または移動中のオブジェクトのプロパティをその場で変更します。Propertiesパネル(または任意のダイアログ)でTab を繰り返し使用すると、パネル内のフィールドを順に移動できます。
X 配置中または移動中のオブジェクトをX軸に沿って反転します。
Y 配置中または移動中のオブジェクトをY軸に沿って反転します。
Alt 最初の移動方向に応じて、移動方向を水平軸または垂直軸に制限します。
Shift オブジェクトの配置中または移動中に自動パンしている場合、パンの速度を上げます。
Esc
(またはRight-Click)
現在の処理(実行中のインタラクティブコマンドの一段階、またはコマンド自体)を終了します。
Spacebar
  • 配置中または移動中のオブジェクトを反時計回りに90°単位で回転します。
  • 90 Degreeまたは45 Degreeの配置モードでワイヤ/バス/シグナルハーネス を配置する際に、開始サブモードと終了サブモードを切り替えます。
  • ラインの配置中に、配置モードを順に切り替えます。
Shift+Spacebar
  • 配置中または移動中のオブジェクトを時計回りに90°単位で回転します。
  • ワイヤ/バス/シグナルハーネスの配置中に、配置モードを順に切り替えます。
Ctrl+Spacebar 電気的オブジェクトのドラッグ中に、接続されているワイヤ、バス、またはシグナルハーネスの配線モードを変更します。
Insert
Click&Hold+Insert 配置済みのワイヤ、ライン、バス、シグナルハーネスの選択したセグメント、または配置済みのポリゴンの辺で操作すると、その位置に頂点を追加します。
Click&Hold+Delete 配置済みのワイヤ、ライン、バス、シグナルハーネス、またはポリゴンの頂点で操作すると、その頂点を削除します。
Backspace または Delete ワイヤ、ライン、バス、シグナルハーネス、またはポリゴンの配置中に、最後に配置した頂点を削除します。
+(テンキー) 配置中または移動中のIEEEシンボルのサイズを拡大します。
-(テンキー) 配置中または移動中のIEEEシンボルのサイズを縮小します。
S 選択して移動中のシートエントリ(1つまたは複数)を、親のシートシンボルの反対側に移動します。
V 選択した2つ以上のシートエントリを移動中に、順序を逆にします。
T
  • 選択した1つ以上のシートエントリを移動中に、I/Oタイプを切り替えます。
  • 親のシートシンボルのサイズをグラフィカルに変更している間に、すべてのシートエントリのI/Oタイプを切り替えます。

ポップアップメニューのショートカット

以下のショートカットを使用すると、設計スペース内から直接、特定のコマンドのポップアップメニューにアクセスできます。一部はエディタのメインメニューにあるサブメニューなので、見覚えがあるかもしれません。各メインメニューにも、設計スペース内からすばやくアクセスするためのポップアップキーが定義されています。詳細は、アクセラレータキーを参照してください。

A Align サブメニュー(メインのEditメニュー内)。
B Toolbars サブメニュー(メインの表示 メニュー内)。
J Jump サブメニュー(メインのEditメニュー内)。
K Panelsサブメニュー(メインの表示 メニュー内)。
M Move サブメニュー(メインのEditメニュー内)。
O オプションと環境設定にすばやくアクセスできるポップアップメニュー。
S Select サブメニュー(メインのEditメニュー内)。
X DeSelect サブメニュー(メインのEditメニュー内)。
Y フィルタリングコマンドを含むポップアップメニュー。
Z ズームコマンドを含むポップアップメニュー。

 

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents