Draftsman 템플릿 만들기

개요

이 문서에서는 Altium Designer에서 Draftsman 문서 템플릿과 시트 템플릿이 작동하는 방식, 각 템플릿 유형이 제어하는 항목, 그리고 연결된 워크스페이스와 로컬 설치 환경에서 템플릿을 생성, 저장, 편집 및 마이그레이션하는 방법을 설명합니다. Draftsman의 전반적인 콘텐츠와 구조를 정의하는 문서 템플릿과 크기, 표제란 등 페이지 수준의 설정을 정의하는 시트 템플릿의 실질적인 차이를 살펴보고, 새 템플릿을 만들거나 기존 템플릿을 재사용하는 기본 워크플로도 알아봅니다. Draftsman 출력물을 표준화하고 템플릿을 더 효율적으로 관리하는 방법을 명확히 이해하고 싶다면 계속 읽어보세요.

- Draftsman 문서 템플릿과 시트 템플릿의 차이점과 각각을 언제 사용해야 하는지 알아봅니다.
- 워크스페이스에서 새 템플릿을 생성하고, 로컬 템플릿을 워크스페이스에 저장하며, 이후 리비전을 편집하거나 업로드하는 방법을 살펴봅니다.
- 기본 템플릿이 저장되는 위치와 전체 템플릿 관리 프로세스에서 로컬 템플릿 생성이 어떤 역할을 하는지 알아봅니다.
AI로 더 깊이 알아보기:

Draftsman 문서에서는 문서 템플릿과 시트 템플릿을 사용할 수 있습니다.

  • Document templates – 새 Draftsman 문서의 내용을 정의하는 데 사용됩니다.

  • Sheet templates – Draftsman 문서의 페이지 속성을 정의하는 데 사용됩니다.

What is the Difference between a Sheet Template and a Document Template?

Draftsman 문서 템플릿은 전체 Draftsman 문서의 내용과 구조에 중점을 두는 반면, 시트 템플릿은 개별 시트의 서식을 처리합니다.

  • Draftsman 문서 템플릿에는 여러 시트(페이지)와 뷰, 테이블 등 다양한 요소를 포함할 수 있습니다. Draftsman 문서를 문서 템플릿으로 저장하면 현재 PCB의 데이터가 유지되어 도면 내용의 '기본 틀'을 정의합니다. 이후 이 템플릿을 새 Draftsman 문서의 문서 템플릿으로 사용하면 템플릿의 PCB 데이터 대신 프로젝트의 현재 PCB 데이터가 이 기본 틀에 로드되어 문서 형식과 내용 유형이 재현됩니다.

  • Draftsman 시트 템플릿을 Draftsman 문서 페이지에 적용하면(자세히 알아보기), 시트 크기와 표제란 등 Draftsman 문서의 시트 수준 속성이 정의됩니다.

여러 Draftsman 문서 및 시트 템플릿이 다음 위치에 기본적으로 제공됩니다.

  • 연결된 워크스페이스 – 워크스페이스의 Managed Content\Templates\Draftsman Templates\Document Templates 및 Managed Content\Templates\Draftsman Templates\Sheet Templates 폴더 내(워크스페이스 활성화/설치 시 샘플 데이터를 포함하도록 선택한 경우).

  • 로컬 – Altium Designer 설치 경로의 Shared Documents 폴더에 있는 Templates 하위 폴더 내(기본 설치의 경우 C:\Users\Public\Documents\Altium\AD<Solution/Version>).

이러한 기본 템플릿을 요구 사항에 맞게 편집하거나 아래 설명에 따라 새 템플릿을 만들 수 있습니다.

워크스페이스 Draftsman 템플릿 만들기

Draftsman 문서 및 시트 템플릿은 연결된 워크스페이스에서 만들 수 있습니다. 워크스페이스는 모든 설계 데이터를 안전하게 중앙에서 관리하며 설계 팀 전체가 액세스할 수 있는 공간입니다.

워크스페이스 Draftsman 문서 템플릿 만들기

연결된 워크스페이스에서 새 Draftsman 문서 템플릿을 만들려면:

  1. Preferences 대화상자의 Data Management – Templates 페이지에서 Templates 탭을 엽니다.

  2.  버튼의 메뉴 또는 템플릿 그리드의 컨텍스트 메뉴에서 Draftsman Document 명령을 선택합니다.

  3. 명령을 선택한 후 열리는 Close Preferences 대화상자에서 OK을 클릭하여 Preferences 대화상자를 닫고 임시 Draftsman 편집기를 엽니다. 새 Draftsman 문서 템플릿 Item의 계획된 리비전이 Draftsman Templates 유형의 워크스페이스 폴더에 자동으로 생성됩니다.

  4. 문서 템플릿의 내용을 정의합니다. 문서 템플릿은 여러 페이지로 구성된 문서, 주요 문서 속성(뷰, 테이블, 목록 등)의 데이터, 페이지 설정, PCB의 설계 내용에 종속되지 않는 Draftsman에서 생성된 요소를 지원합니다.

    시트 템플릿을 사용하여 표제란, 크기 등 페이지 수준의 속성을 정의할 수 있습니다(시트 템플릿 적용을 포함한 문서 시트 구성에 대한 자세한 내용은 Draftsman 문서 설정 페이지 참조). 시트 템플릿에 대한 참조는 문서 템플릿의 일부로 저장됩니다. 시트 템플릿은 다음 섹션에서 설명합니다.

    단일 페이지 Draftsman 문서 템플릿의 예
    단일 페이지 Draftsman 문서 템플릿의 예

    Draftsman 문서는 컨텍스트를 제공하는 PCB 문서를 필요로 합니다. 워크스페이스 Draftsman 문서 템플릿을 정의하는 동안 문서 옵션을 정의할 수 있도록 가상의 6000x4000 mil PCB 문서가 생성되어 이 컨텍스트를 제공합니다.

  5. 기본 메뉴에서 File » Save to Server 명령을 선택하여 문서 템플릿을 연결된 워크스페이스에 저장합니다. Edit Revision 대화상자가 나타나면 워크스페이스에 생성할 Draftsman 문서 템플릿 Item의 Name 및 Description을 정의하고 필요에 따라 릴리스 노트를 추가할 수 있습니다.

    문서 템플릿 형식과 호환되지 않는 요소는 모두 제거됩니다. 호환되지 않는 요소가 있으면 저장 전에 경고 대화상자에 수행 예정인 작업의 세부 정보가 표시됩니다.

워크스페이스 Draftsman 시트 템플릿 만들기

연결된 워크스페이스에서 새 Draftsman 시트 템플릿을 만들려면:

  1. Preferences 대화상자의 Data Management – Templates 페이지에서 Templates 탭을 엽니다.

  2. 버튼의 메뉴 또는 템플릿 그리드의 컨텍스트 메뉴에서 Draftsman Sheet 명령을 선택합니다.

  3. 명령을 선택한 후 열리는 Close Preferences 대화상자에서 OK을 클릭하여 Preferences 대화상자를 닫고 임시 Draftsman 편집기를 엽니다. 새 Draftsman 문서 템플릿 Item의 계획된 리비전이 Draftsman Templates 유형의 워크스페이스 폴더에 자동으로 생성됩니다.

  4. 시트 템플릿의 내용을 정의합니다. 템플릿에는 시트 크기, 파라미터, 구역 및 테두리 설정을 포함한 페이지의 그래픽 정보를 포함할 수 있습니다. 편집기의 그래픽 도구로 생성한 객체(예: 선과 사각형)도 포함됩니다. 예를 들어 이러한 도구로 작성한 표제란과 그 내용이 이에 해당합니다.

    Draftsman 시트 템플릿의 예
    Draftsman 시트 템플릿의 예

    Draftsman 시트 템플릿을 만들 때는 다른 시트 템플릿을 페이지 크기 및 형식의 원본으로 사용하지 않는 것이 좋습니다. 즉, 설계 공간에 정의된 객체가 없는 상태에서 Properties 패널의 Page Options 탭에서 페이지 옵션을 정의할 때 Template 대신 Standard 또는 Custom 모드를 사용하십시오.

    표제란에 자동 시트 번호 지정 파라미터를 사용하는 경우, 문서에는 기존의 SheetNumber 파라미터와 GOST를 준수하는 SheetNumber_OneSheet 파라미터라는 두 가지 시스템 유형이 지원된다는 점에 유의하십시오. 후자는 Draftsman 문서에 시트가 하나만 있는 경우 현재 시트 번호를 표시하지 않으며(GOST 2.104-2006 도면 표준에 따름), 그 외의 경우에는 SheetNumber 파라미터와 동일한 번호를 제공합니다.

  5. 기본 메뉴에서 File » Save to Server 명령을 선택하여 템플릿을 연결된 워크스페이스에 저장합니다. Edit Revision 대화상자가 나타나면 워크스페이스에 생성할 Draftsman 시트 템플릿 Item의 Name 및 Description을 정의하고 필요에 따라 릴리스 노트를 추가할 수 있습니다.

    시트 템플릿 형식과 호환되지 않는 요소는 모두 제거됩니다. 호환되지 않는 요소가 있으면 저장 전에 경고 대화상자에 수행 예정인 작업의 세부 정보가 표시됩니다.

기존 로컬 Draftsman 템플릿을 워크스페이스에 저장하기

기존 Draftsman 문서/시트 템플릿(*.DwfDot/*.DwsDot)이 있는 경우 이 템플릿을 워크스페이스에 직접 저장할 수도 있습니다. 절차는 다음과 같습니다.

  1. Altium Designer에서 템플릿을 엽니다.

  2. 메인 메뉴에서 File » Save to Server 명령을 선택합니다.

    워크스페이스에 저장하기 전에 파일을 로컬에 저장(File » Save)해야 합니다.

  3. Choose Planned Item Revision 대화상자가 나타납니다. 이 대화상자에서 시트를 저장할 타겟 Draftsman 문서/시트 템플릿 Item을 선택합니다. 시트는 해당 Item의 다음 리비전 또는 Planned 상태인 기존 리비전에 저장됩니다. 그런 다음 OK을 클릭합니다.

    타겟 Draftsman 문서/시트 템플릿 Item이 없으면 Choose Planned Item Revision 대화상자에서 선택한 워크스페이스 폴더에 즉시 생성할 수 있습니다. 대화상자의 리비전 목록 영역을 마우스 오른쪽 버튼으로 클릭하거나, 폴더에 아직 Item이 없다면 Add an item 컨트롤을 클릭한 다음 Create Item » Draftsman Document Template / Draftsman Sheet Template 명령을 선택합니다. 이 경우 Create New Item 대화상자에서 Open for editing after creation 옵션을 반드시 비활성화해야 합니다. 그렇지 않으면 직접 편집 모드로 전환됩니다.

  4. Edit Revision 대화상자가 나타나면 Name, Description을 정의하고 필요에 따라 릴리스 노트를 추가할 수 있습니다.

  5. OK을 클릭하면 템플릿이 Item의 리비전에 저장됩니다.

  • Preferences 대화상자의 데이터 관리 – 템플릿 페이지에 있는 Templates 탭에서  버튼 메뉴 또는 템플릿 Grid의 Add 컨텍스트 메뉴에 있는 Load from File 명령을 사용하여 새 워크스페이스 Draftsman 문서/시트 템플릿을 생성할 수도 있습니다. 열리는 Open 대화상자(표준 Windows 열기 대화상자)에서 File name 필드 오른쪽의 드롭다운에 있는 Draftsman Document File (*.DwfDot) / Draftsman Sheet File (*.DwsDot) 옵션을 선택한 다음, 필요한 파일을 찾아 엽니다. 이 파일은 Draftsman Templates 유형의 워크스페이스 폴더에 자동으로 생성되는 새 Draftsman 문서/시트 템플릿 Item의 초기 리비전에 업로드됩니다.

  • 워크스페이스에 저장할 Draftsman 문서/시트 템플릿이 Local Template folder에 있고(Preferences 대화상자의 데이터 관리 – 템플릿 페이지 하단에서 정의됨), 템플릿 Grid의 Local Entry 아래에 나열되어 있다면, 해당 템플릿을 마우스 오른쪽 버튼으로 클릭하고 Migrate to Server 명령을 선택하여 새 Draftsman 문서/시트 템플릿 Item으로 마이그레이션할 수 있습니다. Template migration 대화상자에서 OK 버튼을 클릭하여 마이그레이션을 진행합니다. 이 대화상자에 명시된 대로 원본 템플릿 파일은 로컬 템플릿 폴더의 Zip 아카이브에 추가되므로 Local 템플릿 목록에는 더 이상 표시되지 않습니다.

워크스페이스 Draftsman 템플릿 편집

언제든지 워크스페이스의 Draftsman 문서/시트 템플릿으로 돌아가 편집할 수 있습니다. Preferences 대화상자의 데이터 관리 – 템플릿 페이지에 있는 Templates 탭에서 템플릿 Entry를 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Edit 명령을 선택합니다. 임시 Draftsman Editor가 열리고, 해당 리비전에 포함된 템플릿이 편집용으로 열립니다. 필요한 내용을 변경한 다음 문서를 Draftsman 문서/시트 템플릿 Item의 다음 리비전에 저장합니다.

워크스페이스 Draftsman 문서/시트 템플릿을 업데이트해야 하고 업데이트된 Draftsman 문서/시트 템플릿 파일이 있다면, 해당 파일을 워크스페이스 템플릿에 업로드할 수 있습니다. Preferences 대화상자의 데이터 관리 – 템플릿 페이지에 있는 Templates 탭에서 템플릿 Entry를 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Upload 명령을 선택합니다. 열리는 Open 대화상자(표준 Windows 열기 대화상자)에서 필요한 파일을 찾아 엽니다. 이 파일은 Draftsman 문서/시트 템플릿 Item의 다음 리비전에 업로드됩니다.

로컬 Draftsman 템플릿 생성

현재 Editor에서 열려 있는 Draftsman 문서(*.PCBDwf)를 템플릿 유형 중 하나로 저장하여 로컬 Draftsman 시트/문서 템플릿을 생성할 수도 있습니다.

필요한 Draftsman 문서가 활성 문서인 상태에서 메인 메뉴의 File » Save Copy As 또는 File » Save As 명령을 선택합니다. Save 대화상자가 나타나면 설치된 Altium Designer의 로컬 템플릿 폴더로 이동합니다. 이 폴더는 Preferences 대화상자의 데이터 관리 – 템플릿 페이지 하단에 있는 Local Templates folder 필드에 정의되어 있으며, 기본 설치 시에는 C:\Users\Public\Documents\Altium\AD<Version>입니다. 원하는 템플릿 이름을 입력하고 Save as type 드롭다운에서 Altium Draftsman Sheet Templates (*.DwsDot) 또는 Altium Draftsman Document Templates (*.DwfDot)을 선택합니다.

다른 Altium Designer 문서(Schematic, PCB 등)와 마찬가지로 Save As 명령은 프로젝트 구조의 기존 소스 파일(이 경우 Draftsman 도면 문서)을 새로 저장한 파일(Draftsman 템플릿 문서)로 대체합니다. 소스 문서(*.PCBDwf)는 디스크의 프로젝트 폴더에서 삭제되지 않습니다.

더 나은 방법은 Save Copy As 옵션을 사용하는 것입니다. 이 옵션은 소스 문서와 프로젝트 내용을 그대로 유지하면서 지정한 디렉터리에 새 템플릿을 저장합니다.

로컬 Draftsman 템플릿은 Preferences 대화상자의 데이터 관리 – 템플릿 페이지에 있는 Templates 탭에서 Grid의 Local Region에 나열됩니다. 이 영역은 해당 페이지의 Template visibility 옵션이 Server & Local으로 설정된 경우에만 표시됩니다.

AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents