표 작업하기

개요

이 문서에서는 Altium Designer에서 Draftsman 테이블을 배치하고 구성하는 방법을 설명합니다. 특히 자재 명세서(BOM) 테이블을 중심으로, PCB 프로젝트, ActiveBOM, Variant 및 조립 뷰에서 데이터가 직접 제공되는 방식을 자세히 살펴봅니다. 서식 지정, 데이터 소스 선택, 보기 모드, Variant 기반 필터링, 열 관리, 대규모 설계를 위한 여러 페이지 BOM 처리 등 Properties 패널의 주요 설정을 단계별로 안내합니다. Draftsman 문서에서 제작 및 조립 데이터를 정확하고 깔끔하게 표현하는 방법을 더 명확히 이해하고 싶다면, 이 문서에서 제공되는 옵션과 효과적인 활용 방법을 확인해 보세요. PCB 문서를 더욱 체계적으로 관리할 수 있습니다.

- BOM 테이블 데이터의 출처와 Project, Board, Variant, 조립 뷰 등의 옵션이 표시 내용에 미치는 영향을 알아봅니다.
- 제목, 글꼴, 행 색상, 열, 정렬, 별칭 등 BOM 테이블의 모양과 구조를 사용자 지정하는 방법을 살펴봅니다.
- 분할 BOM 테이블의 작동 방식을 이해하고, 대규모 자재 명세서를 여러 테이블 객체와 페이지에 나누어 표시하는 방법을 알아봅니다.
AI로 더 깊이 알아보기:

Draftsman 문서에서는 다양한 데이터 표를 도면에 배치하고 필요에 맞게 구성할 수 있습니다. 표 데이터는 프로젝트 PCB 문서에서 직접 가져오며, PCB 제작 및 조립 공정에 필요한 핵심 정보를 간단하고 시각적으로 전달합니다.

배치할 표 유형은 Place 주 메뉴에서 선택할 수 있습니다.

자재 명세서

Draftsman 자재 명세서(Place » Bill Of Materials)는 PCB 설계의 물리적 조립 항목을 나열하는 자동 생성 표 객체입니다. BOM 표 데이터는 프로젝트의 ActiveBOM 문서에서 직접 가져오며, 현재 프로젝트에 ActiveBOM 문서가 없으면 프로젝트 소스 문서에서 직접 가져옵니다. BOM 표에는 지정된 설계 Variant 또는 배치된 보드 조립 뷰의 구성 항목을 표시할 수도 있습니다.

두 개의 BOM 객체로 분할된 자재 명세서 표입니다. 위 예에서는 상단면 보드 조립 뷰의 항목만 포함하도록 BOM 내용이 필터링되어 있습니다.
두 개의 BOM 객체로 분할된 자재 명세서 표입니다. 위 예에서는 상단면 보드 조립 뷰의 항목만 포함하도록 BOM 내용이 필터링되어 있습니다.

배치된 자재 명세서 표의 시각적 스타일과 포함할 데이터 내용은 설계 공간에서 표를 선택한 상태로 Properties 패널에서 구성할 수 있습니다. 일반적인 표 속성은 패널의 General 탭에서 구성합니다().

제목

제목

표와 함께 표시할 제목 문자열입니다(표시가 활성화된 경우). 연결된 버튼을 사용하여 도면에서 제목의 표시 여부를 전환합니다.

이 필드에는 정적 텍스트와 특수 문자열 형식의 원하는 파라미터를 포함할 수 있습니다. 제목에 파라미터를 포함하려면 =<ParameterName> 구문을 사용합니다. 포함된 파라미터의 값은 도면 시트의 제목에 표시됩니다. 사용 가능한 시스템 및 PCB 파라미터 목록은 Draftsman 문서 설정 페이지를 참조하십시오.

Location 드롭다운에서 제목의 상대적 위치를 선택합니다. 제목을 수동으로 이동하면(새 위치로 드래그 앤 드롭하면) Manual 옵션이 자동으로 선택됩니다.
Font

제목에 사용할 글꼴을 설정합니다.

  •  Use Document Font 옵션을 활성화하면 문서 옵션에 정의된 제목 글꼴이 사용됩니다(설계 공간에서 객체가 선택되지 않은 상태에서 Properties 패널의 General 탭에 있는 General 영역의 Document Font 항목).

  •  Use Document Font 옵션을 비활성화하면 제공되는 옵션을 사용하여 원하는 글꼴 유형, 크기, 색상 및 텍스트 속성을 선택합니다.

속성

Table Line Style

드롭다운을 사용하여 표를 그리는 데 사용할 선을 선택합니다. 사용 가능한 옵션은 설계 공간에서 객체가 선택되지 않은 상태에서 Properties 패널의 Line Styles 영역에 정의됩니다. 자세한 내용은 Draftsman 문서 설정 페이지를 참조하십시오. 연결된 색상 버튼을 사용하여 선 색상을 지정합니다.

Justification 표 크기가 변경될 때 표 위치 변경의 기준이 되는 점을 선택합니다.
Even Row Color 표의 짝수 행에 사용할 대비 색상을 선택합니다.
Non-Even Row Color 표의 홀수 행에 사용할 대비 색상을 선택합니다.
Font

표 데이터 내용에 사용할 글꼴을 설정합니다.

  •  Use Document Font 옵션을 활성화하면 문서 옵션에 정의된 글꼴이 사용됩니다(설계 공간에서 객체가 선택되지 않은 상태에서 Properties 패널의 General 탭에 있는 General 영역의 Document Font 항목).

  •  Use Document Font 옵션을 비활성화하면 제공되는 옵션을 사용하여 원하는 글꼴 유형, 크기, 색상 및 텍스트 속성을 선택합니다.

선택한 글꼴 크기에 맞게 표 크기가 자동으로 조정됩니다.

Data Source 이 옵션과 프로젝트 내 ActiveBOM 문서의 존재 여부에 따라 표에 포함되는 데이터가 결정됩니다.

 

  • Project – 이 옵션을 선택하고 현재 프로젝트에 ActiveBOM 문서가 포함되어 있으면 해당 문서의 구성과 내용이 Draftsman BOM 표의 데이터 소스가 됩니다. ActiveBOM 문서의 실시간 변경 사항을 반영하려면 Draftsman의 Tools » Import Changes From <PCBDocumentName>.PcbDoc 명령을 사용합니다.
    현재 프로젝트에 ActiveBOM 문서가 포함되어 있지 않으면 Draftsman BOM 표의 데이터는 소스 프로젝트 문서에서 직접 가져옵니다.

  • Board – 이 옵션을 선택하면 Draftsman BOM 표의 항목이 실제 프로젝트 PCB에 있는 컴포넌트로 제한됩니다.

Assembly View 드롭다운 메뉴 옵션을 사용하여 나열된 BOM 항목을 지정된 보드 조립 뷰에 표시된 항목으로 필터링합니다.
View Mode
  • Base – 각 고유 컴포넌트 유형에 표의 행 하나가 할당되며, 포함된 모든 항목이 Designator 열에 나열됩니다.

  • Flat – 각 컴포넌트 항목에 표의 행 하나가 할당됩니다.

  • Consolidated – 소스 프로젝트에 Variant가 포함되어 있으면 모든 설계 Variant의 컴포넌트 항목이 표에 포함됩니다. 이 옵션을 선택하면 Variant 옵션이 자동으로 [No Variations](으)로 설정됩니다.

Variant

사용 가능한 경우 드롭다운 메뉴에서 BOM 표의 데이터 소스로 사용할 설계 Variant를 선택합니다. 표에는 Show Components 옵션에 따라 포함되지 않는 항목이나 파라미터가 변경된 항목이 반영됩니다.

Document : <VariantName> 옵션을 Variation(으)로 선택하면 문서에 지정된 Variant가 표에 적용됩니다. 문서 수준의 Variant는 설계 공간에서 객체가 선택되지 않은 상태에서 Properties 패널의 General 탭에 있는 Source 영역의 Variants 드롭다운을 사용하여 선택합니다. 자세한 내용은 Draftsman 문서 설정 페이지를 참조하십시오.

Show Components

Variant를 선택한 경우 드롭다운을 사용하여 목록에 포함할 컴포넌트 항목을 선택합니다.

  • Fitted – 현재 선택한 설계 Variant에서 실장되는 컴포넌트만 표시합니다.

  • All – 모든 컴포넌트를 표시합니다.

  • Not Fitted – 현재 선택한 설계 Variant에서 실장되지 않는 컴포넌트만 표시합니다.

  • Replaced – 현재 선택한 설계 Variant에서 대체 부품이 선택된 컴포넌트 또는 파라미터 값이 변경된 실장 컴포넌트만 표시합니다.

Show Components에 대해 Fitted, Not Fitted 또는 Replaced 옵션을 선택한 BOM 표는 View Mode에 대해 Base 및 Flat 옵션을 선택한 경우에 작동합니다(Consolidated은 해당하지 않음).

페이지i

BOM Table ID BOM 표 인스턴스의 숫자 식별자입니다. 전체 표를 여러 BOM 표 객체(페이지)로 분할할 수 있으며, ID는 공통으로 유지됩니다.
Limit Page Height 이 옵션을 선택하면 BOM 테이블이 Max Page Height 속성에 지정된 높이의 가상 페이지로 나뉩니다.
Max Page Height 테이블의 각 페이지 높이를 설정하며, 이에 따라 각 페이지에 포함되는 행 수가 결정됩니다. 배치된 BOM 테이블 객체에는 한 페이지만 포함되며(아래 Page 참조), 모든 페이지를 표시하려면 BOM 테이블 객체를 추가로 배치해야 합니다.
Page 선택한 BOM 테이블 객체에 표시되는 테이블 페이지 번호(1 from 2, 3 from 5 등)를 나타냅니다. 연결된 드롭다운 메뉴를 사용하여 현재 선택한 BOM 테이블 객체에 표시할 페이지를 지정합니다.
Show Empty Lines 이 옵션을 선택하면 BOM 테이블의 빈 행이 표시됩니다. 일반적으로 지정된 페이지 높이가 사용 가능한 BOM 데이터 행 수를 초과하는 경우 BOM 테이블의 마지막 페이지에 빈 행이 나타납니다.

Properties 패널의 Columns 탭을 사용하여 BOM 테이블의 데이터 열을 관리합니다.

Properties 패널의 Columns 탭에서 배치된 BOM 테이블의 열을 조정합니다.
Properties 패널의 Columns 탭에서 배치된 BOM 테이블의 열을 조정합니다.

  • 항목을 편집하여 BOM 테이블에 포함할 열(표시할 열)과 해당 열의 텍스트 정렬(Align)을 지정할 수 있습니다.

  • Width 항목을 사용하여 열에 포함된 텍스트를 기준으로 열 너비를 정의합니다. 열의 셀 중 가장 긴 텍스트에 맞춰 너비가 동적으로 변경되도록 하려면 Auto을 입력합니다.

  • Order 열 내부를 클릭하여 테이블 열 데이터의 정렬 순서 옵션(해제, 오름차순, 내림차순)을 순환합니다. 여러 열에 우선순위에 따라 정렬을 적용할 수 있으며, 테이블에서 왼쪽에 있는 정렬 대상 열의 우선순위가 더 높습니다.

  • 테이블 열 파라미터 이름에 대한 Alias을 입력하여 BOM 테이블 머리글을 변경할 수 있습니다. 이는 ActiveBOM 문서가 테이블 내용을 결정하지 않는 경우에 적용됩니다(위의 Data Source 참조).

  • 열 유형 필터 확인란을 사용하여 일치하는 파라미터 데이터 유형의 열을 사용 가능한 열 목록에 표시합니다: BOM(), 회로도(), 서버(), PCB(). 모든 유형의 선택을 해제하면 BOM 테이블에 표시되는 열만 나열됩니다.

  • 및  버튼을 사용하여 선택한 항목을 한 단계 위나 아래로 이동합니다. 이에 따라 BOM 테이블의 열 순서에서 왼쪽이나 오른쪽으로 이동합니다. 표시되도록 설정된 열에 사용할 수 있습니다.

  • 버튼을 클릭하여 테이블 열을 기본 항목으로 복원합니다. 기본 항목은 Preferences 대화 상자의 Draftsman – Defaults 페이지에 있는 BOM 테이블 객체의 기본 설정으로 정의됩니다.

BOM 테이블 분할

대부분의 고급 PCB 프로젝트에서는 BOM 항목 수가 많아 도면 문서에 들어가는 테이블로 작성하기 어려울 수 있습니다. 글꼴 및 테이블 크기를 조정하거나, 여러 사용자 지정 테이블 항목 또는 외부 문서를 사용하는 대신 BOM 분할 기능을 사용하면 BOM 테이블을 여러 '페이지'에 걸쳐 표시할 수 있습니다.

여러 페이지로 구성된 BOM 테이블을 만들려면 배치된 BOM(문서 시트 높이를 초과할 가능성이 있는 BOM)을 선택하고 Properties 패널의 Pages 영역에서 Limit Page Height 확인란을 선택합니다. 이렇게 하면 테이블 높이가 지정된 높이 항목(Max Page Height, mm)으로 제한되며, 이에 따라 BOM 테이블에 표시되는 행 수가 제한됩니다.

Javascript ID: Draftsman_BOM_LimitPageHeight

Draftsman은 전체 BOM이 표시되지 않았음을 감지하며, 이는 패널의 Page 항목(예: Page 1 from 2)에 표시됩니다. 연결된 드롭다운 메뉴에서 표시할 페이지를 지정할 수 있습니다. BOM의 추가 페이지(여기서는 BOM Table ID = 0)를 추가하려면 다른 BOM을 배치하고 Properties 패널의 Pages 영역에서 다음 Page을 지정합니다.

BOM 테이블을 추가하고 적절히 구성하는 방식으로 각 BOM 페이지를 배치하므로, 개별 BOM 페이지(섹션)는 Draftsman 문서의 어느 시트에나 배치할 수 있습니다. 또 다른 different 분할 BOM 페이지 세트를 배치하려면 배치된 BOM에 다른 BOM Table ID을 지정합니다. 예를 들어 0 대신 1을 지정합니다.

Max Page Height 속성은 BOM 테이블의 first 페이지 높이를 지정한다는 점에 유의하십시오. 두 번째 페이지(2 페이지)를 선택하면 Max Page Height 속성은 제외되는 첫 번째 페이지(1 페이지)의 높이를 정의합니다. 따라서 2 페이지에는 나머지 BOM 항목이 표시됩니다. 먼저 각 페이지의 Max Page Height 속성을 동일하게 설정하십시오.

드릴 테이블

Draftsman 드릴 테이블(Place » Drill Table)은 기판의 드릴 심볼과 데이터를 포함하는 자동 생성 테이블 객체입니다. 드릴 테이블은 Draftsman의 드릴 도면 뷰와 함께 기판 제작 공정에 필요한 표 형식 및 그래픽 정보를 제공합니다. 지정된 드릴 홀 유형을 나타내는 심볼 행에는 홀 크기, 도금 구조, 홀 개수 등 다양한 홀 정보가 포함될 수 있습니다. 홀 유형은 Drill Symbol Configurations 대화 상자에 지정된 대로 심볼별로 그룹화됩니다.

홀 항목이 크기별로 그룹화된 배치된 드릴 테이블
홀 항목이 크기별로 그룹화된 배치된 드릴 테이블

Altium Designer에 GOST 2.701-2008/2.106-1996 소프트웨어 확장 기능이 설치되어 있으면, 드릴 테이블의 Plated 열 값이 Есть(도금 홀) 및 Нет(비도금 홀)로 표시됩니다. 

확장 기능 관리에 대한 자세한 내용은 Extending Your Installation 페이지(Altium Designer Develop, Altium Designer Agile, Altium Designer)를 참조하십시오.

배치된 드릴 테이블에 사용되는 심볼을 비롯한 시각적 스타일과 데이터 내용은 설계 공간에서 테이블을 선택한 상태로 Properties 패널에서 구성할 수 있습니다. 일반 테이블 속성은 패널의 General 탭()에서 구성합니다.

제목

Title

활성화된 경우 테이블과 함께 표시되는 제목 문자열입니다. 연결된 버튼을 사용하여 도면에서 제목의 표시 여부를 전환합니다.

이 필드에는 고정 텍스트와 특수 문자열 형식의 원하는 파라미터를 포함할 수 있습니다. 제목에 파라미터를 포함하려면 =<ParameterName> 구문을 사용합니다. 포함된 파라미터의 값은 도면 시트의 제목에 표시됩니다. 사용 가능한 시스템 및 PCB 파라미터 목록은 Draftsman 문서 설정 페이지를 참조하십시오.

Location 드롭다운을 선택하여 제목의 다양한 상대 위치 중에서 선택합니다. 제목을 수동으로 이동하면(새 위치로 끌어다 놓으면) Manual 옵션이 자동으로 선택됩니다.
Font

제목에 사용할 글꼴을 설정합니다.

  • Use Document Font 옵션이 활성화되면 제목 글꼴은 문서 옵션에 정의된 글꼴을 사용합니다( General의 Document Font 항목 영역(설계 공간에서 아무 객체도 선택하지 않은 상태의 Properties Panel에 있는 General 탭).

  • Use Document Font 옵션이 비활성화되어 있으면, 제공된 옵션을 사용하여 원하는 글꼴 유형, 크기, 색상 및 텍스트 속성을 선택합니다.

속성

Layer Pairs 도면 뷰에 표시할 PCB 드릴 레이어 쌍의 홀을 선택합니다. 드롭다운 메뉴를 사용하여 원본 보드 설계에서 사용 가능한 레이어 쌍을 선택합니다. 이 레이어 쌍은 PCB 편집기의 Layer Stack Manager에서 확인하고 편집할 수 있습니다. 모든 보드 설계에는 Top - Bottom 레이어 쌍이 있으며, 다른 쌍은 내부/플레인 레이어와 같은 다른 레이어 사이를 통과하거나 해당 레이어까지 이어지는 비아 홀을 나타냅니다.

Counterhole Bottom 및 Counterhole Top 옵션은 PCB 문서에 PCB의 해당 면에서 카운터홀 기능이 활성화된 패드가 포함되어 있는 경우에만 사용할 수 있습니다(자세히 알아보기).

Counterhole Bottom 및 Counterhole Top 이외의 레이어 쌍에서는 카운터홀이 제외됩니다. All Layers 레이어 쌍에서도 카운터홀이 제외됩니다.

Pads / Vias 드롭다운을 사용하여 표에 표시할 드릴 홀 유형(Pads, Vias 또는 All)을 선택합니다.
Plated / Non-Plated 드롭다운을 사용하여 표에 표시할 홀 도금 유형(Plated, Non-Plated 또는 All)을 선택합니다.
Border Line Style

드롭다운을 사용하여 표의 테두리/외곽선을 표시하는 데 사용할 선을 선택합니다. 사용 가능한 옵션은 설계 공간에서 아무 객체도 선택하지 않은 상태의 Properties Panel에 있는 Line Styles 영역에서 정의됩니다. 자세한 내용은 Draftsman 문서 설정 페이지를 참조하십시오. 연결된 색상 버튼을 사용하여 선의 색상을 지정합니다.

Justification 표의 크기가 변경될 때 표의 위치를 변경할 기준점을 선택합니다.
Even Row Color 표의 짝수 행에 사용할 대비 색상을 선택합니다.
Non-Even Row Color 표의 홀수 행에 사용할 대비 색상을 선택합니다.
Font

표의 데이터 내용에 사용할 글꼴을 설정합니다.

  • Use Document Font 옵션이 활성화되어 있으면, 문서 옵션에 정의된 글꼴이 사용됩니다(설계 공간에서 아무 객체도 선택하지 않은 상태의 Properties Panel에 있는 General 탭의 General 영역에 있는 Document Font 항목).

  • Use Document Font 옵션이 비활성화되어 있으면, 제공된 옵션을 사용하여 원하는 글꼴 유형, 크기, 색상 및 텍스트 속성을 선택합니다.

선택한 글꼴 크기에 맞게 표의 크기가 자동으로 조정됩니다.

Show Footer 총 드릴 홀 수를 표시하는 표 바닥글을 활성화하려면 선택합니다.
모든 드릴 홀 데이터를 표 형식으로 표시하고 각 홀 심볼의 스타일과 크기를 설정할 수 있는 Drill Symbol Configurations 대화 상자를 열려면 선택합니다(자세히 알아보기).

단위

Primary Units

표에 표시할 기본 측정 단위 유형을 선택합니다. 연결된  버튼을 사용하여 측정 단위의 표시 여부를 전환합니다.

Primary Units로 Document : <Units> 옵션을 선택하면 문서에 지정된 기본 단위가 표에 적용됩니다. 문서 수준의 기본 단위는 설계 공간에서 아무 객체도 선택하지 않은 상태의 Properties Panel에 있는 General 탭의 Units 영역에 있는 Primary Units 드롭다운을 사용하여 선택합니다. 자세한 내용은 Draftsman 문서 설정 페이지를 참조하십시오.

Dual Units

표에 표시할 보조(이중) 측정 단위 유형을 선택합니다. 연결된  버튼을 사용하여 보조 단위 값의 표시 여부를 전환합니다.

Dual Units로 Document : <Units> 옵션을 선택하면 문서에 지정된 이중 단위가 표에 적용됩니다. 문서 수준의 이중 단위는 설계 공간에서 아무 객체도 선택하지 않은 상태의 Properties Panel에 있는 General 탭의 Units 영역에 있는 Dual Units 드롭다운을 사용하여 선택합니다. 자세한 내용은 Draftsman 문서 설정 페이지를 참조하십시오.

정밀도

Primary Units

Value Precision 드롭다운 메뉴를 사용하여 기본(주) 홀 크기 표 항목의 정밀도(소수점 이하 최대 다섯 자리, 마지막 자리 반올림)를 설정합니다.

Document : <Precision> 옵션을 선택하면 문서에 지정된 기본 단위 값/공차 정밀도가 표에 적용됩니다. 문서 수준의 기본 단위 값 및 공차 정밀도는 설계 공간에서 아무 객체도 선택하지 않은 상태의 Properties Panel에 있는 General 탭의 Units 영역에서 Primary Units에 대한 Value Precision 및 Tolerance Precision 옵션을 사용하여 선택합니다. 자세한 내용은 Draftsman 문서 설정 페이지를 참조하십시오.

Dual Units

Value Precision 드롭다운 메뉴를 사용하여 이중(보조) 홀 크기 항목이 활성화된 경우 해당 항목의 정밀도(소수점 이하 최대 다섯 자리, 마지막 자리 반올림)를 설정합니다.

Document : <Precision> 옵션을 선택하면 문서에 지정된 이중 단위 값/공차 정밀도가 치수에 적용됩니다. 문서 수준의 이중 단위 값 및 공차 정밀도는 설계 공간에서 아무 객체도 선택하지 않은 상태의 Properties Panel에 있는 General 탭의 Units 영역에서 Dual Units에 대한 Value Precision 및 Tolerance Precision 옵션을 사용하여 선택합니다. 자세한 내용은 Draftsman 문서 설정 페이지를 참조하십시오.

Properties Panel의 Columns 탭을 사용하여 드릴 표의 데이터 열()을 관리합니다.

  • 항목을 편집하여 드릴 표에 포함할(표시할) 열과 해당 열의 Horizontal 및 Vertical 정렬을 지정할 수 있습니다.

  • Width 항목을 사용하여 포함된 텍스트를 기준으로 열 너비를 정의합니다. 가장 긴 열 셀 텍스트에 맞게 너비가 동적으로 변경되도록 하려면 Auto 을 입력합니다.

  • Order 열 내부를 클릭하여 표 열 데이터의 정렬 순서 옵션(해제, 오름차순, 내림차순)을 순환합니다. 여러 열에 우선순위에 따라 정렬을 적용할 수 있으며, 표에서 왼쪽에 있는 정렬된 열의 우선순위가 더 높습니다.

  • 표 열 파라미터 이름에 대한 Caption 을 입력하여 드릴 표의 머리글을 변경할 수 있습니다.

  • 및  사용 선택한 Entry를 한 단계 위 또는 아래로 이동하여 드릴 테이블의 열 순서에서 왼쪽 또는 오른쪽으로 이동하는 버튼입니다. 표시되도록 설정된 열에 사용할 수 있습니다.

드릴 테이블의 심볼 스타일과 각 심볼에 해당하는 드릴 홀 유형의 그룹화는 설계 공간에서 테이블을 선택한 상태에서 Properties 패널(General 탭의 Properties 영역)에 있는 버튼을 클릭하여 여는 Drill Symbol Configurations 대화상자의 설정에 따라 결정됩니다.

이 대화상자는 드릴 도면 뷰의 Properties 패널에서 여는 대화상자와 동일하지만, 이 경우에는 드릴 테이블에서 활성화된(표시되도록 설정된) 열만 표시됩니다. 두 버전의 Drill Symbol Configuration 대화상자는 동일한 소스를 사용하므로 서로 영향을 줍니다.

Symbol Graphics 드롭다운을 사용하여 미리 정의된 다양한 도형과 문자 중에서 원하는 홀 표현 그래픽을 선택합니다.
Sync Symbols with PCB 이 옵션을 활성화하면 드릴 테이블의 심볼이 PCB의 심볼과 동기화됩니다.
Symbol Size Table

심볼 테이블의 원하는 크기를 입력합니다.

  • 심볼 크기는 대화상자 상단의 Grid에서 현재 선택된 드릴 심볼에 대해 변경됩니다. Grid에서 여러 드릴 심볼을 선택하려면 Ctrl+Click 또는 Shift+Click 방식을 사용합니다.

  • 또한 링크 아이콘이 연결된 상태()로 표시되면 드릴 도면 뷰와 드릴 테이블 간에 크기가 연동됩니다. 드릴 심볼 크기를 개별적으로 설정하려면 링크 아이콘을 클릭하여 두 크기의 연결을 해제한 다음 각각 원하는 크기로 설정합니다.

Symbol Size View 심볼 뷰의 원하는 크기를 입력합니다. 이 필드에 접근하여 편집하려면 링크 아이콘이 연결 해제 상태()로 표시되어야 합니다. 링크 아이콘을 클릭하여 연결 상태를 전환합니다.
Symbol Line Style

드롭다운을 사용하여 심볼 그래픽의 테두리/외곽선을 그리는 데 사용할 선을 선택합니다. 사용 가능한 옵션은 설계 공간에서 아무 객체도 선택하지 않았을 때 Properties 패널의 Line Styles 영역에 정의됩니다. 자세한 내용은 Draftsman 문서 설정 페이지를 참조하십시오. 관련 색상 버튼을 사용하여 선 색상을 지정합니다.

Grouping 선택한 기준에 따라 항목들이 하나의 심볼로 그룹화됩니다. 예를 들어 HoleSize 만 선택하면 PCB에 사용된 각 홀 크기마다 개별 심볼이 할당됩니다. 그룹화 옵션을 추가로 선택하면 더 세분화된 그룹화 체계가 생성되어 추가 기준에 따라 심볼이 구분되어 할당됩니다.

Preferences 대화상자의 Draftsman – Defaults 페이지에서 Symbol Size Table, Symbol Size View, Symbol Line Style, Grouping의 기본 설정을 정의할 수 있습니다. 이 페이지의 Primitive List에서 Drill Table을 선택하고 오른쪽 속성 영역에서 Drill Symbol 탭을 엽니다().

전송선 테이블

임피던스 제어 라우팅에 적용되는 계산은 타겟 전송선 임피던스와 그에 따른 기판 설계의 고속 및/또는 EMF 요구사항을 충족하도록 Trace 구조를 도출합니다. 기판 레이어와 해당 레이어에 지정되거나 계산된 속성은 Layer Stack Manager에서 확인할 수 있으며, 여기에서 임피던스 제어 라우팅 레이어를 정의 가능한 임피던스 프로파일과 연결합니다. 각 프로파일의 기판 재료와 치수는 전송선 임피던스 계산에 적용되어 특정 Trace 구조를 도출합니다. 이 구조는 싱글 Trace와 차동 쌍을 모두 지원하며, 스트립라인(내부) 또는 마이크로스트립(표면) 기판 레이어 형식을 지원합니다.

임피던스 프로파일 구성에 대한 자세한 내용은 레이어 스택 정의 페이지를 참조하십시오.

기판 레이어 스택에 정의된 각 전송선의 구조 및 관련 데이터는 PCB 제조 공정에 중요한 정보이므로, Draftsman은 이 정보를 문서화하기 위한 전용 전송선 테이블 객체(Place » Transmission Line Table)를 제공합니다. 이 테이블은 Layer Stack Manager와 해당 전송선 임피던스 계산에서 가져온 데이터로 채워집니다.

배치된 전송선 테이블
배치된 전송선 테이블

배치된 전송선 테이블의 시각적 스타일과 데이터 내용은 설계 공간에서 테이블을 선택한 상태에서 Properties 패널을 통해 구성할 수 있습니다. 일반 테이블 속성은 패널의 General 탭에서 구성합니다().

제목

Title

활성화된 경우 테이블과 함께 표시되는 제목 문자열입니다. 관련 버튼을 사용하여 도면에서 제목 표시 여부를 전환합니다.

이 필드에는 정적 텍스트와 특수 문자열 형식의 원하는 파라미터를 포함할 수 있습니다. 제목에 파라미터를 포함하려면 =<ParameterName> 구문을 사용합니다. 포함된 파라미터의 값은 도면 시트의 제목에 표시됩니다. 사용 가능한 시스템 및 PCB 파라미터 목록은 Draftsman 문서 설정 페이지를 참조하십시오.

Location 드롭다운에서 제목의 다양한 상대 위치 중 하나를 선택합니다. 제목을 수동으로 이동하면(새 위치로 끌어서 놓으면) Manual 옵션이 자동으로 선택됩니다.
Font

제목에 사용할 글꼴을 설정합니다.

  • Use Document Font 옵션이 활성화되어 있으면 문서 옵션에 정의된 글꼴이 제목에 사용됩니다(설계 공간에서 아무 객체도 선택하지 않았을 때 Properties 패널의 General 탭에 있는 General 영역의 Document Font Entry).

  • Use Document Font 옵션이 비활성화되어 있으면 제공된 옵션을 사용하여 원하는 글꼴 유형, 크기, 색상 및 텍스트 속성을 선택합니다.

속성

Table Line Style

드롭다운을 사용하여 테이블의 선을 그리는 데 사용할 선을 선택합니다. 사용 가능한 옵션은 설계 공간에서 아무 객체도 선택하지 않았을 때 Properties 패널의 Line Styles 영역에 정의됩니다. 자세한 내용은 Draftsman 문서 설정 페이지를 참조하십시오. 관련 색상 버튼을 사용하여 선 색상을 지정합니다.

Justification 테이블 크기가 변경될 때 테이블 위치를 변경하는 기준점을 선택합니다.
Even Row Color 테이블의 짝수 행에 사용할 대비 색상을 선택합니다.
Non-Even Row Color 테이블의 홀수 행에 사용할 대비 색상을 선택합니다.
Caption Font

테이블 데이터 내용에 사용할 글꼴을 설정합니다.

  • Use Document Font 옵션이 활성화되어 있으면 문서 옵션에 정의된 글꼴이 사용됩니다(설계 공간에서 아무 객체도 선택하지 않았을 때 Properties 패널의 General 탭에 있는 General 영역의 Document Font Entry).

  • Use Document Font 옵션이  옵션이 비활성화되어 있으면, 제공된 옵션을 사용하여 원하는 글꼴 종류, 크기, 색상 및 텍스트 속성을 선택합니다.

선택한 글꼴 크기에 맞춰 표의 크기가 자동으로 조정됩니다.

Rows Font

표 본문(표 행의 텍스트)에 사용할 글꼴을 설정합니다.

  • Use Document Font 옵션이 활성화되어 있으면, 문서 옵션에 정의된 글꼴이 사용됩니다(설계 공간에서 아무 객체도 선택하지 않았을 때 Properties Panel의 General 탭에 있는 General Region의 Document Font Entry).

  • Use Document Font 옵션이 비활성화되어 있으면, 제공된 옵션을 사용하여 원하는 글꼴 종류, 크기, 색상 및 텍스트 속성을 선택합니다.

선택한 글꼴 크기에 맞춰 표의 크기가 자동으로 조정됩니다.

단위

Primary Units

표에 표시할 기본 측정 단위 유형을 선택합니다. 관련  버튼을 사용하여 측정 단위의 표시 여부를 전환합니다.

Document : <Units> 옵션을 선택하면 문서에 지정된 기본 단위가 표에 적용됩니다. 문서 수준의 기본 단위는 설계 공간에서 아무 객체도 선택하지 않았을 때 Properties Panel의 General 탭에 있는 Units Region의 Units 드롭다운에서 선택합니다. 자세한 내용은 Draftsman 문서 설정 페이지를 참조하십시오.

Primary Precision

기본 단위 값의 정밀도(소수점 이하 최대 5자리, 마지막 자리는 반올림)를 선택합니다.

Document : <Precision> 옵션을 선택하면 문서에 지정된 기본 단위 값/공차 정밀도가 표에 적용됩니다. 문서 수준의 기본 단위 값 및 공차 정밀도는 설계 공간에서 아무 객체도 선택하지 않았을 때 Properties Panel의 General 탭에 있는 Units Region에서 Primary Units에 대한 Value Precision 및 Tolerance Precision 옵션을 사용하여 선택합니다. 자세한 내용은 Draftsman 문서 설정 페이지를 참조하십시오.

Dual Units

표에 표시할 보조(이중) 측정 단위 유형을 선택합니다. 관련  버튼을 사용하여 보조 단위 값의 표시 여부를 전환합니다.

Document : <Units> 옵션을 선택하면 문서에 지정된 이중 단위가 표에 적용됩니다. 문서 수준의 이중 단위는 설계 공간에서 아무 객체도 선택하지 않았을 때 Properties Panel의 General 탭에 있는 Units Region의 Dual_Units 드롭다운에서 선택합니다. 자세한 내용은 Draftsman 문서 설정 페이지를 참조하십시오.

Dual Precision

보조 단위가 활성화된 경우, 보조 단위 값의 정밀도(소수점 이하 최대 5자리, 마지막 자리는 반올림)를 선택합니다.

Document : <Precision> 옵션을 선택하면 문서에 지정된 이중 단위 값/공차 정밀도가 치수에 적용됩니다. 문서 수준의 이중 단위 값 및 공차 정밀도는 설계 공간에서 아무 객체도 선택하지 않았을 때 Properties Panel의 General 탭에 있는 Units Region에서 Dual Units에 대한 Value Precision 및 Tolerance Precision 옵션을 사용하여 선택합니다. 자세한 내용은 Draftsman 문서 설정 페이지를 참조하십시오.

Properties Panel의 Columns 탭을 사용하여 전송선의 데이터 열과 행을 관리합니다 ().

  • Columns Region에는 표에 포함된 열 목록이 표시됩니다. 각 열 Entry는 표시 여부를 전환하거나, 제목을 변경하거나(Caption), 텍스트 정렬 옵션을 차례로 전환하거나(Align), 열 너비를 특정 값 또는 자동으로 설정하여(Width) 편집할 수 있습니다. 관련  및  버튼으로 선택한 열 Entry의 위치를 이동하여 목록 Entry의 순서, 즉 배치된 표의 열 순서를 변경할 수 있습니다.

  • Rows Region에는 소스 레이어 스택의 명명된 보드 레이어에 해당하는 Impedance Id 열을 기준으로 정렬된 표의 행 데이터 목록이 표시됩니다. 각 행 Entry에 연결된 표시 제어를 사용하여 표에서 해당 행의 표시 여부를 전환합니다.

표

Draftsman 문서에서는 도면에 일반 표를 배치한 후 Properties Panel과 표 셀 자체에서 구성할 수 있습니다. Custom 표의 레이아웃과 내용은 용도에 따라 자유롭게 정의할 수 있으므로, 모든 Draftsman 문서에 추가 정보를 유연하게 포함할 수 있습니다.

다양한 셀 서식이 적용된 표
다양한 셀 서식이 적용된 표

  • 표 속성에서 사용할 수 있는 옵션과 표 명령을 함께 사용하면 Draftsman 문서의 다양한 정보 요구 사항에 맞는 Custom 표를 만들 수 있습니다. 예를 들어 아래 표는 보드 스택 보고서의 정보를 표시하도록 구성되었습니다.

    Custom 표는 다양한 PCB 조립 및 제조 정보를 담도록 구성할 수 있습니다.
    Custom 표는 다양한 PCB 조립 및 제조 정보를 담도록 구성할 수 있습니다.

  • 표는 시트 템플릿과 문서 템플릿 모두에 포함할 수 있습니다.

표 배치 명령 (Place » Table)을 실행하면 Insert table 대화 상자가 열리며, 여기서 새 표의 행과 열 수를 지정할 수 있습니다. Insert table 대화 상자에서 OK을 클릭하면 새 표가 커서에 연결되며, 원하는 위치를 한 번 더 클릭하여 배치할 수 있습니다.

표의 행과 열에 포함할 셀 수를 지정합니다. 이 값은 나중에 셀을 마우스 오른쪽 버튼으로 클릭하여 표시되는 Table 명령으로 수정할 수 있습니다.
표의 행과 열에 포함할 셀 수를 지정합니다. 이 값은 나중에 셀을 마우스 오른쪽 버튼으로 클릭하여 표시되는 Table 명령으로 수정할 수 있습니다.

배치된 표의 위치는 설계 공간에서 표 객체를 선택한 후 이동 핸들, 즉 왼쪽 위 모서리의  아이콘을 사용하여 새 위치로 드래그하는 방식으로 변경할 수 있습니다.

선택한 표의 이동 아이콘을 드래그하여 설계 공간에서 위치를 변경합니다.
선택한 표의 이동 아이콘을 드래그하여 설계 공간에서 위치를 변경합니다.

셀이나 표 제목을 클릭하면 표 객체가 선택됩니다. 그러나 Delete 명령은 클릭한 특정 요소에 적용됩니다. 

표에 추가할 내용은 셀에 직접 입력하거나 붙여넣습니다. 셀 내에서 줄을 바꾸려면 Ctrl+Enter을 사용합니다.

설계 공간에서 표를 선택하면 Properties Panel에서 표의 그래픽 및 텍스트 속성을 정의할 수 있습니다(). 표 객체는 다양한 텍스트 및 구조 편집 기능을 제공하며, 표준 Shift+Click 또는 Click, Hold&Drag를 사용하여 셀의 행 또는 열 단위로 적용할 수 있습니다. 기법.

제목

Title

표와 함께 표시되는 제목 문자열입니다(활성화된 경우). 연결된 버튼을 사용하여 도면에서 제목 표시 여부를 전환합니다.

이 필드에는 정적 텍스트와 원하는 파라미터를 특수 문자열 형식으로 포함할 수 있습니다. =<ParameterName> 구문을 사용하여 제목에 파라미터를 포함합니다. 포함된 파라미터의 값은 도면 시트의 제목에 표시됩니다. 사용 가능한 시스템 및 PCB 파라미터 목록은 Draftsman 문서 설정 페이지를 참조하세요.

Location 드롭다운에서 제목의 상대 위치를 선택합니다. 제목을 수동으로 이동하면(새 위치로 드래그 앤 드롭하면) Manual 옵션이 자동으로 선택됩니다.
Font

제목에 사용할 글꼴을 설정합니다.

  •  Use Document Font 옵션을 활성화하면 문서 옵션에 정의된 글꼴이 제목에 사용됩니다(설계 공간에서 아무 객체도 선택하지 않았을 때 Properties 패널의 General 탭에 있는 General 영역의 Document Font 항목).

  •  Use Document Font 옵션을 비활성화하면 제공되는 옵션을 사용하여 원하는 글꼴 종류, 크기, 색상 및 텍스트 속성을 선택합니다.

속성

외곽선

드롭다운을 사용하여 표의 테두리/외곽선을 표시하는 데 사용할 선을 선택합니다. 사용 가능한 옵션은 설계 공간에서 아무 객체도 선택하지 않았을 때 Properties 패널의 Line Styles 영역에 정의되어 있습니다. 자세한 내용은 Draftsman 문서 설정 페이지를 참조하세요. 연결된 색상 버튼을 사용하여 선 색상을 지정합니다.

Inner Line 드롭다운을 사용하여 표의 셀을 구분하는 내부 선을 표시하는 데 사용할 선을 선택합니다. 사용 가능한 옵션은 설계 공간에서 아무 객체도 선택하지 않았을 때 Properties 패널의 Line Styles 영역에 정의되어 있습니다. 자세한 내용은 Draftsman 문서 설정 페이지를 참조하세요. 연결된 색상 버튼을 사용하여 선 색상을 지정합니다.
Column Width

선택한 셀의 너비를 설정하며, 이에 따라 해당 셀이 포함된 열의 너비도 설정됩니다. 표의 외곽선이나 제목을 클릭하여 표 전체를 선택하면 너비 설정이 모든 셀에 적용됩니다. 연결된 색상 버튼을 사용하여 현재 선택한 셀의 색상을 지정합니다.

Row Height 이 필드를 사용하여 설계 공간에서 선택한 행의 높이를 조정합니다. 원하는 높이를 입력한 다음 영국식 또는 미터법 단위를 입력합니다.
Cell Padding Vertical 선택한 셀에서 텍스트 위아래의 여백을 설정합니다.
Cell Padding Horizontal 선택한 셀에서 텍스트 좌우의 여백을 설정합니다.
Font

선택한 셀의 텍스트에 사용할 글꼴을 설정합니다.

  •  Use Document Font 옵션을 활성화하면 문서 옵션에 정의된 글꼴이 사용됩니다(설계 공간에서 아무 객체도 선택하지 않았을 때 Properties 패널의 General 탭에 있는 General 영역의 Document Font 항목).

  •  Use Document Font 옵션을 비활성화하면 제공되는 옵션을 사용하여 원하는 글꼴 종류, 크기, 색상 및 텍스트 속성을 선택합니다.

선택한 글꼴 크기에 맞게 표의 크기가 자동으로 조정됩니다.

Alignment 버튼을 사용하여 선택한 셀의 텍스트 정렬 및 위치를 Horizontal (왼쪽, 가운데 또는 오른쪽) 및 Vertical (위쪽, 가운데 또는 아래쪽)으로 설정합니다.
Justification 표의 크기가 변경될 때 표의 위치를 변경하는 기준점을 선택합니다.

표 셀의 특수 문자열

표에는 Draftsman 문서 파라미터를 특수 문자열로 포함할 수 있습니다. 프로젝트 파라미터(로컬 및 워크스페이스 측 파라미터 모두), 시스템 파라미터, PCB 파라미터 및 사용자 파라미터를 표 셀에 특수 문자열로 입력하면 해당 값으로 변환됩니다. 설계 공간에서 아무 객체도 선택하지 않았을 때 Properties 패널의 Parameters 탭에서 Draftsman 문서 파라미터에 액세스할 수 있습니다. 자세한 내용은 Draftsman 문서 설정 페이지를 참조하세요.

표의 파라미터 문자열 처리 기능에는 표준 복사/붙여넣기 기법을 사용하여 스프레드시트와 특수 문자열 데이터를 올바르게 주고받는 기능도 포함됩니다.

  • Draftsman에서 스프레드시트로 특수 문자열을 붙여넣으면 대상 스프레드시트 셀에 해당 문자열을 해석한 값이 입력됩니다.

  • 스프레드시트에서 Draftsman으로 특수 문자열 데이터를 붙여넣으면, 해당 특수 문자열이 사용 가능한 시스템, 프로젝트 또는 사용자 파라미터와 일치하는 경우 붙여넣은 텍스트가 특수 문자열 값으로 해석됩니다.

    스프레드시트에서 특수 문자열 항목을 작성할 때는 셀 내용이 텍스트 데이터로 처리되도록 각 입력값 앞에 작은따옴표(')를 붙여야 합니다. 예를 들어 Units 파라미터의 특수 문자열은 '=DocumentUnits로 입력합니다. 또는 모든 스프레드시트 셀의 형식을 텍스트로 설정할 수도 있습니다.

표 구조

셀을 마우스 오른쪽 버튼으로 클릭하고 상황에 맞는 메뉴에서 Table 메뉴를 선택하면 셀 구성 명령에 액세스할 수 있습니다. 이러한 명령은 열/행 추가 및 제거, 셀 병합을 위한 다양한 표 편집 기능을 제공합니다.

마우스 오른쪽 버튼 클릭 메뉴의 Table 명령은 다양한 표준 표 편집 기능을 제공합니다.
마우스 오른쪽 버튼 클릭 메뉴의 Table 명령은 다양한 표준 표 편집 기능을 제공합니다.

  • Merge Cells 명령은 표에서 연속된 셀이 두 개 이상 선택된 경우에만 사용할 수 있습니다.

    • 셀을 병합할 때 선택한 셀에 텍스트가 있으면 병합 후에는 가장 왼쪽/위쪽 셀(해당하는 경우)의 텍스트만 병합된 셀에 남습니다.

  • Unmerge Cells 명령은 커서가 표의 병합된 셀 안에 있거나, 선택한 셀 범위에 병합된 셀이 하나 이상 포함된 경우에만 사용할 수 있습니다.

    • 셀에 텍스트가 있는 경우 병합을 해제하면 해당 텍스트는 가장 왼쪽/위쪽 셀(해당하는 경우)에 표시됩니다.

    • 셀 병합을 해제할 때 선택한 셀 범위에 병합된 셀이 여러 개 포함되어 있으면, 이 명령은 가장 왼쪽/위쪽의 병합된 셀에만 적용됩니다(병합 해제).

AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents