Draftsman 편집기 단축키
개요
- 편집, 선택, 이동, 확대/축소, 그리드 제어 등 일상적인 작업에 사용하는 Draftsman 전용 단축키를 알아보세요.
- 항상 사용할 수 있는 단축키와 객체 배치 또는 이동 같은 대화형 작업 중에만 사용할 수 있는 단축키를 구분해 보세요.
- Draftsman 편집기에서 작업을 간소화하는 데 도움이 되는 팝업 메뉴 및 서식 지정용 빠른 접근 키를 찾아보세요.
다음 섹션에서는 Draftsman Editor 전용 단축키를 소개합니다. 단축키 접근 및 편집, 일반적인 Altium 환경 단축키, 액셀러레이터 키를 비롯한 단축키 관련 일반 정보는 Altium Designer 단축키를 참조하세요.
단축키 목록을 볼 때 다음 사항에 유의하세요.
-
단축키에서 더하기(+) 기호는 표시된 순서대로 키보드의 여러 키를 누른 상태로 유지하는 것을 의미합니다. 예를 들어,
Shift+F1는Shift키를 누른 상태에서F1키를 누르는 것을 의미합니다. 마찬가지로Shift+Ctrl+PgUp는Shift키를 누른 상태에서Ctrl키도 함께 누른 다음PgUp키를 누르는 것을 의미합니다. -
표준 마우스 버튼을 사용하는 경우,
Click는 마우스 왼쪽 버튼을 한 번 클릭하는 것을,Double-Click는 마우스 왼쪽 버튼을 두 번 클릭하는 것을,Right-Click는 마우스 오른쪽 버튼을 한 번 클릭하는 것을 의미합니다.
표준 단축키
다음은 Draftsman Editor의 표준 단축키입니다. 일반적으로 사용할 수 있으며, 대화형 작업을 수행 중이지 않아도 사용할 수 있습니다.
일반 편집 |
|
Double-Click |
현재 커서 아래에 있는 객체의 속성을 수정합니다. |
Right-Click |
설계 공간의 컨텍스트 메뉴를 엽니다. 현재 대화형 명령을 실행 중이면 현재 작업을 종료합니다. |
Ctrl+C |
선택 항목을 복사합니다. |
Ctrl+X |
선택 항목을 잘라냅니다. |
Ctrl+V |
선택 항목을 Paste합니다. |
Delete |
선택 항목을 삭제합니다. |
Ctrl+Z |
실행을 취소합니다. |
Ctrl+Y |
다시 실행합니다. |
선택 |
|
Click |
현재 커서 아래에 있는 객체를 선택합니다. |
Shift+Click |
객체 위에서 사용하면 해당 객체를 현재 선택 항목에 추가합니다(누적 선택). |
Ctrl+A |
현재 문서의 모든 객체를 선택합니다. |
Click (객체가 없는 곳에서), Hold&Drag (왼쪽에서 오른쪽으로) |
선택 영역의 경계 안에 완전히 포함된 모든 객체를 선택합니다. |
Click (객체가 없는 곳에서), Hold&Drag (오른쪽에서 왼쪽으로) |
선택 영역 안에 완전히 포함되거나 영역의 경계에 닿는 모든 객체를 선택합니다. |
Shift+Tab |
보드 어셈블리 뷰에서 컴포넌트와 그 위에 겹쳐 있는 Designator 사이에서 선택 대상을 전환합니다. |
이동 |
|
Click (객체 위에서), Hold&Drag |
현재 커서 아래에 있는 싱글 객체를 이동합니다. 해당 객체가 선택 항목에 포함된 경우에는 선택한 객체 그룹을 이동합니다. |
Left Arrow |
현재 문서의 설계 공간에서 현재 선택 항목(선택된 하나 이상의 설계 객체)을 왼쪽으로 Snap Grid 1단위씩 이동합니다. |
Shift+Left Arrow |
현재 문서의 설계 공간에서 현재 선택 항목(선택된 하나 이상의 설계 객체)을 왼쪽으로 Snap Grid 10단위씩 이동합니다. |
Right Arrow |
현재 문서의 설계 공간에서 현재 선택 항목(선택된 하나 이상의 설계 객체)을 오른쪽으로 Snap Grid 1단위씩 이동합니다. |
Shift+Right Arrow |
현재 문서의 설계 공간에서 현재 선택 항목(선택된 하나 이상의 설계 객체)을 오른쪽으로 Snap Grid 10단위씩 이동합니다. |
Up Arrow |
현재 문서의 설계 공간에서 현재 선택 항목(선택된 하나 이상의 설계 객체)을 위쪽으로 Snap Grid 1단위씩 이동합니다. |
Shift+Up Arrow |
현재 문서의 설계 공간에서 현재 선택 항목(선택된 하나 이상의 설계 객체)을 위쪽으로 Snap Grid 10단위씩 이동합니다. |
Down Arrow |
현재 문서의 설계 공간에서 현재 선택 항목(선택된 하나 이상의 설계 객체)을 아래쪽으로 Snap Grid 1단위씩 이동합니다. |
Shift+Down Arrow |
현재 문서의 설계 공간에서 현재 선택 항목(선택된 하나 이상의 설계 객체)을 아래쪽으로 Snap Grid 10단위씩 이동합니다. |
Draftsman 시트 보기 |
|
Ctrl+PgDn |
가능한 경우 활성 Draftsman 문서 전체가 보이도록 설계 공간의 보기를 변경합니다. 문서에 여러 시트가 포함된 경우, 특히 시트 수가 매우 많으면 문서 전체를 화면에 맞추지 못할 수 있습니다. 이 경우 소프트웨어는 문서의 중심을 설계 공간의 중심에 두고 가능한 한 많은 부분이 표시되도록 조정합니다. |
PgUp |
현재 커서 위치를 기준으로 확대합니다. 다음 방법 중 하나로 마우스를 사용하여 문서의 특정 Region을 확대할 수도 있습니다(사용 가능 여부 및 마우스 버튼 할당 설정에 따라 다름).
|
PgDn |
현재 커서 위치를 기준으로 축소합니다. 다음 방법 중 하나로 마우스를 사용하여 문서의 특정 Region을 축소할 수 있습니다(사용 가능 여부 및 마우스 버튼 할당 설정에 따라 다름).
|
Mouse Wheel |
설계 공간 내에서 세로로 스크롤합니다. 이는 Default 설정이며, Preferences 대화 상자의 System – Mouse Wheel Configuration 페이지에서 변경할 수 있습니다. |
Shift+Mouse Wheel |
설계 공간 내에서 가로로 스크롤합니다. 이는 Default 설정이며, Preferences 대화 상자의 System – Mouse Wheel Configuration 페이지에서 변경할 수 있습니다. |
Right-Click, Hold&Drag |
슬라이더(화면 이동) 손 모양 커서를 표시한 다음 드래그하여 설계 공간의 보기를 이동합니다. |
Grid |
|
G |
Snap Grid 대화 상자를 열어 필요한 Grid 크기를 설정합니다. |
Shift+Ctrl+G |
현재 문서에서 Grid 표시를 켜거나 끕니다. |
Ctrl+Shift |
객체를 배치하거나 이동할 때 Grid를 일시적으로 비활성화합니다. |
Shift+E |
Snap 기능을 켜거나 끕니다. |
텍스트 찾기 |
|
Ctrl+F |
텍스트를 찾습니다. |
F3 |
검색한 텍스트의 다음 일치 항목을 찾습니다. |
기타 |
|
Shift+Ctrl+C |
현재 선택한 텍스트 객체(제목 또는 메모)의 서식을 복사합니다. 또는 서식을 복사할 텍스트 객체를 선택하고 기본 Edit 메뉴에서 Format Painter 명령을 실행합니다. |
Shift+Ctrl+V |
이전에 선택한 텍스트 객체에서 복사한 서식을 현재 선택한 텍스트 객체(제목 또는 메모)에 Paste합니다. 또는 기본 Edit 메뉴에서 Format Painter 명령을 실행한 경우, 추가로 서식을 적용할 각 제목/메모 객체를 클릭하기만 하면 '복사한' 서식이 적용됩니다. |
F11 |
Properties Panel의 표시 여부를 전환합니다. |
대화형 단축키
다음 단축키는 새 설계 객체 배치나 기존 객체 이동과 같은 대화형 작업을 시작하면 사용할 수 있습니다. 사용 가능한 단축키는 대화형 명령과 해당 명령의 대상이 되는 특정 설계 객체에 따라 달라집니다.
PgUp |
확대합니다. |
PgDn |
축소합니다. |
X |
이동 중인 객체를 X축을 기준으로 Mirror합니다. |
Y |
이동 중인 객체를 Y축을 기준으로 Mirror합니다. |
Esc |
현재 실행 중인 대화형 명령의 단계 또는 명령 자체를 종료합니다. |
Spacebar |
이동 중인 객체를 시계 반대 방향으로 회전합니다. 회전은 90° 단위로 이루어집니다. |
Shift+Spacebar |
이동 중인 객체를 시계 방향으로 회전합니다. 회전은 90° 단위로 이루어집니다. |
Backspace |
Region을 배치하는 동안 마지막으로 배치한 세그먼트를 제거합니다. |
팝업 메뉴 단축키
다음 단축키를 사용하면 설계 공간 내에서 특정 명령의 팝업 메뉴에 직접 액세스할 수 있습니다. 이 중 일부는 Editor의 기본 메뉴에 있는 하위 메뉴이므로 익숙할 것입니다. 각 기본 메뉴에도 설계 공간 내에서 빠르게 액세스할 수 있는 팝업 키가 지정되어 있습니다. 자세한 내용은 액셀러레이터 키를 참조하세요.
B |
Toolbars 하위 메뉴 (기본 보기 메뉴에 있음). |
K |
Panels 하위 메뉴 (기본 보기 메뉴에 있음). |
M |
이동 명령의 팝업 메뉴입니다. |
S |
Select 하위 메뉴 (기본 Edit 메뉴에 있음). |
Z |
확대/축소 명령이 포함된 팝업 메뉴입니다. |