논리 시스템 설계 캡처

개요

Altium Designer에서 하위 PCB 프로젝트를 멀티보드 Schematic의 모듈에 연결하여 멀티보드 시스템의 Logical 설계를 표현하는 방법을 알아보세요. 이 문서에서는 시스템 수준의 연결을 위해 커넥터를 준비하고, 모듈 소스와 속성을 정의하며, 커넥터 핀 및 Net 데이터를 Import하여 모듈 엔트리를 채우는 방법을 설명합니다. 계속 읽고 시스템의 보드 간 연결을 명확하게 표현해 보세요.

- 멀티보드 Schematic을 생성하고 모듈을 하위 PCB 프로젝트에 연결하는 단계를 이해합니다.
- `System:Connector` 파라미터가 시스템 수준의 설계에 포함할 커넥터를 식별하는 방식을 알아봅니다.
- 하위 PCB 프로젝트를 검증하고 해당 연결 데이터를 모듈 엔트리로 Import하는 방법을 살펴봅니다.
AI로 더 깊이 알아보기:

하위 PCB 프로젝트 설계에서 멀티보드 시스템 Schematic 설계를 생성하는 필수 단계는 다음과 같습니다.

  1. 멀티보드 설계 프로젝트를 생성하고 프로젝트에 멀티보드 Schematic 문서를 추가합니다.

  2. 멀티보드 Schematic에 그래픽 블록(모듈)을 배치하여 하위 PCB 프로젝트를 논리적으로 나타냅니다.

  3. 각 모듈을 해당 하위 프로젝트에 연결합니다.

  4. 하위 프로젝트의 연결 데이터를 멀티보드 설계로 Import합니다.

  5. 모듈 사이에 연결을 추가하여 논리적 시스템 설계를 생성합니다.

멀티보드 설계 프로젝트에 멀티보드 Schematic 문서(*.MbsDoc)를 추가하려면 Projects Panel에서 프로젝트 Entry를 마우스 오른쪽 버튼으로 클릭한 다음 컨텍스트 메뉴에서 Add New to Project » Multi-board Schematic 을 선택합니다.

각 멀티보드 설계 프로젝트에는 멀티보드 Schematic 문서를 하나만 포함할 수 있습니다.

멀티보드 설계에 사용할 PCB 프로젝트 설정하기

멀티보드 설계에서 하위 보드 설계를 나타내는 Altium Designer PCB 프로젝트에는 에지 커넥터나 헤더 플러그/소켓과 같은 특정 연결부가 포함됩니다. 이러한 연결부는 시스템 설계 내 다른 PCB와의 전기적 및 물리적 인터페이스 역할을 합니다.

시스템 수준 설계에서 보드 간 연결을 설정하려면 멀티보드 Schematic(논리적) 설계 문서가 이러한 연결부와 관련 전기적 네트를 감지하고 처리해야 합니다. 이 기능은 PCB 프로젝트 커넥터에 특정 컴포넌트 파라미터가 있을 때 활성화됩니다. 이 파라미터의 이름은 System이며, 파라미터 값은 Connector입니다.

System:Connector 파라미터:값을 갖는 커넥터는 Import from Child Projects 명령을 사용하여 각 시스템 수준 모듈을 하위 PCB 프로젝트와 동기화할 때 감지됩니다. 이에 대한 설명은 뒤에 나오는 멀티보드 Schematic에서 하위 PCB 프로젝트 표현하기 섹션을 참조하십시오.

PCB 프로젝트 설계에서 시스템 수준 상호 연결에 사용할 각 커넥터에 대해 커넥터 부품을 선택한 다음, 컴포넌트가 선택된 상태에서 Properties Panel의 General 탭 아래 Parameters Region에 있는 목록에 특수 컴포넌트 파라미터를 추가합니다.

컴포넌트 속성에 대한 자세한 내용은 배치된 컴포넌트 작업하기 페이지를 참조하십시오.

이름이 System이고 값이 Connector인 파라미터가 있으면 이 PCB 커넥터가 멀티보드 Schematic에 연결됩니다.
이름이 System이고 값이 Connector인 파라미터가 있으면 이 PCB 커넥터가 멀티보드 Schematic에 연결됩니다.

멀티보드 Schematic에서 하위 프로젝트 표현하기

멀티보드 설계를 구성하는 PCB 프로젝트 간의 연결은 Schematic에 각 프로젝트를 나타내는 블록(모듈)을 배치하고, 외부에 노출된 커넥터(모듈 Entry)를 연결 요소로 서로 연결하여 설정합니다.

하위 PCB 프로젝트 설계와 그 안의 특정 PCB를 나타내는 모듈은 Place » Module 메뉴에서 설계 공간에 배치합니다.

배치된 모듈의 소스를 정의하려면 설계 공간에서 해당 모듈을 선택하고, Properties Panel의 General 탭 아래 Source Region에서 Project 필드와 연결된  버튼을 사용하여 Choose Project 대화상자(프로젝트 열기 대화상자의 한 형태)를 엽니다. 이 대화상자에서 PCB 또는 멀티보드 프로젝트를 찾아 모듈의 소스로 선택할 수 있습니다. 필요한 프로젝트를 선택한 후에는 Assembly/Board 드롭다운에서 해당 프로젝트 내의 원하는 PCB 보드 설계 / 멀티보드 어셈블리를 선택합니다.

구성이 완료된 멀티보드 프로젝트는 소스 문서와 Schematic 시스템 설계의 모듈에 연결된 하위 프로젝트를 포함하는 계층적 문서 구조를 갖습니다. 시스템 설계 모듈이 외부 프로젝트에 연결되면 해당 하위 프로젝트의 구조가 멀티보드 프로젝트에 즉시 추가됩니다. Projects Panel에서 프로젝트 구조를 확장하면 멀티보드 프로젝트와 하위 프로젝트를 구성하는 파일을 확인할 수 있습니다.

멀티보드 프로젝트가 하위 프로젝트에서 올바른 데이터를 추출하고 처리하도록 하려면 각 프로젝트의 PCB가 해당 Schematic과 동기화되어 있어야 하며, 설계 또는 도면 작성 오류가 없어야 합니다. PCB 하위 프로젝트를 검증하려면 Panel에서 해당 이름을 마우스 오른쪽 버튼으로 클릭하고 Validate PCB Project <ProjectName>.PrjPcb 명령을 선택합니다. 문제가 있으면 Messages Panel에 나열됩니다.

Javascript ID: Pnl_Properties_MBS_Module_Source
 
 
 
 
 
  • 멀티보드 프로젝트 구조에 PCB, 다른 멀티보드 또는 하네스 설계 프로젝트를 추가하려면 Projects Panel에서 멀티보드 프로젝트의 Entry를 마우스 오른쪽 버튼으로 클릭하고 Add Existing to Project 명령을 선택한 다음, 해당 로컬 *.PrjPcb, *.PrjMbd 또는 *.PrjHar 파일을 찾아 선택합니다. 멀티보드 프로젝트에 포함할 PCB 또는 하네스 설계 프로젝트가 Altium Designer에 이미 열려 있다면, Projects Panel에서 해당 프로젝트의 Entry를 상위 멀티보드 프로젝트의 Entry로 드래그하여 구조에 추가할 수 있습니다(). 그런 다음 상위 멀티보드 프로젝트의 멀티보드 Schematic 문서에 새 모듈을 수동으로 배치하고, 모듈을 선택한 상태에서 Properties Panel의 Source 필드 드롭다운을 통해 하위 PCB 프로젝트(및 해당 PCB 문서) 또는 하위 멀티보드 프로젝트(및 해당 멀티보드 어셈블리 문서)를 해당 모듈의 소스로 선택합니다(). 하네스 프로젝트는 멀티보드 프로젝트와 동기화할 수 있습니다(자세한 내용은 배선도 정의하기 페이지 참조).

  • 상위 멀티보드 프로젝트의 구조에서 하위 PCB 또는 멀티보드 설계 프로젝트를 제거하려면 상위 프로젝트의 멀티보드 Schematic 문서에서 해당 하위 프로젝트를 참조하는 모든 모듈을 제거합니다. 그러면 하위 프로젝트가 구조에서 자동으로 제거됩니다.

  • 하위 프로젝트의 Entry를 멀티보드 프로젝트 구조 밖으로 드래그하여 상위 멀티보드 프로젝트의 구조에서 하위 PCB 또는 하네스 설계 프로젝트를 제거할 수도 있습니다. 이 경우 PCB 프로젝트에 한해서는 하위 프로젝트를 참조하는 모듈이 멀티보드 Schematic 문서에 그대로 남으며, 이러한 모듈에서 하위 프로젝트로 연결되는 링크도 유지됩니다. 제거한 하위 프로젝트의 흔적을 상위 멀티보드 프로젝트에서 완전히 없애려면 이러한 모듈을 수동으로 제거하십시오.

배치된 모듈을 선택한 상태에서 Properties 패널을 사용하여 모듈의 다른 속성을 정의합니다.

  • 패널의 General 탭 아래 Properties 영역에 있는 Designator 및 Title 속성을 사용하여 모듈의 회로도 식별자와 제목 문자열을 각각 지정합니다. 해당 필드 오른쪽의  버튼을 사용하여 멀티보드 회로도에서의 표시 여부를 전환하고,  버튼을 사용하여 값의 편집 가능 여부를 전환합니다. 글꼴 및 Other 컨트롤을 사용하여 문자열의 글꼴과 문서 내 위치를 설정하고, 제목 문자열의 경우 파라미터 이름의 표시 여부도 설정합니다.

  • 모듈을 선택했을 때 Properties 패널의 General 탭 아래 Entries 영역에 있는 표는 모듈에 모듈 엔트리를 추가하면 채워집니다. 아래를 참조하십시오.

  • 패널의 General 탭 아래 Graphical 영역에 있는 컨트롤을 사용하여 모듈의 크기(너비 및 높이), 모듈 외곽선의 두께, 스타일 및 색상, 채우기 색상 등 모듈의 표시 방식을 설정합니다. 사용 가능한 선 두께 및 스타일 옵션은 설계 공간에서 아무 객체도 선택하지 않았을 때 Properties 패널의 Line Styles 영역에 정의되어 있습니다. 자세한 내용은 멀티보드 회로도 문서 설정하기 페이지를 참조하십시오.

  • 패널의 Parameters 탭에 있는 컨트롤을 사용하여 모듈 파라미터를 추가, 수정, 제거하고 설계 공간에서의 표시 여부를 설정합니다.  

전체 시스템 설계에 필요한 만큼 멀티보드 회로도 설계에 모듈과 해당 하위 프로젝트 링크를 추가합니다.

주 메뉴 또는 설계 공간의 마우스 오른쪽 버튼 클릭 메뉴에서 다음 명령을 사용하여 프로젝트 데이터를 가져오면, 연결된 프로젝트 설계의 설계 데이터로 모듈이 채워집니다.

  • Design » Import From Child Projects – 모든 소스(하위) 프로젝트의 설계 데이터를 지정된 모듈에 반영합니다.

  • Design » Import From Selected Child Projects – 현재 선택한 모듈에 해당하는 소스(하위) 프로젝트의 설계 데이터를 반영합니다.

이 과정에서 가장 중요한 점은 특수 System:Connector 파라미터가 연결된 하위 프로젝트의 각 커넥터에서 핀 및 네트 데이터를 처리한다는 것입니다(위의 자세한 내용 참조). 가져오기가 완료되면 각 커넥터에 대한 모듈 엔트리가 해당 모듈 블록 그래픽에 자동으로 생성됩니다. 커넥터 엔트리는 하위 프로젝트에 있는 커넥터의 핀 및 네트와 유기적으로 연결됩니다. 설계 공간에서 모듈 엔트리 그래픽을 선택하면 Properties 패널에서 커넥터 핀/네트 등의 세부 정보를 볼 수 있습니다. 다른 모듈의 엔트리에 연결되기 전까지는 패널의 엔트리 부품/핀 목록에 커넥터와 핀이 체결되지 않은 상태로 표시됩니다.

 
  • 하위 프로젝트에서 데이터를 가져올 때 엔트리가 자동으로 배치되지만, 주 메뉴에서 Place » Entry 명령을 선택하여 모듈 엔트리를 수동으로 배치할 수도 있습니다.

  • 모듈 엔트리의 그래픽을 클릭하여 선택한 다음, 모듈 둘레를 따라 적절한 위치로 드래그합니다. 엔트리의 참조 지정자는 별도로 드래그하여 다른 위치로 옮길 수 있습니다.

  • 여러 엔트리를 선택한 다음 그룹을 원하는 위치로 드래그하여 모듈 엔트리 그룹을 이동할 수도 있습니다.

  • 엔트리의 색상은 올바른 이동 및 배치에 도움이 됩니다. 모듈 밖에 있을 때는 엔트리가 일부만 회색으로 표시되며 배치할 수 없습니다. 모듈 위에 있으면 엔트리 전체가 색상과 함께 표시되어 해당 위치에 배치할 수 있음을 나타냅니다.

엔트리를 선택한 상태에서 Properties 패널을 사용하여 속성을 정의합니다.

  • 패널의 General 탭 아래 Properties 영역에 있는 컨트롤을 사용하여 엔트리의 Designator 값, 표시 여부 및 스타일을 변경하고 엔트리의 Type(Male/Female)을 선택합니다. 패널의 이 영역에는 엔트리 커넥터의 핀 수(Number of Pins)와 상위 모듈에서 이 엔트리에 할당된 식별 번호(Entry Number)도 표시됩니다.

  •  System Entry 옵션을 활성화하면 엔트리가 다른 모듈에 배선되지 않는 시스템 수준 연결임을 나타낼 수 있습니다. 예를 들어 전원 입력 소켓을 나타내는 엔트리가 이에 해당합니다.

    하위 멀티보드 프로젝트에 System Entry 옵션이 활성화된 엔트리를 가진 모듈이 있습니다.

    변경 사항을 상위 멀티보드 프로젝트로 가져오면 이 엔트리 커넥터가 하위 프로젝트 모듈의 모듈 엔트리로 추가됩니다.

     
  • 하네스 또는 케이블 연결을 사용하여 엔트리를 연결하면(자세히 알아보기), 패널의 Mated Component 영역에 체결된 컴포넌트에 대한 데이터가 표시됩니다.

  •  Mated Pins에서 Panel의 Region에서 Pin 열은 커넥터의 개별 핀과 관련 네트를 나열합니다. 이 Entry가 연결되면 Mated Pin 열에 맞물리는 핀 목록이 표시됩니다. 또한 이 Entry가 연결되면 Properties Panel의 Addresses 탭에 해당 Entry의 Connection 경로와 네트가 표 형식으로 표시됩니다(자세히 알아보기).

  • Panel의 Parameters 탭에 있는 컨트롤을 사용하여 Entry 파라미터를 추가, 수정, 제거하고 설계 공간에서의 표시 여부를 설정합니다.

모듈에 모듈 Entry를 추가하면, 모듈을 선택했을 때 Properties Panel의 General 탭 아래 Entries Region에 있는 표에 해당 Entry가 표시됩니다. Part(s) 열에는 소스 설계에 있는 Entry 커넥터의 Designator와 이름으로 각 모듈 Entry가 나열됩니다. 편의에 따라 이를 편집할 수 있습니다. 이 이름은 멀티보드 설계 내에서만 사용되며 소스 하위 프로젝트에는 영향을 주지 않습니다.

  • 멀티보드 설계에서 Connection을 사용하여 해당 Entry를 다른 Entry에 연결하면 Mated part(s) 열에 데이터가 표시됩니다. 자세한 내용은 Connection 작업하기 페이지를 참조하세요.

  • 목록에서 Entry의 Designator 표시 여부(  /  )와 유형(  /  )을 빠르게 전환할 수 있습니다.  및  버튼을 사용하여 각각 모듈과 목록에 정의되지 않은 새 Entry를 추가하거나 목록에서 선택한 Entry를 모듈에서 제거합니다.

  •  및  버튼을 사용하여 각각 목록에서 선택한 Connection을 서로 연관된 두 개의 모듈 Entry로 분할하거나 이전에 분할한 Entry를 다시 하나의 싱글 Entry로 통합합니다. 자세한 내용은 Connection 작업하기 페이지를 참조하세요.

외부 주변 장치/컴포넌트 지원

이 기능은 Advanced Settings 대화상자에서 MBS.PlacePart 및 MBS.UseGeometryMaker 옵션이 활성화되어 있을 때 사용할 수 있습니다.

멀티보드 Schematic 문서는 일반적인 하위 PCB 보드 어셈블리에 속하지 않는 외부 주변 장치/컴포넌트(즉, '비 PCB' 컴포넌트)를 지원합니다. 예를 들어 외부 스위치, 센서 및 기타 타사 기성 전자 모듈이 여기에 포함될 수 있습니다. 이 기능은 다음 두 가지 객체 유형의 지원을 통해 제공됩니다.

  • Custom Part – 하나 이상의 라이브러리 컴포넌트를 연결할 수 있는 모듈 형태의 개체로, 기본 메뉴의 Place » Custom Part 명령을 사용하여 멀티보드 Schematic 문서에 추가합니다. 설계 공간에서 배치된 Custom 부품을 선택한 상태에서 Properties Panel의 Linked Components Region에 있는  및  버튼을 사용하여 각각 Custom 부품에 컴포넌트를 추가하거나 제거합니다. 연결된 컴포넌트 목록에 최신 상태가 아닌 워크스페이스 컴포넌트가 포함되어 있으면  버튼을 클릭하여 해당 컴포넌트를 최신 리비전으로 업데이트합니다. 연결된 각 컴포넌트마다 Entry가 자동으로 추가됩니다.

  • Custom Connection – Components Panel에서 필요한 컴포넌트를 시트의 빈 공간으로 끌어다 놓아 멀티보드 Schematic 문서에 싱글 라이브러리 컴포넌트를 추가할 수 있습니다. 컴포넌트의 각 핀마다 Entry가 자동으로 추가됩니다.

    멀티보드 Schematic 문서 전용으로 사용할 컴포넌트의 Custom 심볼을 만들 수도 있습니다. 핀 속성의 Name 필드에 쉼표로 구분된 이름을 추가하면 여러 핀을 Entry로 그룹화할 수 있습니다. 이를 통해 Entry 수가 적고 시각적으로 더 깔끔한 심볼을 만들 수 있어 이러한 컴포넌트의 연결 작업이 훨씬 간소화됩니다.

    Javascript ID: MBS_CustomConn_MultiplePins_AD24_5

    Schematic 심볼을 편집할 때 핀의 Name 필드에 쉼표로 구분된 여러 이름을 추가합니다.

    멀티보드 Schematic의 Custom 부품에 컴포넌트를 추가하면 컴포넌트 전체에 대한 싱글 Entry 대신 각 컴포넌트 핀에 대한 Entry가 생성되며, 여러 핀이 포함된 Entry도 생성됩니다.

    컴포넌트를 멀티보드 Schematic에 Custom Connection으로 배치하면 여러 핀이 포함된 Entry가 생성됩니다.

라이브러리 컴포넌트는 연결된 워크스페이스 및 사용 가능한 로컬 라이브러리에서 제공되는 컴포넌트입니다. 배치/정의한 후에는 케이블 및 하니스 Connection 등을 사용하여 컴포넌트를 설계의 다른 부분에 연결할 수 있습니다.

Custom 부품 및/또는 Custom Connection을 통해 정의된 연결 컴포넌트는 전체 제품/시스템 BOM에 자동으로 포함되지 않으며 멀티보드 어셈블리(*.MbaDoc)에도 표시되지 않습니다.

크로스 프로빙

Design 기본 메뉴와 설계 공간의 마우스 오른쪽 버튼 클릭 메뉴에서 사용할 수 있는 크로스 프로빙 명령을 통해 멀티보드 Schematic 문서에서 하위 프로젝트의 관련 요소로 빠르게 이동할 수 있습니다.

  • 현재 선택한 모듈 또는 Entry에서 해당 모듈이 참조하는 PCB 설계 프로젝트 내의 PCB 문서 또는 해당 문서의 커넥터로 크로스 프로빙하려면 Design » Crossprobe to PCB/Multi-board 명령을 사용합니다. 모듈이 소스 멀티보드 프로젝트(*.PrjMbd) 내의 멀티보드 어셈블리 문서(*.MbaDoc)를 참조하는 경우에는 멀티보드 어셈블리 문서로 크로스 프로빙됩니다.

  • 현재 선택한 모듈 또는 Entry에서 해당 모듈이 참조하는 PCB 설계 프로젝트 내의 최상위 Schematic 또는 관련 Schematic의 커넥터로 크로스 프로빙하려면 Design » Crossprobe to Schematic 명령을 사용합니다.

  • 현재 선택한 모듈 또는 Entry에서 멀티보드 프로젝트(*.PrjMbd) 내의 멀티보드 어셈블리 문서(*.MbaDoc)에 있는 보드 또는 해당 보드의 커넥터로 크로스 프로빙하려면 Design » Crossprobe to MBA 명령을 사용합니다.

  • 멀티보드 Schematic 문서(*.MbsDoc)에서 현재 선택한 하니스 Connection으로부터 연결된 하니스 프로젝트(*.PrjHar)로 크로스 프로빙하려면 Design » Crossprobe to Harness 명령을 사용합니다. 연결된 하니스 프로젝트의 배선도 문서가 열립니다.

모듈 Entry에서 크로스 프로빙할 때 타겟 Schematic/PCB 문서의 크로스 프로빙된 객체는 Preferences의 System – Navigation 페이지에 정의된 Highlight Methods 옵션에 따라 표시됩니다. 대화 상자입니다. 멀티보드 Schematic 문서에는 강조 표시가 적용되지 않습니다.

인쇄 또는 PDF로 Export

현재 활성화된 멀티보드 Schematic 문서를 인쇄하려면 기본 메뉴에서 File » Print을 선택합니다(단축키: Ctrl+P). Print 대화 상자가 열립니다. 대화 상자 왼쪽에는 크기를 조절할 수 있는 인쇄 미리보기 이미지가 표시됩니다. 오른쪽에는 표준 인쇄 옵션이 있습니다. 이러한 옵션을 통해 특정 프린터 지정, 프린터 위치 확인, 현재 인쇄 대기열에 있는 문서 수 확인, 인쇄 매수 조정, 용지 크기 및 방향 설정을 수행할 수 있습니다. 을 클릭하면 설정한 옵션에 따라 인쇄 작업이 선택한 인쇄 장치로 전송됩니다.

Print 대화 상자
Print 대화 상자

멀티보드 Schematic 문서를 PDF 파일로 Export하려면 기본 메뉴에서 File » Export to PDF을 선택합니다.

AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents