Creating a Simulation Model
W skrócie
- Jak tworzyć lub pozyskiwać modele symulacyjne, korzystając z plików pobranych od producentów, skopiowanych modeli tekstowych oraz ręcznie napisanych plików podobwodów.
- Jak tworzyć, zapisywać, powiązywać i edytować modele symulacyjne w Altium Designer oraz w połączonej przestrzeni roboczej.
- Jakie informacje są niezbędne do prawidłowego zdefiniowania modelu symulacyjnego, w tym nazwy modeli, wskazywane pliki oraz parametry na poziomie modelu.
Aby przeprowadzić symulację projektu obwodu za pomocą symulatora obwodów analogowo-cyfrowych w Altium Designer, wszystkie komponenty w obwodzie muszą być gotowe do symulacji — każdy z nich musi mieć przypisany model symulacyjny.
Typ modelu i sposób jego uzyskania zależą w dużej mierze od komponentu, a w pewnym stopniu także od osobistych preferencji projektanta. Wielu producentów podzespołów udostępnia modele symulacyjne odpowiadające wytwarzanym przez nich elementom. Zazwyczaj wystarczy pobrać wymagany plik modelu i powiązać go z komponentem na schemacie. Dowiedz się więcej o dodawaniu modeli symulacyjnych do projektu.
Niektóre modele mogą wymagać napisania od podstaw — na przykład z użyciem hierarchicznej składni podobwodów w celu utworzenia wymaganego pliku modelu podobwodu (*.ckt).
Tworzenie nowego modelu symulacyjnego
Niektóre modele są udostępniane przez producentów i dostawców jako pliki tekstowe do pobrania. Czasami opis modelu jest prezentowany jako tekst na stronie internetowej zamiast w pliku do pobrania. W takiej sytuacji można utworzyć nowy plik modelu w Altium Designer, a następnie skopiować i wkleić do niego zawartość strony. Użyj odpowiedniego polecenia w podmenu File » New » Mixed Simulation, jak pokazano poniżej.

Polecenia służące do tworzenia nowego, pustego pliku modelu.
Następnie możesz skopiować i wkleić zawartość pliku modelu do edytora modeli.

Przykładowa treść modelu symulacyjnego.
Tworzenie modelu symulacyjnego w przestrzeni roboczej
Altium Designer w połączeniu z podłączoną przestrzenią roboczą umożliwia tworzenie modeli symulacyjnych w przestrzeni roboczej i zarządzanie nimi. Po utworzeniu takiego modelu można go użyć do utworzenia jednego lub większej liczby komponentów przestrzeni roboczej.
Modele symulacyjne w przestrzeni roboczej są tworzone automatycznie po dodaniu pliku modelu symulacyjnego do komponentu definiowanego w edytorze komponentów w trybie edycji pojedynczego komponentu i zapisaniu tego komponentu w przestrzeni roboczej. Można je jednak również tworzyć bezpośrednio w przestrzeni roboczej, jak opisano poniżej.
-
Otwórz panel Components i włącz widoczność modeli, klikając przycisk
u góry panelu i wybierając Models.
-
Przejdź do kategorii Simulations i wybierz Create Component z menu przycisku
.

Przejdź do modeli symulacyjnych w panelu Components i wybierz polecenie utworzenia nowego modelu -
W otwartym oknie dialogowym Create New Item wprowadź wymagane informacje, upewnij się, że opcja Open for editing after creation jest włączona, i kliknij OK. Zostanie utworzony model symulacyjny w przestrzeni roboczej, a tymczasowy edytor SimModel otworzy się z dokumentem
.SimModeljako aktywnym dokumentem w obszarze projektowania. Dokument otrzyma nazwę odpowiadającą rewizji elementu, w formacie:<Item><Revision>.SimModel(np.SIM-001-0001-1.SimModel).
Przykład edycji początkowej rewizji modelu symulacyjnego w przestrzeni roboczej — tymczasowy edytor SimModel udostępnia dokument służący do zdefiniowania modelu symulacyjnego. - Użyj tego dokumentu, aby zdefiniować model symulacyjny w przestrzeni roboczej zgodnie z wymaganiami. Więcej informacji znajdziesz w sekcji Definiowanie modelu symulacyjnego.
- Zapisz model w przestrzeni roboczej za pomocą elementu sterującego Save to Server po prawej stronie wpisu modelu symulacyjnego w panelu Projects. Pojawi się okno dialogowe Edit Revision, w którym można zmienić nazwę i opis oraz w razie potrzeby dodać uwagi do wydania. Po zapisaniu dokument i edytor zostaną zamknięte.
-
Dokument zawierający źródłową definicję modelu symulacyjnego,
*.SimModel, zostanie zapisany w rewizji modelu symulacyjnego w przestrzeni roboczej. Model symulacyjny będzie widoczny w panelu Components, w kategorii Simulations.
Zapisany model symulacyjny przestrzeni roboczej w panelu ComponentsDane zapisane w przestrzeni roboczej obejmują definicję modelu w pliku
.SimModeloraz wszelkie powiązane pliki.mdllub.ckt. W panelu Explorer przejdź do karty widoku Preview, a następnie kliknij powiązany plik, aby wyświetlić podgląd jego zawartości. W stosownych przypadkach wyświetlane są również parametry na poziomie modelu.
Przeglądaj zapisany model symulacyjny przestrzeni roboczej w panelu Explorer. Przejdź do karty widoku Preview, aby zobaczyć zapisane dane.
Zapisany model symulacyjny przestrzeni roboczej można następnie powiązać z komponentem przestrzeni roboczej podczas definiowania go w edytorze komponentów w trybie edycji pojedynczego komponentu lub edycji zbiorczej komponentów.
Definiowanie modelu symulacyjnego
Do zdefiniowania modelu w pliku SimModel wymagane są następujące informacje:
-
Model Name – użyj tego pola, aby określić nazwę modelu. Po zapisaniu w Workspace ten wpis zostanie użyty jako Name rewizji elementu modelu symulacyjnego.
W przypadku odwołania do pliku MDL nazwa musi odpowiadać nazwie w wierszu
.MODELdefinicji modelu. Rozważmy model diody o następującej definicji:.MODEL 1N4002 D(IS=2.55E-9 RS=0.042 N=1.75 TT=5.76E-6 CJO=1.85E-11 + VJ=0.75 M=0.333 BV=100 IBV=1E-5 )Nazwa modelu w tym przykładzie to
1N4002. Tę nazwę należy wprowadzić w polu Model Name.W przypadku odwołania do pliku CKT nazwa musi odpowiadać nazwie w wierszu
.SUBCKTdefinicji modelu. Rozważmy model bezpiecznika o następującej definicji:.SUBCKT FUSE 1 2 PARAMS: CURRENT=1 RESISTANCE=1m SW1 1 2 3 0 SMOD OFF BNLV 3 0 V=(abs(v(1,2)))
.MODEL SMOD SW (VT=\{(CURRENT*RESISTANCE)\} RON=1g ROFF=\{RESISTANCE\})
.ENDS FUSENazwa modelu w tym przykładzie to
FUSE. Tę nazwę należy wprowadzić w polu Model Name. -
Model File – w przypadku modelu zdefiniowanego za pomocą pliku
.mdllub.cktużyj przycisku Browse , aby wskazać wymagany plik z dostępnej biblioteki. - Description – wprowadź opis modelu, na przykład jego przeznaczenie. Po zapisaniu w Workspace ten wpis zostanie użyty jako Description rewizji modelu symulacyjnego.
- Parameters – parametry modelu definiowane na poziomie modelu (patrz Parametry na poziomie modelu).
-
Model Preview – zawartość wskazanego pliku
.mdllub.ckt, wyświetlana tylko do odczytu.
Parametry na poziomie modelu
W stosownych przypadkach parametry na poziomie modelu można definiować bezpośrednio w pliku SimModel, ponieważ stanowią one naturalną część definicji modelu. Sekcja Parameters dokumentu zostanie automatycznie wypełniona parametrami odpowiednimi dla wybranego modelu. Wartości parametrów można edytować bezpośrednio — kliknij pole Parameter Value powiązane z parametrem na liście i wprowadź wymaganą wartość.

Zdefiniuj parametry modelu jako część jego definicji — korzystając z edycji bezpośredniej.
Edycja modelu symulacyjnego w Workspace
Na dowolnym etapie możesz wrócić do dowolnego modelu symulacyjnego w Workspace i bezpośrednio go edytować. Wybierz kategorię Simulations w panelu Components (aby uzyskać dostęp do tej kategorii, w menu
panelu musi być włączona opcja Models), kliknij prawym przyciskiem myszy wpis modelu symulacyjnego i wybierz polecenie Edit z menu kontekstowego. Ponownie otworzy się edytor tymczasowy z plikiem zawartym w modelu symulacyjnym w Workspace (zawierającym źródłową definicję modelu symulacyjnego), otwartym do edycji. Wprowadź wymagane zmiany, a następnie zapisz dokument jako kolejną rewizję modelu symulacyjnego w Workspace.
Generowanie plików SimModel
Pliki SimModel można generować z aktywnego dokumentu biblioteki schematów lub biblioteki bazodanowej za pomocą polecenia Tools » Generate SimModel Files.
Po uruchomieniu polecenia pojawi się okno dialogowe Generate SimModel Files. Każdy plik SimModel (wraz z zawartą w nim definicją modelu symulacyjnego) jest tworzony na podstawie powiązania z modelem symulacyjnym dla komponentu schematowego w aktywnej bibliotece schematów (lub informacji o symulacji dla rekordu komponentu w aktywnej bibliotece bazodanowej). Użyj elementów sterujących w oknie dialogowym, aby odpowiednio skonfigurować generowanie jednego lub wielu plików SimModel. Domyślnie zostanie utworzony podfolder o nazwie Sim Models . W razie potrzeby zmień tę nazwę na bardziej odpowiednią. Jeśli wskazany folder istnieje, zostanie użyty; w przeciwnym razie zostanie utworzony.

Okno dialogowe Generate SimModel Files
Po odpowiednim skonfigurowaniu opcji kliknij OK. Rozpocznie się generowanie, a po zakończeniu procesu pojawi się okno dialogowe z potwierdzeniem i informacją o liczbie wygenerowanych plików SimModel. Wszystkie pliki .mdl, .ckt lub .scb, do których istnieją odwołania, również zostaną zapisane obok plików SimModel.
W przypadku migracji z biblioteki zintegrowanej źródłowe biblioteki schematów (SchLib) można uzyskać, otwierając plik IntLib w Altium Designer i wybierając wyodrębnienie bibliotek źródłowych. Podczas generowania plików SimModel z biblioteki bazodanowej uwzględniane będą tylko komponenty w aktualnie włączonych tabelach.
Nazewnictwo plików SimModel zależy od typu biblioteki źródłowej:
- Schematic Library – każdy plik SimModel otrzymuje nazwę modelu symulacyjnego. Jeśli wiele komponentów schematowych zawiera tę samą implementację modelu symulacyjnego (model symulacyjny o tej samej nazwie), zostanie wygenerowany tylko jeden plik SimModel o tej nazwie.
- Database Library – każdy plik SimModel otrzymuje nazwę modelu symulacyjnego określoną w polu Sim Model Name rekordu komponentu. Jeśli wiele rekordów komponentów (we włączonych tabelach) zawiera tę samą implementację modelu symulacyjnego (ten sam wpis w polu Sim Model Name), zostanie wygenerowany tylko jeden plik SimModel o tej nazwie.
Kreator modeli SPICE
Niektóre modele elementów analogowych wbudowane w SPICE umożliwiają korzystanie z powiązanego pliku modelu (*.mdl), w którym można parametrycznie zdefiniować zaawansowane charakterystyki ich działania (np. rezystora półprzewodnikowego, diody czy tranzystora BJT). Ręczne utworzenie takiego pliku modelu, a następnie powiązanie go z odpowiednim komponentem schematu może być dość pracochłonne. SPICE Model Wizard ułatwia to zadanie. Za pomocą kreatora można zdefiniować charakterystyki takiego elementu na podstawie danych pozyskanych przez użytkownika. Parametry — wprowadzone bezpośrednio lub wyznaczone na podstawie dostarczonych danych — są automatycznie zapisywane w pliku modelu, który następnie jest wiązany ze wskazanym komponentem schematu.
SPICE Model Wizard zapewnia wygodne, częściowo zautomatyzowane rozwiązanie do tworzenia i przypisywania modeli symulacyjnych SPICE dla szeregu elementów analogowych — elementów wbudowanych w SPICE, które wymagają powiązanego pliku modelu (*.mdl). Charakterystyki działania modelu są definiowane na podstawie informacji przekazanych kreatorowi. Zakres tych informacji zależy od typu elementu, dla którego ma zostać utworzony model — od prostego wprowadzenia parametrów modelu po wprowadzenie danych elementu uzyskanych z dokumentacji producenta lub z pomiarów fizycznego elementu.
W kolejnych sekcjach omówiono korzystanie z kreatora — od jego uruchomienia po weryfikację.
Uruchamianie kreatora
Kreator uruchamia się w edytorze symboli schematowych, wybierając polecenie Tools » XSpice Model Wizard z menu głównego.

Strona początkowa SPICE Model Wizard
Na dwóch kolejnych stronach kreatora można wybrać:
- Konkretny element do modelowania z listy obsługiwanych typów elementów.
- Czy wygenerowany model SPICE ma zostać dodany do istniejącego komponentu w dokumencie biblioteki, czy do nowego komponentu, który kreator utworzy i doda do tego dokumentu.
Obsługiwane typy elementów
Kreator umożliwia tworzenie modeli SPICE dla następujących typów elementów analogowych:
- Dioda
- Kondensator półprzewodnikowy
- Rezystor półprzewodnikowy
- Przełącznik sterowany prądem
- Przełącznik sterowany napięciem
- Tranzystor bipolarny
- Linia transmisyjna ze stratami
- Linia transmisyjna o równomiernie rozłożonych parametrach RC
Nadawanie nazwy modelowi
Jednym z najważniejszych kroków podczas przechodzenia przez kolejne strony kreatora jest nadanie nazwy tworzonemu modelowi. Bez wprowadzenia nazwy nie można przejść do etapu definiowania parametrów.
Po utworzeniu modelu nazwa ta pojawi się w polu Model Name okna dialogowego Sim Model. Sam plik modelu również zostanie utworzony pod tą nazwą (<ModelName>.mdl). Jeśli kreator jest używany do dodania modelu do nowego komponentu bibliotecznego, nazwa podana dla modelu zostanie również użyta jako nazwa komponentu.
Podczas nadawania nazwy modelowi można także wprowadzić jego krótki opis. Może on określać funkcję modelu (np. Semiconductor Resistor) lub zawierać bardziej szczegółowe odniesienie do wartości albo konfiguracji (np. NPN BJT).
Modelowane charakterystyki
Po nadaniu modelowi nazwy nastąpi przejście do jednej lub kilku stron dotyczących modelowanych charakterystyk. Typy modeli obsługiwane przez kreator można podzielić na dwie grupy:
- Modele wymagające bezpośredniego wprowadzenia wartości poszczególnych parametrów modelu. Więcej informacji można znaleźć w sekcji Modele elementów tworzone przez bezpośrednie wprowadzanie parametrów.
- Modele wymagające wprowadzenia danych, z których zostaną wyznaczone parametry definiujące wybrane charakterystyki elementu. Wprowadzane dane pochodzą z bezpośrednich pomiarów fizycznego elementu lub z dokumentacji producenta. Więcej informacji można znaleźć w sekcji Modele elementów tworzone przez wyznaczanie parametrów na podstawie danych.
Generowanie modelu
Po zdefiniowaniu wymaganych danych lub parametrów kreator wyświetli wygenerowany model. Jest to zawartość, która zostanie zapisana w pliku MDL.

Podgląd zawartości wygenerowanego pliku modelu.
Model można edytować bezpośrednio na tej stronie, co zapewnia pełną kontrolę nad jego definicją.
Gdy definicja modelu będzie gotowa, kliknij Next, aby przejść do końcowej strony kreatora. Kliknięcie Finish umożliwi zapisanie modelu. W oknie dialogowym Save SPICE Model File określ miejsce zapisu wynikowego pliku MDL. Domyślnie plik zostanie zapisany w tym samym katalogu co dokument biblioteki schematowej. Na tym etapie można również zmienić nazwę pliku.
Jeśli wybrano przypisanie modelu do nowego komponentu, komponent ten zostanie utworzony i dodany do dokumentu biblioteki.
Modele elementów tworzone przez bezpośrednie wprowadzanie parametrów
W przypadku poniższych modeli elementów kreator nie wyznacza parametrów na podstawie wprowadzonych danych. Zamiast tego modele są tworzone przez bezpośrednie wprowadzenie wartości odpowiednich parametrów. Podczas wprowadzania wartości parametrów należy pamiętać o kilku kwestiach:
- Jeśli nie zostanie podana wartość parametru, w utworzonym pliku modelu nie będzie odpowiadającego mu wpisu. W takim przypadku zostanie użyta wartość domyślna zapisana wewnętrznie w SPICE. Innymi słowy, wartość parametru określona w pliku modelu zastępuje jego wartość domyślną.
- Jeśli domyślnym wpisem dla parametru w kreatorze jest „-”, a jego wartość nie zostanie jawnie wprowadzona, do obliczeń zostanie użyta domyślna wartość zero (wbudowana w SPICE).
Kondensator półprzewodnikowy
Dla tego modelu elementu można zdefiniować w kreatorze następujące parametry. Wprowadzenie wartości spowoduje zapisanie danego parametru w wygenerowanym pliku MDL.
CJ |
Pojemność dna złącza (w F/m²). |
|
CJSW |
Pojemność ściany bocznej złącza (w F/m). |
|
DEFW |
Domyślna szerokość elementu (w metrach). (Wartość domyślna = 1e-6). |
|
NARROW |
Zwężenie wskutek trawienia bocznego (w metrach). (Wartość domyślna = 0). |
Rezystor półprzewodnikowy
Za pomocą kreatora można zdefiniować następujące parametry tego modelu elementu. Wprowadzenie wartości spowoduje zapisanie danego parametru w wygenerowanym pliku MDL.
TC1 |
Współczynnik temperaturowy pierwszego rzędu (w Ω/°C). (Domyślnie = 0) |
|
TC2 |
Współczynnik temperaturowy drugiego rzędu (w Ω/°C²). (Domyślnie = 0) |
|
RSH |
Rezystancja powierzchniowa (w omach). |
|
DEFW |
Domyślna szerokość (w metrach). (Domyślnie = 1e-6). |
|
NARROW |
Zwężenie spowodowane trawieniem bocznym (w metrach). (Domyślnie = 0). |
|
TNOM |
Temperatura pomiaru parametrów (w °C). Jeśli nie podano wartości, zostanie użyta wartość domyślna przypisana do TNOM na karcie Advanced w oknie dialogowym Advanced Analyses Settings (domyślnie = 27). |
Przełącznik sterowany prądem
Za pomocą kreatora można zdefiniować następujące parametry tego modelu elementu. Wprowadzenie wartości spowoduje zapisanie danego parametru w wygenerowanym pliku MDL.
IT |
Prąd progowy (w amperach). (Domyślnie = 0). |
|
IH |
Prąd histerezy (w amperach). (Domyślnie = 0). |
|
RON |
Rezystancja w stanie włączenia (w omach). (Domyślnie = 1). |
|
ROFF |
Rezystancja w stanie wyłączenia (w omach). Domyślnie jest ustawiona na 1/GMIN. GMIN to zaawansowany parametr SPICE, określany na karcie Advanced w oknie dialogowym Advanced Analyses Settings. Określa on minimalną konduktancję (maksymalną rezystancję) dowolnego elementu w obwodzie. Jego wartość domyślna wynosi 1e-12 S, co daje domyślną wartość ROFF równą 1000 GΩ. |
Przełącznik sterowany napięciem
Za pomocą kreatora można zdefiniować następujące parametry tego modelu elementu. Wprowadzenie wartości spowoduje zapisanie danego parametru w wygenerowanym pliku MDL.
VT |
Napięcie progowe (w woltach). (Domyślnie = 0). |
|
VH |
Napięcie histerezy (w woltach). (Domyślnie = 0). |
|
RON |
Rezystancja w stanie włączenia (w omach). (Domyślnie = 1). |
|
ROFF |
Rezystancja w stanie wyłączenia (w omach). Domyślnie jest ustawiona na 1/GMIN. GMIN to zaawansowany parametr SPICE, określany na karcie Advanced w oknie dialogowym Advanced Analyses Settings. Określa on minimalną konduktancję (maksymalną rezystancję) dowolnego elementu w obwodzie. Jego wartość domyślna wynosi 1e-12 S, co daje domyślną wartość ROFF równą 1000 GΩ. |
Stratna linia transmisyjna
Za pomocą kreatora można zdefiniować następujące parametry tego modelu elementu. Wprowadzenie wartości (lub ustawienie flagi) spowoduje zapisanie danego parametru w wygenerowanym pliku MDL.
R |
Rezystancja na jednostkę długości (w omach/jednostkę). (Domyślnie = 0). |
|
L |
Indukcyjność na jednostkę długości (w henrach/jednostkę). (Domyślnie = 0). |
|
G |
Konduktancja na jednostkę długości (w siemensach/jednostkę). (Domyślnie = 0). |
|
C |
Pojemność na jednostkę długości (w faradach/jednostkę). (Domyślnie = 0). |
|
LEN |
Długość linii transmisyjnej. |
|
REL |
Sterowanie punktami załamania (w jednostkach umownych). (Domyślnie = 1). |
|
ABS |
Sterowanie punktami załamania (w jednostkach umownych). (Domyślnie = 1). |
|
NOSTEPLIMIT |
Flaga, której ustawienie znosi ograniczenie kroku czasowego do wartości mniejszych niż opóźnienie linii. (Domyślnie = nieustawiona). |
|
NOCONTROL |
Flaga, której ustawienie zapobiega ograniczaniu kroku czasowego na podstawie kryteriów błędu splotu. (Domyślnie = nieustawiona). |
|
LININTERP |
Flaga, której ustawienie powoduje użycie interpolacji liniowej zamiast domyślnej interpolacji kwadratowej do obliczania opóźnionych sygnałów. (Domyślnie = nieustawiona). |
|
MIXEDINTERP |
Flaga, której ustawienie powoduje użycie miary określającej, czy można zastosować interpolację kwadratową, a jeśli nie — zastosowanie interpolacji liniowej. (Domyślnie = nieustawiona). |
|
COMPACTREL |
Wielkość służąca do sterowania kompresją wartości historycznych używanych do obliczania splotu. Domyślnie przyjmuje wartość określoną dla parametru względnej tolerancji błędu symulacji (RELTOL), zdefiniowanego na karcie Advanced w oknie dialogowym Advanced Analyses Settings. |
|
COMPACTABS |
Wielkość służąca do sterowania kompresją wartości historycznych używanych do obliczania splotu. Domyślnie przyjmuje wartość określoną dla parametru bezwzględnej tolerancji błędu prądu (ABSTOL), zdefiniowanego na karcie Advanced w oknie dialogowym Advanced Analyses Settings. |
|
TRUNCNR |
Flaga, której ustawienie włącza stosowanie metody iteracyjnej Newtona-Raphsona do wyznaczania odpowiedniego kroku czasowego w procedurach sterowania krokiem czasowym. (Domyślnie = nieustawiona, co oznacza stosowanie metody prób i błędów — za każdym razem poprzedni krok czasowy jest zmniejszany o połowę). |
|
TRUNCDONTCUT |
Flaga, której ustawienie wyłącza domyślne zmniejszanie kroku czasowego służące ograniczaniu błędów podczas obliczania wielkości związanych z odpowiedzią impulsową. (Domyślnie = nieustawiona). |
Jednorodna linia transmisyjna o rozłożonych parametrach RC
Za pomocą kreatora można zdefiniować następujące parametry tego modelu elementu. Wprowadzenie wartości spowoduje zapisanie danego parametru w wygenerowanym pliku MDL.
K |
Stała propagacji. (Domyślnie = 2). |
|
FMAX |
Maksymalna częstotliwość będąca przedmiotem analizy (w hercach). (Domyślnie = 1.0G). |
|
RPERL |
Rezystancja na jednostkę długości (w omach/metr). (Domyślnie = 1000). |
|
CPERL |
Pojemność na jednostkę długości (w faradach/metr). (Domyślnie = 1.0e-15). |
|
ISPERL |
Prąd nasycenia na jednostkę długości (w amperach/metr). (Domyślnie = 0). |
|
RSPERL |
Rezystancja diody na jednostkę długości (w omach/metr). (Domyślnie = 0). |
Modele elementów tworzone przez ekstrakcję parametrów z danych
W przypadku diod i tranzystorów BJT kreator wyodrębnia informacje o parametrach z wprowadzonych danych. Konkretne parametry wyodrębniane w celu uwzględnienia w pliku modelu zależą od wybranych charakterystyk modelowanej diody lub tranzystora BJT.
Sposób wprowadzania danych zależy od charakterystyki. W niektórych przypadkach wymagane jest bezpośrednie wprowadzenie wartości, a w innych — danych z wykresu. W każdym przypadku wszystkie dane pochodzą z bezpośrednich pomiarów elementu, dokumentacji producenta lub z obu tych źródeł.
Gdy wymagane jest wprowadzenie danych z wykresu, wpisz serię punktów odczytanych z wykresu źródłowego do tabeli udostępnionej przez kreator. Jeśli dane są zapisane w formacie wartości rozdzielanych przecinkami (*.csv), możesz je zaimportować za pomocą przycisku Import Data. Kreator wykorzysta wprowadzone dane do wyodrębnienia wymaganych parametrów modelu. Wyniki ekstrakcji są prezentowane na kolejnej stronie kreatora — w postaci wartości wyodrębnionych parametrów oraz wykresu porównującego wprowadzone dane z wartościami obliczonymi na podstawie tych parametrów. Poniższy rysunek przedstawia przykład takiej prezentacji wyników.

Wprowadź dane źródłowe, aby kreator mógł wyodrębnić wymagane parametry modelu.
Możesz edytować wyodrębnione wartości parametrów, aby jeszcze lepiej dopasować model diody. Wykres porównawczy zostanie zaktualizowany, aby odzwierciedlić zmiany.
Dioda
Poniższe sekcje szczegółowo opisują poszczególne charakterystyki, które można wybrać do modelowania diody. W każdej sekcji omówiono wyodrębniane parametry oraz dane źródłowe wymagane przez kreator do ich wyznaczenia.
Przepływ prądu przy polaryzacji w kierunku przewodzenia
Poniższe parametry służą do opisu stałoprądowej charakterystyki prądowo-napięciowej diody przy polaryzacji w kierunku przewodzenia:
IS |
Prąd nasycenia (w amperach). |
|
N |
Współczynnik emisji. |
|
RS |
Rezystancja omowa (w omach). |
Do wyodrębnienia tych parametrów wymagany jest wykres zależności prądu przewodzenia diody (IF) od napięcia przewodzenia (VF). Wykres ten można uzyskać z dokumentacji producenta lub na podstawie pomiarów rzeczywistego elementu.
Poniższy rysunek przedstawia przykład takiego wykresu pochodzącego z dokumentacji producenta, a także przykładowy układ pomiarowy, w którym można przeprowadzić bezpośrednie pomiary w celu uzyskania wymaganych danych źródłowych.

Przykładowy wykres i układ do pomiaru charakterystyki prądowo-napięciowej diody w kierunku przewodzenia.
Dane wprowadza się do kreatora jako serię punktów odczytanych z wykresu źródłowego.
Pojemność złącza przy polaryzacji zaporowej
Poniższe parametry służą do opisu pojemności diody pracującej przy polaryzacji zaporowej:
CJO |
Pojemność złącza przy zerowym napięciu polaryzacji (w faradach). |
|
M |
Współczynnik gradientu złącza. |
|
VJ |
Potencjał złącza (w woltach). |
Do wyodrębnienia tych parametrów wymagany jest wykres zależności pojemności diody spolaryzowanej zaporowo (Cd) od napięcia zaporowego (VR). Wykres ten można uzyskać z dokumentacji producenta lub na podstawie pomiarów rzeczywistego elementu.
Rysunek przedstawia przykład takiego wykresu pochodzącego z dokumentacji producenta, a także przykładowy układ pomiarowy, w którym można przeprowadzić bezpośrednie pomiary w celu uzyskania wymaganych danych źródłowych. Układ ten można wykorzystać, gdy miernik pojemności nie jest dostępny.

Przykładowy wykres i układ do pomiaru pojemności diody przy polaryzacji zaporowej.
Dane wprowadza się do kreatora jako serię punktów odczytanych z wykresu źródłowego.
Przykładowy układ na powyższym rysunku opiera się na równaniu:
I = C * (dv/dt)
Po przekształceniu tego równania względem C otrzymujemy:
C = I/(dv/dt)
Źródło V1 w układzie wytwarza napięcie narastające liniowo. Obliczając nachylenie przebiegu tego napięcia, można uzyskać człon dv/dt równania. Dzieląc zmierzony prąd diody przez nachylenie przebiegu napięcia, można wyznaczyć krzywą pojemności diody.
Przepływ prądu przy polaryzacji zaporowej
Poniższe parametry służą do opisu przepływu prądu elementu przy polaryzacji zaporowej po przebiciu:
BV |
Napięcie przebicia w kierunku zaporowym (w woltach). |
|
IBV |
Prąd przy napięciu przebicia (w amperach). |
Do wyodrębnienia tych parametrów kreator wymaga wprowadzenia następujących dwóch wartości:
-
Wartości napięcia przebicia w kierunku zaporowym.
-
Wartości prądu płynącego przez diodę w punkcie przebicia w kierunku zaporowym.
Wartości te można uzyskać z dokumentacji producenta lub na podstawie pomiarów rzeczywistego elementu. Dokumentacja zazwyczaj zawiera parametry elektryczne diody dla prądu stałego w formie tabeli, wystarczy więc odnaleźć te wartości i wprowadzić je dokładnie tak, jak zostały podane.
Jeśli dane źródłowe mają postać wykresu — co jest typowe dla bezpośrednich pomiarów rzeczywistego elementu — należy odczytać te dwie wartości w punkcie, w którym rozpoczyna się przebicie diody. Poniższy rysunek przedstawia przykład takiego wykresu.

Odczytywanie z wykresu wartości prądu i napięcia w punkcie przebicia w kierunku zaporowym.
Chociaż wartości przedstawione na wykresie mogą być ujemne, do odpowiednich pól kreatora należy wprowadzać je wyłącznie jako wartości dodatnie.
Charakterystyka odzyskiwania zdolności zaworowej
Poniższy parametr służy do modelowania czasu odzyskiwania zdolności zaworowej diody podczas przełączania jej z polaryzacji w kierunku przewodzenia na polaryzację zaporową:
TT |
Czas przelotu (w sekundach). |
Do wyodrębnienia tego parametru kreator wymaga wprowadzenia czasu odzyskiwania zdolności zaworowej diody (Trr) w warunkach, w których prąd przewodzenia jest równy prądowi wstecznemu (tj. IR/IF=1). Dane te można zazwyczaj znaleźć w dokumentacji producentów diod przełączających w postaci prostych wartości liczbowych.
Poniższy rysunek przedstawia sposób prezentacji tej informacji w dokumentacji producenta. Interesująca nas wartość na rysunku — którą należy wprowadzić do kreatora — wynosi 4 ns.

Odczytywanie czasu odzyskiwania zdolności zaworowej diody.
Tranzystor bipolarny (BJT)
Podczas tworzenia modelu tranzystora bipolarnego (BJT) kreator modelu SPICE wymaga wybrania danych źródłowych, z których zostaną wyznaczone parametry:
- Dane pomiarowe – wybierz tę opcję, jeśli dane źródłowe pochodzą z pomiarów rzeczywistego elementu i chcesz opracować dokładny model opisujący wszystkie aspekty jego zachowania w warunkach stałoprądowych.
- Karta katalogowa producenta – wybierz tę opcję, jeśli dane źródłowe pochodzą z karty katalogowej. Karty katalogowe zazwyczaj nie zawierają informacji o poziomie szczegółowości wymaganym do modelowania wszystkich aspektów działania tranzystora BJT. Zwykle jednak zawierają wystarczające informacje do utworzenia modelu elementu przeznaczonego do pracy wyłącznie w normalnym obszarze aktywnym.
Różnice między tymi dwiema opcjami dotyczą głównie sposobu wyznaczania parametrów modelujących stałoprądowe charakterystyki prądowo-napięciowe tranzystora BJT. W przypadku pojemności złączy spolaryzowanych zaporowo i czasów przelotu sposób wyznaczania parametrów jest identyczny dla obu opcji.
W kolejnych sekcjach szczegółowo opisano poszczególne charakterystyki, które można modelować dla tranzystora BJT, z uwzględnieniem rodzaju danych źródłowych (dane pomiarowe lub karta katalogowa). Omówiono parametry wyznaczane w każdym przypadku oraz dane źródłowe wymagane przez kreator do ich wyznaczenia.
Charakterystyki modelowane na podstawie danych pomiarowych
Na podstawie danych uzyskanych z bezpośrednich pomiarów rzeczywistego elementu można modelować poniższe charakterystyki.
-
Forward-Bias Parameters
Poniższe parametry służą do opisu stałoprądowych charakterystyk prądowo-napięciowych tranzystora BJT w normalnym obszarze pracy:
IS
Transportowy prąd nasycenia (w amperach).
BF
Idealne maksymalne wzmocnienie prądowe beta w normalnym obszarze pracy.
NF
Współczynnik emisji prądu w normalnym obszarze pracy.
RB
Rezystancja bazy przy zerowej polaryzacji (w omach).
RC
Rezystancja kolektora (w omach).
RE
Rezystancja emitera (w omach).
IKF
Prąd graniczny, przy którym wzmocnienie beta w normalnym obszarze pracy zaczyna maleć przy dużych prądach (w amperach).
ISE
Prąd nasycenia upływu złącza B-E (w amperach).
NE
Współczynnik emisji prądu upływu złącza B-E.
VAF
Napięcie Early’ego w normalnym obszarze pracy (w woltach).
W kolejnych sekcjach szczegółowo opisano wymagane dane pomiarowe, których wprowadzenie umożliwi kreatorowi wyznaczenie tych parametrów.
-
Base-Emitter Voltage versus Base Current
Te dane służą do wstępnego wyznaczenia parametru RC. Na poniższej ilustracji przedstawiono przykładowy wykres napięcia baza–emiter (VBE) w funkcji prądu bazy (IB), a także przykładowy układ pomiarowy umożliwiający uzyskanie tych danych. Układ wymusza prąd bazy i mierzy napięcie baza–emiter przy rozwartym obwodzie kolektora.

Przykładowy wykres i układ pomiarowy dla zależności VBE od IB.Dane wprowadza się do kreatora jako serię punktów odczytanych z wykresu źródłowego.
-
Collector-Emitter Voltage versus Base Current
Te dane służą do wstępnego wyznaczenia parametru RE. Na poniższej ilustracji przedstawiono przykładowy wykres napięcia kolektor–emiter (VCE) w funkcji prądu bazy (IB), a także przykładowy układ pomiarowy umożliwiający uzyskanie tych danych. Układ wymusza prąd bazy i mierzy napięcie kolektor–emiter przy rozwartym obwodzie kolektora.

Przykładowy wykres i układ pomiarowy dla zależności VCE od IB.Dane wprowadza się do kreatora jako serię punktów odczytanych z wykresu źródłowego.
-
Forward Gummel Plot
Te dane służą przede wszystkim do wyznaczenia parametrów IS, BF, NF, RB, IKF, ISE i NE. Są również wykorzystywane do optymalizacji parametrów RC, RE i VAF. Na poniższej ilustracji przedstawiono przykładowy wykres Gummela, a także przykładowy układ pomiarowy umożliwiający uzyskanie tych danych. Wykres Gummela przedstawia:
-
Prąd bazy w funkcji napięcia baza–emiter (IB w funkcji VBE).
-
Prąd kolektora w funkcji napięcia baza–emiter (IC w funkcji VBE).
Napięcie baza–kolektor (VBC) jest utrzymywane na poziomie zera woltów.

Przykładowy wykres Gummela dla normalnego obszaru pracy i układ pomiarowy.Dane wprowadza się do kreatora jako serię punktów odczytanych ze źródłowego wykresu Gummela. Należy wprowadzić nieprzetworzone wartości IB i IC – kreator zastosuje funkcję LN do danych krzywych.
-
-
Collector Current versus Base-Emitter Voltage
Te dane służą do wstępnego wyznaczenia parametru VAF. Na poniższej ilustracji przedstawiono przykładowy wykres prądu kolektora (IC) w funkcji napięcia baza–emiter (VBE), a także przykładowy układ pomiarowy umożliwiający uzyskanie tych danych. Układ służy do uzyskania dwóch krzywych IC w funkcji VBE dla dwóch różnych wartości napięcia baza–kolektor (VBC). Pomiary krzywych należy wykonywać przy możliwie małych prądach i przy VBC możliwie bliskim zeru woltów.

Przykładowe wykresy i układ pomiarowy dla zależności VBE od IC.Dane wprowadza się do kreatora jako serię punktów w dwóch tabelach – po jednej dla każdej krzywej źródłowej. W każdym przypadku należy również wprowadzić zastosowaną wartość VBC.
-
-
Reverse-Bias Parameters
Poniższe parametry służą do opisu stałoprądowych charakterystyk prądowo-napięciowych tranzystora BJT w inwersyjnym obszarze pracy:
IS
Transportowy prąd nasycenia (w amperach).
BR
Idealne maksymalne wzmocnienie prądowe beta w inwersyjnym obszarze pracy.
NR
Współczynnik emisji prądu w inwersyjnym obszarze pracy.
RB
Rezystancja bazy przy zerowej polaryzacji (w omach).
RC
Rezystancja kolektora (w omach).
RE
Rezystancja emitera (w omach).
IKR
Prąd graniczny, przy którym wzmocnienie beta w inwersyjnym obszarze pracy zaczyna maleć przy dużych prądach (w amperach).
ISC
Prąd nasycenia upływu złącza B-C (w amperach).
NC
Współczynnik emisji prądu upływu złącza B-C.
VAR
Napięcie Early’ego w inwersyjnym obszarze pracy (w woltach).
W kolejnych sekcjach szczegółowo opisano wymagane dane pomiarowe, których wprowadzenie umożliwi kreatorowi wyznaczenie tych parametrów.
-
Reverse Gummel Plot
Dane te służą przede wszystkim do wyznaczania parametrów IS, BR, NR, RB, IKR, ISC i NC. Są również wykorzystywane do optymalizacji parametrów RC, RE i VAR. Poniższy rysunek przedstawia przykładowy wykres Gummela oraz przykładowy układ pomiarowy, za pomocą którego można uzyskać potrzebne dane. Wykres Gummela przedstawia:
-
Prąd bazy w funkcji napięcia baza–kolektor (IB w funkcji VBC).
-
Prąd emitera w funkcji napięcia baza–kolektor (IE w funkcji VBC).
Napięcie baza–emiter (VBE) jest utrzymywane na poziomie zera woltów.

Przykładowy wykres Gummela dla pracy inwersyjnej i układ pomiarowy.Dane wprowadza się do kreatora w postaci serii punktów odczytanych ze źródłowego wykresu Gummela. Należy wprowadzić surowe wartości IB i IE — kreator zastosuje funkcję LN do danych krzywych.
-
-
Emitter Current versus Base-Collector Voltage
Dane te służą do wstępnego wyznaczenia parametru VAR. Poniższy rysunek przedstawia przykładowy wykres prądu emitera (IE) w funkcji napięcia baza–kolektor (VBC) oraz przykładowy układ pomiarowy, za pomocą którego można uzyskać potrzebne dane. Układ służy do wyznaczenia dwóch krzywych IE w funkcji VBC dla dwóch różnych wartości napięcia baza–emiter (VBE). Pomiary krzywych należy wykonywać przy możliwie małych prądach i przy VBE możliwie bliskim zeru woltów.

Przykładowe wykresy i układ do pomiaru IE w funkcji VBC.Dane wprowadza się do kreatora w postaci serii punktów w dwóch tabelach — po jednej dla każdej krzywej danych źródłowych. W każdym przypadku należy również wprowadzić zastosowaną wartość VBE.
-
Charakterystyki modelowane na podstawie danych z karty katalogowej producenta
Na podstawie danych z karty katalogowej producenta można modelować następujące charakterystyki.
-
Forward-Bias Parameters
Poniższe parametry służą do opisu stałoprądowych charakterystyk prądowo-napięciowych tranzystora bipolarnego (BJT) w obszarze polaryzacji w kierunku przewodzenia:
IS
Transportowy prąd nasycenia (w amperach).
BF
Idealne maksymalne wzmocnienie prądowe beta w kierunku przewodzenia.
NF
Współczynnik emisji prądu w kierunku przewodzenia.
RE
Rezystancja emitera (w omach).
IKF
Prąd początku spadku wzmocnienia beta w kierunku przewodzenia przy dużych prądach (w amperach).
ISE
Prąd nasycenia upływu złącza B–E (w amperach).
NE
Współczynnik emisji prądu upływu złącza B–E.
W kolejnych sekcjach szczegółowo opisano wymagane dane, których wprowadzenie umożliwi kreatorowi wyznaczenie tych parametrów.
-
Base-Emitter Voltage versus Collector Current
Dane te służą do wyznaczania parametrów IS, NF, RE i IKF. Poniższy rysunek przedstawia przykładowy wykres napięcia baza–emiter (VBE) w funkcji prądu kolektora (IC), zaczerpnięty z karty katalogowej.
Dane wprowadza się do kreatora w postaci serii punktów odczytanych z wykresu źródłowego. Należy wprowadzić surowe wartości IC — kreator zastosuje funkcję LN do danych krzywej.
Należy również wprowadzić wartość wymuszonego wzmocnienia beta dla tej krzywej (β = IC/IB). Na przykładowym wykresie na powyższym rysunku wartość ta jest podana w lewym górnym rogu, więc należy wprowadzić wartość 10.
-
DC Current Gain versus Collector Current
Dane te służą do wyznaczania parametrów BF, NE, ISE i IKF. Poniższy rysunek przedstawia przykładowy wykres stałoprądowego wzmocnienia prądowego (hFE) w funkcji prądu kolektora (IC), zaczerpnięty z karty katalogowej.
Dane wprowadza się do kreatora w postaci serii punktów odczytanych z wykresu źródłowego. Aby zapewnić dokładność, należy wprowadzić wartości stałoprądowego wzmocnienia prądowego dla małych, średnich i dużych wartości prądu kolektora.
-
-
Forward Early Voltage
Poniższy parametr służy do modelowania efektu modulacji szerokości bazy w modelu tranzystora Gummela–Poona:
VAF
Napięcie Early’ego w kierunku przewodzenia (w woltach).
Aby wyznaczyć ten parametr, należy wprowadzić punkt z krzywej admitancji wyjściowej (hOE) w funkcji prądu kolektora (IC). Poniższy rysunek przedstawia przykład takiej krzywej.
Odczytaj dowolny punkt na krzywej. W przykładzie na powyższym rysunku można odczytać IC = 1 mA i hOE = 30 μmho.
Dane są zwykle przedstawiane w formie tabeli, której przykład pokazano na poniższym rysunku.

Przykładowy zapis tabelaryczny admitancji wyjściowej.Interesujące nas wartości na rysunku — które należy wprowadzić do kreatora — to 1 mA dla prądu kolektora i 30 μmho dla admitancji wyjściowej (zwykle stosuje się wartość maksymalną).
Charakterystyki modelowane na podstawie danych pomiarowych lub danych producenta
Na podstawie danych z karty katalogowej producenta lub z bezpośrednich pomiarów fizycznego elementu można modelować następujące charakterystyki.
-
Base-Emitter Capacitance
Poniższe parametry służą do opisu pojemności złącza baza–emiter spolaryzowanego zaporowo:
CJE
Pojemność warstwy zubożonej złącza B–E przy zerowej polaryzacji (w faradach).
MJE
Wykładnik potęgowy złącza B–E.
VJE
Potencjał wbudowany złącza B–E (w woltach).
Aby wyznaczyć te parametry, wymagany jest wykres pojemności złącza B–E spolaryzowanego zaporowo (Cj) w funkcji napięcia (VBE). Jeśli miernik pojemności nie jest dostępny, do uzyskania danych można wykorzystać przykładowy układ pomiarowy przedstawiony na poniższym rysunku. Rysunek przedstawia również przykładowe wykresy uzyskane za pomocą takiego układu — odpowiednio VBE i Cj w funkcji czasu. Z wykresów tych można łatwo odczytać wartości VBE i Cj dla odpowiadających sobie chwil.

Przykładowy układ i wykresy pojemności złącza B–E spolaryzowanego zaporowo.Dane wprowadza się do kreatora w postaci serii punktów odczytanych z wykresów źródłowych.
Przykładowy układ przedstawiony na powyższym rysunku opiera się na równaniu:
I = C * (dv/dt)Po rozwiązaniu tego równania względem C otrzymujemy:
C = I/(dv/dt)Układ wytwarza liniowo narastające napięcie ze źródła V1. Obliczając nachylenie tego przebiegu napięcia, można wyznaczyć człon
dv/dtrównania. Dzieląc zmierzony prąd diody przez nachylenie przebiegu napięcia, można uzyskać charakterystykę pojemności diody. Dwa wykresy na powyższym rysunku odnoszą się do układu w następujący sposób:-
Górny wykres – VBE to V1.
-
Dolny wykres – Cj to q1[ie]/(dV1/dt).
-
-
Base-Collector Capacitance
Poniższe parametry służą do opisu pojemności złącza baza–kolektor przy polaryzacji zaporowej:
CJC
Pojemność warstwy zubożonej złącza B-C przy zerowej polaryzacji (w faradach).
MJC
Wykładnik potęgowy złącza B-C.
VJC
Potencjał wbudowany złącza B-C (w woltach).
Aby wyznaczyć te parametry, potrzebny jest wykres pojemności złącza B-C spolaryzowanego zaporowo (Cj) w funkcji napięcia (VBC). Jeśli miernik pojemności nie jest dostępny, do uzyskania danych można wykorzystać przykładowy układ pomiarowy przedstawiony na poniższym rysunku. Rysunek przedstawia również przykładowe wykresy uzyskane z takiego układu – odpowiednio VBC i Cj w funkcji czasu. Z wykresów tych można łatwo odczytać wartości VBC i Cj w odpowiadających sobie chwilach.

Przykładowy układ i wykresy pojemności złącza B-C przy polaryzacji zaporowej.Dane wprowadza się do kreatora jako serię punktów danych odczytanych z wykresu źródłowego.
Przykładowy układ na powyższym rysunku opiera się na równaniu:
I = C * (dv/dt)Po przekształceniu tego równania względem C otrzymujemy:
C = I/(dv/dt)Układ wytwarza liniowo narastające napięcie ze źródła V1. Obliczając nachylenie tego przebiegu napięcia, można wyznaczyć człon
dv/dtrównania. Dzieląc zmierzony prąd diody przez nachylenie przebiegu napięcia, można uzyskać charakterystykę pojemności diody. Dwa wykresy na powyższym rysunku odnoszą się do układu w następujący sposób:-
Górny wykres – VBC to V1.
-
Dolny wykres – Cj to q1[ic]/(dV1/dt).
-
-
Collector-Substrate Capacitance
Poniższe parametry służą do opisu pojemności złącza kolektor–podłoże przy polaryzacji zaporowej:
CJS
Pojemność złącza kolektor–podłoże przy zerowej polaryzacji (w faradach).
MJS
Wykładnik potęgowy złącza z podłożem.
VJS
Potencjał wbudowany złącza z podłożem (w woltach).
Aby wyznaczyć te parametry, potrzebny jest wykres pojemności złącza C-S spolaryzowanego zaporowo (Cj) w funkcji napięcia (VCS). Jeśli miernik pojemności nie jest dostępny, do uzyskania danych można wykorzystać przykładowy układ pomiarowy przedstawiony na poniższym rysunku. Rysunek przedstawia również przykładowe wykresy uzyskane z takiego układu – odpowiednio VCS i Cj w funkcji czasu. Z wykresów tych można łatwo odczytać wartości VCS i Cj w odpowiadających sobie chwilach.

Przykładowy układ i wykresy pojemności złącza C-S przy polaryzacji zaporowej.Dane wprowadza się do kreatora jako serię punktów danych odczytanych z wykresu źródłowego.
Przykładowy układ na powyższym rysunku opiera się na równaniu:
I = C * (dv/dt)Po przekształceniu tego równania względem C otrzymujemy:
C = I/(dv/dt)Układ wytwarza liniowo narastające napięcie ze źródła V1. Obliczając nachylenie tego przebiegu napięcia, można wyznaczyć człon
dv/dtrównania. Dzieląc zmierzony prąd diody przez nachylenie przebiegu napięcia, można uzyskać charakterystykę pojemności diody. Dwa wykresy na powyższym rysunku 24 odnoszą się do układu w następujący sposób:-
Górny wykres – VCS to V1.
-
Dolny wykres – Cj to q1[is]/(dV1/dt).
-
-
Transit Times
Poniższe parametry służą do opisu czasu przelotu nośników w tranzystorze BJT:
TF
Idealny czas przelotu w kierunku normalnym (w sekundach).
TR
Idealny czas przelotu w kierunku inwersyjnym (w sekundach).
Aby wyznaczyć te parametry, należy wprowadzić do kreatora częstotliwość graniczną tranzystora (fT). Jest to częstotliwość, przy której wzmocnienie prądowe tranzystora staje się równe jedności. Dane te zazwyczaj znajdują się w kartach katalogowych producenta w postaci prostych wartości liczbowych.
Poniższy rysunek przedstawia sposób prezentacji tej informacji w karcie katalogowej producenta. Interesująca nas wartość na rysunku – którą należy wprowadzić do kreatora – wynosi 100 MHz.

Przykładowy wpis w tabeli dotyczący iloczynu wzmocnienia prądowego i szerokości pasma.
Parametry niewyznaczane przez kreator
Poniższe parametry są trudne do wyznaczenia na podstawie danych pomiarowych i zwykle nie występują w kartach katalogowych producentów. Nie są one ani wyznaczane przez kreator, ani dodawane do wynikowego pliku modelu tranzystora BJT. Mimo że nie występują w pliku MDL, SPICE nadal używa tych parametrów podczas symulacji tranzystora BJT, korzystając z ich wbudowanych wartości domyślnych. Dla wygody wartości te podano poniżej.
IRB |
Prąd, przy którym rezystancja bazy spada do połowy drogi między wartością początkową a minimalną (w amperach). (Domyślnie = nieskończoność). |
|
RBM |
Minimalna rezystancja bazy przy dużych prądach (w omach). (Domyślnie = RB). |
|
XTF |
Współczynnik zależności TF od polaryzacji. (Domyślnie = 0). |
|
VTF |
Napięcie opisujące zależność TF od VBC (w woltach). (Domyślnie = nieskończoność). |
|
ITF |
Parametr opisujący wpływ dużych prądów na TF (w amperach). (Domyślnie = 0). |
|
PTF |
Dodatkowe przesunięcie fazowe przy częstotliwości = 1.0/(TF*2PI) Hz (w stopniach). (Domyślnie = 0). |
|
XCJC |
Część pojemności warstwy zubożonej złącza B-C połączona z wewnętrznym węzłem bazy. (Domyślnie = 1). |
|
XTB |
Wykładnik temperaturowy współczynnika beta w kierunku normalnym i inwersyjnym. (Domyślnie = 0). |
|
EG |
Szerokość przerwy energetycznej określająca wpływ temperatury na IS (w eV). (Domyślnie = 1,11). |
|
XTI |
Wykładnik temperaturowy opisujący wpływ temperatury na IS. (Domyślnie = 3). |
|
KF |
Współczynnik szumu migotania. (Domyślnie = 0). |
|
AF |
Wykładnik szumu migotania. (Domyślnie = 1). |
|
FC |
Współczynnik we wzorze na pojemność warstwy zubożonej przy polaryzacji w kierunku przewodzenia. (Domyślnie = 0,5). |
|
TNOM |
Temperatura pomiaru parametrów (w ˚C). (Domyślna wartość tego parametru jest równa wartości wprowadzonej dla parametru TNOM na stronie SPICE Options w oknie dialogowym Analysis Setup. Domyślnie wynosi ona 27˚C). |
Oczywiście każdy z tych parametrów można ręcznie dodać do pliku MDL, określając wartości, które mają być używane zgodnie z potrzebami.
