Capturing the Logical System Design

W skrócie

Dowiedz się, jak odwzorować projekt logiczny systemu wielopłytkowego w Altium Designer, łącząc podrzędne projekty PCB z modułami na schemacie wielopłytkowym. W tym artykule wyjaśniamy, jak przygotować złącza do definiowania połączeń na poziomie systemu, określić źródła i właściwości modułów oraz zaimportować dane pinów i sieci złączy w celu uzupełnienia punktów przyłączeniowych modułów. Czytaj dalej, aby rozpocząć tworzenie przejrzystego odwzorowania połączeń między płytkami w swoim systemie.

- Poznaj etapy tworzenia schematu wielopłytkowego i łączenia modułów z podrzędnymi projektami PCB.
- Dowiedz się, jak parametr `System:Connector` wskazuje złącza, które mają zostać uwzględnione w projekcie na poziomie systemu.
- Odkryj, jak weryfikować podrzędne projekty PCB i importować dane ich połączeń do punktów przyłączeniowych modułów.
Zagłęb się w temat dzięki AI:

Podstawowe kroki tworzenia schematu systemu wielopłytkowego na podstawie podrzędnych projektów PCB:

  1. Utwórz projekt wielopłytkowy i dodaj do niego dokument schematu wielopłytkowego.

  2. Umieść na schemacie wielopłytkowym bloki graficzne (moduły), które będą logicznie reprezentować podrzędne projekty PCB.

  3. Powiąż każdy moduł z odpowiednim projektem podrzędnym.

  4. Zaimportuj dane połączeń projektu podrzędnego do projektu wielopłytkowego.

  5. Dodaj połączenia między modułami, aby utworzyć logiczny projekt systemu.

Aby dodać dokument schematu wielopłytkowego (*.MbsDoc) do projektu wielopłytkowego, kliknij prawym przyciskiem myszy pozycję projektu w panelu Projects, a następnie wybierz Add New to Project » Multi-board Schematic z menu kontekstowego.

Każdy projekt wielopłytkowy może zawierać tylko jeden dokument schematu wielopłytkowego.

Przygotowanie projektów PCB do projektowania wielopłytkowego

Projekty PCB w Altium Designer, które reprezentują podrzędne płytki w projekcie wielopłytkowym, zawierają określone złącza, takie jak złącza krawędziowe lub wtyki i gniazda listwowe, pełniące funkcję interfejsu elektrycznego i fizycznego do innych płytek PCB w projekcie systemu.

Te złącza i powiązane z nimi sieci elektryczne muszą zostać wykryte i przetworzone przez dokument schematu wielopłytkowego (logicznego), aby zdefiniować połączenia między płytkami w projekcie na poziomie systemu. Funkcję tę umożliwia obecność określonego parametru komponentu dla złączy w projekcie PCB — parametru o nazwie System i wartości Connector.

Złącza z parą parametr:wartość System:Connector są wykrywane podczas synchronizacji każdego modułu na poziomie systemu z jego podrzędnym projektem PCB za pomocą polecenia Import from Child Projects. Zostało to wyjaśnione w dalszej sekcji Reprezentowanie podrzędnych projektów PCB na schemacie wielopłytkowym.

Dla każdego złącza w projekcie PCB przeznaczonego do połączenia na poziomie systemu zaznacz komponent złącza, a następnie dodaj specjalny parametr komponentu do listy w obszarze Parameters na karcie General panelu Properties, gdy komponent jest zaznaczony.

Aby dowiedzieć się więcej o właściwościach komponentów, zapoznaj się ze stroną Praca z umieszczonymi komponentami.

Obecność parametru o nazwie System i wartości Connector wiąże to złącze PCB ze schematem wielopłytkowym.
Obecność parametru o nazwie System i wartości Connector wiąże to złącze PCB ze schematem wielopłytkowym.

Reprezentowanie projektów podrzędnych na schemacie wielopłytkowym

Połączenia między projektami PCB tworzącymi projekt wielopłytkowy definiuje się przez umieszczenie na schemacie reprezentujących je bloków (modułów) i połączenie ich udostępnionych złączy (wejść modułów) za pomocą połączeń.

Moduły reprezentujące podrzędne projekty PCB i konkretne płytki PCB w tych projektach umieszcza się w obszarze projektowym z menu Place » Module.

Aby określić źródło umieszczonego modułu, zaznacz go w obszarze projektowym, a następnie w panelu Properties użyj przycisku  powiązanego z polem Project w obszarze Source na karcie General, aby otworzyć okno dialogowe Choose Project (odmianę okna dialogowego Open Project), w którym możesz odszukać i wybrać projekt PCB lub projekt wielopłytkowy jako źródło modułu. Po wybraniu wymaganego projektu wybierz z listy rozwijanej Assembly/Board odpowiedni projekt płytki PCB lub zespołu wielopłytkowego w obrębie tego projektu.

Utworzony projekt wielopłytkowy ma hierarchiczną strukturę dokumentów, która obejmuje dokumenty źródłowe oraz podprojekty podrzędne powiązane z modułami na schemacie systemu. Struktura projektu podrzędnego jest dodawana do projektu wielopłytkowego natychmiast po powiązaniu modułu projektu systemu z tym projektem zewnętrznym. Rozwiń strukturę projektu w panelu Projects, aby wyświetlić pliki składowe projektu wielopłytkowego i jego projektów podrzędnych.

Aby projekt wielopłytkowy pobierał i przetwarzał prawidłowe dane ze swoich podprojektów, płytka PCB każdego projektu powinna być zsynchronizowana ze schematem i wolna od błędów projektowych lub rysunkowych. Aby zweryfikować podprojekt PCB, kliknij prawym przyciskiem myszy jego nazwę w panelu i wybierz polecenie Validate PCB Project <ProjectName>.PrjPcb — wszelkie problemy zostaną wyświetlone w panelu Messages.

Javascript ID: Pnl_Properties_MBS_Module_Source
 
 
 
 
 
  • Projekt PCB, inny projekt wielopłytkowy lub projekt wiązki przewodów można dodać do struktury projektu wielopłytkowego, klikając prawym przyciskiem myszy pozycję tego ostatniego w panelu Projects, wybierając polecenie Add Existing to Project, a następnie odszukując i wybierając odpowiedni lokalny plik *.PrjPcb, *.PrjMbd lub *.PrjHar. Jeśli projekt PCB lub wiązki przewodów, który ma zostać częścią projektu wielopłytkowego, jest już otwarty w Altium Designer, możesz przeciągnąć jego pozycję w panelu Projects na pozycję nadrzędnego projektu wielopłytkowego, dodając go do jego struktury (). Następnie ręcznie umieść nowy moduł w dokumencie schematu wielopłytkowego (nadrzędnego projektu wielopłytkowego) i po zaznaczeniu modułu wybierz z listy rozwijanej pola Source w panelu Properties podrzędny projekt PCB (i jego dokument PCB) lub podrzędny projekt wielopłytkowy (i jego dokument zespołu wielopłytkowego) jako źródło tego modułu (). Projekt wiązki przewodów można zsynchronizować z projektem wielopłytkowym (więcej informacji znajdziesz na stronie Definiowanie schematu okablowania).

  • Aby usunąć podrzędny projekt PCB lub projekt wielopłytkowy ze struktury nadrzędnego projektu wielopłytkowego, usuń wszystkie moduły odwołujące się do tego projektu podrzędnego z dokumentu schematu wielopłytkowego projektu nadrzędnego. Projekt podrzędny zostanie wówczas automatycznie usunięty ze struktury.

  • Podrzędny projekt PCB lub wiązki przewodów można również usunąć ze struktury nadrzędnego projektu wielopłytkowego, przeciągając pozycję projektu podrzędnego poza strukturę projektu wielopłytkowego. Pamiętaj, że w takim przypadku (i tylko w przypadku projektu PCB) moduły odwołujące się do projektu podrzędnego pozostaną w dokumencie schematu wielopłytkowego, a ich powiązania z projektem podrzędnym również zostaną zachowane. Aby całkowicie usunąć z nadrzędnego projektu wielopłytkowego odniesienia do usuniętego projektu podrzędnego, usuń te moduły ręcznie.

Po zaznaczeniu umieszczonego modułu użyj panelu Properties, aby zdefiniować pozostałe właściwości modułu:

  • Użyj właściwości Designator i Title w sekcji Properties na karcie General panelu, aby określić odpowiednio identyfikator modułu na schemacie i tekst tytułu. Użyj przycisku  po prawej stronie odpowiedniego pola, aby przełączyć jego widoczność na schemacie wielopłytkowym, oraz przycisku , aby włączyć lub wyłączyć możliwość edycji wartości. Użyj elementów sterujących czcionką oraz Other, aby skonfigurować czcionkę tekstu, jego położenie w dokumencie, a w przypadku tekstu tytułu także widoczność nazwy parametru.

  • Tabela w sekcji Entries na karcie General panelu Properties, wyświetlana po zaznaczeniu modułu, zostanie wypełniona po dodaniu do modułu jego wejść — patrz poniżej.

  • Użyj elementów sterujących w sekcji Graphical na karcie General panelu, aby skonfigurować wygląd modułu: jego rozmiar (szerokość i wysokość), grubość, styl i kolor linii obrysu modułu oraz kolor wypełnienia. Dostępne opcje grubości i stylu linii są zdefiniowane w sekcji Line Styles panelu Properties, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt. Więcej informacji można znaleźć na stronie Konfigurowanie dokumentu schematu wielopłytkowego.

  • Użyj elementów sterujących na karcie Parameters panelu, aby dodawać, modyfikować i usuwać parametry modułu oraz konfigurować ich widoczność w obszarze projektowym.  

Dodaj do schematu wielopłytkowego kolejne moduły oraz ich powiązania z projektami podrzędnymi, zgodnie z wymaganiami kompletnego projektu systemu.

Moduły są wypełniane danymi projektowymi z powiązanych z nimi projektów przez zaimportowanie danych projektu za pomocą następujących poleceń dostępnych w menu głównym lub w menu kontekstowym obszaru projektowego:

  • Design » Import From Child Projects – przenosi dane projektowe ze wszystkich projektów źródłowych (podrzędnych) do przypisanych im modułów.

  • Design » Import From Selected Child Projects – przenosi dane projektowe z odpowiednich projektów źródłowych (podrzędnych) do aktualnie zaznaczonych modułów.

Co najważniejsze, proces ten obejmuje dane wyprowadzeń i sieci każdego złącza w projektach podrzędnych, do którego przypisano specjalny parametr System:Connector (patrz szczegóły powyżej). Po zakończeniu importu dla każdego z tych złączy jest automatycznie tworzone wejście modułu na symbolu graficznym odpowiedniego modułu. Wejście złącza jest aktywnie powiązane z wyprowadzeniami i sieciami złącza w projekcie podrzędnym. Zaznacz symbol graficzny wejścia modułu w obszarze projektowym, aby wyświetlić jego szczegóły, takie jak wyprowadzenia i sieci złącza, w panelu Properties. Dopóki wejście nie zostanie połączone z wejściem innego modułu, lista elementów i wyprowadzeń tego wejścia w panelu będzie wskazywać złącze i wyprowadzenia jako niesparowane.

 
  • Chociaż wejścia są umieszczane automatycznie podczas importowania danych z projektów podrzędnych, wejście modułu można również umieścić ręcznie, wybierając polecenie Place » Entry z menu głównego.

  • Zaznacz wejście modułu, klikając jego symbol graficzny, a następnie przeciągnij je wzdłuż obwodu modułu w odpowiednie miejsce. Pamiętaj, że oznaczenie wejścia można niezależnie przeciągnąć w inne miejsce.

  • Można również przenieść grupę wejść modułu, zaznaczając więcej niż jedno wejście, a następnie przeciągając grupę w żądane miejsce.

  • Kolor wejścia pomaga w jego prawidłowym przenoszeniu i umieszczaniu. Poza modułem wejście będzie wyświetlane częściowo i w kolorze szarym, a jego umieszczenie nie będzie możliwe. Po przesunięciu nad moduł pojawi się pełny, kolorowy symbol wejścia, wskazując, że można je umieścić w tym miejscu.

Po zaznaczeniu wejścia użyj panelu Properties, aby zdefiniować jego właściwości:

  • Użyj elementów sterujących w sekcji Properties na karcie General panelu, aby zmienić wartość, widoczność i styl właściwości Designator wejścia oraz wybrać jego Type (Male/Female). W tej sekcji panelu podawana jest również liczba wyprowadzeń złącza wejścia (Number of Pins) oraz numer identyfikacyjny przypisany do tego wejścia w module nadrzędnym (Entry Number).

  • Włącz opcję System Entry, aby oznaczyć wejście jako połączenie na poziomie systemu, które nie jest połączone przewodem z innym modułem, na przykład wejście reprezentujące gniazdo zasilania.

    Podrzędny projekt wielopłytkowy zawiera moduł, którego wejście ma włączoną opcję System Entry.

    Po zaimportowaniu zmian do nadrzędnego projektu wielopłytkowego to złącze wejścia zostanie dodane jako wejście modułu reprezentującego projekt podrzędny.

     
  • Gdy wejście jest połączone za pomocą wiązki przewodów lub kabla (dowiedz się więcej), sekcja Mated Component panelu jest wypełniana danymi o sparowanym komponencie.

  • W sekcji Mated Pins obszarze panelu kolumna Pin zawiera listę poszczególnych pinów złącza i powiązanych z nimi sieci. Po połączeniu tego wejścia kolumna Mated Pin jest wypełniana listą połączonych pinów. Ponadto po połączeniu tego wejścia karta Addresses panelu Properties jest wypełniana tabelarycznym zestawieniem ścieżek połączeń i sieci dla tego wejścia (dowiedz się więcej).

  • Użyj elementów sterujących na karcie Parameters panelu, aby dodawać, modyfikować i usuwać parametry wejścia oraz konfigurować ich widoczność w obszarze projektowania.

Po dodaniu wejść do modułu tabela w obszarze Entries na karcie General panelu Properties, wyświetlana po zaznaczeniu modułu, zostanie wypełniona tymi wejściami. Kolumna Part(s) przedstawia każde wejście modułu za pomocą oznaczenia i nazwy złącza wejściowego w projekcie źródłowym. Dane te można edytować dla wygody — nazewnictwo jest lokalne dla projektu wielopłytkowego i nie wpływa na źródłowe projekty podrzędne.

  • Kolumna Mated part(s) jest wypełniana danymi po połączeniu wejścia z innym wejściem w projekcie wielopłytkowym za pomocą połączenia. Więcej informacji można znaleźć na stronie Praca z połączeniami.

  • Z poziomu listy można szybko przełączać widoczność oznaczenia wejścia (  /  ) oraz jego typ (  /  ). Przyciski  i  służą odpowiednio do dodawania nowego, niezdefiniowanego wejścia do modułu i listy oraz do usuwania z modułu wejścia zaznaczonego na liście.

  • Przyciski  i  służą odpowiednio do dzielenia zaznaczonego na liście połączenia na dwa powiązane wejścia modułu oraz do ponownego scalania wcześniej rozdzielonych wejść w jedno. Więcej informacji można znaleźć na stronie Praca z połączeniami.

Obsługa zewnętrznych urządzeń peryferyjnych i komponentów

Ta funkcja jest dostępna, gdy opcje MBS.PlacePart i MBS.UseGeometryMaker są włączone w oknie dialogowym Advanced Settings.

Dokument schematu wielopłytkowego obsługuje zewnętrzne urządzenia peryferyjne i komponenty, które nie są częścią standardowych podrzędnych zespołów płytek PCB (czyli komponenty „spoza PCB”). Mogą to być na przykład zewnętrzne przełączniki, czujniki i inne gotowe moduły elektroniczne innych producentów. Funkcjonalność ta jest realizowana poprzez obsługę dwóch typów obiektów:

  • Custom Part – obiekt podobny do modułu, który umożliwia powiązanie jednego lub większej liczby komponentów bibliotecznych i jest dodawany do dokumentu schematu wielopłytkowego za pomocą polecenia Place » Custom Part z menu głównego. Po zaznaczeniu umieszczonej części niestandardowej w obszarze projektowania użyj obszaru Linked Components panelu Properties, aby dodawać komponenty do części niestandardowej i usuwać je z niej za pomocą odpowiednio przycisków  i . Jeśli lista powiązanych komponentów zawiera nieaktualne komponenty z Workspace, kliknij przycisk , aby zaktualizować komponenty do ich najnowszych rewizji. Dla każdego powiązanego komponentu automatycznie dodawane jest wejście.

  • Custom Connection – umożliwia dodanie pojedynczego komponentu bibliotecznego do dokumentu schematu wielopłytkowego przez przeciągnięcie wymaganego komponentu z panelu Components i upuszczenie go w wolnym miejscu na arkuszu. Dla każdego pinu komponentu automatycznie dodawane jest wejście.

    Można również utworzyć niestandardowy symbol komponentu przeznaczony specjalnie do użycia w dokumencie schematu wielopłytkowego. Dodanie nazw rozdzielonych przecinkami do pola Name we właściwościach pinu pozwala grupować wiele pinów w wejścia, tworząc w ten sposób bardziej przejrzyste symbole z mniejszą liczbą wejść i znacznie upraszczając łączenie takich komponentów.

    Javascript ID: MBS_CustomConn_MultiplePins_AD24_5

    Podczas edycji symbolu schematowego dodaj wiele nazw rozdzielonych przecinkami do pola Name pinu.

    Po dodaniu komponentu do części niestandardowej na schemacie wielopłytkowym zamiast pojedynczego wejścia dla komponentu zostanie utworzone wejście dla każdego pinu komponentu, a także zostaną utworzone wejścia z wieloma pinami.

    Po umieszczeniu komponentu na schemacie wielopłytkowym jako połączenia niestandardowego zostaną utworzone wejścia z wieloma pinami.

Komponenty biblioteczne to komponenty dostępne w połączonym Workspace oraz w dostępnych bibliotekach lokalnych. Po ich umieszczeniu lub zdefiniowaniu można połączyć je z pozostałą częścią projektu, na przykład za pomocą połączeń kablowych i wiązkowych.

Powiązane komponenty zdefiniowane za pomocą części niestandardowych lub połączeń niestandardowych nie są automatycznie uwzględniane w ogólnym zestawieniu materiałowym (BOM) produktu/systemu ani prezentowane w zespole wielopłytkowym (*.MbaDoc).

Nawigacja krzyżowa

Polecenia nawigacji krzyżowej dostępne w menu głównym Design oraz w menu kontekstowym obszaru projektowania umożliwiają szybkie przechodzenie z dokumentu schematu wielopłytkowego do powiązanych elementów w projektach podrzędnych.

  • Aby przejść od aktualnie zaznaczonego modułu lub wejścia do dokumentu PCB lub złącza w tym dokumencie w projekcie PCB, do którego odwołuje się dany moduł, użyj polecenia Design » Crossprobe to PCB/Multi-board. Jeśli moduł odwołuje się do dokumentu zespołu wielopłytkowego (*.MbaDoc) w źródłowym projekcie wielopłytkowym (*.PrjMbd), nawigacja krzyżowa prowadzi do dokumentu zespołu wielopłytkowego.

  • Aby przejść od aktualnie zaznaczonego modułu lub wejścia do schematu najwyższego poziomu lub złącza na odpowiednim schemacie w projekcie PCB, do którego odwołuje się dany moduł, użyj polecenia Design » Crossprobe to Schematic.

  • Aby przejść od aktualnie zaznaczonego modułu lub wejścia do płytki lub złącza na tej płytce w dokumencie zespołu wielopłytkowego (*.MbaDoc) w projekcie wielopłytkowym (*.PrjMbd), użyj polecenia Design » Crossprobe to MBA.

  • Aby przejść od aktualnie zaznaczonego połączenia wiązkowego w dokumencie schematu wielopłytkowego (*.MbsDoc) do powiązanego projektu wiązki (*.PrjHar), użyj polecenia Design » Crossprobe to Harness. Zostanie otwarty dokument schematu połączeń powiązanego projektu wiązki.

Podczas nawigacji krzyżowej z wejścia modułu obiekty wskazane w docelowym dokumencie schematu/PCB będą wyświetlane zgodnie z opcjami Highlight Methods zdefiniowanymi na stronie System – Navigation w Preferences. Wyróżnianie nie zostanie zastosowane do dokumentu schematu systemu wielopłytkowego.

Drukowanie lub eksport do PDF

Aby wydrukować aktualnie aktywny dokument schematu systemu wielopłytkowego, wybierz File » Print z menu głównego (skrót: Ctrl+P). Otworzy się okno dialogowe Print . Po lewej stronie okna dialogowego znajduje się skalowalny podgląd wydruku. Po prawej stronie dostępne są standardowe opcje drukowania. Umożliwiają one wybór konkretnej drukarki, sprawdzenie jej lokalizacji, wyświetlenie liczby dokumentów aktualnie znajdujących się w kolejce drukowania, ustawienie liczby kopii do wydrukowania, rozmiaru strony i jej orientacji. Po kliknięciu zestaw do wydruku zostanie wysłany do wybranego urządzenia drukującego zgodnie ze zdefiniowanymi opcjami.

Okno dialogowe Print
Okno dialogowe Print

Aby wyeksportować dokument schematu systemu wielopłytkowego do pliku PDF, wybierz File » Export to PDF z menu głównego.

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents