Defining the Wiring Diagram

Poszczególne połączenia przewodowe w obrębie wiązki są określone na schemacie okablowania wiązki (*.WirDoc). Dodaj ten dokument do projektu wiązki z panelu Projects, klikając prawym przyciskiem myszy wpis projektu, a następnie wybierając Add New to Project » Harness Wiring Diagram z menu kontekstowego (lub używając polecenia File » New » Harness Wiring Diagram z menu głównego).

Konfigurowanie dokumentu schematu okablowania wiązki

Opcje dokumentu schematu okablowania wiązki można skonfigurować w panelu Properties, gdy w obszarze projektowym dokumentu nie jest zaznaczony żaden obiekt. Główne ustawienia to:

  • W obszarze General na karcie General panelu – wybierz jednostki miary obowiązujące dla dokumentu i jego elementów graficznych oraz ustaw siatki, aby ułatwić rozmieszczanie. Altium Designer oferuje trzy typy siatki: visible grid do nawigacji, snap grid do rozmieszczania oraz snap distance wspomagający tworzenie połączeń.

  • W obszarze Page Options na karcie General panelu – skonfiguruj rozmiar arkusza dokumentu i tabelkę rysunkową albo wybierz spośród dostępnych szablonów schematu okablowania wiązki.

Karty General i Parameters panelu Properties, gdy w dokumencie schematu okablowania wiązki nie jest zaznaczony żaden obiekt 
Karty General i Parameters panelu Properties, gdy w dokumencie schematu okablowania wiązki nie jest zaznaczony żaden obiekt

  • Konfigurowanie dokumentu schematu okablowania wiązki jest podobne do konfigurowania dokumentu schematu (*.SchDoc) projektu PCB. Więcej informacji znajdziesz na stronie Setting Up a Schematic Document.

  • Użyj listy rozwijanej Length Units, aby wybrać jednostki długości dla dokumentu. Wartości Strip Length i Pull Off Length dla socket cavities będą wyświetlane z użyciem wybranych jednostek. Obsługiwane jednostki to mm, cm, m, in i ft. Domyślne jednostki długości dla nowo tworzonych dokumentów schematu okablowania można zdefiniować na stronie Harness Design – General page w oknie dialogowym Preferences.

  • Aby dowiedzieć się więcej o tworzeniu szablonów dokumentów okablowania wiązki, przejdź do strony Creating Harness Template Documents.

  • Domyślne właściwości obiektów schematu okablowania wiązki można skonfigurować na stronie Harness Design – Defaults page w oknie dialogowym Preferences. Właściwości te będą stosowane podczas umieszczania kolejnych obiektów.

  • Podczas tworzenia dokumentu schematu okablowania wiązki możesz również używać obiektów tekstowych i rysunkowych. Praca z tymi obiektami w dokumencie schematu okablowania wiązki jest podobna do pracy z nimi w dokumencie schematu (*.SchDoc) projektu PCB. Więcej informacji o tych obiektach znajdziesz w Working with Text Objects on a Schematic oraz Working with Drawing Objects on a Schematic.

    • Zwróć uwagę, że w ramkach tekstowych i notatkach obsługiwane są również active links do obiektów schematu okablowania wiązki (np. przewodów i komponentów) oraz obiektów rysunku rozmieszczenia wiązki (np. wiązek przewodów i punktów połączeń). Kliknij łącze w umieszczonej ramce tekstowej lub notatce, aby wykonać cross-probing do tego obiektu w skojarzonym dokumencie.

  • Aby sprawdzić schemat okablowania wiązki pod kątem naruszeń logicznych, elektrycznych i kreślarskich, obsługiwanych jest szereg kontroli naruszeń. Więcej informacji znajdziesz na stronie Validating the Harness Design .

  • Dokument schematu okablowania wiązki można zapisać w formacie ASCII, co może być korzystne podczas udostępniania. Użyj polecenia File » Save As i wybierz Harness Wiring ascii (*.WirDoc) z listy rozwijanej Save as type w oknie dialogowym Save As, które zostanie otwarte. Podczas zapisywania schematu okablowania ASCII przy użyciu polecenia File » Save otworzy się okno dialogowe File Format, informujące, że używany jest format ASCII. Wybierz wersję ASCII w oknie dialogowym  , aby nadal używać tego formatu.

Synchronizacja projektów Multi-board i Harness

 
 
 
 
 

Gdy projekt wiązki jest częścią projektu wielopłytkowego, schemat okablowania wiązki można zsynchronizować na podstawie danych dokumentu schematu multi-board (*.MbsDoc). W tym celu wybierz polecenie Design » Import Changes From <Multi-board Project> z menu głównego.

Aby dowiedzieć się więcej o dodawaniu projektu wiązki do projektu multi-board, przejdź do strony Harness Design.

Jeśli dokument schematu multi-board zawiera więcej niż jedną definicję połączenia wiązki, otworzy się okno dialogowe Select Harness Definition. Wskaż definicję odnoszącą się do bieżącego projektu wiązki.

Okno dialogowe Select Harness Definition
Okno dialogowe Select Harness Definition

Następnie otworzy się okno dialogowe Engineering Change Order, pokazujące komponenty złączy wiązki i sieci wiązki zdefiniowane na schemacie multi-board, które utworzą podstawę schematu okablowania wiązki.

Użyj okna dialogowego Engineering Change Order, aby zaimportować dane z projektu multi-board. 
Użyj okna dialogowego Engineering Change Order, aby zaimportować dane z projektu multi-board. 

Po wykonaniu zmian () dane z dokumentu schematu multi-board zostaną zaimportowane do schematu okablowania wiązki. Komponenty złączy, z których każdy jest reprezentowany przez swój symbol schematowy, pojawią się w dokumencie schematu okablowania wiązki, początkowo w przypadkowych pozycjach.

Przykład schematu okablowania wiązki tuż po imporcie.
Przykład schematu okablowania wiązki tuż po imporcie.

Między pinami zostaną pokazane linie sieci reprezentujące połączenia logiczne zdefiniowane na schemacie multi-board. Należy pamiętać, że na tym etapie w projekcie nie ma jeszcze fizycznych przewodów.

Zwróć uwagę, że dane łączności importowane z projektu multi-board do projektu wiązki opierają się na nazwach pinów komponentów złączy, dlatego przed importem danych upewnij się, że w bibliotece źródłowej do pinów komponentów przypisano unikalne i poprawne nazwy.

Praca z komponentami

Oprócz synchronizacji z dokumentu schematu multi-board, komponenty można również umieszczać ręcznie na schemacie okablowania wiązki. Umożliwia to umieszczanie komponentów w samodzielnym projekcie wiązki (czyli niebędącym częścią projektu multi-board), a także dodawanie dodatkowych komponentów do schematu okablowania wiązki, który jest częścią projektu multi-board.

Użyj panelu Components, aby umieszczać symbole wymaganych komponentów. Proces umieszczania komponentów jest podobny do tego w edytorze Schematic – więcej informacji znajdziesz na stronie Searching for & Placing Components. Zwróć uwagę, że dla komponentów dodanych ręcznie nie będzie linii sieci, ponieważ nie ma nadrzędnego projektu logicznego, który by nimi sterował.

  • Komponenty są umieszczane z dostępnych bibliotek i reprezentowane na schemacie okablowania wiązki przez modele ich symboli schematowych. Więcej informacji o tworzeniu komponentów znajdziesz w Building & Maintaining Your Components and Libraries.

  • Komponenty wieloczęściowe można również umieszczać na schemacie okablowania wiązki. Gdy dane projektu są importowane do rysunku rozmieszczenia wiązki, oznaczenia są poprawnie przypisywane do komponentów na rysunku rozmieszczenia wiązki. Jeśli na schemacie okablowania wiązki umieszczono wiele części tego samego komponentu, na rysunku rozmieszczenia wiązki zostanie umieszczona tylko jedna instancja komponentu ().

  • Złącza wiązki mogą być używane do tworzenia połączeń między wieloma projektami multi-board, które są zagnieżdżone konfiguracyjnie.

  • Podczas wklejania wyciętych/skopiowanych komponentów wiązki na schemat okablowania wiązki oznaczenia wklejonych komponentów uwzględniają opcję Reset Parts Designators On Paste ze strony Schematic – Graphical Editing page okna dialogowego Preferences. Po wklejeniu komponentów część numeryczna ich oznaczeń zostanie zresetowana do ? po włączeniu tej opcji.

Aby przenieść umieszczony komponent (lub komponent umieszczany z panelu Components) w żądane miejsce, kliknij go i przytrzymaj lewy przycisk myszy, a następnie przesuń mysz. Podczas przeciągania użyj Spacebar, aby obrócić komponent o 90 stopni, oraz klawiszy X i Y, aby odwrócić go odpowiednio w poziomie i w pionie.

Schemat okablowania wiązki po przeniesieniu komponentów
Schemat okablowania wiązki po przeniesieniu komponentów

Właściwości umieszczonego komponentu można skonfigurować w panelu Properties, gdy komponent jest zaznaczony w obszarze projektowym. Panel Properties dla komponentu zawiera następujące karty:

 
 
 
 
 
  • General – ogólne właściwości komponentu, takie jak oznaczenie, komentarz, położenie, parametry itp.

  • Pins – lista pinów komponentu.

  • Cavities – umożliwia przypisywanie componentowi socket cavities (dowiedz się więcej).

  • Associated Parts – umożliwia przypisywanie do komponentu dodatkowych części, takich jak koszulka termokurczliwa.

Karty panelu Properties, gdy zaznaczony jest komponent
Karty panelu Properties, gdy zaznaczony jest komponent

Przypisywanie wnęk gniazd

 
 
 
 
 

Do komponentu wiązki można przypisać wnęki gniazd i ich typ. Aby dodać wnękę i typ, zaznacz komponent w obszarze projektowym. Wybierz pin na karcie Properties panelu Cavities , a następnie kliknij przycisk . Wybierz żądany typ z listy rozwijanej. Obsługiwane są następujące typy wnęk:

  • Crimp – używany do zapewnienia połączenia elektrycznego przez zaciśnięcie tulejki styku wokół przewodnika.

  • Seal – używany do zapewnienia ochrony środowiskowej przez uszczelnienie punktu wejścia przewodu.

  • Plug – używany do wypełnienia otwartej (nieużywanej) wnęki złącza w celu zachowania integralności uszczelnienia środowiskowego.

  • Other – używany do określania innych/dodatkowych części lub materiałów, np. lutu.

Dla typu wnęki Crimp lub wierszy bez dodanego typu wnęki można określić następujące wartości:

  • Strip Length – długość, na której izolacja jest odcinana od przewodnika.

  • Pull Off Length – długość, na której odcięta izolacja jest zsuwana z przewodnika. Może to być użyteczne w przypadkach, gdy koniec przewodu nie jest całkowicie odizolowany, a usunięty fragment izolacji pozostaje na przewodzie, aby zapobiec uszkodzeniu żyły.

Jednostki, w których te wartości są wyświetlane w panelu Properties, gdy zaznaczony jest komponent, określa lista rozwijana Length Units na karcie General panelu Properties, gdy w dokumencie nie jest zaznaczony żaden obiekt.

W oknie dialogowym Select Connector, które zostanie otwarte, wyszukaj i wybierz żądany komponent. Określony typ i związane z nim informacje zostaną dodane do pinu na karcie, jak pokazano na poniższych ilustracjach, na przykład dla dodania zacisku crimp do pinu 1.

Zwróć uwagę, że piny są prezentowane w tabeli karty Cavities według swoich nazw (kolumna Pins), a przypisanie wnęk opiera się na nazwach pinów, dlatego upewnij się, że do pinów komponentu przypisano unikalne i poprawne nazwy.

Dla crimp, seal lub plug do pinu można dodać tylko jedną wnękę danego typu. Po dodaniu wnęki określonego typu pozycja ta będzie niedostępna (wyszarzona) na liście rozwijanej. Do pinu można dodać dowolną liczbę wnęk typu Other.

Piny z przypisanymi zaciskami crimp są oznaczone w obszarze projektowym symbolem , jak pokazano na ilustracji poniżej.

Obszar siatki na karcie Cavities obsługuje wielokrotny wybór oraz operacje kopiowania/wklejania/usuwania dla zaznaczonych wpisów.

  • Wiele wpisów pinów można zaznaczyć za pomocą skrótów Click, Hold&DragCtrl+ClickShift+ClickCtrl+A.

  • Gdy zaznaczonych jest wiele wpisów pinów, kliknij  , aby dodać wnękę do wszystkich zaznaczonych pinów, albo kliknij  lub naciśnij Delete, aby usunąć dodane wnęki z zaznaczonych pinów. 

  • Aby zmienić wnękę pinu, zaznacz jego wpis, a następnie kliknij , aby otworzyć okno dialogowe Select Connector i wybrać nową wnękę.

  • Zaznacz jeden lub więcej wpisów pinów i użyj skrótów Ctrl+X/Ctrl+C, aby wyciąć/skopiować zaznaczone wpisy, a następnie użyj skrótu Ctrl+V, aby wkleić wyciętą/skopiowaną zawartość do aktualnie zaznaczonego wpisu.

Tworzenie połączeń na schemacie okablowania wiązki

Przewody fizyczne są umieszczane w dokumencie schematu okablowania wiązki przez wybranie polecenia Place » Harness Wire z menu głównych (skrót: Shift+W).

Po wybraniu polecenia kliknij pin złącza (gdy kursor znajduje się nad aktywnym punktem pinu, pojawi się przy nim czerwony krzyżyk), aby umieścić punkt początkowy przewodu wiązki. Przesuwaj kursor i klikaj, aby zakotwiczyć serię punktów wierzchołkowych definiujących kształt przewodu wiązki. Po umieszczeniu końcowego punktu wierzchołkowego na aktywnym punkcie innego pinu kliknij prawym przyciskiem myszy, aby zakończyć umieszczanie.

Podczas umieszczania przewodu wiązki naciśnij Shift+Spacebar, aby przełączać tryby umieszczania. Tryb określa sposób tworzenia narożników podczas umieszczania przewodów oraz kąty, pod jakimi można je prowadzić. W trybie 90 Degree lub 45 Degree (rzeczywiste tryby ortogonalne) naciśnij Spacebar, aby przełączać się między podtrybami początku i końca. Bieżący tryb i podtryb są wyświetlane na pasku stanu.

Podczas umieszczania przewodu wiązki linie sieci śledzą/odświeżają się „na żywo”, pokazując w czasie rzeczywistym, gdzie należy poprowadzić przewód, jak pokazano na poniższym filmie. Po zakończeniu połączenia jego linia sieci znika z dokumentu.

Demonstracja funkcji śledzenia na żywo

Po umieszczeniu i zaznaczeniu przewodu wiązki jego wierzchołki można przeciągać, aby zmienić kąt między dwoma sąsiednimi odcinkami (Pokaż przykład).

Zaznacz przewód wiązki w obszarze projektu, aby zmienić go w panelu Properties. W panelu możesz zmienić nazwę zaznaczonego przewodu wiązki, jego szerokość i kolor oraz dodać parametry, które mogą być pokazywane lub ukrywane w obszarze projektu.

Panel Properties, gdy zaznaczony jest przewód wiązki
Panel Properties, gdy zaznaczony jest przewód wiązki

  • Umieszczony przewód wiązki można zastąpić komponentem okablowania wiązki zawierającym pojedynczy przewód. W tym celu zaznacz przewód wiązki do zastąpienia i kliknij przycisk  po prawej stronie pola Design Item ID w panelu Properties. W otwartym oknie dialogowym Replace Component wyszukaj i wybierz wymagany komponent. Umieszczony przewód zostanie zaktualizowany o właściwości i parametry wybranego komponentu przy zachowaniu niezmienionej geometrii. Więcej informacji znajdziesz w sekcji Placing a Harness Wiring Component.

  • Podstawowy kolor przewodu jest definiowany przez parametr Color, który domyślnie jest prezentowany na umieszczonym przewodzie wiązki. Aby edytować kolor, wprowadź jego nazwę (np. Red) lub kod szesnastkowy (wpisując znak #, a następnie liczbę szesnastkową, np. #9900FF) jako wartość parametru. Alternatywnie kliknij przycisk koloru po lewej stronie wartości parametru i użyj otwartego selektora kolorów, w którym kolor przewodu można określić za pomocą wartości RGB lub HEX, przez swobodny wybór albo z zakresu ustawień predefiniowanych.

  • Na schemacie okablowania wiązki obsługiwane są wielokolorowe przewody wiązki poprzez wybór koloru wtórnego i trzeciorzędowego przewodu. W panelu Properties kliknij listę rozwijaną   u dołu obszaru Parameters , a następnie wybierz Secondary i Tertiary , aby zdefiniować żądane kolory; parametr dla wybranego koloru pojawi się w obszarze Parameters . Za pomocą tej samej listy rozwijanej możesz również zdefiniować kolor obramowania przewodu wiązki, wybierając Border. Zwróć uwagę, że parametr Color steruje widocznością połączonej wartości zdefiniowanych parametrów przewodu Color, Secondary Color i Tertiary Color. Klikaj slajdy poniżej, aby zobaczyć przykłady.

    Javascript ID: Harness_WD_Pnl_Properties_Wire_Colors_AD25

    Przewód z zdefiniowanym tylko kolorem podstawowym

    Przewód z zdefiniowanym kolorem wtórnym

    Przewód z zdefiniowanym kolorem trzeciorzędowym

    Przewód z zdefiniowanym kolorem obramowania

    Przewód ze zdefiniowanymi wszystkimi opcjami kolorów

    Wielokolorowe przewody są obsługiwane przez tabele w dokumentach rysunków produkcyjnych projektu wiązki (*.HarDwf) – dowiedz się więcej.

  • Jeśli przewód wiązki ma wartość No dla parametru Include Cut, ten przewód nie będzie prezentowany na liście okablowania ani w tabeli połączeń na rysunku produkcyjnym.

  • Parametry Color, Min. Bending Radius, Thickness i Units przewodu wiązki są używane podczas synchronizacji projektu wiązki z narzędziem MCAD przy użyciu MCAD CoDesigner. Więcej informacji można znaleźć na stronie Synchronizing a Harness Design Project.

Dodawanie złączek i odczepów

W sytuacjach projektowych, gdy nowy przewód musi zostać podłączony do już umieszczonego przewodu, należy najpierw umieścić obiekt złączki (Place » Splice) lub odczepu (Place » Tap).

  • Splice – oryginalny przewód zostaje rozdzielony przez złączkę na dwa oddzielne przewody.

    Javascript ID: Harness_WD_PlacingSplice_AD25

    Do zaznaczonego przewodu (W4) należy podłączyć inny przewód.

    Złączka umieszczona na przewodzie. Zwróć uwagę, że złączka rozdziela oryginalny przewód na dwa w miejscu jej umieszczenia.

    Do złączki podłączono inny przewód.

    Gdy dwa przewody są połączone w układzie typu T, złączka jest umieszczana automatycznie w miejscu złącza T (Pokaż przykład).

  • Tap – oryginalny przewód pozostaje nieprzerwany.

    Javascript ID: Harness_WD_PlacingTap_AD25

    Do zaznaczonego przewodu (W4) należy podłączyć inny przewód.

    Odczep umieszczony na przewodzie. Zwróć uwagę, że odczep nie rozdziela oryginalnego przewodu.

    Do odczepu podłączono inny przewód.

Właściwości umieszczonej złączki lub odczepu (jej położenie i reprezentacja wizualna) można skonfigurować w panelu Properties, gdy obiekt jest zaznaczony w obszarze projektu.

Panel Properties, gdy zaznaczona jest złączka/odczep
Panel Properties, gdy zaznaczona jest złączka/odczep

Obszar Associated Parts panelu Properties umożliwia przypisanie komponentów do zaznaczonej złączki/odczepu, a komponent ten będzie odzwierciedlony w BOM projektu.

Dodawanie kabli

Aby zdefiniować jeden lub więcej przewodów jako dodane do kabla, możesz umieścić obiekt kabla na schemacie okablowania wiązki (Place » Harness Cable).

Umieść kabel, aby zdefiniować jeden lub więcej przewodów jako dodane do kabla.
Umieść kabel, aby zdefiniować jeden lub więcej przewodów jako dodane do kabla.

Gdy obiekt kabla jest zaznaczony, przewody objęte tym kablem są podświetlane w obszarze projektu na neonowo zielono ().

Właściwości umieszczonego obiektu kabla (jego położenie, reprezentację wizualną i parametry) można skonfigurować w panelu Properties, gdy obiekt jest zaznaczony w obszarze projektu.

 
 
 
 
 

Panel Properties, gdy zaznaczony jest kabel
Panel Properties, gdy zaznaczony jest kabel

Kabel ma stałe proporcje 2:1 podczas umieszczania lub edycji graficznej, a końcowy rozmiar po umieszczeniu jest określany przez bieżącą wartość siatki przyciągania dokumentu.

  • Jeśli kabel jest powiązany z przewodami w wielu miejscach na schemacie okablowania wiązki (tj. gdy wiele obiektów kabla o tym samym oznaczeniu jest umieszczonych na różnych przewodach), zaznaczenie jednego obiektu spowoduje podświetlenie wszystkich powiązanych przewodów w grupie, a wszystkie te przewody zostaną wymienione w obszarze Cable Objects panelu Properties ().

  • Parametry Color, Min. Bending Radius, Thickness i Units kabla są używane podczas synchronizacji projektu wiązki z narzędziem MCAD przy użyciu MCAD CoDesigner. Więcej informacji można znaleźć na stronie Synchronizing a Harness Design Project.

Ekranowanie i skręcanie przewodów

Ekran (z połączeniem lub bez, takim jak połączenie przewodu drenażowego) można dołączyć do grupy przewodów przez umieszczenie obiektu ekranu (Place » Shield) lub ekranu z połączeniem (Place » Shield with Connection).

W przykładzie pokazanym poniżej przewody W1, W2 i W3 są ekranowane ekranem bez połączenia (SH1), a przewody W4, W8 i W9 są ekranowane ekranem z połączeniem (SH2). Przewód W10 został umieszczony, aby połączyć SH2 z pinem komponentu.

Umieść obiekt ekranu lub ekranu z połączeniem, aby oznaczyć przewody jako ekranowane.
Umieść obiekt ekranu lub ekranu z połączeniem, aby oznaczyć przewody jako ekranowane.

Gdy zaznaczony jest obiekt ekranu lub ekranu z połączeniem, objęte nim przewody są podświetlane w obszarze projektu na neonowo zielono ().

Właściwości umieszczonego obiektu ekranu lub ekranu z połączeniem (położenie i reprezentacja wizualna) można skonfigurować w panelu Properties, gdy obiekt jest zaznaczony w obszarze projektu. Obszar Shield Objects panelu zawiera listę przewodów objętych zaznaczonym obiektem.

 
 
 
 
 

Panel Properties, gdy zaznaczony jest ekran
Panel Properties, gdy zaznaczony jest ekran

  • Ekran ma stałe proporcje 2:1 podczas umieszczania lub edycji graficznej, a końcowy rozmiar po umieszczeniu jest określany przez bieżącą wartość siatki przyciągania dokumentu. 

  • Jeśli ekran jest powiązany z przewodami w wielu miejscach na schemacie okablowania wiązki (tj. gdy wiele obiektów ekranu o tym samym oznaczeniu jest umieszczonych na różnych przewodach), zaznaczenie jednego obiektu spowoduje podświetlenie wszystkich powiązanych przewodów w grupie, a wszystkie te przewody zostaną wymienione w obszarze Shield Objects panelu Properties ().

Przewody można oznaczyć jako skręcone razem przez umieszczenie skrętki (Place » Twist). Skrętkę można umieścić na dwóch lub większej liczbie przewodów.

W poniższym przykładzie przewody W1 i W2 oznaczono jako skręcone razem za pomocą skrętki Tw1.

Umieść obiekt skrętki, aby oznaczyć przewody jako skręcone razem.
Umieść obiekt skrętki, aby oznaczyć przewody jako skręcone razem.

Gdy zaznaczona jest skrętka, objęte nią przewody są podświetlane w obszarze projektu na neonowo zielono ().

Właściwości umieszczonej skrętki (jej położenie i reprezentacja wizualna) można skonfigurować w panelu Properties, gdy obiekt jest zaznaczony w obszarze projektu. Obszar Twist Objects panelu zawiera listę przewodów objętych zaznaczoną skrętką.

 
 
 
 
 

Panel Properties, gdy zaznaczona jest skrętka
Panel Properties, gdy zaznaczona jest skrętka

  • Skrętka ma stałe proporcje 1:1 podczas umieszczania lub edycji graficznej, a końcowy rozmiar po umieszczeniu jest określany przez bieżącą wartość siatki przyciągania dokumentu. 

  • Jeśli skrętka jest powiązana z przewodami w wielu miejscach na schemacie okablowania wiązki (tj. gdy wiele obiektów skrętki o tym samym oznaczeniu jest umieszczonych na różnych przewodach), zaznaczenie jednego obiektu spowoduje podświetlenie wszystkich powiązanych przewodów w grupie, a wszystkie te przewody zostaną wymienione w obszarze Twist Objects panelu Properties ().

  • Parametr Twists per Unit Length oraz parametr Thickness skrętki są używane podczas synchronizacji projektu wiązki z narzędziem MCAD przy użyciu MCAD CoDesigner. Więcej informacji można znaleźć na stronie Synchronizing a Harness Design Project.

Niepodłączone przewody

Niepodłączone końce przewodów są oznaczane pełnym kwadratem.

Oznaczony niepodłączony przewód
Oznaczony niepodłączony przewód

Końcówka przewodu nie powinna pozostawać niepodłączona. Jeśli projekt wymaga niepodłączonego końca przewodu, na jego końcu należy umieścić obiekt „no connect” (Place » No Connect).

Umieść obiekt „no connect” na końcu przewodu, który ma pozostać niepodłączony.
Umieść obiekt „no connect” na końcu przewodu, który ma pozostać niepodłączony.

Właściwości umieszczonego obiektu „no connect” (jego położenie i reprezentacja wizualna) można skonfigurować w panelu Properties, gdy obiekt jest zaznaczony w obszarze projektu.

Panel Properties, gdy zaznaczony jest obiekt „no connect”
Panel Properties, gdy zaznaczony jest obiekt „no connect”

Praca z wieloma arkuszami

Pełny schemat okablowania wiązki można zdefiniować na wielu arkuszach (w układzie „płaskim”, gdzie wszystkie arkusze znajdują się na tym samym poziomie), z których każdy jest reprezentowany przez własny dokument *.WirDoc. Połączenia są tworzone bezpośrednio z dowolnego arkusza do dowolnego innego arkusza za pomocą obiektów przerwania przewodu (Place » Wire Break) z tym samym oznaczeniem przewodu.

Po wybraniu polecenia umieszczania przerwania przewodu ustaw obiekt tak, aby jego hotspot elektryczny (koniec trzymany przez kursor) dotykał przewodu, z którym chcesz się połączyć, a następnie kliknij lub naciśnij Enter, aby zatwierdzić umieszczenie. Umieszczone przerwanie przewodu dziedziczy właściwości (oznaczenie i kolor) przewodu, do którego jest podłączone.

Wybierz przerwanie przewodu w obszarze roboczym projektu, aby zmienić je w panelu Properties. W panelu możesz zdefiniować oznaczenie przewodu, do którego jest podłączone, oraz jego styl: kierunek (Left lub Right) i kolor.

Synchronizacja przewodów

Przewody wiązki połączone za pomocą przerwania przewodu są rozpoznawane, nawet jeśli mają różne Design Item ID. Dodatkowo wszystkie segmenty przewodów z tym samym oznaczeniem, połączone tym samym przerwaniem przewodu, są porównywane (pod względem numeru części, komentarza, koloru i wszystkich parametrów). Jeśli zostaną znalezione jakiekolwiek różnice, zgłaszane jest naruszenie Mismatched parameters in connected wire segments. Ostrzeżenie pojawia się również w panelu Properties przewodu i przerwania przewodu, sygnalizując wykrycie konfliktu między parametrami. Kliknij Synchronize w obrębie ostrzeżenia, aby otworzyć okno dialogowe Conflict Wire Parameters, które umożliwia wybór parametrów do użycia dla segmentu przewodu.

Właściwości i parametry przewodu przed synchronizacją

W panelu Properties pojawia się ostrzeżenie informujące o konflikcie między parametrami. Po kliknięciu Synchronize w ostrzeżeniu otwiera się okno dialogowe Confirm Wire Parameters. Wybierz żądaną opcję, a następnie kliknij OK, aby wykonać synchronizację.

Naruszenie Mismatched parameters in connected wire segments w oknie dialogowym Project Options

Po synchronizacji właściwości segmentów przewodów zostały zsynchronizowane. 

 
  • Zwróć uwagę, że przy zmianie koloru i oznaczenia przerwania przewodu odpowiednio zmieniane są kolor i oznaczenie przewodu, do którego przerwanie jest podłączone, i odwrotnie — przy zmianie koloru i oznaczenia przewodu odpowiednio zmieniane są kolor i oznaczenie przerwania przewodu podłączonego do tego przewodu.

  • Możesz również zmienić właściwości umieszczanego przerwania przewodu, naciskając Tab po wybraniu polecenia umieszczania. Zwróć uwagę, że jeśli oznaczenie zostanie zdefiniowane dla przerwania przewodu przed jego umieszczeniem, przewód, do którego zostanie ono podłączone, odziedziczy oznaczenie i kolor przerwania przewodu.

  • Jeśli dla przewodu, do którego podłączone jest przerwanie przewodu, zdefiniowano kolor obramowania, to przerwanie przewodu również będzie wyświetlane z obramowaniem w tym kolorze. Oznaczenie przerwania przewodu będzie także wyświetlane w kolorze obramowania podłączonego przewodu.

  • Przerwania przewodu nie mają niezależnych właściwości czcionki; używają właściwości Document Font dokumentu schematu okablowania wiązki, na którym zostały umieszczone.

  • Przerwania przewodu mogą być również używane do tworzenia połączeń w obrębie tego samego arkusza schematu okablowania wiązki — na przykład zamiast prowadzić przewód od jednego pinu złącza do drugiego, możesz umieścić krótki przewód wiązki i przerwanie przewodu na każdym z tych pinów ().

Umieszczanie komponentu okablowania wiązki

Po połączeniu z Workspace możesz tworzyć komponenty o predefiniowanej strukturze i właściwościach zgodnie z wymaganiami w podłączonym Workspace, a następnie ponownie wykorzystywać te komponenty w projektach wiązek, umieszczając je bezpośrednio w dokumentach schematu okablowania wiązki.

Więcej informacji znajduje się na stronie Creating a Harness Wiring Component.

Do tych komponentów (każdy z przypisanym modelem okablowania wiązki) można uzyskać dostęp z panelu Components panel. Gdy wymagany dokument schematu okablowania wiązki jest aktywnym dokumentem w obszarze projektowym, umieść komponent, klikając prawym przyciskiem jego pozycję w panelu i wybierając polecenie Place <ComponentName> z menu kontekstowego. Zachowanie podczas umieszczania komponentu różni się w zależności od tego, czy komponent zawiera pojedynczy obiekt przewodu, czy strukturę kabla (wiele przewodów i/lub dodatkowe obiekty: kable, ekrany itp.).

  • Single wire – podczas umieszczania komponentu zawierającego pojedynczy obiekt przewodu zostanie włączony tryb umieszczania przewodu wiązki. Umieszczany przewód odziedziczy właściwości zdefiniowane podczas tworzenia komponentu. Więcej informacji o umieszczaniu przewodów wiązki znajduje się w sekcji Creating Connectivity in the Harness Wiring Diagram powyżej.

  • Cable structure – po wybraniu polecenia umieszczania komponentu zawierającego strukturę kabla, ta struktura kabla pojawi się przyczepiona do kursora dokładnie tak, jak została zdefiniowana podczas tworzenia komponentu. Kliknij w wybranym miejscu dokumentu schematu okablowania wiązki, aby umieścić komponent. Następnie możesz indywidualnie edytować obiekty komponentu, na przykład aby podłączyć przewody tworzące kabel do pinów złączy wiązki.

Aktualizacja schematu okablowania z bibliotek

Następujące obiekty mogą być aktualizowane z ich źródłowej biblioteki Workspace:

  • Komponenty wiązki

  • Komory komponentów wiązki

  • Części powiązane z komponentami wiązki

  • Przewody

Po wybraniu obiektu informacje o połączonym komponencie Workspace można znaleźć w panelu Properties (np. karta Associated Parts dla części powiązanych z komponentem wiązki).

Jeśli dostępna jest nowsza rewizja komponentu Workspace, wpis stanu rewizji będzie to odzwierciedlał za pomocą tekstu Out of date. Na poziomie pojedynczego obiektu połączenie można zaktualizować do najnowszej rewizji komponentu Workspace, klikając przycisk .

Przykład oznaczenia nieaktualnej rewizji komponentu wiązki
Przykład oznaczenia nieaktualnej rewizji komponentu wiązki

Funkcja Update from Libraries (Tools » Update from Libraries) może być również używana do aktualizacji nieaktualnych komponentów połączonych z obiektami wymienionymi powyżej. Zwróć uwagę, że aby obiekt został uwzględniony w aktualizacji za pomocą funkcji Update from Libraries, komponent przypisany do obiektu musi zawierać łącze do symbolu schematowego.

Adnotowanie obiektów schematu okablowania wiązki

Użyj poleceń z menu Tools » Annotation, aby nadać oznaczenia następującym obiektom w dokumencie schematu okablowania wiązki:

  • Komponenty wiązki

  • Przewody

  • Złącza lutowane i odczepy

  • Kable

  • Ekrany i ekrany z połączeniem

  • Skręcenia

  • Obiekty „No connect”

Adnotowanie obiektów w dokumencie schematu okablowania wiązki jest podobne do adnotowania komponentów w dokumencie schematu (*.SchDoc) projektu PCB. Skorzystaj z poniższych łączy, aby dowiedzieć się więcej o poleceniach adnotacji dostępnych dla dokumentu schematu okablowania wiązki:

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Content