Annotating the Components in a Design
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
W skrócie
- Poznaj cel numeracji elementów i dowiedz się, dlaczego unikatowe oznaczenia komponentów są ważne na schematach, w projekcie PCB oraz w dokumentacji wyjściowej, takiej jak zestawienie materiałów (BOM).
- Zrozum różnice między numeracją na poziomie schematu, PCB i płytki, a także dowiedz się, do jakich typów projektów najlepiej nadaje się każda z tych metod.
- Zapoznaj się z oknem dialogowym Annotate i głównymi ustawieniami, które pozwalają określić zakres numeracji, kolejność przetwarzania, opcje dopasowania oraz proponowane zmiany.
Numeracja elementów w projekcie to systematyczny i metodyczny proces zapewniający możliwość indywidualnej identyfikacji każdego elementu za pomocą unikatowego oznaczenia. Chociaż Altium Designer może identyfikować elementy przy użyciu globalnie unikatowych identyfikatorów (GUID), większość projektantów tradycyjnie używa oznaczenia elementu jako podstawowego sposobu odwoływania się do niego zarówno na schemacie (w domenie logicznej), jak i na PCB (w domenie fizycznej), a także w dokumentacji wyjściowej, takiej jak zestawienie materiałowe (BOM).
Istnieją trzy podejścia do numeracji elementów w projekcie. Wybór narzędzia do numeracji zależy od wielu czynników, w tym rodzaju projektu, osobistych preferencji oraz zasad i procedur obowiązujących w firmie.
Schematic Level Annotation
Numeracja na poziomie schematu wykorzystuje wyłącznie logiczny widok projektu do określania oznaczeń elementów. Jest najbardziej przydatna w prostych projektach, które nie korzystają z arkuszy Device Sheets. Ponieważ jednak umożliwia określenie kolejności przetwarzania oraz uzupełnianie istniejących obudów elementów wieloczęściowych, stanowi również niezbędny etap poprzedzający numerację na poziomie płytki.
Podsumowując, numerację na poziomie schematu należy stosować, aby:
- Grupować części elementów wieloczęściowych w obudowach.
- Numerować elementy na podstawie ich położenia na schemacie.
- Numerować projekty wielokanałowe przy użyciu domyślnego schematu nazewnictwa określonego w opcjach projektu.
- Przygotować projekt do dalszej numeracji.
PCB Annotation
Numeracja PCB wykorzystuje fizyczne położenie elementów na PCB do określania ich oznaczeń. Pozwala to skutecznie zakodować informacje o położeniu w oznaczeniu elementu i może być bardzo pomocne podczas diagnozowania problemów ze zmontowaną płytką PCB. Krótko mówiąc, numerację PCB należy stosować do numerowania elementów na podstawie ich położenia na płytce w projekcie PCB.
Board Level Annotation
Numeracja na poziomie płytki zapewnia mapowanie między oznaczeniami używanymi w projekcie schematu (logicznym) a ich rzeczywistymi odpowiednikami w projekcie PCB (fizycznym). Chociaż numerację na poziomie płytki można stosować w dowolnym projekcie, jest ona szczególnie przydatna w projektach wielokanałowych oraz projektach zawierających arkusze Device Sheets, w których oznaczeń nie można edytować bezpośrednio w samym arkuszu. W ten sposób można ponownie ponumerować cały projekt bez modyfikowania oryginalnych arkuszy Device Sheets. Numeracja na poziomie płytki rozwiązuje wszelkie konflikty numeracji wynikające z powtarzających się oznaczeń w projekcie i zapisuje wprowadzone zmiany w pliku tekstowym *.Annotation. Udostępnia dodatkowe słowa kluczowe umożliwiające dostosowanie schematów nazewnictwa i pozwala stosować je do wszystkich lub tylko wybranych części.
Podsumowując, numerację na poziomie płytki należy stosować, aby:
- Numerować skompilowane elementy w arkuszach Device Sheets.
- Nadawać unikatowe nazwy wszystkim elementom w wielu kanałach przy użyciu schematów nazewnictwa uwzględniających numerację według położenia, indeksowanie globalne i inne konfigurowalne opcje.
- Ręcznie nadawać nazwy elementom.
Numeracja na schemacie
Numerację na schemacie konfiguruje się w oknie dialogowym Annotate . Okno to udostępnia opcje systematycznego przypisywania oznaczeń wszystkim lub wybranym częściom na wybranych arkuszach projektu oraz zapewnia unikatowość oznaczeń i ich uporządkowanie na podstawie położenia. Opcje numeracji można skonfigurować tak, aby grupować części elementów wieloczęściowych w obudowach, ustawiać opcje indeksów i przyrostków, resetować oznaczenia na schemacie, w tym wszelkie oznaczenia powtarzające się, oraz przenosić oznaczenia z PCB na schemat.
Okno dialogowe Annotate otwiera się po uruchomieniu polecenia Annotate Schematics (Tools » Annotation » Annotate Schematics).

Okno dialogowe Annotate jest otwierane za pomocą polecenia Annotate Schematics.
Okno dialogowe jest podzielone na dwa główne obszary:
- Schematic Annotation Configuration — ten obszar służy do konfigurowania schematu i zakresu numeracji.
- Proposed Change List — ten obszar zawiera listę proponowanych zmian, które zostaną wprowadzone po ich zaakceptowaniu i wykonaniu za pomocą zlecenia zmian inżynierskich (ECO).
Opcje i elementy sterujące okna dialogowego Annotate
Konfiguracja numeracji na schemacie
Kolejność przetwarzania
W tym obszarze można określić wymaganą metodę numeracji według położenia. Po wybraniu metody z listy rozwijanej powiązana z nią ilustracja jest dynamicznie aktualizowana, pokazując sposób numerowania elementów. Dostępne są następujące metody numeracji według położenia:
- Up Then Across
- Down Then Across
- Across Then Up
- Across Then Down
Położenie odniesienia
W tym obszarze można określić punkt odniesienia dla położenia elementów podczas ustalania kolejności numeracji. Dostępne są następujące opcje:
- Designator — przy ustalaniu kolejności przetwarzania jako punkt odniesienia dla położenia elementu wykorzystywane jest jego oznaczenie.
- Part — przy ustalaniu kolejności przetwarzania jako punkt odniesienia dla położenia elementu wykorzystywany jest jego środek.
Zastępowanie części składowych
Z listy rozwijanej należy wybrać, czy części składowe mają być zastępowane w ramach procesu numeracji.
Opcje dopasowywania
W przypadku obudów elementów wieloczęściowych często pożądane jest umieszczenie jak największej liczby części w jak najmniejszej liczbie elementów fizycznych, ponieważ minimalizuje to całkowity koszt zestawienia materiałowego projektu. Opcje w tym obszarze pozwalają określić sposób dopasowywania i grupowania elementów oraz kryteria ustalania prawidłowych grup.
-
Complete Existing Packages — ta opcja pozwala określić, czy i w jaki sposób części bez przypisanych oznaczeń będą dołączane do istniejących obudów. Z listy rozwijanej można wybrać następujące opcje:
- None — istniejące obudowy nie będą uzupełniane, a wszystkie nowe części zostaną umieszczone w nowych obudowach.
- Per Sheet — istniejące obudowy będą uzupełniane wyłącznie nowymi częściami z tego samego arkusza schematu.
- Whole Project — istniejące obudowy będą uzupełniane nowymi częściami z dowolnych arkuszy schematu w projekcie.
- Component Parameter — ta lista zawiera wszystkie parametry znalezione w elementach bieżącego projektu. Zaznacz pole wyboru przy parametrze, aby używać go do dopasowywania części do obudów. Jeśli części elementów wieloczęściowych mają te same zaznaczone parametry o jednakowych wartościach, zostaną umieszczone we wspólnej obudowie (pod warunkiem że opcja Complete Existing Packages nie jest ustawiona na None). Wszystkie pozostałe elementy, które nie mają zaznaczonych parametrów, również zostaną zgrupowane we wspólnych obudowach.
- Strictly - włącz tę opcję dla Component Parameter na liście, aby określić, że wszystkie komponenty must mieć ten parametr, aby mogły zostać połączone w jedną obudowę. Komponenty, które nie mają tego parametru, otrzymują oznaczenia jako osobne komponenty i nie są łączone w obudowy.
Menu kontekstowe
- Parameter » Enable Selected Parameters - służy do zaznaczania pola wyboru „Uwzględnij” dla wszystkich parametrów aktualnie zaznaczonych na liście.
- Parameter » Enable All Parameters - służy do zaznaczania pola wyboru „Uwzględnij” dla wszystkich parametrów na liście.
- Parameter » Disable Selected Parameters - służy do usuwania zaznaczenia pola wyboru „Uwzględnij” dla wszystkich parametrów aktualnie zaznaczonych na liście.
- Parameter » Disable All Parameters - służy do usuwania zaznaczenia pola wyboru „Uwzględnij” dla wszystkich parametrów na liście.
- Match Strictly » Enable Strict Matching On Selected Parameters - służy do włączania opcji Strictly dla wszystkich parametrów aktualnie zaznaczonych na liście.
- Match Strictly » Enable Strict Matching On All Parameters - służy do włączania opcji Strictly dla wszystkich parametrów na liście.
- Match Strictly » Disable Strict Matching On Selected Parameters - służy do wyłączania opcji Strictly dla wszystkich parametrów aktualnie zaznaczonych na liście.
- Match Strictly » Disable Strict Matching On All Parameters - służy do wyłączania opcji Strictly dla wszystkich parametrów na liście.
- Selection » Select All - służy do zaznaczania wszystkich pozycji parametrów na liście.
- Selection » Deselect All - służy do usuwania zaznaczenia wszystkich pozycji parametrów na liście.
- Selection » Invert Selection - służy do zaznaczania wszystkich parametrów aktualnie niezaznaczonych na liście i usuwania zaznaczenia pozostałych.
Arkusze schematu do nadania oznaczeń
W tej sekcji okna dialogowego wyświetlane są wszystkie źródłowe arkusze schematu w projekcie. Dostępne tu elementy sterujące służą do określania, które arkusze mają zostać uwzględnione w procesie nadawania oznaczeń oraz w jaki sposób mają być obliczane zmiany oznaczeń. Dla każdego arkusza prezentowane są następujące informacje:
- Include/Exclude checkbox - zaznacz to pole wyboru, aby uwzględnić arkusz schematu w procesie nadawania oznaczeń.
- Schematic Sheet - to pole wyświetla nazwę arkusza schematu.
-
Annotation Scope - użyj tego pola, aby określić zakres nadawania oznaczeń komponentom na arkuszu. Z listy rozwijanej wybierz jeden z następujących zakresów:
- All - oznaczenia zostaną nadane wszystkim częściom na arkuszu schematu.
- Ignore Selected Parts - oznaczenia zostaną nadane wszystkim częściom z wyjątkiem tych, które są aktualnie zaznaczone w projekcie.
- Only Selected Parts - oznaczenia zostaną nadane tylko częściom aktualnie zaznaczonym w projekcie.
- Order - użyj tego pola, aby określić miejsce tego arkusza w ogólnej kolejności nadawania oznaczeń na arkuszach. Wpisz żądany numer kolejności bezpośrednio w polu lub ustaw go za pomocą strzałek wyświetlanych po kliknięciu pola.
- Designator Index Control - użyj elementów sterujących w tej kolumnie, aby włączyć stosowanie indeksu początkowego (zaznaczając odpowiednie pole) i określić jego wartość. Numeracja oznaczeń rozpocznie się od tej wartości.
- Add Suffix - użyj tego pola, aby określić przyrostek dodawany do każdego nadawanego oznaczenia. Obsługiwane są przyrostki literowe (A, B, C...), cyfrowe (1, 2, 3...), ze znaków niealfanumerycznych (_ * . %...), a także ich kombinacje.
Additional Controls
- All On - kliknij, aby uwzględnić wszystkie arkusze schematu w procesie nadawania oznaczeń.
- All Off - kliknij, aby wykluczyć wszystkie arkusze schematu z procesu nadawania oznaczeń.
-
Right-Click Menu - w menu kontekstowym tej sekcji dostępne są następujące polecenia:
-
Order Alphabetically - służy do sortowania listy schematów alfabetycznie. Wpłynie to na powiązaną pozycję Order dla każdego arkusza.
-
Order By Project Order - służy do sortowania listy schematów według kolejności ich występowania w projekcie (widocznej w panelu Projects ). Wpłynie to na powiązaną pozycję Order dla każdego arkusza.
-
All On - służy do uwzględniania wszystkich arkuszy schematu w procesie nadawania oznaczeń.
-
All Off - służy do wykluczania wszystkich arkuszy schematu z procesu nadawania oznaczeń.
-
Lista proponowanych zmian
-
Main List - w tej sekcji okna dialogowego wyświetlane są wszystkie oznaczenia części znajdujących się na arkuszach wybranych do nadania oznaczeń. Każda pozycja zawiera szczegółowe informacje o wartościach Current i Proposed Designator , a także Sub (część) komponentu i źródłowy Location of Part. Ikony kłódek wskazują zablokowane kolumny, aby zapobiec zmianom oznaczeń i części składowych.
Zaznaczenie pola obok oznaczenia w kolumnie Current („oznaczenie zablokowane”) zablokuje możliwość wprowadzania jakichkolwiek zmian w tym oznaczeniu. Podobnie zaznaczenie pola obok pola Sub danego oznaczenia („część składowa zablokowana”) uniemożliwi aktualizację tej konkretnej części składowej nadrzędnego komponentu wieloczęściowego.
W menu kontekstowym tej sekcji dostępne są następujące polecenia:
- Designator » Lock Selected Designators - służy do zaznaczania pola wyboru „oznaczenie zablokowane” dla wszystkich oznaczeń aktualnie zaznaczonych na liście.
- Designator » Lock All Designators - służy do zaznaczania pola wyboru „oznaczenie zablokowane” dla wszystkich oznaczeń.
- Designator » Unlock Selected Designators - służy do usuwania zaznaczenia pola wyboru „oznaczenie zablokowane” dla wszystkich oznaczeń aktualnie zaznaczonych na liście.
- Designator » Unlock All Designators - służy do usuwania zaznaczenia pola wyboru „oznaczenie zablokowane” dla wszystkich oznaczeń.
- Part ID » Lock Selected Part ID - służy do zaznaczania pola wyboru „część składowa zablokowana” dla wszystkich oznaczeń aktualnie zaznaczonych na liście.
- Part ID » Lock All Part ID - służy do zaznaczania pola wyboru „część składowa zablokowana” dla wszystkich oznaczeń.
- Part ID » Unlock Selected Part ID - służy do usuwania zaznaczenia pola wyboru „część składowa zablokowana” dla wszystkich oznaczeń aktualnie zaznaczonych na liście.
- Part ID » Unlock All Part ID - służy do usuwania zaznaczenia pola wyboru „część składowa zablokowana” dla wszystkich oznaczeń.
- Selection » Select All - służy do zaznaczania wszystkich pozycji oznaczeń na liście.
- Selection » Select All With '?' - służy do zaznaczania wszystkich pozycji, których bieżące oznaczenie zawiera znak ? (tj. zostało zresetowane).
- Selection » Deselect All - służy do usuwania zaznaczenia wszystkich pozycji oznaczeń na liście.
- Selection » Invert Selection - służy do zaznaczania wszystkich oznaczeń aktualnie niezaznaczonych na liście i usuwania zaznaczenia pozostałych.
- Annotation Summary - ten obszar zawiera podsumowanie nadawania oznaczeń obejmujące liczbę uwzględnionych arkuszy oraz opcje dopasowywania. Jest ono aktualizowane dynamicznie w miarę wprowadzania zmian w tych obszarach.
- Update Changes List - kliknij, aby zaktualizować główną listę proponowanych zmian o nowe zmiany obliczone na podstawie ustawień numeracji zdefiniowanych po lewej stronie okna dialogowego. W oknie informacyjnym zostaną wyświetlone szczegóły dotyczące liczby zmian wprowadzonych względem poprzedniego stanu oraz względem stanu początkowego.
- Reset All - kliknij, aby zresetować wszystkie niezablokowane oznaczenia na głównej liście do domyślnych prefiksów komponentów, np. R?, C?, D?. Zmiany zostaną wprowadzone w kolumnie oznaczeń Proposed . Menu rozwijane przycisku umożliwia zmianę polecenia na Reset Duplicates. Jeśli co najmniej dwa komponenty mają to samo oznaczenie, wszystkie poza jednym zostaną zresetowane do domyślnych prefiksów. Również w tym przypadku w oknie informacyjnym zostaną wyświetlone szczegóły dotyczące liczby zmian wprowadzonych względem poprzedniego stanu oraz względem stanu początkowego.
- Back Annotate - kliknij, aby otworzyć okno dialogowe umożliwiające wyszukanie i wybranie pliku do numeracji wstecznej.
- Accept Changes (Create ECO) - po przejrzeniu wszystkich proponowanych zmian kliknij ten przycisk, aby otworzyć okno dialogowe Engineering Change Order, w którym proponowane zmiany są wymienione jako modyfikacje w kategorii Annotate Component. Użyj tego okna do sprawdzenia i wykonania ECO, kończąc proces numeracji na poziomie schematu.
Blokowanie komponentów
W przypadku niejednorodnych komponentów wieloczęściowych upewnij się, że ikony blokady w panelu Properties są zamknięte, aby zapobiec zmianom części składowych podczas numeracji.
Opcja Strictly
Jeśli pole wyboru Strictly jest zaznaczone dla Component Parameter, wszystkie komponenty grupowane w jednej obudowie muszą mieć zgodną wartość tego parametru. Komponenty bez tego parametru są numerowane jako pojedyncze komponenty i nie są grupowane w obudowach.
Poniższy przykład ilustruje, jak połączenie tych opcji daje określony wynik:
Rozważmy projekt z ośmioma bramkami OR i ośmioma rezystorami (jak pokazano na ilustracji poniżej). Bramki OR zawierają parametr o nazwie QuadOrGate, przy czym jedna grupa czterech bramek OR ma wartość parametru Package1, a druga grupa czterech bramek OR ma wartość parametru Package2. Rezystory nie mają takiego parametru. Zaznaczenie pola wyboru dla QuadOrGate w elemencie sterującym Component Parameter sprawi, że parametr ten będzie używany do sterowania grupowaniem komponentów w obudowach; w tym przypadku pole wyboru Strictly nie jest zaznaczone.
Po uruchomieniu polecenia Tools » Annotation » Annotate Schematics części z parametrem QuadOrGate = Package1 zostaną zgrupowane w jednym fizycznym komponencie, a części z parametrem QuadOrGate = Package2 zostaną zgrupowane osobno. Wszystkie pozostałe komponenty, które nie mają parametru QuadOrGate, zostaną zgrupowane razem. W tym przypadku rezystory są grupowane razem, ponieważ ich wspólną cechą jest brak parametru QuadOrGate.

Przykład komponentów zgrupowanych w obudowach przy niezaznaczonej opcji Strictly .
Jeśli ten sam projekt zostanie ponumerowany z zaznaczoną opcją Strictly , w obudowach zostaną zgrupowane tylko komponenty z parametrem QuadOrGate . W tym przypadku bramki OR zostaną zgrupowane, natomiast rezystory pozostaną niezgrupowane. Zatem choć opcja Strictly zapewnia bardzo precyzyjną kontrolę nad procesem grupowania, w większości sytuacji powinna pozostać niezaznaczona.

Przykład komponentów zgrupowanych w obudowach przy zaznaczonej opcji Strictly .
Arkusze schematu do ponumerowania
Dostępne są rozbudowane możliwości określania, które arkusze schematu i komponenty zostaną objęte numeracją, a także sposobu obliczania tych zmian.

Określanie zakresu numeracji.
- Zaznaczenie pola po lewej stronie arkusza schematu na liście oznacza, że zostanie on przetworzony w ramach polecenia numeracji.
- Zakres numeracji określa lista rozwijana Annotation Scope . Może on obejmować cały arkusz schematu lub być ograniczony do zaznaczonych bądź niezaznaczonych komponentów. Użycie opcji Ignore Selected Parts lub Only Selected Parts wymaga zaznaczenia komponentów w projekcie przed uruchomieniem polecenia numeracji.
- Określ kolejność numerowania arkuszy schematu za pomocą pola Order. Wpisz wartość bezpośrednio w polu lub użyj strzałek pojawiających się po kliknięciu pola, aby ustawić żądaną wartość.
- Jeśli opcja Designator Index Control jest zaznaczona, numeracja oznaczeń rozpocznie się od wartości Start Index. Ustawienie Start Index nie ma wpływu na numerację, jeśli opcja Designator Index Control nie jest zaznaczona.
- Do każdego oznaczenia można dodać dodatkowy sufiks, podając ciąg znaków lub wartość w odpowiedniej kolumnie Suffix . Unikaj sufiksów jednoznakowych, takich jak „A” lub „1”, ponieważ można je łatwo pomylić z częściami składowymi lub innymi wartościami oznaczeń.
Lista proponowanych zmian
Kliknij przycisk Update Changes List, aby zaktualizować Proposed Change List i umożliwić przejrzenie wszystkich zmian oznaczeń przed ich zastosowaniem. Zmiany obejmą tylko oznaczenia, które nie zostały wcześniej nadane (tj. R?, C? itd.). Dlatego aby zaktualizować wszystkie oznaczenia w projekcie, należy je najpierw zresetować, naciskając przycisk Reset All.

Resetowanie oznaczeń przed zastosowaniem ustawień numeracji.
Lista Proposed Change List zawiera wszystkie oznaczenia części znajdujących się na arkuszach wybranych do numeracji. Każda pozycja zawiera wartości oznaczeń Current i Proposed, a także Sub (część) komponentu oraz źródłowy Location of Part.
Zaznaczenie pola powiązanego z Designator zablokuje dane oznaczenie przed wszelkimi zmianami. Podobnie zaznaczenie pola Sub zapobiegnie aktualizacji danego komponentu wieloczęściowego. Tej opcji można użyć zamiast ustawiania ikony Lock w panelu Properties .
Po przejrzeniu listy proponowanych zmian kliknij przycisk Accept Changes (Create ECO), aby otworzyć okno dialogowe Engineering Change Order. Po wykonaniu ECO zmiany numeracji zostaną zastosowane w projekcie.
Dodatkowe polecenia numeracji schematu
Menu Narzędzia » Annotation zawiera szereg wyspecjalizowanych poleceń numeracji schematu. Pierwsza pozycja w tej grupie, Annotate Schematic, została już omówiona.

Dostępne polecenia numeracji
Resetowanie oznaczeń na schemacie
Jeśli duże fragmenty zawartości zostały wycięte i wklejone z różnych źródeł do nowego projektu, może być konieczne zresetowanie wszystkich oznaczeń. Ponieważ to polecenie korzysta z ustawień okna dialogowego Adnotacja , zostanie zastosowane do elementów wcześniej wskazanych w tym oknie. Na przykład jeśli wcześniej zaznaczono wszystkie Schematic Sheets To Annotate, polecenie Reset Schematic Designators zostanie zastosowane do całego projektu, niezależnie od tego, czy arkusze są obecnie otwarte w edytorze. Jeśli wcześniej zaznaczono tylko kilka Schematic Sheets To Annotate, polecenie Reset Schematic Designators będzie dotyczyć tylko tych arkuszy.
Po uruchomieniu polecenia pojawi się okno dialogowe potwierdzenia, które podsumowuje liczbę oznaczeń wymagających aktualizacji i zawiera pytanie, czy kontynuować wprowadzanie zmian. Po kliknięciu Yes wszystkie oznaczenia komponentów we wszystkich arkuszach schematu aktywnego projektu, dla których włączono adnotację, zostaną zresetowane i przyjmą postać: R?, C?, D?, U? itd.
Oznaczenia o statusie zablokowanym nie są resetowane ani w żaden sposób zmieniane.
Resetowanie zduplikowanych oznaczeń na schemacie
Podczas powielania fragmentów projektu nowo skopiowane komponenty zachowują te same oznaczenia co komponenty źródłowe. Polecenie Reset Duplicate Schematic Designators umożliwia szybkie zresetowanie zduplikowanych oznaczeń do „?”. Ponieważ to polecenie korzysta z ustawień okna dialogowego Annotate , zostanie zastosowane do elementów wcześniej wskazanych w tym oknie. Na przykład jeśli wcześniej zaznaczono wszystkie Schematic Sheets To Annotate, polecenie Reset Duplicate Schematic Designators zostanie zastosowane do całego projektu, niezależnie od tego, czy arkusze są obecnie otwarte w edytorze. Jeśli wcześniej zaznaczono tylko kilka Schematic Sheets to Annotate, polecenie Reset Schematic Designators będzie dotyczyć tylko tych arkuszy.
Po uruchomieniu polecenia pojawi się okno dialogowe potwierdzenia, które podsumowuje liczbę oznaczeń wymagających aktualizacji i zawiera pytanie, czy kontynuować wprowadzanie zmian. Po kliknięciu Yes wszystkie zduplikowane oznaczenia komponentów znalezione we wszystkich arkuszach schematu aktywnego projektu, dla których włączono adnotację, zostaną zresetowane i przyjmą postać: R?, C?, D?, U? itd.
Oznaczenia o statusie zablokowanym nie są resetowane ani w żaden sposób zmieniane.
Adnotacja schematów w trybie cichym
Polecenie Annotate Schematics Quietly służy do sprawdzania wszystkich źródłowych dokumentów schematów aktywnego projektu, dla których włączono adnotację, i przypisywania unikatowego oznaczenia każdemu komponentowi, który go obecnie nie ma. Adnotacja jest przeprowadzana w trybie cichym — umożliwia to zastosowanie wszystkich wcześniejszych ustawień okna dialogowego Annotate bez konieczności jego ponownego otwierania. Jest to szczególnie przydatne, gdy projekt jest intensywnie rozwijany, a projektant chce szybko przeprowadzić adnotację przed kompilacją projektu.
Wymuszanie adnotacji wszystkich schematów
To polecenie służy do sprawdzania wszystkich źródłowych dokumentów schematów aktywnego projektu, dla których włączono adnotację, i ponownego nadawania oznaczeń wszystkim zawartym w nich komponentom zgodnie ze schematem adnotacji aktualnie zdefiniowanym w oknie dialogowym Annotate.
Uruchomienie polecenia Force Annotate All Schematics jest równoważne uruchomieniu polecenia Reset Schematic Designators, a bezpośrednio po nim polecenia Annotate Schematics Quietly. W związku z tym polecenie Force Annotate All Schematics korzysta z ustawień wcześniej określonych w oknie dialogowym Annotate , aby ustalić, które komponenty i arkusze mogą zostać zaktualizowane.
Po uruchomieniu tego polecenia pojawi się prośba o potwierdzenie, zawierająca liczbę oznaczeń, które zostaną zaktualizowane po zaakceptowaniu. Po kliknięciu Yes wszystkie oznaczenia komponentów we wszystkich arkuszach schematu aktywnego projektu, dla których włączono adnotację, zostaną w razie potrzeby nadane ponownie, zgodnie z bieżącym schematem adnotacji według położenia zdefiniowanym w sekcji Schematic Annotation Configuration okna dialogowego Annotate .
Adnotacja wsteczna schematów
Przed wprowadzeniem w Altium Designer funkcji Design Compiler i Synchronizer zmiany oznaczeń były przekazywane ze schematu do PCB za pośrednictwem pliku listy połączeń (*.net). Zmiany oznaczeń, które należało przenieść w przeciwnym kierunku — z PCB do schematu — obsługiwano za pomocą procesu adnotacji wstecznej. Proces ten wykorzystuje plik Was-Is (*.WAS) lub plik zlecenia zmian inżynierskich (ECO) (*.ECO) do określenia zmian, które mają zostać zastosowane do oznaczeń na schemacie.
Po uruchomieniu polecenia pojawi się okno dialogowe Choose WAS-IS File for Back-Annotation from PCB. Odszukaj i wybierz wymagany plik .was (lub .eco). Po kliknięciu Open pojawi się okno informacyjne z liczbą zmian oznaczeń wprowadzonych od poprzedniego stanu oraz od stanu początkowego. Na tym etapie zmiany nie są jeszcze faktycznie wprowadzane. Kliknij OK , aby otworzyć okno dialogowe Annotate, w którym można przejrzeć proponowane zmiany bieżących oznaczeń przed podjęciem decyzji o utworzeniu zlecenia ECO w celu ich wdrożenia.
Numerowanie arkuszy schematu
Polecenie Number Schematic Sheets nie zmienia oznaczeń komponentów, lecz oznaczenia (numery) arkuszy schematu. Jest więc pojęciowo związane z ogólną koncepcją adnotacji projektu.
Numerowanie arkuszy i dokumentów pozwala kontrolować oznaczenia arkuszy i zapisywać je jako parametry w odpowiednich dokumentach schematów. Funkcja ciągów specjalnych w Altium Designer (=SheetNumber, =DocumentNumber, =SheetTotal) umożliwia następnie wyświetlanie tych wartości na arkuszu (na przykład w jego stopce) jako obiektów tekstowych.
Proces numerowania arkuszy przebiega następująco:
Automatyczne numerowanie arkuszy (opcja projektu)
Włącz tę opcję, aby automatycznie numerować arkusze. Wartości będą wyświetlane w panelu Projects. Automatyczne numerowanie arkuszy można również włączyć, zaznaczając opcję Automatic Sheet Numbering na karcie Opcje okna dialogowego Project Options.
Automatyczne nadawanie numerów arkuszy
Kliknij przycisk rozwijany Auto Sheet Number, aby uzyskać dostęp do opcji numerowania arkuszy.
Dostępne opcje Select Numbering Scheme:
- Display Order — arkusze są numerowane w kolejności ich wyświetlania.
- Sheets Hierarchical Structure - Depth First - arkusze są numerowane od najwyższego poziomu w głąb każdej gałęzi. Najpierw numerowany jest najwyższy poziom, następnie w całości pierwsza gałąź poniżej najwyższego poziomu, potem druga gałąź i tak dalej.
- Sheets Hierarchical Structure - Breadth First - arkusze są numerowane zgodnie z ich poziomem w hierarchii. Najpierw numerowany jest najwyższy poziom, następnie wszystkie arkusze drugiego poziomu i tak dalej.
Opcje Select Numbering Method umożliwiają wybór wartości sekwencyjnych Increasing lub Decreasing .
Automatyczne numerowanie dokumentów
Kliknij listę rozwijaną Auto Document Number , aby uzyskać dostęp do opcji numerowania dokumentów. Są one zasadniczo takie same jak opcje Auto Sheet Number, z dodatkowymi wartościami Prefix i Postfix .
Dostępne są następujące opcje Parameters :
-
Prefix - wybierz prefiks, który zostanie umieszczony przed numerem dokumentu. Obsługiwane są prefiksy literowe (
A,B,Citd.), numeryczne (1,2,3itd.) i nienumeryczne (_,*,.,%itd.), a także ich dowolne kombinacje. - Start - wybierz wartość liczbową, od której rozpocznie się numerowanie.
-
Postfix - wybierz przyrostek, który zostanie dodany do numeru dokumentu. Obsługiwane są przyrostki literowe (
A,B,Citd.), numeryczne (1,2,3itd.) i nienumeryczne (_,*,.,%itd.), a także ich dowolne kombinacje. - Step - wybierz wartość, o którą będzie zwiększany każdy kolejny numer dokumentu. Na przykład, jeśli indeks Start ma wartość 1, a wartość Step jest ustawiona na 100, pierwszy numer dokumentu będzie wynosić 1, następny 101 (wartość początkowa + krok), kolejny 201 i tak dalej.
Aktualizacja liczby arkuszy
Kliknij przycisk Update Sheet Count, aby zliczyć arkusze w bieżącym projekcie i umieścić wynik w kolumnie SheetTotal. Liczba arkuszy będzie równa całkowitej liczbie arkuszy w projekcie, niezależnie od schematu numerowania wybranego w którymkolwiek z poprzednich ustawień.
Przesuwanie w górę/w dół
Użyj przycisków Move Up lub Move Down, aby przesunąć wybrany dokument schematu w górę lub w dół listy. Ma to znaczenie podczas korzystania ze schematu numerowania Display Order do określania numerów arkuszy lub dokumentów.
Niestandardowe numerowanie i nazewnictwo
Jeśli organizacja stosuje określony system numerowania lub nazewnictwa, którego nie można zautomatyzować za pomocą poleceń Auto Sheet Number lub Auto Document Number, niestandardowe nazwy i numery arkuszy można wpisać bezpośrednio w polach SheetNumber lub DocumentNumber .
Numerowanie arkuszy schematu a arkusze Device Sheets
Numerów arkuszy ani dokumentów nie można konfigurować dla arkuszy Device Sheets w trybie tylko do odczytu (stan domyślny). W oknie dialogowym Numerowanie arkuszy projektu będą one oznaczone kreskowaniem, wskazującym, że nie można ich aktualizować. Gdy arkusze Device Sheets zostaną ustawione jako edytowalne, kreskowanie zniknie, a numerowanie arkuszy i dokumentów będzie można konfigurować w zwykły sposób.
Sterowanie wyświetlaniem oznaczeń na PCB
Umieszczanie rozbudowanych oznaczeń w projekcie wielokanałowym w edytorze PCB może być uciążliwe. Można wybrać opcje nazewnictwa zapewniające krótkie nazwy lub zamiast tego wyświetlać oryginalne, logiczne oznaczenie komponentu. Na przykład C30_CIN1 byłoby wyświetlane jako C30. Wymagałoby to dodania na płytce innego oznaczenia wskazującego poszczególne kanały, na przykład obramowania każdego kanału na warstwie opisowej komponentów.
Możesz przełączać się między wyświetlaniem oznaczeń logicznych i fizycznych na PCB za pomocą listy rozwijanej Designator Display w sekcji Other panelu Properties w trybie Board . Jeśli wybierzesz wyświetlanie oznaczeń logicznych komponentów w projekcie wielokanałowym, będą one widoczne na PCB oraz we wszystkich generowanych plikach wyjściowych, takich jak wydruki i pliki Gerber. Natomiast podczas generowania zestawienia materiałowego zawsze używane są unikatowe oznaczenia fizyczne.
Synchronizacja projektu — zakończenie procesu anotacji
Bezpośrednia synchronizacja projektu jest preferowaną metodą utrzymywania zgodności oznaczeń na schemacie i PCB, chyba że nie masz dostępu do obu edytorów: schematów i PCB. Synchronizacja projektu porównuje komponenty i połączenia na schemacie bezpośrednio z PCB, tworząc listę różnic. Lista zmian wymaganych do usunięcia tych różnic jest generowana jako ECO (Engineering Change Order — zlecenie zmian inżynierskich). Plik ECO opisuje różnice między bieżącym a docelowym stanem projektu i może zostać wykonany, aktualizując dokument docelowy i zapewniając synchronizację projektu.
Synchronizacja w przód i synchronizacja wsteczna
Terminy „synchronizacja w przód” i „synchronizacja wsteczna” określają kierunek przenoszenia anotacji i zmian projektu podczas synchronizacji danych. Przyjmując proces projektowy, który rozpoczyna się od schematu i jest przez niego sterowany, synchronizacja w przód polega na przenoszeniu zmian wprowadzonych w edytorze schematów do PCB. Synchronizacja wsteczna polega na przenoszeniu zmian wprowadzonych na PCB do edytora schematów.
Synchronizacja w przód
Oto kilka powodów, dla których warto zsynchronizować dane ze schematu z PCB:
- W edytorze schematów dodano nowy komponent, który jest potrzebny w projekcie PCB.
- Przeprowadzono anotację schematu po raz pierwszy lub od czasu ostatniej synchronizacji projektu.
- W projekcie wielokanałowym zmieniono Project Options, aby zmodyfikować styl nazewnictwa fizycznego (PCB).
- Przeprowadzono anotację na poziomie płytki po raz pierwszy lub od czasu ostatniej synchronizacji projektu.
Synchronizowanie projektu schematu z projektem PCB
Wybierz jedną z poniższych metod synchronizacji projektu schematu z projektem PCB:
- Wybierz Update PCB Document z menu Design w edytorze schematów. Jeśli istnieją różnice między schematami a docelowym dokumentem PCB, otworzy się okno dialogowe Engineering Change Order z listą modyfikacji wymaganych do zsynchronizowania PCB z projektem schematu. Kliknij Execute Changes, aby zsynchronizować projekt.
- Wybierz Import Changes z menu Design w edytorze PCB, aby zaimportować zmiany z dokumentów schematu do dokumentu PCB.
Synchronizacja wsteczna
Synchronizację wsteczną wykonuje się po przeprowadzeniu anotacji lub wprowadzeniu zmian w projekcie PCB, gdy chcesz zaktualizować projekt schematu.
Synchronizowanie projektu PCB z projektem schematu
Wybierz jedną z poniższych metod synchronizacji projektu PCB z projektem schematu:
-
W edytorze PCB wybierz Update Schematics z menu Design . Domyślnie opcja Push Component Designator Changes to Annotation File (if any) na karcie Generowanie ECO w oknie dialogowym Project Optionsjest zaznaczona, dzięki czemu zmiany wprowadzone w edytorze PCB będą przekazywane wyłącznie do pliku anotacji, a następnie, podczas kompilacji, do skompilowanych dokumentów. Usuń zaznaczenie tej opcji, aby przekazywać zmiany wyłącznie do źródłowego dokumentu schematu (widok Editor ).
- W edytorze schematów wybierz Tools » Annotation » Annotate Schematics, a następnie kliknij przycisk Back Annotate w oknie dialogowym Numeracja. Wybierz plik WAS-IS wygenerowany podczas ponownej numeracji oznaczeń w środowisku PCB.
- W edytorze schematów wybierz Tools » Annotation » Board Level Annotate, a następnie kliknij przycisk Back Annotate w oknie dialogowym Numeracja na poziomie płytki. Wybierz plik WAS-IS wygenerowany podczas ponownej numeracji oznaczeń w środowisku PCB.
- W edytorze schematów wybierz Tools » Annotation » Back Annotate Schematics. Wybierz plik WAS-IS wygenerowany podczas ponownej numeracji oznaczeń w środowisku PCB.
Tradycyjne metody synchronizacji projektu
Altium Designer obsługuje tradycyjną metodę synchronizacji projektu z użyciem plików pośrednich (listy połączeń i WAS/IS). Synchronizację danych numeracji w kierunku od schematu do PCB można przeprowadzić za pomocą pliku listy połączeń, a synchronizację wsteczną — za pomocą pliku WAS/IS (zawierającego informacje o tym, jakie każde oznaczenie WAS i jakie obecnie IS). Zalecaną metodą synchronizacji projektu jest bezpośrednia synchronizacja projektu.
Łączenie komponentów za pomocą unikatowych identyfikatorów
Po ponownej numeracji projektu oznaczenia komponentów na schemacie lub oznaczenia komponentów po kompilacji nie będą już zgodne z oznaczeniami komponentów na PCB, dlatego do pomyślnego ukończenia projektu konieczna jest synchronizacja. Zamiast polegać na samym oznaczeniu jako polu kluczowym łączącym symbol na schemacie z odpowiadającą mu obudową na PCB, Altium Designer może utrzymywać synchronizację projektu za pomocą systemu unikatowych identyfikatorów (UID). UID to generowana przez system wartość, która jednoznacznie identyfikuje komponent źródłowy i wiąże każdy komponent na schemacie z odpowiadającym mu komponentem na PCB.
Po umieszczeniu komponentu na arkuszu schematu jest mu automatycznie przypisywany UID. Przy pierwszym przenoszeniu informacji o komponentach ze źródłowych dokumentów schematu do pustego dokumentu PCB identyfikator UID każdego komponentu na schemacie jest przypisywany odpowiadającemu mu komponentowi na PCB.
Refaktoryzacja umożliwia przekształcanie arkuszy urządzeń w arkusze schematu i odwrotnie, z zachowaniem unikatowego identyfikatora arkusza oraz jego komponentów. Ponadto można refaktoryzować (lub przenosić) podobwody do innych arkuszy schematu w bieżącym projekcie, zachowując unikatowy identyfikator podobwodu. Polecenie Refactor znajduje się w menu Edit .
Funkcja synchronizacji w Altium Designer, uruchamiana poleceniem Design » Update, wykorzystuje te identyfikatory UID do powiązania każdego komponentu na schemacie z jego odpowiednikiem na PCB. Aktualizacje i zmiany projektu można następnie wprowadzać za pomocą zleceń zmian inżynierskich (ECO). Zlecenie ECO zawiera listę wszystkich modyfikacji wymaganych do wprowadzenia zmian w co najmniej jednym dokumencie projektu w celu wykonania żądanej operacji synchronizacji. Zlecenia ECO służą do aktualizowania projektu w różnych sytuacjach, takich jak:
- Aktualizacja projektu PCB na podstawie schematu.
- Aktualizacja numeracji oznaczeń komponentów na schemacie oraz oznaczeń komponentów po kompilacji.
- Wprowadzanie aktualizacji parametrów za pomocą Parameter Manager (Tools » Parameter Manager).
- Aktualizacja informacji o parametrach na podstawie danych przechowywanych w bibliotekach źródłowych lub firmowej bazie danych. Przy każdym porównaniu schematu i PCB (na przykład po wybraniu Design » Update) Altium Designer najpierw dopasowuje komponenty o tym samym identyfikatorze UID. W przypadku wykrycia komponentów, których identyfikatory UID nie są zgodne, wyświetlane jest powiadomienie, a aplikacja proponuje próbę dopasowania ich według oznaczeń. Komunikat ten będzie się pojawiał, dopóki komponentom na schemacie i PCB nie zostaną przypisane zgodne identyfikatory UID. Unikatowymi identyfikatorami i ich powiązaniami zarządza się w oknie dialogowym Edytuj powiązania komponentów (Project » Component Links).
Należy pamiętać, że to okno dialogowe można otworzyć tylko wtedy, gdy aktywny jest dokument PCB, ponieważ zmiany identyfikatorów UID są zawsze wprowadzane na PCB, a nie na schemacie. Z tego okna można korzystać na dowolnym etapie projektowania, aby przeglądać powiązania między komponentami i sprawdzać, czy komponenty w poszczególnych dokumentach są poprawnie dopasowane, a także przypisywać zgodne identyfikatory UID komponentom, które obecnie nie są dopasowane.

