Criando o documento BOM
Num relance
- Você aprenderá a criar um BomDoc, o que acontece quando ele é adicionado a um projeto e a importante limitação de um BomDoc por projeto.
- Você verá como a lista de itens da BOM é organizada, incluindo modos de visualização, controles de colunas, ferramentas de edição, comportamento de agrupamento e opções de configuração de exibição.
- Você entenderá como o ActiveBOM lida com componentes agrupados e entradas personalizadas da BOM, ajudando a contemplar tanto os componentes do projeto quanto os itens adicionais.
Criando o documento BOM
O documento BOM de trabalho do ActiveBOM é chamado de BomDoc. Adicione um novo BomDoc ao projeto pelo submenu File » New ou clique com o botão direito no projeto no painel Projects. Quando houver pelo menos um componente no projeto, um novo BomDoc poderá ser criado clicando no controle + Create ao lado da entrada ActiveBOM na estrutura do projeto no painel Projects. Observe que cada projeto de PCB pode incluir apenas um BomDoc.
Quando você adiciona um novo BomDoc ao projeto, o esquemático é compilado automaticamente e todos os componentes existentes são listados no BomDoc. Para componentes da Biblioteca do Workspace que incluem opções de peças, as soluções serão detalhadas na região inferior da interface, conforme explicado na seção Entendendo a solução abaixo.
À medida que novos componentes são posicionados no esquemático, eles são adicionados automaticamente ao BomDoc. Itens de BOM e parâmetros adicionais também podem ser adicionados manualmente diretamente no ActiveBOM pelo botão Add new, localizado acima da lista de componentes. Consulte a seção Itens e colunas personalizados da BOM para saber mais.
A lista de itens da BOM
A região superior do BomDoc é uma lista em formato de tabela de todos os componentes detectados no projeto de PCB, além dos itens de BOM adicionais que você adicionou diretamente ao BomDoc. Essa região é chamada de lista de itens da BOM.

A lista de componentes, ou itens da BOM, exibida na visualização Base.
Há 3 modos de visualização disponíveis para exibir os itens da BOM. Selecione o modo desejado usando os botões localizados acima da lista:
Flat view - uma linha para cada componente.
Base view - uma linha para cada componente exclusivo do projeto; a coluna Designador lista os designadores de todos os componentes desse tipo. Há várias opções de apresentação disponíveis para designadores agrupados. Selecione o modo Designator Grouping desejado no painel Properties.
Consolidated view - usado quando o projeto inclui variantes, para exibir uma BOM consolidada de todas as variantes.
Recursos de edição da lista de itens da BOM
A lista de componentes oferece vários recursos de edição semelhantes aos de uma planilha, incluindo:
- Use a guia Column do painel Properties para exibir/ocultar uma coluna e definir um nome alternativo para ela. Um nome alternativo também pode ser definido usando a caixa de diálogo Inserir propriedades da coluna, acessada clicando com o botão direito no nome de uma coluna na região de cabeçalhos de coluna do BomDoc e selecionando o comando Rename Column no menu de contexto. Observe que o nome alternativo é o nome da coluna nas saídas de BOM geradas.
-
As colunas também podem ser adicionadas e removidas usando a caixa de diálogo Select Columns , acessada clicando com o botão direito no nome de uma coluna na região de cabeçalhos de coluna do BomDoc e escolhendo Select Columns.

A caixa de diálogo Select ColumnsOpções/controles da caixa de diálogo Selecionar colunas
- Search - digite caracteres no campo para filtrar a lista de colunas, mostrando apenas aquelas cujo nome inclui os caracteres digitados.
-
Visibility column - usado para controlar se uma coluna do ActiveBOM está visível no documento do ActiveBOM (
*.BomDoc). Clique no ícone de olho para alternar uma coluna entre visível e oculta. As colunas visíveis são sempre listadas na parte superior da caixa de diálogo na ordem em que aparecem no BomDoc. -
Data Source column - exibe a fonte de dados da coluna. As fontes de dados compatíveis incluem:
-
- itens adicionados diretamente à BOM
-
- parâmetros dos componentes do esquemático
-
- parâmetros dos componentes do Workspace
-
- parâmetros do banco de dados vinculado (DbLink, DbLib)
-
- parâmetros do documento esquemático
-
- Altium Cloud Services
-
- Column Name - exibe o nome da fonte de dados, que aparece como o nome da coluna no BomDoc.
- Up / Down - use para mover a coluna selecionada para cima ou para baixo na lista. Como resultado, a coluna será movida para a esquerda ou para a direita no BomDoc quando OK for clicado. Observe que apenas as colunas visíveis podem ter sua posição na ordem alterada.
-
- clique no símbolo de filtro ao lado de cada cabeçalho para filtrar as informações na grade pelo item escolhido na lista.
- Arraste e solte para alterar a ordem das colunas.
- Classifique por qualquer coluna e mantenha Shift pressionado para aplicar uma classificação secundária nas colunas subsequentes.
-
Clique no ícone de filtro para filtrar pelos valores das colunas
- Selecione células usando as técnicas padrão de seleção do Windows.
- Copie o conteúdo das células do ActiveBOM e cole valores de um editor de planilhas externo nas colunas personalizadas do ActiveBOM.
- Números de linha configuráveis pelo usuário podem ser definidos quando a BOM está na visualização Base. Na visualização Base, clique no botão Set line numbers para adicionar um número de linha a cada linha. Clique no ícone de menu suspenso à direita do botão para abrir a caixa de diálogo Opções de número de linha, na qual os valores inicial e de incremento podem ser definidos. Consulte a seção Coluna de número de linha para saber mais.
- Clique no menu suspenso Add New para adicionar mais linhas ou colunas. Consulte a seção Itens e colunas personalizados da BOM para saber mais.
- Clique no botão Group by para agrupar a grade pela coluna habilitada. Várias colunas de agrupamento podem ser habilitadas (mostrar imagem), e sua ordem pode ser alterada arrastando e soltando. Esse é um recurso de exibição da grade; o agrupamento não é transferido para a caixa de diálogo Report Manager quando o comando Bill of Materials é executado.
- Clique no botão Reset Supply Chain para remover a classificação de soluções definida pelo usuário e as prioridades de SPN atribuídas manualmente dos itens da BOM selecionados.
- A configuração atual da grade de itens da BOM pode ser salva como um conjunto de BOM. Consulte a seção Configuração e salvamento da exibição da grade de itens da BOM para saber mais.
-
Use os atalhos padrão do Windows para percorrer a lista de itens da BOM:
- Rolagem vertical = MouseWheel Roll
- Rolagem horizontal = Shift + MouseWheel Roll
Os grupos de colunas

A lista de componentes do ActiveBOM tem grupos distintos de colunas presentes em cada modo de visualização; a imagem acima mostra a visualização Base.
A grade de itens da BOM é organizada nos seguintes grupos principais:
- Item Details (destaque em laranja na imagem) — essas colunas exibem detalhes paramétricos dos componentes, como designador, descrição, referência de biblioteca e outros parâmetros de componente.
- Solutions (destaque em verde na imagem) — o fabricante + fornecedor(es) mais bem classificados da cadeia de suprimentos. O número de soluções (peças de fabricante) e o número de fornecedores de cada solução são configurados no painel Properties do ActiveBOM — eles são indicados por uma faixa de cor sólida no bloco do fornecedor. A classificação é automática e também pode ser definida manualmente, conforme discutido na seção Entendendo a solução abaixo.
- BOM Status (destaque em ciano na imagem) — uma indicação do risco atual associado a cada componente. Passe o cursor sobre um ícone para ver uma descrição ou, como alternativa, habilite a coluna detalhada BOM Status no painel Properties para exibir a descrição.
Itens e colunas personalizados da BOM
O gerenciamento da BOM de um projeto de PCB exige o gerenciamento de componentes e itens da BOM além daqueles posicionados no esquemático e na PCB, por exemplo, peças ainda não detalhadas, elementos de fixação, a placa nua ou a cola de montagem. Há muitos casos em que itens ou parâmetros personalizados da BOM são usados no projeto de PCB. Para essas situações, o ActiveBOM permite adicionar itens e colunas (parâmetros) à BOM, que podem então ser incluídos na BOM gerada:
- Custom row — uma maneira fácil de adicionar um item personalizado à BOM que precisa ser considerado no projeto (placa nua, cola etc.). Todos os campos de uma linha personalizada são definidos pelo usuário. As linhas personalizadas não são gerenciadas pelo ActiveBOM; por exemplo, se a quantidade for definida como 3, não serão exibidos 3 itens separados na visualização Plana. A pesquisa na cadeia de suprimentos também não é compatível com linhas personalizadas.
- Custom column — uma coluna adicional da BOM, gerenciada no ActiveBOM, que pode conter qualquer texto definido pelo usuário.
- Custom Item — um item adicional da BOM, normalmente destinado a itens que serão necessários, mas ainda não são totalmente conhecidos ou ainda não existem na biblioteca. Isso permite que o custo desses itens seja incluído na estimativa do custo total da placa.
-
Managed Component — um item adicional da BOM, gerenciado manualmente no documento da BOM. A caixa de diálogo Component Search será aberta, listando os componentes do Workspace conectado no momento.
Opções e controles da caixa de diálogo Component Search
- Search — use a caixa de texto de pesquisa para pesquisar manualmente um componente específico.
-
— clique para acessar um menu e selecionar entre:
- File-based Libraries Preferences — clique para abrir a caixa de diálogo Available File-based Libraries para adicionar ou remover bibliotecas.
- File-based Libraries Search — clique para abrir a caixa de diálogo File-based Libraries Search para pesquisar bibliotecas.
- Refresh — clique para atualizar a caixa de diálogo.
-
— clique para abrir/fechar a Details região da caixa de diálogo (descrita abaixo).
Categorias
Use este filtro para mostrar determinados tipos de componentes ou para exibir todos os componentes disponíveis. Use
para acessar a Categories barra de pesquisa, que permite pesquisar manualmente um componente específico ou um arquivo .IntLib.
Filtros
Clique no Filters ícone para abrir a Filters região, onde você pode filtrar ainda mais as categorias selecionadas na Components lista.
Componentes
- Name - o nome do componente.
- Description - a descrição de cada componente.
- Footprint - o footprint do componente.
- Operating Temperature Range - a faixa de temperatura adequada em que esses componentes operam.
- Package Description - a descrição do encapsulamento do componente.
- Manufacturer Part Search - clique para abrir o painel Pesquisa de peças do fabricante para pesquisar e escolher a peça de componente mais adequada.
- Create component - clique para abrir a caixa de diálogo Create new component para selecionar o tipo de componente.
- Results - lista o número total de componentes encontrados/listados na pesquisa.
Detalhes
- Component Revision ID - lista o ID da revisão e o preço de um determinado componente. Clique no ID da revisão para abrir o painel Explorer e obter mais informações sobre um componente.
- References - clique para abrir informações de referência do componente em um navegador da Web. Use a lista suspensa para acessar Manufacturer URL ou Datasheet.
- Place - clique para posicionar o componente selecionado em um documento esquemático.
- Component information - lista informações relevantes sobre o componente, incluindo fabricante, data de lançamento e informações descritivas. Clique no link Show More para visualizar todas as informações; clique em Show Less para recolher as informações.
- Models - expanda para visualizar os modelos fornecidos. Use os links disponíveis para exibir várias partes de um único modelo.
- References - expanda para acessar Manufacturer URL ou Datasheet.
- Part Choices - expanda para visualizar as opções de peças. São fornecidos nome, preço e descrição. A folha de dados do componente também será listada.
- Where Used - expanda para visualizar os projetos que utilizam o componente.
Menu de contexto
- Place <component> - clique para posicionar o componente no documento apropriado.
- Edit - clique para abrir os documentos da biblioteca de componentes do componente selecionado.
- Navigate to <revision> - clique para abrir o componente selecionado no painel Explorer.
- Operations - passe o cursor sobre a opção para acessar as funções Submit Request, Create, Download, Make a copy, Change Component Type, Create / Edit PCL e Full Item History.
- Refresh - clique para atualizar e visualizar atualizações ou edições recentes. Você também pode atualizar usando o atalho F5.
Como adicionar instâncias de um componente gerenciado ou item personalizado
Após adicionar um componente gerenciado ou um item personalizado, clique nele com o botão direito do mouse e selecione o comando Operations » Add Instances of para acessar a caixa de diálogo Add to BOM Components. Use essa caixa de diálogo para definir o número de instâncias do componente na BOM.
Especifique Designator prefix, opcionalmente Separator (que pode ser definido para gerar resultados como X-1 ou X:1) e Quantity de componentes necessários (esse valor é usado para definir o intervalo de designadores e também aparecerá na coluna Quantity do ActiveBOM). Todos os outros parâmetros, como a descrição, podem ser editados diretamente na grade de itens da BOM.
Como alterar/remover um componente gerenciado ou item personalizado
Para editar o designador ou remover uma instância de um componente gerenciado ou de um item personalizado, clique nele com o botão direito do mouse e selecione o comando Operations » Edit item. A caixa de diálogo Change / Remove será aberta.
Opções e controles da caixa de diálogo Alterar/Remover
- BOM Components - a região da grade da caixa de diálogo lista cada instância do novo item. Para editar o prefixo ou o valor do designador, clique na célula New Designator apropriada e edite-a conforme necessário.
- Remove All - clicar neste botão selecionará todas as instâncias do item adicional da BOM listadas na caixa de diálogo e as marcará para remoção. Quando o botão OK da caixa de diálogo for clicado, todos os itens marcados para remoção serão removidos da grade de itens da BOM do ActiveBOM. Observe que, como não haverá mais nenhuma instância desse novo item, o item também será removido. Essa ação não pode ser desfeita.
- Remove None - clique neste botão para limpar todas as marcações de remoção.
- Remove Selected - quando uma instância que não está marcada para remoção é selecionada, o terceiro botão pode ser usado para marcar as instâncias atualmente selecionadas para remoção.
- Restore Selected - quando uma instância que está marcada para remoção é selecionada, o terceiro botão pode ser usado para limpar a marcação de remoção das instâncias atualmente selecionadas.
Fontes de dados
As fontes de dados padrão disponíveis no ActiveBOM são os parâmetros dos componentes do esquemático , os parâmetros dos componentes do Workspace para o conteúdo do Workspace e os dados fornecidos pelo ActiveBOM A partir dessas fontes, o ActiveBOM gera a grade principal de itens da BOM do projeto. As fontes de dados são habilitadas e sua exibição é controlada na guia Columns do painel Propriedades do ActiveBOM.
Ao habilitar o botão Sources correspondente (acima da lista de colunas), a BOM também pode incluir informações obtidas das seguintes fontes de dados adicionais:
The PCB - habilite estas opções para incluir dados de localização/rotação/lado da placa da PCB nas Columns disponíveis, para cada um dos componentes. Se o projeto contiver vários documentos de PCB, a caixa de diálogo Escolher PCB a usar será aberta para selecionar a PCB desejada.
Database - para carregar parâmetros adicionais de componentes de um banco de dados externo (via *.DbLib, *.SVNDbLib ou *.DbLink).
Altium Cloud Services - habilite esta opção para acessar uma ampla variedade de dados adicionais de componentes para os itens da BOM que foram identificados pelo Altium Parts Provider e apresentam uma solução de cadeia de suprimentos.
Document Parameters - habilite esta opção para incluir todos os parâmetros de documentos esquemáticos detectados, em todos os esquemáticos do projeto de PCB, nas Columns disponíveis.

A fonte de cada parâmetro é indicada pelo ícone na lista de colunas.
Prioridade dos parâmetros das fontes de dados
Se o mesmo parâmetro estiver presente em mais de uma fonte de dados, as seguintes prioridades serão aplicadas no ActiveBOM (da mais alta para a mais baixa):
- BOM
- PCB
- Documentos
- Servidor
- Banco de dados
- Nuvem
- Esquemático
- Manual
Coluna Número da linha
Para projetos de PCB com desenhos de montagem ou para a troca de dados de BOM entre engenheiros de projeto, engenheiros de custos ou especialistas em compras, o número da linha da BOM (número de posição do item da BOM) é um método simples para distinguir individualmente as linhas da BOM, que podem então ser usadas para identificar explicitamente ou find a chamada, o componente e a representação correspondentes no projeto.
Como fonte de dados da BOM do projeto, o ActiveBOM oferece suporte a números de linha definidos pelo usuário para a BOM do projeto e conta com recursos de gerenciamento manual e automático do Nº da linha (número de posição do item da BOM).
-
Para definir automaticamente o número de posição de todos os itens da BOM do projeto (na visualização Base), clique no botão Set Line #
. Os números das linhas são exibidos na coluna Line #, no grupo de colunas Detalhes do item. Clique no ícone de menu suspenso à direita do botão para abrir a caixa de diálogo Line # Options, na qual é possível definir os valores inicial e de incremento.

A caixa de diálogo Line Number Options- Start number - o valor a ser usado se a primeira célula Line # estiver vazia.
- Increment - incrementar cada campo Line # vazio por esse valor.
-
Para alterar manualmente os números das linhas, alterne para o modo de visualização Base, selecione as células desejadas na coluna Nº da linha e:
- Pressione Delete no teclado para limpar as células e, em seguida,
- digite manualmente os novos valores ou
- cole um intervalo de valores da área de transferência do Windows.
-
Para renumerar ou continuar a numeração a partir de um número adicionado manualmente, clique na célula Nº da linha do item desejado e, em seguida, no botão Set Line #
. A caixa de diálogo Line Numbering será aberta, na qual você poderá usar os números existentes como referência e numerar sequencialmente as células vazias selecionadas ou todas as células vazias, começando pelas células não vazias mais próximas acima (Continue numbering), ou excluir todos os números existentes e renumerar todas as linhas (Renumber all). Os últimos valores de base e incremento definidos na caixa de diálogo Line # Options são usados para calcular os números adicionados. Se necessário, você pode inserir um valor inicial na célula Nº da linha selecionada para definir o número de início.
Configuração e salvamento da exibição da grade de itens da BOM
Como qualquer bom aplicativo de planilhas, a grade de itens da BOM pode ser configurada para atender às suas necessidades. Além dos recursos tradicionais de organização e classificação de colunas, a configuração atual pode ser salva como um conjunto de BOM.
Recursos de configuração da grade
- Exibir/ocultar qualquer coluna - por meio do recurso Colunas no painel Properties. Use o campo Search na parte superior do painel para localizar rapidamente uma coluna.
- Alterar a ordem das colunas - clique no título da coluna, mantenha o botão do mouse pressionado e arraste e solte.
- Alterar a largura de uma coluna - posicione o ponteiro sobre a borda da coluna na região do título e clique e arraste (procure o cursor , ou clique duas vezes nesse local para ajustar automaticamente a largura ao conteúdo da coluna.
-
Classificar toda a grade por uma coluna:
- Clique no título da coluna para classificar a grade alfanumericamente pelo conteúdo dessa coluna.
- Clique uma segunda vez para classificar na ordem inversa.
- Mantenha a tecla Shift pressionada e clique no título de outra coluna para aplicar uma classificação secundária pelo conteúdo dessa coluna.
-
Filtrar a grade por um valor específico - clique no ícone Filtrar
para filtrar a grade por um valor usado nessa coluna. Selecione (Custom) para acessar a caixa de diálogo Filter Editor e definir a condição, o operador, o valor, o tipo de operador etc. para filtrar a coluna selecionada.
- Armazenar a configuração como um conjunto de BOM - veja mais sobre isso abaixo.
Como trabalhar com conjuntos de BOM
É possível salvar qualquer quantidade de configurações da grade de itens da BOM — cada uma delas é chamada de conjunto de BOM. Após configurar a grade de acordo com suas necessidades, clique no botão Add na região BOM Sets do painel Properties do ActiveBOM para adicionar um conjunto de BOM à lista.

Clique no ícone de olho para habilitar um conjunto de BOM.
Os conjuntos de BOM são configurados no painel Propriedades do ActiveBOM.
Substituição de um componente
Não é incomum identificar um problema com um componente quando o BomDoc está sendo verificado e preparado para a compra das peças. Por exemplo, o projetista pode ter se esquecido de finalizar a seleção de um componente, ou um componente pode ter chegado ao fim da vida útil (EOL) e o projetista deseja verificar o preço e a disponibilidade de possíveis substitutos. Anteriormente, a única maneira de resolver isso era voltar ao esquemático e editar o componente, selecionar uma peça adequada e, em seguida, atualizar o BomDoc.
Como alternativa, você pode alterar um componente no BomDoc e, em seguida, enviar essa alteração de volta ao esquemático por meio de uma ordem de alteração de engenharia. Clique com o botão direito do mouse nos componentes selecionados e selecione o comando Operations » Change <ComponentName>. A caixa de diálogo Substituir componente será aberta, na qual você poderá pesquisar o componente substituto.
Ao clicar no botão Replace Component OK, a caixa de diálogo Engineering Change Order será aberta, detalhando as alterações necessárias para sincronizar o esquemático com o BomDoc.
Trabalhando com variantes
O ActiveBOM oferece suporte a projetos de PCB que incluem variantes de projeto. O recurso Variantes de projeto permite criar um único projeto base de PCB, que é então montado com diferentes configurações de componentes. Cada configuração de montagem diferente da placa é chamada de design variant.
Trabalhando com variantes de projeto:
- As variantes de projeto são configuradas na caixa de diálogo Gerenciamento de variantes ou no Gerenciador de variantes (Project » Variants).
- Para examinar uma variante, clique duas vezes em seu nome na pasta Variantes do projeto no painel Projects, conforme mostrado na imagem abaixo.
O ActiveBOM oferece suporte a variantes das seguintes formas:
- Exibição da BOM de uma variante específica no modo de visualização Base ou Plano
- Opção para incluir os itens Não montados na lista de itens da BOM
- Exibição de uma lista consolidada de todas as peças usadas em todas as variantes, no modo de visualização Consolidado
- Definição de soluções manuais tanto para componentes base quanto para componentes com variações
Variantes no modo de visualização Base
Para a variante selecionada, habilite a opção Show Not Fitted no painel Properties para incluir essas peças na grade de itens da BOM. Quando essa opção está habilitada, a coluna Fitted é exibida automaticamente nos Detalhes do item.
No modo de visualização Base, a coluna Fitted exibirá Fitted ou Not Fitted. Se uma peça tiver uma variação (uma peça alternativa tiver sido escolhida nessa variante), os detalhes da peça alternativa serão exibidos automaticamente para esse item da BOM.

Observe que a variante atual é exibida na linha de status do ActiveBOM.
Variantes no modo de visualização Consolidado
O modo de visualização Consolidado exibe todos os componentes usados em todas as variantes. A visualização Consolidada oferece os seguintes recursos:
- Se um componente tiver uma variação, haverá um item da BOM para cada componente alternativo utilizado, e todos esses itens da BOM terão o mesmo designador. Por exemplo, na imagem abaixo, os componentes DS1 e DS2 aparecem duas vezes cada, pois a variante BGA utiliza um LED de cor diferente do utilizado na variante TSOP. O componente R1 aparece três vezes porque as variantes BGA e TSOP utilizam resistores diferentes do original no projeto base.
-
No modo de visualização Consolidado, quando a opção Show Not Fitted está habilitada, a coluna Fitted exibirá
FittedouVaried. Como a visualização Consolidada mostra todos os componentes usados em todas as variantes, cada componente exibido é montado no projeto base ou em uma variante. - Para cada variante, há uma coluna <VariantName> - Qty (que indica quantas unidades desse componente são usadas nessa variante) e uma coluna <VariantName> - Price, que corresponde ao preço unitário multiplicado pelo valor na coluna de quantidade.
- Como alguns projetistas criam documentação de montagem tanto a partir do projeto base quanto das variantes, também há uma coluna Quantity, que reflete o número de instâncias desse componente usadas na montagem do projeto base. Oculte essa coluna se você não gerar documentação de montagem a partir do projeto base.
- A grade no modo de visualização Consolidado usa cores para indicar uma célula cujo valor é diferente do valor da mesma célula no projeto base, conforme mostrado abaixo.

A cor de uma célula indica que seu valor é diferente do valor da mesma célula no projeto base.
Para saber mais sobre variantes, consulte a página Variantes de projeto.
Trabalhando entre o BomDoc, o esquemático e a PCB
Há dois recursos disponíveis para ajudar você a trabalhar entre o BomDoc, o esquemático e o projeto da PCB: Seleção cruzada e Sondagem cruzada. O comportamento desses recursos é configurado na página Sistema - Navegação da caixa de diálogo Preferences.
Ambos os recursos podem ser usados para localizar o mesmo componente em outros documentos. A diferença entre Seleção cruzada e Sondagem cruzada é que o modo de Seleção cruzada seleciona o componente no documento de destino, mas não exibe esse documento ativamente, enquanto a Sondagem cruzada exibe ativamente o documento de destino e também pode alternar para o editor desse documento e torná-lo o editor ativo.
Você pode usar a Seleção cruzada ou a Sondagem cruzada do BomDoc para o esquemático e a PCB, mas não pode usar a Seleção cruzada ou a Sondagem cruzada do esquemático ou da PCB para o BomDoc.
Modo de Seleção cruzada
O modo de Seleção cruzada deve ser habilitado em cada editor no qual você deseja utilizá-lo. Selecione o comando Tools » Cross Select Mode (Shift+Ctrl+X). Quando o modo de Seleção cruzada está habilitado, o ícone do menu fica destacado com um contorno
.
O modo de Seleção cruzada exige que o documento de destino esteja aberto. Quando você seleciona um componente na lista de itens da BOM do BomDoc, esse componente é selecionado e centralizado nos documentos de esquemático e PCB de destino (se Zooming estiver habilitado nas opções Cross Select Mode da página Sistema - Navegação da caixa de diálogo Preferences). Observe que o documento de destino não será exibido como o documento ativo.
Se o BomDoc estiver no modo de visualização Base, todas as instâncias dessa peça serão selecionadas no esquemático e na PCB, conforme mostrado na imagem abaixo.

Use o recurso Seleção cruzada para localizar e selecionar, no esquemático e na PCB, o componente escolhido na lista de itens da BOM.
Sondagem cruzada
Enquanto a Seleção cruzada é apenas um modo que, quando habilitado, exibe o resultado sempre que você clica na lista de itens da BOM, a Sondagem cruzada é uma ação deliberada.
Escolha o Tools » Cross Probe comando nos menus principais ou clique com o botão direito em um item da BOM e selecione Cross Probe no menu de contexto para fazer a sondagem cruzada desse componente no esquemático. A sondagem cruzada também será realizada no componente da PCB se o arquivo da placa estiver aberto.
Um recurso importante da sondagem cruzada é a capacidade de alternar para o editor do documento de destino. Para realizar a sondagem cruzada e alternar entre editores, mantenha a tecla Ctrl pressionada ao selecionar o comando Cross Probe.

Clique com o botão direito para acessar o comando de sondagem cruzada; haverá uma entrada para o designador de cada componente presente nesse item da BOM.
Painel Propriedades
Quando o documento ativo é um documento BOM (*.BomDoc), o painel Properties apresenta o Document Options.
As seções recolhíveis a seguir contêm informações sobre as opções e os controles disponíveis:
Geral
- Production Quantity – o número de placas a serem fabricadas. É importante definir este campo, pois ele é usado durante a pesquisa na cadeia de suprimentos para verificar a disponibilidade dos componentes nos fornecedores.
- Currency – a moeda preferencial para exibir os preços dos componentes. As taxas de câmbio para conversão de moeda são atualizadas diariamente, desde que você esteja conectado à sua conta Altium. Ao se desconectar da Altium (na página Sistema – Gerenciamento de contas da caixa de diálogo Preferences), o acesso a essas taxas atualizadas é perdido. Nessa situação, há uma opção na caixa de diálogo de relatórios de BOM para usar dados em cache.
- Price Per Board – calculado a partir dos dados dos fornecedores, este valor é a soma de Supplier Subtotals per Board, conforme descrito abaixo. Observe que o Price Per Board não considera nenhuma quantidade mínima de pedido (MOQ).
- Order Price – soma de Supplier Subtotals. Observe que o Order Price considera as MOQs; este é o valor pago ao fornecedor.
Cadeia de suprimentos
As informações da cadeia de suprimentos são apresentadas na região inferior da interface do ActiveBOM, mostrando um componente do fabricante à esquerda, com um ou mais blocos coloridos de fornecedores à direita. Essa região exibe dados quando é possível identificar informações válidas da cadeia de suprimentos para um item da BOM. Cada uma dessas linhas Manufacturer & Supplier(s) Details é chamada de solução. Os detalhes do fabricante são abreviados como MPNs (códigos de peça do fabricante), e os detalhes do fornecedor são abreviados como SPNs (códigos de peça do fornecedor).
- Solutions per Item – o número de peças de fabricantes que você deseja localizar para cada item da BOM.
- Suppliers per Solution – o número de fornecedores que você deseja localizar para cada peça do fabricante.
-
Solutions
- Exclude Invalid SPNs – selecione para excluir SPNs inválidos.
- Favorite Suppliers List – abre a caixa de diálogo Fornecedores favoritos, na qual é possível configurar a lista geral de fornecedores para este BomDoc.
-
Manufacturer Link – abre a caixa de diálogo Definir campos de vínculo com o fabricante, na qual são identificados os parâmetros dos componentes do esquemático que contêm o nome do fabricante e o código de peça do fabricante. Se houver no projeto peças de bibliotecas que não sejam de um Workspace (peças que não foram inseridas a partir de um Workspace e que também não possuem detalhes de fornecedores), o ActiveBOM poderá consultar o Altium Parts Provider para identificar soluções adequadas da cadeia de suprimentos. É possível definir vários pares de parâmetros de nome / código de peça. Na caixa de diálogo, clique no botão Detect fields para adicionar automaticamente todos os pares de parâmetros que incluam o termo
manufacturerno nome e que possam ser associados logicamente.
Itens da BOM
Esta região é usada para configurar como os itens da BOM devem ser agrupados na grade de itens da BOM.
-
Items
-
Show not Fitted – se o projeto de PCB incluir variantes e a variante escolhida tiver peças definidas como
Not Fitted, habilite esta opção para exibir os itens não montados na grade de itens da BOM. - Designator Grouping – os modos de visualização Base e Consolidado mostram peças comuns em uma única linha na grade de itens da BOM. Use esta opção para configurar se os designadores serão exibidos individualmente ou em intervalos quando uma linha exibir várias peças.
- Component Grouping – clicar no botão Edit abre a caixa de diálogo Component Grouping. Na visualização Base ou Consolidated, o ActiveBOM identifica componentes como iguais quando compartilham o mesmo ItemID (biblioteca do Workspace) ou LibRef (biblioteca baseada em arquivos ou banco de dados). Habilite parâmetros na caixa de diálogo para refinar ainda mais como os componentes devem ser agrupados. Observe que, se o projeto incluir apenas componentes gerenciados, o botão Edit não estará acessível, pois os componentes gerenciados são sempre agrupados por ItemID.
-
Show not Fitted – se o projeto de PCB incluir variantes e a variante escolhida tiver peças definidas como
Conjuntos de BOM
Os conjuntos de BOM permitem capturar o layout e a configuração da grade de itens da BOM e salvá-los como um conjunto nomeado. É possível definir qualquer quantidade de conjuntos de BOM.
-
Current BOM Set – clique no ícone de olho para aplicar esse conjunto de BOM à grade de itens da BOM.
-
Add – configure a visibilidade, a ordem e a largura das colunas e clique em Add para salvar essa configuração como um conjunto de BOM. Para editar o nome do conjunto de BOM, clique uma vez para selecioná-lo e, em seguida, clique novamente para editar o texto.
-
Update – se a configuração da grade de itens da BOM for alterada, clique em Update para salvar novamente essa configuração.
-
Delete – clique em
para remover o conjunto de BOM selecionado.
Verificações da BOM
O ActiveBOM realiza uma verificação abrangente de cada item da BOM e de todos os dados da cadeia de suprimentos detectados para esse item.
- Violation Type grid – exibe uma lista de cada tipo e da quantidade de violações presentes no BomDoc. Clique no ícone de filtro para exibir apenas os itens da BOM que não passam nessa verificação da BOM. Observe que um item da BOM pode não passar em várias verificações da BOM.
-
BOM Checks – clique em
para abrir a caixa de diálogo Verificações da BOM, na qual o modo de relatório pode ser configurado para cada tipo de violação possível.
Colunas
Esta região do painel é usada para configurar quais parâmetros são exibidos para cada item da BOM e as fontes de dados disponíveis para esses parâmetros.
-
Sources – além dos dados adicionados diretamente ao BomDoc , as fontes de dados padrão disponíveis no ActiveBOM são os parâmetros dos componentes do esquemático e os parâmetros dos componentes da biblioteca do Workspace para conteúdo do Workspace A partir dessas fontes, o ActiveBOM gera a grade principal de itens da BOM do projeto. A BOM também pode incluir informações obtidas das seguintes fontes de dados adicionais:
-
PCB – habilite para incluir dados de localização/rotação/lado da placa da PCB nos Columns disponíveis para cada componente.
-
Database – habilite para carregar parâmetros adicionais dos componentes a partir de um banco de dados externo (*.DbLib,*.SVNDbLibou*.DbLink). -
Document – habilite para incluir todos os parâmetros de documentos esquemáticos detectados em todos os esquemáticos do projeto de PCB nos Columns disponíveis.
-
Altium Cloud Services – habilite para acessar uma ampla variedade de dados adicionais de componentes para os itens da BOM que foram identificados pelo Altium Parts Provider e apresentam uma solução de cadeia de suprimentos.
-
-
Columns – lista de todas as fontes de informações de componentes disponíveis para o ActiveBOM. A região Colunas pode ser ordenada clicando em qualquer um dos campos do cabeçalho.
- Visibility – cada linha tem um ícone de olho; clique para controlar a visibilidade dessa coluna na grade principal de itens da BOM.
- Source – exibe um ícone que indica a origem desse parâmetro.
- Name – o nome da propriedade/parâmetro conforme definido no documento de origem ou inserido em uma coluna do BomDoc criada pelo usuário.
- Alias – se necessário, é possível definir um alias para renomear uma coluna.
- Add – clique para adicionar uma nova coluna personalizada à grade de itens da BOM.





