Criando a montagem física de múltiplas placas
O Altium Designer suporta a criação de uma montagem de múltiplas placas, denominada multi-board assembly. Depois que a estrutura lógica do sistema é definida em um esquemático multi-board (*.MbsDoc), o projeto físico multi-board é então criado transferindo o projeto do sistema para um documento vazio de montagem multi-board (*.MbaDoc). Esse processo carregará no editor de montagem multi-board a representação física (PCBs e outras montagens multi-board) referenciada por cada bloco lógico no esquemático multi-board. Esta página aborda esse processo.
Para saber mais sobre a etapa de projeto lógico de uma montagem multi-board, consulte a página Capturing the Logical System Design.
Para criar um novo documento de montagem multi-board:
-
Adicione um novo documento de montagem multi-board (
*.MbaDoc) ao projeto multi-board clicando com o botão direito na entrada do projeto no painel Projects e, em seguida, selecionando Add New to Project » Multi-board Assembly no menu de contexto. -
Salve o novo documento de montagem multi-board (clique com o botão direito em sua entrada no painel Projects e selecione Save As no menu de contexto).
-
Transfira a representação lógica do sistema do esquemático multi-board para o documento de montagem multi-board – saiba mais.
-
Se o invólucro estiver disponível, carregue-o na montagem – saiba mais.
-
Posicione cada elemento dentro da montagem – consulte a página Positioning & Orienting Your Boards para saber mais.
-
Conecte elementos dentro da montagem usando mates – consulte a página Working with Mates para saber mais.

Exemplo de uma montagem multi-board. Várias PCBs conectadas são colocadas dentro de um invólucro.
Transferindo o projeto do sistema para o documento de montagem multi-board
O projeto multi-board é transferido do esquemático multi-board para o documento de montagem multi-board usando um dos seguintes comandos:
-
Design » Update Assembly - <MultiBoardAssemblyDocumentName>.MbaDoc do menu principal do editor de esquemático multi-board.
-
Design » Import Changes From <MultiBoardProjectName>.PrjMbd do menu principal do editor de montagem multi-board.
Quando você executa um desses comandos, o software analisa cada módulo no esquemático multi-board, identifica a PCB/montagem que foi selecionada para cada um dos projetos filhos e apresenta a lista de modificações necessárias para adicionar cada uma dessas placas à montagem na caixa de diálogo Engineering Change Order.

A placa de cada projeto PCB é listada como uma modificação ECO e é carregada no editor de Multi-board Assembly quando os ECOs são executados.
Quando o botão
é clicado, as placas/montagens são carregadas no editor de montagem multi-board. Cada placa/montagem é colocada no espaço de projeto na mesma orientação que possui no projeto filho. Esse processo levará algum tempo, pois o conjunto completo de dados de cada PCB deve ser analisado e carregado.

Placas nesta montagem multi-board carregadas no espaço de projeto do editor de montagem multi-board, prontas para serem posicionadas.
Adicionando objetos adicionais à montagem multi-board
Você também pode carregar objetos adicionais em uma montagem multi-board (além das PCBs referenciadas no esquemático multi-board). Objetos adicionais podem ser carregados usando o menu Design ou usando os botões localizados na parte superior do painel Multi-board Assembly.
Use o comando ou botão apropriado para:
-
Insert PCB Part – inserir outra PCB nesta montagem.
-
Insert MBA Part – inserir outra montagem multi-board nesta montagem.
-
Insert STEP Part – inserir um modelo mecânico em formato STEP nesta montagem.
Atualizando ou editando uma peça da montagem
Bloqueando/Desbloqueando uma peça
Para bloquear/desbloquear uma peça, selecione a peça desejada, clique com o botão direito e escolha o comando Lock Selected Part/Unlock Selected Part no menu de contexto para bloquear/desbloquear a peça (ou peças com mate) em sua localização atual no espaço de projeto do editor de montagem. Como alternativa, clique com o botão direito em uma entrada de peça no painel Multiboard Assembly e escolha Locked.
-
Uma peça bloqueada não pode ser editada/movida.
-
Peças bloqueadas são marcadas com um ícone de cadeado no painel Multiboard Assembly .
-
Uma peça individual bloqueada não exibe um gizmo de objeto (para saber mais sobre o gizmo de objeto, consulte a página Positioning & Orienting Your Boards).
Uma peça bloqueada não pode receber mate se for selecionada como a origem (o objeto que se move – para saber mais sobre mating de peças, consulte a página Working with Mates).
Atualizando uma peça
Se uma peça ou corpo 3D adicionado a uma montagem tiver sido atualizado, a atualização poderá ser carregada na montagem multi-board usando uma das seguintes ações:
-
Escolha o comando Edit » Update All Parts nos menus principais ou clique com o botão direito em qualquer lugar do espaço de projeto e escolha o comando Update All Parts no menu de contexto (atalho:
Shift+Ctrl+U) para atualizar todas as peças na montagem multi-board ativa com as informações de layout mais recentes de seus documentos PCB filhos correspondentes. -
Selecione a(s) peça(s) necessária(s) e escolha o comando Edit » Update Selected Part nos menus principais ou clique com o botão direito em qualquer lugar do espaço de projeto e escolha o comando Update Selected Part no menu de contexto (atalho:
Ctrl+U) para atualizar as peças selecionadas na montagem multi-board ativa com as informações de layout mais recentes de seus documentos PCB filhos correspondentes. -
Selecione o corpo 3D necessário e escolha o comando Edit » Update Selected 3D Body nos menus principais ou clique com o botão direito em qualquer lugar do espaço de projeto e escolha o comando Update Selected 3D Body no menu de contexto para atualizar os corpos 3D selecionados na montagem multi-board ativa com as informações de layout mais recentes de seus documentos PCB filhos correspondentes.
Editando uma peça
Uma sessão de edição de montagem ou PCB pode ser iniciada de dentro do editor de montagem multi-board. Selecione a peça desejada e execute o comando Edit » Edit Selected Part ou clique com o botão direito em qualquer lugar do espaço de projeto e escolha o comando Edit Selected Part no menu de contexto (atalho: Ctrl+E). Após executar o comando, você entrará no modo de edição de peça, com a PCB selecionada ampliada e centralizada (quando possível) para se ajustar à janela principal de projeto. A placa permanecerá exibida em sua coloração completa, com todas as outras placas em cinza (somente leitura).
Faça as alterações necessárias no posicionamento dos componentes, usando posicionamento manual e/ou recursos de alinhamento. Quando terminar a edição, use o comando Finish Part Editing (Ctrl+E). A visualização do espaço de projeto voltará a ajustar todas as placas na montagem, com a placa que estava sendo editada permanecendo selecionada.
Se quiser cancelar a edição sem implementar nenhuma das alterações, use o comando Cancel Part Editing .
Navegando e gerenciando a montagem multi-board
Para navegar e gerenciar uma montagem multi-board, você pode usar o painel Multiboard Assembly.
O painel apresenta uma visualização em árvore expansível da estrutura completa da montagem, incluindo:
-
As placas incluídas (PCBs) e montagens multi-board e os componentes, camadas e nets dentro de cada PCB
-
Modelos STEP que foram incluídos
-
Outras montagens multi-board que foram incluídas
-
Mates formados entre objetos na montagem
Destacando elementos na montagem multi-board
O painel Multiboard Assembly fornece recursos de destaque, em que a peça selecionada na árvore é destacada no espaço de projeto. O destaque é bidirecional para seleções feitas no topo da árvore da montagem; por exemplo, o estado de seleção das entradas do painel mudará em resposta a objetos de nível superior que tenham sido selecionados no espaço de projeto. No painel, a seleção é suportada em todos os níveis da árvore em que isso for lógico. Por exemplo, selecionar uma net individual destacará essa net em toda a placa, mas selecionar uma camada dielétrica individual não destacará essa camada. Os atalhos padrão do Windows Shift+Click ou Ctrl+Click podem ser usados para multisseleção no painel.

Três placas selecionadas no espaço de projeto também são destacadas no painel.
Controlando a visibilidade e a transparência das peças da montagem
Além de destacar uma peça específica ou peças, o painel também pode ser usado para controlar a visibilidade e a transparência das peças atualmente selecionadas no painel. Clique com o botão direito na(s) peça(s) selecionada(s) e escolha Visible ou Transparent no menu de contexto. Peças transparentes se tornarão translúcidas. Peças com a opção Visible desabilitada ficarão ocultas.
|
Um modelo STEP está totalmente visível na montagem. O mesmo modelo foi tornado transparente. O mesmo modelo foi completamente ocultado. |
Medindo a distância
O comando Tools » Measure Distance dos menus principais (atalho: Ctrl+M) é usado para medir distâncias entre corpos 3D na montagem multi-board. Após executar o comando, você entrará no modo de medição. A medição é realizada da seguinte forma:
-
Escolha o primeiro objeto 3D ou uma face específica desse objeto. À medida que você move o cursor sobre um objeto 3D em potencial, a cor desse objeto mudará. Se quiser selecionar uma face específica do objeto, mantenha pressionada a tecla
Ctrlenquanto move o cursor – a face atualmente sob o cursor será destacada. Com o cursor posicionado, clique para confirmar a seleção do objeto/face. -
Escolha o segundo objeto 3D ou uma face específica desse objeto.
-
A ferramenta apresenta visualmente a menor distância entre os dois objetos (faces) escolhidos.
-
Continue medindo a distância entre outros objetos/faces ou pressione
Escpara sair do modo de medição.
Teste de colisão
Colisões são sinalizadas sempre que dois objetos têm superfícies que se tocam ou se interceptam.
Para verificar colisões, selecione Tools » Check Collisions (atalho: Ctrl+K). Após executar o comando, o software verifica colisões entre as várias entidades envolvidas na montagem multi-board. Primeiro, cada placa é verificada quanto a colisão com as partes superior e inferior do invólucro/caixa (peças STEP), seguido da verificação entre as próprias placas (PCBs).
Quaisquer colisões serão reportadas por meio do painel Messages , e os objetos problemáticos serão destacados usando a cor de sistema Violation . Use a região Details do painel Messages para investigar qual componente em uma placa envolvida em um conflito está causando a colisão.
Se necessário, as violações de colisão destacadas no espaço de projeto após a execução da verificação de colisão podem ser limpas selecionando o comando Tools » Clear Violations .
Suporte a rigid-flex
O editor de montagem multi-board oferece suporte a PCBs rigid-flex. Rigid-flex é o nome dado a um circuito impresso que é uma combinação de circuito(s) flexível(is) e circuito(s) rígido(s). O editor de montagem multi-board exibe a PCB no estado final dobrado, conforme definido no editor PCB.
Para obter informações sobre o projeto de PCBs rigid-flex, consulte a página Designing a Rigid-Flex PCB.
Exportando para MCAD
A montagem pode ser exportada em formato STEP 3D ou Parasolid. Para exportar a montagem inteira em STEP 3D (*.step ou *.stp), selecione File » Export » STEP 3D nos menus principais. Para exportar a montagem inteira em formato Parasolid (*.x_t), selecione File » Export » Parasolid nos menus principais.

Um exemplo do arquivo STEP da montagem multi-board aberto em uma ferramenta MCAD.
Exportando para PDF 3D
Um documento de montagem multi-board também pode ser exportado para um arquivo PDF (*.pdf). Para fazer isso, escolha o comando File » Export to PDF File nos menus principais.
Para mais informações, consulte a página Preparing a PDF3D File.



