Preparação de um ficheiro PDF 3D

Num relance

Compartilhe uma visualização 3D interativa do seu projeto de PCB com fabricantes, empresas de montagem e clientes usando o recurso de exportação PDF3D do Altium Designer. Este artigo explica como gerar um PDF 3D, configurar o conteúdo e a aparência do projeto e explorar a placa exportada no Adobe Acrobat Reader. Continue lendo para preparar um PDF 3D adaptado ao que seu público precisa visualizar.

- Saiba como acessar a exportação PDF3D e configurar a geometria, os esquemas de cores, as vistas iniciais e as vistas opcionais salvas como quadros-chave.
- Entenda como o conteúdo do projeto incluído afeta o tamanho do arquivo e o desempenho da visualização.
- Descubra como a barra de ferramentas 3D e a Árvore de modelos do Acrobat Reader permitem navegar, destacar e controlar a visibilidade de componentes e redes.
Aprofunde-se com a IA:

Os usuários do Altium Designer há muito tempo contam com a possibilidade de visualizar interativamente projetos de PCB em 3D totalmente renderizado, o que proporciona uma visão única da estrutura real do projeto da placa, de seus componentes e das peças mecânicas associadas.

Há vantagens significativas em disponibilizar esse recurso 3D para pessoas de fora da equipe de projeto, como fabricantes e montadoras de placas e, não menos importante, clientes. Isso é possível graças ao recurso de exportação de PDF 3D do Altium Designer. Esse formato 3D interativo é acessível a qualquer pessoa que tenha uma versão recente do amplamente utilizado Adobe® Acrobat® Reader.

Visualize interativamente um projeto 3D exportado no Adobe Reader: aplique zoom, gire e selecione os elementos do projeto que deseja ver.
Visualize interativamente um projeto 3D exportado no Adobe Reader: aplique zoom, gire e selecione os elementos do projeto que deseja ver.

Diferentemente de uma vista fixa de um projeto 3D de placa, que oferece uma perspectiva em um ângulo específico, o formato PDF 3D exportado é conceitualmente equivalente à 3D Layout Mode interativa do Altium Designer. Assim, o PDF 3D exportado oferece os mesmos recursos de rotação, zoom e deslocamento, além de marcadores para cada componente e rede, e pode adotar um dos vários esquemas de cores predefinidos.

Para acessar o recurso de exportação de PDF 3D no Altium Designer, a extensão de software PDF3D Exporter deve estar instalada. Essa extensão é instalada por padrão com o Altium Designer. Ela pode ser instalada ou removida manualmente.

Para obter mais informações sobre o gerenciamento de extensões, consulte a página Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

3D no Acrobat Reader

A visualização 3D interativa de arquivos PDF tornou-se possível com a introdução de recursos avançados de visualização 3D no Acrobat Reader, a partir da versão 7. Aprimorados progressivamente nas versões posteriores do Acrobat Reader, o alto nível de detalhamento e as opções de configuração produzidos pela exportação de PDF 3D do Altium Designer são compatíveis com as versões 9 e superiores.

A base desse novo recurso 3D é o formato Universal 3D (U3D) para arquivos de computação gráfica, desenvolvido pela indústria e padronizado pela European Computer Manufacturers Association (ECMA) como Norma ECMA-363 — Formato de arquivo Universal 3D. O U3D tem suporte nativo no formato PDF e pode ser facilmente incorporado (e compactado) em um arquivo PDF para visualização 3D interativa no Acrobat Reader.

O resultado é um formato de arquivo 3D de tamanho reduzido e multiplataforma que não exige software especializado de visualização 3D. No caso dos arquivos PDF 3D exportados do Altium Designer, o conteúdo incorporado inclui a maior parte dos dados visíveis na própria visualização 3D do Altium Designer, incluindo todas as trilhas, ilhas, vias, polígonos etc., todos os componentes e o conjunto completo de camadas da placa.

Como gerar um PDF

Para exportar um arquivo PDF 3D, abra o documento de projeto de PCB desejado na área de projeto e escolha o comando File » Export » PDF3D nos menus principais (um arquivo PDF 3D será criado em formato 3D, independentemente do modo de visualização atual do Editor de PCB, 2D ou 3D).

Diferentemente de uma vista fixa de um projeto 3D de placa, com uma perspectiva em um ângulo específico, a nova exportação de PDF 3D é conceitualmente equivalente à própria visualização 3D interativa do Altium Designer.

Assim, o PDF 3D exportado oferece os mesmos recursos de rotação, zoom e deslocamento e pode adotar qualquer um dos esquemas de cores definidos pela configuração de visualização ativa. Para examinar ou editar a configuração atual e, portanto, as cores de renderização disponíveis para o PDF exportado, alterne para a visualização da placa em 3D (atalho de teclado: 3) e abra o painel View Configuration. As cores de renderização podem ser visualizadas na seção 3D Settings, na aba View Options do painel.

A aba View Options do painel View Configuration pode ser acessada rapidamente usando o atalho de teclado Ctrl+D.

Um arquivo PDF 3D será criado em formato 3D, independentemente do modo de visualização atual do editor de PCB (2D ou 3D).

Opções de exportação

Depois que a exportação de PDF 3D for iniciada (File » Export » PDF3D) e um nome e local para o arquivo de destino forem especificados na caixa de diálogo padrão do Windows Export File, a caixa de diálogo Export 3D será aberta para permitir a definição da renderização, do comportamento e do conteúdo do projeto incluído no PDF.

A caixa de diálogo Export 3D permite configurar a aparência e o comportamento do PDF exportado.
A caixa de diálogo Export 3D permite configurar a aparência e o comportamento do PDF exportado.

Use a caixa de diálogo Export 3D para configurar as opções de exportação conforme necessário e, em seguida, clique no botão Export para gerar o arquivo PDF 3D.

Os arquivos 3D podem ser grandes, mesmo com a compactação de dados inerente ao formato, portanto, considere qual nível de conteúdo do projeto é importante para o usuário final. Por exemplo, o conteúdo das camadas de cobre (trilhas, pads etc.) pode não ser necessário para alguém que esteja analisando os aspectos mecânicos do projeto de uma placa.

  • Observe que o Acrobat Reader permite aos usuários ativar ou desativar a exibição dos elementos do modelo (em grupos ou individualmente) para atender às suas necessidades — veja abaixo.

  • Os quadros-chave definidos em um documento PCB podem ser integrados à exportação de PDF 3D marcando a opção Use 3D Movie views na caixa de diálogo Export 3D. Os quadros-chave exportados para o documento PDF 3D ficarão disponíveis como vistas selecionáveis no Acrobat Reader.

Ao escolher o conteúdo 3D a ser incluído, também vale a pena considerar os recursos de renderização 3D do PC de quem visualizará o arquivo. Embora o tamanho do arquivo PDF 3D resultante possa ser razoável, a CPU e o sistema gráfico da máquina de destino podem ter dificuldade para renderizar com fluidez um projeto multicamadas complexo.

As opções acima definem as configurações iniciais quando o PDF é aberto no Acrobat Reader e podem ser facilmente alteradas conforme a preferência na barra de ferramentas 3D do leitor. Observe que, se a barra de ferramentas estiver desabilitada nas opções de exportação de PDF 3D, o usuário não poderá alterar a visualização.

Visualização de um PDF 3D

Como você pode imaginar, visualizar um PDF 3D no Acrobat Reader é bastante simples, com comandos e menus que são extensões lógicas das conhecidas funções 2D.

Os objetos 3D podem ser deslocados, ampliados, reduzidos e girados com operações simples de arrastar o mouse e usar a roda de rolagem, com as funções selecionadas na barra de ferramentas flutuante 3D.

A barra de ferramentas 3D do Acrobat fornece controles para navegação 3D e configurações de iluminação e visualização.
A barra de ferramentas 3D do Acrobat fornece controles para navegação 3D e configurações de iluminação e visualização.

Um recurso particularmente útil do leitor é o painel de navegação Model Tree, que pode ser aberto (caso ainda não esteja) com o botão . Ele permite ao usuário navegar por todos os objetos no PDF 3D, selecionar e realçar os de interesse e ativar ou desativar sua visibilidade.


O painel de navegação Árvore do modelo é particularmente útil
para controlar a exibição de componentes e redes específicos.

O painel de navegação Model Tree oferece uma maneira poderosa de examinar todos os aspectos de um projeto 3D com alto nível de detalhe. Seja para uma análise minuciosa do posicionamento e do layout dos componentes ou para uma inspeção detalhada da estrutura interna da placa, a árvore de navegação pode ser usada para localizar e exibir os objetos apropriados.

O projeto exibido com os componentes e as camadas de serigrafia da placa desmarcados, ilustrando o nível de controle 3D disponível no Acrobat Reader.
O projeto exibido com os componentes e as camadas de serigrafia da placa desmarcados, ilustrando o nível de controle 3D disponível no Acrobat Reader.

Quando selecionados no painel Model Tree, os objetos individuais são realçados na janela de visualização com a cor definida na parte superior do painel (vermelho, neste caso). Isso facilita a localização de um componente ou de uma rede específicos e evita a necessidade de ativar e desativar a visibilidade de um objeto para encontrá-lo. Da mesma forma, selecionar um objeto na janela de visualização 3D realça sua entrada no painel Model Tree.

Para obter mais informações sobre como usar os diversos controles, funções e configurações do Acrobat Reader, consulte o conteúdo de ajuda relevante da Adobe: Exibição de modelos 3D em PDFs.

Os metadados básicos do projeto do Altium Designer também são incluídos no documento PDF 3D exportado. Os dados incluem o arquivo de origem do projeto, seu autor, a versão do Altium Designer, as datas de criação e modificação etc. As informações podem ser visualizadas no Adobe Reader na aba Description da caixa de diálogo Document Properties — File » Properties.

Exportação de PDF 3D via OutJob

Para incluir uma exportação de arquivo PDF 3D em um OutJob do projeto, clique em Add New Documentation Output na entrada Documentation Outputs, selecione PDF3D e, em seguida, selecione a origem desejada do documento — um documento PCB específico para exportar (ou [PCB Document] para manter o OutJob reutilizável de forma genérica).

Adição de um gerador de saída PDF3D a um arquivo de configuração de tarefa de saída.Adição de um gerador de saída PDF3D a um arquivo de configuração de tarefa de saída.

As configurações de geração de PDF 3D podem ser predefinidas selecionando a entrada do gerador de saída, clicando com o botão direito do mouse e escolhendo Configure no menu de contexto. Isso abre a caixa de diálogo de configuração Export 3D (conforme descrito anteriormente).

Quando a tarefa de saída for executada ou iniciada manualmente, o arquivo PDF 3D será exportado conforme definido na seção Output Containers do OutJob. O destino será o Workspace e o caminho configurados, ou o destino de publicação local/remoto definido na página Gerenciamento de dados – Destinos de publicação da caixa de diálogo Preferences.

Geração de um arquivo PDF 3D em um contêiner de saída PDF definido, a partir de um OutJob configurado.
Geração de um arquivo PDF 3D em um contêiner de saída PDF definido, a partir de um OutJob configurado.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents