Sua visão da PCB

Altium Training

Altium Essentials: PCB Introduction

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Num relance

Este artigo apresenta como o Altium Designer permite trabalhar com sua PCB nos modos de visualização Planejamento da Placa, 2D e 3D real, ajudando a aproximar a edição tradicional baseada em camadas da realidade física da placa finalizada. Ele destaca os benefícios práticos dos recursos 3D, incluindo a verificação de folgas, a visualização do acesso aos componentes, a consideração de aspectos de fabricação e uma comunicação mais realista com as partes interessadas. Também explica como o painel Configuração de Visualização controla o que você vê na tela por meio da visibilidade das camadas, das cores e das opções de exibição. Você também terá uma visão clara de como gerenciar a visibilidade das camadas e usar Conjuntos de Camadas para agilizar tarefas comuns de visualização. Continue lendo para aprender a adaptar a visualização da PCB às suas necessidades e aprimorar a maneira como você inspeciona e apresenta seu projeto.

- Entenda as diferenças entre os modos Planejamento da Placa, Layout 2D e Layout 3D e quando usar cada um deles.
- Saiba como o painel Configuração de Visualização ajuda a controlar camadas, cores, visibilidade de objetos e outras configurações de exibição.
- Veja como as ferramentas de visibilidade de camadas e os Conjuntos de Camadas podem tornar a navegação em projetos complexos de PCB mais rápida e fácil.
Aprofunde-se com a IA:

Historicamente, as PCBs têm sido projetadas em um espaço de projeto bidimensional que usa cores para representar as diversas camadas da PCB. No entanto, a PCB física é um objeto tridimensional, o que exige que o projetista de PCB transforme mentalmente a representação 2D de múltiplas camadas na tela em uma representação 3D.

Os avanços significativos nas placas de vídeo 3D e na tecnologia de software associada permitiram à Altium desenvolver uma solução para esse problema: a edição de PCBs em um ambiente verdadeiramente tridimensional. Mais do que uma simples visualização, os recursos 3D do Altium Designer permitem:

  • Realizar a verificação de folgas em 3D — os componentes podem ser alinhados com precisão entre si e com o gabinete, conforme necessário.

  • Localizar visualmente conectores e outros componentes que precisam ser acessíveis para manutenção.

  • Definir melhor os processos de fabricação e a ordem de montagem, sabendo que todas as restrições mecânicas foram consideradas.

  • Gerar instruções de montagem manual, manuais do usuário e instruções mais detalhados usando imagens muito mais próximas do que uma pessoa verá na realidade.

  • Experimentar máscaras de solda de diferentes cores para criar um produto esteticamente mais agradável, que combine bem com seu gabinete e com o ambiente ao redor.

  • Obter mais facilmente o apoio das principais partes interessadas apresentando uma visão mais concreta do produto final.

Vistas 2D e 3D da mesma região de uma placa.
Vistas 2D e 3D da mesma região de uma placa.

ECAD-MCAD CoDesign

Para os pacotes MCAD compatíveis, também é possível transferir a placa e os componentes diretamente entre MCAD e ECAD usando o CoDesigner, a tecnologia de conectividade ECAD-MCAD da Altium. Por meio de um Workspace conectado, como um Workspace do Altium 365, o CoDesigner pode transferir o formato da placa e os componentes posicionados em ambas as direções entre seu software MCAD e o Altium Designer.

Saiba mais sobre Projeto ECAD-MCAD direto com o Altium CoDesigner

Modos de exibição

O Altium Designer permite exibir e editar a placa em 2D ou em 3D; essas opções são chamadas de display modes. Selecione o modo desejado no menu View ou pressione o atalho 1, 2 ou 3 para alternar diretamente para esse modo.

Há três modos de exibição, cada um com funções distintas.

  • Board Planning Mode (tecla de atalho 1) — use para definir o formato da placa e também para posicionar e configurar linhas de divisão e linhas de dobra em um projeto rígido-flexível. As linhas de divisão são usadas para dividir a placa em regiões, e cada região pode receber um empilhamento de camadas diferente. Para saber mais sobre regiões da placa e linhas de divisão e de dobra, consulte Definição do empilhamento de camadas.

  • 2D Layout Mode (tecla de atalho 2) — a visualização 2D tradicional da PCB, com múltiplas camadas. O Altium Designer incorpora um conjunto de recursos para ajudar a gerenciar a visualização da placa, chamado Sistema Board Insight.

  • 3D Layout Mode (tecla de atalho 3) — o projeto verdadeiramente em 3D. Combine o modo de exibição 3D com um mouse 3D para visualizar e manipular a placa 3D carregada como se você a estivesse segurando na mão. Para saber mais sobre como controlar a visualização da PCB em 3D, consulte a página Controle da visualização 3D.

    O 3D Layout Mode requer uma placa de vídeo compatível com DirectX 9 ou posterior, com Shader Model 3 ou posterior.

A mesma placa é mostrada no modo de planejamento da placa, no modo de layout 2D e no modo de layout 3D. A mesma placa é mostrada no modo de planejamento da placa, no modo de layout 2D e no modo de layout 3D.

O painel de configuração da visualização

O que é exibido atualmente no espaço de projeto do editor de PCB e como é exibido podem ser configurados no painel View Configuration. Isso inclui a visibilidade e a cor das camadas, a visibilidade e a transparência dos objetos, os níveis de mascaramento e atenuação, o modo de camada única atual e vários recursos adicionais de exibição do espaço de projeto, como a exibição de nomes de redes em pads, vias e trilhas.

Além das formas padrão de acessar um painel (pelo botão Panels no canto inferior direito do espaço de projeto ou pelo menu View » Panels), o painel View Configuration também pode ser acessado usando as teclas de atalho L ou Ctrl+D (para abrir o painel com a aba Layers & Colors ou View Options exibida, respectivamente) ou clicando na amostra de cor do controle de conjuntos de camadas no canto inferior esquerdo do espaço de projeto ().

O conteúdo do painel é dividido em duas abas. Clique em uma aba na parte superior do painel para exibir as opções disponíveis nela:

  • Layers and Colors aba — inclui opções para controlar a visibilidade das camadas disponíveis, adicionar, renomear ou excluir camadas mecânicas e configurar a cor e a visibilidade de recursos especiais de exibição do sistema, como furos de pads, o marcador de origem e erros de DRC.

    As camadas de sinal e de plano são adicionadas, nomeadas e removidas no Gerenciador de empilhamento de camadas.
  • View Options aba — inclui opções para selecionar, salvar ou carregar a configuração de cores/visibilidade das camadas, configurar a visibilidade dos tipos de objetos, controlar os níveis de mascaramento e atenuação e configurar outras opções relacionadas à exibição.

As opções disponíveis dependerão do Modo de layout atual (2D ou 3D).

No modo de layout 3D, a aba Section View também está disponível no painel View Configuration. Use essa aba para configurar a vista em corte da sua PCB — saiba mais.

Configuração da visibilidade das camadas

Cada camada pode ser exibida ou ocultada na região Layers da aba Layers & Colors do painel View Configuration. Clique no ícone de visibilidade () para ativar ou desativar a visibilidade.

Gerencie a visibilidade das camadas usando os ícones de visibilidade
Gerencie a visibilidade das camadas usando os ícones de visibilidade

Quando aplicável, cada grupo também inclui um ícone de visibilidade. Por exemplo, na imagem acima:

  • O ícone de visibilidade à esquerda do texto Component Layer Pairs (C) ativa ou desativa a visibilidade das camadas de componentes all.
  • O ícone de visibilidade à esquerda da string Top alterna a visibilidade das camadas de componentes all top side. As camadas do lado Bottom também podem ser exibidas/ocultadas da mesma forma.

Conjuntos de camadas

Um conjunto de camadas é um conjunto nomeado de camadas visíveis. Use a lista suspensa Layers Sets na região Layers da aba Layers & Colors do painel View Configuration para selecionar um conjunto de camadas existente; a exibição será atualizada para mostrar apenas as camadas habilitadas para esse conjunto.

Vários conjuntos de camadas são fornecidos por padrão:

  • All Layers – selecione para mostrar todas as camadas.

  • Signal Layers – selecione para mostrar apenas as camadas definidas como sendo do tipo Signal no Gerenciador de Empilhamento de Camadas, além das camadas Die e Wire Bonding, se existirem.

  • Plane Layers – selecione para mostrar apenas as camadas definidas como sendo do tipo Plane no Gerenciador de Empilhamento de Camadas.

  • NonSignal Layers – selecione para mostrar apenas as camadas Overlay, Paste, Solder e Other Layers (Drill Drawing, Drill Guide, Keep-Out Layer e Multi-Layer).

  • Mechanical Layers – selecione para mostrar apenas as camadas mecânicas e os pares de camadas de componentes.

É possível criar qualquer quantidade de conjuntos de camadas definidos pelo usuário, e o conjunto de camadas atualmente selecionado também pode ser editado.

  • Para criar um novo conjunto de camadas definido pelo usuário, configure a visibilidade das camadas na região Layers conforme necessário e clique no botão . O conjunto aparecerá como My Layers na lista suspensa. Cada conjunto de camadas adicionado posteriormente será numerado.

  • Para alterar a configuração das camadas habilitadas em um conjunto de camadas existente definido pelo usuário, selecione-o na lista suspensa Layers Sets, configure a visibilidade das camadas conforme necessário e clique no botão  para salvar as alterações no conjunto de camadas.

  • Para renomear um conjunto de camadas existente definido pelo usuário, selecione-o na lista suspensa Layers Sets e insira o nome desejado nos campos Layer Sets. Observe que renomear um conjunto de camadas não exige uma ação de salvamento; o novo nome será salvo automaticamente.

  • Para excluir um conjunto de camadas existente definido pelo usuário, selecione-o na lista suspensa Layers Sets e clique no botão .

  • Para importar o conjunto de camadas desejado de um arquivo de conjunto de camadas de PCB (*.layerset) ou exportá-lo como um arquivo de conjunto de camadas de PCB, use os botões Import e Export, respectivamente.

Use as seguintes técnicas para alternar os conjuntos de camadas visíveis:

  • Layer Set lista suspensa no painel View Configuration
  • Design » Manage Layer Sets submenu
  • Layer Set controle — acessado ao clicar na parte LS do botão à esquerda das abas de camadas na parte inferior do espaço de projeto ().

Cores do sistema

A região System Colors pode ser usada para configurar as cores usadas na PCB para os itens listados. As cores e a visibilidade são configuradas usando as técnicas habituais.

Abas de camadas

As abas associadas a cada camada atualmente definida como visível no painel View Configuration estão localizadas ao longo da borda inferior do espaço de projeto.

Elas permitem alternar a camada ativa (a camada na qual você posicionará objetos) e fornecem uma indicação visual de quais camadas estão sendo exibidas e de qual é a camada ativa (a aba destacada). Se houver mais abas de camadas do que é possível exibir de uma vez, use as setas  para percorrer as abas.

As cores das camadas serão exibidas à esquerda das abas de camadas, e um clique duplo na cor da camada abrirá a caixa de diálogo Choose Color.

Clique duas vezes no nome da camada para abrir a caixa de diálogo Edit Layer, na qual você pode editar o nome da camada (e o nome da rede para uma camada de plano interno).

A caixa de diálogo Edit Layer 
A caixa de diálogo Edit Layer

Modo de camada única

Modo de exibição 2D de camada única

Os recursos do modo de camada única estão integrados ao Board Insight e são configurados na página Editor de PCB - Exibição do Board Insight de Preferences caixa de diálogo. O modo de camada única exibe o conteúdo da camada atual, ocultando ou atenuando o conteúdo de todas as outras camadas. Além de ocultar todos os objetos de todas as outras camadas para exibir apenas o conteúdo da camada atual, o modo de camada única oferece modos de exibição em escala de cinza e monocromático. Converter as cores de todas as outras camadas para escala de cinza ou monocromático permite preservar as informações sobre a relação espacial entre os objetos no projeto, sem desviar sua atenção da camada de interesse. Para alternar entre a exibição completa e cada um dos modos de camada única habilitados, pressione o atalho Shift+S. A cada vez que você pressiona Shift+S, o software passa para o próximo modo habilitado, até retornar ao modo de exibição completa. Os modos de camada única são habilitados na página PCB Editor - Board Insight Display da caixa de diálogo Preferences. Desabilite (desmarque) os modos que não deseja incluir ao pressionar Shift+S. Essas configurações se aplicam a todos os projetos nesta instalação do Altium Designer.

Os modos de camada única disponíveis são:

  • Hide Other Layers - todas as outras camadas ficam ocultas; apenas o conteúdo da camada ativa (atual) é exibido.
  • Gray Scale Other Layers - todas as outras camadas são exibidas em um tom de cinza derivado da cor atual de cada camada; a camada ativa é exibida em sua cor padrão.
  • Monochrome Other Layers - todas as outras camadas são exibidas no mesmo tom de cinza; a camada ativa é exibida em sua cor padrão.

As imagens abaixo mostram a exibição normal com várias camadas e os três modos de exibição de camada única.

O modo de camada única selecionado é exibido na região General Settings da aba View Options do painel View Configuration. Clique no link do modo (ao lado do botão On ) para acessar a página PCB Editor - Board Insight Display da caixa de diálogo Preferences, onde você pode configurar os modos de camada única disponíveis conforme necessário.

Use o controle deslizante Masked Objects na região Mask and Dim Settings da aba View Options do painel View Configuration para controlar o brilho das outras camadas nos modos de camada única em escala de cinza ou monocromático.

Modo de exibição 3D de camada única

O modo de camada única também está disponível quando a placa é exibida em 3D Layout Mode. Use esse modo para tarefas como examinar a qualidade do roteamento em uma camada específica ou a qualidade de uma camada de plano de alimentação. No modo de camada única, use o atalho Ctrl+Shift+Wheel Roll para percorrer as camadas.

Exibir uma camada permanentemente no modo de camada única

Para incluir uma camada na exibição do modo de camada única, execute um Ctrl+Click no ícone de olho associado à camada desejada na aba Layers & Colors do painel View Configuration para adicionar essa camada à exibição do modo de camada única; um quadrado aparecerá atrás do ícone de olho () para indicar que a camada será exibida permanentemente no modo de camada única.

Visualizar a placa pelo lado inferior

Para visualizar a placa pelo lado inferior (essencialmente, virar a placa), habilite a opção View From Bottom Side na região Layers da aba Layers & Colors do painel View Configuration, selecione o comando View » Flip Board nos menus principais ou use o atalho de teclado Ctrl+F.

Todas as ações e comandos de edição são compatíveis com placas/componentes virados. O espaço de coordenadas permanece logicamente o mesmo, ou seja, a origem do espaço de projeto passa do canto inferior esquerdo para o canto inferior direito. A posição atual na grade aumenta na direção X (horizontal) à medida que você move o mouse da direita para a esquerda, em vez do movimento normal da esquerda para a direita. Qualquer saída gerada enquanto a visualização estiver invertida manterá as informações corretas de coordenadas da vista superior.

Quando a placa/componente é virado, a ordem de desenho das camadas também é alterada por um processo lógico de troca de pares, o que significa que Top Overlay trocará de posição na ordem atual de desenho das camadas com Bottom Overlay, Top Layer com Bottom Layer, Mid-Layer 1 com Mid-Layer 30, Internal Plane 1 com Internal Plane 16, e assim por diante. A ordem de desenho das camadas mecânicas não é alterada.

Controlar a visibilidade dos objetos

Além de controlar a exibição dos objetos no espaço de projeto ativando e desativando camadas, outra abordagem é controlar a visibilidade e a transparência dos objetos com base em seu tipo. No modo de layout 2D, use as opções disponíveis na região Object Visibility da aba View Options do painel View Configuration para configurar a visibilidade e a transparência dos objetos por tipo.

A seção Object Visibility da aba View Options do painel
A seção Object Visibility da aba View Options do painel

  •  – controle a visibilidade de tipos específicos de objetos clicando no ícone de visibilidade correspondente. Clique no ícone de visibilidade All Objects para alternar a visibilidade de todos os objetos e, em seguida, habilite a visibilidade de tipos específicos de objetos.

  • Name – lista todos os objetos cuja aparência pode ser ajustada.

  • Draft – habilite para exibir apenas o contorno dos objetos desse tipo.

  • Transparency – ajuste a transparência desse tipo de objeto usando o controle deslizante ou clique no valor e insira manualmente a porcentagem desejada entre 0 e 100 (0% é totalmente visível (sólido); 100% é totalmente transparente (invisível)). Definir um objeto como transparente permite visualizar quando um objeto cobre outro, por exemplo, onde a extremidade de um segmento de trilha encontra um pad.

  • Advanced – clique para abrir a caixa de diálogo Object Visibility, na qual você pode definir um nível de transparência comum para um determinado objeto em diferentes camadas e definir transparências diferentes para objetos distintos em uma camada específica.

Para saber mais sobre como controlar a transparência de objetos e camadas, consulte a página Transparência de objetos e camadas.

Restaure facilmente suas configurações de visibilidade preferidas criando uma configuração personalizada na região General Settings deste painel.

Configurações de mascaramento e atenuação

Para ajudar a gerenciar a exibição da grande quantidade de objetos que podem existir mesmo em um projeto de PCB simples, o editor de PCB permite esmaecer os objetos que não são de interesse. Por exemplo, se você clicar em uma rede no modo Nets do painel PCB e a lista suspensa do painel estiver definida como Dim ou Mask, todos os objetos que não pertencem a essa rede serão esmaecidos. Isso permite concentrar sua atenção com mais facilidade em um elemento específico do projeto, como uma rede ou uma classe de redes, uma classe de componentes, objetos aos quais se aplica uma determinada regra de projeto e assim por diante. Use os controles deslizantes na região Mask and Dim Settings da aba View Options do painel View Configuration para configurar os níveis de mascaramento e atenuação.

A região Mask and Dim Settings da guia View Options do painel View Configuration
A região Mask and Dim Settings da guia View Options do painel View Configuration

  • Dimmed Objects – os objetos atualmente esmaecidos mantêm sua cor, mas aparecem atenuados. Use este controle deslizante para configurar o grau de atenuação dos objetos esmaecidos. Os objetos esmaecidos podem ser editados.

    Para aumentar ou diminuir o nível de esmaecimento, você também pode usar os comandos View » Increase Mask Level (atalho: ]) ou View » Decrease Mask Level (atalho: [) nos menus principais, respectivamente.
  • Highlighted Objects – quando o esmaecimento está ativado e você clica em um objeto em um painel, por exemplo, uma rede no modo Nets do painel PCB, essa rede também é realçada enquanto todas as outras redes são esmaecidas. Os objetos realçados têm sua cor clareada para se destacarem. Este controle deslizante é usado para controlar a quantidade de branco adicionada aos objetos realçados.
  • Masked Objects – os objetos atualmente mascarados são exibidos em cinza e não podem ser editados. Use este controle deslizante para configurar o grau de atenuação dos objetos mascarados.

Gerenciamento de configurações

Uma configuração é um conjunto predefinido de ajustes de cor e visibilidade das camadas. Selecione uma configuração existente na lista suspensa Configuration, na região General Settings da guia View Options do painel View Configuration, ou use os botões ao lado da lista suspensa para criar, salvar ou excluir uma configuração. As configurações personalizadas salvam os ajustes de exibição 2D e 3D atuais ou utilizados por último.

  • – clique para criar uma nova configuração personalizada, digite um novo nome e clique no botão .
  • – clique para salvar ao criar uma nova configuração personalizada ou após editar a configuração personalizada selecionada.
  • – clique para excluir a configuração personalizada selecionada.
  • As configurações personalizadas criadas e salvas são carregadas automaticamente e ficam disponíveis para seleção na lista suspensa do campo Configuration.
  • Use a opção Load View Configuration da lista suspensa do campo Configuration para carregar um arquivo de configuração armazenado em um local não padrão para a instalação atual do Altium Designer. Observe que as configurações definidas pelo usuário são salvas como uma configuração complexa (com a extensão de arquivo .config_complex), portanto, talvez seja necessário alterar a lista suspensa File Type na caixa de diálogo Open ao carregar uma configuração personalizada.

Opções adicionais

A região Additional Options da guia View Options do painel View Configuration oferece opções adicionais para controlar a visualização de elementos específicos.

A seção Additional Options da guia View Options do painel View Configuration
A seção Additional Options da guia View Options do painel View Configuration

  • Test Points – ative esta opção para exibir informações adicionais sobre pads e vias configurados como pontos de teste. Um pad ou uma via pode ser configurado como ponto de teste ativando as opções de ponto de teste Fabrication e/ou Assembly no modo correspondente do painel Properties. Os pontos de teste são indicados pela adição do texto <Layer> Fab Testpoint ou <Layer> Assy Testpoint ao pad ou à via.
  • Status Info – ative esta opção para exibir informações resumidas, como posição das coordenadas e camada, no Status Bar ao passar o cursor sobre um objeto no espaço de projeto.
  • Pad Nets – ative esta opção para exibir o nome da rede associada em um pad. Observe que os nomes das redes só ficarão visíveis se o nível de zoom for suficientemente alto.
  • Pad Numbers – ative esta opção para exibir os números dos pads. Observe que os números dos pads só ficarão visíveis se o nível de zoom for suficientemente alto.
  • Via Nets – ative esta opção para exibir o nome da rede correspondente em uma via. Observe que os nomes das redes só ficarão visíveis se o nível de zoom for suficientemente alto.
  • Via Span – ative esta opção para exibir a extensão que a via pode abranger. As propriedades das vias posicionadas (diâmetro, tamanho do furo etc.) são então definidas por regras de projeto ou manualmente. Observe que os nomes das redes só ficarão visíveis se o nível de zoom for suficientemente alto. Os números das camadas abrangidas pela via podem ser exibidos dentro de todos os tipos de via.
  • All Connections in Single Layer Mode – ative esta opção para sempre exibir todas as linhas de conexão no modo de camada única. Com esta opção desativada, todas as linhas de conexão que não começam nem terminam na camada atual também são ocultadas ao alternar para o modo de camada única, pois se presume que não sejam relevantes.
  • Net Color Override – cada rede pode receber uma cor. Para configurar a cor, clique duas vezes no nome da rede no modo Redes do painel PCB; a caixa de diálogo Editar rede será aberta. A cor é aplicada automaticamente às linhas de conexão dessa rede e também pode ser aplicada ao roteamento ao ativar esta opção. A cor é aplicada ao roteamento de acordo com os ajustes atuais na página Editor de PCB – Substituições de cor do Board Insight da caixa de diálogo Preferences, na qual você escolhe uma opção de padrão para definir como a cor é aplicada e um comportamento de zoom para definir quando ela é aplicada. Pressione o atalho F5 para ativar ou desativar a opção de substituição de cor da rede.
  • Use Layer Colors for Connection Drawing – ative esta opção para exibir as linhas de conexão usando as cores das camadas inicial e final entre as quais a linha de conexão passa. As linhas de conexão são exibidas na cor pura da camada junto ao objeto em que começam ou terminam, com uma transição entre essas cores ao longo da linha de conexão. Esse recurso é útil ao rotear uma placa multicamadas, pois indica a camada de destino à qual a conexão sendo roteada deve chegar. Observe que a transição de cores só é aplicada a conexões que passam de uma camada para outra. Se a conexão começa e termina na mesma camada, ela mantém a cor atribuída à rede.
  • Repeated Net Names on Tracks – ative para mostrar os nomes das redes repetidos nas trilhas.
  • Special Strings – quando esta opção está ativada, qualquer texto posicionado que tenha sido gerado pela conversão de textos especiais receberá uma sobreposição (rótulo) com o nome do texto especial não convertido. Aumente o zoom sobre um texto para ver o rótulo sobreposto.
AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents