Preparando relatórios

Num relance

O Altium Designer oferece relatórios para documentar componentes, acompanhar alterações no projeto e preparar dados de fabricação. Este artigo apresenta os tipos de relatório disponíveis, explica como configurar e exportar relatórios usando o Gerenciador de Relatórios e mostra onde gerar e salvar os arquivos de saída. Continue lendo para escolher os relatórios necessários e organizar os arquivos de saída do seu projeto.

- Explore os tipos de relatório, incluindo lista de materiais, comparação de BOMs, dados de fabricação de chicotes, referências cruzadas de componentes, comentários e histórico do projeto.
- Saiba como configurar os relatórios compatíveis, visualizá-los, imprimi-los e exportá-los em diversos formatos de arquivo.
- Entenda como adicionar relatórios a arquivos de tarefas de saída ou gerá-los diretamente, além de gerenciar as pastas de saída para evitar a substituição de relatórios existentes.
Aprofunde-se com a IA:

É possível preparar e gerar diversos relatórios relacionados ao projeto ou a um documento específico do projeto para o seu design, incluindo:

  • Lista de materiais – este documento de relatório fornece uma lista de consulta rápida de todos os componentes necessários para fabricar o produto – incluindo a placa nua, que é essencialmente o “componente” base sobre o qual todas as outras peças são montadas. A BOM serve como guia do que precisa ser adquirido para fabricar o produto conforme projetado. Ela também permite calcular o custo com base na quantidade necessária de placas montadas em uma determinada rodada de fabricação.

    Os dados apresentados na caixa de diálogo Report Manager – usada para configurar o relatório de lista de materiais – podem vir de uma de duas fontes. Se houver um documento ActiveBOM (*.BomDoc) associado ao projeto, ele será usado como fonte dos dados. Caso contrário, os dados serão extraídos dos documentos esquemáticos de origem do projeto.

  • Comparação de BOM – um relatório que fornece informações sobre quais componentes foram alterados (como adicionados, removidos ou substituídos) durante a liberação de um projeto do Workspace.

  • Manufacturing Data – uma única pasta de trabalho do Excel contendo dados para uso por fabricantes de chicotes elétricos. A pasta de trabalho gerada inclui quatro planilhas distintas:

    • Bill of Materials – útil para gerar orçamentos rapidamente.

    • Wiring List – para uso com máquinas de processamento de fios.

    • Labels – um resumo das etiquetas físicas a serem impressas para os feixes de fios do chicote, para uso com impressoras Zebra ou outras impressoras.

    • Coverings – um resumo dos revestimentos a serem aplicados sobre os feixes de fios do chicote.

     

    Recomenda-se usar o documento ActiveBOM do projeto de chicote elétrico como fonte da saída de dados de fabricação.

    Para obter mais informações sobre projetos de chicotes elétricos, consulte a página Projeto de chicotes elétricos.

  • Relatório de referência cruzada de componentes – cria uma lista de componentes com base na folha esquemática em que estão localizados no projeto.

    Os relatórios de lista de materiais e de referência cruzada de componentes são altamente configuráveis por meio de um mecanismo dedicado e avançado de geração de relatórios, cuja interface é a caixa de diálogo Report Manager. Depois que o conteúdo do relatório necessário for definido e organizado conforme desejado, o relatório poderá ser gerado – impresso ou exportado para um dos vários formatos de arquivo – CSV (delimitado por vírgulas) (*.csv), Planilha do Microsoft Excel (*.xls;*.xlsx;*.xlt;*.xltx), Portable Document Format (*.pdf), Texto delimitado por tabulações (*.txt), Página da Web (*.htm;*.html), Planilha XML (*.xml). Um arquivo exportado pode ser salvo em qualquer local especificado. Além disso, ele pode ser aberto no aplicativo correspondente e/ou adicionado ao projeto após sua criação. Use o comando Report , nos menus da caixa de diálogo Report Manager, para acessar a caixa de diálogo Report Preview, com o relatório já carregado. Use os diversos controles da janela para ajustar a visualização do relatório. Clique no botão Print para abrir a caixa de diálogo Print , na qual é possível determinar o que será impresso e para qual dispositivo de impressão o trabalho será enviado. A visualização do relatório também pode ser exportada para diversos formatos de arquivo.

  • Exportar comentários – cria um arquivo PDF com os comentários exportados dos documentos do projeto.

  • Histórico do projeto – cria um arquivo PDF com o histórico exportado do projeto. Configure a saída usando a caixa de diálogo Project History Report Configuration, na qual é possível definir o Period para o qual o relatório deve ser exportado: todo o histórico do projeto ou um intervalo entre liberações específicas do projeto (ou a mais recente).

  • Relatório da hierarquia do projeto – cria uma lista dos documentos de origem usados no projeto. Esta saída não possui opções de configuração; o relatório ASCII é gravado na pasta de saída especificada.

  • Relatório de redes com um único pino – cria um relatório que lista todas as redes que possuem apenas uma conexão. Esta saída não possui opções de configuração; o relatório ASCII é gravado na pasta de saída especificada. Um relatório que lista todos os documentos esquemáticos de origem do projeto, de acordo com sua hierarquia no projeto. O arquivo é gerado diretamente e está no formato <ActiveDocumentName>.REP.

As saídas de relatório podem ser adicionadas ao arquivo Output Job ativo pelo menu do controle [Add New Report Output] na região Report Outputs do arquivo ou pelos submenus Edit » Add Report Outputs dos menus principais.

Embora os arquivos OutputJob facilitem a preparação simplificada das saídas dos seus projetos e sua posterior geração usando o processo de liberação de projetos de alta integridade, as saídas de relatório do projeto ativo também podem ser geradas diretamente usando o comando do menu principal Reports do editor de esquemáticos ou do submenu Reports » Project Reports do editor de PCB.
  • Como a caixa de diálogo Report Manager é altamente configurável, ela também pode ser usada para gerar relatórios em qualquer formato necessário, como um arquivo de pick and place cujos dados precisem ser estruturados de uma maneira específica para atender a uma determinada máquina de montagem.
  • Todos os arquivos de saída serão gravados na pasta de saída especificada no campo Output Path, na aba Options da caixa de diálogo Options for Project. Por padrão, o caminho de saída é definido como uma subpasta da pasta que contém o arquivo do projeto e recebe o nome Project Outputs for <ProjectName>. O caminho de saída pode ser alterado conforme necessário. No painel Projects, os arquivos gerados serão apresentados nas subpastas Generated\Text Documents (.csv, .txt, .rep) ou Generated\Documents (.xls, .pdf, .htm, .xml). Lembre-se de que, se um formato de relatório diferente for gerado a partir do mesmo documento ativo, o arquivo de relatório gerado anteriormente será sobrescrito (se tiver o mesmo nome de arquivo).
  • Se a opção Use separate folder for each output type estiver habilitada (também na aba Options ), a saída será gravada em uma subpasta adicional, chamada Reports (por exemplo, Project Outputs for <ProjectName>\Reports). No painel Projects , a saída aparecerá nas subpastas Generated (Reports)\Text Documents (.csv, .txt, .rep) ou Generated (Reports)\Documents (.xls, .pdf, .htm, .xml). Isso permite gerar vários relatórios a partir do mesmo documento ativo, sem que nenhum arquivo seja sobrescrito.
AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.