Criando e Mantendo Seus Componentes e Bibliotecas
Um projeto eletrônico é um conjunto de componentes conectados. A parte gratificante do desenvolvimento de produtos é encontrar maneiras criativas de resolver esses desafios de engenharia e conectar esses componentes para criar seu projeto exclusivo.
No entanto, uma grande parte do trabalho — e, para muitos projetistas, a parte mais tediosa — é criar os componentes. Embora isso possa não ser empolgante, os componentes se tornam um recurso valioso para sua empresa, e é essencial que representem com precisão o componente real.
O componente que você compra e solda na placa ou utiliza em um chicote elétrico é o componente real, mas ele precisa ser modelado em cada um dos domínios de projeto eletrônico nos quais você deseja utilizá-lo.
Dependendo dos tipos de implementação de projeto que você pretende realizar, seu componente pode incluir um símbolo para o esquemático, um modelo de simulação para o simulador de circuitos, um modelo IBIS para análise de integridade de sinal, um padrão ou footprint para o layout da PCB, e um modelo 3D para visualização, verificação de folgas em 3D e exportação para o ambiente de CAD mecânico.
Gerenciamento de componentes
O gerenciamento eficaz dos dados dos componentes é essencial para o projeto eletrônico, e o gerenciamento dos componentes utilizados em um projeto sempre foi um elemento fundamental do software de projeto da Altium. À medida que o software evoluiu ao longo dos anos, as metodologias de gerenciamento de componentes percorreram um longo caminho: desde simples bibliotecas individuais de modelos de esquemático e PCB, passando por bibliotecas de banco de dados, até os componentes do Workspace, que permitem representar os componentes de projeto em um contexto mais amplo de desenvolvimento de produtos, juntamente com recursos avançados e fáceis de usar para uma colaboração incomparável durante todo o processo de projeto.
| Biblioteca do Workspace | Componentes armazenados em um Workspace conectado, que fornece uma fonte única de dados de componentes atualizados e padronizados para toda a sua equipe de projeto. Os recursos de pesquisa paramétrica e por facetas permitem encontrar e inserir as peças necessárias com eficiência e rapidez. Esses componentes estão estreitamente vinculados à peça física fabricada e aos dados da cadeia de suprimentos acessíveis durante o projeto, oferecendo uma melhoria significativa em termos de custo e tempo de aquisição ao fabricar o produto montado. |
|
| Biblioteca de banco de dados | Quer vincular estreitamente os componentes do projeto ao banco de dados da sua empresa? Então explore as bibliotecas de banco de dados. Cada registro é um componente que referencia os modelos necessários e os dados paramétricos do componente. Os vínculos com os modelos e os parâmetros são adicionados ao símbolo durante a inserção, transformando-o em um componente do Altium Designer. | |
| Biblioteca de banco de dados SVN | Uma biblioteca de banco de dados SVN é uma extensão do modelo de biblioteca de banco de dados, com a diferença de que o símbolo de origem e os modelos são armazenados sob controle de versão. As bibliotecas de origem são criadas, ampliadas e mantidas em um repositório baseado em Subversion. O vínculo com o repositório e com o banco de dados externo é definido em um arquivo de biblioteca de banco de dados SVN (*.SVNDbLib). |
|
| Vínculo com banco de dados | Nesse método, o arquivo de vínculo com banco de dados (*.DbLink) define a ligação entre o componente do esquemático e um registro correspondente em um banco de dados. A correspondência do registro é estabelecida por meio de campos-chave, que podem ser um único campo-chave (por exemplo, um número de peça) ou vários campos-chave (definindo uma cláusula Where). |
|
| Biblioteca integrada | Prefere ter seus componentes previamente agrupados e verificados em um único arquivo? Então compile os modelos de origem de esquemático/PCB/simulação para gerar uma biblioteca integrada (*.IntLib). |
|
| Biblioteca de esquemáticos | Uma biblioteca de esquemáticos (*.SchLib) pode ser uma biblioteca de modelos que contém símbolos de componentes; ou, se vínculos com modelos e dados paramétricos forem adicionados a cada símbolo, ela se torna uma biblioteca de componentes. |
|
| Biblioteca de PCB | Uma biblioteca para armazenar modelos de footprints de PCB (*.PcbLib). Se necessário, um modelo 3D pode ser adicionado a cada footprint. Os modelos 3D são criados a partir de objetos de corpo 3D ou de um modelo STEP importado para um objeto de corpo 3D. |
Biblioteca do Workspace
Os componentes são armazenados no seu Workspace — um local centralizado e seguro para todos os seus dados de projeto, acessível a toda a sua equipe de projeto. Os benefícios de utilizar componentes hospedados em um Workspace são muitos. Algumas das vantagens são:
-
Single source of component data – com um Workspace acessível a toda a equipe, os engenheiros podem obter componentes atualizados e padronizados em um único local seguro, acessar dados da cadeia de suprimentos em tempo real e utilizar a pesquisa paramétrica e por facetas para encontrar exatamente os componentes de que precisam.
-
Design-time choice of physical components – para qualquer componente, você pode escolher quais peças de fabricantes podem ser utilizadas para implementá-lo na montagem da placa.
-
Real-time supply-chain information – fornecidos a partir do banco de dados agregado de peças do Altium Parts Provider (que, por sua vez, se conecta aos fornecedores habilitados e reúne suas peças) para informar ao projetista os preços e a disponibilidade atuais das peças escolhidas em todos os fornecedores que as vendem (conforme definido no catálogo local de peças do Workspace). Essas informações podem ser adicionadas a um componente a qualquer momento, inclusive depois de ele ser salvo no Workspace — sem editá-lo diretamente e, portanto, sem afetar os projetos nos quais já é utilizado — e depois utilizadas como parte de uma lista de materiais.
-
Concurrent editing of the library – como a biblioteca do Workspace é essencialmente um conjunto de itens de componente hospedados nesse Workspace, vários usuários podem editar ou criar novos componentes para a biblioteca do Workspace de forma independente, sem precisar esperar que outros usuários concluam seu trabalho.
-
Component Models Reuse – um componente pode ser considerado um “recipiente” no qual são armazenadas todas as informações paramétricas e todos os modelos de domínio, incluindo o símbolo do esquemático, footprints de PCB, modelos de fiação de chicotes e de simulação. Um componente não contém os modelos de domínio em si, mas sim vínculos com os itens de modelo correspondentes, que também estão em um Workspace, de modo que um único modelo de domínio pode ser utilizado por vários componentes. Se um modelo for alterado, será sugerido que você atualize todos os componentes que o utilizam, garantindo que nenhum componente utilize um modelo desatualizado.
-
Direct Component Editing – se um componente precisar ser editado, você poderá abri-lo para edição diretamente no seu Workspace. Uma instância temporária do Editor de Componentes permite editar todos os aspectos desse componente, inclusive modificar os modelos de domínio referenciados por ele, sem precisar lidar com documentos baseados em arquivos.
-
Use of Component Templates – aplique modelos baseados em parâmetros e na taxonomia dos componentes para que cada novo tipo de componente tenha automaticamente o conjunto correto de parâmetros compatíveis com a BOM, além de automatizar os esquemas corretos de nomenclatura, revisão e ciclo de vida.
-
Component Lifecycle Validation – se um componente estiver no estado “fim de vida”, “obsoleto” ou “abandonado”, você receberá um aviso antes de tentar fabricar placas que o utilizem.
-
Where-used Component Traceability – os componentes podem ser rastreados em todas as suas utilizações: se uma peça se tornar obsoleta, você poderá verificar em quais projetos ela foi utilizada para saber quais precisam ser atualizados. Se um símbolo ou footprint tiver um erro, você poderá visualizar todos os componentes que utilizam esse símbolo e footprint para poder corrigi-los.
-
Requests of new components – um engenheiro pode enviar solicitações de componentes novos (ou ausentes) aos responsáveis pelas bibliotecas e receber uma notificação quando o componente estiver disponível para uso em projetos pelo solicitante e por outros engenheiros da empresa.
Criar um novo componente da biblioteca do Workspace
O componente físico montado na placa ou usado na produção do chicote elétrico é representado como um símbolo esquemático durante a captura do esquemático e como um footprint de PCB no projeto da placa (opcionalmente, com um modelo 3D para visualização, verificação de folgas em 3D e exportação para o ambiente de CAD mecânico). Um componente de projeto também pode incluir um modelo de simulação para o simulador de circuitos e um modelo IBIS para análise de integridade de sinal. Para fornecer uma representação dos componentes de projeto em um contexto mais amplo de desenvolvimento de produtos, uma ou mais opções de peças podem ser adicionadas a ele.
Os componentes do seu projeto podem ser criados e inseridos na biblioteca do Workspace da sua empresa. Eles são inseridos por meio do painel Components, que usa o mecanismo avançado de busca de componentes do Altium Designer.
Um novo componente da biblioteca do Workspace é criado usando o Editor de Componentes, no qual você pode definir manualmente todos os dados do componente (modelos de domínio, parâmetros, opções de peças etc.) ou usar dados obtidos do painel Manufacturer Part Search.
Para criar um novo componente da biblioteca do Workspace:
-
Selecione um comando de criação de componente. Ele pode ser acessado das seguintes formas:
-
Selecione o comando File » New » Component nos menus principais.
-
Selecione File » New » Library nos menus principais e, na caixa de diálogo New Library que se abre, selecione Create Library Content » Component na região Workspace da caixa de diálogo.
-
No painel Componentes, clique com o botão direito na região da lista de componentes e selecione o comando Create no menu de contexto.
-
-
Na caixa de diálogo Create new component que se abre, escolha um tipo de componente. Se houver um template de componente vinculado ao tipo de componente selecionado, ele será usado para predefinir o componente com seus dados.

Acesse a caixa de diálogo Create new component para selecionar o tipo de componente a ser criado. -
Após clicar em OK, o Editor de Componentes no modo de Edição de Componente Único será aberto. Ele fornece uma interface simplificada para definir/editar um único componente.
-
Defina o componente adicionando seus detalhes no Editor de Componentes:
- Na região Component do Editor de Componentes, defina o Name e a Description do componente. Esses detalhes são essenciais para buscas posteriores, quando você precisar usar um componente no seu projeto.
-
Clique no controle Advanced Settings para definir ou alterar outros detalhes do componente, como o Id usado para o componente salvo no Workspace e a Folder no Workspace de destino em que o componente será salvo.
-
Na região Parameters do Editor de Componentes, defina outros detalhes do componente: parâmetros padrão, links de URL para páginas da web (por exemplo, o site de um fabricante) e links para folhas de dados (em qualquer formato).
-
Na região Part Choices do Editor de Componentes, especifique uma ou mais opções de peças para o componente – as peças de fabricantes 'permitidas' que podem ser usadas para implementar o componente na placa montada.
-
Na região Models do Editor de Componentes, adicione links para modelos de domínio salvos (ou criados durante o processo) para uso pelo componente. Um componente pode ter um símbolo esquemático e vários modelos de footprint de PCB e de simulação, ou pode ter um modelo de fiação de chicote. Um componente deve ter pelo menos um modelo.
-
Verifique o componente definido para garantir que ele atenda aos requisitos de acordo com as configurações da página Gerenciamento de Dados – Verificações de Regras de Componentes da caixa de diálogo Preferences. Salve seu componente localmente (File » Save) e, em seguida, escolha o comando Tools » Component Rule Check nos menus principais. Todas as violações encontradas são listadas no painel Messages.
-
Com o componente definido, selecione o comando File » Save to Server nos menus principais para salvar o componente no Workspace. A caixa de diálogo Edit Revision será exibida, na qual você poderá alterar o Nome e a Descrição e adicionar notas de versão conforme necessário. O editor será fechado após o salvamento.
Seu novo componente estará disponível para consulta e uso por meio do painel Componentes.
Notas
-
Para criar um novo componente semelhante a um componente existente no seu Workspace, você pode fazer uma cópia desse componente. No painel Components, localize o componente desejado, clique nele com o botão direito e selecione o comando Operations » Make a copy. O Editor de Componentes será aberto com o componente predefinido com os dados do componente escolhido.
-
Um componente pode ser definido usando dados fornecidos pela funcionalidade Pesquisa de Peças do Fabricante. Comece a digitar no campo Name e selecione uma peça correspondente do fabricante ou adicione uma opção de peça ao componente que está sendo definido. A caixa de diálogo Usar Dados do Componente será aberta, fornecendo controles para selecionar os dados que você deseja aplicar ao componente que está sendo criado/editado: nome, descrição, parâmetros, modelos e folhas de dados.

Os dados do componente podem ser obtidos na pesquisa de peças do fabricante. Um exemplo de acesso à funcionalidade, digitando o nome de um componente no campo Name e selecionando uma entrada correspondente na lista pop-up, é mostrado aqui. -
O editor de componentes também pode operar no modo de Edição de Componentes em Lote, que fornece a interface para definir/editar vários componentes. Com o editor de componentes no modo Single Component Editing, o acesso ao modo de edição em lote é feito escolhendo o comando Tools » Switch to Batch Editor nos menus principais do editor.
-
Para importar rapidamente suas bibliotecas existentes baseadas em arquivos e em bancos de dados (SchLib, PcbLib, IntLib, DbLib, SVNDbLib) para o Workspace, você pode usar o Importador de Bibliotecas. O Importador de Bibliotecas oferece uma solução de um clique que analisa automaticamente as bibliotecas selecionadas e as importa para o Workspace ao qual você está conectado.
-
Um novo componente também pode ser criado clicando com o botão direito do mouse na entrada do Workspace conectado no painel Projects e escolhendo o comando Create Component no menu.
-
Para editar um Componente do Workspace, clique com o botão direito do mouse na entrada de um componente no painel Componentes e escolha o comando Edit no menu de contexto. O Editor de Componentes será aberto no modo Single Component Editing, com a definição do componente aberta para edição. Faça as alterações necessárias e salve a definição do componente na próxima revisão do Componente do Workspace.
-
Da mesma forma, você pode selecionar vários componentes no painel Componentes e escolher o comando Edit no menu de contexto. Se os componentes selecionados fizerem referência ao mesmo modelo de componente, uma única instância do Editor de Componentes será aberta no modo de Edição de Componentes em Lote. Caso contrário, uma instância separada do Editor de Componentes será aberta para cada grupo de componentes que compartilham o mesmo modelo de componente.
-
Os componentes do Workspace abertos para edição são exibidos sob a entrada Workspace Components no painel Projects.
No menu de contexto acessado ao clicar com o botão direito do mouse na entrada Workspace Component, você pode abrir os componentes do grupo, fechar, salvar localmente, salvar no Workspace conectado ou descartar as alterações (fechar sem modificar)
. Ao usar o comando Close All, se vários componentes do grupo tiverem sido modificados, será exibida uma caixa de diálogo de confirmação de salvamento, com opções de decisão pertinentes ao trabalho com uma entidade do Workspace aberta para edição
-
Ao tentar abrir um componente do Workspace para edição como um usuário com permissões somente de visualização, o editor de componentes será aberto, permitindo acessar os detalhes do componente, mas sem a possibilidade de salvar alterações no Workspace. Nesse caso, a entrada desse componente do Workspace no painel Projects é exibida com o rótulo Local Edits Only
-
Ao salvar um componente editado na biblioteca do seu Workspace, você pode preservar o estado atual do ciclo de vida do componente. Esse controle é fornecido pela opção Preserve lifecycle state (not recommended), disponível na caixa de diálogo Edit Revision ao salvar novamente (mostrar imagem). Quando ela está habilitada, a nova revisão do componente será automaticamente definida com o estado do ciclo de vida da revisão anterior. Esse recurso está disponível para quem possui a permissão operacional Allow to skip lifecycle state change for new revisions atribuída (saiba mais sobre Definir Permissões de Operações Globais para um Workspace).
Bibliotecas de Banco de Dados
O Altium Designer permite inserir componentes diretamente de um banco de dados da empresa, criando e usando uma Database Library. A inserção é realizada pelo painel Components, que, após a instalação de uma biblioteca de banco de dados, funciona como um navegador do seu banco de dados.
Após a inserção, as informações dos parâmetros do projeto podem ser sincronizadas entre os componentes inseridos e seus respectivos registros vinculados no banco de dados. É possível realizar atualizações completas dos componentes, incluindo o símbolo gráfico, as referências a modelos e os parâmetros. As informações paramétricas do banco de dados também podem ser incluídas na Lista de Materiais (BOM) final, pronta para a aquisição de componentes.
Leia sobre Bibliotecas de Banco de Dados.
Bibliotecas Baseadas em Arquivos
Se você precisar manter seus componentes localmente, no seu sistema de arquivos, poderá organizá-los em bibliotecas baseadas em arquivos.
Uma biblioteca baseada em arquivos do Altium Designer é uma coleção arbitrária de modelos ou componentes. Você decide como os modelos ou componentes são organizados em bibliotecas. Você pode estruturar suas bibliotecas por fornecedores de dispositivos ou agrupar os componentes por função, por exemplo, com uma biblioteca para todos os microcontroladores usados pela sua empresa.
Os símbolos dos componentes esquemáticos são criados em bibliotecas de esquemáticos (*.SchLib). Os componentes dessas bibliotecas fazem referência a footprints e outros modelos definidos em bibliotecas de footprints separadas (*.PcbLib) e arquivos de modelos. Como projetista, você pode inserir componentes dessas bibliotecas de componentes individuais ou compilar as bibliotecas de símbolos, as bibliotecas de footprints e os arquivos de modelos em bibliotecas integradas (*.IntLib).
Leia sobre Bibliotecas de Componentes Baseadas em Arquivos.
Modelos
Da perspectiva de um projetista, um componente reúne, em uma única entidade, todas as informações necessárias para representá-lo em todos os domínios do projeto. Nesse sentido, ele pode ser considerado um contêiner.
Cada componente é uma coleção de modelos vinculados e dados paramétricos do componente. São os modelos que contêm as informações detalhadas necessárias para cada domínio do projeto.
Os seguintes tipos de modelos podem ser usados:
| Símbolo esquemático | O símbolo representa o componente na folha de esquemático. O símbolo é criado usando objetos de desenho padrão, e os pinos adicionam as propriedades elétricas. |
| Modelo SPICE | Simule o comportamento dos componentes conectados usando o simulador SPICE. Os modelos SPICE geralmente são obtidos dos fornecedores de dispositivos. |
| Modelo de integridade de sinal | As interconexões da PCB estão se tornando parte do circuito à medida que as velocidades de comutação dos dispositivos e circuitos aumentam. Os modelos IBIS descrevem o comportamento dos pinos, permitindo que o simulador de integridade de sinal do Altium Designer analise as trilhas. |
| Footprint de PCB | Cada componente precisa ter um local definido na PCB onde será montado e conectado — o footprint é o modelo que define esse espaço na PCB. Um footprint de PCB é criado a partir de um conjunto de objetos padrão, com os pads fornecendo a conectividade. |
| Modelo 3D | Os produtos eletrônicos atuais são compactos, têm componentes densamente agrupados, apresentam formatos incomuns e podem até ter uma PCB dobrada para caber no gabinete. Para projetar um produto assim, você precisa conseguir modelar a PCB em 3D — para visualizar a placa finalizada, verificar as folgas em 3D e transferir a placa com os componentes montados para o ambiente de CAD mecânico. Para isso, você precisará de um modelo 3D de cada componente. |
Leia sobre como criar e gerenciar Símbolos, Modelos de footprints, Modelos de simulação e Modelos 3D no seu Workspace.
O painel Components
O painel Components fornece acesso direto a todos os componentes disponíveis no Altium Designer, incluindo componentes do Workspace, de bancos de dados e de bibliotecas baseadas em arquivos.
O painel obtém componentes de um Workspace e de quaisquer arquivos de biblioteca abertos ou instalados. Ele oferece detalhes completos do componente selecionado (parâmetros, modelos, opções de peças, dados de fornecedores etc.), comparação de componentes e, para os componentes do Workspace, um recurso de pesquisa paramétrica baseado em filtros para especificar os parâmetros desejados do componente. Com base em filtros dinâmicos contextuais, o recurso de pesquisa do painel permite localizar rapidamente a peça exata de que você precisa no Workspace conectado da sua empresa.
Leia sobre o painel Components.
O painel Manufacturer Part Search
Você também pode pesquisar peças reais de fabricantes usando o painel Manufacturer Part Search, que utiliza a funcionalidade básica do mecanismo de pesquisa e a visualização empregadas no painel Components. Uma peça de fabricante selecionada pode ser usada como base para um novo componente no seu Workspace conectado, ou seus parâmetros e folhas de dados podem ser adicionados a um componente já posicionado.
O ícone
na entrada de uma peça indica que há modelos (símbolos esquemáticos, footprints de PCB, modelos de simulação) associados a esse componente. Ao criar um novo componente com base nessa peça de fabricante, os modelos dela também serão obtidos. Como alternativa, você pode baixar essa peça localmente ou posicioná-la diretamente no seu esquemático.
Leia sobre o painel Manufacturer Part Search.
Próximos passos
Criar um componente de fiação de chicote



).
).



