Criando Modelos e Bibliotecas de Pads e Vias
Num relance
- Aprenda a criar uma biblioteca do zero ou a partir de pads e vias de uma PCB existente.
- Entenda como adicionar, excluir e editar modelos de pads e vias.
- Explore as opções de configuração de dimensões dos furos, máscaras, pilhas de pads e vias e alívio térmico.
Juntamente com os objetos de trilha, pads e vias são elementos fundamentais de todos os projetos de placas de circuito. Para ampliar os recursos de reutilização e gerenciamento de pads e vias em projetos de PCB, o Altium Designer oferece suporte a bibliotecas de modelos de pads e vias.
O conceito de modelos de pads e vias que podem ser reunidos em uma biblioteca é semelhante ao das bibliotecas de footprints de PCB, embora seja um pouco mais básico. A biblioteca de modelos de pads e vias não armazena pads e vias propriamente ditos, mas sim definições pré-configuradas que são aplicadas a uma instância de pad ou via durante seu posicionamento. As bibliotecas de modelos de pads e vias salvas podem ser carregadas e usadas para posicionar instâncias de pads e vias predefinidos em qualquer projeto de PCB ou footprint de PCB.
As bibliotecas de modelos de pads e vias são outro tipo de documento de projeto que pode ser criado no Altium Designer e têm a extensão de arquivo *.PvLib. As bibliotecas de modelos de pads e vias podem ser incluídas como documentos do projeto e, nesse caso, esses modelos ficam sempre disponíveis para esse projeto por meio do painel PCB Pad Via Templates. As bibliotecas de modelos também podem ser instaladas no painel, ficando disponíveis para todos os projetos abertos. Saiba mais sobre como disponibilizar modelos na página Como trabalhar com modelos de pads e vias.
Os modelos de pads e vias são criados e editados abrindo um arquivo PvLib. Os modelos de pads e vias da PvLib são listados no painel Pad Via Library, e o modelo de pad ou via selecionado é exibido no Editor de modelos de pads/vias, conforme mostrado abaixo.
|
Tanto os modelos de pads quanto os de vias são editados abrindo o arquivo PvLib. As opções do editor mudam de acordo com o tipo de objeto que está sendo editado. O Editor de modelos de pads é mostrado aqui. Tanto os modelos de pads quanto os de vias são editados abrindo o arquivo PvLib. As opções do editor mudam de acordo com o tipo de objeto que está sendo editado. O Editor de modelos de vias é mostrado aqui. |
Como criar uma biblioteca de modelos de pads e vias
Uma nova biblioteca de modelos de pads/vias pode ser criada das seguintes maneiras:
-
Selecione o comando File » New » Library nos menus principais e selecione a opção Pad Via Library na região File da caixa de diálogo New Library que é aberta; em seguida, clique em Create. A nova biblioteca de modelos de pads e vias recebe o nome padrão
PvLib1.PvLib. Nesse estágio, o arquivo ainda não foi salvo no disco rígido; ele existe apenas na memória do computador. Como ainda não foi salvo, na primeira vez que você o salvar, a caixa de diálogo Save As será aberta, oferecendo a opção de salvá-lo no Default Location definido na página Sistema – Locais padrão da caixa de diálogo Preferences. -
Uma nova biblioteca de modelos de pads e vias também pode ser adicionada ao projeto atual clicando com o botão direito do mouse no projeto, no painel Projects, e selecionando Add New to Project » Pad Via Library no menu de contexto. O arquivo aparecerá na pasta
Libraries/Pad Via Library Documentsda estrutura do projeto. Quando o arquivo for salvo, o local padrão será a pasta do projeto. -
Uma biblioteca de modelos de pads e vias pode ser criada a partir dos pads e vias de uma PCB aberta no modo Modelos de pads e vias do painel PCB. Usando as técnicas padrão de seleção do Windows, selecione os modelos de pads/vias que serão salvos na biblioteca e clique no botão Save as Library. A nova PvLib será aberta, pronta para edição, mas ainda não terá sido salva no disco rígido. Salve o arquivo em um local adequado, com o nome desejado. Quando a biblioteca de modelos de pads e vias for aberta pela primeira vez no Editor de modelos, ela poderá mostrar apenas um modelo de pad no painel Pad Via Library (o modelo padrão). Se isso ocorrer, salve, feche e reabra o arquivo para atualizar a lista de modelos no painel Pad Via Library.

Uma biblioteca de modelos de pads e vias pode ser criada a partir dos pads/vias selecionados na PCB atual.
Painel de biblioteca de pads e vias
O painel Pad Via Library fornece acesso aos modelos contidos na biblioteca de pads e vias ativa. O painel Pad Via Library, disponível no editor de modelos de pads/vias, lista os modelos de pads e vias contidos na biblioteca de modelos de pads e vias atual. As unidades preferidas para esta sessão de edição são selecionadas no menu suspenso Display Units, na parte superior do painel.
Acesso ao painel
O painel é acessado a partir do Editor de modelos de pads/vias (com um documento *.PvLib aberto como documento ativo na área de projeto) das seguintes maneiras:
- Clique no botão Panels no canto inferior direito da área de projeto e selecione Pad Via Library.
- Clique em View » Panels » Pad Via Library nos menus principais.
Como criar um modelo de pad ou via
Para criar um novo modelo de pad ou via, clique com o botão direito do mouse dentro do painel e selecione Add Pad template ou Add Via template no menu de contexto. Use Delete para remover um modelo da biblioteca.

O painel fornece acesso aos modelos contidos na biblioteca de pads e vias atual. Clique com o botão direito do mouse para adicionar um novo modelo.
Editor de modelos de pads/vias
O Pad Template Editor é usado para definir as opções básicas de configuração de um modelo de pad ou via que pode ser aplicado a um pad ou via em um documento de PCB ou de footprint de PCB. Essas opções incluem as propriedades principais de uma configuração de pad/via, enquanto as propriedades específicas do documento (como posição, orientação, camada etc.) são definidas quando o pad ou a via é posicionado em um documento de projeto.

O Editor de modelos é usado para configurar o modelo de pad ou via atualmente selecionado no painel Pad Via Library.
A maioria das opções de configuração de pads/vias corresponde às configurações padrão e conhecidas de pads e vias do Altium Designer (tamanho, furo, máscara etc.). O Editor de modelos de pads compartilha o mesmo design de interface e muitas opções com o Editor de modelos de vias. Cada região do Editor de modelos é descrita abaixo, com as opções específicas de pads ou vias identificadas como tal.
Geral
-
Name – por padrão, usa um nome automático baseado nos atributos do pad/via, de acordo com o IPC-7251/7351 Padstack naming conventions (descrito aqui). Um nome manual pode ser definido, se necessário, e removido posteriormente clicando no botão
. Se um modelo com nome manual tiver sido usado em um projeto de placa e depois for desvinculado da biblioteca de modelos (de modo que suas propriedades se tornem editáveis), o nome manual será substituído pelo nome automático.
- Description – descrição opcional.
- Pad Type (somente pads) – Montagem em superfície ou furo passante.
Informações do furo
- Hole Size – indicado por h<Value> no nome, diâmetro do furo.
- Tolerance – indicado por Tol no nome, insira as tolerâncias + e - do furo, se necessário. Insira N/A se não for aplicável.
- Hole Type (somente pad) – Redondo, quadrado ou oblongo.
- Length (somente pad) – indicado por _<Value> acrescentado ao tamanho do furo no nome; comprimento do furo quadrado ou oblongo.
- Rotation (somente pad) – ângulo de rotação do furo quadrado ou oblongo.
- Plated (somente pad) – metalizado ou não metalizado (não metalizado é indicado por n no nome).
Máscara de pasta (somente pad)
- Manual Expansion – marque a caixa para definir um valor de expansão manual que substituirá o valor de uma regra de projeto quando o pad for inserido em um projeto de PCB. Esse valor é indicado por p<Value> no nome do modelo de pad.
- Expansion – valor para expandir (um valor positivo) ou contrair (um valor negativo) a abertura na máscara de pasta. Pode ser definido como um valor absoluto (mil/mm) ou como uma porcentagem da área do pad. Quando um valor absoluto é definido, a porcentagem é exibida à direita do campo, e vice-versa. Desmarque a caixa Use Paste à esquerda do campo para desativar o uso da máscara de pasta no modelo de pad.
Máscara de solda
- Manual Expansion – indicada por m<Value> no nome, em que m<Value> é o tamanho total da abertura na máscara de solda. O elemento de nomenclatura passa a ser m<Value>mx<Value> se os valores de expansão superior e inferior não estiverem vinculados.
- Top/Bottom – valor da expansão, medido a partir da borda do pad/via, a menos que a opção Solder mask from the hole edge esteja ativada.
-
– os valores superior e inferior estão vinculados (iguais); clique para definir valores diferentes para os lados superior e inferior.
- Tented – ative para fechar a abertura na máscara de solda (o tamanho da abertura é definido como zero).
- Solder mask from the hole edge – ative para usar a borda do furo como referência para o valor de expansão, em vez da borda do pad/via.
Tipos e características de vias (somente via)
- IPC 4761 Via Type – use a lista suspensa para selecionar um tipo de via de acordo com a norma IPC 4761, Design Guide for Protection of Printed Board Via Structures.
-
Grid – aparece quando um tipo de via diferente de
Noneé selecionado na lista suspensa IPC 4761 Via Type. Selecione Side da placa e insira um Material para as características disponíveis de acordo com o tipo de via selecionado.
Tamanho e formato
- Offset From Hole Center (X/Y) (somente pad) – indicado por o<Xvalue>_<Yvalue> no nome; valor do deslocamento do furo do pad em relação ao centro do pad.
-
Mode – tipo de pilha de pads/vias; as opções incluem
Simple,Top-Middle-BottomouFull Stack(para pads, esta opção só está disponível quando Pad Type é do tipo furo passante). Permite que pads/vias tenham propriedades de tamanho e formato diferentes nas camadas disponíveis para esse modo. O elemento de nomenclatura x<Xvalue_Yvalue> é adicionado quando um tamanho/formato diferente é definido para a camada inferior. O elemento de nomenclatura z<Xvalue_Yvalue> é adicionado quando um tamanho/formato diferente é definido para as camadas intermediárias. -
Attributes on Layer – atributos padrão de pads/vias.
-
Shape (somente pad) – indicado por c<SizeValue> (circular); s<SizeValue> (quadrado) ou r<xSizeValue_ySizeValue> (retangular), dependendo de as dimensões X/Y serem iguais ou diferentes; s<SizeValue>c<Value> (octogonal); s<Sizevalue>r<Radius%Value> ou r<xSizeValue_ySizeValue>r<Radius%Value> (retângulo arredondado).
-
X & Y Size (somente pad) – dimensão do pad no plano X e Y.
-
Corner Radius (somente pad) – valor absoluto do raio dos cantos do pad. O valor deve ser menor ou igual à metade do lado mais curto do pad. Insira um valor seguido do símbolo
%para definir o raio como uma porcentagem da metade do lado mais curto do pad, em que100%arredonda completamente o lado mais curto do pad. Esta opção só está disponível se Rounded Rectangle estiver selecionado para o Shape do pad. -
Diameter (somente via) – diâmetro da via (vias só podem ser circulares).
-
-
Thermal Relief – configurações de alívio térmico deste pad para um polígono ao redor pertencente à mesma rede; desmarque a caixa From Rule para editar e usar essas configurações locais.
- From Rule – as configurações locais não são aplicadas quando esta opção está ativada; desmarque-a para definir e usar configurações locais.
- Connect Style – estilo do alívio térmico.
- Air Gap – distância da borda do pad até o polígono ao redor.
- Conductors – número de condutores entre o pad e o polígono ao redor.
- Width – largura dos condutores entre o pad e o polígono ao redor.
- Angle – padrão angular dos condutores de alívio térmico.
- Layer – camadas nesta pilha de pads/vias; as camadas disponíveis dependem da configuração atual de Mode; clique com o botão direito para adicionar, remover ou redefinir as camadas quando Mode estiver definido como pilha completa.


