Создание документа BOM
Краткий обзор
- Вы научитесь создавать BomDoc, узнаете, что происходит при его добавлении в проект, и познакомитесь с важным ограничением: в проекте может быть только один документ BomDoc.
- Вы узнаете, как устроен список BOM Items, включая режимы просмотра, управление столбцами, инструменты редактирования, принципы группировки и параметры отображения.
- Вы разберётесь, как ActiveBOM обрабатывает сгруппированные компоненты и пользовательские позиции спецификации, чтобы учитывать как компоненты схемы, так и дополнительные позиции проекта.
Создание документа BOM
Рабочий документ спецификации ActiveBOM называется BomDoc. Добавьте новый BomDoc в проект через подменю File » New или щелкните правой кнопкой мыши по проекту на панели Projects. Если в проекте есть хотя бы один компонент, новый BomDoc можно создать, нажав элемент управления + Create рядом с записью ActiveBOM в структуре проекта на панели Projects. Обратите внимание: каждый проект печатной платы может содержать только один BomDoc.
При добавлении нового BomDoc в проект схема автоматически компилируется, а все существующие компоненты отображаются в BomDoc. Для компонентов библиотеки Workspace, содержащих варианты выбора деталей (Part Choices), в нижней части интерфейса отображается подробная информация о решениях, как описано ниже в разделе Общие сведения о решении.
По мере размещения дополнительных компонентов на схеме они автоматически добавляются в BomDoc. Дополнительные позиции BOM и параметры также можно добавлять вручную непосредственно в ActiveBOM с помощью кнопки Add new, расположенной над списком компонентов. Подробнее см. в разделе Пользовательские позиции и столбцы BOM.
Список позиций BOM
В верхней области BomDoc находится таблица со списком всех компонентов, обнаруженных в проекте печатной платы, а также дополнительных позиций BOM, добавленных непосредственно в BomDoc. Эта область называется списком позиций BOM.

Список компонентов, или позиций BOM, в режиме Base.
Для отображения позиций BOM доступны 3 режима просмотра. Выберите нужный режим с помощью кнопок над списком:
Flat view — отдельная строка для каждого компонента.
Base view — отдельная строка для каждого уникального компонента проекта; в столбце Designator перечислены позиционные обозначения всех компонентов этого типа. Для сгруппированных позиционных обозначений доступно несколько вариантов отображения. Выберите нужный режим Designator Grouping на панели Properties.
Consolidated view — используется, если проект содержит варианты исполнения, для отображения сводной BOM по всем вариантам.
Возможности редактирования списка позиций BOM
Список компонентов поддерживает ряд функций редактирования, аналогичных функциям электронных таблиц:
- На вкладке Column панели Properties можно показать или скрыть столбец, а также задать для него псевдоним. Псевдоним также можно задать в диалоговом окне Enter Column Properties. Чтобы открыть его, щелкните правой кнопкой мыши по имени столбца в области заголовков BomDoc и выберите в контекстном меню команду Rename Column. Обратите внимание: в формируемых выходных документах BOM псевдоним используется в качестве имени столбца.
-
Столбцы также можно добавлять и удалять с помощью диалогового окна Select Columns. Чтобы открыть его, щелкните правой кнопкой мыши по имени столбца в области заголовков BomDoc и выберите Select Columns.

Диалоговое окно Select ColumnsПараметры и элементы управления диалогового окна Select Columns
- Search — вводите символы в это поле для фильтрации списка столбцов: будут показаны только столбцы, имена которых содержат введенные символы.
-
Visibility column — определяет, отображается ли столбец ActiveBOM в документе ActiveBOM (
*.BomDoc). Нажмите значок глаза, чтобы показать или скрыть столбец. Видимые столбцы всегда располагаются вверху диалогового окна в том порядке, в котором они отображаются в BomDoc. -
Data Source column — отображает источник данных столбца. Поддерживаются следующие источники данных:
-
— позиции, добавленные непосредственно в BOM
-
— параметры компонентов схемы
-
— параметры компонентов Workspace
-
— параметры связанной базы данных (DbLink, DbLib)
-
— параметры документа схемы
-
— Altium Cloud Services
-
- Column Name — отображает имя источника данных, которое используется в качестве имени столбца в BomDoc.
- Up / Down — позволяет перемещать выбранный столбец вверх или вниз по списку. После нажатия OK этот столбец переместится влево или вправо в BomDoc. Обратите внимание: изменять порядок можно только для видимых столбцов.
-
— нажмите значок фильтра рядом с каждым заголовком, чтобы отфильтровать информацию в таблице по выбранному элементу списка.
- Перетаскивайте столбцы, чтобы изменить их порядок.
- Сортируйте данные по любому столбцу; удерживайте Shift, чтобы задать дополнительную сортировку по другим столбцам.
-
Нажмите значок фильтра, чтобы отфильтровать данные по значениям столбца.
- Выделяйте ячейки стандартными способами Windows.
- Копируйте содержимое ячеек из ActiveBOM и вставляйте значения из внешнего редактора электронных таблиц в пользовательские столбцы ActiveBOM.
- В режиме Base можно задать настраиваемые номера строк. В этом режиме нажмите кнопку Set line numbers , чтобы добавить номер каждой строке. Нажмите значок раскрывающегося списка справа от кнопки, чтобы открыть диалоговое окно Line # Options, в котором можно задать начальное значение и шаг нумерации. Подробнее см. в разделе Столбец номеров строк.
- Нажмите раскрывающийся список Add New , чтобы добавить строки или столбцы. Подробнее см. в разделе Пользовательские позиции и столбцы BOM.
- Нажмите кнопку Group by , чтобы сгруппировать таблицу по выбранному столбцу. Можно включить несколько столбцов группировки Group By (показать изображение) и изменить их порядок перетаскиванием. Эта функция влияет только на отображение таблицы: группировка не переносится в диалоговое окно Report Manager при выполнении команды Bill of Materials.
- Нажмите кнопку Reset Supply Chain , чтобы удалить заданное пользователем ранжирование решений и вручную назначенные приоритеты SPN для выбранных позиций BOM.
- Текущую конфигурацию таблицы позиций BOM можно сохранить как набор BOM. Подробнее см. в разделе Настройка и сохранение отображения таблицы позиций BOM.
-
Для прокрутки списка позиций BOM используйте стандартные сочетания клавиш Windows:
- Вертикальная прокрутка = MouseWheel Roll
- Горизонтальная прокрутка = Shift + MouseWheel Roll
Группы столбцов

Список компонентов ActiveBOM содержит отдельные группы столбцов, присутствующие в каждом режиме просмотра. На изображении выше показано представление Base.
Таблица позиций BOM разделена на следующие основные группы:
- Item Details (выделены оранжевым на изображении) — в этих столбцах отображаются данные компонентов, такие как позиционное обозначение, описание, ссылка на библиотеку и другие параметры компонентов.
- Solutions (выделены зеленым на изображении) — производитель и поставщик(и) с наивысшим рейтингом в цепочке поставок. Количество решений (компонентов производителей) и количество поставщиков для каждого решения настраиваются на панели Properties в ActiveBOM. Они обозначаются сплошной цветной полосой на плитке поставщика. Ранжирование выполняется автоматически, но его также можно задать вручную, как описано ниже в разделе Обзор решения.
- BOM Status (выделены голубым на изображении) — индикация текущего риска, связанного с каждым компонентом. Наведите указатель на значок, чтобы увидеть описание, или включите подробный столбец BOM Status на панели Properties для отображения описания.
Пользовательские позиции и столбцы BOM
Управление BOM в проекте печатной платы требует учета компонентов и позиций BOM помимо тех, которые размещены на схеме и печатной плате, например еще не детализированных деталей, крепежа, заготовки платы или монтажного клея. Во многих случаях в проекте печатной платы используются пользовательские позиции или параметры BOM. Для таких ситуаций ActiveBOM поддерживает добавление дополнительных позиций BOM и столбцов (параметров), которые затем можно включить в формируемую BOM:
- Custom row — простой способ добавить пользовательскую позицию BOM, которую необходимо учесть в проекте (незагруженная плата, клей и т. п.). Все поля пользовательской строки задаются пользователем. Пользовательские строки не управляются ActiveBOM: например, если задано количество 3, в представлении Flat не будут отображаться 3 отдельные позиции. Поиск в цепочке поставок для пользовательских строк также не поддерживается.
- Custom column — дополнительный столбец BOM, управляемый в ActiveBOM, который может содержать любой пользовательский текст.
- Custom Item — дополнительная позиция BOM, обычно предназначенная для тех элементов, которые понадобятся, но пока не определены полностью или еще отсутствуют в библиотеке. Это позволяет включить их стоимость в общую оценку стоимости платы.
-
Managed Component — дополнительная позиция BOM, управляемая вручную в документе BOM. Откроется диалоговое окно Component Search со списком компонентов в текущем подключенном Workspace.
Параметры и элементы управления диалогового окна Component Search
- Search — используйте текстовое поле поиска, чтобы вручную найти определенный компонент.
-
— нажмите, чтобы открыть меню и выбрать один из следующих пунктов:
- File-based Libraries Preferences — нажмите, чтобы открыть диалоговое окно Available File-based Libraries для добавления или удаления библиотек.
- File-based Libraries Search — нажмите, чтобы открыть диалоговое окно File-based Libraries Search для поиска библиотек.
- Refresh — нажмите, чтобы обновить диалоговое окно.
-
— нажмите, чтобы открыть или закрыть Details область диалогового окна (описана ниже).
Категории
Используйте этот фильтр для отображения определенных типов компонентов или всех доступных компонентов. Используйте
для доступа к Categories строке поиска, которая позволяет вручную найти определенный компонент или файл .IntLib.
Фильтры
Нажмите Filters значок , чтобы открыть область Filters , где можно дополнительно отфильтровать категории, выбранные в списке Components .
Компоненты
- Name - имя компонента.
- Description - описание каждого компонента.
- Footprint - посадочное место компонента.
- Operating Temperature Range - допустимый температурный диапазон работы этих компонентов.
- Package Description - описание корпуса компонента.
- Manufacturer Part Search — нажмите, чтобы открыть панель Manufacturer Part Search для поиска и выбора наиболее подходящего компонента.
- Create component — нажмите, чтобы открыть диалоговое окно Create new component для выбора типа компонента.
- Results - показывает общее количество компонентов, найденных при поиске.
Подробные сведения
- Component Revision ID - показывает идентификатор ревизии и цену компонента. Нажмите на идентификатор ревизии, чтобы открыть панель Explorer и получить дополнительную информацию о компоненте.
- References - нажмите, чтобы открыть справочную информацию о компоненте в веб-браузере. Используйте раскрывающийся список для доступа к Manufacturer URL или Datasheet.
- Place — нажмите, чтобы разместить выбранный компонент в документе схемы.
- Component information — показывает сведения о компоненте, включая производителя, дату выпуска и описание. Нажмите на ссылку Show More для просмотра всех сведений; нажмите Show Less , чтобы свернуть сведения.
- Models - разверните, чтобы просмотреть доступные модели. Используйте ссылки для отображения различных частей одной модели.
- References - разверните для доступа к Manufacturer URL или Datasheet.
- Part Choices - разверните, чтобы просмотреть варианты компонентов. Для каждого варианта указаны название, цена и описание. Также приводится техническое описание компонента (Datasheet).
- Where Used — разверните, чтобы просмотреть проекты, в которых используется компонент.
Контекстное меню
- Place <component> — нажмите, чтобы разместить компонент в соответствующем документе.
- Edit — нажмите, чтобы открыть документы библиотеки выбранного компонента.
- Navigate to <revision> — нажмите, чтобы открыть выбранный компонент на панели Explorer.
- Operations — наведите указатель, чтобы получить доступ к действиям Submit Request, Create, Download, Make a copy, Change Component Type, Create / Edit PCL и Full Item History.
- Refresh — нажмите, чтобы обновить данные и увидеть последние изменения. Для обновления также можно использовать сочетание клавиш F5.
Добавление экземпляров управляемого компонента или пользовательской позиции
После добавления управляемого компонента или пользовательской позиции щелкните по ним правой кнопкой мыши и выберите команду Operations » Add Instances of, чтобы открыть диалоговое окно Add to BOM Components. В этом окне можно задать количество экземпляров компонента, добавляемых в спецификацию.
Укажите Designator prefix, необязательный параметр Separator (его можно задать так, чтобы получить результаты вида X-1 или X:1) и Quantity требуемых компонентов (это значение используется для определения диапазона позиционных обозначений и также отображается в столбце Quantity ActiveBOM). Все остальные параметры, например описание, можно редактировать непосредственно в таблице позиций спецификации.
Изменение и удаление управляемого компонента или пользовательской позиции
Чтобы изменить позиционное обозначение или удалить экземпляр управляемого компонента либо пользовательской позиции, щелкните по нему правой кнопкой мыши и выберите команду Operations » Edit item. Откроется диалоговое окно Change / Remove.
Параметры и элементы управления диалогового окна Change/Remove
- BOM Components — в таблице диалогового окна перечислены все экземпляры новой позиции. Чтобы изменить префикс или значение позиционного обозначения, щелкните соответствующую ячейку New Designator и внесите необходимые изменения.
- Remove All — при нажатии этой кнопки выбираются все экземпляры дополнительной позиции спецификации, перечисленные в диалоговом окне, и помечаются для удаления. После нажатия кнопки OK все позиции с флажком Remove будут удалены из таблицы позиций спецификации ActiveBOM. Обратите внимание: поскольку экземпляров новой позиции больше не останется, сама позиция также будет удалена. Это действие нельзя отменить.
- Remove None — нажмите эту кнопку, чтобы снять все флажки Remove.
- Remove Selected — если выбран экземпляр, не помеченный для удаления, третья кнопка позволяет установить флажок Remove для выбранных экземпляров.
- Restore Selected — если выбран экземпляр, помеченный для удаления, третья кнопка позволяет снять флажок Remove для выбранных экземпляров.
Источники данных
По умолчанию в ActiveBOM доступны следующие источники данных: параметры компонентов схемы , параметры компонентов из рабочего пространства и данные, предоставляемые ActiveBOM На основе этих источников ActiveBOM формирует основную таблицу позиций спецификации проекта. Включение источников данных и управление их отображением выполняются на вкладке Columns панели Properties ActiveBOM.
При включении соответствующей кнопки Sources (над списком Columns) в спецификацию также можно добавить информацию из следующих дополнительных источников данных:
The PCB — включите эти источники, чтобы добавить для каждого компонента данные о его расположении, повороте и стороне установки на плате в доступные Columns. Если проект содержит несколько документов печатной платы, откроется диалоговое окно Choose PCB to Use, в котором можно выбрать нужную плату.
Database — для загрузки дополнительных параметров компонентов из внешней базы данных (через *.DbLib, *.SVNDbLib или *.DbLink).
Altium Cloud Services — включите этот источник, чтобы получить доступ к широкому набору дополнительных данных о компонентах для тех позиций спецификации, которые были идентифицированы поставщиком данных Altium Parts Provider и для которых найден вариант поставки.
Document Parameters — включите этот источник, чтобы добавить все обнаруженные параметры документов схемы из всех схем проекта печатной платы в доступные Columns.

Источник каждого параметра обозначается значком в списке столбцов.
Приоритет параметров источников данных
Если один и тот же параметр присутствует в нескольких источниках данных, в ActiveBOM применяется следующий порядок приоритетов (от высшего к низшему):
- Спецификация
- Печатная плата
- Документы
- Сервер
- База данных
- Облако
- Схема
- Ручной ввод
Столбец номеров строк
В проектах печатных плат со сборочными чертежами, а также при обмене данными спецификации между инженерами-разработчиками, инженерами по расчету стоимости и специалистами по закупкам номер строки спецификации (номер позиции в спецификации) — это простой способ однозначно различать строки спецификации. Его можно использовать, чтобы точно идентифицировать или find соответствующую выноску, компонент и его изображение в проекте.
Будучи источником данных спецификации проекта, ActiveBOM поддерживает пользовательские номера строк (Line #) в спецификации проекта и предоставляет функции как ручного, так и автоматического управления номерами строк (номерами позиций в спецификации).
-
Чтобы автоматически задать номера позиций для всех элементов спецификации проекта (в режиме Base), нажмите кнопку Set Line #
. Номера строк отображаются в столбце Line #, входящем в группу столбцов Item Details. Нажмите значок раскрывающегося списка справа на кнопке, чтобы открыть диалоговое окно Line # Options, в котором можно задать начальное значение и шаг нумерации.

Диалоговое окно Line Number Options- Start number — значение, используемое, если первая ячейка Line # пуста.
- Increment — шаг увеличения номера для каждого пустого поля Line #.
-
Чтобы изменить номера строк вручную, переключитесь в режим Base, затем выделите нужные ячейки в столбце Line # и:
- Нажмите Delete на клавиатуре, чтобы очистить ячейки, затем
- введите новые значения вручную или
- вставьте диапазон значений из буфера обмена Windows.
-
Чтобы перенумеровать строки или продолжить нумерацию с номера, заданного вручную, выберите ячейку Line # нужного элемента и нажмите кнопку Set Line #
. Откроется диалоговое окно Line Numbering, в котором можно использовать существующие номера как опорные и последовательно пронумеровать выбранные или все пустые ячейки, начиная с ближайших непустых ячеек выше (Continue numbering), либо удалить все существующие номера и заново пронумеровать все строки (Renumber all). Для вычисления добавляемых номеров используются начальное значение и шаг, заданные при последнем использовании диалогового окна Line # Options. При необходимости можно ввести исходное значение в выбранную ячейку Line #, чтобы задать начальный номер.
Настройка и сохранение вида таблицы элементов спецификации
Как и в любом хорошем приложении для работы с электронными таблицами, таблицу элементов спецификации можно настроить под свои требования. Помимо стандартных функций изменения порядка столбцов и сортировки, предусмотрено сохранение текущей конфигурации в виде набора BOM Set.
Возможности настройки таблицы
- Отображение и скрытие любого столбца — с помощью функции Columns на панели Properties. Используйте поле Search в верхней части панели, чтобы быстро найти столбец.
- Изменение порядка столбцов — нажмите и удерживайте заголовок столбца, затем перетащите его в нужное место.
- Изменение ширины столбца — наведите указатель на границу столбца в области заголовка, нажмите и перетащите ее (указатель должен принять вид либо дважды щелкните в этом месте, чтобы автоматически подобрать ширину по содержимому столбца.
-
Сортировка всей таблицы по столбцу:
- Нажмите заголовок столбца, чтобы отсортировать таблицу по его содержимому в алфавитно-числовом порядке.
- Нажмите еще раз, чтобы изменить порядок сортировки на обратный.
- Удерживая Shift, нажмите заголовок другого столбца, чтобы выполнить дополнительную сортировку по его содержимому.
-
Фильтрация таблицы по определенному значению — нажмите значок фильтра
, чтобы отфильтровать таблицу по значению, используемому в этом столбце. Выберите (Custom), чтобы открыть диалоговое окно Filter Editor и задать условие, оператор, значение, тип оператора и другие параметры фильтрации выбранного столбца.
- Сохранение конфигурации в виде набора BOM Set — подробнее об этом ниже.
Работа с наборами BOM Set
Можно сохранить любое количество конфигураций таблицы элементов спецификации — каждая из них называется набором BOM Set. Настроив таблицу под свои требования, нажмите кнопку Add в области BOM Sets панели Properties ActiveBOM, чтобы добавить набор BOM Set в список.

Нажмите значок глаза, чтобы активировать набор BOM Set.
Наборы BOM Set настраиваются на панели Properties ActiveBOM.
Замена компонента
При проверке BomDoc и подготовке к заказу компонентов нередко обнаруживаются проблемы с тем или иным компонентом. Например, разработчик мог забыть окончательно выбрать компонент, либо компонент был снят с производства и разработчик хочет оценить цены и доступность возможных замен. Раньше для решения такой проблемы требовалось вернуться к схеме, отредактировать компонент, выбрать подходящую деталь, а затем обновить BomDoc.
Теперь можно заменить компонент в BomDoc, а затем передать это изменение в схему с помощью извещения об изменениях (Engineering Change Order). Щелкните правой кнопкой мыши выбранный компонент или компоненты и выберите команду Operations » Change <ComponentName>. Откроется диалоговое окно Replace Component, в котором можно найти компонент для замены.
При нажатии кнопки Replace Component OK откроется диалоговое окно Engineering Change Order с подробным перечнем изменений, необходимых для синхронизации схемы с BomDoc.
Работа с вариантами
ActiveBOM поддерживает проекты печатных плат, содержащие варианты исполнения. Функция вариантов исполнения позволяет создать один базовый проект печатной платы, а затем использовать для него различные комплектации. Каждая такая комплектация собранной платы называется design variant.
Работа с вариантами исполнения:
- Варианты исполнения настраиваются в диалоговом окне Variant Management или в Variant Manager (Project » Variants).
- Чтобы просмотреть вариант, дважды щелкните его имя в папке Variants проекта на панели Projects, как показано на изображении ниже.
ActiveBOM поддерживает следующие возможности работы с вариантами:
- Отображение спецификации для выбранного варианта в режиме Base или Flat.
- Возможность включения неустанавливаемых компонентов в список позиций спецификации.
- Отображение сводного списка всех компонентов, используемых во всех вариантах, в режиме Consolidated.
- Задание решений вручную как для базовых, так и для измененных компонентов.
Варианты в режиме Base
Для выбранного варианта включите параметр Show Not Fitted на панели Properties, чтобы включить эти компоненты в таблицу позиций спецификации. При включении этого параметра столбец Fitted автоматически отображается в сведениях о позиции.
В режиме Base в столбце Fitted отображается значение Fitted или Not Fitted. Если компонент изменен (для этого варианта выбран альтернативный компонент), сведения об альтернативном компоненте автоматически отображаются для соответствующей позиции спецификации.

Обратите внимание: текущий вариант отображается в строке состояния ActiveBOM.
Варианты в режиме Consolidated
В режиме Consolidated отображаются все компоненты, используемые во всех вариантах. Этот режим предоставляет следующие возможности:
- Если компонент изменен, для каждого используемого альтернативного компонента создается отдельная позиция спецификации, причем все эти позиции имеют одно и то же позиционное обозначение. Например, на изображении ниже компоненты DS1 и DS2 указаны по два раза, поскольку в варианте BGA используются светодиоды другого цвета, чем в варианте TSOP. Компонент R1 указан три раза, поскольку в вариантах BGA и TSOP используются резисторы, отличающиеся друг от друга и от исходного резистора в базовом проекте.
-
В режиме Consolidated при включенном параметре Show Not Fitted в столбце Fitted отображается
FittedилиVaried. Поскольку в режиме Consolidated показаны все компоненты, используемые во всех вариантах, каждый отображаемый компонент устанавливается либо в базовом исполнении, либо в одном из вариантов. - Для каждого варианта предусмотрены столбец <VariantName> - Qty (показывающий количество этих компонентов в данном варианте) и столбец <VariantName> - Price, значение которого равно произведению цены за единицу на значение в столбце количества.
- Поскольку некоторые разработчики создают сборочную документацию не только для вариантов, но и для базового проекта, также предусмотрен столбец Quantity, отражающий количество экземпляров данного компонента при сборке базового проекта. Скройте этот столбец, если вы не создаете сборочную документацию для базового проекта.
- В таблице режима Consolidated цветом выделяются ячейки, значения которых отличаются от значений соответствующих ячеек базового проекта, как показано ниже.

Цвет ячейки указывает на то, что ее значение отличается от значения соответствующей ячейки базового проекта.
Подробнее о вариантах см. на странице Варианты исполнения.
Работа между BomDoc, схемой и печатной платой
Для работы между BomDoc, схемой и проектом печатной платы доступны две функции: перекрестное выделение (Cross Select) и перекрестное зондирование (Cross Probe). Их поведение настраивается на странице System - Navigation диалогового окна Preferences.
Обе функции позволяют находить один и тот же компонент в других документах. Разница между Cross Select и Cross Probe заключается в том, что режим Cross Select выделяет компонент в целевом документе, но не выводит сам документ на передний план, тогда как Cross Probe выводит целевой документ на передний план, а также может переключать редакторы, делая редактор целевого документа активным.
Функции Cross Select и Cross Probe можно использовать для перехода из BomDoc к схеме и печатной плате, но нельзя использовать для перехода из схемы или печатной платы к BomDoc.
Режим Cross Select
Режим Cross Select необходимо включить в каждом редакторе, в котором вы хотите его использовать. Выберите команду Tools » Cross Select Mode (Shift+Ctrl+X). Когда режим Cross Select включен, значок меню выделяется рамкой
.
Для работы режима Cross Select целевой документ должен быть открыт. При выборе компонента в списке позиций спецификации документа BomDoc этот компонент будет выделен и расположен по центру в целевых документах схемы и печатной платы (если включен параметр Zooming в группе настроек Cross Select Mode на странице System - Navigation диалогового окна Preferences). При этом целевой документ не становится активным.
Если BomDoc находится в режиме Base, на схеме и печатной плате выделяются все экземпляры данного компонента, как показано на изображении ниже.

Используйте функцию Cross Select, чтобы найти и выделить на схеме и печатной плате компонент, выбранный в списке позиций спецификации.
Перекрестное зондирование
В отличие от Cross Select — режима, который после включения отображает результат при каждом щелчке в списке позиций спецификации, — Cross Probe представляет собой отдельное действие.
Выберите Tools » Cross Probe в главном меню или щелкните правой кнопкой мыши по позиции BOM и выберите Cross Probe в контекстном меню, чтобы перейти к соответствующему компоненту на схеме. Если файл платы открыт, также будет выполнен переход к этому компоненту на плате.
Важная возможность перекрестного перехода — переключение в редактор целевого документа. Чтобы выполнить перекрестный переход и переключиться в другой редактор, удерживайте клавишу Ctrl при выборе команды Cross Probe.

Щелкните правой кнопкой мыши, чтобы вызвать команду перекрестного перехода. В меню будет отдельный пункт для позиционного обозначения каждого компонента, входящего в эту позицию BOM.
Панель Properties
Когда активным документом является документ BOM (*.BomDoc), на панели Properties отображается Document Options.
В следующих раскрывающихся разделах приведена информация о доступных параметрах и элементах управления:
Общие
- Production Quantity — количество плат, которые требуется изготовить. Это поле важно заполнить, поскольку его значение используется при поиске по цепочке поставок для проверки наличия компонентов у поставщиков.
- Currency — предпочтительная валюта для отображения цен компонентов. Курсы обмена для пересчета валют обновляются ежедневно, если вы вошли в свою учетную запись Altium. При отключении от Altium (на странице System – Account Management диалогового окна Preferences) доступ к обновленным курсам теряется. В этом случае в диалоговом окне отчетов BOM можно выбрать использование кэшированных данных.
- Price Per Board — рассчитывается на основе данных поставщиков и представляет собой сумму Supplier Subtotals per Board, как описано ниже. Обратите внимание, что Price Per Board не учитывает минимальный объем заказа (MOQ).
- Order Price — сумма Supplier Subtotals. Обратите внимание, что Order Price учитывает MOQ: именно эта сумма выплачивается поставщику.
Цепочка поставок
Информация о цепочке поставок отображается в нижней области интерфейса ActiveBOM: слева показан компонент производителя, а справа от него — одна или несколько цветных плиток поставщиков. Данные в этой области отображаются, если для позиции BOM удалось определить корректную информацию о цепочке поставок. Каждая из этих строк Manufacturer & Supplier(s) Details называется вариантом поставки. Сведения о производителе сокращенно обозначаются как MPN (Manufacturer Part Numbers — номера компонентов производителя), а сведения о поставщике — как SPN (Supplier Part Numbers — номера компонентов у поставщика).
- Solutions per Item — количество компонентов производителей, которое требуется найти для каждой позиции BOM.
- Suppliers per Solution — количество поставщиков, которое требуется найти для каждого компонента производителя.
-
Solutions
- Exclude Invalid SPNs — установите этот флажок, чтобы исключить недействительные SPN.
- Favorite Suppliers List — открывает диалоговое окно Favorite Suppliers, в котором можно настроить общий список поставщиков для этого документа BomDoc.
-
Manufacturer Link — открывает диалоговое окно Define Manufacturer Link Fields, в котором указываются параметры компонентов схемы, содержащие название производителя и номер компонента производителя. Если в проекте есть библиотечные компоненты не из Workspace (компоненты, размещенные не из Workspace и не содержащие сведений о поставщиках), ActiveBOM может обратиться к Altium Parts Provider, чтобы найти подходящие варианты поставки. Можно задать несколько пар параметров «Название / Номер компонента». В диалоговом окне нажмите кнопку Detect fields, чтобы автоматически добавить все пары параметров, которые содержат термин
manufacturerв имени и могут быть логически объединены в пары.
Позиции BOM
В этой области настраивается группировка позиций BOM в таблице позиций BOM.
-
Items
-
Show not Fitted — если проект платы содержит варианты исполнения и в выбранном варианте для некоторых компонентов задано состояние
Not Fitted, включите этот параметр, чтобы отображать неустанавливаемые компоненты в таблице позиций BOM. - Designator Grouping — в базовом и сводном режимах просмотра одинаковые компоненты отображаются в одной строке таблицы позиций BOM. Этот параметр определяет, будут ли позиционные обозначения отображаться по отдельности или диапазонами, если строка содержит несколько компонентов.
- Component Grouping — нажатие кнопки Edit открывает диалоговое окно Component Grouping. В режиме Base или Consolidated ActiveBOM считает компоненты одинаковыми, если у них совпадает ItemID (библиотека Workspace) или LibRef (файловая библиотека или библиотека базы данных). Включите параметры в этом диалоговом окне, чтобы уточнить правила группировки компонентов. Обратите внимание: если проект содержит только управляемые компоненты, кнопка Edit недоступна, поскольку управляемые компоненты всегда группируются по ItemID.
-
Show not Fitted — если проект платы содержит варианты исполнения и в выбранном варианте для некоторых компонентов задано состояние
Наборы BOM
Наборы BOM позволяют сохранять компоновку и настройки таблицы позиций BOM в виде именованного набора. Можно создать любое количество наборов BOM.
-
Current BOM Set — нажмите значок глаза, чтобы применить этот набор BOM к таблице позиций BOM.
-
Add – настройте видимость, порядок и ширину столбцов, затем нажмите Add, чтобы сохранить эту конфигурацию как набор BOM. Чтобы изменить имя набора BOM, щелкните один раз для его выбора, затем щелкните повторно для редактирования строки.
-
Update – если конфигурация таблицы позиций BOM изменена, нажмите Update, чтобы повторно сохранить эту конфигурацию.
-
Delete – нажмите
для удаления выбранного набора BOM.
Проверки BOM
ActiveBOM выполняет комплексную проверку каждой позиции BOM и всех найденных для нее данных о цепочке поставок.
- Violation Type grid – отображает список типов и количество нарушений каждого типа, имеющихся в BomDoc. Нажмите значок фильтра, чтобы отобразить только те позиции BOM, которые не прошли соответствующую проверку BOM. Обратите внимание: одна позиция BOM может не пройти несколько проверок BOM.
-
BOM Checks – нажмите
, чтобы открыть диалоговое окно проверок BOM, в котором можно настроить режим отчетности для каждого возможного типа нарушения.
Столбцы
Эта область панели используется для настройки параметров, отображаемых для каждой позиции BOM, и доступных для них источников данных.
-
Sources – помимо данных, добавленных непосредственно в BomDoc , по умолчанию в ActiveBOM доступны следующие источники данных: параметры компонентов схемы и параметры библиотечных компонентов рабочего пространства для содержимого рабочего пространства На основе этих источников ActiveBOM формирует основную таблицу позиций BOM проекта. В BOM также можно включить информацию из следующих дополнительных источников данных:
-
PCB – включите, чтобы добавить данные о расположении компонентов на плате, угле их поворота и стороне установки в список доступных Columns для каждого компонента.
-
Database – включите, чтобы загрузить дополнительные параметры компонентов из внешней базы данных (*.DbLib,*.SVNDbLibили*.DbLink). -
Document – включите, чтобы добавить все обнаруженные параметры документов схем из всех схем проекта печатной платы в список доступных Columns.
-
Altium Cloud Services – включите, чтобы получить доступ к широкому набору дополнительных данных о компонентах для тех позиций BOM, которые были идентифицированы поставщиком данных Altium Parts Provider и для которых найден вариант поставки.
-
-
Columns – список всех источников информации о компонентах, доступных в ActiveBOM. Область столбцов можно сортировать, щелкнув любой из заголовков.
- Visibility – в каждой строке есть значок глаза; щелкните его, чтобы управлять видимостью соответствующего столбца в основной таблице позиций BOM.
- Source – отображает значок, указывающий источник параметра.
- Name – имя свойства/параметра, заданное в исходном документе или введенное для пользовательского столбца BomDoc.
- Alias – при необходимости можно задать псевдоним для переименования столбца.
- Add – нажмите, чтобы добавить новый пользовательский столбец в таблицу позиций BOM.





