Создание модели симуляции
Краткий обзор
- Способы создания и получения моделей для моделирования, включая загрузку файлов от производителей, копирование текстовых моделей и написание файлов подсхем вручную.
- Создание, сохранение, привязка и редактирование моделей для моделирования в Altium Designer и подключённом рабочем пространстве.
- Сведения, необходимые для корректного определения модели для моделирования, включая имена моделей, используемые файлы и параметры уровня модели.
Для моделирования схемы с помощью симулятора смешанных сигналов Altium Designer все компоненты схемы должны быть подготовлены к моделированию, то есть с каждым из них должна быть связана модель для моделирования.
Тип модели и способ ее получения во многом зависят от компонента и в некоторой степени от личных предпочтений разработчика. Многие производители предоставляют модели для моделирования выпускаемых ими устройств. Как правило, достаточно скачать нужный файл модели и связать его с компонентом схемы. Подробнее см. в разделе Добавление моделей для моделирования в проект.
Некоторые модели может потребоваться написать с нуля — например, используя синтаксис иерархических подсхем для создания необходимого файла модели подсхемы (*.ckt).
Создание новой модели для моделирования
Некоторые модели предоставляются производителями и поставщиками в виде текстовых файлов для скачивания. Иногда описание модели представлено в виде текста на странице браузера, а не отдельного файла. В таком случае можно создать новый файл модели в Altium Designer и скопировать в него содержимое страницы браузера. Используйте соответствующую команду в подменю File » New » Mixed Simulation, как показано ниже.

Команды создания нового пустого файла модели.
Затем можно скопировать содержимое файла модели и вставить его в редактор моделей.

Пример текстового содержимого модели для моделирования.
Создание модели для моделирования в Workspace
Altium Designer совместно с подключенным Workspace позволяет создавать модели для моделирования в Workspace и управлять ими. Созданную в Workspace модель для моделирования можно использовать при создании одного или нескольких компонентов Workspace.
Модели для моделирования в Workspace создаются автоматически при добавлении файла модели к компоненту, определяемому в редакторе компонентов в режиме редактирования одного компонента, и последующем сохранении этого компонента в Workspace. Однако их также можно создавать непосредственно в Workspace, как описано ниже.
-
Откройте панель Components и включите отображение моделей, нажав кнопку
в верхней части панели и выбрав Models.
-
Перейдите в категорию Simulations и выберите Create Component в меню кнопки
.

Перейдите к моделям для моделирования на панели Components и выберите команду создания новой модели -
В открывшемся диалоговом окне Create New Item введите необходимые сведения, убедитесь, что параметр Open for editing after creation включен, и нажмите OK. Будет создана модель для моделирования в Workspace и открыт временный редактор SimModel. Активным документом в рабочей области проектирования станет документ
.SimModel. Имя этого документа будет соответствовать элементу и его ревизии в формате:<Item><Revision>.SimModel(например,SIM-001-0001-1.SimModel).
Пример редактирования начальной ревизии модели для моделирования в Workspace — временный редактор SimModel предоставляет документ для определения модели. - Используйте этот документ, чтобы задать модель для моделирования в Workspace в соответствии с требованиями. Подробнее см. в разделе Определение модели для моделирования.
- Сохраните модель в Workspace с помощью элемента управления Save to Server справа от записи модели на панели Projects. Откроется диалоговое окно Edit Revision, в котором можно изменить имя и описание, а также при необходимости добавить примечания к выпуску. После сохранения документ и редактор будут закрыты.
-
Документ с исходным определением модели для моделирования,
*.SimModel, будет сохранен в ревизии модели в Workspace. Модель будет отображаться на панели Components в категории Simulations.
Сохраненная модель для моделирования в Workspace на панели ComponentsДанные, сохраненные в Workspace, включают определение модели в файле
.SimModel, а также все файлы.mdlили.ckt, на которые оно ссылается. На панели Explorer перейдите на вкладку представления Preview, затем нажмите на файл, на который имеется ссылка, чтобы просмотреть его содержимое. При наличии также будут показаны параметры уровня модели.
Просмотрите сохраненную модель для моделирования в Workspace на панели Explorer. Перейдите на вкладку представления Preview, чтобы увидеть сохраненные данные.
Сохраненную модель для моделирования в Workspace затем можно связать с компонентом Workspace при его определении в редакторе компонентов в режиме редактирования одного компонента или пакетного редактирования компонентов.
Определение модели для моделирования
Для определения модели в файле SimModel требуются следующие сведения:
-
Model Name – используйте это поле, чтобы указать имя модели. При сохранении в Workspace это значение будет использоваться в качестве Name ревизии элемента модели моделирования.
При использовании файла MDL имя должно совпадать с именем в строке
.MODELопределения модели. Рассмотрим модель диода со следующим определением:.MODEL 1N4002 D(IS=2.55E-9 RS=0.042 N=1.75 TT=5.76E-6 CJO=1.85E-11 + VJ=0.75 M=0.333 BV=100 IBV=1E-5 )В данном случае имя модели —
1N4002. Именно это имя необходимо ввести в поле Model Name.При использовании файла CKT имя должно совпадать с именем в строке
.SUBCKTопределения модели. Рассмотрим модель плавкого предохранителя со следующим определением:.SUBCKT FUSE 1 2 PARAMS: CURRENT=1 RESISTANCE=1m SW1 1 2 3 0 SMOD OFF BNLV 3 0 V=(abs(v(1,2)))
.MODEL SMOD SW (VT=\{(CURRENT*RESISTANCE)\} RON=1g ROFF=\{RESISTANCE\})
.ENDS FUSEВ данном случае имя модели —
FUSE. Именно это имя необходимо ввести в поле Model Name. -
Model File – для модели, определенной с помощью файла
.mdlили.ckt, используйте кнопку Browse для выбора нужного файла из доступной библиотеки. - Description – введите описание модели, например ее назначение. При сохранении в Workspace это значение будет использоваться в качестве Description ревизии модели моделирования.
- Parameters – параметры уровня модели (см. Параметры уровня модели).
-
Model Preview – содержимое файла
.mdlили.ckt, на который ссылается модель; доступно только для чтения.
Параметры уровня модели
В соответствующих случаях параметры уровня модели можно задавать непосредственно в файле SimModel, поскольку они являются частью определения модели. Область Parameters документа автоматически заполняется параметрами, применимыми к выбранной модели. Значения параметров можно изменять непосредственно в списке — щелкните поле Parameter Value нужного параметра и введите требуемое значение.

Задавайте параметры модели как часть ее определения, редактируя их непосредственно в списке.
Редактирование модели моделирования Workspace
На любом этапе можно вернуться к любой модели моделирования Workspace и отредактировать ее напрямую. Выберите категорию Simulations на панели Components (для доступа к этой категории в меню
панели должна быть включена опция Models), щелкните правой кнопкой мыши запись модели моделирования и выберите команду Edit в контекстном меню. Снова откроется временный редактор, в котором для редактирования будет открыт файл с исходным определением модели, хранящийся в модели моделирования Workspace. Внесите необходимые изменения, затем сохраните документ в следующей ревизии модели моделирования Workspace.
Создание файлов SimModel
Файлы SimModel можно создавать на основе активного документа библиотеки схемных компонентов или библиотеки базы данных с помощью команды Tools » Generate SimModel Files.
После запуска команды появится диалоговое окно Generate SimModel Files. Каждый файл SimModel и содержащееся в нем определение модели создаются на основе ссылки на модель моделирования схемного компонента в активной библиотеке схемных компонентов (или сведений о моделировании в записи компонента активной библиотеки базы данных). С помощью элементов управления диалогового окна настройте создание одного или нескольких файлов SimModel. По умолчанию будет создана вложенная папка с именем Sim Models. При необходимости задайте более подходящее имя. Если указанная папка существует, будет использована она; в противном случае папка будет создана.

Диалоговое окно Generate SimModel Files
Задав необходимые параметры, нажмите OK. Начнется создание файлов. По завершении процесса появится диалоговое окно подтверждения с указанием количества созданных файлов SimModel. Все файлы .mdl, .ckt или .scb, на которые имеются ссылки, также будут сохранены вместе с файлами SimModel.
При переносе из интегрированной библиотеки исходные библиотеки схемных компонентов (SchLib) можно получить, открыв IntLib в Altium Designer и выбрав извлечение исходных библиотек. При создании файлов SimModel из библиотеки базы данных учитываются только компоненты из таблиц, включенных в данный момент.
Имена файлов SimModel зависят от типа исходной библиотеки:
- Schematic Library — каждому файлу SimModel присваивается имя модели моделирования. Если несколько схемных компонентов используют одну и ту же реализацию модели моделирования (модель с одинаковым именем), будет создан только один файл SimModel с этим именем.
- Database Library — каждому файлу SimModel присваивается имя модели моделирования, указанное в поле Sim Model Name записи компонента. Если несколько записей компонентов во включенных таблицах используют одну и ту же реализацию модели моделирования (одинаковое значение в поле Sim Model Name), будет создан только один файл SimModel с этим именем.
Мастер создания моделей SPICE
Для некоторых моделей аналоговых устройств, встроенных в SPICE, предусмотрен связанный файл модели (*.mdl), в котором с помощью параметров задаются расширенные поведенческие характеристики (например, для полупроводникового резистора, диода или биполярного транзистора). Создание такого файла вручную и его последующее ручное связывание с нужным компонентом схемы может быть довольно трудоемким. SPICE Model Wizard упрощает эту задачу. С помощью мастера можно задать характеристики устройства на основе полученных пользователем данных. Параметры, введенные напрямую или извлеченные из предоставленных данных, автоматически записываются в файл модели, который затем связывается с указанным компонентом схемы.
SPICE Model Wizard предоставляет удобное полуавтоматическое решение для создания и подключения моделей SPICE для ряда аналоговых устройств — устройств, встроенных в SPICE и требующих связанного файла модели (*.mdl). Поведенческие характеристики модели задаются на основе информации, которую вы предоставляете мастеру. Объем этой информации зависит от типа устройства, для которого создается модель: от простого ввода параметров модели до ввода данных устройства, взятых из технического описания производителя или полученных путем измерений на самом устройстве.
В следующих разделах рассматривается работа с мастером — от его запуска до проверки результата.
Запуск мастера
Мастер запускается из редактора схемных символов с помощью команды Tools » XSpice Model Wizard в главном меню.

Начальная страница SPICE Model Wizard
На двух следующих страницах мастера можно выбрать:
- Конкретное устройство для моделирования из списка поддерживаемых типов устройств.
- Добавить ли создаваемую модель SPICE к существующему компоненту в документе библиотеки или к новому компоненту, который мастер создаст и добавит в этот документ.
Поддерживаемые типы устройств
Мастер позволяет создавать модели SPICE для следующих типов аналоговых устройств:
- Диод
- Полупроводниковый конденсатор
- Полупроводниковый резистор
- Ключ, управляемый током
- Ключ, управляемый напряжением
- Биполярный транзистор
- Линия передачи с потерями
- Однородная распределенная RC-линия передачи
Задание имени модели
Один из важнейших шагов при работе с мастером — задать имя создаваемой модели. Пока имя не введено, перейти к этапу определения параметров модели невозможно.
После создания модели это имя появится в поле Model Name диалогового окна Sim Model. Файл модели также создается с этим именем (<ModelName>.mdl). Если мастер используется для добавления модели к новому библиотечному компоненту, указанное имя модели будет также использовано в качестве имени компонента.
При задании имени модели можно также ввести ее краткое описание. В нем можно указать назначение модели (например, Semiconductor Resistor) или более конкретные сведения о номинале либо конфигурации (например, NPN BJT).
Моделируемые характеристики
После задания имени модели вы перейдете на одну или несколько страниц, посвященных моделируемым характеристикам. Типы моделей, поддерживаемые мастером, можно разделить на две группы:
- Модели, требующие прямого ввода значений различных параметров. Дополнительные сведения см. в разделе Модели устройств, создаваемые путем прямого ввода параметров.
- Модели, требующие ввода данных, из которых извлекаются параметры, определяющие выбранные характеристики устройства. Вводимые данные получают либо путем непосредственных измерений на физическом устройстве, либо из технического описания производителя. Дополнительные сведения см. в разделе Модели устройств, создаваемые путем извлечения параметров из данных.
Формирование модели
После задания необходимых данных и параметров мастер отобразит сформированную модель. Именно это содержимое будет сохранено в MDL-файл.

Предварительный просмотр содержимого сформированного файла модели.
Модель можно редактировать непосредственно на этой странице, что дает полный контроль над ее описанием.
Когда описание модели будет готово, нажмите Next, чтобы перейти к завершающему этапу мастера. Нажатие Finish позволит сохранить модель. В диалоговом окне Save SPICE Model File укажите, куда следует сохранить полученный MDL-файл. По умолчанию файл сохраняется в том же каталоге, что и документ библиотеки схемных символов. При желании на этом этапе можно также изменить имя файла.
Если вы выбрали подключение модели к новому компоненту, этот компонент будет создан и добавлен в документ библиотеки.
Модели устройств, создаваемые путем прямого ввода параметров
Для перечисленных ниже моделей устройств мастер не извлекает параметры из введенных данных. Вместо этого модели создаются на основе непосредственно введенных значений соответствующих параметров. При вводе значений следует учитывать следующее:
- Если значение параметра не указано, запись о нем не добавляется в создаваемый файл модели. В этом случае используется значение по умолчанию, заданное внутри SPICE. Иными словами, если значение параметра указано в файле модели, оно переопределяет значение этого параметра по умолчанию.
- Если в мастере для параметра по умолчанию указано «-» и его значение не введено явно, при расчетах будет использоваться нулевое значение по умолчанию, заданное внутри SPICE.
Полупроводниковый конденсатор
Для этой модели устройства с помощью мастера можно задать следующие параметры. Если ввести значение параметра, он будет записан в создаваемый MDL-файл.
CJ |
Удельная емкость донной части перехода (в Ф/м²). |
|
CJSW |
Удельная емкость боковой стенки перехода (в Ф/м). |
|
DEFW |
Ширина устройства по умолчанию (в метрах). (По умолчанию = 1e-6). |
|
NARROW |
Уменьшение ширины из-за бокового травления (в метрах). (По умолчанию = 0). |
Полупроводниковый резистор
Для этой модели устройства с помощью мастера можно задать следующие параметры. Если ввести значение параметра, он будет записан в создаваемый MDL-файл.
TC1 |
Температурный коэффициент первого порядка (в Ом/°C). (По умолчанию = 0) |
|
TC2 |
Температурный коэффициент второго порядка (в Ом/°C²). (По умолчанию = 0) |
|
RSH |
Поверхностное сопротивление (в Ом). |
|
DEFW |
Ширина по умолчанию (в метрах). (По умолчанию = 1e-6). |
|
NARROW |
Уменьшение ширины вследствие бокового подтравливания (в метрах). (По умолчанию = 0). |
|
TNOM |
Температура измерения параметров (в °C). Если значение не задано, используется значение по умолчанию, заданное для TNOM на вкладке Advanced диалогового окна Advanced Analyses Settings (по умолчанию = 27). |
Ключ, управляемый током
Для этой модели устройства с помощью мастера можно задать следующие параметры. Если ввести значение параметра, он будет записан в создаваемый MDL-файл.
IT |
Пороговый ток (в амперах). (По умолчанию = 0). |
|
IH |
Ток гистерезиса (в амперах). (По умолчанию = 0). |
|
RON |
Сопротивление во включенном состоянии (в Ом). (По умолчанию = 1). |
|
ROFF |
Сопротивление в выключенном состоянии (в Ом). По умолчанию равно 1/GMIN. GMIN — это расширенный параметр SPICE, задаваемый на вкладке Advanced диалогового окна Advanced Analyses Settings. Он определяет минимальную проводимость (максимальное сопротивление) любого устройства в схеме. Его значение по умолчанию составляет 1e-12 См, что дает значение ROFF по умолчанию 1000 ГОм. |
Ключ, управляемый напряжением
Для этой модели устройства с помощью мастера можно задать следующие параметры. Если ввести значение параметра, он будет записан в создаваемый MDL-файл.
VT |
Пороговое напряжение (в вольтах). (По умолчанию = 0). |
|
VH |
Напряжение гистерезиса (в вольтах). (По умолчанию = 0). |
|
RON |
Сопротивление во включенном состоянии (в Ом). (По умолчанию = 1). |
|
ROFF |
Сопротивление в выключенном состоянии (в Ом). По умолчанию равно 1/GMIN. GMIN — это расширенный параметр SPICE, задаваемый на вкладке Advanced диалогового окна Advanced Analyses Settings. Он определяет минимальную проводимость (максимальное сопротивление) любого устройства в схеме. Его значение по умолчанию составляет 1e-12 См, что дает значение ROFF по умолчанию 1000 ГОм. |
Линия передачи с потерями
Для этой модели устройства с помощью мастера можно задать следующие параметры. Если ввести значение параметра (или установить флаг), он будет записан в создаваемый MDL-файл.
R |
Сопротивление на единицу длины (в Ом/ед. длины). (По умолчанию = 0). |
|
L |
Индуктивность на единицу длины (в Гн/ед. длины). (По умолчанию = 0). |
|
G |
Проводимость на единицу длины (в См/ед. длины). (По умолчанию = 0). |
|
C |
Емкость на единицу длины (в Ф/ед. длины). (По умолчанию = 0). |
|
LEN |
Длина линии передачи. |
|
REL |
Управление точками излома (в условных единицах). (По умолчанию = 1). |
|
ABS |
Управление точками излома (в условных единицах). (По умолчанию = 1). |
|
NOSTEPLIMIT |
Флаг, установка которого снимает ограничение, требующее, чтобы шаг по времени был меньше задержки линии. (По умолчанию не установлен). |
|
NOCONTROL |
Флаг, установка которого отключает ограничение шага по времени на основе критериев погрешности свертки. (По умолчанию не установлен). |
|
LININTERP |
Флаг, установка которого включает линейную интерполяцию вместо используемой по умолчанию квадратичной интерполяции при расчете задержанных сигналов. (По умолчанию не установлен). |
|
MIXEDINTERP |
Флаг, установка которого включает проверку применимости квадратичной интерполяции по специальному критерию. Если она неприменима, используется линейная интерполяция. (По умолчанию не установлен). |
|
COMPACTREL |
Величина, управляющая уплотнением ранее рассчитанных значений, используемых для свертки. По умолчанию используется значение параметра допуска относительной погрешности моделирования (RELTOL), заданного на вкладке Advanced диалогового окна Advanced Analyses Settings. |
|
COMPACTABS |
Величина, управляющая уплотнением ранее рассчитанных значений, используемых для свертки. По умолчанию используется значение параметра допуска абсолютной погрешности тока (ABSTOL), заданного на вкладке Advanced диалогового окна Advanced Analyses Settings. |
|
TRUNCNR |
Флаг, установка которого включает итерационный метод Ньютона — Рафсона для определения подходящего шага по времени в процедурах управления шагом. (По умолчанию не установлен; в этом случае используется метод проб и ошибок с последовательным уменьшением предыдущего шага вдвое). |
|
TRUNCDONTCUT |
Флаг, установка которого отключает выполняемое по умолчанию уменьшение шага по времени для ограничения погрешностей при вычислении величин, связанных с импульсной характеристикой. (По умолчанию не установлен). |
Однородная RC-линия передачи с распределенными параметрами
Для этой модели устройства с помощью мастера можно задать следующие параметры. Если ввести значение параметра, он будет записан в создаваемый MDL-файл.
K |
Постоянная распространения. (По умолчанию = 2). |
|
FMAX |
Максимальная рассматриваемая частота (в герцах). (По умолчанию = 1.0G). |
|
RPERL |
Сопротивление на единицу длины (в Ом/м). (По умолчанию = 1000). |
|
CPERL |
Емкость на единицу длины (в Ф/м). (По умолчанию = 1.0e-15). |
|
ISPERL |
Ток насыщения на единицу длины (в А/м). (По умолчанию = 0). |
|
RSPERL |
Сопротивление диода на единицу длины (в Ом/м). (По умолчанию = 0). |
Модели приборов, создаваемые путем извлечения параметров из данных
Для диодов и биполярных транзисторов мастер извлекает параметры из введенных вами данных. Конкретный набор параметров, извлекаемых для включения в файл модели, зависит от характеристик диода или биполярного транзистора, которые вы выбрали для моделирования.
Способ ввода данных зависит от характеристики. В одних случаях необходимо вводить числовые значения напрямую, в других — данные с графиков. В любом случае источником данных служат непосредственные измерения параметров прибора, техническое описание производителя или их сочетание.
Если требуется ввести данные с графика, внесите ряд точек, считанных с исходного графика, в таблицу мастера. Если данные сохранены в формате значений, разделенных запятыми (*.csv), их можно импортировать с помощью кнопки Import Data. Мастер использует введенные данные для извлечения необходимых параметров модели. Результаты извлечения отображаются на следующей странице мастера: приводятся сами значения извлеченных параметров и сравнительный график введенных данных и значений, рассчитанных с использованием этих параметров. На изображении ниже показан пример такого представления результатов.

Введите исходные данные, чтобы мастер мог извлечь необходимые параметры модели.
Вы можете изменить извлеченные значения параметров для дальнейшего повышения точности модели диода. Сравнительный график будет обновлен с учетом изменений.
Диод
В следующих разделах подробно описаны характеристики, которые можно выбрать для моделирования диода. В каждом разделе рассматриваются извлекаемые параметры и исходные данные, необходимые мастеру для их извлечения.
Ток при прямом смещении
Следующие параметры используются для описания вольт-амперной характеристики диода по постоянному току в области прямого смещения:
IS |
Ток насыщения (в амперах). |
|
N |
Коэффициент эмиссии. |
|
RS |
Омическое сопротивление (в омах). |
Для извлечения этих параметров необходим график зависимости прямого тока диода (IF) от прямого напряжения на диоде (VF). Этот график можно получить из технического описания производителя или по результатам измерений, выполненных на реальном приборе.
На изображении ниже показаны пример такого графика из технического описания, а также пример измерительной схемы, с помощью которой можно выполнить непосредственные измерения для получения необходимых исходных данных.

Пример графика и схемы для определения вольт-амперной характеристики диода в области прямого смещения.
Данные вводятся в мастер в виде ряда точек, считанных с исходного графика.
Емкость перехода при обратном смещении
Следующие параметры используются для описания емкости диода при работе в области обратного смещения:
CJO |
Емкость перехода при нулевом смещении (в фарадах). |
|
M |
Коэффициент плавности перехода. |
|
VJ |
Контактная разность потенциалов перехода (в вольтах). |
Для извлечения этих параметров необходим график зависимости емкости диода при обратном смещении (Cd) от обратного напряжения на диоде (VR). Этот график можно получить из технического описания производителя или по результатам измерений, выполненных на реальном приборе.
На изображении показаны пример такого графика из технического описания, а также пример измерительной схемы, с помощью которой можно выполнить непосредственные измерения для получения необходимых исходных данных. Эту схему можно использовать при отсутствии измерителя емкости.

Пример графика и схемы для определения емкости диода в области обратного смещения.
Данные вводятся в мастер в виде ряда точек, считанных с исходного графика.
Пример схемы на изображении выше основан на следующем уравнении:
I = C * (dv/dt)
Выразив C из этого уравнения, получим:
C = I/(dv/dt)
В схеме источник V1 формирует линейно изменяющееся напряжение. Рассчитав скорость изменения этого напряжения, можно получить величину dv/dt в уравнении. Разделив измеренный ток диода на скорость изменения напряжения, можно получить кривую зависимости емкости диода.
Ток при обратном смещении
Следующие параметры используются для описания обратного тока прибора после пробоя:
BV |
Напряжение обратного пробоя (в вольтах). |
|
IBV |
Ток при напряжении пробоя (в амперах). |
Для извлечения этих параметров необходимо ввести в мастер следующие два значения:
-
Значение напряжения обратного пробоя.
-
Значение тока через диод в точке обратного пробоя.
Эти значения можно получить из технического описания производителя или по результатам измерений, выполненных на реальном приборе. В технических описаниях электрические характеристики диода по постоянному току обычно представлены в виде таблицы, поэтому достаточно найти эти значения и ввести их в точности так, как они указаны.
Если исходные данные представлены графически, что характерно для непосредственных измерений на реальном приборе, необходимо считать эти два значения с графика в точке начала пробоя диода. На изображении ниже показан пример такого графика.

Определение значений тока и напряжения в точке обратного пробоя по графику.
Хотя на графике эти значения могут быть отрицательными, в соответствующие поля мастера их следует вводить только как положительные величины.
Характеристики обратного восстановления
Следующий параметр используется для моделирования времени обратного восстановления диода при переключении с прямого смещения на обратное:
TT |
Время переноса носителей заряда (в секундах). |
Для извлечения этого параметра необходимо ввести в мастер время обратного восстановления диода (Trr) для случая, когда прямой ток равен обратному (т. е. IR/IF=1). Эти данные обычно приводятся в технических описаниях импульсных диодов в виде простых числовых значений.
На изображении ниже показано, как эта информация представлена в техническом описании производителя. Нужное значение на изображении — то, которое следует ввести в мастер, — составляет 4 нс.

Определение времени обратного восстановления диода.
Биполярный транзистор (BJT)
При создании модели биполярного транзистора (BJT) мастер SPICE-моделей предлагает выбрать источник данных, из которого будут извлекаться значения параметров:
- Данные измерений — выберите этот вариант, если исходные данные получены при измерениях реального устройства и вы хотите разработать точную модель, описывающую все аспекты его поведения на постоянном токе.
- Техническое описание производителя — выберите этот вариант, если исходные данные взяты из технического описания. Технические описания, как правило, не содержат достаточно подробной информации для моделирования всех аспектов работы биполярного транзистора. Однако обычно в них достаточно данных для создания модели устройства, работающей только в прямом активном режиме.
Различия между этими двумя вариантами в основном касаются способа извлечения параметров, моделирующих вольт-амперные характеристики биполярного транзистора на постоянном токе. Параметры ёмкостей обратно смещённых переходов и времени переноса извлекаются одинаково в обоих случаях.
В следующих разделах подробно описаны характеристики биполярного транзистора, которые можно моделировать, в зависимости от типа исходных данных — результатов измерений или технического описания. Рассматриваются параметры, извлекаемые в каждом случае, и исходные данные, необходимые мастеру для их извлечения.
Характеристики, моделируемые по данным измерений
При использовании данных, полученных в результате непосредственных измерений реального устройства, можно моделировать следующие характеристики.
-
Forward-Bias Parameters
Для описания вольт-амперных характеристик биполярного транзистора на постоянном токе в прямом режиме используются следующие параметры:
IS
Ток насыщения переноса (А).
BF
Идеальный максимальный коэффициент усиления по току в прямом режиме.
NF
Коэффициент эмиссии тока в прямом режиме.
RB
Сопротивление базы при нулевом смещении (Ом).
RC
Сопротивление коллектора (Ом).
RE
Сопротивление эмиттера (Ом).
IKF
Ток начала спада коэффициента усиления в прямом режиме при больших токах (А).
ISE
Ток насыщения утечки перехода база–эмиттер (А).
NE
Коэффициент эмиссии тока утечки перехода база–эмиттер.
VAF
Напряжение Эрли в прямом режиме (В).
В следующих разделах подробно описаны необходимые данные измерений, ввод которых позволит мастеру извлечь эти параметры.
-
Base-Emitter Voltage versus Base Current
Эти данные используются для первоначального извлечения параметра RC. На рисунке ниже приведены пример графика зависимости напряжения база–эмиттер (VBE) от тока базы (IB), а также пример измерительной схемы, с помощью которой можно получить эти данные. Схема задаёт ток базы, при этом измеряется напряжение база–эмиттер при разомкнутой цепи коллектора.

Пример графика зависимости VBE от IB и измерительной схемы.Данные вводятся в мастер в виде последовательности точек, полученных из исходного графика.
-
Collector-Emitter Voltage versus Base Current
Эти данные используются для первоначального извлечения параметра RE. На рисунке ниже приведены пример графика зависимости напряжения коллектор–эмиттер (VCE) от тока базы (IB), а также пример измерительной схемы, с помощью которой можно получить эти данные. Схема задаёт ток базы, при этом измеряется напряжение коллектор–эмиттер при разомкнутой цепи коллектора.

Пример графика зависимости VCE от IB и измерительной схемы.Данные вводятся в мастер в виде последовательности точек, полученных из исходного графика.
-
Forward Gummel Plot
Эти данные в первую очередь используются для извлечения параметров IS, BF, NF, RB, IKF, ISE и NE. Они также используются для оптимизации параметров RC, RE и VAF. На рисунке ниже приведены пример графика Гуммеля, а также пример измерительной схемы, с помощью которой можно получить эти данные. График Гуммеля показывает:
-
Зависимость тока базы от напряжения база–эмиттер (IB от VBE).
-
Зависимость тока коллектора от напряжения база–эмиттер (IC от VBE).
Напряжение база–коллектор (VBC) поддерживается равным нулю.

Пример графика Гуммеля для прямого режима и измерительной схемы.Данные вводятся в мастер в виде последовательности точек, полученных из исходного графика Гуммеля. Необходимо вводить исходные значения IB и IC — мастер сам применит функцию LN к данным кривых.
-
-
Collector Current versus Base-Emitter Voltage
Эти данные используются для первоначального извлечения параметра VAF. На рисунке ниже приведены пример графика зависимости тока коллектора (IC) от напряжения база–эмиттер (VBE), а также пример измерительной схемы, с помощью которой можно получить эти данные. Схема используется для получения двух кривых зависимости IC от VBE при двух различных значениях напряжения база–коллектор (VBC). Измерения для построения кривых следует выполнять при как можно меньших токах и при значении VBC, максимально близком к нулю, насколько это практически возможно.

Примеры графиков зависимости VBE от IC и измерительной схемы.Данные вводятся в мастер в виде последовательностей точек в две таблицы — по одной для каждой исходной кривой. В каждом случае также необходимо указать использованное значение VBC.
-
-
Reverse-Bias Parameters
Для описания вольт-амперных характеристик биполярного транзистора на постоянном токе в инверсном режиме используются следующие параметры:
IS
Ток насыщения переноса (А).
BR
Идеальный максимальный коэффициент усиления по току в инверсном режиме.
NR
Коэффициент эмиссии тока в инверсном режиме.
RB
Сопротивление базы при нулевом смещении (Ом).
RC
Сопротивление коллектора (Ом).
RE
Сопротивление эмиттера (Ом).
IKR
Ток начала спада коэффициента усиления в инверсном режиме при больших токах (А).
ISC
Ток насыщения утечки перехода база–коллектор (А).
NC
Коэффициент эмиссии тока утечки перехода база–коллектор.
VAR
Напряжение Эрли в инверсном режиме (В).
В следующих разделах подробно описаны необходимые данные измерений, ввод которых позволит мастеру извлечь эти параметры.
-
Reverse Gummel Plot
Эти данные используются главным образом для определения параметров IS, BR, NR, RB, IKR, ISC и NC. Они также используются для оптимизации параметров RC, RE и VAR. На изображении ниже приведены пример графика Гуммеля и пример измерительной схемы, с помощью которой можно получить необходимые данные. На графике Гуммеля показаны:
-
Зависимость тока базы от напряжения база–коллектор (IB от VBC).
-
Зависимость тока эмиттера от напряжения база–коллектор (IE от VBC).
Напряжение база–эмиттер (VBE) поддерживается равным нулю вольт.

Пример обратного графика Гуммеля и измерительной схемы.Данные вводятся в мастер в виде набора точек, полученных из исходного графика Гуммеля. Необходимо вводить исходные значения IB и IE — мастер сам применит функцию LN к данным кривых.
-
-
Emitter Current versus Base-Collector Voltage
Эти данные используются для первоначального определения параметра VAR. На изображении ниже приведены пример графика зависимости тока эмиттера (IE) от напряжения база–коллектор (VBC), а также пример измерительной схемы, с помощью которой можно получить необходимые данные. Схема используется для получения двух кривых зависимости IE от VBC при двух разных значениях напряжения база–эмиттер (VBE). Измерения для построения кривых следует выполнять при как можно меньших токах и при VBE, максимально близком к нулю вольт, насколько это практически возможно.

Примеры графиков и схемы для получения зависимости IE от VBC.Данные вводятся в мастер в виде набора точек в две таблицы — по одной для каждой исходной кривой. В каждом случае также необходимо ввести использованное значение VBE.
-
Характеристики, моделируемые по данным технического описания производителя
При использовании данных из технического описания производителя можно моделировать следующие характеристики.
-
Forward-Bias Parameters
Следующие параметры используются для описания вольт-амперных характеристик биполярного транзистора по постоянному току в области прямого смещения:
IS
Транспортный ток насыщения (в амперах).
BF
Идеальный максимальный коэффициент усиления по току в прямом включении.
NF
Коэффициент эмиссии тока в прямом включении.
RE
Сопротивление эмиттера (в омах).
IKF
Ток начала спада коэффициента усиления в прямом включении при больших токах (в амперах).
ISE
Ток насыщения утечки перехода база–эмиттер (в амперах).
NE
Коэффициент эмиссии тока утечки перехода база–эмиттер.
В следующих разделах подробно описаны данные, ввод которых позволит мастеру определить эти параметры.
-
Base-Emitter Voltage versus Collector Current
Эти данные используются для определения параметров IS, NF, RE и IKF. На изображении ниже приведён пример графика зависимости напряжения база–эмиттер (VBE) от тока коллектора (IC), взятого из технического описания.
Данные вводятся в мастер в виде набора точек, полученных из исходного графика. Необходимо вводить исходные значения IC — мастер сам применит функцию LN к данным кривой.
Также необходимо ввести значение принудительно заданного коэффициента усиления по току для этой кривой (β = IC/IB). В примере на изображении выше это значение указано в левом верхнем углу графика, поэтому следует ввести 10.
-
DC Current Gain versus Collector Current
Эти данные используются для определения параметров BF, NE, ISE и IKF. На изображении ниже приведён пример графика зависимости коэффициента усиления по постоянному току (hFE) от тока коллектора (IC), взятого из технического описания.
Данные вводятся в мастер в виде набора точек, полученных из исходного графика. Для обеспечения точности значения коэффициента усиления по постоянному току следует вводить для малых, средних и больших значений тока коллектора.
-
-
Forward Early Voltage
Следующий параметр используется для моделирования эффекта модуляции ширины базы в модели транзистора Гуммеля–Пуна:
VAF
Напряжение Эрли в прямом включении (в вольтах).
Для определения этого параметра необходимо ввести точку с кривой зависимости выходной проводимости (hOE) от тока коллектора (IC). На изображении ниже приведён пример такой кривой.
Считайте любую точку с кривой. В примере на изображении выше можно считать значения IC = 1 мА и hOE = 30 мкСм.
Обычно эти данные приводятся в табличном виде, пример которого показан на изображении ниже.

Пример представления выходной проводимости в таблице.На изображении нас интересуют значения 1 мА для тока коллектора и 30 мкСм для выходной проводимости (обычно используется максимальное значение) — именно их следует ввести в мастер.
Характеристики, моделируемые по результатам измерений или данным производителя
Следующие характеристики можно моделировать по данным из технического описания производителя или по результатам прямых измерений на реальном приборе.
-
Base-Emitter Capacitance
Следующие параметры используются для описания ёмкости перехода база–эмиттер при обратном смещении:
CJE
Барьерная ёмкость перехода база–эмиттер при нулевом смещении (в фарадах).
MJE
Показатель степени для перехода база–эмиттер.
VJE
Контактная разность потенциалов перехода база–эмиттер (в вольтах).
Для определения этих параметров требуется график зависимости ёмкости обратно смещённого перехода база–эмиттер (Cj) от напряжения (VBE). Если измеритель ёмкости недоступен, для получения данных можно использовать пример измерительной схемы, приведённый на изображении ниже. На изображении также показаны примеры графиков, полученных с помощью такой схемы, — зависимости VBE и Cj от времени соответственно. По этим графикам можно легко считать значения VBE и Cj в соответствующие моменты времени.

Пример схемы и графиков для ёмкости перехода база–эмиттер при обратном смещении.Данные вводятся в мастер в виде набора точек, полученных из исходного графика или графиков.
Пример схемы на изображении выше основан на следующем уравнении:
I = C * (dv/dt)Выразив C из этого уравнения, получим:
C = I/(dv/dt)Схема формирует линейно нарастающее напряжение с помощью источника V1. Вычислив скорость изменения этого напряжения, можно получить член уравнения
dv/dt. Разделив измеренный ток диода на скорость изменения напряжения, можно получить кривую ёмкости диода. Два графика на изображении выше связаны со схемой следующим образом:-
Верхний график — VBE соответствует V1.
-
Нижний график — Cj соответствует q1[ie]/(dV1/dt).
-
-
Base-Collector Capacitance
Для описания ёмкости обратно смещённого перехода база–коллектор используются следующие параметры:
CJC
Барьерная ёмкость перехода база–коллектор при нулевом смещении (в фарадах).
MJC
Показатель степени для перехода база–коллектор.
VJC
Контактная разность потенциалов перехода база–коллектор (в вольтах).
Для определения этих параметров требуется график зависимости ёмкости обратно смещённого перехода база–коллектор (Cj) от напряжения (VBC). Если измеритель ёмкости недоступен, для получения данных можно использовать пример испытательной схемы на изображении ниже. На изображении также приведены примеры графиков, полученных с помощью такой схемы, — зависимости VBC и Cj от времени соответственно. По этим графикам легко определить значения VBC и Cj в соответствующие моменты времени.

Пример схемы и графиков для ёмкости обратно смещённого перехода база–коллектор.Данные вводятся в мастер в виде набора точек, полученных из исходного графика.
Пример схемы на изображении выше основан на уравнении:
I = C * (dv/dt)Решив это уравнение относительно C, получим:
C = I/(dv/dt)Схема формирует линейно нарастающее напряжение с помощью источника V1. Вычислив скорость изменения этого напряжения, можно получить член уравнения
dv/dt. Разделив измеренный ток диода на скорость изменения напряжения, можно получить кривую ёмкости диода. Два графика на изображении выше связаны со схемой следующим образом:-
Верхний график — VBC соответствует V1.
-
Нижний график — Cj соответствует q1[ic]/(dV1/dt).
-
-
Collector-Substrate Capacitance
Для описания ёмкости обратно смещённого перехода коллектор–подложка используются следующие параметры:
CJS
Ёмкость перехода коллектор–подложка при нулевом смещении (в фарадах).
MJS
Показатель степени для перехода подложки.
VJS
Контактная разность потенциалов перехода подложки (в вольтах).
Для определения этих параметров требуется график зависимости ёмкости обратно смещённого перехода коллектор–подложка (Cj) от напряжения (VCS). Если измеритель ёмкости недоступен, для получения данных можно использовать пример испытательной схемы на изображении ниже. На изображении также приведены примеры графиков, полученных с помощью такой схемы, — зависимости VCS и Cj от времени соответственно. По этим графикам легко определить значения VCS и Cj в соответствующие моменты времени.

Пример схемы и графиков для ёмкости обратно смещённого перехода коллектор–подложка.Данные вводятся в мастер в виде набора точек, полученных из исходного графика.
Пример схемы на изображении выше основан на уравнении:
I = C * (dv/dt)Решив это уравнение относительно C, получим:
C = I/(dv/dt)Схема формирует линейно нарастающее напряжение с помощью источника V1. Вычислив скорость изменения этого напряжения, можно получить член уравнения
dv/dt. Разделив измеренный ток диода на скорость изменения напряжения, можно получить кривую ёмкости диода. Два графика на изображении выше 24 связаны со схемой следующим образом:-
Верхний график — VCS соответствует V1.
-
Нижний график — Cj соответствует q1[is]/(dV1/dt).
-
-
Transit Times
Для описания времени переноса носителей заряда в биполярном транзисторе используются следующие параметры:
TF
Идеальное время переноса в прямом режиме (в секундах).
TR
Идеальное время переноса в инверсном режиме (в секундах).
Для определения этих параметров в мастер необходимо ввести граничную частоту коэффициента передачи тока транзистора (fT). Это частота, на которой коэффициент усиления транзистора по току становится равным единице. Эти данные обычно приводятся в технической документации производителя в виде числовых значений.
На изображении ниже показано, как эта информация представлена в технической документации производителя. Нужное значение на изображении, которое следует ввести в мастер, — 100 МГц.

Пример строки таблицы с произведением коэффициента усиления по току на полосу пропускания.
Параметры, не определяемые мастером
Следующие параметры сложно определить по результатам измерений, и обычно они отсутствуют в технической документации производителя. Мастер не определяет их и не добавляет в результирующий файл модели биполярного транзистора. Несмотря на их отсутствие в файле MDL, SPICE использует эти параметры при моделировании биполярного транзистора, подставляя встроенные значения по умолчанию. Для удобства эти значения приведены ниже.
IRB |
Ток, при котором сопротивление базы снижается до середины диапазона между начальным и минимальным значениями (в амперах). (По умолчанию — бесконечность). |
|
RBM |
Минимальное сопротивление базы при больших токах (в омах). (По умолчанию — RB). |
|
XTF |
Коэффициент зависимости TF от смещения. (По умолчанию — 0). |
|
VTF |
Напряжение, описывающее зависимость TF от VBC (в вольтах). (По умолчанию — бесконечность). |
|
ITF |
Параметр влияния больших токов на TF (в амперах). (По умолчанию — 0). |
|
PTF |
Дополнительный фазовый сдвиг на частоте freq=1.0/(TF*2PI) Гц (в градусах). (По умолчанию — 0). |
|
XCJC |
Доля барьерной ёмкости перехода база–коллектор, подключённая к внутреннему узлу базы. (По умолчанию — 1). |
|
XTB |
Температурный показатель степени коэффициента усиления по току в прямом и инверсном режимах. (По умолчанию — 0). |
|
EG |
Ширина запрещённой зоны, определяющая температурную зависимость IS (в эВ). (По умолчанию — 1.11). |
|
XTI |
Показатель степени температурной зависимости IS. (По умолчанию — 3). |
|
KF |
Коэффициент фликкер-шума. (По умолчанию — 0). |
|
AF |
Показатель степени фликкер-шума. (По умолчанию — 1). |
|
FC |
Коэффициент в формуле ёмкости обеднённого слоя при прямом смещении. (По умолчанию = 0,5). |
|
TNOM |
Температура измерения параметров (в ˚C). (Значение этого параметра по умолчанию равно значению параметра TNOM, заданному на странице SPICE Options диалогового окна Analysis Setup. По умолчанию оно составляет 27 ˚C). |
Разумеется, любой из этих параметров можно вручную добавить в MDL-файл, указав нужные значения.
