Создание чертежа компоновки

После того как конструкция жгута зафиксирована в виде схемы соединений, можно создать физическое представление конструкции в виде чертежа компоновки жгута (*.LdrDoc). Добавьте этот документ в проект жгута из панели Projects, щелкнув правой кнопкой мыши по записи проекта и затем выбрав Add New to Project » Harness Wiring Diagram в контекстном меню (или используйте команду File » New » Harness Layout Drawing в главном меню).

Настройка документа чертежа компоновки жгута

Параметры документа чертежа компоновки можно настроить на панели Properties, когда в рабочей области документа не выбран ни один объект. Основные настройки:

  • В области General вкладки General панели — выберите единицы измерения, применяемые к документу и его графическим элементам, и настройте сетки для упрощения размещения. Altium Designer предлагает три типа сетки: видимая сетка для навигации, сетка привязки для размещения и шаг привязки для облегчения создания соединений.

  • В области Page Options вкладки General панели — настройте размер листа документа и основную надпись либо выберите один из доступных шаблонов чертежа компоновки жгута.

Вкладки General и Parameters панели Properties, когда в документе чертежа компоновки жгута не выбран ни один объект 
Вкладки General и Parameters панели Properties, когда в документе чертежа компоновки жгута не выбран ни один объект

  • Настройка документа чертежа компоновки жгута аналогична настройке схемного документа (*.SchDoc) проекта разработки PCB. Подробнее см. на странице Настройка схемного документа.

  • Используйте раскрывающийся список Length Units, чтобы выбрать единицы длины для документа. Значения Bundle Length и объектов жгута Length Value и Offset Length будут отображаться в выбранных единицах. Поддерживаются единицы mm, cm, m, in и ft. Единицы длины по умолчанию для вновь создаваемых документов чертежей компоновки можно задать на странице Harness Design – General page диалогового окна Preferences.

  • Чтобы узнать больше о создании шаблонов документов чертежей компоновки, см. страницу Создание шаблонов документов жгута.

  • Свойства по умолчанию для объектов чертежа компоновки жгута можно настроить на странице Harness Design – Defaults page диалогового окна Preferences. Эти свойства будут применяться при размещении последующих объектов.

  • При создании документа чертежа компоновки жгута также можно использовать текстовые и графические объекты. Работа с этими объектами в документе чертежа компоновки жгута аналогична работе с ними в схемном документе (*.SchDoc) проекта разработки PCB. Подробнее об этих объектах см. в разделах Работа с текстовыми объектами на схеме и Работа с графическими объектами на схеме.

    • Обратите внимание, что в текстовых рамках и примечаниях также поддерживаются активные ссылки на объекты схемы соединений жгута (например, провода и компоненты) и объекты чертежа компоновки жгута (например, жгуты и точки соединения). Щелкните ссылку в размещенной текстовой рамке или примечании, чтобы выполнить перекрестный переход к этому объекту в связанном документе.

  • Для проверки чертежа компоновки жгута на логические, электрические и оформительские нарушения поддерживается ряд проверок. Подробнее см. на странице Проверка проекта жгута.

  • Документ чертежа компоновки жгута можно сохранить в формате ASCII, что может быть полезно при совместном использовании. Используйте команду File » Save As и выберите Harness Layout ascii (*.LdrDoc) в раскрывающемся списке Save as type в открывшемся диалоговом окне Save As. При сохранении чертежа компоновки в ASCII с помощью команды File » Save откроется диалоговое окно File Format, предупреждающее о том, что используется формат ASCII. Выберите версию ASCII в диалоговом окне , чтобы продолжить использование этого формата.

Импорт данных из схемы соединений

Выберите команду Design » Import Wiring Diagram в главном меню, чтобы импортировать данные проекта из схемы соединений. Компонент будет размещен на листе чертежа компоновки в относительных позициях, заданных в схеме соединений. Точки соединения, связанные с компонентами, также будут размещены рядом с каждым компонентом на чертеже компоновки.

Документ чертежа компоновки жгута с импортированными данными из схемы соединений
Документ чертежа компоновки жгута с импортированными данными из схемы соединений

  • После использования команды внесенные изменения перечисляются на панели Messages ().

  • Любые изменения в схеме соединений можно импортировать в чертеж с помощью той же команды Design » Import Wiring Diagram.

Работа с компонентами

Изначально каждый компонент представлен на чертеже компоновки своим символом. Свойства размещенного компонента можно настроить на панели Properties, когда компонент выбран в рабочей области. Панель Properties для компонента включает следующие вкладки:

 
 
 
 
 
  • General — общие свойства компонента, такие как позиционное обозначение и комментарий, местоположение, представление модели, параметры и т. д.

  • Pins — список выводов компонента.

  • Cavities — представление только для чтения назначенных компоненту полостей разъема. Назначения полостей можно изменять только в схеме соединений — подробнее.

  • Associated Parts — позволяет назначать компоненту дополнительные части, например термоусадку.

При вставке вырезанных/скопированных компонентов жгута на чертеж компоновки жгута позиционные обозначения вставленных компонентов учитывают параметр Reset Parts Designators On Paste со страницы Schematic – Graphical Editing page диалогового окна Preferences. При вставке компонентов числовая часть их позиционных обозначений будет сбрасываться на ?, если этот параметр включен.

Настройка представления компонента

Используя параметр Graphical SymbolPhysical Model в области Model панели Properties (на вкладке General) при выбранном компоненте, можно переключаться между представлением в виде символа (схемный symbol компонента) и проекцией 3D-модели (посадочное место footprint компонента). Для настройки представления используйте другие параметры в этой области панели.

Javascript ID: Harness_LD_HarnessComponent_ModelType_AD25

Компонент, представленный своим схемным символом

Тот же компонент, представленный проекцией его 3D-модели

При использовании представления Physical Model применяйте параметры Style , чтобы отображать модель либо как Solid (без линий), либо как Wireframe. Используйте параметры раскрывающегося списка Side, чтобы выбрать требуемую сторону обзора модели (доступны ортогональные и изометрические варианты). Ниже приведены изображения, демонстрирующие некоторые из настроек и соответствующие результаты в рабочей области.

Javascript ID: Harness_LD_HarnessComponent_ModelType_Footprint_Config_AD25

Вид физической модели можно повернуть графически в рабочей области, взявшись за маркер поворота, расположенный в правом нижнем углу вида модели, и перемещая мышь; поле Rotation будет автоматически обновляться (поворот выполняется с шагом 1 градус). Также можно удерживать клавишу Alt, чтобы ограничить поворот шагом 45 градусов. Для удобства при вращении вида мышью текущий угол отображается в Status Bar.

Если проект, содержащий модели, повернутые с использованием пользовательских значений, открыть в версии Altium Designer до 26.9, будет показано предупреждение о совместимости с предыдущими версиями. Вы можете заново сгенерировать физические модели с использованием прежней функциональности, то есть выбора из раскрывающегося списка. 

  • Для стилей Solid и Wireframe значение Zoom определяет размер зеленой ограничивающей рамки вида модели в рабочей области, и вид модели всегда вписывается в эту рамку.

  • Упрощая интеграцию при использовании Altium MCAD CoDesigner with harness design projects, 3D-модели, используемые в физических представлениях компонентов жгута, встраиваются в документ чертежа компоновки (в формате Parasolid). Любые отсутствующие 3D-модели (существующие, но не встроенные) будут встроены после сохранения документа (File » Save). Эта возможность находится в Open Beta и доступна, когда в диалоговом окне Advanced Settings dialog включен параметр HarnessDesign.Embed3DModel.

Adding Multiple Physical Model Views

  • Используйте стрелку раскрывающегося списка, чтобы просматривать и редактировать свойства физического представления ().

  • Для компонента можно добавить несколько представлений физической модели с помощью элемента управления Add Component View на панели Properties ().  

  • Дополнительные физические представления, добавленные для компонента, можно независимо перемещать в рабочей области с помощью перетаскивания.

  • Независимо от того, какое физическое представление модели компонента выбрано в рабочей области, панель Properties  отображает свойства самого компонента.

Определение физического расположения на чертеже компоновки жгута

Все физические соединения внутри жгута определяются как жгуты (bundles), даже если жгут содержит только один провод. Каждый жгут должен начинаться и заканчиваться в точке соединения. При первоначальном импорте данных проекта жгута (как описано выше) рядом с каждым компонентом автоматически размещается точка соединения, и эта точка соединения связывается с компонентом и всеми его выводами. Если этого требует физическая структура проекта, можно размещать новые точки соединения и настраивать назначенные им объекты.

Чтобы упростить понимание связности компонентов в документе чертежа компоновки жгута, в документе можно отображать граф связности. Когда параметр Connective Graph включен на странице System – Navigation page диалогового окна Preferences, используйте сочетание клавиш Alt+Click на компоненте, чтобы отобразить граф связности в рабочей области (). Очистить граф можно с помощью сочетания клавиш Shift+C или команды Clear Filter из контекстного меню рабочей области.

Работа с точками соединения

Чтобы разместить новую точку соединения, используйте команду Place » Connection Point из главного меню. Точки соединения отображаются в рабочей области, как показано ниже.

Свойства размещенной точки соединения (ее положение, визуальное представление и т. д.) можно настроить на панели Properties, когда точка соединения выбрана в рабочей области.

Панель Properties, когда выбрана точка соединения
Панель Properties, когда выбрана точка соединения

Используйте область Associated Parts панели Properties для выбранной точки соединения, чтобы управлять списком частей, связанных с точкой соединения, то есть физических объектов, которые вы хотите связать с отображаемым графическим представлением. 3D-модель части, связанной с точкой соединения, может использоваться для представления точки соединения в документе. Когда точка соединения выбрана, выберите Physical Model в области Properties панели Properties, затем используйте раскрывающийся список Associated Part в области Type, чтобы выбрать требуемую связанную часть (). Модель будет сгенерирована и отображена в документе. Используйте параметры в области Type для настройки отображения модели ().

Упрощая интеграцию при использовании Altium MCAD CoDesigner with harness design projects, 3D-модели, используемые в физических представлениях точек соединения, встраиваются в документ чертежа компоновки (в формате Parasolid). Любые отсутствующие 3D-модели (существующие, но не встроенные) будут встроены после сохранения документа (File » Save). Эта возможность находится в Open Beta и доступна, когда в диалоговом окне Advanced Settings dialog включен параметр HarnessDesign.Embed3DModel.

Назначение объектов точкам соединения

Назначенные точке соединения объекты можно настраивать по мере необходимости в соответствии с замыслом проекта. Один или несколько объектов (компоненты, сращивания/ответвления, объекты «без соединения» и экраны с соединением) можно назначить точке соединения с помощью диалогового окна Add Assigned Objects, которое открывается нажатием кнопки   в области Assigned Objects  панели Properties .

  • По умолчанию в диалоговом окне включен параметр Show only unassigned objects, и отображаются только те объекты, которые в данный момент не назначены другим точкам соединения. Отключите этот параметр, чтобы показать список всех объектов на чертеже компоновки.

  • Если в диалоговом окне выбран объект, уже назначенный другой точке соединения, будут показаны соответствующие предупреждения и значки (). Чтобы избежать назначения одного сращивания более чем одной точке соединения, сращивание автоматически удаляется из точки соединения, если оно уже назначено другой точке соединения.

Когда компонент назначен точке соединения, в рабочей области между компонентом и точкой соединения отображается штрихпунктирная линия, как показано ниже. В Properties можно выбрать, какие выводы компонента назначены. Щелкните ячейку в столбце Pins сетки в области Assigned Objects, чтобы открыть раскрывающийся список и выбрать требуемые выводы компонента.

При перетаскивании одной точки соединения на другую (если это допустимо) на чертеже компоновки они объединяются в один объект, а списки назначенных им объектов объединяются.

Работа с жгутами

Чтобы разместить новый жгут, используйте команду Place » Harness Bundle из главного меню (сочетание клавиш: Shift+B).

После выбора команды щелкните точку соединения (когда курсор находится над горячей точкой точки соединения, у него появляется красный крест), чтобы разместить начальную точку жгута. Перемещайте курсор и щелкайте, чтобы зафиксировать ряд вершин, определяющих форму жгута. После размещения последней вершины в горячей точке другой точки соединения щелкните правой кнопкой мыши, чтобы завершить размещение.

По умолчанию жгут размещается в режиме Any Angle. При размещении жгута нажимайте Shift+Spacebar, чтобы переключаться между режимами размещения. Режим определяет, как создаются углы при размещении жгутов и под какими углами их можно размещать.  Находясь в режиме 90 Degree или 45 Degree (истинно ортогональные режимы), нажимайте Spacebar, чтобы переключаться между подрежимами начала и конца. Текущий режим и подрежим отображаются в строке состояния.

Пример жгута, размещенного между точками соединения CP1 и CP_P2.
Пример жгута, размещенного между точками соединения CP1 и CP_P2.

После размещения и выбора жгута его вершины можно перетаскивать, чтобы изменять угол между двумя соседними сегментами.

  • Когда жгуты подключаются к точке соединения, не назначенные в данный момент сращивания будут автоматически назначены этой точке соединения в соответствии со схемой соединений.

  • Точку соединения можно разместить прямо на существующем жгуте. Это разделит исходный жгут на два отдельных жгута.

  • Если удалить точку соединения, которая делит жгут на чертеже компоновки на две части, эти два жгута автоматически объединятся в один объект жгута.

Свойства размещенного жгута (положение, визуальное представление и т. д.) можно настроить на панели Properties, когда жгут выбран в рабочей области.

Панель Properties, когда выбран жгут
Панель Properties, когда выбран жгут

Каждый жгутовый пучок автоматически содержит объекты (провода и/или кабели) в соответствии со связностью, заданной на схеме соединений. Эти объекты перечислены в области Bundle Objects панели Properties, когда выбран пучок. Щелкните объект в этом списке, чтобы подсветить все пучки, через которые проходит выбранный объект.

В случае сложной разветвленной физической структуры пучка может потребоваться изменить назначение провода другому пучку. Используйте раскрывающийся список в области Bundle Objects Assignment панели Properties, когда нужный пучок выбран в рабочей области, чтобы при необходимости обновить назначение провода для этого пучка.

С помощью поля Length в области Properties панели можно задать длину выбранного пучка. Длины проводов и кабелей, проходящих через пучки, вычисляются на основе значений Length этих пучков. Вычисленные значения длины провода/кабеля отображаются в столбце Length Value таблицы в области Bundle Objects панели.

Добавление вида сегмента провода

Вид сегмента провода отображает провода, находящиеся внутри сегмента, то есть отдельные провода, витые пары проводов и провода, входящие в состав кабелей. Это позволяет точно увидеть, как провода физически размещаются внутри сегмента жгутового пучка. Каждый провод имеет метку и окрашен в заданный для него цвет, а его толщина определяется значением параметра Thickness этого провода (заданного на схеме соединений (*.WirDoc)). Вы можете разместить вид сегмента уже размещенного сегмента пучка в чертеже компоновки (*.LdrDoc) с помощью команды Add Segment View в области Model панели Properties . Затем в области Segment View отображается раскрывающийся список, в котором можно выбрать уровень Zoom для добавляемого вида. Рабочая область масштабируется к этому виду, как показано в примере слайд-шоу ниже. Чтобы удалить вид сегмента, используйте команду Delete в области Segment View. Щелкните, чтобы выбрать вид, и переместите его в нужное место в рабочей области.

Нажмите Add Segment View, чтобы добавить новый вид.

Раскрывающийся список Zoom позволяет выбрать требуемый уровень масштабирования для вида сегмента. 

Свойства проводов со схемы соединений передаются в вид сегмента, как показано для W9.

Чтобы удалить вид сегмента, нажмите Delete.  

Добавление точки разрыва

Точка разрыва, используемая как указание того, что пучок не в масштабе (NTS), может быть размещена на жгутовом пучке. На пучке будет отображаться символ разрыва посередине его самого длинного сегмента, как показано на первом изображении ниже, а в свойствах будет отображаться Drawn Length. Чтобы разместить разрыв, включите параметр Add Break Symbol в области Properties свойств пучка. Покрытия жгута, которые покрывают жгутовый пучок с точкой разрыва, также будут отображать разрыв в том же месте. Если покрытие жгута заканчивается в точке разрыва жгутового пучка, покрытие будет нарисовано немного длиннее, как показано на втором изображении.

Размещенная точка разрыва на пучке

Размещенное покрытие поверх размещенной точки разрыва

 
  • При необходимости вы можете переопределить вычисленную длину провода/кабеля. Введите требуемое значение Offset Length или выберите Manual в раскрывающемся списке в столбце Length Type, чтобы вручную задать требуемую абсолютную длину.

  • Для проводов, длина которых была определена в инструменте MCAD, а затем импортирована в Altium Designer с помощью MCAD CoDesigner, запись MCAD CoDesigner будет показана в записи Length Type. В этом случае Offset Length задать нельзя, но можно переопределить значение длины, выбрав Manual из раскрывающегося списка (). Подробнее см. в разделе Синхронизация проекта конструкции жгута с использованием MCAD CoDesigner.

  • Единицы измерения, в которых значение Length пучка и значения Length Value и Offset Length его объектов отображаются на панели Properties, когда выбран пучок, задаются с помощью раскрывающегося списка Length Units на вкладке General панели Properties, когда в документе не выбран ни один объект.

Переназначение объектов пучка

Вы можете переназначать объекты пучка на чертеже компоновки, где провод может проходить более чем по одному пути между исходным и конечным разъемами. По умолчанию такой провод автоматически назначается кратчайшему пути пучка, но вы можете переопределить это поведение. Элемент управления Assign Objects to Bundle появляется в нижней части раздела Bundle Objects панели Properties (когда в рабочей области выбран Bundle) и только тогда, когда существует альтернативный путь трассировки. Открывается диалоговое окно Assign Objects to Bundle, в котором можно выбрать объекты (провода/кабели) для перемещения между соответствующими и допустимыми пучками.

Покрытие жгутовых пучков

Объект покрытия жгута (Place » Harness Covering) может быть размещен поверх жгутового пучка. Длину покрытия можно графически изменять в рабочей области во время или после размещения.

После выбора команды размещения покрытия жгута в рабочей области появится оранжевая точка, когда курсор находится над жгутовым пучком; это означает, что покрытие жгута можно разместить (серая точка означает, что покрытие жгута нельзя разместить в данном конкретном месте). Щелкните в точке, где должно начинаться покрытие, затем переместите курсор вдоль пучка к точке, где покрытие должно заканчиваться, и щелкните еще раз. Покрытия жгута могут перекрывать друг друга, как показано в видео ниже. Кроме того, вы можете применить/продлить покрытие жгута через точку соединения (точку соединения на чертеже компоновки, где сходятся два или более пучка). Это устраняет необходимость иметь отдельные покрытия жгута между точками соединения в секции, содержащей несколько разъемов.

Началом покрытия считается крайняя левая, верхняя точка его пути, и путь включает только те пучки, на которых лежит покрытие.

Свойства размещенного покрытия жгута можно настроить на панели Properties, когда покрытие жгута выбрано в рабочей области.

Панель Properties, когда выбрано покрытие жгута
Панель Properties, когда выбрано покрытие жгута

Вы можете задать размер объекта покрытия жгута относительно размера покрываемого им пучка (значения Line Width пучка) с помощью раскрывающегося списка Size на панели Properties. Пролистайте изображения ниже, чтобы увидеть примеры покрытий жгута разных размеров для различных размеров жгутовых пучков.

 
 
 
 
 
 

После размещения покрытия жгута на чертеже компоновки вы можете назначить ему библиотечный компонент (или, если компонент уже назначен покрытию жгута, выбрать другой компонент). Для этого выберите покрытие жгута и нажмите кнопку  справа от поля Design Item ID в области General панели Properties. В открывшемся диалоговом окне Replace найдите и выберите требуемый компонент. Размещенное покрытие жгута будет обновлено параметрами выбранного компонента.

Добавление меток компоновки

Физические метки могут быть размещены на чертеже компоновки (Place » Layout Label).

Свойства размещенной метки компоновки (ее позиционное обозначение, текст, визуальное представление и т. д.) можно настроить на панели Properties, когда метка компоновки выбрана в рабочей области.

Панель Properties, когда выбрана метка компоновки
Панель Properties, когда выбрана метка компоновки

При задании текста метки в поле Text используйте Ctrl+Enter или Shift+Enter для добавления новой строки текста. Включите Show only first line, чтобы отображать в рабочей области только первую строку поля Text. Текст метки компоновки также можно выровнять в соответствии с вашими потребностями с помощью элементов управления Alignment.

Javascript ID: Harness_LD_LayoutLabel_TextOptions_AD25
  • Чтобы отображать текст метки в BOM, можно включить столбец Label Text в документе ActiveBOM проекта () или в таблице BOM на производственном чертеже (). Обратите внимание, что свойство Type метки компоновки должно быть установлено в Standard, чтобы она отображалась в BOM ().

  • После размещения метки компоновки на чертеже компоновки вы можете назначить ей библиотечный компонент (или, если компонент уже назначен метке компоновки, выбрать другой компонент). Для этого выберите метку компоновки и нажмите кнопку  справа от поля Design Item ID в области General панели Properties. В открывшемся диалоговом окне Replace найдите и выберите требуемый компонент. Размещенная метка компоновки будет обновлена параметрами выбранного компонента.

Обновление объектов чертежа компоновки из библиотек

Следующие объекты могут быть обновлены из их исходной библиотеки Workspace:

  • Компоненты жгута

  • Части, связанные с компонентами жгута

  • Части, связанные с точками соединения

  • Покрытия жгута

  • Метки компоновки

Когда объект выбран, информация о связанном компоненте Workspace доступна на панели Properties (например, вкладка Associated Parts для частей, связанных с компонентом жгута, или область General для метки компоновки).

Если доступна более поздняя редакция компонента Workspace, запись о состоянии редакции будет отражать это с помощью текста Out of date. На уровне отдельного объекта связь можно обновить до последней редакции компонента Workspace, нажав кнопку .

Пример указания устаревшей редакции компонента жгута
Пример указания устаревшей редакции компонента жгута

Функцию Update from Libraries (Tools » Update from Libraries) также можно использовать для обновления устаревших компонентов, связанных с перечисленными выше объектами. Обратите внимание: чтобы объект был включен в обновление с использованием функции Update from Libraries, компонент, назначенный объекту, должен содержать ссылку на условное графическое обозначение.

Аннотирование объектов чертежа компоновки жгута

Используйте команды в меню Tools » Annotation, чтобы аннотировать следующие объекты в документе чертежа компоновки жгута:

  • Компоненты жгута

  • Точки соединения

  • Жгутовые пучки

  • Покрытия жгута

  • Метки компоновки

Аннотирование объектов в документе чертежа компоновки жгута аналогично аннотированию компонентов в документе схемы (*.SchDoc) проекта печатной платы. Чтобы узнать больше о командах аннотирования, доступных для документа чертежа компоновки жгута, воспользуйтесь следующими ссылками:

Перекрестное выделение между схемой соединений и чертежом компоновки

Поддерживается перекрестное выделение между схемой соединений и чертежом компоновки проекта жгута. Команда Cross Probe доступна в главном меню Tools и в контекстном меню в рабочей области.

Перекрестное выделение может выполняться:

  • Между компонентами на схеме соединений и чертеже компоновки.

  • От провода на схеме соединений к пучку(ам), через которые проходит этот провод на чертеже компоновки.

  • От пучка на чертеже компоновки к проводу(ам), проходящим через этот пучок на схеме соединений.

Javascript ID: Harness_CrossProbe_AD25

Перекрестное выделение от компонента на схеме соединений к соответствующему компоненту на чертеже компоновки.

Перекрестное выделение от компонента на чертеже компоновки к соответствующему компоненту на схеме соединений.

Перекрестное выделение от провода на схеме соединений к соответствующим пучкам на чертеже компоновки.

Перекрестное выделение от пучка на чертеже компоновки к соответствующим проводам на схеме соединений.

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Content