Создание посадочного места для печатной платы

Область, которую компонент занимает на изготовленной плате, определяется его посадочным местом. Типовое посадочное место включает контактные площадки и изображение компонента на слое шелкографии, а также может содержать любые другие необходимые механические элементы. В приведенном ниже примере посадочного места большая часть контура компонента задана на механическом слое (зеленые линии), а не на слое шелкографии (желтые линии), поскольку компонент будет установлен так, что часть его корпуса будет нависать над вырезом в плате.

Посадочное место определяет пространство, занимаемое компонентом, и задает точки подключения его выводов и контактных площадок к проводникам на плате. 
Посадочное место определяет пространство, занимаемое компонентом, и задает точки подключения его выводов и контактных площадок к проводникам на плате.

Компонент, устанавливаемый на это посадочное место, можно смоделировать с помощью объектов 3D-тело. Объект «3D-тело» служит контейнером, в который можно импортировать модель в одном из распространенных форматов MCAD, как показано на изображении ниже.

Подходящую модель MCAD можно импортировать в объект «3D-тело».
Подходящую модель MCAD можно импортировать в объект «3D-тело».

Несмотря на богатый выбор ресурсов с готовыми компонентами печатных плат (например, панель Manufacturer Part Search), скорее всего, на каком-то этапе работы вам потребуется создать собственный компонент печатной платы. Посадочные места компонентов создаются в редакторе посадочных мест с помощью того же набора примитивных объектов, который доступен в редакторе печатных плат. Помимо посадочных мест, в виде компонентов печатной платы можно сохранять логотипы компаний, элементы для оформления производства и другие объекты, необходимые при проектировании платы.

Создание нового посадочного места

Посадочные места можно создавать непосредственно в подключенном рабочем пространстве. Для этого:

  1. Выберите File » New » Library в главном меню, затем в открывшемся диалоговом окне New Library выберите Create Library Content » Footprint в области Workspace этого окна.

    Создание нового посадочного места в рабочем пространстве с помощью диалогового окна New Library
    Создание нового посадочного места в рабочем пространстве с помощью диалогового окна New Library

  2. В открывшемся диалоговом окне Create New Item введите необходимые сведения, убедитесь, что параметр Open for editing after creation включен, и нажмите OK. Посадочное место будет создано в рабочем пространстве, и откроется временный редактор посадочных мест с активным документом .PcbLib. Имя этого документа будет соответствовать ревизии элемента и иметь формат: <Item><Revision>.PcbLib (например, PCC-001-0001-1.PcbLib). Задайте посадочное место в этом документе, как описано ниже.

    Пример редактирования начальной ревизии посадочного места рабочего пространства: временный редактор посадочных мест предоставляет документ для создания посадочного места.
    Пример редактирования начальной ревизии посадочного места рабочего пространства: временный редактор посадочных мест предоставляет документ для создания посадочного места.

  3. Когда посадочное место будет готово, сохраните его в рабочем пространстве с помощью элемента управления Save to Server справа от записи посадочного места на панели Projects. Откроется диалоговое окно Edit Revision, в котором при необходимости можно изменить имя и описание, а также добавить примечания к выпуску. После сохранения документ и редактор закроются.

Сохраненное в рабочем пространстве посадочное место можно использовать при создании компонента в редакторе компонентов в режиме редактирования одного компонента или режиме пакетного редактирования компонентов.

Посадочные места рабочего пространства можно просматривать на панели Components. Включите отображение моделей, нажав кнопку  в верхней части панели и выбрав Models, затем выберите категорию Footprints.

Чтобы отредактировать посадочное место рабочего пространства, щелкните правой кнопкой мыши его запись на панели Components и выберите команду Edit. Снова откроется временный редактор с посадочным местом, доступным для редактирования. Внесите необходимые изменения, затем сохраните документ в качестве следующей ревизии посадочного места рабочего пространства.

 
 
 
 
 

При сохранении отредактированного посадочного места в рабочем пространстве можно сохранить его текущее состояние жизненного цикла. Для этого используется параметр Preserve lifecycle state (not recommended), доступный в диалоговом окне Create Revision при повторном сохранении (). Если этот параметр включен, новой ревизии посадочного места автоматически присваивается состояние жизненного цикла предыдущей ревизии. Эта возможность доступна пользователям, которым назначено разрешение на выполнение операции Allow to skip lifecycle state change for new revisions (подробнее см. в разделе Настройка глобальных разрешений на выполнение операций в рабочем пространстве).

  • Когда вы изменяете посадочное место рабочего пространства и сохраняете изменения в новой ревизии, все использующие его компоненты рабочего пространства фактически становятся устаревшими, поскольку продолжают использовать предыдущую ревизию. В большинстве случаев такие компоненты следует сохранить повторно, обновив соответствующие ссылки на модели до последних доступных ревизий. Чтобы упростить этот процесс, рабочее пространство совместно с Altium Designer позволяет обновлять родительские компоненты при повторном сохранении посадочного места после внесения в него изменений с помощью функции непосредственного редактирования.

    Подробнее об обновлении родительских компонентов при сохранении модели для определенной области проектирования см. на странице Создание и редактирование содержимого.

  • Кроме того, посадочное место, используемое компонентом рабочего пространства, можно обновить непосредственно в процессе редактирования этого компонента в редакторе компонентов в режиме редактирования одного компонента или режиме пакетного редактирования компонентов.

  • С точки зрения разработчика компонент рабочего пространства объединяет в одной сущности всю информацию, необходимую для представления компонента во всех областях проектирования. Поэтому его можно рассматривать как контейнер, в котором хранятся все модели для различных областей проектирования и параметрические данные. При этом компонент рабочего пространства содержит не сами модели, хранящиеся в рабочем пространстве, а ссылки на них. Эти ссылки задаются при создании компонента.

  • Посадочные места также можно создавать в рабочем пространстве при импорте существующих библиотек компонентов предыдущего поколения (SchLib, PcbLib, IntLib, DbLib, SVNDbLib). Интерфейс этого процесса — Library Importer — предлагает интуитивно понятную последовательность действий для импорта выбранных исходных библиотек в рабочее пространство. Подробнее см. в разделе Library Importer.

  • Новое посадочное место рабочего пространства также можно создать при создании компонента рабочего пространства в редакторе компонентов в режиме редактирования одного компонента.

  • Посадочное место также можно создать в составе файловой библиотеки посадочных мест.

Создание посадочного места

Посадочные места всегда создаются на верхней стороне платы независимо от того, на какой стороне они будут в итоге размещены, с помощью того же набора инструментов и объектов проектирования, который доступен в редакторе PCB. Атрибуты, привязанные к слоям, например контактные площадки для поверхностного монтажа и параметры паяльной маски, автоматически переносятся на соответствующие нижние слои, когда при размещении компонента вы переворачиваете посадочное место на другую сторону платы.

Объекты проектирования можно размещать на любом слое, однако контур обычно создают на слое Top Overlay (шелкография), а контактные площадки — на слое Multi-Layer (для выводов компонентов, монтируемых в отверстия) или на верхнем сигнальном слое (для выводов компонентов поверхностного монтажа). При размещении посадочного места на печатной плате все составляющие его объекты будут назначены заданным для них слоям.

Двумерный и трехмерный виды посадочного места джойстика. На трехмерном изображении показана импортированная STEP-модель компонента. Обратите внимание: под STEP-моделью видны контактные площадки и контур компонента на слое шелкографии.
Двумерный и трехмерный виды посадочного места джойстика. На трехмерном изображении показана импортированная STEP-модель компонента. Обратите внимание: под STEP-моделью видны контактные площадки и контур компонента на слое шелкографии.

Посадочные места, показанные на этой странице, служат только для иллюстрации необходимых процедур; их размеры не являются точными. Всегда сверяйте параметры нового посадочного места с технической документацией производителя.

Типичная последовательность ручного создания посадочного места компонента:

  1. Подготовьте рабочую область: задайте параметры привязки, настройте сетки и направляющие — подробнее.

  2. Посадочные места следует создавать вокруг опорной точки рабочей области, расположенной в центре редактора посадочных мест PCB. Эта опорная точка фактически является относительным началом координат рабочей области и точкой, за которую курсор захватывает посадочное место компонента при размещении и перемещении (в зависимости от текущего Object Snap Options на странице PCB Editor – General диалогового окна Preferences). Используйте сочетание клавиш J, R, чтобы перейти непосредственно к опорной точке. Если перед началом создания посадочного места вы забыли перейти к опорной точке, ее можно перенести к посадочному месту с помощью команд подменю Edit » Set Reference:
    • Pin 1 — установить опорную точку компонента на выводе 1 посадочного места.

    • Center — установить опорную точку компонента в центре посадочного места.

    • Location — установить опорную точку компонента в указанном пользователем месте.

    Выбранной точке будут присвоены координаты 0,0 — она станет новым относительным началом координат, и координаты всех примитивов будут пересчитаны относительно этой точки.

  3. Разместите контактные площадки (Place » Pad) в соответствии с требованиями к компоненту. После запуска команды Place Pad, но до размещения первой площадки, нажмите клавишу Tab, чтобы открыть панель Properties и задать все свойства площадки, включая Designator, Size and Shape, Layer и Hole Size (для площадки с металлизированным отверстием). Обозначение автоматически увеличивается при размещении каждой следующей площадки. Для площадки поверхностного монтажа задайте для Layer значение Top Layer. Для площадки с металлизированным отверстием задайте для Layer значение Multi-Layer.

    Для некоторых посадочных мест требуются площадки нестандартной формы. Их можно создать с помощью объектов контактных площадок с произвольной формой (Custom Shape). Подробнее см. на странице Настройка стека контактной площадки.
    • Одна из важнейших процедур при создании нового посадочного места компонента — размещение контактных площадок, к которым компонент будет припаян на печатной плате. Их необходимо расположить строго в нужных местах, соответствующих выводам физического компонента.
    • Также следует внимательно назначать обозначения площадок, поскольку именно это свойство Altium Designer использует для сопоставления с номерами выводов условного графического обозначения на схеме.
  4. Чтобы обеспечить точное размещение площадок, настройте сетку специально для этой задачи. Используйте сочетание клавиш Ctrl+G, чтобы открыть диалоговое окно Cartesian Grid Editor, и клавишу Q, чтобы переключить сетку с дюймовой системы на метрическую.

  5. Для точного размещения площадки при перемещении мышью используйте клавиши со стрелками, чтобы перемещать курсор с текущим шагом сетки. При удержании Shift перемещение выполняется с шагом, в 10 раз превышающим шаг сетки. Текущие координаты X, Y отображаются в строке состояния, а также на экранном индикаторе Heads Up Display. Этот индикатор показывает как текущие координаты, так и смещение от точки последнего щелчка до текущего положения курсора. Используйте сочетание клавиш Shift+H, чтобы включать и выключать Heads Up Display. Другой способ — дважды щелкнуть размещенную площадку и ввести требуемые координаты X и Y на панели Properties .

  6. Чтобы проверить расстояние между двумя точками рабочей области, используйте Reports » Measure Distance (сочетание клавиш Ctrl+M). Следуйте подсказкам в строке состояния.

  7. Атрибуты контактных площадок, такие как паяльная маска и маска паяльной пасты, рассчитываются автоматически на основе размеров площадок и применимых правил проектирования масок. Хотя параметры масок можно задать вручную для каждой площадки, это затрудняет их последующее изменение в процессе проектирования платы. Обычно так поступают только тогда, когда невозможно применить к нужным площадкам правила проектирования. Обратите внимание: правила задаются в редакторе PCB при проектировании платы.

  8. Используйте дорожки, дуги и другие примитивы, чтобы задать контур компонента, отображаемый на шелкографии платы на слое Top Overlay. Если при размещении компонент переворачивается на нижнюю сторону платы, его контур автоматически переносится на слой Bottom Overlay.

  9. Разместите дорожки и другие примитивы на механическом слое, чтобы задать дополнительные механические сведения, например зону размещения компонента (courtyard). Механические слои — это слои общего назначения. Следует определить назначение этих слоев и использовать их единообразно во всех посадочных местах.

  10. Разместите объекты 3D Body, чтобы задать трехмерную форму физического компонента, устанавливаемого на печатную плату.

    Объект 3D Body, добавленный в посадочное место, может ссылаться на 3D-модель, загруженную в подключенное рабочее пространство Workspace.
  11. Строки Designator и Comment автоматически добавляются на слой шелкографии посадочного места при его размещении в рабочей области PCB. Дополнительные строки Designator и Comment можно включить, разместив специальные строки .Designator и .Comment на механическом слое.

    При размещении строк Designator и Comment необходимо задать пару слоев (Layer Pair) в редакторе PCB. Это обеспечивает привязку строк к стороне платы, на которой установлен компонент, и их перенос на другую сторону платы при перевороте компонента. Подробнее см. раздел Учет особых требований, связанных со слоями ниже.
  12. Задайте свойства посадочного места (например, его имя и описание) на вкладке Footprint панели Properties в режиме Library Options (активен, когда в рабочей области не выбран ни один объект; доступен с помощью Tools » Footprint Properties команду в главном меню). Подробнее о параметрах и элементах управления на вкладке Footprint панели см. в разделе ниже.

  • Для использования стандартных определений контактных площадок и переходных отверстий во всех посадочных местах при их размещении можно использовать библиотеку контактных площадок и переходных отверстий (*.PvLib) — подробнее.
  • Редактор посадочных мест печатной платы также предоставляет несколько мастеров для ускорения создания посадочных мест:
    • IPC Compliant Footprint Wizard – создает посадочное место печатной платы, полностью соответствующее редакции B стандарта IPC 7351 — Generic Requirements for Surface Mount Design and Land Pattern Standard — подробнее.
    • IPC Compliant Footprints Batch Generator – при работе с файловой библиотекой посадочных мест печатной платы используйте IPC Compliant Footprints Batch Generator для быстрого создания нескольких посадочных мест с различными уровнями плотности — подробнее.
    • Footprint Wizard — позволяет выбрать один из различных типов корпусов и указать соответствующие данные, после чего создает посадочное место компонента — подробнее.

Подготовка рабочего пространства

По умолчанию сетки отображаются точками. При желании их можно отображать линиями. Это настраивается в диалоговом окне Grid Editor, которое открывается нажатием кнопки Properties на панели Properties, как показано на изображении ниже. Также можно использовать сочетание клавиш Ctrl+G, чтобы открыть это диалоговое окно.

На изображении мелкая сетка отображается точками, а крупная — линиями.
На изображении мелкая сетка отображается точками, а крупная — линиями.

Панель свойств

При редактировании посадочного места в редакторе посадочных мест печатной платы, если в рабочем пространстве не выбран ни один объект проекта, на панели Properties отображается Library Options.

Следующие раскрывающиеся разделы содержат информацию о параметрах и элементах управления на вкладке General панели:

В следующих раскрывающихся разделах приведена информация о параметрах и элементах управления, доступных на вкладке Footprint панели:

Возможность задавать свойства посадочного места на вкладке Footprint панели Properties доступна, когда в диалоговом окне Расширенные настройки включен параметр PCB.FootprintParameters. Если этот параметр отключен, свойства посадочного места задаются в диалоговом окне PCB Library Footprint (), которое можно открыть, выбрав команду Tools » Footprint Properties в главном меню, выбрав посадочное место в области Footprints панели PCB Library и нажав кнопку Edit либо дважды щелкнув посадочное место в области Footprints панели PCB Library.

При выборе объекта проекта на панели отображаются параметры, соответствующие типу этого объекта. В следующей таблице перечислены типы объектов, доступные для размещения в рабочей области редактора посадочных мест печатной платы. Нажмите ссылку, чтобы перейти на страницу свойств соответствующего объекта.

3D-тело Дуга
Дуга запрета размещения Заливка
Заливка запрета размещения Контактная площадка
Область Область запрета размещения
Текст (строка, текстовая рамка) Дорожка
Дорожка запрета размещения Переходное отверстие

Расширение паяльной маски и маски паяльной пасты

Чтобы проверить правильность задания паяльной маски и/или маски паяльной пасты в редакторе посадочных мест печатной платы, откройте панель View Configuration и включите отображение () для каждого слоя маски.

Кольцо, отображаемое по краю каждой контактной площадки цветом слоя Top Solder Mask, обозначает край фигуры паяльной маски, выступающей из-под многослойной контактной площадки на величину расширения, поскольку multi-layer находится в начале порядка отрисовки слоев и отрисовывается поверх остальных. Параметр Layer Drawing Order задается на странице PCB Editor — Display диалогового окна Preferences).

На изображении ниже показано посадочное место печатной платы с фиолетовой окантовкой (цвет слоя Top Solder Mask) по краю каждой контактной площадки.

Для быстрого переключения между слоями используйте режим одного слоя (Shift+S) в сочетании с Ctrl+Shift+Wheel roll.

По умолчанию фигура, создаваемая на слоях масок, повторяет форму контактной площадки с расширением или сжатием на величину, указанную в правилах проектирования Solder Mask Expansion и Paste Mask Expansion, заданных на печатной плате, на которой размещено посадочное место. В некоторых случаях может потребоваться переопределить правила расширения и задать расширение маски как атрибут контактной площадки, выбрать одну из стандартных предустановленных форм маски или создать собственную форму. В таких случаях можно настроить маску паяльной пасты и паяльную маску для выбранной контактной площадки на ее панели Properties — подробнее. Кроме того, можно разместить подходящие примитивы (области, дорожки и т. д.) на нужном слое маски.

В библиотеке печатных плат для всех объектов, расширение паяльной маски которых определяется правилами, значение расширения будет равно 0 мил. Эта функция доступна, когда параметр PCB.SolderMaskZeroExpansion включен в диалоговом окне Advanced Settings. Когда этот параметр отключен, значение расширения паяльной маски для таких объектов в библиотеке печатных плат составляет 4 мил.

Поддержка параметров

Параметры, назначаемые объектам в Altium Designer, — это мощный и гибкий инструмент для добавления дополнительной информации в проект печатной платы. Параметры являются свойствами родительского объекта и могут назначаться на различных уровнях, включая проекты, документы, шаблоны и отдельные объекты в документе проекта.

Подробнее см. в разделе Объект «Параметр».

Параметры, доступные в рабочей области печатной платы, можно использовать для фильтрации в запросах, правилах проектирования, скриптах и вариантах исполнения, а также в посадочных местах компонентов для вывода пользовательских строк в размещенных посадочных местах.

Передача параметров через извещение об изменении (ECO)

Работа с параметрами на печатной плате основана на функциях механизма ECO и документа печатной платы, которые позволяют передавать пользовательские параметры компонентов в рабочую область печатной платы и сохранять их там. Эта передача выполняется в одном направлении, и переданные параметры доступны на печатной плате только для чтения.

Для передачи параметров создается ECO из схемы на печатную плату с помощью команды меню Design » Update PCB Document.

При выполнении ECO (с помощью кнопки Execute Changes ) все новые пользовательские параметры компонентов схемы передаются соответствующему экземпляру посадочного места в проекте печатной платы. 

Обнаружение параметров и их перенос на печатную плату определяются настройками проекта (Project » Project Options). В диалоговом окне Project Options настройте обнаружение различий и порядок внесения изменений в разделе Differences Associated with Parameters на вкладке Comparator и в разделе Modifications Associated with Parameters на вкладке ECO Generation.

Чтобы просмотреть переданные параметры в редакторе печатных плат, дважды щелкните компонент, чтобы открыть панель Properties , затем выберите вкладку Parameters . На этой вкладке перечислены текущие пользовательские параметры, назначенные выбранному посадочному месту компонента. Параметры выбранного посадочного места компонента также доступны на панели Components .

Ссылки на справочную информацию

В рабочую область печатной платы автоматически передаются предопределенные параметры ComponentLink из схемы. Они задаются в виде пар параметров (описание и URL ссылки), которые обычно служат ссылками на справочную информацию в определенных файлах или в интернете — как правило, на сайт производителя или техническое описание.

Информацию о параметрах ссылок на справочные материалы см. в разделах Задание активных ссылок на справочную информацию в библиотеке схемных компонентов и Доступ к активным ссылкам на справочную информацию в документе печатной платы.

Как в рабочей области схемы, так и в рабочей области печатной платы ссылки доступны в контекстном меню, вызываемом правой кнопкой мыши при наведении указателя на компонент (в подменю References). Специальные параметры добавляются на панели Properties , а после передачи в рабочую область печатной платы отображаются как параметры посадочного места компонента. 

Параметры в исходных посадочных местах

Переданные на печатную плату параметры можно использовать для отображения дополнительной производственной или функциональной информации в посадочных местах компонентов. Если добавить специальные строки параметров в посадочные места на уровне исходной библиотеки, их значения будут подставлены на целевом механическом слое или слое шелкографии.

Специальную строку, представляющую пользовательский параметр, можно добавить в исходное посадочное место компонента с помощью кнопки специальных строк и раскрывающегося списка () на панели Properties .

В показанном ниже библиотечном посадочном месте специальная строка .Designator размещена на слое Mechanical 2.

Специальную строку, представляющую пользовательский параметр, можно добавить в посадочное место компонента.

Если этот пользовательский параметр также назначен компонентам схемы, а данные параметра переданы на печатную плату, строки посадочных мест с подставленными значениями будут отображаться как на виде платы, так и в сформированных выходных файлах. В данном случае специальная строка параметра содержит пользовательский идентификатор компонента, облегчающий сборку.

Использование пользовательских параметров в качестве специальных строк в посадочных местах компонентов позволяет удовлетворить и другие специфические требования к печатной плате, в том числе добавить обозначения функций переключателей и разъемов: строку параметра «функция» можно разместить на слое Top Overlay в посадочных местах компонентов этих типов.

Чтобы увидеть подставленные значения специальных строк на плате, включите параметр Special Strings в области Additional Options на вкладке View Options в View Configuration панель. Специальные строки всегда преобразуются в создаваемых выходных файлах.
При необходимости в редакторе схем включите параметр Display Names of Special Strings that have No Value Defined на странице Schematic – Graphical Editing диалогового окна Preferences.

Запросы к параметрам

Строки параметров в редакторе печатных плат также доступны через язык запросов Altium Designer, поэтому их можно использовать в функциях фильтрации объектов, включая функцию поиска похожих объектов.

Чтобы выбрать похожие объекты, щелкните компонент правой кнопкой мыши и выберите Find Similar Objects в контекстном меню, чтобы открыть диалоговое окно Find Similar Objects.

Диалоговое окно Поиск похожих объектов содержит раздел Parameters, в котором можно выбрать необходимые параметры фильтрации.

На панели PCB Filter можно применять ключевые слова запросов для работы с параметрами в качестве критериев фильтрации, а также создавать правила проектирования на основе параметров печатной платы.

Для работы с параметрами посадочных мест печатной платы доступен ряд ключевых слов запросов, в том числе специальные функции для преобразования строковых значений в числа (например, StrToNumber). При преобразовании строковых значений учитываются единицы измерения (В, мА, мВ, кОм и т. д.), что позволяет определять результат запроса путем числовой обработки строки значения параметра.

В запросах можно указывать следующие поддерживаемые типы единиц измерения:

  • % – Проценты
  • A – Ток
  • C – Температура
  • dB – Децибелы
  • F – Емкость
  • G – Электрическая проводимость
  • H – Индуктивность
  • Hz – Частота
  • Kg – Масса
  • m – Длина
  • Ohm – Сопротивление
  • Q – Заряд
  • s – Время
  • V – Напряжение
  • W – Мощность
  • Z – Импеданс

Для работы с параметрами посадочных мест компонентов печатной платы доступен ряд ключевых слов запросов к параметрам.

В примере, показанном в диалоговом окне Query Helper выше, обрабатывается параметр Voltage Rating каждого компонента (с преобразованием строки в число — StrToNumber(Unit Value, Unit Type)), чтобы определить, превышает ли его значение 50 В. При применении запроса на панели PCB Filter на плате из примера выявляется один высоковольтный компонент, C1 (у которого значение Voltage Rating равно 3 кВ.

Также поддерживается экспоненциальная запись с буквой E, поэтому, например, запрос для фильтрации конденсаторов с емкостью более 1 нФ будет выглядеть примерно так:
StrToNumber(ParameterValue('CapacitanceValue'), F) > 1e-9
Кроме того, функцию преобразования в число можно использовать как для возвращаемого значения ParameterValue, and так и для значения сравнения:
StrToNumber(ParameterValue('CapacitanceValue'), F) > StrToNumber('1nF', F)

Правила и скрипты

Запросы к параметрам печатной платы также можно использовать в скриптах и правилах проектирования Altium Designer. С помощью правил можно выполнять проверки топологии, например определять параметры посадочных мест для оценки размещения компонентов или назначения слоев. Обратите внимание, что функции, перечисленные в диалоговом окне Query Helper выше, доступны в языке скриптов.

В приведенном ниже примере запрос номинального напряжения конденсатора (см. запрос фильтра выше) применяется к правилу размещения компонентов. При выполнении это правило проверяет заданные значения зазоров для компонентов, определенных как высоковольтные устройства (>50V).

Правила проектирования, заданные на основе определенных параметров посадочных мест, переданных из схемы, можно использовать для выявления нестандартных условий в топологии.

Аналогичным образом пользовательские параметры печатной платы можно использовать для проверки допустимости размещения компонентов на определенных слоях — например, если компонент не поддерживает пайку волной припоя и поэтому не может размещаться на нижнем слое. В этом случае запрос соответствия объектов, обрабатывающий пользовательский параметр WaveSoldering (Yes/No), можно применить к правилу допустимых слоев.

Затем при пакетной проверке правило проверит значение этого параметра компонента и зафиксирует нарушение, если компонент нельзя размещать на нижнем слое.

Варианты

Параметры, переданные на печатную плату и включенные в варианты исполнения проекта (Варианты исполнения проекта), обрабатываются в соответствии с выбранным вариантом.

На практике изменяемый в зависимости от варианта параметр компонента на печатной плате будет динамически определяться строкой запроса или, например, отображаться на слое платы с помощью специальной строки. 

Пользовательские параметры посадочных мест

Эта функция доступна, если параметр PCB.FootprintParameters включен в диалоговом окне Расширенные настройки.

Altium Designer поддерживает пользовательские параметры посадочных мест. Область Parameters на вкладке Footprint панели Properties  в режиме Library Options  позволяет просматривать и редактировать параметры посадочного места, когда в рабочей области редактора посадочных мест печатных плат не выбран ни один объект.

После размещения компонента на печатной плате эти параметры можно просмотреть на панели Properties  в режиме Component  на вкладке Parameters .

  • Параметры посадочных мест компонентов, размещенных на печатной плате, передаются в посадочные места в библиотеках, создаваемых с помощью команды Make PCB Library или Make Integrated Library главного меню редактора печатных плат.
  • Параметры посадочных мест поддерживаются механизмом сравнения Altium Designer, а также при формировании выходных данных Pick and Place и ODB++.
Altium MCAD CoDesigner поддерживает размещение собственных компонентов MCAD в MCAD-системе в соответствии с настроенными связями. В некоторых случаях с одним компонентом связывают несколько посадочных мест с разными моделями (например, светодиод, который можно установить на печатную плату двумя способами: вертикально, с прямыми выводами, или горизонтально, с изогнутыми выводами). Теперь с помощью параметров посадочных мест можно задавать ссылки на разные модели MCAD для этих посадочных мест. Подробнее см. в разделе Связывание собственных компонентов проектов ECAD и MCAD.

Строки позиционного обозначения и комментария

Строки позиционного обозначения и комментария по умолчанию

При размещении посадочного места на плате ему присваиваются позиционное обозначение и комментарий на основе данных, полученных из схемы проекта. Заполнители для строк позиционного обозначения и комментария не требуется задавать вручную: они добавляются автоматически при размещении посадочного места на плате. Расположение этих строк определяется параметром Autoposition  строки позиционного обозначения или комментария на панели Properties в режиме Parameter , когда соответствующая строка выбрана в рабочей области. Положение и размер строк позиционного обозначения и комментария по умолчанию настраиваются для соответствующего примитива на странице Редактор печатных плат — Значения по умолчанию диалогового окна Preferences .

Дополнительные строки позиционного обозначения и комментария

В некоторых случаях могут потребоваться дополнительные копии строк позиционного обозначения или комментария. Например, вашему сборочному производству нужен подробный сборочный чертеж с позиционным обозначением внутри контура каждого компонента, а ваша компания требует, чтобы на готовой плате позиционное обозначение располагалось непосредственно над компонентом в слое шелкографии. Добавить такое дополнительное позиционное обозначение можно, включив в посадочное место специальную строку .Designator. Также доступна специальная строка .Comment, позволяющая задать положение строки комментария на других слоях или в других местах.

Чтобы выполнить требования сборочного производства, строку .Designator следует разместить на механическом слое в редакторе посадочных мест печатных плат. Затем можно сформировать распечатки с этим слоем и включить их в инструкции по сборке изделия.

Учет особых требований к слоям

К компоненту печатной платы может предъявляться ряд особых требований, например необходимость нанесения точки клея или задания области снимаемой паяльной маски. Многие из этих требований зависят от стороны платы, на которой установлен компонент, и при переносе компонента на другую сторону платы соответствующие объекты также должны переноситься на другую сторону.

Вместо большого количества специализированных слоев, которые могут использоваться лишь изредка, редактор печатных плат Altium Designer поддерживает эту возможность с помощью функции пар слоев. Пара слоев — это два механических слоя, объединенных в пару. При переносе компонента с одной стороны платы на другую все объекты на парном механическом слое переносятся на другой механический слой этой пары. При таком подходе вы выбираете подходящий механический слой для размещения точки клея (или объектов, связанных с другими особыми требованиями) и задаете ее форму с помощью доступных объектов. При размещении такого посадочного места на плате необходимо настроить пары слоев. Это указывает программе, на какой слой следует переносить объекты при переносе компонента на другую сторону платы. Задать пары слоев в редакторе посадочных мест нельзя; это выполняется в редакторе печатных плат.

Пары слоев необходимо определить before переноса компонента на другую сторону платы. Если пара определена после переноса компонента на нижнюю сторону, объекты механического слоя будут отражены, но останутся на исходном слое. Если вы забыли создать пары слоев до переноса, можно выполнить обновление из библиотеки, чтобы обновить экземпляр компонента, размещенный на плате.

Имена механических слоев можно редактировать непосредственно на панели View Configurations: щелкните правой кнопкой мыши и выберите Edit Layer.

Распространенный подход к использованию механических слоев — назначение отдельного номера слоя для каждой требуемой функции механического слоя. При таком подходе все разработчики должны придерживаться единой схемы назначения и нумерации слоев. Это также может создавать трудности при использовании компонентов из других источников, в которых применяется иная схема назначения и нумерации. Если использовалась другая схема, объекты проекта необходимо переместить с текущего механического слоя на механический слой, назначенный для соответствующей функции.

Эта проблема решается благодаря свойству Layer Type. Когда компонент размещается из библиотеки в редакторе печатных плат, копируется из одной библиотеки в другую или создается с помощью IPC Footprint Wizard, существующие назначения типов слоев автоматически сопоставляются независимо от номеров механических слоев, которым назначены эти типы. Объекты перемещаются на нужные слои в соответствии с типом слоя. Если программе не удается выполнить сопоставление по типу слоя, она выполняет сопоставление по номеру слоя.

Как для отдельных механических слоев, так и для пар слоев компонентов можно выбрать тип слоя из предопределенного списка. Чтобы открыть показанные ниже диалоговые окна, щелкните правой кнопкой мыши по отдельному слою и выберите в меню команду Edit Layer или Add Component Layer.

Подробную информацию о типах механических слоев, связанных с компонентами, см. на странице Работа с механическими слоями.

Добавление высоты в посадочное место печатной платы

Самый простой способ трехмерного представления — добавить в посадочное место информацию о высоте. Для этого откройте панель Properties в режиме Library Options (он активен, когда в рабочей области не выбран ни один объект) и введите рекомендуемую высоту компонента в поле Height на вкладке Footprint этой панели.

Правила проектирования для высоты можно задать при разработке платы (нажмите Design » Rules в редакторе печатных плат). Обычно они проверяют максимальную высоту компонентов определенного класса или в пределах заданной области размещения.

Более эффективный способ задать информацию о высоте — добавить к посадочному месту 3D-тела.

Управление компонентами с примитивами трассировки

При передаче проекта посадочное место, указанное для каждого компонента, извлекается из доступных библиотек и размещается на плате. Затем свойству цепи каждой контактной площадки посадочного места присваивается имя цепи, подключенной к соответствующему выводу компонента на схеме. Все объекты, соприкасающиеся с контактной площадкой, подключаются к той же цепи, что и площадка.

Редактор печатных плат включает многофункциональный инструмент управления цепями. Чтобы запустить его, выберите Design » Netlist » Configure Physical Nets в главном меню: откроется диалоговое окно Configure Physical Nets. Нажмите кнопку Menu, чтобы открыть меню параметров. Откройте раскрывающийся список в заголовке New Net Name, чтобы выбрать цепь для назначения примитивам, которым цепь еще не назначена.

Посадочные места с несколькими контактными площадками, подключенными к одному выводу

Показанное ниже посадочное место транзистора в корпусе SOT223 содержит несколько контактных площадок, подключенных к одному и тому же логическому выводу компонента на схеме — выводу 2. Для реализации этого соединения добавлены две контактные площадки с одинаковым обозначением — «2». При использовании команды Design » Update PCB в редакторе схем для передачи проектных данных на печатную плату в результате синхронизации в редакторе печатных плат линии связи будут идти к обеим контактным площадкам, то есть они будут принадлежать одной цепи. Обе площадки можно трассировать.

Посадочное место SOT223 с двумя контактными площадками с обозначением 2.
Посадочное место SOT223 с двумя контактными площадками с обозначением 2.

Подготовка шелкографии

Для устранения типичных проблем технологичности изготовления (DFM), связанных с наложением шелкографии на открытую медь и отверстия, редактор посадочных мест содержит специальный инструмент подготовки шелкографии. Эти проблемы можно эффективно устранить с помощью:

  • автоматической обрезки линий и дуг шелкографии;
  • автоматической обрезки или перемещения заливок и областей;
  • автоматического перемещения текстовых строк шелкографии.
Инструмент подготовки шелкографии также доступен при проектировании печатной платы — подробнее.

Чтобы открыть инструмент подготовки шелкографии в редакторе посадочных мест, выберите команду Tools » Silkscreen Preparation в главном меню. Откроется диалоговое окно Silkscreen Preparation.

В этом диалоговом окне можно настроить параметры обрезки и перемещения объектов шелкографии. Доступны следующие параметры:

  • Clip to Exposed Copper — включите для автоматической обрезки объектов по границам открытой меди.
  • Clip to Solder Mask Openings — включите для автоматической обрезки объектов по границам окон в паяльной маске.
  • Silkscreen Clearance — задайте минимально допустимый зазор между объектами шелкографии и открытой медью, окнами в паяльной маске и отверстиями.
  • Min Remaining Length – если длина линии/дуги после обрезки меньше заданного значения, объекты будут удалены из посадочного места. Обратите внимание, что эта длина измеряется между вершинами, а не между краями – показать изображение.
  • Move Text – включите, чтобы отодвигать текстовые строки шелкографии от открытой меди / окон паяльной маски и отверстий, если расстояние между ними меньше Silkscreen Clearance. Перемещение ограничивается значением Max Distance.
  • Fill & Region – выберите действие для заливок и областей, если расстояние между ними и открытой медью / окнами паяльной маски и отверстиями меньше Silkscreen Clearance:
    • None – заливки и области остаются без изменений.
    • Clip – заливки и области будут обрезаны для соблюдения Silkscreen Clearance. При необходимости заливки преобразуются в области.
    • Move – заливки и области будут отодвинуты от открытой меди / окон паяльной маски и отверстий. Перемещение ограничивается значением Max Distance.
  • Max Distance – задайте максимальное расстояние, на которое можно перемещать текстовые строки, позиционные обозначения компонентов, заливки и области для соблюдения Silkscreen Clearance.

Нажмите OK, чтобы выполнить обрезку и/или перемещение объектов шелкографии в соответствии с настройками диалогового окна.

Если действие невозможно выполнить для объекта (например, текстовую строку нельзя переместить из-за ограничения Max Distance), сообщение об этом объекте появится на панели Messages.

Ниже показан пример работы инструмента подготовки шелкографии.

Javascript

Создание посадочного места с помощью мастера посадочных мест, соответствующих IPC

IPC Compliant Footprint Wizard создает посадочное место печатной платы, полностью соответствующее редакции B стандарта IPC 7351 — Generic Requirements for Surface Mount Design and Land Pattern Standard. Вместо непосредственного использования размеров посадочного места (как это делает мастер посадочных мест), IPC Compliant Footprint Wizard использует данные о размерах самого компонента, а затем рассчитывает подходящие параметры контактных площадок и другие параметры посадочного места в соответствии с алгоритмами, опубликованными IPC.

Вместо ввода параметров контактных площадок и дорожек, из которых формируется посадочное место, Wizard использует в качестве исходных данных фактические размеры компонента. Затем на основе формул, разработанных для стандарта IPC-7351, Wizard создает посадочное место с использованием стандартных объектов Altium Designer, таких как контактные площадки и дорожки.

  • Это диалоговое окно соответствует редакции B стандарта IPC 7351 — «Общие требования к проектированию поверхностного монтажа и стандарт на посадочные места». Стандарт IPC-7351B был выпущен в 2010 году и заменяет IPC-7351A (выпущенный в 2007 году).

  • Для доступа к IPC Compliant Footprint Wizard в Altium Designer необходимо установить программное расширение IPC Footprint Generator. По умолчанию это расширение устанавливается вместе с Altium Designer. Его можно установить или удалить вручную.

    Дополнительные сведения об управлении расширениями см. на странице Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Чтобы запустить IPC Compliant Footprint Wizard, выберите Tools » IPC Compliant Footprint Wizard в главном меню документа библиотеки печатных плат.

На странице Select Component Type выберите семейство компонентов, для которого требуется создать посадочное место на странице Select Component Type. Область предварительного просмотра в правой части мастера динамически обновляется, отображая выбранный компонент, а также указывает типы корпусов, которые можно создать. В следующей таблице перечислены типы компонентов и корпусов, поддерживаемые мастером.

Название Описание Поддерживаемые корпуса
BGA Корпус с матрицей шариковых выводов BGA, CGA
BQFP Плоский четырехсторонний корпус с защитными выступами BQFP
CAPAE Алюминиевый электролитический конденсатор CAPAE
CFP Керамический плоский двухсторонний корпус с обрезанными и сформованными выводами типа «крыло чайки» CFP
Сборка чип-компонентов Сборка чип-компонентов Сборка чип-компонентов
DFN Плоский двухсторонний безвыводной корпус DFN
CHIP Чип-компоненты с двумя выводами Конденсатор, катушка индуктивности, резистор
CQFP Керамический плоский четырехсторонний корпус с обрезанными и сформованными выводами типа «крыло чайки» CQFP
DPAK Корпус транзистора DPAK
LCC Безвыводной корпус микросхемы LCC
LGA Корпус с матрицей контактных площадок LGA
MELF Компоненты MELF с двумя выводами Диод, резистор
MOLDED Компоненты в формованном корпусе с двумя выводами Конденсатор, катушка индуктивности, диод
PLCC Квадратный пластиковый корпус микросхемы с J-образными выводами PLCC
PQFN Плоский четырехсторонний безвыводной корпус с контактами, утопленными относительно края корпуса PQFN
PQFP Пластиковый плоский четырехсторонний корпус PQFP, PQFP с открытой контактной площадкой
PSON Малогабаритный безвыводной корпус с контактами, утопленными относительно края корпуса PSON
QFN Плоский четырехсторонний безвыводной корпус QFN, LLP
QFN-2ROW Квадратный плоский четырехсторонний безвыводной корпус с двумя рядами контактов Двухрядный QFN
SODFL Малогабаритный корпус диода с плоскими выводами SODFL
SOIC Малогабаритный корпус интегральной схемы с шагом 1,27 мм и выводами типа «крыло чайки» SOIC, SOIC с открытой контактной площадкой
SOJ Малогабаритный корпус с J-образными выводами SOJ
SON Малогабаритный безвыводной корпус SON, SON с открытой контактной площадкой
SOP, TSOP Малогабаритный корпус с выводами типа «крыло чайки» SOP, TSOP, TSSOP
SOT143/343 Малогабаритный корпус транзистора SOT143, SOT343
SOT223 Малогабаритный корпус транзистора SOT223
SOT23 Малогабаритный корпус транзистора 3 вывода, 5 выводов, 6 выводов
SOT89 Малогабаритный корпус транзистора SOT89
SOTFL Малогабаритный корпус транзистора с плоскими выводами 3 вывода, 5 выводов, 6 выводов
WIRE WOUND Прецизионная проволочная катушка индуктивности с двумя выводами Катушка индуктивности

Последующие страницы мастера меняются в зависимости от выбранного типа компонента. Следуйте указаниям на интуитивно понятных страницах мастера, чтобы настроить посадочное место конкретного компонента в соответствии с требованиями. Несколько замечаний по работе с IPC Compliant Footprint Wizard:

  • Все размеры в мастере вводятся в метрических единицах (мм).

  • Габаритные размеры корпуса, сведения о выводах, расстояние между пятками выводов, параметры паяных галтелей и допуски можно вводить и сразу просматривать результат.

    Изменение допусков IPC может привести к созданию посадочных мест печатной платы, не соответствующих требованиям IPC.

  • Можно задать механические размеры, включая границу размещения (Courtyard), сборочный контур (Assembly) и данные о 3D-теле компонента.

  • В Wizard можно возвращаться к предыдущим шагам, что упрощает проверку и внесение изменений.

  • Предварительный просмотр посадочного места доступен на каждом этапе. Для каждого типа компонента область Preview динамически обновляется, отображая новое положение, размеры и другие параметры при изменении ряда настроек. В области Preview можно нажать  или  для переключения между 2D- и 3D-представлениями.

  • При необходимости можно просмотреть 3D-модель STEP перед ее созданием. После выбора типа компонента нажмите Generate STEP Model Preview на любой странице Wizard, чтобы увидеть предварительный просмотр 3D-модели STEP в области Preview.

  • Для корпусов с большой теплоотводящей площадкой (размером 2,1 мм × 1,6 мм или больше) окна маски паяльной пасты разделяются на небольшие области заполнения.

  • Для корпусов с выводами типа «крыло чайки» контактные площадки укорачиваются, чтобы они не заходили под тело корпуса.

  • Для небольших корпусов с большой центральной теплоотводящей площадкой периферийные контактные площадки укорачиваются, чтобы обеспечить требуемый зазор между площадками в соответствии со стандартом IPC.

  • При укорачивании контактных площадок в диалоговом окне отображается предупреждение.

  • Имя и описание посадочного места предлагаются автоматически на основе данных, введенных в Wizard , но их можно изменить в соответствии с требованиями организации.

  • В соответствии со стандартом IPC мастер поддерживает три варианта посадочных мест (_L, _N, _M), каждый из которых предназначен для определенной плотности монтажа на плате.

  • Кнопку Finish можно нажать на любом этапе, чтобы создать посадочное место, отображаемое в области предварительного просмотра. Если нажать Finish до завершения всех шагов Wizard, посадочное место будет создано с использованием системных значений по умолчанию для выбранного типа компонента.

  • При работе с файловой библиотекой посадочных мест используйте генератор пакетного создания посадочных мест по стандарту IPC для быстрого создания нескольких посадочных мест с разными уровнями плотности монтажа.

При запуске мастера из файловой библиотеки посадочных мест доступна страница Footprint Destination, на которой можно выбрать место сохранения созданного посадочного места — показать изображение:

  • Выберите Existing PcbLib File, если хотите сохранить посадочное место в существующем файле библиотеки посадочных мест. Можно указать файл непосредственно в текстовом поле или использовать  для открытия диалогового окна поиска нужного файла.
  • Выберите New PcbLib File, если хотите сохранить посадочное место в новом файле библиотеки посадочных мест. Введите имя нового файла библиотеки в текстовом поле. Система добавит к имени нового файла библиотеки расширение .PcbLib.
  • Выберите Current PcbLib File, чтобы сохранить посадочное место в указанном файле библиотеки посадочных мест.
  • Включите Produce 3D/STEP model, чтобы создать 3D-модель STEP.
  • Если у вас есть действующая лицензия 'MCAD Co-Designer - SOLIDWORKS(R)', можно сохранить модель в файле типа Parasolid. Откройте раскрывающийся список справа от Format и выберите Parasolid. Теперь в текстовом поле External File указан файл *.x_t. Это имя и расположение файла, который будет сохранен.
  • Выберите Embedded (по умолчанию) или External File. Выберите External File, чтобы сохранить 3D-модель STEP во внешнем файле. По умолчанию используется тип файла STEP, а имя файла отображается в текстовом поле External File с расширением *.step. При необходимости нажмите  для выбора папки, в которой будет сохранена созданная 3D-модель STEP.

Создание посадочного места с помощью мастера посадочных мест

Редактор посадочных мест включает Footprint Wizard. Этот Wizard позволяет выбрать один из различных типов корпусов и ввести соответствующие данные, после чего создаст посадочное место компонента. Обратите внимание: в Footprint Wizard необходимо указать требуемые размеры контактных площадок и контура компонента на слое шелкографии.

Чтобы запустить Footprint Wizard, выберите Tools » Footprint Wizard в главном меню или щелкните правой кнопкой мыши в рабочей области и выберите команду Tools » Footprint Wizard в контекстном меню.

На странице Component patterns укажите тип компонента, который хотите создать. Выберите нужный тип из списка, затем в раскрывающемся списке выберите единицы измерения для компонента (Imperial (mil) или Metric (mm)). Доступны следующие типы:

  • Ball Grid Arrays (BGA)
  • Capacitors
  • Diodes
  • Dual In-line Packages (DIP)
  • Edge Connectors
  • Leadless Chip Carriers (LCC)
  • Pin Grid Arrays (PGA)
  • Quad Packs (QUAD)
  • Resistors
  • Small Outline Packages (SOP)
  • Staggered Ball Grid Arrays (SBGA)
  • Staggered Pin Grid Arrays (SPGA)

Последующие страницы мастера меняются в зависимости от выбранного типа компонента. Следуйте интуитивно понятным страницам мастера, чтобы настроить посадочное место конкретного компонента нужным образом.

При настройке схемы именования контактных площадок для посадочного места типа Edge Connectors, Leadless Chip Carriers (LCC) или Quad Packs (QUAD) нажмите зеленую стрелку, чтобы изменить порядок или направление именования — показать изображение.

Создание отчета о компоненте

Чтобы создать отчет об активном посадочном месте, выберите команду Reports » Component в главном меню. После запуска команды отчет (<PCBLibraryDocumentName>.CMP) будет создан в той же папке, что и исходный документ библиотеки посадочных мест, и автоматически открыт как активный документ в главном окне проектирования. В отчете приведены размеры посадочного места, перечень составляющих его примитивных объектов и слои, на которых они расположены.

Отчет будет добавлен на панель Projects как свободный документ в подпапку Documentation\Text Documents.

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents