Определение логической структуры устройства из нескольких электронных модулей

Краткий обзор

Узнайте, как описать логическую структуру многоплатной системы в Altium Designer, связав дочерние проекты печатных плат с модулями на схеме многоплатной системы. В этой статье объясняется, как подготовить разъёмы для описания соединений на уровне системы, задать источники и свойства модулей, а также импортировать данные о контактах и цепях разъёмов для заполнения точек подключения модулей. Читайте дальше, чтобы начать создавать наглядное представление межплатных соединений вашей системы.

- Изучите этапы создания схемы многоплатной системы и привязки модулей к дочерним проектам печатных плат.
- Узнайте, как параметр `System:Connector` определяет разъёмы, которые будут включены в проект на уровне системы.
- Узнайте, как проверять дочерние проекты печатных плат и импортировать данные об их соединениях в точки подключения модулей.
Узнайте больше с ИИ:

Основные этапы создания схемы многоплатной системы на основе дочерних проектов печатных плат:

  1. Создайте проект многоплатной системы и добавьте в него документ многоплатной схемы.

  2. Разместите на многоплатной схеме графические блоки (модули), логически представляющие дочерние проекты печатных плат.

  3. Свяжите каждый модуль с соответствующим дочерним проектом.

  4. Импортируйте данные о соединениях дочерних проектов в проект многоплатной системы.

  5. Добавьте соединения между модулями, чтобы сформировать логическую структуру системы.

Чтобы добавить документ многоплатной схемы (*.MbsDoc) в проект многоплатной системы, щелкните правой кнопкой мыши запись проекта на панели Projects и выберите Add New to Project » Multi-board Schematic в контекстном меню.

Каждый проект многоплатной системы может содержать только один документ многоплатной схемы.

Подготовка проектов печатных плат к проектированию многоплатных систем

Проекты печатных плат Altium Designer, представляющие дочерние платы в проекте многоплатной системы, содержат специальные соединительные элементы, например краевые разъемы или штыревые вилки и розетки, которые служат электрическим и механическим интерфейсом для подключения к другим печатным платам системы.

Эти соединительные элементы и связанные с ними электрические цепи должны распознаваться и обрабатываться в документе многоплатной (логической) схемы, чтобы установить межплатные соединения на уровне системы. Эта возможность обеспечивается наличием у разъемов в проекте печатной платы специального параметра компонента с именем System и значением Connector.

Разъемы с парой «параметр:значение» System:Connector распознаются при синхронизации каждого модуля системы с его дочерним проектом печатной платы с помощью команды Import from Child Projects. Подробнее об этом рассказывается далее, в разделе Представление дочерних проектов печатных плат на многоплатной схеме.

Для каждого разъема в проекте печатной платы, предназначенного для межсоединений на уровне системы, выберите компонент разъема и добавьте специальный параметр компонента в список в области Parameters на вкладке General панели Properties, отображаемой при выбранном компоненте.

Подробнее о свойствах компонентов см. на странице Работа с размещенными компонентами.

Наличие параметра с именем System и значением Connector связывает этот разъем печатной платы с многоплатной схемой.
Наличие параметра с именем System и значением Connector связывает этот разъем печатной платы с многоплатной схемой.

Представление дочерних проектов на многоплатной схеме

Соединения между проектами печатных плат, составляющими проект многоплатной системы, задаются путем размещения на схеме представляющих их блоков (модулей) и связывания их доступных разъемов (входов модулей) с помощью соединений.

Модули, представляющие дочерние проекты печатных плат и конкретные платы в их составе, размещаются в рабочей области с помощью меню Place » Module.

Чтобы задать источник для размещенного модуля, выберите его в рабочей области и на панели Properties нажмите кнопку , связанную с полем Project в области Source на вкладке General. Откроется диалоговое окно Choose Project (разновидность диалогового окна Open Project), в котором можно найти и выбрать проект печатной платы или многоплатной системы в качестве источника модуля. После выбора нужного проекта выберите в раскрывающемся списке Assembly/Board нужную печатную плату или многоплатную сборку из этого проекта.

Сформированный проект многоплатной системы имеет иерархическую структуру документов, включающую исходные документы и дочерние подпроекты, связанные с модулями на схеме системы. Структура дочернего проекта добавляется в проект многоплатной системы сразу после связывания модуля системы с этим внешним проектом. Разверните структуру проекта на панели Projects, чтобы увидеть файлы, входящие в проект многоплатной системы и его дочерние проекты.

Чтобы проект многоплатной системы извлекал и обрабатывал корректные данные из своих подпроектов, печатная плата каждого проекта должна быть синхронизирована с его схемой и не содержать ошибок проектирования или оформления. Для проверки подпроекта печатной платы щелкните его имя на панели правой кнопкой мыши и выберите команду Validate PCB Project <ProjectName>.PrjPcb — все обнаруженные проблемы будут перечислены на панели Messages.

Javascript ID: Pnl_Properties_MBS_Module_Source
 
 
 
 
 
  • Проект печатной платы, другой многоплатной системы или жгута можно добавить в структуру проекта многоплатной системы. Для этого щелкните правой кнопкой мыши запись последнего на панели Projects, выберите команду Add Existing to Project, затем найдите и выберите соответствующий локальный файл *.PrjPcb, *.PrjMbd или *.PrjHar. Если проект печатной платы или жгута, который требуется включить в проект многоплатной системы, уже открыт в Altium Designer, можно перетащить его запись на панели Projects на запись родительского проекта многоплатной системы, добавив его в структуру (). После этого вручную разместите новый модуль в документе многоплатной схемы родительского проекта и, выбрав этот модуль, укажите для него источник в раскрывающемся списке поля Source на панели Properties: дочерний проект печатной платы (и его документ печатной платы) либо дочерний проект многоплатной системы (и его документ многоплатной сборки) (). Проект жгута можно синхронизировать с проектом многоплатной системы (подробнее см. на странице Определение схемы соединений).

  • Чтобы удалить дочерний проект печатной платы или многоплатной системы из структуры родительского проекта многоплатной системы, удалите из документа многоплатной схемы родительского проекта все модули, ссылающиеся на этот дочерний проект. После этого дочерний проект будет автоматически удален из структуры.

  • Дочерний проект печатной платы или жгута также можно удалить из структуры родительского проекта многоплатной системы, перетащив запись дочернего проекта за пределы этой структуры. Обратите внимание: в этом случае (только для проекта печатной платы) модули, ссылающиеся на дочерний проект, останутся в документе многоплатной схемы, а их связи с дочерним проектом сохранятся. Чтобы полностью очистить родительский проект многоплатной системы от удаленного дочернего проекта, удалите эти модули вручную.

Выделив размещенный модуль, используйте панель Properties для настройки других его свойств:

  • Используйте свойства Designator и Title в области Properties на вкладке General панели, чтобы задать позиционное обозначение модуля на схеме и строку заголовка соответственно. Используйте кнопку  справа от соответствующего поля, чтобы включить или отключить его видимость на многоплатной схеме, и кнопку , чтобы разрешить или запретить редактирование значения. С помощью элементов управления шрифтом и Other настройте шрифт строки, ее положение в документе, а для строки заголовка — также видимость имени параметра.

  • Таблица в области Entries на вкладке General панели Properties при выделенном модуле будет заполняться по мере добавления в модуль точек подключения — см. ниже.

  • Используйте элементы управления в области Graphical на вкладке General панели, чтобы настроить отображение модуля: его размер (ширину и высоту), толщину, стиль и цвет линии контура модуля, а также цвет заливки. Доступные варианты толщины и стиля линии задаются в области Line Styles панели Properties, когда в рабочей области не выделено ни одного объекта. Дополнительные сведения см. на странице Настройка документа многоплатной схемы.

  • Используйте элементы управления на вкладке Parameters панели для добавления, изменения и удаления параметров модуля, а также настройки их видимости в рабочей области.  

При необходимости добавьте в многоплатную схему другие модули и ссылки на их дочерние проекты, чтобы охватить всю проектируемую систему.

Модули заполняются проектными данными из связанных с ними проектов путем импорта данных с помощью следующих команд главного меню или контекстного меню рабочей области:

  • Design » Import From Child Projects — передать проектные данные из всех исходных (дочерних) проектов в соответствующие модули.

  • Design » Import From Selected Child Projects — передать проектные данные из соответствующих исходных (дочерних) проектов для выделенного модуля или модулей.

Прежде всего при этом обрабатываются данные о выводах и цепях каждого разъема в дочерних проектах, которому назначен специальный параметр System:Connector (подробнее см. выше). После завершения импорта для каждого из этих разъемов автоматически создается точка подключения на графическом блоке соответствующего модуля. Точка подключения разъема связана с выводами и цепями разъема в дочернем проекте. Выделите графическое изображение точки подключения модуля в рабочей области, чтобы просмотреть сведения о ней, например выводы и цепи разъема, на панели Properties. Пока точка подключения не соединена с точкой подключения другого модуля, разъем и его выводы в списке компонентов и выводов на панели будут отображаться как несоединенные.

 
  • Хотя точки подключения размещаются автоматически при импорте данных из дочерних проектов, точку подключения модуля также можно разместить вручную, выбрав команду Place » Entry в главном меню.

  • Выделите точку подключения модуля, щелкнув по ее графическому изображению, а затем перетащите ее вдоль периметра модуля в подходящее место. Обратите внимание, что обозначение точки подключения можно независимо перетащить в другое положение.

  • Также можно переместить группу точек подключения модуля: выделите несколько точек подключения, а затем перетащите группу в нужное место.

  • Цвет точки подключения помогает правильно переместить и разместить ее. За пределами модуля точка подключения отображается частично и серым цветом, а ее размещение невозможно. Над модулем точка подключения отображается полностью и в цвете, что указывает на возможность размещения в этом месте.

Выделив точку подключения, используйте панель Properties для настройки ее свойств:

  • Используйте элементы управления в области Properties на вкладке General панели, чтобы изменить значение, видимость и стиль Designator точки подключения, а также выбрать ее Type (Male/Female). В этой области панели также отображаются количество выводов разъема точки подключения (Number of Pins) и идентификационный номер, присвоенный этой точке подключения в родительском модуле (Entry Number).

  • Включите параметр System Entry, чтобы обозначить точку подключения как соединение уровня системы, не подключенное к другому модулю, например точку подключения, представляющую входной разъем питания.

    В дочернем многоплатном проекте есть модуль, у точки подключения которого включен параметр System Entry.

    При импорте изменений в родительский многоплатный проект этот разъем будет добавлен как точка подключения модуля дочернего проекта.

     
  • Если точка подключения соединена с помощью жгута или кабеля (подробнее), область Mated Component панели заполняется данными о соединенном компоненте.

  • В Mated Pins области панели столбец Pin содержит список отдельных контактов разъема и связанных с ними цепей. После подключения этого входа в столбце Mated Pin появляется список ответных контактов. Кроме того, после подключения этого входа на вкладке Addresses панели Properties появляется таблица путей соединений и цепей для данного входа (подробнее).

  • Используйте элементы управления на вкладке Parameters панели для добавления, изменения и удаления параметров входа, а также для настройки их видимости в рабочей области.

При добавлении входов в модуль они отображаются в таблице области Entries на вкладке General панели Properties, когда модуль выбран. В столбце Part(s) каждый вход модуля представлен обозначением и именем разъема входа в исходном проекте. Для удобства это имя можно изменить: оно используется только в многоплатном проекте и не влияет на исходные дочерние проекты.

  • Столбец Mated part(s) заполняется данными после подключения входа к другому входу в многоплатном проекте с помощью соединения. Дополнительные сведения см. на странице Работа с соединениями.

  • В списке можно быстро переключить видимость обозначения входа (  /  ) и его тип (  /  ). Используйте кнопки  и , чтобы соответственно добавить новый неопределенный вход в модуль и список или удалить выбранный в списке вход из модуля.

  • Используйте кнопки  и , чтобы соответственно разделить выбранное в списке соединение на два связанных входа модуля или снова объединить ранее разделенные входы в один. Дополнительные сведения см. на странице Работа с соединениями.

Поддержка внешних периферийных устройств и компонентов

Эта функция доступна, если параметры MBS.PlacePart и MBS.UseGeometryMaker включены в диалоговом окне Advanced Settings.

Документ многоплатной схемы поддерживает внешние периферийные устройства и компоненты, которые не входят в состав обычных дочерних сборок печатных плат (то есть компоненты вне печатных плат). К ним могут относиться, например, внешние переключатели, датчики и любые другие готовые электронные модули сторонних производителей. Эта возможность реализована благодаря поддержке двух типов объектов:

  • Custom Part — объект, подобный модулю, который позволяет связать один или несколько библиотечных компонентов и добавляется в документ многоплатной схемы с помощью команды Place » Custom Part главного меню. Выбрав размещенную пользовательскую часть в рабочей области, используйте область Linked Components панели Properties для добавления компонентов в пользовательскую часть и их удаления с помощью кнопок  и  соответственно. Если список связанных компонентов содержит устаревшие компоненты Workspace, нажмите кнопку , чтобы обновить их до последних ревизий. Для каждого связанного компонента автоматически добавляется вход.

  • Custom Connection — позволяет добавить один библиотечный компонент в документ многоплатной схемы, перетащив нужный компонент из панели Components на свободное место листа. Для каждого вывода компонента автоматически добавляется вход.

    Также можно создать пользовательское условное обозначение компонента специально для использования в документе многоплатной схемы. Указав в поле Name свойств вывода несколько имен через запятую, можно сгруппировать несколько выводов во входы. Это позволяет создавать визуально более простые обозначения с меньшим количеством входов, значительно упрощая подключение таких компонентов.

    Javascript ID: MBS_CustomConn_MultiplePins_AD24_5

    При редактировании условного обозначения компонента укажите в поле Name вывода несколько имен через запятую.

    При добавлении компонента в пользовательскую часть на многоплатной схеме вместо одного входа для всего компонента будут созданы входы для каждого вывода компонента, в том числе входы с несколькими выводами.

    При размещении компонента на многоплатной схеме в качестве пользовательского соединения будут созданы входы с несколькими выводами.

Библиотечные компоненты — это компоненты, доступные в подключенном Workspace и доступных локальных библиотеках. После размещения или определения компонентов их можно подключить к остальной части проекта, например с помощью кабельных и жгутовых соединений.

Связанные компоненты, определенные с помощью пользовательских частей и/или пользовательских соединений, не включаются автоматически в общую спецификацию изделия или системы и не отображаются в многоплатной сборке (*.MbaDoc).

Перекрестный переход

Команды перекрестного перехода, доступные в главном меню Design и контекстном меню рабочей области, позволяют быстро переходить из документа многоплатной схемы к связанным элементам в дочерних проектах.

  • Чтобы перейти от выбранного модуля или входа к документу печатной платы или разъему в этом документе в рамках проекта печатной платы, на который ссылается модуль, используйте команду Design » Crossprobe to PCB/Multi-board. Если модуль ссылается на документ многоплатной сборки (*.MbaDoc) в исходном многоплатном проекте (*.PrjMbd), переход будет выполнен к документу многоплатной сборки.

  • Чтобы перейти от выбранного модуля или входа к схеме верхнего уровня или разъему на соответствующей схеме в рамках проекта печатной платы, на который ссылается модуль, используйте команду Design » Crossprobe to Schematic.

  • Чтобы перейти от выбранного модуля или входа к плате или разъему на этой плате в документе многоплатной сборки (*.MbaDoc) в многоплатном проекте (*.PrjMbd), используйте команду Design » Crossprobe to MBA.

  • Чтобы перейти от выбранного жгутового соединения в документе многоплатной схемы (*.MbsDoc) к связанному проекту жгута (*.PrjHar), используйте команду Design » Crossprobe to Harness. Откроется документ монтажной схемы соответствующего проекта жгута.

При перекрестном переходе от входа модуля объекты в целевом документе схемы или печатной платы отображаются в соответствии с параметрами Highlight Methods, заданными на странице System – Navigation в Preferences диалоговом окне. Подсветка не будет применена к документу схемы многоплатной системы.

Печать или экспорт в PDF

Чтобы распечатать текущий активный документ схемы многоплатной системы, выберите File » Print в главном меню (сочетание клавиш: Ctrl+P). Откроется диалоговое окно Print . В левой части диалогового окна отображается масштабируемое изображение предварительного просмотра печати. В правой части диалогового окна доступны стандартные параметры печати. Они позволяют выбрать принтер, проверить его расположение, просмотреть количество документов в очереди печати, задать количество копий, размер страницы и её ориентацию. После нажатия комплект документов будет отправлен на выбранное печатающее устройство в соответствии с заданными параметрами.

Диалоговое окно Print
Диалоговое окно Print

Чтобы экспортировать документ схемы многоплатной системы в файл PDF, выберите File » Export to PDF в главном меню.

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents