Определение конструкции устройства из нескольких электронных модулей

Altium Designer поддерживает создание многоплатной сборки, называемой multi-board assembly. После определения логической структуры системы в многоплатной схеме (*.MbsDoc) физическая многоплатная конструкция затем создается путем переноса проекта системы в пустой документ многоплатной сборки (*.MbaDoc). В ходе этого процесса в редактор многоплатной сборки будет загружено физическое представление (PCB и другие многоплатные сборки), на которое ссылается каждый логический блок в многоплатной схеме. На этой странице рассматривается данный процесс.

Чтобы узнать больше о стадии логического проектирования многоплатной сборки, см. страницу Capturing the Logical System Design.

Многоплатные проекты и связанные с ними подпроекты можно сохранять в подключенном Workspace, где для них будут доступны возможности контроля версий, совместного использования и управления, предоставляемые Altium 365 Workspace или Enterprise Server Workspace.

Сведения о хранении и совместном использовании многоплатного проекта в Altium 365 Workspace см. на странице Workspace Projects .

Чтобы создать новый документ многоплатной сборки:

  1. Добавьте новый документ многоплатной сборки (*.MbaDoc) в многоплатный проект, щелкнув правой кнопкой мыши по записи проекта в панели Projects, а затем выбрав Add New to Project » Multi-board Assembly в контекстном меню.

    Каждый проект многоплатной конструкции может включать только один документ многоплатной сборки.

  2. Сохраните новый документ многоплатной сборки (щелкните правой кнопкой мыши по его записи в панели Projects и выберите Save As в контекстном меню).

  3. Перенесите логическое представление системы из многоплатной схемы в документ многоплатной сборки – подробнее.

  4. Если корпус доступен, загрузите его в сборку – подробнее.

  5. Расположите каждый элемент внутри сборки – подробнее см. на странице Positioning & Orienting Your Boards.

  6. Соедините элементы в сборке с помощью сопряжений – подробнее см. на странице Working with Mates.

Пример многоплатной сборки. Несколько соединенных PCB размещены внутри корпуса.
Пример многоплатной сборки. Несколько соединенных PCB размещены внутри корпуса.

Opening a Multi-board Assembly Created in Altium Designer 18

Многоплатные сборки, созданные в Altium Designer 18, необходимо импортировать из-за изменений формата файла, требовавшихся для поддержки 3D-движка и улучшенного набора функций. При открытии документа многоплатной сборки старого формата откроется диалоговое окно Legacy document import.

Выберите команду Design » Import в редакторе многоплатной сборки, чтобы сгенерировать ECO, которые перезагрузят дочерние модули.

Обратите внимание, что из-за изменений формата файла, необходимых для поддержки улучшенного набора функций и 3D-движка, многоплатную сборку, сохраненную в более поздней версии Altium Designer, невозможно открыть в Altium Designer 18.

Редактор Multi-board Assembly использует библиотеку Open CASCADE для геометрического моделирования многоплатной сборки. Обратите внимание, что при открытии более старого документа многоплатной сборки (из предыдущей версии ПО) созданные сопряжения будут удалены (можно выбрать сохранение относительных положений частей сборки или размещение их в линию). При открытии у вас будет возможность создать резервную копию этой старой версии.

Эта функция находится в состоянии Open Beta и доступна, когда в диалоговом окне Advanced Settings dialog включен параметр System.MBAEngine.UseOpenCascade.

Перенос проекта системы в документ Multi-board Assembly

Многоплатная конструкция переносится из многоплатной схемы в документ многоплатной сборки с помощью одной из следующих команд:

  • Design » Update Assembly - <MultiBoardAssemblyDocumentName>.MbaDoc из главного меню редактора многоплатной схемы.

  • Design » Import Changes From <MultiBoardProjectName>.PrjMbd из главного меню редактора многоплатной сборки.

При запуске одной из этих команд программа анализирует каждый модуль на многоплатной схеме, определяет PCB/сборку, выбранную для каждого из дочерних проектов, и выводит список изменений, необходимых для добавления каждой из этих плат в сборку, в диалоговом окне Engineering Change Order.

Плата из каждого PCB-проекта отображается как изменение ECO и загружается в редактор Multi-board Assembly при выполнении ECO.
Плата из каждого PCB-проекта отображается как изменение ECO и загружается в редактор Multi-board Assembly при выполнении ECO.

После нажатия кнопки  платы/сборки загружаются в редактор многоплатной сборки. Каждая плата/сборка размещается в пространстве проекта в той же ориентации, что и в дочернем проекте. Этот процесс займет некоторое время, поскольку необходимо проанализировать и загрузить полный набор данных для каждой PCB.

Платы этой многоплатной сборки загружены в пространство проекта редактора многоплатной сборки и готовы к размещению.
Платы этой многоплатной сборки загружены в пространство проекта редактора многоплатной сборки и готовы к размещению.

  • С помощью параметров на странице Multi-board Assembly – General page диалогового окна Preferences можно настроить, следует ли импортировать свободные 3D-тела из дочерних PCB и следует ли не импортировать 3D-тела, высота которых меньше указанного значения.

  • Используйте команду View » Toggle Units из главного меню (или сочетание клавиш Q), чтобы переключать единицы измерения между британскими и метрическими.

Добавление дополнительных объектов в многоплатную сборку

Вы также можете загружать в многоплатную сборку дополнительные объекты (помимо PCB, на которые есть ссылки в многоплатной схеме). Дополнительные объекты можно загрузить с помощью меню Design или кнопок, расположенных в верхней части панели Multi-board Assembly.

Каждый объект или элемент в многоплатной сборке называется part.

Используйте соответствующую команду или кнопку, чтобы:

  • Insert PCB Part () – вставить в эту сборку еще одну PCB.

  • Insert MBA Part () – вставить в эту сборку еще одну многоплатную сборку.

  • Insert STEP Part () – вставить в эту сборку механическую модель в формате STEP.

  • Обратите внимание, что деталь вставляется в многоплатную сборку как единый объект. Например, если вы вставите STEP-модель корпуса, состоящего из верхней и нижней половин, вы не сможете манипулировать этими половинами независимо. В такой ситуации необходимо вставлять каждую половину в сборку по отдельности.

  • Вставленная сборка или PCB not добавляется в проект Multi-board Design (*.PrjMbd), и поэтому не отображается как дочерний элемент этого проекта в панели Projects.

Обновление или редактирование части сборки

Блокировка/разблокировка части

Чтобы заблокировать/разблокировать часть, выберите нужную часть, щелкните правой кнопкой мыши, а затем выберите команду Lock Selected Part/Unlock Selected Part в контекстном меню, чтобы заблокировать/разблокировать часть (или сопряженные части) в ее текущем положении в пространстве проекта редактора сборки. Либо щелкните правой кнопкой мыши по записи части в панели Multiboard Assembly, затем выберите Locked.

  • Заблокированную часть нельзя редактировать/перемещать.

  • Заблокированные части помечаются значком замка в панели Multiboard Assembly .

  • Для заблокированной отдельной части не отображается гизмо объекта (подробнее о гизмо объекта см. на странице Positioning & Orienting Your Boards). Заблокированную часть нельзя использовать в сопряжении, если она выбрана как источник (перемещаемый объект — подробнее о сопряжении частей см. на странице Working with Mates).

Обновление части

Если часть или 3D-тело, добавленные в сборку, были обновлены, это обновление можно загрузить в многоплатную сборку с помощью одного из следующих действий:

  • Выберите команду Edit » Update All Parts в главном меню или щелкните правой кнопкой мыши в любом месте пространства проекта и выберите команду Update All Parts в контекстном меню (сочетание клавиш: Shift+Ctrl+U), чтобы обновить все части в активной многоплатной сборке с использованием актуальной информации о компоновке из соответствующих дочерних документов PCB.

  • Выберите нужную часть(и) и выполните команду Edit » Update Selected Part из главного меню или щелкните правой кнопкой мыши в любом месте пространства проекта и выберите команду Update Selected Part в контекстном меню (сочетание клавиш: Ctrl+U), чтобы обновить выбранные части в активной многоплатной сборке с использованием актуальной информации о компоновке из соответствующих дочерних документов PCB.

  • Выберите нужное 3D-тело и выполните команду Edit » Update Selected 3D Body из главного меню или щелкните правой кнопкой мыши в любом месте пространства проекта и выберите команду Update Selected 3D Body в контекстном меню, чтобы обновить выбранные 3D-тела в активной многоплатной сборке с использованием актуальной информации о компоновке из соответствующих дочерних документов PCB.

Редактирование части

Сеанс редактирования сборки или PCB можно запустить из редактора многоплатной сборки. Выберите нужную часть и выполните команду Edit » Edit Selected Part или щелкните правой кнопкой мыши в любом месте пространства проекта и выберите команду Edit Selected Part в контекстном меню (сочетание клавиш: Ctrl+E). После запуска команды вы перейдете в режим редактирования части, при этом выбранная PCB будет увеличена и центрирована (где это возможно) так, чтобы поместиться в главном окне проекта. Плата останется отображаться в полном цвете, а все остальные платы будут показаны серым цветом (только для чтения).

Внесите необходимые изменения в размещение компонентов, используя ручное размещение и/или функции выравнивания. Когда вы закончите редактирование, используйте команду Finish Part Editing (Ctrl+E). Вид пространства проекта вернется к отображению всех плат сборки, при этом плата, которая редактировалась, останется выбранной.

Если вы хотите отменить редактирование без применения каких-либо изменений, используйте команду Cancel Part Editing .

Навигация и управление многоплатной сборкой

Для навигации и управления многоплатной сборкой можно использовать панель Multiboard Assembly.

Панель представляет раскрывающееся древовидное представление полной структуры сборки, включая:

  • Включенные платы (PCB) и многоплатные сборки, а также компоненты, слои и цепи в каждой PCB

  • Включенные модели STEP

  • Другие включенные многоплатные сборки

  • Сопряжения, созданные между объектами в сборке

Подсветка элементов в многоплатной сборке

Панель Multiboard Assembly предоставляет возможности подсветки: часть, выбранная в дереве, подсвечивается в пространстве проекта. Для выборок, сделанных на верхнем уровне дерева сборки, подсветка является двунаправленной; например, состояние выбора записей в панели будет изменяться в ответ на выбор объектов верхнего уровня в пространстве проекта. В панели поддерживается выбор на всех уровнях дерева, где это логично. Например, выбор отдельной цепи подсветит эту цепь по всей плате, но выбор отдельного диэлектрического слоя не подсветит этот слой. Для множественного выбора в панели можно использовать стандартные сочетания клавиш Windows Shift+Click или Ctrl+Click.

Три платы, выбранные в пространстве проекта, также подсвечены в панели.
Три платы, выбранные в пространстве проекта, также подсвечены в панели.

Подсветка из панели — отличный способ найти определенную часть или проследить путь набора цепей, проходящих под дочерней платой.

Управление видимостью и прозрачностью частей сборки

Помимо подсветки определенной части или частей, панель также может использоваться для управления видимостью и прозрачностью частей, выбранных в данный момент в панели. Щелкните правой кнопкой мыши по выбранной части(ям), затем выберите Visible или Transparent в контекстном меню. Прозрачные части станут полупрозрачными. Части, для которых параметр Visible отключен, будут скрыты.

Javascript ID: MBA_Pnl_MultiboardAssembly_PartVisibility

Модель STEP полностью видима в сборке.

Та же модель была сделана прозрачной.

Та же модель была полностью скрыта.

Вы также можете управлять видимостью PCB, компонента PCB или модели STEP непосредственно в пространстве проекта.

  • Для целого объекта, такого как PCB или модель STEP, выберите объект, затем щелкните правой кнопкой мыши, чтобы открыть контекстное меню, и выберите параметр Visible, чтобы скрыть объект. Для восстановления видимости используйте панель Multi-board Assembly.

  • Для компонента PCB выберите PCB в пространстве проекта, щелкните правой кнопкой мыши и выберите Edit Selected Part. Затем щелкните правой кнопкой мыши по любому компоненту на этой плате и выберите команды Visible или Transparent в контекстном меню. Когда вы закончите настраивать видимость компонентов на этой плате, снова щелкните по ней правой кнопкой мыши и выберите Finish Editing Part или Cancel Editing Part.

Измерение расстояния

Команда Tools » Measure Distance из главного меню (сочетание клавиш: Ctrl+M) используется для измерения расстояний между 3D-телами в многоплатной сборке. После запуска команды вы перейдете в режим измерения. Измерение выполняется следующим образом:

  1. Выберите первый 3D-объект или конкретную грань этого объекта. При перемещении курсора над возможным 3D-объектом его цвет будет изменяться. Если вы хотите выбрать конкретную грань объекта, удерживайте клавишу Ctrl  при перемещении курсора — грань, находящаяся в данный момент под курсором, будет подсвечена. Установив курсор, щелкните для подтверждения выбора объекта/грани.

  2. Выберите второй 3D-объект или конкретную грань этого объекта.

  3. Инструмент визуально показывает кратчайшее расстояние между двумя выбранными объектами (гранями).

  4. Продолжайте измерять расстояние между другими объектами/гранями или нажмите Esc для выхода из режима измерения.

  • Все результаты измерений в ходе активного сеанса измерения отображаются в панели Messages . Вы можете дважды щелкнуть по записи, чтобы выполнить перекрестный переход к соответствующему измерению в пространстве проекта.

  • После завершения сеанса измерения все визуальные измерения будут очищены вместе со всеми записями измерений в панели Messages .

  • При наведении курсора на 3D-тело (или его грань) цвет изменится на заданный для системного цвета Highlight Under Cursor в разделе System Colors панели View Configuration.

Проверка коллизий

Коллизии отмечаются всякий раз, когда поверхности двух объектов соприкасаются или пересекаются.

Чтобы проверить наличие коллизий, выберите Tools » Check Collisions (сочетание клавиш: Ctrl+K). После запуска команды программа проверяет коллизии между различными объектами, входящими в многоплатную сборку. Сначала каждая плата проверяется на коллизии с верхней и нижней частями корпуса/кожуха (STEP-деталями), после чего выполняется проверка между самими платами (PCB).

Все коллизии будут показаны в панели Messages , а проблемные объекты будут подсвечены с использованием системного цвета Violation. Используйте область Details панели Messages, чтобы определить, какой компонент на плате, участвующей в конфликте, вызывает коллизию.

При необходимости нарушения коллизий, подсвеченные в пространстве проекта после выполнения проверки коллизий, можно очистить, выбрав команду Tools » Clear Violations .

  • Проверка коллизий выполняется между всеми платами и частями корпуса/кожуха независимо от видимости платы/части в пространстве проекта.

  • Сопряженные поверхности не считаются находящимися в коллизии.

Поддержка rigid-flex

Редактор многоплатной сборки поддерживает rigid-flex PCB. Rigid-flex — это название печатной платы, представляющей собой комбинацию как гибких, так и жестких схем. Редактор многоплатной сборки отображает PCB в конечном сложенном состоянии, как оно определено в редакторе PCB.

Сведения о проектировании rigid-flex PCB см. на странице Designing a Rigid-Flex PCB.

Экспорт в MCAD

Сборку можно экспортировать в формате STEP 3D или Parasolid. Чтобы экспортировать всю сборку в STEP 3D (*.step или *.stp), выберите File » Export » STEP 3D  в главном меню. Чтобы экспортировать всю сборку в формате Parasolid (*.x_t), выберите File » Export » Parasolid в главном меню.

Пример файла STEP многоплатной сборки, открытого в инструменте MCAD.
Пример файла STEP многоплатной сборки, открытого в инструменте MCAD.

Многоплатную сборку также можно синхронизировать между Altium Designer и поддерживаемым инструментом MCAD с помощью функциональности Altium MCAD CoDesigner.

Чтобы узнать больше, см. страницу Synchronizing a Multi-board Assembly.

Экспорт в PDF 3D

Документ многоплатной сборки также можно экспортировать в файл PDF (*.pdf). Для этого выберите команду File » Export to PDF File в главном меню.

Дополнительные сведения см. на странице Preparing a PDF3D File.

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Content