Горячие клавиши редактора Draftsman

Краткий обзор

Эта статья — краткий справочник по сочетаниям клавиш и действиям мышью, используемым в редакторе Draftsman в Altium Designer. В ней объясняются обозначения сочетаний клавиш и основные действия мышью, а доступные команды сгруппированы по категориям: стандартные сочетания клавиш, сочетания клавиш для интерактивных операций и сочетания клавиш для всплывающих меню. Это поможет вам быстро находить нужные команды для редактирования, выбора и перемещения объектов, настройки вида, работы с сетками, поиска текста и доступа к меню. Если вы хотите быстрее ориентироваться и работать в Draftsman, не тратя время на поиск команд в меню, это руководство поможет вам действовать увереннее и эффективнее. Читайте дальше, чтобы усовершенствовать свой рабочий процесс.

- Изучите сочетания клавиш Draftsman для повседневных действий: редактирования, выбора и перемещения объектов, масштабирования и управления сеткой.
- Узнайте, какие сочетания клавиш доступны всегда, а какие работают только во время интерактивных операций, например при размещении или перемещении объектов.
- Найдите сочетания клавиш для быстрого доступа к всплывающим меню и командам форматирования, которые помогут ускорить работу в редакторе Draftsman.
Узнайте больше с ИИ:

В следующих разделах представлены сочетания клавиш, специфичные для редактора Draftsman. Общие сведения о сочетаниях клавиш, включая доступ к ним и их редактирование, общие сочетания клавиш среды Altium и клавиши быстрого доступа, см. в разделе Сочетания клавиш Altium Designer.

При просмотре списков сочетаний клавиш учитывайте следующее:

  • В обозначениях сочетаний клавиш символ «плюс» (+) означает удержание нескольких клавиш на клавиатуре в указанной последовательности. Например, Shift+F1 означает, что нужно удерживать клавишу Shift, а затем нажать клавишу F1. Аналогично, Shift+Ctrl+PgUp означает, что нужно удерживать клавишу Shift , затем, не отпуская ее, удерживать клавишу Ctrl и нажать клавишу PgUp.

  • При использовании стандартных кнопок мыши Click означает однократное нажатие левой кнопки мыши, Double-Click — двойное нажатие левой кнопки мыши, а Right-Click — однократное нажатие правой кнопки мыши.

Стандартные сочетания клавиш

Следующие сочетания клавиш являются стандартными для редактора Draftsman. Они доступны в обычном режиме и не требуют запуска интерактивной операции.

Общее редактирование

Double-Click Изменить свойства объекта, находящегося под курсором.
Right-Click Открыть контекстное меню рабочей области. Если выполняется интерактивная команда, прервать текущую операцию.
Ctrl+C Копировать выделенное.
Ctrl+X Вырезать выделенное.
Ctrl+V Вставить выделенное.
Delete Удалить выделенное.
Ctrl+Z Отменить действие.
Ctrl+Y Повторить действие.

Выделение

Click Выделить объект, находящийся под курсором.
Shift+Click На объекте — добавить его к текущему выделению (накопительное выделение).
Ctrl+A Выделить все объекты в текущем документе.
Click (вне объектов), Hold&Drag (слева направо) Выделить все объекты, полностью попадающие в область выделения.
Click (вне объектов), Hold&Drag (справа налево) Выделить все объекты, полностью попадающие в область выделения или пересекаемые ее границей.
Shift+Tab Переключаться между выделением компонента и перекрывающего его позиционного обозначения на сборочном виде платы.

Перемещение

Click (на объекте), Hold&Drag

Переместить отдельный объект, находящийся под курсором (или группу выделенных объектов, если объект входит в эту группу).

Left Arrow Переместить текущее выделение (один или несколько выделенных объектов проекта) влево в рабочей области текущего документа с шагом в одну единицу сетки привязки.
Shift+Left Arrow Переместить текущее выделение (один или несколько выделенных объектов проекта) влево в рабочей области текущего документа с шагом в 10 единиц сетки привязки.
Right Arrow Переместить текущее выделение (один или несколько выделенных объектов проекта) вправо в рабочей области текущего документа с шагом в одну единицу сетки привязки.
Shift+Right Arrow Переместить текущее выделение (один или несколько выделенных объектов проекта) вправо в рабочей области текущего документа с шагом в 10 единиц сетки привязки.
Up Arrow Переместить текущее выделение (один или несколько выделенных объектов проекта) вверх в рабочей области текущего документа с шагом в одну единицу сетки привязки.
Shift+Up Arrow Переместить текущее выделение (один или несколько выделенных объектов проекта) вверх в рабочей области текущего документа с шагом в 10 единиц сетки привязки.
Down Arrow Переместить текущее выделение (один или несколько выделенных объектов проекта) вниз в рабочей области текущего документа с шагом в одну единицу сетки привязки.
Shift+Down Arrow Переместить текущее выделение (один или несколько выделенных объектов проекта) вниз в рабочей области текущего документа с шагом в 10 единиц сетки привязки.

Просмотр листа Draftsman

Ctrl+PgDn Изменить масштаб в рабочей области так, чтобы активный документ Draftsman был виден целиком (если это возможно). Если документ содержит несколько листов, особенно если их очень много, отобразить весь документ целиком может быть невозможно. В этом случае программа попытается отобразить максимально возможную часть документа, совместив его центр с центром рабочей области.
PgUp Увеличить масштаб относительно текущего положения курсора.

Для увеличения масштаба области документа также можно использовать мышь одним из следующих способов (если применимо и в зависимости от назначения кнопок мыши):

  • Удерживая клавишу Ctrl , прокрутите колесо мыши вверх. Использование клавиши Ctrl задано по умолчанию; эту настройку можно изменить на странице System – Mouse Wheel Configuration диалогового окна Preferences.

  • Удерживая клавишу Ctrl и правую кнопку мыши, переместите мышь вперед.

  • Нажмите и удерживайте колесо мыши, затем переместите мышь вперед.

PgDn Уменьшить масштаб относительно текущего положения курсора.

Для уменьшения масштаба области документа можно использовать мышь одним из следующих способов (если применимо и в зависимости от назначения кнопок мыши):

  • Удерживая клавишу Ctrl , прокрутите колесо мыши вниз. Использование клавиши Ctrl задано по умолчанию; эту настройку можно изменить на странице System – Mouse Wheel Configuration диалогового окна Preferences.

  • Удерживая клавишу Ctrl и правую кнопку мыши, переместите мышь назад.

  • Нажмите и удерживайте колесо мыши, затем переместите мышь назад.

Mouse Wheel Прокрутить рабочую область по вертикали. Эта настройка задана по умолчанию; ее можно изменить на странице System – Mouse Wheel Configuration диалогового окна Preferences.
Shift+Mouse Wheel Прокрутить рабочую область по горизонтали. Эта настройка задана по умолчанию; ее можно изменить на странице System – Mouse Wheel Configuration диалогового окна Preferences.
Right-Click, Hold&Drag Отобразить курсор в виде руки для панорамирования, затем перетащить его, чтобы изменить отображаемую часть рабочей области.

Сетки

G Открыть диалоговое окно Snap Grid, чтобы задать нужный шаг сетки.
Shift+Ctrl+G Включить или выключить отображение сетки в текущем документе.
Ctrl+Shift Временно отключить сетку при размещении или перемещении объекта.
Shift+E Включить или выключить привязку.

Поиск текста

Ctrl+F Найти текст.
F3 Найти следующее вхождение искомого текста.

Прочее

Shift+Ctrl+C Скопировать форматирование выделенного текстового объекта (заголовка или примечания). Также можно выделить текстовый объект, форматирование которого требуется скопировать, и выполнить команду Format Painter из главного меню Edit.
Shift+Ctrl+V Применить форматирование, скопированное из ранее выделенного текстового объекта, к текущему выделенному текстовому объекту (заголовку или примечанию). Если команда Format Painter была запущена из главного меню Edit, достаточно щелкнуть по каждому дополнительному заголовку или примечанию, чтобы применить скопированное форматирование.
F11 Включить или выключить отображение панели Properties.

Сочетания клавиш для интерактивных операций

Следующие сочетания клавиш становятся доступны после запуска интерактивной операции, например размещения нового объекта проекта или перемещения существующего. Обратите внимание, что доступные сочетания клавиш зависят от интерактивной команды и конкретного объекта проекта, с которым она работает.

PgUp Увеличить масштаб.
PgDn Уменьшить масштаб.
X Зеркально отразить перемещаемый объект относительно оси X.
Y Зеркально отразить перемещаемый объект относительно оси Y.
Esc Выйти из текущего процесса — завершить текущий этап выполняемой интерактивной команды или саму команду.
Spacebar

Повернуть перемещаемый объект против часовой стрелки. Поворот выполняется с шагом 90°.

Shift+Spacebar

Повернуть перемещаемый объект по часовой стрелке. Поворот выполняется с шагом 90°.

Backspace Удалить последний размещенный сегмент при размещении области.

Сочетания клавиш для всплывающих меню

Следующие сочетания клавиш позволяют открывать определенные всплывающие меню команд непосредственно в рабочей области проектирования. Некоторые из них могут быть вам знакомы: это подменю главных меню редактора. Для каждого главного меню также назначена клавиша быстрого вызова из рабочей области проектирования. Подробнее см. в разделе Клавиши быстрого доступа.

B Подменю Toolbars  (из главного меню Вид).
K Подменю Panels (из главного меню Вид).
M Всплывающее меню команд перемещения.
S Подменю Select  (из главного меню Edit).
Z Всплывающее меню команд масштабирования.
AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents