Xác định đường uốn - Chế độ nâng cao

Sơ lược

Bài viết này giải thích cách hoạt động của các đường uốn trong chế độ Advanced Rigid-Flex của Altium Designer, tập trung làm rõ sự khác biệt giữa chế độ này và chế độ rigid-flex tiêu chuẩn, cũng như ảnh hưởng của những khác biệt đó đến việc xác định vùng mạch mềm và gập bo mạch. Bạn sẽ biết cách nhận diện chế độ rigid-flex mà PCB đang sử dụng, đặt và điều chỉnh các đường uốn trong Board Planning Mode, chỉnh sửa thuộc tính của chúng và kiểm soát cách các phần uốn hiển thị khi bo mạch được gập trong môi trường 3D. Nếu bạn đang thực hiện một thiết kế mạch cứng-mềm phức tạp hơn và cần hướng dẫn thực tế để xác định vị trí uốn, góc uốn, bán kính uốn và thứ tự gập, bài viết này sẽ giúp bạn tự tin triển khai. Hãy đọc tiếp để quy trình thiết kế mạch cứng-mềm của bạn trở nên chính xác và dễ dự đoán hơn.

- Hiểu sự khác biệt giữa chế độ rigid-flex tiêu chuẩn và Advanced Rigid-Flex, đặc biệt là lý do chế độ Advanced không sử dụng các đối tượng Split Line.
- Tìm hiểu quy trình cơ bản để đặt, di chuyển, xóa và định vị chính xác các đường uốn trong Board Planning Mode.
- Tìm hiểu những thuộc tính của đường uốn chi phối cách bo mạch uốn trong môi trường 3D, bao gồm góc uốn, bán kính uốn, vùng xếp chồng lớp được gán và thứ tự gập.
Tìm hiểu sâu hơn với AI:

Có hai chế độ thiết kế mạch cứng-dẻo trong phần mềm thiết kế PCB của Altium. Chế độ ban đầu, hay chế độ tiêu chuẩn, được gọi là Rigid-Flex, hỗ trợ các thiết kế mạch cứng-dẻo đơn giản. Nếu thiết kế của bạn có các yêu cầu phức tạp hơn về mạch cứng-dẻo, chẳng hạn như các vùng mạch dẻo chồng lấn, bạn cần sử dụng chế độ Advanced Rigid-Flex (còn được gọi là rigid-flex 2.0). Chế độ được chọn trong menu Tools của Trình quản lý xếp chồng lớp.

Điểm khác biệt cơ bản giữa hai chế độ là ở chế độ ban đầu, hình dạng bo mạch được chia thành các vùng bo mạch riêng biệt bằng cách đặt Đường phân chia; Đường phân chia này vẫn tồn tại dưới dạng một đối tượng xác định ranh giới kết thúc của vùng bo mạch này và bắt đầu của vùng bo mạch khác. Trong chế độ nâng cao, mỗi vùng bo mạch được đặt riêng biệt, hoặc nếu một vùng lớn hơn được cắt ra thì nó sẽ trở thành hai đối tượng vùng riêng biệt. Trong chế độ nâng cao, các cạnh của những vùng bo mạch liền kề xác định nơi hai vùng tiếp giáp nhau, thay vì dựa vào Đường phân chia. Do sự khác biệt này, không có đối tượng Đường phân chia khi bo mạch ở chế độ Advanced Rigid-Flex.

► Tìm hiểu thêm về Thiết kế PCB cứng-dẻo

Menu View có ba chế độ làm việc của trình biên tập PCB với các phím tắt dễ nhớ, cho phép bạn chuyển đổi nhanh giữa:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

Theo mặc định, khi chuyển đổi giữa chế độ xem 2D và 3D, các thiết lập thu phóng và hướng nhìn riêng cho từng chế độ xem sẽ được giữ lại. Nếu muốn giữ nguyên vị trí và hướng nhìn của bo mạch khi chuyển đổi, hãy nhấn Ctrl+Alt+2 hoặc Ctrl+Alt+3, thay vì 2 hoặc 3.

Bạn vừa mở một PCB và đang băn khoăn liệu nó đang sử dụng chế độ mạch cứng-dẻo tiêu chuẩn hay chế độ mạch cứng-dẻo nâng cao?

Bạn có thể mở Trình quản lý xếp chồng lớp để kiểm tra. Hoặc chuyển sang Chế độ quy hoạch bo mạch (phím tắt 1) rồi quan sát Thanh công cụ Active Bar:

Chế độ Rigid-Flex tiêu chuẩn
Chế độ Advanced Rigid-Flex

Để xác định cách uốn một bo mạch dẻo, bạn đặt một hoặc nhiều Đường uốn. Đường uốn xác định vị trí uốn trên bề mặt vùng mạch dẻo. Đường uốn cũng xác định góc và bán kính uốn. Chiều rộng của dải bề mặt bo mạch được uốn hiển thị bằng màu cam; chiều rộng này được tính từ góc và bán kính uốn (tìm hiểu thêm về các thuộc tính đường uốn). Đường uốn được đặt và chỉnh sửa bằng trình biên tập PCB ở Board Planning Mode (View » Board Planning Mode, hoặc nhấn phím tắt 1).


Một Đường uốn được đặt trên vùng mạch dẻo và được cấu hình để bo mạch có thể gập 180 độ. Video này minh họa cách đặt Đường uốn trong chế độ Advanced Rigid-Flex.

Đặt Đường uốn

Để đặt Đường uốn:

  1. Chọn View » Board Planning Mode hoặc nhấn phím tắt 1 để vào Board Planning Mode.
  2. Chọn lệnh Place » Define Bending Line, hoặc nhấp vào nút  trên Thanh công cụ Active Bar.
  3. Đường uốn được đặt trên Vùng bo mạch mong muốn, chứ không gắn vào vùng đó (Đường uốn được liên kết với một hoặc nhiều Vùng bo mạch thông qua thuộc tính Stack Regions). Nhấp gần cạnh của Vùng bo mạch để xác định vị trí bắt đầu của Đường uốn.
  4. Di chuyển con trỏ đến vị trí kết thúc mong muốn rồi nhấp để đặt Đường uốn. Lưu ý rằng ít nhất một đầu của Đường uốn phải chạm hoặc cắt qua ranh giới của Vùng bo mạch mà đường đó áp dụng.
  5. Bạn vẫn ở chế độ đặt Đường uốn, sẵn sàng đặt thêm Đường uốn nếu cần. Nếu không, hãy nhấp chuột phải hoặc nhấn Esc để thoát chế độ đặt Đường uốn.

Có thể chỉnh sửa các thuộc tính của Đường uốn được chọn trong bảng Properties. Vì Đường uốn nằm trên một vùng, khi nhấp vào Đường uốn, bạn có thể thấy vùng bên dưới được chọn thay vì đường đó. Không di chuyển con trỏ, hãy nhấp lần thứ hai để chọn Đường uốn thay vì Vùng bo mạch.

Các thuộc tính của Đường uốn được chọn hiển thị trong bảng Thuộc tính.
Các thuộc tính của Đường uốn được chọn hiển thị trong bảng Thuộc tính.

  • Không nhất thiết phải đặt chính xác điểm bắt đầu hoặc kết thúc của Đường uốn trên cạnh của Vùng bo mạch; phần mềm sẽ tự động kéo dài hoặc thu ngắn Đường uốn để đường này được xác định từ cạnh này đến cạnh kia của vùng.
  • Đảm bảo Vùng bo mạch phù hợp được bật trong phần Stack Regions của bảng Properties.

Di chuyển Đường uốn

Để thay đổi vị trí của Đường uốn hiện có:

  1. Chọn View » Board Planning Mode (hoặc nhấn phím tắt 1) để vào Board Planning Mode.
  2. Nhấp và giữ tại đỉnh ở một trong hai đầu của Đường uốn, sau đó kéo đỉnh đó đến vị trí mong muốn rồi thả nút chuột. Con trỏ sẽ bị ràng buộc theo các thiết lập bắt dính con trỏ hiện tại; nhấn Ctrl+E để thay đổi thiết lập trong khi thao tác.
  3. Vị trí uốn sẽ được xác định lại theo vị trí mới của Đường uốn.

Chọn và kéo một đỉnh của Đường uốn để thay đổi vị trí Đường uốn trên bo mạch — con trỏ sẽ bị ràng buộc theo các thiết lập bắt dính con trỏ hiện tại.
Chọn và kéo một đỉnh của Đường uốn để thay đổi vị trí Đường uốn trên bo mạch — con trỏ sẽ bị ràng buộc theo các thiết lập bắt dính con trỏ hiện tại.

Định vị chính xác Đường uốn

Khi di chuyển điểm điều khiển của Đường uốn, điểm này sẽ bắt dính theo các thiết lập bắt dính hiện tại. Nhấn Ctrl+E trong khi di chuyển để mở bảng điều khiển tương tác thiết lập bắt dính, như minh họa trong hình bên dưới. Nhấn Esc sau khi thay đổi thiết lập để áp dụng và đóng bảng.

Ngoài việc bắt dính vào lưới bắt dính và các đường dẫn hướng trong không gian làm việc, Đường uốn còn có thể bắt dính vào các đối tượng thiết kế hiện có, chẳng hạn như các đường trên lớp cơ khí. Hình bên dưới cho thấy một điểm điều khiển của Đường uốn đang được đặt tại đỉnh cuối của một đường trên lớp cơ khí. Lưu ý rằng thiết lập Hotspot Snap hiện tại được áp dụng trong khi di chuyển (hiển thị trên Thanh trạng thái); nếu lớp cơ khí không phải là lớp thiết kế đang hoạt động, Hotspot Snap phải được cấu hình thành All Layers để có thể bắt dính theo cách này. Nhấn phím tắt Shift+E để lần lượt chuyển thiết lập Hotspot Snap qua các chế độ có sẵn trong khi thao tác.

Điểm điều khiển của Đường uốn đang bắt dính vào đỉnh của một đoạn đường mạch đặt trên lớp cơ khí.
Điểm điều khiển của Đường uốn đang bắt dính vào đỉnh của một đoạn đường mạch đặt trên lớp cơ khí.

Xóa Đường uốn

Để xóa Đường uốn:

  1. Chọn View » Board Planning Mode (hoặc nhấn phím tắt 1) để vào Board Planning Mode.
  2. Nhấp và giữ tại một trong các đỉnh để chọn Đường uốn, sau đó nhấn phím Delete.

Cấu hình thuộc tính Đường uốn

Để chỉnh sửa các thuộc tính của Đường uốn trong bảng Properties:

  1. Chuyển sang Board Planning Mode (nhấn 1).
  2. Nhấp vào vị trí bất kỳ trong dải màu cam của Đường uốn để chọn đường đó.
  3. Có thể chỉnh sửa Đường uốn trong bảng Properties.

Có thể áp dụng các nếp uốn đã xác định khi bo mạch được hiển thị ở chế độ 3D; nhấn phím tắt 5 để gấp bo mạch. Vùng bo mạch cứng có hộp kiểm 3D Locked được chọn là mặt phẳng tham chiếu vật lý cho chế độ hiển thị 3D (tại Z = 0). Nếu bo mạch không gấp như mong đợi, hãy kiểm tra xem hộp kiểm 3D Locked đã được chọn cho đúng vùng cứng hay chưa. Lưu ý rằng không cần bỏ chọn tùy chọn này ở một Vùng bo mạch trước khi bật nó ở vùng khác.

AI-LocalizedBản địa hóa bằng AI
Nếu bạn phát hiện vấn đề, hãy chọn văn bản/hình ảnh và nhấnCtrl + Enterđể gửi phản hồi cho chúng tôi.
Nav
Contents
Tính khả dụng của tính năng

Các tính năng bạn có thể sử dụng phụ thuộc vào giải pháp Altium mà bạn đang có – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, hoặc Altium Designer (đang trong thời hạn hiệu lực).

Nếu bạn không thấy một tính năng được nêu trong tài liệu có trong phần mềm thực tế của mình, liên hệ Bộ phận Kinh doanh của Altium để tìm hiểu thêm.

Tài liệu cũ

Tài liệu Altium Designer không còn được phân phiên bản. Nếu bạn cần truy cập tài liệu cho các phiên bản cũ hơn của Altium Designer, hãy truy cập mục Tài liệu cũ trên trang Trình cài đặt khác.

Contents